Windows 上で Illustrator の動作の速度と効率性を向上させる方法を説明します。

いかに迅速に効率的に Adobe Illustrator が動作するかは、オペレーティング・システム、ハードウェア構成、ワークフロー、選択したオプションなど、複数の要因に左右されます。 Illustrator の動作が通常より遅い場合は以下の技法を試して、Illustrator のパフォーマンスだけでなく他のアプリケーションのパフォーマンスも最適化してください。(パフォーマンスの改善は大規模ファイルで作業している場合により顕著になります)。

開始する前に

以下のタスクを実行する前に、Illustrator の最新バージョン、またはご使用のバージョンに対する Illustrator のすべてのアップデートがインストールされていることを確認してください。ソフトウェアアップデートには、多くの場合、パフォーマンスに関する修正または機能拡張が含まれています。 

Illustrator CC を使用している場合、Creative Cloud デスクトップアプリケーションによって Illustrator をアップデートできます

注意:

この文書内の手順は、初期設定の インタフェースに基づいています。 インタフェースがカスタマイズされている場合、いくつかの手順が異なります。 たとえば、コントロールパネルに移動するパスは異なる場合があります。 Windows のバージョンに応じて「スタート/設定/コントロールパネル」、または「スタート/設定/コントロールパネル」を選択します。Windows に関するトラブルシューティングのヒントと一般情報については、Adobe サポートおよび Microsoft サポートを参照してください。

Windows の最適化

効率的に動作するようオペレーティングシステムを設定することで、アプリケーションが使用できるメモリの量が増え、アプリケーションがスムーズに動作できます。 以下は Win ows を最適化し、Illustrator のパフォーマンスを改善するための技法のいくつかです。

使用可能なメモリの増大

仮想メモリを使用すると、通常は RAM に格納される情報を、システムがハードディスク領域に格納できるようになります。 しかしメモリ内の情報にアクセスするよりも、ハードディスク上の情報にアクセスする方が時間がかかります。 そのため、仮想メモリを多用しすぎると、パフォーマンスが損なわれることがあります。

パフォーマンスを向上させるには、ページングファイル(仮想メモリを保管するハードドライブの領域)に適切なサイズを選択します。 ページングファイルのサイズを変更するには管理者権限が必要です。 Illustrator が最高のパフォーマンスを達成するのは、ページングファイルの最大サイズが、搭載済み RAM の約 3 倍に設定されているときです。

  1. すべてのアプリケーションを終了します。

  2. スタートコントロールパネルシステムシステム詳細設定の順に選択します。

  3. システムのプロパティダイアログボックスで、「詳細設定」タブをクリックします。

  4. 「パフォーマンス」セクションの「設定」をクリックし、「詳細設定」タブをクリックします。

  5. 「仮想メモリ」セクションで「 変更」をクリックします。

  6. すべてのドライブのページングファイルのサイズを自動的に管理する」チェックボックスをオフにします。

  7. ドライブリストから、コンピューターに搭載済みのRAMの少なくとも3倍の容量がある1台のハードディスクドライブを選択します。 例えば、コンピューターに64MBのRAMが搭載済みである場合は、少なくとも192MBの空き容量がある1台のハードディスクドライブを選択します。 最高のパフォーマンスを達成するには、Illustratorの仮想記憶ディスクとして使用されているのとは異なるハードディスクドライブを選択します。

ドライバーの機能の無効化

ビデオアダプタードライバーの一部には、グラフィック表示をアクセラレート(高速化)または変更するための詳細設定があります。 これらの設定はIllustratorによる画面再描画パフォーマンスに悪影響を及ぼす可能性があります。 Illustratorでの使用に最適の設定を判定するために、試しにドライバー固有の機能を無効にします。 詳しくは、使用するビデオアダプターのドキュメントを参照してください。

フォントの管理

すべてのフォントが、Windows が使用する RAM の量を増加させます。 システムパフォーマンス、およびフォントにアクセスするアプリケーションのパフォーマンスを改善するには、必要なフォントのみをインストールします。 フォント管理ユーティリティを使用することで、多数のフォントの管理が容易になります。

スタートアップアプリケーションの制限

Windows の起動時に自動的に開始するアプリケーションは、使用可能な RAM を取得するために Illustrator と競合します。 アプリケーションが自動的に開始しないようにするには、以下の手順に従います。

  1. すべてのアプリケーションを終了します。

  2. Windowsエクスプローラを起動します。
  3. スタートアップフォルダー(OSDisk\ProgramData\Microsoft\Windows\Start Menu\Programs\StartUp)からすべてのアイコンとショートカットを別のフォルダーに移動して、起動アプリケーションを無効にします。

  4. Windowsを再起動します。

レジストリにある自動的に開始するよう指定されたアプリケーションを閉じるには、以下の手順に従います。

  1. Windowsを再起動します。
  2. Ctrl + Shift + Escキーを押します。

  3. プロセス」タブを選択します。

  4. いずれかのアプリケーション名をクリックし、「タスクの終了」をクリックします。

  5. Illustratorを再起動します。 Illustrator のパフォーマンスが改善された場合は、自動的に起動するアプリケーションを完全に無効にする方法をアプリケーションの製造元に問い合わせます。 残りの各スタートアップアプリケーションに対して手順 2~5 を繰り返します。

アイコンとショートカットの再有効化

再起動後に Illustratorのパフォーマンスが改善されない場合は、Windows Explorer のアイコンとショートカットをスタートアップフォルダーに戻して再有効化します。

Illustratorのパフォーマンスが改善された場合は、パフォーマンスの問題を 1 つまたは複数のプログラムに切り分け、Windows Explorer を使用してアイコンとショートカットをスタートアップフォルダーに入れることで再有効化します。

アイコンとショートカットの組み合わせをそれぞれ再有効化した後でコンピューターを再起動し、Illustrator のパフォーマンスを確認します。

Illustratorのパフォーマンスが低下するまで、このプロセスを繰り返します。 パフォーマンスの問題を引き起こすアイコンまたはショートカットを切り分けた後、そのアイコンまたはショートカットを再度削除しま。アップデートが入手できるかどうかをプログラムの製造元に問い合わせます。

ハードウェアの最適化

使用するハードウェアは、Illustrator のパフォーマンスに影響を及ぼします。高速なプロセッサーまたはハードディスクドライブを使用すると、Illustrator は情報を高速に処理できます。 追加のRAMの搭載、マルチプロセッサーシステムの使用またはドライブの最適化のような他のハードウェア強化を行うと、パフォーマンスが改善される可能性があります。 ハードウェアを最適化するには以下の技法を試してください。

より高速のプロセッサーの使用

コンピューターの中央演算装置(CPU)の速度は、Illustrator の速度に影響を及ぼします。 Illustrator は大量のデータを操作し、多くの計算を実行するので、Illustrator の速度はプロセッサーの速度に左右されます。 より高速のプロセッサーを備えたコンピューターの使用を検討してください。

追加の RAM のインストール

Illustrator で RAM が不足した場合は、Illustrator は情報を処理するためにハードディスク領域(仮想メモリと仮想記憶ディスクの一方または両方)を使用します。 Illustrator が最も高速に動作するのは、ハードディスクを使用せずに、情報をメモリ内で処理できる場合です。

ディスク容量の最適化

以下に、ディスクスペースを最適化する方法をいくつか示します。

  • CHKDSK.exe と Disk Defragmenter プログラムを使用して、ハードディスクにエラーがないか確認し、ファイルをデフラグして、使用可能なハードディスク容量を最適化します。 詳細については、Windows のドキュメントまたは「Windows におけるパフォーマンスの改善」を参照してください。
  • より高速なアクセス速度で、ファイルをドライブに保存します。 たとえば、ネットワークサーバー(ネットワークドライブ)や外部ドライブではなく、内部ハードドライブを使用します。
  • ファイルをネットワークドライブまたは外部ドライブに保存する場合は、まず、内部ハードドライブにファイルを保存します。 次にファイルを閉じ、Windows Explorer を使用してそのファイルをネットワークドライブまたは外部ドライブにコピーします。

PostScript プリンターの使用

Illustratorからプリントするときに最高の結果を得るには、PostScript対応プリンターを使用します。 ほとんどのPostScript非対応プリンターでは、表示情報、ホストコンピューターのリソースおよび自社独自のプリンタードライバーを使用してプリント情報をプリンターに中継します。 そのため、プリントするのにPostScript プリンタよりもかなり時間がかかる可能性があります。

Illustrator の機能を効率的に使用

Illustrator での作業の方法、特にアートワークを表示する動作は、Illustrator のパフォーマンスに影響を与えます。 Illustrator 機能を効率的に使用する方法は以下のとおりです。

アウトライン表示で作業

[Outline] ビューでは、ペイントの属性を非表示にして、塗りつぶされていないパスとしてアートワークを表示します。 [Outline] ビューを使用すると、グラデーションやパターンが含まれているオブジェクトなどの複雑なアートワークを高速表示できます。 また、[Outline] ビューを使用すると、他の塗りつぶされたオブジェクトに隠れたオブジェクトを簡単に編集できます。

Illustrator 文書をアウトラインで表示するには、「表示/アウトライン」を選択します。

カスタムビューの作成

文書のカスタムビューを作成できます。 カスタムビューを使用すると簡単に表示モード、拡大率、スクロール位置およびレイヤーオプションを変更できます。

Illustrator 文書のカスタムビューを作成するには、保存したい表示属性を設定します。 「表示/新規表示」を選択し、新規表示ダイアログボックスに名前を入力します。 表示メニューにカスタムビューが表示されます。

ラスター効果の設定を変更

ラスタライズ効果の解像度を変更することで、Illustrator のパフォーマンスを最適化できます。

ラスタライズ効果の解像度を変更するには、効果/ドキュメントのラスタライズ効果設定を選択します。 解像度ポップアップメニューで、以下のいずれかの操作を行います。

  • ファイルを編集する場合は、「スクリーン」を選択します。 Illustratorはラスタライズ効果に72ppiの解像度を使用し、表示速度を向上させます。
  • ファイルを印刷する場合、「」を選択します。 Illustratorはラスタライズ効果に300ppiの解像度を使用します。プリント速度は低下しますが、プリント品質は向上します。

OK」をクリックします。

レイヤーを隠し、サムネールを削除する

アートワークを整理したり修正するには、レイヤーパネルを使用します。 複雑なアートワークまたは高解像度ビットマップイメージを含むレイヤーを非表示にすると、Illustratorの画面の再描画が高速になります。

レイヤーを非表示にするには、レイヤー名の左側にある目のアイコンをクリックします。 選択したレイヤー以外のすべてのレイヤーを非表示にするには、目のアイコンを Alt キー(Mac の場合は Option キー)を押しながらクリックします。

レイヤーパネルでは、最上位レイヤー、ネストしたレイヤー、グループおよびオブジェクトのサムネールを表示できます。 サムネールの数を減らして Illustrator が画面により迅速に再描画できるようにするには、レイヤーパネルメニューから「パネルオプション」を選択し、サムネールの数を減らします。

オプションパネル

オーバープリントプレビューの無効化

オーバープリントプレビューを使用すると、「インクプレビュー」、つまり描画、透明およびオーバープリントが色分版でどのように表示されるかが近似表示されます。 パフォーマンスを向上させるには、オーバープリントプレビューを使用しないようにします。

オーバープリントプレビューを有効、または無効にするには、「表示/オーバープリントプレビュー」を選択します。

使用されていないアートボードの削除

アートボードはプリント可能なアートワークを収容できる領域を表します。 パフォーマンスを最適化するためには、使用していない、または不要なアートボードを削除することを検討してください。

アートボードの管理は、「ウィンドウ/アートボード」を選択します。 削除するアートボードを選択し、「削除」をクリックします。

仮想記憶ディスクの環境設定を変更

埋め込まれたビットマップイメージで作業していて、システムの RAM が不十分な場合、Illustrator は仮想記憶ディスクとしてハードディスク容量を使用します。 メモリ内の情報にアクセスするよりも、ハードディスク上の情報にアクセスする方が時間がかかります。 そのため、ハードディスクの一部を仮想メモリとして使用すると、パフォーマンスが低下する可能性があります。 Illustratorでの操作のためにさらにメモリが必要な場合は、より多くの RAM を搭載することをお勧めします。

デフォルトでは、Illustratorはシステムドライブをプライマリ仮想記憶ディスクとして使用します。 Illustratorのプライマリ仮想記憶ディスク設定を、使用中の最も高速なハードディスクドライブに変更します。

仮想記憶ディスクの環境設定を変更するには、以下の操作を行います。

  1. 編集環境設定プラグインと仮想記憶ディスクを選択します。

  2. プライマリポップアップメニューからハードディスクを選択します。多数の画像を処理していて複数のハードディスクを使用している場合は、セカンダリポップアップメニューから別のディスクを選択します。

  3. OK」をクリックし、Illusratorを再起動します。

使用されていない要素を文書プロファイルから削除

Illustrator ドキュメントプロファイルには、新しいIllustorator文書で表示されるデフォルトのパターン、グラデーション、グラフデザイン、カラー、カラーライブラリ、およびブラシが含まれています。 これらのファイルは、新規ドキュメントのズームレベル、ウィンドウサイズ、環境設定およびスクロール位置も決定します。 Illustratorの新規ドキュメントプロファイルから不要なスウォッチとブラシを削除することにより、新規ドキュメントのファイルサイズを最小化します。

Illustrator でカスタムのドキュメントプロファイルを作成する方法については、「スタートアッププロファイル:新規文書をカスタマイズするための優れたツール」を参照してください。

使用されていない要素をテンプレートから削除

テンプレートを使用すると、一般設定とデザイン要素を共有する複数のドキュメントを作成できます。テンプレートから不要なスウォッチ、シンボル、グラフィックスタイルおよびブラシを削除することにより、新規ドキュメントのファイルサイズを最小化できます。

テンプレートファイルの作成に関する手順については、「Files and Templates(ファイルとテンプレート)」を参照してください。

画像へのリンクを有効化

埋め込まれたビットマップイメージ(例えば、TIFF、BMPまたはPhotoshop EPS)はIllustratorドキュメントのサイズを大幅に増加させ、パフォーマンスを低下させる可能性があります。 パフォーマンスを改善するには、ビットマップ画像の配置時に「リンク」オプションを有効にします。 「リンク」オプションは、ハードディスク上にある、配置されたイメージを参照します。

  • ファイル配置を選択します。配置ダイアログボックスで「リンク」を選択します。

サービスビューローが埋め込まれた画像を必要としている場合には、ファイルのコピーを保存するようにします。 Illustrator ネイティブフォーマットオプションまたは EPS フォーマットオプション ダイアログボックスで、「リンクされたファイルを含める 」を選択します。

低解像度 EPS プレビューを使用

文書が、高解像度プレビュー付きのリンク付けされたEPSイメージを含んでいる場合、Illustratorはアートワークを編集するよりも画面の再描画が低速になります。 Illustrator で画面の再描画の高速化を有効にするには、低解像度 EPS プレビューを使用します。 次の操作を実行します :

  1. 編集環境設定ファイル管理とクリップボードを選択します。

  2. リンクされた EPS に低解像度のプロキシを使用」を選択し、「OK」をクリックします。

「DCS 形式への透明の影響を表示」操作を無効化

リンクパネルオプションダイアログボックスには、「DCS 透明のインタラクティブ表示」オプションが含まれています。 このオプションが選択されている場合は、リンクパネルでは黄色いアイコンが表示され、リンクされているDCS EPSグラフィックが透明オブジェクトまたはオーバーラップ透明オブジェクトであることを識別します。 このオプションにより、リンクされている EPS ファイルの透明のインタラクティブ状態が Illustrator で常に判定されるようになるので、パフォーマンスが低下する可能性があります。

「透明の影響を表示」オプションを無効にするには、次の手順に従います。

  1. ウィンドウリンクを選択します。リンクパネルメニューから「パネルオプション」を選択します。

  2. DCS 形式への透明の影響を表示」を選択解除し、「OK」をクリックします。

ナビゲーターパネルの非表示

ナビゲーターパネルでは、ナビゲーションが簡単に実行できるように、現在のアートワークのサムネールビューが表示されます。 文書を変更するたびサムネイルを更新するのに必要な処理時間は、アートワークの複雑さに依存します。 複雑な文書でスクリーンの再描画速度を向上させるには、ナビゲーターパネルを非表示にします。 ウィンドウメニューで「ナビゲーター」を選択解除します。

文書の特定の領域をより効率的にズームするには、カスタムビューを設定できます。

アンチエイリアスアートワークを無効にする

「アートワークのアンチエイリアス」オプションは、オブジェクトのエッジピクセルの色を隣り合ったピクセルの色と混合することにより、テキストとグラフィックをスムーズにします。 ただし、このプロセスが原因で、画面の再描画が低速になる可能性があります。 このオプションを無効化するには、次の操作を行います。

  1. 編集環境設定一般を選択します。

  2. アートワークのアンチエイリアス 」を選択解除し、「OK」をクリックします。

単純化コマンドを適用

「単純化」コマンドを使用すると、パス内およびパスシェイプ内のアンカーポイントの数が減り、ファイルサイズが小さくなり、パフォーマンスが向上します。 「単純化」コマンドを適用するには、目的のパスまたはオブジェクトを選択し、次にオブジェクトパス単純化を選択します。

「単純化」コマンドについて詳しくは、Illustrator のヘルプを参照してください。

スマートガイドを無効化

スマートガイドを使用すると、他のオブジェクトを基準にしてIllustratorオブジェクトの作成、整列、編集および変形ができます。 アートワークに多数のオブジェクトがある場合、Illustratorはスマートガイドを表示するのにより時間がかかります。 スマートガイドを無効化するには、表示メニューから「スマートガイド」を選択解除します。

スマートガイドに関する詳細については、「定規、グリッド、ガイドおよびトリムマーク」を参照してください。

刷毛ブラシパスをラスタライズし、PDF機能を無効化

刷毛ブラシストロークは、塗りつぶされた複数の透明パスの重なりによって形成されています。 これらのパスは、Illustrator内での他の塗りつぶされたパスと同様、他の刷毛ブラシパスを含む他のオブジェクトのペイントとインタラクティブ動作します。

大掛かりなアートワークに着手する前に、刷毛ブラシとペイントの動作をテストおよび経験してください。 ブラシ属性を変更して、再適用すると、使用されているすべてのブラシが初めから再レンダリングされます。

刷毛ブラシを使用する場合は、次の方法で複雑さを緩和し、ドキュメントのファイルサイズを縮小できます。

  • 複数の刷毛ブラシパスをラスタライズします。 ラスタライズを行う前に、必ず元のアートワークのコピーを保存してください。

アートワークの刷毛ブラシに大きな数(30より大きい)が含まれていると、複雑さが緩和され、刷毛ブラシパスの数が減少します。 刷毛ブラシパスを選択してから、オブジェクトラスタライズを選択します。

  • PDF 機能を無効化します。

デフォルトでは、Illustrator は PDF データを保存するときに、Illustrator(*ai)ファイルが他の Adobe アプリケーションと互換性を維持できるようにします。 ファイル保存またはファイル別名で保存を選択し、保存をクリックします。Illustrator オプションダイアログボックスで、「 PDF 互換ファイルを作成」を選択解除します。

本作品は Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License によってライセンス許可を受けています。  Twitter™ および Facebook の投稿には、Creative Commons の規約内容は適用されません。

リーガルノーティス   |   プライバシーポリシー