Animacja klatka po klatce w programie Animate

  1. Podręcznik użytkownika programu Adobe Animate
  2. Wprowadzenie do programu Animate
    1. Nowości w programie Animate
    2. Słownik wizualny
    3. Wymagania systemowe programu Animate
    4. Skróty klawiaturowe programu Animate
    5. Praca z wieloma typami plików w programie Animate
  3. Animacja
    1. Podstawowe informacje o animacjach w programie Animate
    2. Korzystanie z klatek i klatek kluczowych w programie Animate
    3. Animacja klatka po klatce w programie Animate
    4. Praca z animacjami klasycznymi w programie Animate
    5. Narzędzie Pędzel
    6. Linie pomocnicze ruchu
    7. Animacje ruchu a język ActionScript 3.0
    8. Informacje o animacjach ruchu
    9. Animacje ruchu
    10. Tworzenie animacji ruchu
    11. Używanie klatek kluczowych właściwości
    12. Animowanie położenia za pomocą klatek pośrednich
    13. Edytowanie animacji ruchu za pomocą Edytora ruchu
    14. Edytowanie ścieżki ruchu animacji
    15. Operacje na animacjach ruchu
    16. Dodawanie własnych krzywych dynamiki
    17. Tworzenie i stosowanie ruchów predefiniowanych
    18. Konfigurowanie zakresów animacji
    19. Praca z animacjami ruchu zapisanymi jako pliki XML
    20. Porównanie animacji ruchu i animacji klasycznych
    21. Animowanie kształtów metodą klatek pośrednich
    22. Animacja oparta na narzędziu Kość w programie Animate
    23. Tworzenie konstrukcji postaci w programie Animate
    24. Używanie warstw maskujących w programie Adobe Animate
    25. Praca ze scenami w programie Animate
  4. Funkcje interaktywne
    1. Tworzenie przycisków w programie Animate
    2. Konwertowanie projektów programu Animate na dokumenty innych typów
    3. Tworzenie i publikowanie dokumentów HTML5 Canvas w programie Animate
    4. Programowanie elementów interaktywnych za pomocą wycinków kodu w programie Animate
    5. Tworzenie własnych składników HTML5
    6. Używanie składników w zawartości HTML5 Canvas
    7. Tworzenie własnych składników: przykłady
    8. Wycinki kodu dla składników dostosowanych
    9. Sprawdzone procedury — reklama oparta na programie Animate
    10. Tworzenie i publikowanie materiałów rzeczywistości wirtualnej
  5. Przestrzeń robocza i obieg pracy
    1. Tworzenie pędzli malarskich i zarządzanie nimi
    2. Używanie czcionek Google Fonts w dokumentach HTML5 Canvas
    3. Korzystanie z Bibliotek Creative Cloud w programie Adobe Animate
    4. Korzystanie ze stołu montażowego i panelu Narzędzia w programie Animate
    5. Obieg pracy i przestrzeń robocza w programie Animate
    6. Używanie czcionek internetowych w dokumentach HTML5 Canvas
    7. Osie czasu a język ActionScript
    8. Praca z wieloma osiami czasu
    9. Ustawianie preferencji
    10. Korzystanie z paneli narzędziowych programu Animate
    11. Tworzenie warstw na osi czasu w programie Animate
    12. Eksportowanie animacji do aplikacji mobilnych i platform gier
    13. Przesuwanie i kopiowanie obiektów
    14. Szablony
    15. Znajdowanie i zamienianie w programie Animate
    16. Cofanie, ponawianie i panel Historia
    17. Skróty klawiaturowe
    18. Korzystanie z osi czasu w programie Animate
    19. Tworzenie rozszerzeń HTML
    20. Opcje optymalizacji obrazów i animowanych plików GIF
    21. Eksportowanie ustawień obrazów oraz plików GIF
    22. Panel Zasoby w programie Animate
  6. Multimedia i wideo
    1. Przekształcanie i łączenie obiektów graficznych w programie Animate
    2. Tworzenie i obsługa wystąpień symboli w programie Animate
    3. Obrys obrazu
    4. Używanie dźwięku w programie Adobe Animate
    5. Eksportowanie plików SVG
    6. Tworzenie plików wideo do używania w programie Animate
    7. Dodawanie wideo w programie Animate
    8. Praca z punktami sygnalizacji wideo
    9. Rysowanie i tworzenie obiektów w programie Animate
    10. Przekształcanie linii i kształtów
    11. Obrysy, wypełnienia, i gradienty w programie Animate CC
    12. Korzystanie z programów Adobe Premiere Pro i After Effects
    13. Panel Kolory w programie Animate CC
    14. Otwieranie plików programu Flash CS6 w programie Animate
    15. Praca z tekstem klasycznym w programie Animate
    16. Umieszczanie kompozycji w programie Animate
    17. Zaimportowane bitmapy w programie Animate
    18. Grafika 3D
    19. Praca z symbolami w programie Animate
    20. Rysowanie linii i kształtów przy użyciu programu Animate
    21. Praca z bibliotekami w programie Animate
    22. Eksportowanie dźwięków
    23. Zaznaczanie obiektów w programie Animate CC
    24. Praca z plikami AI programu Illustrator w programie Animate
    25. Stosowanie wzorków przy użyciu narzędzia Rozpylacz
    26. Stosowanie trybów mieszania
    27. Układanie obiektów
    28. Automatyzacja zadań za pomocą menu Polecenia
    29. Teksty wielojęzyczne
    30. Korzystanie z kamery w programie Animate
    31. Korzystanie z programów Animate i Adobe Scout
    32. Praca z plikami programu Fireworks
    33. Filtry graficzne
    34. Dźwięk a język ActionScript
    35. Preferencje rysowania
    36. Rysowanie za pomocą narzędzia Pióro
  7. Platformy
    1. Konwertowanie projektów programu Animate na dokumenty innych typów
    2. Obsługa platform niestandardowych
    3. Tworzenie i publikowanie dokumentów HTML5 Canvas w programie Animate
    4. Tworzenie i publikowanie dokumentów WebGL
    5. Pakowanie aplikacji na potrzeby środowiska AIR for iOS
    6. Publikowanie aplikacji dla środowiska AIR for Android
    7. Publikowanie dla środowiska AIR na komputery
    8. Ustawienia publikowania kodu ActionScript
    9. Sprawdzone procedury — porządkowanie kodu ActionScript w aplikacji
    10. Korzystanie z kodu ActionScript w programie Animate
    11. Sprawdzone procedury — wskazówki dotyczące ułatwień dostępu
    12. Ułatwienia dostępu w przestrzeni roboczej programu Animate
    13. Pisanie skryptów i zarządzanie nimi
    14. Włączanie obsługi platform niestandardowych
    15. Omówienie obsługi platform niestandardowych
    16. Tworzenie zawartości z ułatwieniami dostępu
    17. Praca z wtyczkami obsługi platform niestandardowych
    18. Debugowanie kodu ActionScript 3.0
    19. Włączanie obsługi platform niestandardowych
  8. Eksportowanie i publikowanie
    1. Eksportowanie plików z programu Animate CC
    2. Publikowanie plików OAM
    3. Eksportowanie plików SVG
    4. Eksportowanie grafiki i wideo w programie Animate
    5. Publikowanie dokumentów ActionScript 3.0
    6. Eksportowanie animacji do aplikacji mobilnych i platform gier
    7. Eksportowanie dźwięków
    8. Eksportowanie plików wideo QuickTime
    9. Sterowanie zewnętrznym odtwarzaniem wideo przy użyciu kodu ActionScript
    10. Sprawdzone procedury — wskazówki dotyczące tworzenia zawartości dla urządzeń przenośnych
    11. Sprawdzone procedury — konwencje dotyczące wideo
    12. Sprawdzone procedury — wskazówki dotyczące tworzenia aplikacji SWF
    13. Sprawdzone procedury — określanie struktury pliku FLA
    14. Sprawdzone procedury optymalizowania plików FLA dla programu Animate
    15. Ustawienia publikowania kodu ActionScript
    16. Określanie ustawień publikowania w programie Animate
    17. Eksportowanie plików projektora
    18. Eksportowanie obrazów i animowanych plików GIF
    19. Szablony publikowania w formacie HTML
    20. Korzystanie z programów Adobe Premiere Pro i After Effects
    21. Szybkie udostępnianie i publikowanie animacji

Tworzenie animacji klatka po klatce

Animacja klatka po klatce powoduje zmienianie zawartości stołu montażowego w każdej klatce. Animacje takie sprawdzają się najlepiej w przypadku złożonych projektów, gdy nie wystarczy prosty ruch po stole montażowym, lecz wymagane jest tworzenie odrębnych klatek dla kolejnych stanów obrazu. Pliki takich animacji są jednak dużo większe od plików animacji z klatkami pośrednimi. W przypadku animacji poklatkowej program Animate musi zapisać pełne dane wszystkich klatek.

Tworzenie animacji klatka po klatce polega na tworzeniu kolejnych klatek kluczowych i przypisywaniu im odrębnych obrazów. Każda nowa klatka kluczowa ma początkowo tę samą zawartość, co klatka ją poprzedzająca. Zawartość tę należy odpowiednio zmodyfikować.

  1. Uaktywnij wybraną warstwę, klikając jej nazwę, a następnie zaznacz na niej klatkę początkową animacji.
  2. Jeśli wybrana klatka nie jest klatką kluczową, wybierz polecenie Wstaw > Oś czasu > Klatka kluczowa.
  3. Utwórz kompozycję, która będzie przypisana do pierwszej klatki. Skorzystaj z narzędzi do rysowania, wklej grafikę ze schowka lub zaimportuj plik.
  4. Aby dodać klatkę kluczową o takiej samej zawartości co pierwsza klatka kluczowa, kliknij kolejną klatkę z prawej w tym samym wierszu. Wybierz opcję Wstaw > Oś czasu > Klatka kluczowa lub kliknij prawym przyciskiem myszy (Windows) albo z wciśniętym klawiszem Control (Mac OS) i wybierz opcję Wstaw klatkę kluczową.

  5. Utwórz kolejny krok animacji, odpowiednio zmieniając zawartość ramki na stole montażowym.
  6. Powtarzaj kroki 4 i 5, aż do utworzenia wszystkich klatek animacji.
  7. Przetestuj animację. W tym celu wybierz polecenie Sterowanie > Odtwórz albo kliknij przycisk Odtwórz w Kontrolerze (Okno > Paski narzędzi > Kontroler).

Tworzenie animacji klatka po klatce przez konwertowanie animacji klasycznych i animacji ruchu

Zakres animacji klasycznej lub animacji ruchu można przekształcić w animację klatka po klatce. W animacji klatka po klatce każda klatka zawiera osobne klatki kluczowe (nie klatki kluczowe właściwości), a każda z nich zawiera osobne instancje animowanego symbolu. Animacja klatka po klatce nie zawiera interpolowanych wartości właściwości.

  1. Kliknij zakres animacji wybrany do konwersji prawym przyciskiem myszy (Windows) lub przytrzymując klawisz Ctrl (Macintosh), a następnie wybierz z menu kontekstowego opcję Konwertuj na animację klatka po klatce.

Korzystanie z przenikania ujęć

Zwykle na stole montażowym są wyświetlane pojedyncze klatki i sekwencje. Funkcja przenikania ujęć ułatwia rysowanie, rozmieszczanie i montaż animacji poklatkowych. Wyświetla ona zawartość poprzedniej i następnej klatki na stole montażowym. Klatka pod pozycją głowicy odtwarzania jest wyświetlana w pełnych kolorach, a klatki przeszłe i przyszłe są różnicowane za pomocą różnych kolorów i wartości kanału alfa. 

Poprzednia i następna klatka wyświetlane przez funkcję przenikania ujęć mają tintę domyślną. Aby dostosować te kolory, użyj opcji Ustawienia zaawansowane.

Przełączanie przenikania ujęć

  • Kliknij przycisk Przenikanie ujęć , aby włączyć lub wyłączyć efekt przenikania ujęć.
  • Aby selektywnie wykluczyć lub dołączyć klatki, w nagłówku osi czasu kliknij prawym przyciskiem myszy klatkę przenikania ujęć w zakresie tej funkcji.
  • Aby wyświetlić i wybrać opcje, kliknij i przytrzymaj przycisk Przenikanie ujęć .

Zaawansowane ustawienia przenikania ujęć

Kliknij i przytrzymaj przycisk Przenikanie ujęć , a następnie wybierz opcję Ustawienia zaawansowane.

Dostosowywanie zakresu

Dostosowywanie kolorów wyświetlania przenikania ujęć

  1. Aby dostosować kolor klatek w mechanizmie przenikania ujęć, na pasku Oś czasu wybierz opcję Przenikanie ujęć.
  2. Kliknij i przytrzymaj przycisk Przenikanie ujęć , a następnie wybierz opcję Ustawienia zaawansowane.
  3. Zmień tintę poprzedniej i następnej klatki.

Tryb konturów i wypełnień

Dostosowywanie krycia

  1. Aby dostosować krycie klatek wyświetlanych przez funkcję przenikania ujęć, kliknij i przeciągnij suwak Krycie na początku.

  2. Aby zmniejszyć różnice między kolejnymi klatkami przenikania ujęć o określony procent, przeciągnij suwak Zmniejsz o.

Pokaż tylko klatki kluczowe

  1. Aby dostosować kolor klatek w mechanizmie przenikania ujęć, na pasku Oś czasu wybierz opcję Przenikanie ujęć.
  2. Wybierz pozycję Edycja > Preferencje.
  3. W polu Kolory przenikania ujęć wybierz przyciski próbek kolorów, aby dostosować i ustawić kolory przeszłych, obecnych i przyszłych klatek
    .

Markery kotwiczenia

Wyświetlanie na stole montażowym wielu klatek animacji

Kliknij przycisk Przenikanie ujęć . Wszystkie klatki pomiędzy znacznikami początku i końca (w nagłówku osi czasu) w oknie dokumentu są nałożone na siebie i prezentowane jako jedna klatka.

Znaczniki przenikania ujęć

Przenikanie ujęć kodowane kolorami

Dzięki różnym kolorom można łatwo rozpoznać klatki przeszłe, teraźniejsze i przyszłe w kontekście przenikania ujęć. Dzięki mechanizmowi przenikania ujęć klatki oddalone od aktywnej są wyświetlane z rosnącym poziomem przezroczystości.

Przenikanie ujęć na osi czasu

Kolory przenikania ująć identyfikujące klatki — przeszłe, obecne i przyszłe

Tryb obramowania przenikania ujęć

Dostosowywanie kolorów wyświetlania przenikania ujęć

  1. Aby dostosować kolor klatek w mechanizmie przenikania ujęć, na pasku Oś czasu wybierz opcję Przenikanie ujęć.
  2. Wybierz pozycję Edycja > Preferencje.
  3. W polu Kolory przenikania ujęć wybierz przyciski próbek kolorów, aby dostosować i ustawić kolory przeszłych, obecnych i przyszłych klatek
    .
Uwaga:

Kodowanie kolorami funkcjonuje także w trybie obramowania.

Tryb osi czasu przenikania ujęć

Dostosowane przenikanie ujęć

  • Aby zmienić położenie znacznika przenikania ujęć, przeciągnij go w nowe miejsce. Zwykle znaczniki przenikania ujęć przesuwają się zgodnie ze wskaźnikiem klatki bieżącej. Przeciągnij z wciśniętym klawiszem Control/Command, aby zmienić położenie znacznika po obu stronach.
  • Aby włączyć tryb edycji wszystkich klatek między znacznikami przenikania ujęć, kliknij przycisk Edytuj wiele klatek . Zwykle w trybie przenikania ujęć można edytować tylko bieżącą klatkę. Można wyświetlać zawartość poszczególnych klatek między znacznikami przenikania ujęć i edytować je.
  • Aby przenieść zakres pętli na osi czasu do miejsca zawierającego głowicę odtwarzania, użyj znaczników na osi czasu i przeciągnij zakres z wciśniętym klawiszem Shift. 

  • Aby ustawiać znaczniki zakresu, wystarczy przeciągać je z wciśniętym klawiszem Shift. Można też zapętlić zakres przy użyciu dowolnego ze znaczników na osi czasu.
Uwaga:

Kiedy przenikanie ujęć jest włączone, nie są widoczne warstwy zablokowane (warstwy z ikonami kłódek). Dlatego też, aby uniknąć nadmiaru przenikających się obrazów, warto zablokować (czyli ukryć) niektóre warstwy.

Podgląd materiałów podczas pracy

Aby sprawdzić działanie efektu przenikania ujęć, przesuń kursorem myszy przez całą długość osi czasu. Animacja będzie odtwarzana w kolorowych obramowaniach, z dokładnym podglądem zmian. 

Logo Adobe

Zaloguj się na swoje konto