Eksportowanie obrazów i grafiki

Sekwencja PNG

Można wyeksportować serię plików obrazów z klipu filmowego, przycisku lub symbolu graficznego znajdującego się w panelu Biblioteka lub na stole montażowym. Podczas eksportowania program Animate CC (dawniej Flash Professional CC) tworzy oddzielny plik obrazu dla każdej klatki w symbolu. W przypadku eksportowania ze stołu montażowego wszelkie przekształcenia (na przykład skalowanie) zastosowane do wystąpienia symbolu są zachowywane na obrazie wyjściowym.

Aby wyeksportować sekwencję PNG:

  1. Zaznacz klip filmowy, przycisk lub symbol grafiki w panelu Biblioteka lub na stole montażowym.

  2. Kliknij prawym przyciskiem myszy i wybierz polecenie Eksportuj sekwencję PNG.

    select-png-sequence
  3. W oknie dialogowym zapisywania jako wybierz lokalizację wyjściową i kliknij przycisk OK.

     

  4. Ustaw odpowiednie opcje w oknie dialogowym eksportowania sekwencji PNG.

    export-pngsequence

    Szerokość — szerokość obrazu wyjściowego. Można skalować obraz wyjściowy, zmieniając tę wartość. Wartością domyślą jest szerokość zawartości symbolu.

    Wysokość — wysokość obrazu wyjściowego. Można skalować obraz wyjściowy, zmieniając tę wartość. Wartością domyślą jest wysokość zawartości symbolu.

    Rozdzielczość — rozdzielczość obrazu wyjściowego. Wartość domyślna wynosi 72 dpi.

    Kolory — głębia bitowa obrazu wyjściowego. Można wybrać wartość 8 bitów, 24 bity lub 32 bity. Wartość domyślna to 32 bity z obsługą przezroczystości. Wybranie opcji 24 bity lub 8 bitów (nieobsługującej przezroczystości) powoduje zmianę ustawienia tła na stół montażowy. Zobacz poniżej.

    Tło — kolor tła, jaki ma być używany na obrazie wyjściowym. To ustawienie jest dostępne tylko w przypadku ustawienia wartości 8 bitów lub 24 bity w polu Kolory. W przypadku ustawienia kolorów 32-bitowych tło obrazu jest zawsze przezroczyste. Gdy opcja Kolory jest ustawiona na 8 bitów lub 24 bity, opcja Tło przyjmuje domyślnie wartość koloru stołu montażowego. W przypadku obrazów 8- i 24-bitowych można zmienić ustawienie na Nieprzezroczyste i ustawić kolor tła za pomocą próbnika kolorów. Jest również możliwe uzyskanie przezroczystości przez wybranie wartości kanału alfa dla tła.

    Wygładzanie — przełącza funkcję wygładzania krawędzi obrazu wyjściowego. Tę opcję należy wyłączyć, jeśli nie jest używane tło przezroczyste i obrazy mogą zostać umieszczone na tle o kolorze innym niż bieżący kolor stołu montażowego.

  5. Aby wyeksportować sekwencję PNG, kliknij przycisk Eksportuj.

Eksportowanie animowanego pliku GIF

W programie Animate można eksportować animowane pliki GIF, wykonując następujące czynności: 

  1. Wybierz polecenie Plik > Eksportuj > Eksportuj animowany plik GIF.

    Zostanie wyświetlone okno dialogowe. 

    export-animated-gif
  2. Wybierz odpowiednie opcje w tym oknie i kliknij przycisk Gotowe, aby wyeksportować animację jako animowany plik GIF. 

    animated-gif-dialog

    Można również wyeksportować statyczny obraz GIF, używając polecenia Plik > Eksportuj > Eksportuj obraz.

Eksportowanie obrazów i grafik do Bibliotek Creative Cloud

Aby wyeksportować obrazy lub grafikę do Bibliotek Creative Cloud, wybierz opcję Okno > Biblioteka Creative Cloud.

Zostanie wyświetlone okno Biblioteki Creative Cloud. 

add-to-cc-library

Kliknij ikonę + w lewym górnym rogu okna Biblioteki Creative Cloud, wybierz obrazy lub pliki graficzne i kliknij przycisk Dodaj.

Format wymiany grafiki FXG (przestarzały od wersji Animate CC)

Informacje o plikach FXG

FXG to format pliku do wymiany grafiki dla platformy oprogramowania Animate/Flash. Opiera się na podzbiorze języka MXML — języka programowania typu XML, z którego korzysta struktura Flex. Format FXG ułatwia programistom i projektantom wydajną współpracę, pozwalając na wymianę zawartości graficznej z zachowaniem wierności. Projektanci mogą tworzyć zawartość za pomocą narzędzi graficznych aplikacji Adobe i eksportować tę grafikę w formacie FXG. Pliki FXG można następnie wykorzystać w takich narzędziach, jak Adobe Flash Builder i Adobe Flash Catalyst, tworząc zaawansowane interfejsy i aplikacje internetowe.

Grafika wektorowa jest zapisywana bezpośrednio w pliku FXG. Elementy, dla których nie ma odpowiedniego znacznika FXG, są eksportowane jako grafika bitmapowa, a w pliku FXG dodawane są odniesienia do tej zawartości. Są to m.in. bitmapy, niektóre filtry, niektóre tryby mieszania, gradienty, maski i obiekty 3D. Niektóre z tych efektów można wyeksportować w formacie FXG, ale nie można ich zaimportować w aplikacjach otwierających pliki FXG.

Podczas eksportowania pliku zawierającego obrazy wektorowe i bitmapowe, wraz z plikiem FXG tworzony jest odrębny folder. Folder ten ma nazwę <nazwa_pliku.assets> i zawiera obrazy bitmapowe związane z plikiem FXG.

Więcej informacji o formacie plików FXG zawiera specyfikacja standardu FXG 2.0.

Ograniczenia eksportu w formacie FXG

Program Animate umożliwia wyeksportowanie dowolnie wielu obiektów zaznaczonych na stole montażowym do pliku w formacie FXG. Podczas eksportu do formatu FXG zachowywane są nazwy obiektów i warstw.

Zapis elementów do pliku FXG podlega jednak następującym ograniczeniom:

  • Siatki Scale-9: są eksportowane, ale czytelne tylko dla programu Adobe Illustrator.

  • Dźwięk i wideo: nie są eksportowane.

  • Składniki: nie są eksportowane.

  • Animacje i animacje wieloklatkowe: Nie są eksportowane, ale zaznaczona klatka zostanie wyeksportowana jako obiekt statyczny.

  • Czcionki osadzone: nie są eksportowane.

  • Symbole przycisków: program Animate eksportuje tylko stan niewciśnięty przycisków.

  • Właściwości 3D: nie są eksportowane.

  • Właściwości kinematyki odwrotnej (IK): nie są eksportowane.

  • Atrybuty tekstu: niektóre atrybuty mogą nie zostać wyeksportowane.

Eksportowanie treści Animate w formacie FXG

Program Animate udostępnia dwa sposoby eksportowania treści w formacie FXG:

  • Aby wyeksportować obiekty ze stołu montażowego w formacie FXG, zaznacz obiekty i wybierz polecenie Eksportuj > Eksportuj zaznaczenie, a następnie wybierz format FXG z menu Typ pliku.

  • Aby zapisać cały stół montażowy w formacie FXG, wybierz polecenie Eksportuj > Eksportuj obraz i z menu Typ pliku wybierz format Adobe FXG.

Sekwencja JPEG i Obraz JPEG

Te opcje odpowiadają opcjom Ustawienia publikowania plików JPEG. Opcja Tak jak ekran powoduje dopasowanie wyeksportowanego obrazu do rozmiaru materiałów w programie Animate w postaci wyświetlonej na ekranie. Polecenie Dopasuj film dopasowuje obraz JPEG do zawartości programu Animate i pozwala zachować proporcje oryginalnego obrazu.

Sekwencja PNG i Obraz PNG

Opcje ustawień eksportu PNG są podobne do opcji ustawień publikowania PNG (gdzie mają również zastosowanie), z następującymi wyjątkami:

Wymiary

Pozwala określić wymiary eksportowanego obrazu bitmapowego; należy wprowadzić odpowiednie liczby pikseli w polach Szerokość i Wysokość.

Rozdzielczość

Pozwala określić rozdzielczość w dpi. Można zaznaczyć opcję Dopasuj ekran, aby zastosować rozdzielczość ekranu i pozostawić proporcje oryginalnego obrazu.

Kolory

Działa tak samo jak opcja Głębia bitowa na zakładce Ustawienia publikowania pliku PNG. Określa liczbę bitów na piksel w tworzonym obrazie. Dla obrazu o 256 kolorach należy zaznaczyć opcję 8 bitów; dla tysięcy kolorów — 24 bity na kanał; dla tysięcy kolorów z przezroczystością (32 bity na kanał) — 24 bity na kanał i Alfa. Im większa głębia bitowa, tym większy plik.

Dołączanie

Pozwala wyeksportować mały wycinek obrazu lub cały dokument.

Uwaga:

Wymiary eksportowanego obrazu GIF są ograniczone do wartości mniejszych niż 4000 pikseli. To ograniczenie dotyczy tylko wersji programu nowszych niż CS6.

Uwaga:

Opcja Roztrząsaj kolory jednolite nie działa, gdy jest wybrana opcja 256 kolorów. Oznacza to, że nie jest wykonywane roztrząsanie obrazu GIF, jeśli wybrano schemat 256 kolorów dla formatu GIF.

(Przestarzałe w programie Animate CC) Obraz bitmapowy (BMP)

Program pozwala tworzyć obrazy bitmapowe do zastosowania w innych aplikacjach. Okno dialogowe eksportowania bitmapy zawiera następujące opcje:

Wymiary

Pozwala ustawić rozmiar eksportowanego obrazu bitmapowego w pikselach. Ustawiony rozmiar ma zawsze takie same proporcje jak rozmiar oryginalnego obrazu.

Rozdzielczość

Ustawienie rozdzielczości wyeksportowanego obrazu bitmapy w punktach na cal (dpi) oraz wyliczenie szerokości i wysokości jest oparte na rozmiarze rysunku. Aby dopasować rozdzielczość do monitora, zaznacz opcję Dopasuj ekran.

Głębia koloru

Pozwala określić głębię bitową obrazu. Głębia obrazów bitmapowych o 32 bitach na kanał nie jest obsługiwana przez niektóre aplikacje systemu Windows. Jeśli wystąpią problemy z formatem 32 bitów na kanał, należy użyć formatu 24 bitów na kanał.

Gładki

Do wyeksportowanej bitmapy jest stosowane wygładzanie. W wyniku zastosowania wygładzania powstaje obraz bitmapowy o wyższej jakości, ale powoduje to, że na kolorowym tle wokół obrazu tworzy się otoczka szarych pikseli. Jeżeli pojawi się otoczka, należy wyłączyć tę opcję.

Dokument programu Animate (SWF)

Aby umieścić obiekty programu Animate w innej aplikacji, takiej jak program Dreamweaver, należy wyeksportować cały dokument jako plik SWF. Program Animate eksportuje plik SWF, używając bieżących ustawień okna dialogowego Ustawienia publikowania dla danego pliku FLA.

Eksportowanie wideo HD przy użyciu narzędzia Adobe Media Encoder

Program Animate CC umożliwia eksportowanie animacji, symboli i grafiki do plików wideo HD w wielu formatach. Wideo HD eksportowanych przy użyciu programu Animate można używać w aplikacjach obsługujących komunikację konferencje wideo, przesyłanie strumieniowe i udostępnianie.

Domyślnie program Animate może eksportować tylko pliki w formacie QuickTime Movie (MOV). Funkcja eksportowania wymaga zainstalowania najnowszej wersji programu QuickTime Player, ponieważ podczas eksportowania plików MOV program Animate korzysta z bibliotek QuickTime.

Obieg pracy eksportowania wideo HD został zmodyfikowany. Obecnie program Animate jest zintegrowany z narzędziem Adobe Media Encoder. Umożliwia ono konwertowanie plików MOV na szereg innych formatów. W celu zapewnienia tych opcji narzędzie Adobe Media Encoder zostało zoptymalizowane tak, aby wyświetlało tylko formaty eksportowania powiązane z zawartością Animate. Więcej informacji o kodowaniu i eksportowaniu wideo przy użyciu narzędzia Adobe Media Encoder zawiera artykuł Kodowanie i eksportowanie wideo i dźwięku.

Uwaga:

Narzędzie Adobe Media Encoder jest automatycznie instalowane wraz z programem Animate CC w przypadku używania aplikacji Creative Cloud na komputery.

Różnica między starszym a najnowszym obiegiem pracy eksportowania wideo

Nowy obieg pracy eksportowania wideo różni się od procedur używanych w programie CS6 lub starszym.

Najważniejsze różnice:

  • Integracja z programem Adobe Media Encoder: Program Animate CC jest zintegrowany z narzędziem Adobe Media Encoder 7.0. Wcześniejsze wersje działały niezależnie od tego narzędzia.
  • Formaty eksportowania: Program Animate CC pozwala eksportować tylko filmy QuickTime.
  • Wideo HD: Program Animate CC umożliwia eksportowanie wideo HD.

W wersji CS6 występowały następujące problemy z tym obiegiem pracy:

  • W obiegu pracy eksportowania plików MOV opartym na oprogramowaniu QuickTime często występowały błędy i nadmierne użycie pamięci.
  • Mechanizm eksportowania do formatu AVI nie obsługiwał klipów filmowych.

W programie Animate CC powyższe problemy nie występują. Wyeliminowano w nim między innymi błąd powodujący utratę klatek. Obieg pracy oparty na narzędziu Adobe Media Encoder umożliwia bezproblemowe eksportowanie filmów MOV w programie Animate CC. Ta nowa metoda pozwala na eksportowanie zawartości Animate do plików MOV, a następnie konwertowanie plików MOV w programie Adobe Media Encoder na dowolny wymagany format wyjściowy.

Eksportowanie od klatki 2

Zależnie od struktury osi czasu materiał wideo może być eksportowany na dwa sposoby:

  1. Jeśli główna oś czasu zawiera więcej niż jedną klatkę, eksport zaczyna się od klatki 2.
  2. Jeśli główna oś czasu zawiera tylko jedną klatkę, eksport obejmuje klatkę 1.
  3. Jeśli główna oś czasu zawiera więcej niż jedną klatkę i do klatki 1 zostanie dodany kod ActionScript lub dźwięk, ta funkcja nie zostanie wywołana.

Eksportowanie wideo HD

Przed rozpoczęciem eksportowania wykonaj następujące czynności:

  • Zainstaluj program QuickTime.
  • Ustaw płynność odtwarzania równą 60 kl./s lub niższą. Więcej informacji znajduje się w rozdziale Podstawy stosowania kanałów.
  1. Utwórz lub otwórz plik FLA.

  2. Wybierz polecenie Plik > Eksportuj > Eksportuj wideo.

    export-video
    Okno dialogowe Eksportowanie wideo

  3. W oknie dialogowym Eksportowanie wideo pola Renderowana szerokość i Renderowana wysokość przyjmują wartości odpowiadające rozmiarowi stołu montażowego.

  4. Ustaw odpowiednie opcje w oknie dialogowym Eksportowanie wideo:

    • Rozmiar renderowanywysokość i szerokość: Pozwala skonfigurować rozmiar renderowanego obrazu odpowiednio do rozdzielczości, w której będzie on renderowany (zależnie od tego, czy wideo będzie eksportowane w rozdzielczości HD czy standardowej). Ustawione wartości równają się szerokości i wysokości stołu montażowego. Aby zmienić wartości Renderowana szerokość i Renderowana wysokość, zmodyfikuj rozmiar stołu montażowego. Program Animate zachowuje proporcje zgodne z wymiarami stołu montażowego.
    • Ignoruj kolor stołu montażowego (generuj kanał alfa): Tworzy kanał alfa przy użyciu koloru stołu montażowego. Kanał alfa jest kodowany jako ścieżka przezroczystości. Umożliwia nałożenie wyeksportowanego filmu QuickTime na wierzch innych materiałów w celu zmiany koloru tła lub sceny.
    • Konwertuj wideo w programie Adobe Media Encoder: Wybierz tę opcję, aby przekonwertować wyeksportowany plik MOV na inny format za pomocą programu Adobe Media Encoder. W przypadku wybrania tej opcji po zakończeniu eksportowania wideo przez program Animate jest uruchamiany program Adobe Media Encoder.
    • Ścieżka do wyeksportowanego wideo: Umożliwia wprowadzenie lub wskazanie ścieżki do lokalizacji, do której ma zostać wyeksportowany materiał wideo.
    • Zatrzymaj eksportowanie: Określa, kiedy program Animate ma zatrzymać eksportowanie.
      • Po osiągnięciu ostatniej klatki: Wybierz tę opcję, jeśli operacja ma zostać zakończona na ostatniej klatce.
    Zatrzymanie eksportowania po osiągnięciu ostatniej klatki
    Zatrzymanie eksportowania po osiągnięciu ostatniej klatki
    • Zatrzymaj eksportowanie: Określa, kiedy program Animate ma zatrzymać eksportowanie.
      • Wykorzystany czas po: Wybierz tę opcję, aby określić czas, po jakim eksportowanie ma zostać zatrzymane. Ta opcja umożliwia oddzielne eksportowanie części wideo.
    Zatrzymanie eksportowania po 1 min 15 s
    Zatrzymanie eksportowania po 1 min 15 s
    Zatrzymanie eksportowania po 3 s
    Zatrzymanie eksportowania po 3 s

  5. Kliknij przycisk Eksportuj. Jeśli zaznaczono opcję Konwertuj wideo w programie Adobe Media Encoder, zostanie uruchomiony program Adobe Media Encoder, a wyeksportowany plik MOV będzie dostępny w nowej kolejce. Więcej informacji o kodowaniu i konwertowaniu wideo przy użyciu programu Adobe Media Encoder zawiera artykuł Kodowanie i eksportowanie wideo i dźwięku.


Ta zawartość jest licencjonowana na warunkach licencji Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Posty z serwisów Twitter™ i Facebook nie są objęte licencją Creative Commons.

Informacje prawne   |   Zasady prywatności online