Formatowanie kodu

Kod może być formatowany i rozmieszczany (wcięcia) automatycznie podczas pisania. Zaleca się korzystanie z dynamicznego odwzorowywania czcionek, ponieważ zapewnia ono poprawny wybór czcionek w przypadku tekstów wielojęzycznych.

Ustawianie opcji automatycznego formatowania

  1. Wykonaj jedną z następujących czynności:
    • Przejdź do menu panelu  (w prawym górnym rogu panelu Operacje) i wybierz polecenie Preferencje.

    • W oknie Skrypt wybierz polecenie Edycja > Preferencje (Windows) lub Animate > Preferencje (Mac OS).

  2. W oknie dialogowym Preferencje wybierz polecenie Auto-format.
  3. Zaznacz dowolne opcje automatycznego formatowania.

    Po skonfigurowaniu opcji Auto-format ustawienia zostaną automatycznie zastosowane do tworzonego kodu, ale nie zostaną zastosowane do kodu już istniejącego; do już utworzonego kodu ustawienia należy zastosować ręcznie.

Formatowanie kodu zgodnie z ustawieniami automatycznego formatowania

  • Na pasku narzędzi panelu Operacje lub okna Skrypt kliknij przycisk Autoformatowanie .
  • Przejdź do menu panelu (w prawym górnym rogu panelu Operacje) i wybierz polecenie Auto-format.
  • Naciśnij klawisze Control+Shift+F (Windows) lub Command+Shift+F (Mac OS).
  • W oknie Skrypt wybierz polecenie Narzędzia > Auto-format.

Używanie dynamicznego odwzorowywania czcionek

  1. Do włączanie i wyłączania dynamicznego odwzorowywania czcionek służy opcja Użyj dynamicznego odwzorowania czcionek, dostępna w oknie Preferencje.

    Dynamiczne odwzorowywanie czcionek jest domyślnie wyłączone, ponieważ zwiększa ono czas przetwarzania skryptu. Funkcję tę należy jednak włączyć w przypadku tekstów wielojęzycznych, gdyż w ich wypadku zapewnia ona poprawny wybór czcionek.

Używanie automatycznych wcięć

  1. Do włączanie i wyłączania automatycznych wcięć służy opcja Automatyczne wcięcie, dostępna w oknie Preferencje.

    Zaznaczenie tej opcji powoduje, że tekst wpisywany po otwarciu nawiasów (zwykłych lub klamrowych) jest automatycznie wcinany — zgodnie z ustawieniem Rozmiar zakładki w preferencjach języka ActionScript.

    W trakcie pisania skryptu linię można wciąć, zaznaczając ją i naciskając klawisz Tab. Aby usunąć wcięcie, należy zaznaczyć linię i nacisnąć klawisze Shift+Tab.

Sekcje komentarzy do kodu

Komentarze do kodu są to fragmenty kodu pomijane przez kompilator języka ActionScript. Komentarze zawierają pewne wyjaśnienia. Za ich pomocą można także wycinać ze skryptu kod, którego z jakichś powodów nie można usunąć na stałe. Pojedyncza linia kodu stanowi komentarz, jeśli zaczyna się od podwójnego ukośnika (//). Kompilator ignoruje wszystkie linie tak oznaczone. Aby komentarz obejmował większy fragment kodu, należy umieścić na jego początku ukośnik i gwiazdkę (/*), a na końcu gwiazdkę i ukośnik (*/).

Wymienione znaczniki komentarzy można wprowadzić ręcznie lub za pomocą przycisków dostępnych u góry panelu Operacje lub okna Skrypt.

Komentowanie linii kodu

  1. Umieść punkt wstawiania na początku linii kodu lub przed znakiem, od którego ma się rozpocząć komentarz.
  2. Kliknij prawym przyciskiem myszy i wybierz polecenie Komentarz. Można również skorzystać ze skrótu klawiaturowego Ctrl + M (Windows) albo Command + M (Mac OS) lub wybrać polecenie Edycja > Komentarz zaznaczenia.

W punkcie wstawiania pojawi się podwójny ukośnik (//).

Komentowanie wielu linii kodu

  1. Zaznacz linie do skomentowania. (Pierwsza i ostatnia linia mogą być zaznaczone częściowo.)
  2. Kliknij prawym przyciskiem myszy i wybierz polecenie Komentarz. Można również skorzystać ze skrótu klawiaturowego Ctrl + M (Windows) albo Command + M (Mac OS) lub wybrać polecenie Edycja > Komentarz zaznaczenia.

Na początku zaznaczenia zostanie umieszczony znak początku komentarza (/*), a na końcu — znak końca komentarza (*/).

Uwaga:

Dla komentarzy między zaznaczonymi wierszami tekstu we wszystkich zaznaczonych wierszach zostanie zastosowany format wiersza komentarza.

Usuwanie komentarza

  1. Umieść punkt wstawiania w linii zawierającej komentarz lub zaznacz blok kodu stanowiący komentarz.
  2. Kliknij prawym przyciskiem myszy i wybierz polecenie Usuń komentarz. Można również skorzystać ze skrótu klawiaturowego Ctrl + Shift + M (Windows) albo Command + Shift + M (Mac OS) lub wybrać polecenie Edycja > Usuń komentarz zaznaczenia.

Kolorowanie konstrukcji składniowych

W języku ActionScript, podobnie jak w każdym innym języku, obowiązuje pewna składnia, czyli zbiór reguł odpowiedzialnych za konstruowanie złożonych wyrażeń językowych. Skrypty ActionScript o nieprawidłowej składni nie działają.

Wykrywane w skryptach błędy składniowe można wyróżniać określonymi kolorami. Załóżmy dla przykładu, że określono preferencję kolorowania słów kluczowych na niebiesko. Po wpisaniu poprawnego słowa kluczowego, czyli var, słowo var zostanie wyróżnione kolorem niebieskim. Jeśli jednak omyłkowo zostanie wpisane niepoprawne słowo kluczowe vae, słowo to, czyli vae pozostanie czarne. W ten sposób będzie można dostrzec błąd.

Wykonaj jedną z następujących czynności:

  • Wybierz polecenie Edycja > Preferencje (Windows) lub Animate > Preferencje (Mac OS), kliknij opcję Edytor kodu na liście kategorii, a następnie określ ustawienia kolorowania składni.

  • Gdy punkt wstawiania znajduje się w okienku Skrypt naciśnij klawisze Control-U (Windows) lub Command-U (Mac OS).

Uwaga:

Jeśli skrypt jest tworzony za pomocą panelu Operacje, to wszelkie polecenie nieobsługiwane przez wskazaną wersję odtwarzacza są wyróżniane w przyborniku na żółto. Na przykład, jeśli wersję odtwarzacza Flash Player ustawiono jako 7, wszelkie fragmenty kodu ActionScript, które są obsługiwane tylko przez odtwarzacz Flash Player 8, będą wyświetlane w przyborniku Operacje na żółto.

Używanie listy identyfikatorów i słów kluczowych w czasie działania

Podczas uruchamiania program Animate wczytuje listy identyfikatorów i słów kluczowych z pliku zasobów i umieszcza je w buforze. Poza odczytem list domyślnych z zasobów jest skanowany folder Preference w poszukiwaniu listy dodatkowych słów kluczowych i identyfikatorów. Umieszczając pliki TXT w następujących folderach, można dodawać słowa kluczowe i identyfikatory:

  • C:\Użytkownicy\<nazwa użytkownika>\[AppData]\Roaming\Adobe\Animate\13.0[ActionscriptKeywords]\

  • C:\Użytkownicy\<nazwa użytkownika>\[AppData]\Roaming\Adobe\Animate\13.0[ActionscriptIdentifiers]\

  • C:\Użytkownicy\<nazwa użytkownika>\[AppData]\Roaming\Adobe\Animate\13.0[JavascriptKeywords]\

  • C:\Użytkownicy\<nazwa użytkownika>\[AppData]\Roaming\Adobe\Animate\13.0[JavascriptIdentifiers]\

Używanie numerów linii i zawijania linii

Numery linii ułatwiają przeglądanie kodu i sprawdzanie jego poprawności. Funkcja zawijania pozwala uniknąć zbyt długich linii kodu, które trzeba przewijać w poziomie (jest ona szczególnie przydatna przy niskiej rozdzielczości ekranu).

Włączanie lub wyłączanie numerów linii

  • W oknie Skrypt wybierz polecenie Widok > Numery linii.
  • Naciśnij klawisze Control+Shift+L (Windows) lub Command+Shift+L (Mac OS).

Wyróżnianie konkretnej linii

  • W oknie Skrypt wybierz polecenie Edycja > Przejdź do linii.

Włączanie lub wyłączanie zawijania linii

  • W oknie Skrypt wybierz polecenie Widok > Zawijanie tekstu.
  • Naciśnij klawisze Control+Shift+W (Windows) lub Command+Shift+W (Mac OS).

Wyświetlanie znaków ukrytych

W kodzie ActionScript są ukrywane takie znaki, jak spacje, znaki tabulacji i znaki podziału linii. W pewnych sytuacjach może wystąpić konieczność wyświetlenia takich znaków, na przykład, kiedy trzeba odszukać spacje dwubajtowe powodujące błędy na etapie kompilacji.

  • Naciśnij klawisze Control+Shift+8 (Windows) lub Command+Shift+8 (Mac OS).

Do wyświetlania znaków ukrytych są używane następujące symbole.

Znak ukryty

Symbol

Spacja jednobajtowa

.

Spacja dwubajtowa

l

Znak tabulacji

>>

Znak podziału linii


Wyszukiwanie tekstu w skrypcie

Narzędzie Znajdź pozwala znajdować i zastępować w skrypcie ciągi tekstowe.

Uwaga:

Aby przeszukiwane były wszystkie skrypty w danym dokumencie programu Animate, należy użyć Eksploratora filmu.

Wyszukiwanie tekstu

  1. W panelu Operacje lub w oknie Skrypt kliknij przycisk Znajdź  albo naciśnij klawisze Control+F (Windows) lub Command+F (Mac OS).
  2. Wprowadź ciąg do wyszukania.
  3. Kliknij przycisk Znajdź następny.

Wyszukiwanie i zastępowanie tekstu w skrypcie

  1. W panelu Operacje lub w oknie Skrypt kliknij przycisk Znajdź  albo naciśnij klawisze Control+F (Windows) lub Command+F (Mac OS).
  2. Wprowadź ciąg do wyszukania.
  3. W polu Zamień wpisz nowy tekst.
  4. Kliknij przycisk Znajdź następny.
  5. Aby zastąpić znaleziony ciąg, kliknij przycisk Zamień; aby zastąpić wszystkie wystąpienia ciągu, kliknij przycisk Zamień wszystko.

(Przestarzałe w programie Animate) Powtarzanie wyszukiwania w panelu Operacje

  1. Przejdź do menu panelu  (w prawym górnym rogu panelu Operacje) i wybierz polecenie Znajdź ponownie.

(Przestarzałe w programie Animate) Powtarzanie wyszukiwania w oknie Skrypt

  1. Wybierz polecenie Edycja > Znajdź ponownie.

(Przestarzałe w programie Animate) Sprawdzenie składni i interpunkcji

Poprawność kodu ActionScript można sprawdzać bez publikowania pliku FLA.

Sprawdzanie składni obejmuje zawsze bieżący skrypt. Jeśli bieżący skrypt wywołuje klasy ActionScript, również te klasy są sprawdzane. Inne skrypty znajdujące się w pliku FLA nie są sprawdzane.

W przypadku plików w języku ActionScript 2.0 funkcja Sprawdzanie składni uruchamia kod na poziomie kompilatora, generując raporty o błędach składni i kompilatora.

W przypadku plików w języku ActionScript 3.0 funkcja Sprawdzanie składni generuje jedynie raporty na temat błędów składni. Aby wygenerować raporty o błędach kompilatora, dotyczące na przykład niezgodności typu, nieprawidłowych wartości zwracanych, niepoprawnie wpisanych nazw metod lub zmiennych, należy użyć polecenia Sterowanie > Testuj.

Sprawdzanie składni

Aby sprawdzić składnię, wykonaj jedną z następujących czynności:

  • W panelu Operacje lub oknie Skrypt kliknij przycisk Sprawdź składnię .
  • Kliknij w panelu Skrypt, a następnie naciśnij klawisze Control+T (Windows) lub Command+T (Mac OS). Kliknięcie lub rozpoczęcie pisania w panelu Skrypt powoduje, że staje się on aktywny. Jeśli aktywny był obiekt na stole montażowym, zamiast panelu Skrypt otwierany jest panel Przekształć.

Błędy składniowe są wyświetlane w panelu Błędy kompilatora.

Uwaga:

Jeśli w oknie Skrypt jest wyświetlany plik zewnętrznej klasy ActionScript, wówczas globalna ścieżka klasy (AS2) lub ścieżka źródłowa (AS3) może mieć wpływ na sprawdzanie składni. Nawet jeśli globalna ścieżka klasy lub ścieżka źródłowa jest ustawiona poprawnie, mogą powstawać błędy. Dzieje się tak, ponieważ na etapie kompilacji nie zawsze wiadomo, czy dana klasa jest kompilowana.

Sprawdzanie poprawności interpunkcji

  1. Kliknij pomiędzy nawiasami klamrowymi {}, nawiasami kwadratowymi [] lub nawiasami okrągłymi ().
  2. W systemie Windows naciśnij klawisze Control+' (pojedynczy cudzysłów); w systemie Mac OS naciśnij klawisze Command+' (pojedynczy cudzysłów). Tekst pomiędzy nawiasami zostanie podświetlony i będzie można sprawdzić, czy liczba nawiasów otwierających zgadza się z liczbą nawiasów zamykających.

(Przestarzałe w programie Animate) Importowanie i eksportowanie skryptów

Skrypty mogą być importowane do panelu Operacje lub okna Skrypt. Skrypty opracowywane w panelu Operacje mogą też być eksportowane do zewnętrznych plików ActionScript. (Jeśli jest używane okno Skrypt, eksportowanie jest zbędne, ponieważ skrypt można zapisać w postaci pliku AS.)

Jeśli po otwarciu lub zaimportowaniu pliku zawarte w nim skrypty nie wyglądają tak jak powinny, należy zmienić preferencję kodowania danych importowanych.

Importowanie zewnętrznego pliku AS

  1. Przejdź do okienka Skrypt i umieść punkt wstawiania w wybranym miejscu wstawienia pierwszej linii skryptu zewnętrznego.
  2. Wykonaj jedną z następujących czynności:
    • Z menu panelu Operacje wybierz polecenie Importuj skrypt albo naciśnij klawisze Control+Shift+I (Windows) lub Command+Shift+I (Mac OS).

    • W oknie Skrypt wybierz polecenie Plik > Importuj skrypt albo naciśnij klawisze Control+Shift+I (Windows) lub Command+Shift+I (Mac OS).

Eksportowanie skryptu z panelu Operacje

  1. Zaznacz skrypt do wyeksportowania. Następnie przejdź do menu panelu Operacje i wybierz polecenie Eksportuj skrypt albo naciśnij klawisze Control+Shift+X (Windows) lub Command+Shift+X (Mac OS).
  2. Zapisz plik ActionScript (AS).

Ustawianie opcji kodowania tekstu

  1. Wybierz polecenie Edycja > Preferencje (Windows) lub Animate > Preferencje (Mac OS), przejdź na listę Kategoria i wybierz pozycję ActionScript.

  2. Ustaw dowolne spośród następujących opcji:

    Otwórz/Importuj

    Wybierz ustawienie Kodowanie UTF-8, aby przy otwieraniu lub importowaniu pliku było używane kodowanie Unicode. Wybierz ustawienie Kodowanie domyślne, aby było używane kodowanie właściwe dla aktualnego języka systemu.

    Zapisz/Eksportuj

    Wybierz ustawienie Kodowanie UTF-8, aby przy zapisywaniu lub eksportowaniu pliku było używane kodowanie Unicode. Wybierz ustawienie Kodowanie domyślne, aby było używane kodowanie właściwe dla aktualnego języka systemu.

Włączanie lub wyłączanie ostrzeżenia o kodowaniu

  1. Wybierz polecenie Edycja > Preferencje (Windows) lub Animate > Preferencje (Mac OS), przejdź na listę Kategoria i wybierz pozycję Ostrzeżenia.

  2. Zaznacz opcję Ostrzegaj o konfliktach kodowania podczas eksportowania plików ActionScript lub usuń jej zaznaczenie.

(Przestarzałe w programie Animate) Kodowanie importowanych i eksportowanych skryptów

Za pomocą preferencji języka ActionScript można określić typ kodowania, jaki ma obowiązywać w importowanych i eksportowanych plikach ActionScript. Kodowanie UTF‑8 odpowiada 8-bitowemu formatowi Unicode, który pozwala umieścić w pliku tekst wielojęzyczny; Kodowanie domyślne jest to kodowanie obsługiwane przez język używany aktualnie w systemie (obsługiwane przez tzw. tradycyjną stronę kodową).

Uwaga:

Na przykład, jeśli w systemie anglojęzycznym jest używana aplikacja nieanglojęzyczna, to polecenie Testuj film zwraca błąd, o ile jakakolwiek część ścieżki pliku SWF zawiera znaki nie mające swojej reprezentacji w schemacie kodowania MBCS (Multibyte Character Sets). Na przykład, ścieżki japońskojęzyczne, które działają w systemie japońskim, nie działają w systemie angielskim. W systemach angielskich należy używać wyłącznie anglojęzycznych nazw ścieżek. Ograniczeniu temu podlegają wszystkie te funkcje aplikacji, które są zależne od odtwarzacza do testowania filmów.

Przypinanie skryptów w panelu Operacje

Funkcja dołączania skryptów umożliwia przypinanie zakładek poszczególnych skryptów w okienku Skrypt i pozwala przenosić je w odpowiedni sposób. Ta funkcja jest przydatna, jeśli nie uporządkowano kodu w pliku FLA w jednej, centralnej lokalizacji albo jest używanych wiele skryptów.

Skrypt można przypiąć na potrzeby zachowania otwartej lokalizacji w kodzie w panelu Operacje oraz przełączania się między otwartymi skryptami. Funkcja ta jest szczególnie przydatna podczas debugowania. 

Skrypt lub skrypty można odpiąć od zaznaczonego skryptu. Można również odpiąć wszystkie skrypty od panelu Operacje.

Na poniższym rysunku pokazano skrypt skojarzony z aktualną pozycją na osi czasu, czyli klatką nr 1 na warstwie Cleanup. Ostatnia zakładka po lewej stronie zawsze odnosi się do bieżącego położenia skryptu na osi czasu. Skrypt ten jest również przypięty (odpowiada mu ostania zakładka po prawej stronie). Następujące skrypty są przypięte:

  • W klatce 1
  • W klatce 15 warstwy o nazwie Intro

W celu przechodzenia między przypiętymi skryptami można używać skrótów klawiaturowych lub klikać ich zakładki. Przechodzenie między przypiętymi skryptami nie powoduje zmian ich położenia na osi czasu.Jeśli w nawigatorze skryptów ActionScript zostanie wybrany nowy skrypt, punkt skupienia zostanie przeniesiony do pierwszej klatki (klatki 1).

Uwaga:

Jeśli zawartość okienka Skrypt nie zmienia się odpowiednio do zmian położenia na osi czasu, w okienku tym najprawdopodobniej jest pokazywany przypięty skrypt. Aby wyświetlić skrypt skojarzony z bieżącym położeniem na osi czasu, kliknij zakładkę bieżącej klatki po lewej stronie okienka Skrypt.

as_pin_scripts
Przypięty skrypt

Przypinanie skryptu

  1. Kliknij oś czasu, aby wyświetlić skrypt na zakładce bieżącej klatki w lewym górnym rogu okienka Skrypt w panelu Operacje.

  2. Wykonaj jedną z następujących czynności:
    • Kliknij ikonę pinezki po prawej stronie zakładki.
    • Aby przypiąć skrypt, wybierz opcję Widok > Przypnij skrypt.

     

Odpinanie wszystkich skryptów

  1. Zaznacz przypięty skrypt w panelu Operacje.

  2. Wybierz polecenie Widok > Odepnij skrypt, aby odpiąć zaznaczony skrypt od panelu Operacje.

  3. Wybierz polecenie Widok > Odepnij wszystkie skrypty, aby odpiąć wszystkie skrypty od panelu Operacje.

pinscript4
Opcje odpinania

Skróty klawiszowe dotyczące przypiętych skryptów

Jeśli punkt wstawiania znajduje się w okienku Skrypt, pewne operacje na przypiętych skryptach można wykonywać za pomocą następujących skrótów klawiszowych:

Operacja

System Windows 

System Macintosh

Przypięcie skryptu

Control+Shift+= (znak równości)

Command+Shift+=

Odpięcie skryptu

Control+Shift+- (minus)

Command+Shift+-

Wstawianie ścieżek docelowych

Wiele skryptów ma wpływ na działanie klipów filmowych, przycisków i symboli. Odwołania do tych obiektów są reprezentowane w kodzie przez tzw. ścieżki docelowe—czyli adresy obiektów docelowych. Ścieżki docelowe dzielą się na bezwzględne i względne. Ścieżka bezwzględna zawiera cały adres obiektu. Ścieżka względna zawiera tylko część adresu (nie jest to adres samego skryptu z pliku FLA). Po przeniesieniu skryptu w inne miejsce adres względny traci swoje znaczenie.

  1. Przejdź do panelu Operacje i kliknij operację zdefiniowaną w skrypcie.
  2. Kliknij przycisk Ścieżka docelowa .
  3. Wprowadź ścieżkę do obiektu docelowego lub wybierz obiekt z listy.
  4. Zaznacz odpowiednią opcję ścieżki, Względna lub Bezwzględna.

Korzystanie ze wskazówek do kodu

Jeśli użytkownik korzysta z panelu Operacje lub okna Skrypt, program może rozpoznawać wprowadzane operacje i wyświetlać wskazówki do kodu. Należy odróżnić dwa rodzaje wskazówek do kodu: podpowiedzi opisujące pełną składnię operacji oraz wyskakujące menu, zawierające listę dostępnych elementów języka ActionScript, np metod lub właściwości (jest to pewna forma uzupełniania kodu).

Wskazówki do kodu są włączone domyślnie. Za pomocą odpowiednich preferencji można je wyłączyć lub określić szybkość ich wyświetlania. Nawet jeśli wybierze się preferencję wyłączonych wskazówek, będzie je można włączać za pomocą odpowiedniego polecenia.

Uwaga:

Jeśli w przypadku pewnej zmiennej lub pewnego obiektu z kodu ActionScript 2.0 nie można wyświetlić wskazówki, a preferencja wskazówek do kodu ActionScript jest włączona, należy upewnić się, czy podano właściwą nazwę zmiennej lub obiektu (np. czy użyto właściwego sufiksu).

Włączanie podpowiedzi do kodu

Wskazówki do kodu mogą być wywoływane na różne sposoby:

Ścisłe typowanie obiektów

Jeśli jest używany język ActionScript 2.0 i jest definiowana zmienna oparta na wbudowanej klasie (np. Button lub Array), w okienku Skrypt są wyświetlane wskazówki do kodu dotyczącego zmiennej. Załóżmy dla przykładu, że wprowadzono dwie linie kodu:

var foo:Array = new Array(); 
foo.

Natychmiast po wpisaniu kropki (.), program Animate wyświetli menu podręczne z listą metod i właściwości dostępnych dla obiektów typu Array (ponieważ zmienną zdefiniowano jako tablicę).

Sufiksy i wskazówki do kodu

Jeśli jest używany język ActionScript 1.0 lub zachodzi potrzeba wyświetlania wskazówek dla obiektów bez ich ręcznego wpisywania, do nazw tworzonych obiektów można dodawać sufiksy. Na przykład, sufiks wywołujący wskazówkę dotyczącą klasy Camera to _cam. Załóżmy, ze wpisano następujący kod: var my_array = new Array(); var my_cam = Camera.get();

Jeśli zostanie wpisana fraza my_cam, a po niej kropka, pojawią się wskazówki dotyczące obiektu Camera.

W przypadku obiektów wyświetlanych na stole montażowym sufiksy należy wpisywać w oknie Inspektor właściwości, w polu Nazwa sufiksu. Na przykład, aby były wyświetlane wskazówki dla obiektów MovieClip, należy przypisać - za pomocą Inspektora właściwości - do wszystkich obiektów MovieClip nazwy z sufiksami _mc. Dzięki temu po każdym wpisaniu nazwy obiektu zakończonej kropką, będzie wyświetlana wskazówka do kodu.

var my_array = new Array(); 
var my_cam = Camera.get();

Uwaga:

Chociaż sufiksy nie są wymagane (do wyświetlania wskazówek do kodu), jeśli obiekty są definiowane metodą bezpośredniego wpisywania, to ich stosowanie zwiększa przejrzystość kodu.

W poniższej tabeli zestawiono sufiksy wywołujące wskazówki do kodu ActionScript 2.0:

Typ obiektu

Sufiks zmiennej

Array

_array

Button

_btn

Camera

_cam

Color

_color

ContextMenu

_cm

ContextMenuItem

_cmi

Date

_date

Error

_err

LoadVars

_lv

LocalConnection

_lc

Microphone

_mic

MovieClip

_mc

MovieClipLoader

_mcl

PrintJob

_pj

NetConnection

_nc

NetStream

_ns

SharedObject

_so

Sound

_sound

String

_str

TextField

_txt

TextFormat

_fmt

Video

_video

XML

_xml

XMLNode

_xmlnode

XMLSocket

_xmlsocket

Komentarze i wskazówki do kodu

W kodzie ActionScript można wstawiać komentarze określające klasę obiektu. Komentarze takie są brane pod uwagę przy wyświetlaniu wskazówek do kodu. W poniższym przykładzie komentarz informuje o tym, że klasą obiektu theObject jest Object (i podobnie dla kolejnych obiektów).

// Object theObject;// Array theArray;// MovieClip theMC;

Jeśli użytkownik wprowadzi frazę theMC, a po niej kropkę, pojawi się wskazówka do kodu zawierająca listę metod i właściwości klasy MovieClip. Jeśli użytkownik wprowadzi frazę theArray, a po niej kropkę, pojawi się wskazówka do kodu zawierająca listę metod i właściwości klasy Array (i podobnie dla kolejnych obiektów).

Firma Adobe zaleca jednak, aby zamiast tej techniki stosować bezpośrednie wpisywanie danych lub sufiksy. Metody te pozwalają bowiem automatycznie wyświetlać wskazówki do kodu, a ponadto czynią od bardziej przejrzystym.

Określanie preferencji dotyczących automatycznych wskazówek do kodu

  • W panelu Operacje lub oknie Skrypt wybierz polecenie Edycja > Preferencje (Windows) lub Animate > Preferencje (Mac OS), kliknij opcję Edytor kodu na liście kategorii, po czym włącz lub wyłącz opcję Wskazówki do kodu.

(Przestarzałe w programie Animate) Określanie opóźnienia wskazówek do kodu

  1. W panelu Operacje lub w oknie Skrypt wybierz polecenie Edycja > Preferencje (Windows) lub Animate > Preferencje (Mac OS).

  2. Na liście Kategoria kliknij przycisk ActionScript.
  3. Ustaw opóźnienie (w sekundach) za pomocą suwaka.

Korzystanie ze wskazówek do kodu w formie podpowiedzi

  1. Wyświetl wskazówkę do kodu, wpisując nawias otwierający „(” po elemencie wymagającym nawiasów (np. po nazwie metody lub po instrukcji typu if lub do..while).
    as_code_hint_paren1
    Nawiasy otwierające uaktywniają wskazówki do kodu.

  2. Wprowadź wartość parametru.

    W przypadku wielu parametrów oddziel ich wartości przecinkami. W przypadku funkcji lub instrukcji typu for oddziel parametry za pomocą średników.

    W przypadku funkcji lub metod, które mogą być wywoływane z różnymi zestawami parametrów, np. gotoAndPlay() lub for, są wyświetlane wskaźniki pozwalające wybrać parametry. Do wyboru parametrów służą małe strzałki oraz klawisze Control+Strzałka w lewo i Control+Strzałka w prawo.

    as_code_hint_paren3
    Wskazówka do kodu z wieloma zestawami parametrów

  3. Aby zakończyć wyświetlanie wskazówki do kodu, wykonaj jedną z następujących czynności:
    • Wpisz nawias zamykający „)”.

    • Kliknij na zewnątrz instrukcji.

    • Naciśnij klawisz Escape.

Korzystanie ze wskazówek do kodu w formie menu:

  1. Wyświetl wskazówkę, wpisując kropkę po nazwie zmiennej lub obiektu.
    as_code_hint_dot1
    Wskazówki do kodu w formie menu

  2. Do przechodzenia między wskazówkami do kodu używaj klawiszy Strzałka w górę i Strzałka w dół.
  3. Aby wybrać element z menu, naciśnij klawisz Enter lub Tab. Można też dwukrotnie kliknąć element.
  4. Aby zakończyć wyświetlanie wskazówki do kodu, wykonaj jedną z następujących czynności:
    • Wybierz jeden z elementów menu.

    • Kliknij nad lub pod oknem menu.

    • Wpisz nawias zamykający „)” (jeśli wcześniej został użyty nawias zamykający „(”).

    • Naciśnij klawisz Escape.

Ręczne wyświetlanie wskazówki do kodu

  1. Kliknij wewnątrz kodu, w miejscu, gdzie mogą być dostępne wskazówki do kodu, na przykład:
    • Po kropce (.) po instrukcji lub poleceniu, które wymaga określenia właściwości lub metody

    • Między nawiasami [()] w nazwie metody

  2. Wykonaj jedną z następujących czynności:
    • Aby ręcznie włączyć wskazówki do kodu, wybierz polecenie Widok > Pokaż wskazówki do kodu.

    • Naciśnij klawisze Control+Spacja (Windows) lub Command+Spacja (Mac OS).

Podpowiedzi do kodu klas użytkownika

Gdy użytkownik tworzy własne klasy w języku ActionScript 3.0, program Animate analizuje składnię tych klas i określa, jakie obiekty, właściwości i metody są w nich zawarte. Na tej podstawie program Animate może następnie wyświetlać podpowiedzi do kodu odwołującego się do klas niestandardowych. Uzupełnianie kodu odbywa się automatycznie we wszystkich klasach powiązanych z jakimkolwiek innym kodem za pomocą polecenia import.

Podpowiedzi do kodu przyspieszają pracę programistów, ponieważ dzięki nim nie trzeba pamiętać nazw obiektów, metod ani właściwości używanych w klasie. Projektanci mogą używać klas, których sami nie napisali i których gruntownie nie znają.

Wyróżnia się następujące rodzaje podpowiedzi do kodu:

  • Podpowiedzi do zagnieżdżonych odniesień do klas

    Podpowiedzi do kodu są szczególnie przydatne podczas pisania zagnieżdżonych odwołań.

  • Podpowiedzi do słowa kluczowego „this”

    Wpisanie słowa „this” w pliku klasy powoduje wyświetlenie podpowiedzi dotyczącej tej właśnie klasy.

  • Podpowiedzi do kodu „new+<spacja>”

    Po wpisaniu kodu „new+<spacja>” w programie Animate wyświetlana jest lista dostępnych klas i pakietów.

  • Podpowiedzi do słowa kluczowego „import”

    Po wpisaniu kodu „import + <spacja>” w programie Animate wyświetlana jest lista wszystkich pakietów wbudowanych i niestandardowych.

  • Podpowiedzi do kodu bibliotek SWC

    Gdy biblioteka SWC zostanie dodana do ścieżki bibliotek zewnętrznych, w programie Animate możliwe będzie wyświetlanie podpowiedzi do kodu wszystkich klas zawartych w pliku SWC.

Ta zawartość jest licencjonowana na warunkach licencji Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Posty z serwisów Twitter™ i Facebook nie są objęte licencją Creative Commons.

Informacje prawne   |   Zasady prywatności online