Używanie dźwięku w programie Adobe Animate

  1. Podręcznik użytkownika programu Adobe Animate
  2. Wprowadzenie do programu Animate
    1. Nowości w programie Animate
    2. Słownik wizualny
    3. Wymagania systemowe programu Animate
    4. Skróty klawiaturowe programu Animate
    5. Praca z wieloma typami plików w programie Animate
  3. Animacja
    1. Podstawowe informacje o animacjach w programie Animate
    2. Korzystanie z klatek i klatek kluczowych w programie Animate
    3. Animacja klatka po klatce w programie Animate
    4. Praca z animacjami klasycznymi w programie Animate
    5. Narzędzie Pędzel
    6. Linie pomocnicze ruchu
    7. Animacje ruchu a język ActionScript 3.0
    8. Informacje o animacjach ruchu
    9. Animacje ruchu
    10. Tworzenie animacji ruchu
    11. Używanie klatek kluczowych właściwości
    12. Animowanie położenia za pomocą klatek pośrednich
    13. Edytowanie animacji ruchu za pomocą Edytora ruchu
    14. Edytowanie ścieżki ruchu animacji
    15. Operacje na animacjach ruchu
    16. Dodawanie własnych krzywych dynamiki
    17. Tworzenie i stosowanie ruchów predefiniowanych
    18. Konfigurowanie zakresów animacji
    19. Praca z animacjami ruchu zapisanymi jako pliki XML
    20. Porównanie animacji ruchu i animacji klasycznych
    21. Animowanie kształtów metodą klatek pośrednich
    22. Animacja oparta na narzędziu Kość w programie Animate
    23. Tworzenie konstrukcji postaci w programie Animate
    24. Używanie warstw maskujących w programie Adobe Animate
    25. Praca ze scenami w programie Animate
  4. Funkcje interaktywne
    1. Tworzenie przycisków w programie Animate
    2. Konwertowanie projektów programu Animate na dokumenty innych typów
    3. Tworzenie i publikowanie dokumentów HTML5 Canvas w programie Animate
    4. Programowanie elementów interaktywnych za pomocą wycinków kodu w programie Animate
    5. Tworzenie własnych składników HTML5
    6. Używanie składników w zawartości HTML5 Canvas
    7. Tworzenie własnych składników: przykłady
    8. Wycinki kodu dla składników dostosowanych
    9. Sprawdzone procedury — reklama oparta na programie Animate
    10. Tworzenie i publikowanie materiałów rzeczywistości wirtualnej
  5. Przestrzeń robocza i obieg pracy
    1. Tworzenie pędzli malarskich i zarządzanie nimi
    2. Używanie czcionek Google Fonts w dokumentach HTML5 Canvas
    3. Korzystanie z Bibliotek Creative Cloud w programie Adobe Animate
    4. Korzystanie ze stołu montażowego i panelu Narzędzia w programie Animate
    5. Obieg pracy i przestrzeń robocza w programie Animate
    6. Używanie czcionek internetowych w dokumentach HTML5 Canvas
    7. Osie czasu a język ActionScript
    8. Praca z wieloma osiami czasu
    9. Ustawianie preferencji
    10. Korzystanie z paneli narzędziowych programu Animate
    11. Tworzenie warstw na osi czasu w programie Animate
    12. Eksportowanie animacji do aplikacji mobilnych i platform gier
    13. Przesuwanie i kopiowanie obiektów
    14. Szablony
    15. Znajdowanie i zamienianie w programie Animate
    16. Cofanie, ponawianie i panel Historia
    17. Skróty klawiaturowe
    18. Korzystanie z osi czasu w programie Animate
    19. Tworzenie rozszerzeń HTML
    20. Opcje optymalizacji obrazów i animowanych plików GIF
    21. Eksportowanie ustawień obrazów oraz plików GIF
    22. Panel Zasoby w programie Animate
  6. Multimedia i wideo
    1. Przekształcanie i łączenie obiektów graficznych w programie Animate
    2. Tworzenie i obsługa wystąpień symboli w programie Animate
    3. Obrys obrazu
    4. Używanie dźwięku w programie Adobe Animate
    5. Eksportowanie plików SVG
    6. Tworzenie plików wideo do używania w programie Animate
    7. Dodawanie wideo w programie Animate
    8. Praca z punktami sygnalizacji wideo
    9. Rysowanie i tworzenie obiektów w programie Animate
    10. Przekształcanie linii i kształtów
    11. Obrysy, wypełnienia, i gradienty w programie Animate CC
    12. Korzystanie z programów Adobe Premiere Pro i After Effects
    13. Panel Kolory w programie Animate CC
    14. Otwieranie plików programu Flash CS6 w programie Animate
    15. Praca z tekstem klasycznym w programie Animate
    16. Umieszczanie kompozycji w programie Animate
    17. Zaimportowane bitmapy w programie Animate
    18. Grafika 3D
    19. Praca z symbolami w programie Animate
    20. Rysowanie linii i kształtów przy użyciu programu Animate
    21. Praca z bibliotekami w programie Animate
    22. Eksportowanie dźwięków
    23. Zaznaczanie obiektów w programie Animate CC
    24. Praca z plikami AI programu Illustrator w programie Animate
    25. Stosowanie wzorków przy użyciu narzędzia Rozpylacz
    26. Stosowanie trybów mieszania
    27. Układanie obiektów
    28. Automatyzacja zadań za pomocą menu Polecenia
    29. Teksty wielojęzyczne
    30. Korzystanie z kamery w programie Animate
    31. Korzystanie z programów Animate i Adobe Scout
    32. Praca z plikami programu Fireworks
    33. Filtry graficzne
    34. Dźwięk a język ActionScript
    35. Preferencje rysowania
    36. Rysowanie za pomocą narzędzia Pióro
  7. Platformy
    1. Konwertowanie projektów programu Animate na dokumenty innych typów
    2. Obsługa platform niestandardowych
    3. Tworzenie i publikowanie dokumentów HTML5 Canvas w programie Animate
    4. Tworzenie i publikowanie dokumentów WebGL
    5. Pakowanie aplikacji na potrzeby środowiska AIR for iOS
    6. Publikowanie aplikacji dla środowiska AIR for Android
    7. Publikowanie dla środowiska AIR na komputery
    8. Ustawienia publikowania kodu ActionScript
    9. Sprawdzone procedury — porządkowanie kodu ActionScript w aplikacji
    10. Korzystanie z kodu ActionScript w programie Animate
    11. Sprawdzone procedury — wskazówki dotyczące ułatwień dostępu
    12. Ułatwienia dostępu w przestrzeni roboczej programu Animate
    13. Pisanie skryptów i zarządzanie nimi
    14. Włączanie obsługi platform niestandardowych
    15. Omówienie obsługi platform niestandardowych
    16. Tworzenie zawartości z ułatwieniami dostępu
    17. Praca z wtyczkami obsługi platform niestandardowych
    18. Debugowanie kodu ActionScript 3.0
    19. Włączanie obsługi platform niestandardowych
  8. Eksportowanie i publikowanie
    1. Eksportowanie plików z programu Animate CC
    2. Publikowanie plików OAM
    3. Eksportowanie plików SVG
    4. Eksportowanie grafiki i wideo w programie Animate
    5. Publikowanie dokumentów ActionScript 3.0
    6. Eksportowanie animacji do aplikacji mobilnych i platform gier
    7. Eksportowanie dźwięków
    8. Eksportowanie plików wideo QuickTime
    9. Sterowanie zewnętrznym odtwarzaniem wideo przy użyciu kodu ActionScript
    10. Sprawdzone procedury — wskazówki dotyczące tworzenia zawartości dla urządzeń przenośnych
    11. Sprawdzone procedury — konwencje dotyczące wideo
    12. Sprawdzone procedury — wskazówki dotyczące tworzenia aplikacji SWF
    13. Sprawdzone procedury — określanie struktury pliku FLA
    14. Sprawdzone procedury optymalizowania plików FLA dla programu Animate
    15. Ustawienia publikowania kodu ActionScript
    16. Określanie ustawień publikowania w programie Animate
    17. Eksportowanie plików projektora
    18. Eksportowanie obrazów i animowanych plików GIF
    19. Szablony publikowania w formacie HTML
    20. Korzystanie z programów Adobe Premiere Pro i After Effects
    21. Szybkie udostępnianie i publikowanie animacji

Przegląd

Program Adobe Animate pozwala używać dźwięków na różne sposoby. Istnieje możliwość tworzenia dźwięków odtwarzanych bez przerwy, niezależnie od Osi czasu, lub posłużenia się Osią dla zsynchronizowania animacji ze ścieżką dźwiękową Można też przypisywać dźwięki do przycisków dla uzyskania większej interaktywności, jak również powodować zanik lub narastanie dźwięku dla nadania ścieżce dźwiękowej większej płynności.

W programie Animate występują dwa rodzaje dźwięków: dźwięki strumieniowe i dźwięki zdarzeń. Dźwięk zdarzenia musi zostać w pełni pobrany zanim rozpocznie się jego odtwarzanie, które nie wygasa samoczynnie, lecz trwa dopóki nie zostanie w sposób celowy zatrzymane. Dźwięki strumieniowe odtwarzane są zaraz po pobraniu kilku pierwszych klatek; są one zsynchronizowane z Osią czasu w celu odtwarzania na stronach internetowych.

Podczas pracy nad zawartością programu Animate dla urządzeń przenośnych (na przykład telefonów komórkowych) program umożliwia zamieszczanie dźwięków urządzenia w opublikowanym pliku SWF. Dźwięki urządzenia zakodowane są w formacie audio, który jest przez nie obsługiwany, np. MIDI, MFi, lub SMAF.

Aby dołączyć dźwięk do wielu dokumentów można skorzystać z bibliotek wspólnych. Zdarzenie języka ActionScript® 2.0 onSoundComplete i zdarzenie języka ActionScript® 3.0 soundComplete pozwalają wywołać zdarzenie po odtworzeniu dźwięku.

Dźwięki można pobierać, a ich odtwarzanie kontrolować przy użyciu wstępnie napisanych zachowań lub składników nośników. Te ostatnie pozwalają również na wyłączanie, zatrzymywanie i cofanie ścieżki dźwiękowej. Kod ActionScript 2.0 lub 3.0 pozwala także na dynamiczne pobieranie dźwięków.

Więcej informacji można uzyskać pod hasłami attachSound (metoda Sound.attachSound) oraz loadSound (metoda Sound.loadSound) na stronie Dokumentacja języka ActionScript 2.0 lub Klasa Sound na stronie Dokumentacja języka i składników ActionScript 3.0.

Uwaga:

Program Animate nie obsługuje języków ActionScript 2.0 i ActionScript 1.0.

Importowanie dźwięków

Pliki dźwiękowe są umieszczane w programie Animate przez importowanie ich do biblioteki lub bezpośrednie importowanie na stół montażowy.

Polecenie Plik > Importuj > Importuj do biblioteki powoduje umieszczenie pliku dźwiękowego wyłącznie w bibliotece, a nie na osi czasu.

Po zaimportowaniu pliku dźwiękowego za pomocą polecenia Plik > Importuj > Importuj na stół montażowy lub przeciągnięciu pliku audio bezpośrednio na oś czasu plik zostanie umieszczony w aktywnej klatce na aktywnej warstwie. Po przeciągnięciu wielu plików dźwiękowych zaimportowany zostanie tylko jeden plik, ponieważ jedna klatka może zawierać tylko jeden plik dźwiękowy. 

Aby zaimportować plik dźwiękowy, wykonaj jedną z następujących czynności:

  • Aby zaimportować plik dźwiękowy do biblioteki, wybierz polecenie Plik > Importuj > Importuj do biblioteki, a następnie wybierz plik, który chcesz zaimportować.
  • Aby zaimportować plik dźwiękowy na stół montażowy, wybierz polecenie Plik > Importuj > Importuj na stół montażowy, a następnie wybierz plik, który chcesz zaimportować. 
  • Przeciągnij plik dźwiękowy bezpośrednio nad stół montażowy i upuść go.

Uwaga:

Można również przeciągnąć dźwięk z biblioteki wspólnej do biblioteki bieżącego dokumentu.

Program Animate przechowuje dźwięki w bibliotece wraz z bitmapami i symbolami. Wystarczy jedna kopia pliku dźwiękowego, aby użyć go w dokumencie na wiele sposobów.

Umieszczanie dźwięków w bibliotekach udostępnionych pozwala na stosowanie ich w różnych dokumentach programu Animate.

Dźwięki mogą zajmować dużo miejsca na dysku i wymagać znacznych ilości pamięci RAM. Należy jednak przy tym pamiętać, że dane dźwiękowe typu mp3 mają postać skompresowaną i nie są tak wymagające jak format WAV czy AIFF. Przy używaniu plików WAV lub AIFF najlepiej jest korzystać z dźwięków mono o częstotliwości 16–22 kHz (dźwięk stereo oznacza dwa razy więcej danych niż mono), jednak program Animate może importować dźwięki 8- lub 16-bitowe o częstotliwości próbkowania 11, 22 lub 44 kHz. Dźwięki nagrane w formatach niebędących wielokrotnością 11 kHz (na przykład 8, 32 lub 96 kHz) są podczas importowania do programu Animate ponownie próbkowane. Program Animate pozwala konwertować na niższe stopnie próbkowania na potrzeby eksportowania.

Jeśli do dźwięków w programie Animate będą dodawane efekty, najlepiej jest importować dźwięki 16-bitowe. Przy ograniczonej ilości pamięci RAM klipy dźwiękowe powinny być krótkie lub ograniczone do dźwięków 8-bitowych (zamiast 16-bitowych).

Uwaga:

W celu importowania lub odtwarzania dźwięków w programie Animate nie jest konieczne wstępne zainstalowanie programów QuickTime ani iTunes.

Obsługiwane formaty plików dźwiękowych

Do programu Animate można importować pliki dźwiękowe w następujących formatach:

  • Dźwięk Adobe (ASND). Jest to natywny format dźwięku programu Adobe® Soundbooth™.

  • Wave (WAV).

  • AIFF (AIF, AIFC)

  • MP3

    Można importować dźwięki w następujących formatach plików:

  • Sound Designer® II (SD2)

  • Sun AU (AU, SND)

  • FLAC (FLAC)

  • Ogg Vorbis (OGG, OGA)

Uwaga:
  • Format ASND jest nieniszczącym formatem plików audio, rodzimym dla programu Adobe Soundbooth. Pliki ASND mogą zawierać dane audio z efektami, które można modyfikować, sesje wielościeżkowe Soundbooth, a także dane migawkowe, które umożliwiają przywrócenie poprzedniego stanu pliku ASND.
  • Dokumenty WebGL i HTML5 Canvas obsługują tylko formaty MP3 i WAV.

Dodawanie dźwięków w programie Animate

Dodawanie dźwięku bezpośrednio z komputera do osi czasu

Plik dźwiękowy można zaimportować na oś czasu bezpośrednio z komputera za pomocą jednej z następujących metod:

  • Wybierz polecenie Plik > Importuj > Importuj na stół montażowy, a następnie wybierz plik, który chcesz zaimportować.
  • Przeciągnij plik dźwiękowy i upuść go na stół montażowy lub oś czasu. 

Można importować jeden plik dźwiękowy naraz. Przeciągnięcie i upuszczenie wielu plików dźwiękowych spowoduje zaimportowanie tylko jednego z nich.

Dodawanie dźwięku z biblioteki do osi czasu

Dźwięk można dodać do dokumentu za pośrednictwem biblioteki. Można też pobrać go do pliku SWF podczas działania programu za pomocą metody loadSound obiektu Sound. Więcej informacji można znaleźć w opisie klasy Sound w dokumentacji języka ActionScript 3.0.

  1. Jeśli pożądanego dźwięku jeszcze nie ma w bibliotece, zaimportuj go tam.
  2. Wybierz polecenie Wstaw > Oś czasu > Warstwa.

  3. Po zaznaczeniu nowej warstwy dźwięku, przeciągnij dźwięk z panelu biblioteki na obszar Stołu montażowego. Dźwięk zostanie dodany do bieżącej warstwy.

    Istnieje możliwość umieszczenia wielu dźwięków na jednej warstwie, lub na warstwach zawierających inne obiekty. Niemniej jednak zaleca się przydzielanie każdemu dźwiękowi osobnej warstwy. Każda warstwa zachowuje się jak odrębny kanał dźwiękowy. Podczas odtwarzania pliku SWF następuje połączenie dźwięków ze wszystkich warstw.

  4. Na Osi czasu zaznacz pierwszą klatkę zawierającą plik dźwiękowy.
  5. Wybierz polecenie Okno > Właściwości, a następnie kliknij strzałkę w prawym górnym rogu, aby rozwinąć inspektora Właściwości.

  6. W oknie Inspektora właściwości wybierz plik dźwiękowy z menu podręcznego Dźwięk.
  7. Wybierz jedną z opcji z wysuwanego menu Efekty:

    Brak

    Do pliku dźwiękowego nie są stosowane żadne efekty. Opcję tę należy zaznaczyć dla usunięcia uprzednio dodanych efektów.

    Kanał lewy/Kanał prawy

    Dźwięk jest odtwarzany tylko w jednym kanale — lewym lub prawym.

    Zanikanie od lewej do prawej/Zanikanie od prawej do lewej

    Następuje przesunięcie dźwięku z jednego kanału do drugiego.

    Narastanie

    W czasie trwania dźwięku następuje jego stopniowe nasilenie.

    Zanikanie

    W czasie trwania dźwięku następuje jego stopniowe ściszanie.

    Własne

    Pozwala na utworzenie punktów wejścia i wyjścia dźwięku przy użyciu opcji Edytuj formę.

    Uwaga:

    Efekty nie są obsługiwane w dokumentach WebGL i HTML5 Canvas.

  8. Wybierz opcję synchronizacji z menu wysuwanego Synchronizacja:

    Zdarzenie

    Zestraja dźwięk z wystąpieniem zdarzenia. Dźwięk zdarzenia jest odtwarzany, gdy uruchamiająca go klatka kluczowa pojawia się po raz pierwszy i jest odtwarzana w całości — niezależnie od głowicy odtwarzania na osi czasu, nawet w przypadku zatrzymania odtwarzania pliku SWF. W czasie odtwarzania opublikowanego pliku SWF dźwięki zdarzeń są mieszane.

    Jeśli podczas odtwarzania dźwięku zdarzenia zostanie utworzone wystąpienie tego samego dźwięku (na przykład użytkownik ponownie kliknie przycisk lub głowica odtwarzania minie klatkę kluczową uruchamiającą dany dźwięk), będzie kontynuowane odtwarzanie pierwszego wystąpienia dźwięku i jednocześnie rozpocznie się odtwarzanie kolejnego wystąpienia tego dźwięku. Należy o tym pamiętać w przypadku używania długich dźwięków, gdyż mogą się one nakładać, generując niezamierzone efekty audio.

    Początek

    Zastosowanie tej opcji daje podobne wyniki jak opcja Zdarzenie, ale jeśli dźwięk jest już odtwarzany, nie można rozpocząć odtwarzania nowego wystąpienia tego dźwięku.

    Zatrzymaj

    Powoduje wyciszenie wskazanego dźwięku.

    Strumień

    Synchronizuje dźwięk do odtwarzania w witrynie internetowej. Program Animate wymusza zestrojenie animacji z dźwiękiem strumieniowym. Jeśli klatki animacji nie mogą być wystarczająco szybko rysowane, program Animate je pomija. W przeciwieństwie do dźwięków zdarzenia, dźwięki strumieniowe ustają wraz z zatrzymaniem odtwarzania pliku SWF. Ponadto odtwarzanie dźwięku strumieniowego nie może przekraczać zakresu klatek, na które przypada. W czasie odtwarzania opublikowanego pliku SWF dźwięki strumieniowe zostają wymieszane.

    Przykładem dźwięku strumieniowego jest głos postaci występującej w animacji odtwarzanej z klatek wielokrotnych.

    Program Animate zapamięta opcje synchronizacji dźwięku w inspektorze Właściwości. Jeśli w obszarze Dźwięk w inspektorze Właściwości zostanie wybrany dźwięk, to przy próbie ustawienia innego dźwięku w nowej klatce kluczowej z poziomu inspektowa Właściwości program Animate pamięta opcje synchronizacji — Strumień lub Zdarzenie — ustawione dla poprzedniego dźwięku.

    Uwaga:

    W przypadku korzystania z dźwięku mp3 jako dźwięku strumieniowego, należy go ponownie skompresować w celu wyeksportowania. Plik mp3 można wyeksportować zachowując kompresję zastosowaną przy jego importowaniu.

    Ustawienie strumienia nie jest obsługiwane w dokumentach WebGL.

  9. Wprowadź wartość dla opcji Powtórz aby określić ile razy dany dźwięk ma wykonać pętlę, lub też zaznacz opcję Pętla, w celu jego ciągłego powtarzania.

    W celu ciągłego odtwarzania dźwięku należy wprowadzić odpowiednio dużą wartość. Na przykład aby dźwięk wykonywał pętlę co 15 sekund przez 15 minut, należy wprowadzić wartość 60. Nie zaleca się wprowadzania pętli dla dźwięków strumieniowych. Jeśli bowiem dźwiękowi strumieniowemu narzuci się wykonywanie pętli, do pliku będą dodawane kolejne klatki, co zwiększy jego rozmiar, uzależniając go od ilości pętli.

  10. W celu testowania dźwięku należy przeciągnąć wskaźnik odtwarzania przez klatki zawierające dźwięk lub użyć poleceń Kontrolera albo menu Sterowanie.

Usuwanie dźwięku z osi czasu

  1. Na warstwie osi czasu zawierającej dźwięk zaznacz klatkę, która także zawiera dźwięk.
  2. W inspektorze Właściwości przejdź do sekcji Dźwięk i z menu Nazwa wybierz opcję Brak.

    Program Animate usunie dźwięk z warstwy osi czasu.

Przypisywanie dźwięku do przycisku

Dźwięki można kojarzyć z działaniem symboli przycisków. Ponieważ dźwięk zostaje przypisany do symbolu, jest on obecny we wszystkich jego obiektach.

  1. Zaznacz przycisk na panelu Biblioteka.
  2. Z menu Panel w górnym prawym rogu wybierz polecenie Edycja.
  3. Na Osi czasu przycisku dodaj warstwę dla dźwięku (za pomocą polecenia Wstaw > Oś czasu > Warstwa).

  4. Na warstwie dźwięku utwórz zwykłą lub pustą klatkę kluczową odpowiadającą stanowi przycisku, do którego ma zostać przypisany dźwięk.

    Kliknij polecenie Wstaw > Oś czasu > Klatka kluczowa lub Wstaw > Oś czasu > Pusta klatka kluczowa.

    Na przykład, aby przypisać do przycisku dźwięk odtwarzany po jego kliknięciu, utwórz klatkę kluczową na klatce oznaczonej etykietą Wciśnięty.

  5. Kliknij utworzoną klatkę kluczową.
  6. Wybierz polecenie Okno > Właściwości.

  7. W oknie Inspektora właściwości wybierz plik dźwiękowy z menu wysuwanego Dźwięk.
  8. Z menu wysuwanego Synchronizacja wybierz opcję Zdarzenie.

    Aby z każdą kluczową klatką przycisku skojarzyć inny dźwięk, utwórz pustą klatkę kluczową oraz wprowadź inny plik dźwiękowy dla każdej klatki kluczowej. Można również posłużyć się tym samym plikiem dźwiękowym, ale zastosować dla każdej klatki kluczowej inny efekt dźwiękowy.

Synchronizacja dźwięku z animacją

Dla zestrojenia dźwięku z animacją należy rozpoczynać go i zatrzymywać na klatkach kluczowych.

  1. Dodaj dźwięk do osi czasu w jej własnej warstwie. (Instrukcje podano powyżej).
  2. Aby zsynchronizować dźwięk ze zdarzeniem na scenie, utwórz klatkę kluczową rozpoczynającą dźwięk tak, aby odpowiadała klatce kluczowej zdarzenia na scenie, dla którego ma zostać wywołany dźwięk. Można wybrać dowolną z opisanych powyżej opcji synchronizacji (zobacz „Dodawanie dźwięku do osi czasu”).
  3. Utwórz klatkę kluczową na Osi czasu warstwy dźwięku na klatce, która ma kończyć dźwięk. Na Osi czasu pojawi się symbol pliku dźwiękowego.
  4. Wybierz polecenie Okno > Właściwości, a następnie kliknij strzałkę w prawym górnym rogu, aby rozwinąć inspektora Właściwości.

  5. W oknie Inspektora właściwości wybierz ten sam dźwięk z menu wysuwanego Dźwięk.
  6. W Inspektorze właściwości wybierz opcję Zatrzymaj z menu podręcznego Synchronizacja.

    Podczas odtwarzania piku SWF dźwięk ustanie wraz z pojawieniem się końcowej klatki kluczowej.

  7. Aby odtworzyć dźwięk, przeciągnij głowicę odtwarzania na osi czasu.

Edytowanie dźwięku

Edytowanie dźwięku w programie Animate 

W programie Animate można wyznaczyć punkt początkowy danego dźwięku oraz regulować jego natężenie w trakcie odtwarzania. Punkt, w którym odtwarzanie rozpoczyna się lub kończy można zmieniać. Jest to przydatne przy zmniejszaniu plików dźwiękowych, usuwa się bowiem niepotrzebne fragmenty.

  1. Dodaj dźwięk do klatki, lub zaznacz klatkę, która już dźwięk zawiera.
  2. Wybierz polecenie Okno > Właściwości.

  3. Kliknij przycisk Edycja po prawej stronie okna Inspektora właściwości.
  4. Wykonaj dowolną z następujących czynności:
    • W celu zmiany punktu początkowego i końcowego dźwięku przeciągnij przyciski sterujące wejścia i wyjścia w obszarze edycji formy.

    • Aby dokonać zmiany formy dźwięku, przeciągnij uchwyty formy, co pociągnie za sobą zmianę poziomów w różnych punktach dźwięku. Linie obwiedni ujawniają natężenie dźwięku w trakcie odtwarzania. Aby utworzyć dodatkowe uchwyty dla formy (w sumie może ich być osiem), kliknij jej linie. Aby usunąć uchwyt formy, przeciągnij go poza okno.

    • Aby wyświetlić mniej lub więcej dźwięku w oknie, kliknij opcję Powiększ lub Zmniejsz.

    • Aby dokonywać zmian jednostek czasu z sekund na klatki, posłuż się przyciskami Sekundy i Klatki.

  5. Aby odsłuchać dźwięk powstały w wyniku edycji kliknij przycisk Odtwórz.

Edytowanie dźwięku w programie Soundbooth

Jeśli jest zainstalowany program Adobe Soundbooth, można w nim edytować dźwięki zaimportowane do pliku programu Animate. Po wprowadzeniu zmian w programie Soundbooth, zapisaniu pliku i zastąpieniu oryginału zmiany są automatycznie uwzględniane w pliku programu Animate.

Jeśli po zakończeniu edycji zmieni się nazwa pliku lub format dźwięku, konieczne będzie ponowne zaimportowanie pliku do programu Animate.

Uwaga:

Narzędzie Soundbooth jest dostępne tylko w komputerach z systemem Windows oraz na komputerach Mac z procesorami Intel®.

Aby edytować zaimportowany dźwięk w aplikacji Soundbooth:

  1. Kliknij prawym przyciskiem myszy (Windows) lub kliknij przytrzymując klawisz Ctrl (Macintosh) dźwięk w panelu Biblioteka.
  2. W menu podręcznym wybierz opcję Edycja w Soundbooth. Plik zostanie otwarty w aplikacji Soundbooth.
  3. Dokonaj edycji pliku w aplikacji Soundbooth.
  4. Po wprowadzeniu zmian zapisz plik. Aby zapisać zmiany, nie modyfikując przy tym wersji oryginalnej, wybierz format ASND. Jeśli plik zostanie zapisany w formacie innym niż oryginalny, należy ponownie zaimportować plik dźwiękowy do programu Animate.

  5. Powróć do programu Animate, aby sprawdzić wersję pliku dźwiękowego po edycji w panelu Biblioteka.

Uwaga:

Za pomocą polecenia Edytuj w narzędziu Soundbooth nie można edytować dźwięków z biblioteki dźwięków (Okno > Wspólne biblioteki > Dźwięki). Aby edytować te dźwięki w narzędziu Soundbooth, należy otworzyć narzędzie Soundbooth i wybrać dźwięk w panelu Centrum zasobów. Następnie należy edytować dźwięk i zaimportować go do programu Animate.

Dzielenie i zapętlanie dźwięku na osi czasu

Dzielenie dźwięku na osi czasu

Menu kontekstowe podziału dźwięku umożliwia rozdzielenie dźwięku przesyłanego strumieniowo znajdującego się na osi czasu. Funkcja Podziel audio umożliwia wstrzymanie dźwięku, gdy jest to konieczne, i wznowienie jego odtwarzania od tego samego momentu w późniejszej klatce na osi czasu. Program pozwala podzielić dźwięk przesyłany strumieniowo na wiele części, gdyż zachowuje jego efekty.

Aby podzielić klip dźwiękowy na osi czasu i zachować jego efekty:

  1. Wybierz polecenie Plik > Importuj > Importuj do biblioteki

  2. Wybierz klip audio i importuj go do biblioteki.

  3. Utwórz nową warstwę na osi czasu i dodaj do niej klip audio. 

  4. W obszarze Właściwości > Dźwięk wybierz opcję Efekt.

  5. Ustaw typ synchronizacji na Strumień.

  6. Kliknij prawym przyciskiem myszy klatkę, w której chcesz podzielić dźwięk, i wybierz polecenie Podziel audio

    Uwaga:

    Efekty dźwiękowe są zachowywane nawet w przypadku przeniesienia dźwięku lub zmiany jego zakresu czasu albo zakresu klatek.

Zapętlanie dźwięku na osi czasu

Funkcja zapętlenia dźwięku pozwala na powtarzanie małego fragmentu przez szereg klatek na osi czasu. Gdy na osi czasu jest włączona opcja Pętla, można zapętlać dźwięk strumieniowy w zakresie klatek obok innych animacji.

Aby utworzyć pętlę, wystarczy włączyć tę opcję na osi czasu:

Przycisk zapętlania dźwięku na osi czasu

Korzystanie z dźwięków w programie Flash Lite

Program Adobe® Flash® Lite obsługuje dwa typy dźwięku: zwykłe dźwięki programu Animate, na przykład występujące w aplikacjach komputerowych programu Animate, oraz dźwięki urządzeń. Program Flash Lite w wersji 1.0 obsługuje jedynie dźwięki urządzeń; podczas gdy wersje 1.1 oraz 2.x obsługują zarówno dźwięki urządzeń jak i zwykłe.

Dźwięki urządzeń są zapisywane w opublikowanym pliku SWF w swoim formacie pierwotnym (takim jak MIDI lub MFi). W czasie odtwarzania program przesyła dane dźwięku do urządzenia, które odczytuje je i odtwarza dźwięk. Ponieważ nie ma możliwości importowania większości formatów dźwiękowych urządzeń do programu Animate, importuje się dźwięk zastępczy w formacie obsługiwanym (takim jak MP3 lub AIFF), który jest następnie zastępowany zewnętrznym dźwiękiem urządzenia wskazanym przez użytkownika.

Dźwięki urządzeń mogą służyć jedynie jako dźwięki zdarzeń, gdyż w przeciwieństwie do zwykłych dźwięków nie można ich zsynchronizować z osią czasu.

Programy Flash Lite 1.0 i Flash Lite 1.1 nie obsługują następujących funkcji programu Flash® Player dla komputerów:

  • Obiekt dźwiękowy ActionScript

  • Wczytywanie zewnętrznych plików mp3

  • Opcja kompresji głosu

Więcej informacji można znaleźć w temacie „Working with Sound, Video, and Images” w sekcji Developing Flash Lite 2.x Applications lub „Working with Sound” w sekcji Developing Flash Lite 1.x Applications.

Logo Adobe

Zaloguj się na swoje konto