마스크 만들기

다음 방법 중 하나를 사용하여 컴포지션에 있는 레이어마다 하나 이상의 마스크를 만들 수 있습니다.

레이어에 마스크를 만들면 마스크를 만드는 순서대로 [타임라인] 패널 개요에 마스크 이름이 나타납니다. 마스크를 구성하고 추적하려면 마스크 이름을 바꿉니다.

참고:

마스크 이름을 바꾸려면 해당 마스크를 선택하고 Enter 키(Windows) 또는 Return 키(Mac OS)를 누르거나, 마스크 이름을 마우스 오른쪽 버튼으로 클릭(Windows)하거나 Control 키를 누른 상태에서 클릭(Mac OS)한 다음 [이름 바꾸기]를 선택합니다.

[레이어] 패널에서 한 레이어의 마스크를 추가로 만들 때는 [레이어] 패널의 [대상] 메뉴가 [없음]으로 설정되었는지 확인하십시오. 그렇지 않으면 새 마스크가 만들어지는 것이 아니라 대상으로 지정된 마스크가 바뀌게 됩니다. 변경하지 못하도록 마스크를 잠글 수도 있습니다.

레이어 패널에서 대상 마스크를 지정하기 위한 메뉴 선택
레이어 패널에서 대상 마스크를 지정하기 위한 메뉴 선택

A. 보기 메뉴 B. 대상 메뉴 

마스크를 만들거나 편집할 때 [정보] 패널에서 마스크 이름 및 마스크에 있는 정점 개수와 같은 정보를 확인할 수 있습니다.

참고:

마스크하는 기본 레이어와 관계없이 이동할 수 있는 마스크를 만들려면 다음을 수행합니다.

  1. 별도의 흰색 단색 레이어에 마스크를 만들고 트랙 매트로 기본 레이어에 대해 단색 레이어를 사용합니다.
  2. 부모/자식 관리를 사용하여 단색 레이어를 기본 레이어의 자식으로 설정하면 마치 직접 적용된 것처럼 마스크가 기본 레이어와 함께 이동합니다. 단색 레이어는 자식 레이어이므로 부모와 관계없이 애니메이션을 적용할 수도 있습니다.
  3. 동작 추적 기능을 사용하여 단색 레이어와 마스크가 기본 레이어의 움직이는 개체를 따르도록 할 수 있습니다. 자세한 내용은 레이어를 트랙 매트로 변환부모 및 자식 레이어를 참조하십시오.

숫자를 사용하여 사각형 또는 원형 마스크 만들기

  1. [컴포지션] 패널에서 레이어를 선택하거나 [레이어] 패널에서 레이어를 표시합니다.
  2. [레이어] > [마스크] > [새 마스크]를 선택합니다. [컴포지션] 또는 [레이어] 패널에 새 마스크가 나타나고 프레임의 외부 가장자리에 해당 핸들이 나타납니다.
  3. [레이어] > [마스크] > [마스크 모양]을 선택합니다.
  4. [다음으로 다시 설정]을 선택하고, [모양] 메뉴에서 [사각형] 또는 [타원]을 선택하고, 마스크에 대한 테두리 상자의 크기 및 위치를 지정합니다.

자동 추적을 사용하여 채널에서 마스크 만들기

  1. 자동 추적 명령을 사용하여 레이어의 알파, 빨강, 녹색, 파랑 또는 광도 채널을 하나 이상의 마스크로 변환할 수 있습니다.
  2. 자동 추적은 레이어에서 지정된 채널 값을 윤곽선으로 만드는 데 필요한 수만큼 베지어 마스크를 만듭니다.
  3. 또한 자동 추적은 선택한 설정에 부합하면서 가장 적은 개수의 정점으로 마스크를 만듭니다.
  4. 다른 모든 마스크와 마찬가지로 자동 추적으로 만든 마스크도 수정할 수 있으며, 표현식을 사용하여 해당 패스를 모양 레이어에 있는 모양 패스와 같은 다른 패스 유형에 연결할 수 있습니다.

자동 추적을 적용하면 영향을 받는 레이어가 [최고 품질]로 자동 설정되어 정확한 결과를 얻게 됩니다.

참고:

자동 추적으로 만들어지는 마스크의 수를 줄이려면 자동 추적을 적용하기 전에 키잉 효과를 레이어에 적용하여 대상을 격리합니다.

  1. [타임라인] 패널에서 다음 중 하나를 수행합니다.
    • 단일 프레임에 마스크 키프레임을 만들려면 현재 시간 표시기를 원하는 프레임으로 드래그합니다.
    • 여러 프레임에 마스크 키프레임을 만들려면 해당 범위를 포함하는 작업 영역을 설정합니다.
  2. 하나 이상의 레이어를 선택합니다.
  3. [레이어] > [자동 추적]을 선택합니다.
  4. 다음 중 하나를 선택합니다.

    현재 프레임

    현재 프레임에만 마스크 키프레임을 만듭니다.

    작업 영역

    작업 영역 내의 프레임에 대해 마스크 키프레임을 만듭니다.

  5. 다음 옵션을 설정합니다.

    반전

    가장자리를 검색하기 전에 입력 레이어를 반전합니다.

    흐림

    추적 결과를 생성하기 전에 원본 이미지를 흐리게 합니다. 이 옵션을 선택하면 자연스럽게 표현되고 추적 결과에서 톱날 모양의 가장자리가 매끄러워집니다. 이 옵션을 선택 해제하면 고대비 이미지에서 세부 정보가 면밀하게 추적됩니다. 흐림 작업에 사용할 영역의 반경(픽셀)을 지정합니다. 값이 클수록 더 흐려집니다.

    허용치

    추적된 패스가 채널 윤곽선에서 벗어날 수 있는 거리(픽셀)입니다.

    임계값

    픽셀이 가장자리의 일부로 간주되도록 하기 위해 해당 픽셀의 채널이 가져야 하는 값(백분율)을 지정합니다. 채널 값이 임계값을 초과하는 픽셀은 흰색에 매핑되고 불투명합니다. 채널 값이 임계값 미만인 픽셀은 검정에 매핑되고 투명합니다.

    최소 영역

    원본 이미지에서 추적하게 될 가장 작은 기능을 지정합니다. 예를 들어 4의 값을 지정하면 2픽셀(폭) x 2픽셀(높이)보다 작은 기능이 추적 결과에서 제거됩니다.

    모퉁이 원형률

    정점의 마스크 곡선 원형률을 지정합니다. 입력하는 값이 높을수록 곡선이 매끄러워집니다.

    새 레이어에 적용

    선택한 레이어와 같은 크기의 새 단색 레이어에 마스크를 적용합니다. 이 컨트롤은 [변형 축소]를 사용하는 레이어의 경우 자동으로 선택되며 해당 레이어가 포함된 컴포지션과 같은 크기로 새 레이어를 만듭니다.

    미리 보기

    [자동 추적] 명령의 여러 옵션에 대한 결과 및 마스크 결과를 미리 보려면 선택합니다.

모양 및 모양 레이어 만들기

[컴포지션] 패널에서 모양 툴이나 [펜] 툴로 그려서 모양 레이어를 만듭니다. 그런 다음 기존 모양에 모양 특성을 추가하거나 해당 모양 레이어 내에 새 모양을 만들 수 있습니다. 기본적으로 모양 레이어가 선택되어 있을 때 [컴포지션] 패널에서 그리면 해당 모양 레이어 내에서 선택한 모양이나 모양 그룹 위에 새 모양이 만들어집니다. 모양 레이어가 아닌 이미지 레이어가 선택되어 있을 때 [컴포지션] 패널에서 모양 툴이나 [펜] 툴을 사용하여 그리면 마스크가 만들어집니다.

참고:

새 모양 레이어를 만들려면 [컴포지션] 패널에서 그리기 전에 F2 키를 눌러 모든 레이어를 선택 해제합니다.

다음 방법 중 하나를 사용하여 모양과 모양 레이어를 만들 수 있습니다.

대부분의 경우 새 모양에는 모양을 그릴 때 [툴] 패널에서 구성한 [칠] 및 [선] 설정에 해당하는 칠과 선이 있습니다. 해당 모양을 그린 후 [툴] 패널에서 같은 컨트롤을 사용하여 선택한 모양의 이러한 특성을 변경할 수 있습니다. 텍스트로 만든 모양은 원본 텍스트의 칠 및 선과 일치하는 칠과 선을 사용하여 만들어집니다.

참고:

모양 레이어에 마스크를 그리려면 모양 툴이나 [펜] 툴을 활성화한 상태로 [툴] 패널에서 [툴로 마스크 만들기] 버튼 을 클릭합니다. 마스크를 만드는 방법에 대한 자세한 내용은 마스크 만들기를 참조하십시오.

벡터 아트 푸티지를 모양으로 변환 | CC, CS6

이전 버전의 After Effects에서는 Illustrator(.ai), EPS(.eps) 또는 PDF(.pdf) 파일을 가져올 수 있어도 수정할 수는 없었습니다. 이제 벡터 아트 푸티지 레이어로 모양 레이어를 만든 다음 이를 수정할 수 있습니다.

After Effects 에서 개체에 경사와 돌출을 만드는 기능을 사용하여 아트워크에 돌출을 적용할 수도 있습니다. 예를 들어 돌출된 로고를 만들 수 있습니다. 자세한 내용은 텍스트 및 모양 레이어 돌출을 참조하십시오.

벡터 아트 푸티지 레이어를 모양 레이어로 변환하려면

  • 레이어 > 벡터 레이어에서 모양 만들기 를 선택합니다. 일치하는 모양 레이어가 푸티지 레이어 위로 표시되고 푸티지 레이어가 희미해집니다.

    알려진 문제는 다음과 같습니다.

    • 현재 Illustrator 파일의 일부 기능이 유지되지 않습니다. 이러한 기능으로는 불투명도, 이미지 및 그라디언트가 있습니다.
    • 변환된 모양이 [푸티지 해석] 대화 상자에 지정된 PAR 재정의를 무시합니다.
    • 그라디언트 및 지원되지 않는 유형이 50%의 회색 모양으로 표시될 수 있습니다.
    • 패스가 수천 개 있는 파일을 피드백 없이 매우 느리게 가져올 수 있습니다.
    • 메뉴 명령이 한 번에 하나의 선택된 레이어에서 작동합니다.
    • Illustrator 파일을 컴포지션, 즉 여러 레이어로 가져오면 모든 레이어를 한 패스에서 변환할 수 없습니다. 하지만 파일을 푸티지로 가져오면 명령을 사용하여 단일 푸티지 레이어를 여러 모양으로 변환할 수 있습니다.

이 비디오에서는 video2brain의 Todd Kopriva가 After Effects CS6에서 신속하게 Illustrator의 벡터 그래픽을 모양 레이어로 변환하고 패스에 애니메이션을 적용하는 방법을 알아봅니다. 이 프로세스는 이전 버전의 After Effects보다 훨씬 더 간단합니다.

모양 툴로 드래그하여 모양 또는 마스크 만들기

모양 툴은 [사각형] , [둥근 사각형] , [타원] , [다각형] 및 [별] 툴입니다.

참고:

모양 툴을 활성화하고 순환하려면 Q 키를 누릅니다.

다각형은 [내부 반경] 또는 [내부 원형률] 속성이 없는 별이므로 다각형이나 별로 만들어진 모양의 이름은 다각형 별로 같습니다.

[컴포지션] 패널이나 [레이어] 패널에서 모양 툴로 드래그하여 선택한 레이어에 마스크를 만들 수 있습니다. [컴포지션] 패널에서 모양 툴로 드래그하여 선택한 모양 레이어에 모양을 만들 수 있습니다. 레이어를 선택하지 않은 상태로 [컴포지션] 패널에서 모양 툴로 드래그하면 새 모양 레이어에 모양이 만들어집니다.

참고:

모양 레이어에 마스크를 그리려면 모양 툴을 활성화한 상태로 [툴] 패널에서 [툴로 마스크 만들기] 버튼 을 클릭합니다.

[컴포지션] 패널에서 모양 툴로 드래그하여 모양을 만들면 파라메트릭 모양 패스가 만들어집니다. 대신에 베지어 모양 패스를 만들려면 클릭하여 드래그를 시작하기 전에 Alt 키(Windows) 또는 Option 키(Mac OS)를 누릅니다. 드래그 작업을 완료하기 전에 키를 놓을 수 있습니다. 모든 마스크 패스는 베지어 패스입니다. 자세한 내용은 모양 및 모양 레이어를 참조하십시오.

드래그는 [컴포지션] 패널이나 [레이어] 패널에서 클릭하여 그리기를 시작할 때 시작되고 마우스 버튼을 놓을 때 끝납니다. 단일 드래그 작업 중에 서로 다른 시간에 수정자 키를 누르면 다음과 같이 결과가 달라집니다.

  • 그리고 있는 모양이나 마스크의 위치를 변경하려면 드래그하는 동안 스페이스바나 마우스 가운데 버튼을 누르고 있습니다.

  • 그리는 동안 해당 중심을 기준으로 원, 타원, 정사각형, 둥근 정사각형, 사각형 또는 둥근 사각형의 비율을 조정하려면 드래그를 시작한 후 Ctrl 키(Windows) 또는 Command 키(Mac OS)를 누르고 있습니다. 마우스 버튼을 놓아서 그리기를 마칠 때까지는 키를 놓지 마십시오.

  • 그리기 작업을 취소하려면 Esc 키를 누릅니다.

참고:

각각의 모양 툴은 해당 툴로 최근에 수행한 그리기 작업의 설정을 유지합니다. 예를 들어 별을 그리고 점 개수를 10으로 수정하면 다음에 그리는 별에도 10개의 점이 있게 됩니다. 툴 설정을 다시 설정하고 기본 설정으로 모양을 만들려면 [툴] 패널에서 툴을 두 번 클릭합니다. 자세한 내용은 레이어 크기로 모양 또는 마스크 만들기를 참조하십시오.

사각형, 둥근 사각형, 정사각형 및 둥근 정사각형 그리기

  1. [사각형] 툴 이나 [둥근 사각형] 툴 을 선택하고 다음 중 하나를 수행합니다.
    • 사각형이나 둥근 사각형을 그리려면 대각선으로 드래그합니다.
    • 정사각형이나 둥근 정사각형을 그리려면 Shift 키를 누른 상태에서 대각선으로 드래그합니다.
  2. (선택 사항) 둥근 사각형이나 둥근 정사각형을 그리는 경우 마우스 버튼을 놓기 전에 다음을 수행합니다.
    • 모퉁이 원형률을 높이거나 낮추려면 위쪽 또는 아래쪽 화살표 키를 누르거나 마우스 휠을 앞 또는 뒤로 굴립니다.
    • 모퉁이 원형률을 최소값이나 최대값으로 설정하려면 왼쪽 또는 오른쪽 화살표 키를 누릅니다.
  3. 그리기를 마치려면 마우스 버튼을 놓습니다. 정사각형이나 둥근 정사각형을 그리는 경우에는 마우스 버튼을 놓은 후 Shift 키를 놓습니다.

참고:

정사각형은 컴포지션의 픽셀 종횡비에 따라 정사각형으로 만들어집니다. 컴포지션의 픽셀 종횡비가 1이 아닌 경우 정사각형은 [컴포지션] 패널 아래쪽에서 [픽셀 종횡비 교정 켜기/끄기] 버튼 을 선택해야만 [컴포지션] 패널에 정사각형으로 나타납니다.

타원 및 원 그리기

  1. [타원] 툴 을 선택하고 다음 중 하나를 수행합니다.
    • 타원을 그리려면 대각선으로 드래그합니다.
    • 원을 그리려면 Shift 키를 누른 상태에서 대각선으로 드래그합니다.
  2. 그리기를 마치려면 마우스 버튼을 놓습니다. 원을 그리는 경우에는 마우스 버튼을 놓은 후 Shift 키를 놓습니다.

참고:

원은 컴포지션의 픽셀 종횡비에 따라 원형으로 만들어집니다. 컴포지션의 픽셀 종횡비가 1이 아닌 경우 원은 [컴포지션] 패널 아래쪽에서 [픽셀 종횡비 교정 켜기/끄기] 버튼 을 선택해야만 [컴포지션] 패널에 원으로 나타납니다.

다각형 및 별 그리기

  1. [다각형] 툴 이나 [별] 툴 을 선택하고 다음 중 하나를 수행합니다.
    • 다각형이나 별을 그릴 때 드래그하여 비율을 조정하고 회전합니다.
    • 다각형이나 별을 그릴 때 Shift 키를 누른 상태에서 드래그하여 회전을 방지하면서 비율을 조정합니다.
  2. (선택 사항) 마우스 버튼을 놓기 전에 다음을 수행합니다.
    • 점을 추가하거나 제거하려면 위쪽 또는 아래쪽 화살표 키를 누르거나 마우스 휠을 앞 또는 뒤로 굴립니다.
    • 외부 원형률을 높이거나 낮추려면 왼쪽 또는 오른쪽 화살표 키를 누릅니다.
    • 마우스를 이동하여 외부 반경을 높일 때 별의 내부 반경을 일정하게 유지하려면 Ctrl 키(Windows) 또는 Command 키(Mac OS)를 누르고 있습니다.
    • 별의 내부 원형률을 높이거나 낮추려면 Page Up 키 또는 Page Down 키를 누릅니다.
  3. 그리기를 마치려면 마우스 버튼을 놓습니다. Shift 키를 누른 상태에서 드래그하여 회전을 방지하는 경우에는 마우스 버튼을 놓은 후에 Shift 키를 놓습니다.

펜 툴을 사용하여 베지어 모양 또는 마스크 만들기

[컴포지션] 패널이나 [레이어] 패널에서 [펜] 툴을 사용하여 선택한 레이어에 베지어 마스크를 만들 수 있습니다. [컴포지션] 패널에서 [펜] 툴을 사용하여 선택한 모양 레이어에 베지어 패스가 있는 모양을 만들 수 있습니다. 레이어를 선택하지 않은 상태로 [컴포지션] 패널에서 [펜] 툴로 그리면 새 모양 레이어에 모양이 만들어집니다.

로토베지어 패스 만들기는 수동 베지어 패스 만들기와 유사합니다. 주된 차이점은 정점의 방향선과 패스 선분의 곡률이 자동으로 계산된다는 것입니다.

펜 툴을 사용하여 수동 베지어 패스 만들기

  1. [펜] 툴을 선택하고 [툴] 패널에서 [로토베지어] 옵션을 선택 해제한 상태로 [컴포지션] 패널에서 첫 번째 정점을 배치할 곳을 클릭합니다.
  2. 다음 정점을 배치할 곳을 클릭합니다. 곡선 선분을 만들려면 방향선 핸들을 드래그하여 원하는 곡선을 만듭니다.

    참고:

    클릭하여 배치한 후 마우스 버튼을 놓기 전에 정점의 위치를 변경하려면 드래그하는 동안 스페이스바를 누르고 있습니다.

    마지막으로 추가한 정점은 내부가 칠해진 정사각형으로 표시되어 선택된 상태임을 나타냅니다. 이전에 추가한 정점은 정점을 더 추가함에 따라 내부가 칠해지지 않은 상태가 되고 선택 해제됩니다.

  3. 패스를 완성할 준비가 될 때까지 2단계를 반복합니다.
  4. 다음 중 하나를 수행하여 패스를 완성합니다.
    • 패스를 닫으려면 첫 번째 정점 위에 포인터를 놓고 포인터  옆에 닫힌 원 아이콘이 나타나면 정점을 클릭합니다.

    참고:

    마지막 정점을 두 번 클릭하거나 [레이어] > [마스크 및 모양 패스] > [닫힘]을 선택하여 패스를 닫을 수도 있습니다.

    • 패스를 열어 두려면 다른 툴을 활성화하거나 F2 키를 눌러 해당 패스를 선택 해제합니다.

펜 툴로 직선 수동 베지어 패스 선분 그리기

[펜] 툴로 그릴 수 있는 가장 단순한 패스는 직선으로, [펜] 툴로 클릭하여 두 개의 정점을 만들면 직선을 그릴 수 있습니다. 계속해서 클릭하면 모퉁이 점으로 연결된 직선 선분으로 구성된 패스가 만들어집니다.

펜 툴로 클릭하면 직선 선분이 만들어집니다
펜 툴로 클릭하면 직선 선분이 만들어집니다.

  1. [펜] 툴을 직선 선분이 시작될 곳에 놓고 클릭하여 정점을 배치합니다. 드래그하지 마십시오.
  2. 선분이 끝날 곳을 다시 클릭합니다. Shift 키를 누른 상태에서 클릭하면 모퉁이 점에서 선분 사이의 각도가 45°의 정배수로 제한됩니다.
  3. 계속해서 클릭하여 추가 직선 선분의 정점을 설정합니다.

펜 툴로 곡선 수동 베지어 패스 선분 그리기

방향선을 드래그하여 곡선 패스 선분을 만듭니다. 방향선의 길이와 방향에 따라 곡선 모양이 결정됩니다.

참고:

Shift 키를 누른 상태에서 드래그하면 방향선의 각도가 45°의 정배수로 제한됩니다. Alt 키(Windows) 또는 Option 키(Mac OS)를 누른 상태에서 드래그하면 나가는 방향선만 수정됩니다.

  1. 곡선이 시작될 곳에 [펜] 툴을 놓고 마우스 버튼을 누르고 있습니다.

    정점이 나타나고 [펜] 툴 포인터가 화살촉으로 바뀝니다.

  2. 드래그하여 정점의 양쪽 방향선 모두의 길이와 방향을 수정한 다음 마우스 버튼을 놓습니다.
    곡선 패스의 첫 번째 정점 그리기
    곡선 패스의 첫 번째 정점 그리기

    A. 펜 툴 배치 B. 마우스 버튼을 누른 상태에서 드래그 시작 C. 드래그하여 방향선 확장 
  3. 곡선 선분이 끝날 곳에 [펜] 툴을 놓고 다음 중 하나를 수행합니다.
    • C자 모양의 곡선을 만들려면 이전 방향선을 드래그한 방향과 반대되는 방향으로 드래그한 다음 마우스 버튼을 놓습니다.
    곡선 패스의 두 번째 정점 그리기
    곡선 패스의 두 번째 정점 그리기

    A. 드래그 시작 B. 이전 방향선과 반대 방향으로 드래그하여 C자 곡선 만들기 C. 마우스 버튼을 놓은 후의 결과 
    • S자 모양의 곡선을 만들려면 이전 방향선과 같은 방향으로 드래그한 다음 마우스 버튼을 놓습니다.
    S자 곡선 그리기
    S자 곡선 그리기

    A. 드래그 시작 B. 이전의 방향선과 같은 방향으로 드래그하여 S자 곡선 만들기 C. 마우스 버튼을 놓은 후의 결과 
  4. 계속해서 다른 위치에서 [펜] 툴을 드래그하여 일련의 매끄러운 곡선을 만듭니다.

레이어 크기로 모양 또는 마스크 만들기

  1. 새 마스크나 모양의 대상을 선택합니다.
    • 기존 모양 레이어에 모양을 만들려면 모양 레이어를 선택합니다.
    • 컴포지션 치수로 새 모양 레이어에 모양을 만들려면 F2 키를 눌러 모든 레이어를 선택 해제합니다.
    • 마스크를 만들려면 [타임라인] 패널, [레이어] 패널 또는 [컴포지션] 패널에서 레이어를 선택합니다. 모양 레이어에 마스크를 만들려면 모양 툴을 활성화한 상태로 [툴] 패널에서 [툴로 마스크 만들기] 를 선택합니다.
    • 마스크 패스를 바꾸려면 [타임라인] 패널, [레이어] 패널 또는 [컴포지션] 패널에서 마스크를 선택합니다.
    • 모양 패스를 바꾸려면 [컴포지션] 패널이나 [타임라인] 패널에서 모양 패스(그룹이 아님)를 선택합니다.
  2. [툴] 패널에서 [사각형] , [둥근 사각형] , [타원] , [다각형] 또는 [별] 툴을 두 번 클릭합니다.

텍스트 문자로 모양 또는 마스크 만들기

[텍스트로 모양 만들기] 명령은 각 문자의 윤곽선을 추출하고 윤곽선에서 모양을 만들어 새 모양 레이어에 배치합니다. 그런 다음 다른 모든 모양과 마찬가지로 해당 모양을 사용할 수 있습니다.

[텍스트로 마스크 만들기] 명령은 각 문자의 윤곽선을 추출하고 윤곽선에서 마스크를 만들어 새 단색 레이어에 배치합니다. 그런 다음 다른 모든 마스크와 마찬가지로 해당 마스크를 사용할 수 있습니다.

참고:

Webdings와 같은 일부 글꼴 모음에는 텍스트가 아닌 그래픽 이미지인 문자가 포함됩니다. 이러한 글꼴 모음의 텍스트를 변환하는 것은 모양 레이어에서 단순 그래픽 요소로 시작하는 좋은 방법이 될 수 있습니다.

텍스트로 모양 만들기

  1. 모양으로 변환할 텍스트를 선택합니다.
    • 텍스트 레이어에 있는 모든 문자의 모양을 만들려면 [타임라인] 패널 또는 [컴포지션] 패널에서 텍스트 레이어를 선택합니다.
    • 특정 문자의 모양을 만들려면 [컴포지션] 패널에서 문자를 선택합니다.
  2. 다음 중 하나를 수행합니다.
    • [레이어] > [텍스트로 모양 만들기]를 선택합니다.
    • 레이어 또는 텍스트를 마우스 오른쪽 버튼으로 클릭(Windows)하거나 Control 키를 누른 상태에서 클릭(Mac OS)하고 문맥 메뉴에서 [텍스트로 모양 만들기]를 선택합니다.

텍스트 레이어의 [비디오] 스위치 가 꺼집니다.

레이어 겹침 순서 맨 위에 새 모양 레이어가 만들어집니다. 새 레이어에는 선택한 문자마다 하나의 모양 그룹이 포함되고 텍스트의 칠 및 선 속성과 일치하는 칠 및 선 속성도 포함됩니다.

ie와 같이 복합 패스로 구성되는 문자의 경우 여러 패스가 만들어져 [패스 병합] 패스 작업과 결합됩니다.

텍스트 레이어의 [변형] 속성 그룹에 있는 속성의 효과, 마스크, 레이어 스타일, 키프레임 및 표현식이 새 모양 레이어 또는 단색 레이어에 복사됩니다.

텍스트로 마스크 만들기

  1. 마스크로 변환할 텍스트를 선택합니다.
    • 텍스트 레이어에 있는 모든 문자의 마스크를 만들려면 [타임라인] 패널 또는 [컴포지션] 패널에서 텍스트 레이어를 선택합니다.
    • 특정 문자의 마스크를 만들려면 [컴포지션] 패널에서 문자를 선택합니다.
  2. 다음 중 하나를 수행합니다.
    • [레이어] > [텍스트로 마스크 만들기]를 선택합니다.
    • 레이어 또는 텍스트를 마우스 오른쪽 버튼으로 클릭(Windows)하거나 Control 키를 누른 상태에서 클릭(Mac OS)하고 문맥 메뉴에서 [텍스트로 마스크 만들기]를 선택합니다.

텍스트 레이어의 [비디오] 스위치 가 꺼집니다.

레이어 겹침 순서 맨 위에 새 단색 레이어가 만들어집니다.

ie와 같이 복합 패스로 구성되는 문자의 경우 여러 마스크가 만들어져 [빼기] 마스크 모드와 결합됩니다.

Illustrator, Photoshop 또는 Fireworks에서 패스 복사

Illustrator, Photoshop 또는 Fireworks에서 패스를 복사하여 After Effects에 마스크 패스나 모양 패스로 붙여넣을 수 있습니다.

Illustrator에서 복사한 데이터가 After Effects와 호환되도록 하려면 Adobe Illustrator [환경 설정] 대화 상자의 [파일과 클립보드] 섹션에서 [AICB] 옵션을 선택해야 합니다.

Photoshop에서 가져온 패스의 비율을 올바르게 조정하려면 Photoshop 문서의 해상도가 72dpi여야 하는데, 72 dpi는 [필름 및 비디오] 사전 설정을 사용하여 Photoshop에서 만든 문서의 [해상도] 설정입니다.

참고:     복사된 Illustrator, Photoshop 또는 Fireworks 패스를 After Effects 동작 패스로 사용할 수도 있습니다. 자세한 내용은 마스크, 모양 또는 페인트 패스로 동작 패스 만들기를 참조하십시오.

Adobe Illustrator에서 그린 패스(왼쪽)와 After Effects에 마스크로 붙여넣은 패스(오른쪽)
Adobe Illustrator에서 그린 패스(왼쪽)와 After Effects에 마스크로 붙여넣은 패스(오른쪽)

  1. Illustrator, Photoshop 또는 Fireworks에서 전체 패스를 선택하고 [편집] > [복사]를 선택합니다.
  2. After Effects에서 다음 중 하나를 수행하여 붙여넣기 작업의 대상을 정의합니다.
    • 새 마스크를 만들려면 레이어를 선택합니다.
    • 기존 마스크 패스 또는 모양 패스를 바꾸려면 해당 [패스] 속성을 선택합니다.

    참고:

    패스를 모양 패스로 붙여넣으려면 모양 레이어에서 기존 모양의 [패스] 속성을 선택해야 합니다. 이렇게 선택하면 After Effects에 붙여넣기 작업의 대상이 지정됩니다. 이 방법으로 대상을 지정하지 않으면 전체 레이어가 대상으로 간주되므로 새 마스크가 그려집니다. 모양 레이어가 비어 있는 등의 이유로 [패스] 속성이 없는 경우에는 [펜] 툴로 자리 표시자 패스를 그린 다음 Illustrator에서 가져온 패스를 해당 자리 표시자 패스에 붙여넣을 수 있습니다.

  3. [편집] > [붙여넣기]를 선택합니다.

    여러 패스를 모양 패스에 붙여넣으면 첫 번째 패스는 모양 패스에 붙여넣어지고 나머지 패스는 새 마스크 패스에 붙여넣어집니다. 이러한 동작은 첫 번째 패스 이외의 패스는 명확하게 정의된 대상이 없어 전체 레이어에 마스크로 추가되기 때문입니다.

Illustrator의 패스를 After Effects에서 동작 패스로 사용하는 방법에 대한 자세한 내용은 Andrew Devis가 Creative COW 웹 사이트에서 제공하는 비디오를 참조하십시오.

동작 패스로 마스크 또는 모양 만들기

위치 키프레임, 기준점 키프레임 또는 효과 조절점 위치 키프레임을 복사하여 선택한 마스크 패스나 모양 패스에 붙여넣을 수 있습니다. 동작 패스로 마스크 패스나 모양 패스를 만들 때는 단일 [위치] 속성에서만 키프레임을 복사해야 합니다. 다른 속성의 키프레임은 복사하지 마십시오.

참고:

[동작 스케치]를 사용하여 동작 패스를 그린 다음 해당 패스를 마스크 패스 또는 모양 패스에 붙여넣습니다.

동작 패스로 마스크 또는 모양 만들기
우주선의 동작 패스(위쪽)가 배경 레이어에 복사되고(왼쪽 아래) 베가스 효과에 사용됩니다(오른쪽 아래).

참고:

마스크 패스와 동작 패스 간에 복사하는 경우 마스크 패스의 값은 레이어 좌표계(레이어 공간)에, 동작 패스의 값은 컴포지션 좌표계(컴포지션 공간)에 표현됩니다. 이러한 차이로 인해 붙여넣은 패스가 오프셋되므로 패스를 붙여넣은 후 해당 패스의 위치를 다시 지정해야 할 수도 있습니다. 자세한 내용은 좌표계: 컴포지션 공간 및 레이어 공간을 참조하십시오.

동작 패스로 마스크 패스 만들기

  1. [타임라인] 패널에서 동작 패스를 복사할 [위치] 속성 또는 [기준점] 속성 이름을 클릭합니다. 그러면 모든 키프레임이 선택됩니다. 동작 패스에서 일부 키프레임만 선택하려면 Shift 키를 누른 상태로 클릭합니다.
  2. [편집] > [복사]를 선택합니다.
  3. 새 마스크를 만들려면 마스크를 만들 레이어를 선택하고 [레이어] > [마스크] > [새 마스크]를 선택합니다.
  4. [타임라인] 패널에서 동작 패스의 키프레임을 붙여넣을 마스크의 [마스크 패스] 속성 이름을 클릭합니다.
  5. [편집] > [붙여넣기]를 선택합니다.
    위치 키프레임 선택 및 복사
    위치 프레임을 선택 및 복사(왼쪽)한 다음 선택한 마스크 패스 속성에 붙여넣기(오른쪽)

동작 패스로 모양 패스 만들기

  1. [타임라인] 패널에서 동작 패스를 복사할 [위치] 속성 또는 [기준점] 속성 이름을 클릭합니다. 그러면 모든 키프레임이 선택됩니다. 동작 패스에서 일부 키프레임만 선택하려면 Shift 키를 누른 상태로 클릭합니다.
  2. [편집] > [복사]를 선택합니다.
  3. 새 모양 레이어를 만들려면 F2 키를 눌러 모든 레이어를 선택 해제한 다음 [펜] 툴로 [컴포지션] 패널을 클릭하여 단일 점 베지어 패스를 만듭니다.
  4. 모양의 [패스] 속성을 표시하려면 SS를 누릅니다. 모션 패스의 키프레임을 붙여넣을 [패스] 속성의 이름을 클릭합니다.
  5. [편집] > [붙여넣기]를 선택합니다.

변형하는 동안 모양 그룹 복제

그룹 선택 모드에서 모양 그룹을 선택한 경우 [컴포지션] 패널에서 이동 또는 회전하거나 비율을 조정하는 동안 그룹을 복제할 수 있습니다.

  • Alt 키(Windows) 또는 Option 키(Mac OS)를 누른 상태에서 드래그하여 그룹을 변형합니다.

    키를 누른 상태에서 포인터를 그룹 변형 상자 가까이에 놓으면 포인터가 복제 포인터( 또는 )로 바뀝니다.

이 작업에는 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License의 라이센스가 부여되었습니다.  Twitter™ 및 Facebook 게시물은 Creative Commons 약관을 적용받지 않습니다.

법적 고지 사항   |   온라인 개인 정보 보호 정책