Adobe Bridge 및 After Effects를 사용한 작업

Adobe Bridge를 사용하여 애니메이션 사전 설정을 실행하고, 제품 간 워크플로 자동화 스크립트를 실행하고, 파일과 폴더를 확인 및 관리하며, 키워드, 레이블 및 등급을 지정하여 파일을 정리하고, 파일 및 폴더를 검색하고, 메타데이터를 보고 편집 및 추가할 수 있습니다.

  • After Effects에서 Adobe Bridge를 열려면 [파일] > [Bridge에서 찾아보기]를 선택합니다.
  • Adobe Bridge에 파일을 표시하려면 [프로젝트] 패널에서 파일을 선택하고 [파일] > [Bridge에 표시]를 선택합니다.
  • Adobe Bridge를 사용하여 애니메이션 사전 설정을 찾아보려면 [애니메이션] > [사전 설정 찾아보기]를 선택합니다.

Adobe Bridge는 Creative Cloud 응용 프로그램 제품군의 일부이며 Creative Cloud에서 다운로드하여 설치할 수 있습니다. 자세한 내용은 도움말 설명서Adobe Bridge CC 제품 페이지를 참조하십시오.

Adobe Bridge CC를 개괄적으로 살펴보려면 이 비디오를 참조하십시오.

Photoshop 및 After Effects를 사용한 작업

Photoshop을 사용하여 스틸 이미지를 만든 경우 After Effects를 사용하여 이러한 스틸 이미지를 함께 이동 및 변경할 수 있습니다. After Effects에서 전체 Photoshop 이미지 또는 해당 레이어의 일부를 애니메이션으로 나타낼 수 있습니다. 레이어 스타일 속성과 같은 Photoshop 이미지의 각 속성을 애니메이션으로 나타낼 수도 있습니다. After Effects를 사용하여 동영상을 만든 경우 Photoshop을 사용하여 이러한 동영상의 각 프레임을 다듬을 수 있습니다.

특정 작업에 대한 상대적 장점

After Effects의 장점은 애니메이션과 자동화 기능입니다. 즉, After Effects를 사용하면 프레임 간에 자동화할 수 있는 작업의 속도를 높일 수 있습니다. 예를 들어 After Effects의 동작 추적 기능을 사용하여 마이크 붐의 동작을 추적한 다음, 같은 동작을 [복제 도장] 도구로 만든 선에 자동으로 적용할 수 있습니다. 이러한 방법으로 각 프레임에서 일일이 마이크를 손으로 페인트하여 지우지 않고 모든 프레임 샷에서 마이크를 제거할 수 있습니다.

반면에 Photoshop에는 페인트 및 그리기를 위한 훌륭한 도구가 있습니다.

페인트에 사용할 응용 프로그램은 작업에 따라 결정하는 것이 좋습니다. Photoshop의 페인트 획은 레이어의 픽셀에 직접 적용됩니다. After Effects의 페인트 획은 효과 요소로서 언제든지 각 선을 설정 또는 해제하거나 수정할 수 있습니다. 페인트 획을 적용한 다음 각 페인트 획을 전체적으로 제어하거나 페인트 획 자체를 애니메이션으로 나타내려면 After Effects 페인트 도구를 사용하십시오. 스틸 이미지를 영구적으로 수정하기 위해 페인트 획을 적용하는 것이라면 Photoshop 페인트 도구를 사용하십시오. 여러 페인트 선을 수작업으로 적용하여 더스트를 없애고 있다면 Photoshop의 페인트 도구를 사용해 보십시오.

Photoshop의 애니메이션 및 비디오 기능에는 간단한 키프레임 기반의 애니메이션이 포함되어 있습니다. After Effects에서는 비슷한 인터페이스를 사용하지만 애니메이션 기능이 훨씬 다양하고 유연합니다.

또한 After Effects에서는 Photoshop의 소실점 기능으로 만든 평면과 비슷한 3D 레이어를 자동으로 만들 수 있습니다.

스틸 이미지 교환

After Effects에서는 다양한 형식의 스틸 이미지를 가져오고 내보낼 수 있지만 After Effects와 Photoshop 간에 개별 프레임이나 스틸 이미지 시퀀스를 전송할 때는 대개 기본 Photoshop PSD 형식을 사용합니다.

After Effects에서는 PSD 파일을 가져오거나 내보낼 때 각 레이어, 마스크, 레이어 스타일 및 대부분의 기타 특성을 유지할 수 있습니다. PSD 파일을 After Effects로 가져올 때 병합 이미지로 가져올 것인지 또는 별도의 레이어를 포함하는 컴포지션으로 가져올 것인지 선택할 수 있습니다.

After Effects로 가져오기 전에 Photoshop에서 스틸 이미지를 준비하는 것이 좋을 때도 있습니다. 이러한 준비 작업으로는 색상 교정, 비율 조정, 자르기 등이 있습니다. After Effects에서는 각 프레임을 미리 보기용과 최종 출력용으로 렌더링하여 동일한 작업을 하는 데 Photoshop에 비해 많은 시간이 소요되므로 Photoshop에서 소스 이미지 작업을 하는 것이 좋을 때가 많습니다.

Photoshop의 [새 파일] 대화 상자에서 [필름 및 비디오] 사전 설정을 사용하여 새 PSD 문서를 만들면 특정 비디오 출력 형식에 맞게 설정된 문서로 작업을 시작할 수 있습니다. After Effects에서 작업 중인 경우에는 [파일] > [새로 만들기] > [Adobe Photoshop 파일]을 선택하여 해당 합성 및 프로젝트 설정에 맞게 새 PSD 문서를 만들 수 있습니다.

동영상 교환

Photoshop과 After Effects 간에 QuickTime 동영상 등의 비디오 파일을 교환할 수도 있습니다. Photoshop에서 동영상을 열면 소스 푸티지 파일을 참조하는 비디오 레이어가 만들어집니다. 비디오 레이어를 사용하면 After Effects에서 레이어와 동영상을 소스로 작업하는 것처럼 동영상 프레임을 변경하지 않고 페인트할 수 있습니다. PSD 파일을 비디오 레이어로 저장하면 소스 푸티지 자체에 대한 편집 내용은 저장되지 않고 비디오 레이어에 대한 편집 내용이 저장됩니다.

또한 Photoshop에서 직접 동영상을 렌더링할 수도 있습니다. 예를 들어 Photoshop에서 After Effects로 가져올 수 있는 QuickTime 동영상을 만들 수 있습니다.

색상

After Effects에서는 내부적으로 RGB(빨강, 녹색, 파랑) 색상 공간의 색을 사용하여 작업합니다. After Effects에서 CMYK 이미지를 RGB로 변환할 수도 있지만 Photoshop에서 RGB로 비디오 및 애니메이션 작업을 해야 합니다.

최종 출력을 대비하여 이미지를 After Effects로 가져오기 전에 Photoshop에서 이미지의 색상이 브로드캐스팅에 적합한지 확인하는 것이 좋습니다. 이를 위해서는 Photoshop에서 문서에 적절한 대상 색상 공간(예: SDTV(Rec. 601))을 할당하는 것이 좋습니다. After Effects에서는 가져온 PSD 파일 등의 문서에 포함된 색상 프로파일에 따라 색상 관리를 수행합니다.

Animate CC 및 After Effects를 사용한 작업

Adobe Animate(이전 명칭: Flash Professional)를 사용하여 비디오나 애니메이션을 만들면 After Effects를 사용하여 비디오를 편집하고 다듬을 수 있습니다. 예를 들어, Adobe Animate 애니메이션 및 응용 프로그램을 QuickTime 동영상, .mp4 및 기타 표준 비디오 형식으로 내보낼 수 있습니다. 그런 다음 After Effects를 사용하여 비디오를 편집하고 다듬을 수 있습니다.

After Effects를 사용하여 비디오를 편집하고 합성한 다음 Animate를 사용하여 해당 비디오를 게시할 수 있습니다.

Animate와 After Effects는 공통되는 일부 개념에 대해 서로 다른 용어를 사용합니다. 다음 표에서는 두 응용 프로그램에 사용되는 용어의 차이점을 보여 줍니다.

After Effects 애니메이션
컴포지션 동영상 클립
컴포지션 프레임(컴포지션 패널) 단계
프로젝트 패널 라이브러리 패널
프로젝트 파일 FLA 파일
동영상 렌더링 및 내보내기 SWF 파일 게시

추가 리소스

다음 기사는 Animate와 After Effects를 함께 사용하는 방법에 대한 정보를 추가로 제공합니다.

  • Richard Harrington과 Marcus Geduld는 Peachpit 웹 사이트를 통해 자신들의 저서 After Effects for Flash | Flash for After Effects의 발췌본인 "Flash Essentials for After Effects Users(After Effects 사용자를 위한 Flash 요점)"를 제공합니다. 이 장에서 Richard와 Marcus는 After Effects 사용자가 이해할 수 있는 용어로 Animate를 설명합니다. http://www.peachpit.com/articles/article.aspx?p=1350895

  • 또한 Richard Harrington과 Marcus Geduld는 자신들의 저서 After Effects for Flash | Flash for After Effects의 또 다른 발췌본인 "After Effects Essentials for Flash Users(Flash 사용자를 위한 After Effects 요점)"을 제공합니다. 이 장에서 Richard와 Marcus는 Animate 사용자가 이해할 수 있는 용어로 After Effects를 설명합니다. http://www.peachpit.com/articles/article.aspx?p=1350894

  • Robert Powers는 Slippery Rock NYC 웹 사이트를 통해 Animate에 익숙한 사용자의 관점에서 After Effects 사용 방법에 대한 기본 정보를 보여 주는 비디오 자습서를 제공합니다.

Animate에서 QuickTime 비디오 내보내기

Animate를 사용하여 만든 애니메이션이나 응용 프로그램을 Animate에서 [파일] > [내보내기]> [동영상 내보내기] 명령을 사용하여 QuickTime 동영상으로 내보낼 수 있습니다. Animate 애니메이션의 경우 애니메이션의 비디오 출력을 최적화할 수 있습니다. Animate 응용 프로그램의 경우에는 응용 프로그램 비디오가 실행 시 렌더링되므로 사용자가 이를 조작할 수 있습니다. 이렇게 하면 비디오 파일에 포함하려는 응용 프로그램의 분기 또는 상태를 캡처할 수 있습니다.

Animate에서 비디오 가져오기 및 게시

동영상 파일을 Animate로 가져오면 스크립팅 또는 Animate 구성 요소와 같은 다양한 기술을 사용하여 비디오 주위의 시각적 인터페이스를 제어할 수 있습니다. 예를 들어, 재생 컨트롤 또는 다른 그래픽을 포함할 수 있습니다. 또한 동영상에 그래픽 레이어를 추가하여 합성 결과를 얻을 수 있습니다.

합성 그래픽, 애니메이션 및 비디오

Animate와 After Effects에는 각각 복잡한 비디오 및 그래픽 합성을 수행할 수 있는 여러 가지 기능이 포함되어 있습니다. 사용하려는 응용 프로그램은 개인 환경 설정 및 만들려는 최종 출력 형식에 따라 선택하는 것이 좋습니다.

Animate는 두 응용 프로그램 중 보다 웹 지향적이고 최종 파일의 크기가 작으며 애니메이션의 런타임 제어도 가능합니다. After Effects는 비디오 및 필름을 제작하기 위한 프로그램으로 다양한 시각 효과를 제공하고 일반적으로 비디오 파일을 최종 출력으로 만드는 데 사용됩니다.

두 응용 프로그램 모두 원본 그래픽과 애니메이션을 만드는 데 사용할 수 있습니다. 또한 둘 다 타임라인을 사용하며 스크립팅 기능을 제공하므로 애니메이션을 프로그래밍 방식으로 제어할 수 있습니다. After Effects에는 매우 다양한 효과 세트가 포함되어 있습니다.

두 응용 프로그램에서는 합성을 위해 별도의 레이어에 그래픽을 배치할 수 있습니다. 필요에 따라 이러한 레이어를 설정하고 해제할 수 있습니다. 또한 개별 레이어의 콘텐트에 효과를 적용할 수도 있습니다.

Animate에서는 합성하면 비디오 내용에 직접적으로 영향을 주지 않고 Flash Player에서 재생하는 동안 표시되는 비디오의 모양에만 영향을 줍니다. 반면, After Effects에서는 가져온 비디오에 합성하면 합성된 그래픽과 효과가 내보내는 비디오 파일에 실제로 적용됩니다.

After Effects의 모든 그리기 및 페인팅 작업은 가져온 비디오가 아닌 별도의 레이어에서 수행되기 때문에 항상 비파괴적입니다. Animate에는 파괴적 및 비파괴적 그리기 모드가 모두 있습니다.

 

SWF 파일을 After Effects로 가져오기

Animate의 고유한 벡터 아트 도구 세트를 사용하면 After Effects 또는 Adobe® Illustrator®에서는 불가능한 다양한 방법으로 그릴 수 있습니다. SWF 파일을 After Effects로 가져와서 다른 비디오와 합성하거나 기타 독창적인 효과가 적용된 비디오로 렌더링할 수 있습니다. 대화형 콘텐트 및 스크립팅된 애니메이션은 유지되지 않습니다. 키프레임으로 정의되는 애니메이션은 유지됩니다.

After Effects로 불러온 각 SWF 파일은 알파 채널이 보존되어 지속적으로 래스터화된 단일 레이어로 병합됩니다. 지속적 래스터화란 그래픽이 확대될 때 선명하게 유지되는 것을 의미합니다. 이 가져오기 방법을 사용하면 After Effects에서 SWF 파일의 루트 레이어나 오브젝트를 매끄럽게 렌더링된 요소로 사용할 수 있으므로 각 도구에서 가장 좋은 기능을 사용하여 작업할 수 있습니다.

FLA 파일을 After Effects로 가져오기

Animate FLA 파일을 레이어가 있는 .swf 파일의 컴포지션으로 After Effects로 가져올 수 있습니다. 창의적인 추가 효과를 사용하여 이를 비디오와 합성하거나 비디오로 렌더링할 수 있습니다.

이 기능을 사용하려면 동일한 컴퓨터에 Animate 19.0을 설치해야 합니다.

Animate 문서를 After Effects로 가져오는 경우 Animate에서 개별 레이어를 .swf 파일로 내보내며 이러한 파일이 컴포지션에 추가됩니다. 가져오는 동안 가져오기 환경 설정 대화 상자에서 가져오는 파일의 위치를 선택합니다.

[오디오 가져오기] 옵션이 활성화되어 있는 경우 Animate에서는 오디오 레이어를 .wav 파일로 내보냅니다.

참고:

ActionScript 3.0 문서만 지원됩니다. HTML5 Canvas 또는 WebGL 문서를 ActionScript 3.0으로 변환하려면 문서를 Animate에서 열고 파일] > 변환 대상 > ActionScript 3.0을 선택합니다.

Adobe XD 및 After Effects를 사용한 작업

레이어 및 아트보드를 Adobe XD에서 After Effects 프로젝트로 내보낼 수 있습니다. 이 기능은 레이어, 아트보드, 벡터, 텍스트 및 아트워크의 기본 매핑을 통해 XD와 After Effects 간의 에셋 전송 성능을 개선합니다. Adobe XD 디자이너는 레이어 그룹을 After Effects로 전송하고 고급 마이크로 상호 작용 또는 아트보드를 정의하여 복잡하고 다듬어진 전환 및 상호 작용을 만들 수 있습니다. 컴퓨터에 After Effects가 설치되어 있지 않으면 XD 메뉴의 After Effects 옵션이 회색으로 음영 처리됩니다.

XD에서 After Effects로 디자인 에셋을 내보내려면 다음과 같이 하십시오.

  1. XD에서 After Effects에서 애니메이션 처리하려는 레이어 또는 아트보드를 선택합니다.

  2. 파일 > 내보내기 > After Effects를 선택합니다. After Effects가 시작(닫혀 있는 경우)되거나 포그라운드로 이동(백그라운드에서 열려 있는 경우)합니다.

  3. 새 컴포지션에서 레이어와 아트보드가 기본 모양, 텍스트, 에셋 및 중첩된 컴포지션으로 After Effects 프로젝트에 추가됩니다.

지원되는 XD 기능 목록

After Effects에서 지원하는 XD 기능은 다음과 같습니다.

  • 벡터 모양
  • 패스
  • 텍스트 레이어
  • 비트맵
  • 마스크
  • 그룹
  • 아트보드
  • 심볼
  • 부울 연산
  • 어두운 영역
  • 불투명도
  • 개체 흐림 효과
  • 배경 흐림 효과 및 밝기
  • 이미지로 나타낸 그라디언트
  • 격자 반복

Adobe Premiere Pro 및 After Effects를 사용한 작업

Adobe Premiere Pro는 동영상 캡처, 가져오기 및 편집을 위한 프로그램입니다. After Effects는 기타 동영상용 동작 그래픽 생성, 시각 효과 적용, 시각 요소 합성, 색상 교정 수행 및 포스트 프로덕션 작업 수행을 위한 프로그램입니다.

After Effects와 Adobe Premiere Pro 사이에서 프로젝트, 컴포지션, 시퀀스, 트랙 및 레이어를 쉽게 교환할 수 있습니다.

Adobe Premiere Pro가 있는 경우 다음을 수행할 수 있습니다.

  • Adobe Premiere Pro에서 Adobe Dynamic Link를 사용하여 After Effects 컴포지션 작업을 수행할 수 있습니다. 동적으로 연결된 컴포지션은 Adobe Premiere Pro에서 클립으로 표시됩니다.
  • After Effects에서 Adobe Dynamic Link를 사용하여 Adobe Premiere Pro 시퀀스 작업을 수행할 수 있습니다. 동적으로 연결된 시퀀스는 After Effects에 푸티지 항목으로 표시됩니다.
  • Premiere Pro 내에서 After Effects를 시작하고 Premiere Pro 프로젝트의 설정과 일치하는 설정을 사용하여 새 컴포지션을 만듭니다.
  • Adobe Premiere Pro에서 한 세트의 클립을 선택한 다음 After Effects에서 하나의 컴포지션으로 변환합니다.

Dynamic Link를 After Effects 및 Premiere Pro와 함께 사용하는 방법에 대한 자세한 내용은 Adobe Premiere Pro 도움말에서 Dynamic Link 및 After EffectsDynamic Link 섹션을 참조하십시오.

Adobe Media Encoder 및 After Effects를 사용한 작업

Adobe Media Encoder를 사용하여 After Effects에서 비디오를 내보낼 수 있습니다. Adobe Media Encoder를 사용하여 H.264, MPEG-2, WMV 등의 형식을 인코딩할 수 있습니다. 다른 형식은 Adobe Media Encoder에서는 사용할 수 있지만 After Effects에서는 사용할 수 없습니다. 예를 들어, DNxHD 형식은 Adobe Media Encoder에서는 사용할 수 있지만 After Effects에서는 사용할 수 없습니다.

Adobe Media Encoder에서 감시 폴더에 After Effects 프로젝트 파일을 추가할 수 있고 이 컴포지션은 Adobe Media Encoder의 인코딩 대기열에 자동으로 추가됩니다. 자세한 내용은 Adobe Media Encoder의 감시 폴더를 사용하여 파일 가져오기 섹션을 참조하십시오.

Adobe Media Encoder를 After Effects와 함께 사용하는 방법에 대한 자세한 내용은 Adobe Media Encoder를 참조하십시오.

자습서를 참조하여Adobe Media Encoder를사용하여 After Effects 컴포지션을 내보내는 방법을 알아보십시오.

Adobe Audition에서 편집

After Effects에서 작업하는 동안 Adobe Audition에서 제공하는 보다 강력한 오디오 편집 기능을 사용하여 오디오를 세밀하게 조정할 수 있습니다. [Adobe Audition에서 편집] 명령을 사용하여 After Effects 내에서 Adobe Audition을 시작할 수 있습니다.

WAV 파일 같은 오디오 전용 파일을 Adobe Audition에서 편집하면 원본 파일이 변경됩니다. 오디오와 비디오가 모두 포함된 레이어(예: AVI 파일을 소스로 하는 레이어)를 편집하는 경우에는 소스 오디오 파일의 복사본이 편집됩니다.

  1. 편집할 오디오가 포함된 레이어를 선택합니다. 이 항목은 Adobe Audition에서 편집할 수 있는 형식이어야 합니다.

  2. Adobe Audition의 [편집] 보기에서 클립을 열려면 [편집] > [Adobe Audition에서 편집]을 선택합니다.

  3. 파일을 편집하고 다음 중 하나를 수행합니다.

    • 오디오 전용 레이어를 편집하는 경우 [파일] > [저장]을 선택하여 편집 내용을 원본 오디오 파일에 저장합니다. [파일] > [다른 이름으로 저장]을 선택하여 편집 내용을 오디오 파일의 복사본에 저장할 수도 있습니다. [파일] > [다른 이름으로 저장]을 선택한 경우에는 파일의 복사본을 After Effects로 다시 가져옵니다.

    • 오디오와 비디오가 모두 포함된 레이어를 편집하는 경우 [파일] > [다른 이름으로 저장]을 선택합니다. 파일을 저장한 후에는 After Effects로 가져옵니다. 그런 다음 파일을 컴포지션에 추가하고, [타임라인] 패널의 [오디오] 스위치를 선택 취소하여 오디오-비디오 클립에서 원본 오디오를 음소거합니다.

    참고:

    Adobe Audition으로 보내는 복사본에는 After Effects에서 오디오에 적용한 효과는 전혀 포함되지 않습니다.

After Effects의 오디오를 수정하기 위해 Adobe Audition을 사용하는 방법에 대한 자습서 및 관련 리소스는 After Effects Region of Interest 블로그의 게시물을 참조하십시오.

이 작업에는 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License의 라이센스가 부여되었습니다.  Twitter™ 및 Facebook 게시물은 Creative Commons 약관을 적용받지 않습니다.

법적 고지 사항   |   온라인 개인 정보 보호 정책