레이어 선택

속성이 함께 선택된 선택 레이어는 [타임라인] 패널에서 속이 빈 강조 표시로 나타납니다. 속성이 선택되지 않은 선택 레이어는 단색 강조 표시로 나타납니다.

속성이 선택되지 않은 위쪽 선택 레이어와 속성이 함께 선택된 아래쪽 선택 레이어
속성이 선택되지 않은 위쪽 선택 레이어와 속성이 함께 선택된 아래쪽 선택 레이어

참고:

가장 위에서 선택한 레이어를 [타임라인] 패널의 맨 위로 스크롤하려면 X 키를 누릅니다.

  • 레이어를 선택하려면 [컴포지션] 패널에서 레이어를 클릭하거나, [타임라인] 패널에서 레이어의 이름 또는 지속 시간 표시줄을 클릭하거나, [흐름도] 패널에서 레이어의 이름을 클릭합니다.
  • [컴포지션] 패널에서 숨겨진 레이어를 선택하려면 [컴포지션] 패널에서 해당 레이어 위를 마우스 오른쪽 단추로 클릭(Windows)하거나 Control 키를 누른 상태에서 클릭(Mac OS)하고, [선택] > [레이어 이름]을 클릭합니다.
  • 레이어가 해당 [레이어] 패널에서 열려 있는 경우 레이어를 선택하려면 [창] 메뉴 또는 [레이어] 패널 뷰어 메뉴에서 레이어 이름을 선택합니다.
  • 위치 번호로 레이어를 선택하려면 숫자 키패드에서 해당 레이어 번호를 입력합니다. 레이어 번호가 두 자리 수 이상인 경우 After Effects에서 해당 숫자가 단일 숫자로 인식되도록 해당 숫자를 빠르게 입력합니다.
  • 겹침 순서에서 다음 레이어를 선택하려면 Ctrl+아래쪽 화살표(Windows) 또는 Command+아래쪽 화살표(Mac OS)를 누릅니다. 이전 레이어를 선택하려면 Ctrl+위쪽 화살표(Windows) 또는 Command+위쪽 화살표(Mac OS)를 누릅니다.
  • 겹침 순서에서 선택 항목을 다음 레이어로 확장하려면 Ctrl+Shift+아래쪽 화살표(Windows) 또는 Command+Shift+아래쪽 화살표(Mac OS)를 누릅니다. 겹침 순서에서 선택 항목을 이전 레이어로 확장하려면 Ctrl+Shift+위쪽 화살표(Windows) 또는 Command+Shift+위쪽 화살표(Mac OS)를 누릅니다.
  • 모든 레이어를 선택하려면 [타임라인] 또는 [컴포지션] 패널이 활성화된 상태에서 [편집] > [모두 선택]을 선택합니다. 모든 레이어를 선택 해제하려면 [편집] > [모두 선택 해제]를 선택합니다. 컴포지션의 [감춤 레이어 숨김] 스위치가 선택되어 있으면 [타임라인] 패널이 활성화된 상태에서 [모두 선택]을 사용하더라도 감춤 레이어는 선택되지 않습니다. (타임라인 패널에서 레이어 표시 및 숨기기를 참조하십시오.)
  • 하나 이상의 레이어가 선택된 상태에서 현재 선택된 레이어를 모두 선택 해제하고 다른 레이어를 모두 선택하려면, [컴포지션] 또는 [타임라인] 패널의 문맥 메뉴에서 [선택 항목 반전]을 선택합니다.
  • 동일한 색상 레이블을 사용하는 레이어를 모두 선택하려면 [타임라인] 패널에서 색상 레이블을 클릭하고 [레이블 그룹 선택]을 선택하거나, 해당 색상 레이블의 레이어를 선택한 다음 [편집] > [레이블] > [레이블 그룹 선택]을 선택합니다.
  • 부모 레이어에 할당된 자식 레이어를 모두 선택하려면 부모 레이어를 선택한 다음 [컴포지션] 또는 [타임라인] 패널의 문맥 메뉴에서 [자식 선택]을 선택합니다. 자식 레이어가 기존 선택 항목에 추가됩니다.
  • [컴포지션] 패널에서 여러 개의 레이어를 선택할 수 있습니다. [선택] 도구로 드래그하여 레이어 주위에 선택 상자(선택 윤곽)를 만들어서 선택합니다. Shift 키를 누른 상태에서 클릭하거나 드래그하여 추가적인 레이어를 선택하거나 레이어의 선택을 해제할 수도 있습니다.

Lloyd Alvarez는 After Effects Scripts 웹 사이트에서 레이어에 태그를 지정하고 태그에 따라 레이어를 선택하거나 감추거나 단독으로 설정할 수 있는 스크립트를 제공합니다. 태그는 [타임라인] 패널에 있는 [주석] 필드의 주석에 추가됩니다.

선택한 레이어의 겹침 순서 변경

[타임라인] 패널에서 레이어는 레이어 겹침 순서에 따라 세로로 배열되며 이며 이는 렌더링 순서와 직접적으로 관련되어 있습니다. 레이어 겹침 순서를 변경하여 각 레이어가 구성되는 순서를 변경할 수 있습니다.

참고:

각 레이어의 심도 속성으로 인해, [타임라인] 패널의 3D 레이어 겹침 순서가 반드시 컴포지션에서 해당 레이어가 차지하는 공간 위치를 나타내는 것은 아닙니다.  

  • [타임라인] 패널에서 레이어 이름을 레이어 겹침 순서의 새 위치로 드래그합니다.
  • 레이어 겹침 순서에서 선택한 레이어를 한 단계 위로 이동하려면 Ctrl+Alt+위쪽 화살표(Windows) 또는 Command+Option+위쪽 화살표(Mac OS)를 누르고, 선택한 레이어를 한 단계 아래로 이동하려면 Ctrl+Alt+아래쪽 화살표(Windows) 또는 Command+Option+아래쪽 화살표(Mac OS)를 누릅니다.
  • 레이어 겹침 순서에서 선택한 레이어를 맨 위로 이동하려면 Ctrl+Alt+Shift+위쪽 화살표(Windows) 또는 Command+Option+Shift+위쪽 화살표(Mac OS)를 누르고, 선택한 레이어를 맨 아래로 이동하려면 Ctrl+Alt+Shift+아래쪽 화살표(Windows) 또는 Command+Option+shift+아래쪽 화살표(Mac OS)를 누릅니다.
  • [레이어] > [정렬]을 선택한 다음 [레이어를 앞으로 가져오기], [레이어를 뒤로 보내기], [레이어를 맨 앞으로 가져오기] 또는 [레이어를 맨 뒤로 보내기]를 선택합니다.

참고:

레이어를 복사(또는 잘라내기)하여 붙여넣으면 레이어는 복사(또는 잘라내기) 작업 전에 선택한 순서와 동일한 순서로 [타임라인] 패널에 표시됩니다. Ctrl 키(Windows) 또는 Command 키(Mac OS)를 누른 상태에서 레이어를 클릭하여 임의의 순서로 레이어를 선택하여 잘라낸 다음 바로 붙여넣으면 레이어가 앞에서 선택한 순서대로 다시 정렬됩니다.

Jeff Almasol은 redefinery 웹 사이트에서 시작 지점, 종료 지점, 선택 순서, 레이어 이름 또는 임의 순서에 따라 정렬하여 컴포지션의 레이어 겹침 순서를 변경하는 데 사용할 수 있는 스크립트를 제공합니다.

좌표계: 컴포지션 공간 및 레이어 공간

각 레이어의 좌표계는 레이어 공간입니다. 각 컴포지션의 좌표계는 컴포지션 공간입니다. 효과 조절점 및 기준점과 같은 레이어 내에 있는 항목에 대한 속성 값은 레이어 공간에 존재하며 해당 레이어의 레이어 공간에서 원점을 기준으로 측정됩니다. 하지만 레이어의 [위치] 속성은 컴포지션 내에 레이어가 있는 위치를 설명하며, 따라서 해당 컴포지션의 컴포지션 공간에서 측정됩니다.

[레이어] 패널에서 레이어 프레임 위로 포인터를 이동하면 레이어 공간의 포인터 아래에 있는 픽셀 좌표가 [정보] 패널에 표시됩니다. X 좌표는 가로 축 위치를 나타내고 Y 좌표는 세로 축 위치를 나타냅니다. 이러한 좌표의 값은 픽셀 단위로 표시됩니다. X 및 Y 좌표는 레이어의 왼쪽 위에 고정된 원점(0.0)을 기준으로 합니다.

눈금자의 0 지점은 수정할 수 있지만 레이어 공간의 원점은 수정할 수 없습니다. 0 지점이 원점과 다른 경우 [정보] 패널의 X 및 Y 좌표 아래에 X' 및 Y' 좌표가 표시되어 눈금자의 0 지점을 기준으로 하는 좌표임을 나타냅니다.

[컴포지션] 패널에서 컴포지션 프레임 위로 포인터를 이동하면 [정보] 패널에 컴포지션 공간의 좌표가 표시됩니다. 레이어를 드래그할 때 [정보] 패널의 아래쪽 부분에 레이어의 기준점 좌표가 표시됩니다.

공간에서 레이어 이동

공간에서 레이어를 이동하면 위치 속성이 수정됩니다.

[위치] 속성의 구성 요소를 [X 위치], [Y 위치] 및 [Z 위치](3D 레이어의 경우)와 같은 개별 속성으로 구분하여 각 속성을 개별적으로 수정하거나 애니메이션을 적용할 수 있습니다. (위치의 차원을 분리하여 구성 요소에 개별적으로 애니메이션 적용을 참조하십시오.)

Jeff Almasol은 redefinery 웹 사이트에서 선택한 두 레이어의 기준점 사이에 있는 선에 새로운 Null 레이어를 배치하는 스크립트를 제공합니다. Null 레이어에서 슬라이더 컨트롤을 사용하여 이 선을 따라 Null 레이어의 위치를 다시 지정할 수 있습니다.

참고:

선택한 여러 레이어의 기준점이 현재 보기의 가운데에 위치하도록 해당 레이어를 이동하려면 [레이어] > [변형] > [보기에서 가운데 표시]를 선택하거나 Ctrl+Home(Windows) 또는 Command+Home(Mac OS)을 누릅니다.

참고:

한 레이어의 기준점이 컴포지션 가운데에 위치하도록 해당 레이어를 이동하려면 [위치] 속성을 마우스 오른쪽 단추로 클릭(Windows)하거나 Control 키를 누른 상태로 클릭(Mac OS)하고 [값 편집]을 선택한 다음 [단위] 메뉴에서 [%(컴포지션 대비)]를 선택하고 [위치] 속성의 각 컴포지션에 대해 50을 입력합니다.

이동하지 않는 이미지가 부드럽게 되는 것을 방지하려면 레이어의 위치 값이 소수가 아닌 값이어야 합니다. 그러면 이미지 품질이 최고로 설정된 레이어가 하위 픽셀에 배치되는 경우 사용되는 리샘플링이 발생하지 않습니다.

컴포지션 패널에서 레이어를 드래그하여 이동

참고:

드래그할 때 레이어의 가장자리를 격자나 안내선에 스냅하려면 [보기] > [격자에 스냅] 또는 [보기] > [안내선에 스냅]을 선택합니다.

  • 하나 이상의 레이어를 선택한 다음 [선택 도구] 를 사용하여 드래그합니다.

    [컴포지션] 패널에서 레이어를 드래그하여 이동하면 [정보] 패널의 위치 속성에 드래그에 따른 변경 사항이 표시됩니다.

위치 속성을 직접 수정하여 레이어 이동

  1. 하나 이상의 레이어를 선택합니다.
  2. [타임라인] 패널에서 P 키를 눌러 위치 속성을 표시합니다.
  3. [타임라인] 패널에서 위치 속성을 수정합니다.

화살표 키를 사용하여 레이어 이동

  1. 하나 이상의 레이어를 선택합니다.
  2. 선택한 레이어를 1픽셀 단위로 왼쪽, 오른쪽, 위쪽 또는 아래쪽으로 이동하려면 화살표 키를 누릅니다. 10픽셀 단위로 이동하려면 Shift 키를 누른 상태에서 화살표 키를 누릅니다.

    참고:

    화살표 키는 레이어를 현재 확대율에서 1픽셀 이동합니다. 화살표 키로 레이어를 좀더 정밀하게 이동하려면 [컴포지션] 패널을 확대하십시오. (미리 보기의 이미지 확대/축소를 참조하십시오.)

위치 차원을 분리하여 구성 요소에 개별적으로 애니메이션 적용

기본적으로 각 [위치] 속성은 공간 차원() 중 하나에 대한 값을 유지하는 2차원 또는 3차원을 갖고 있습니다. [위치] 속성의 구성 요소를 [X 위치], [Y 위치] 및 [Z 위치](3D 레이어의 경우)와 같은 개별 속성으로 구분할 수 있습니다. 차원을 구분하면 x 축, y 축 및 z 축을 따라 개별적으로 레이어의 위치를 수정하거나 애니메이션을 적용할 수 있습니다.

선택한 [위치] 속성을 개별 [X 위치], [Y 위치] 및 [Z 위치](3D 레이어) 속성으로 분해하려면 다음 중 하나를 수행합니다.

  • [애니메이션] > [차원 분리]를 선택합니다.
  • [위치] 속성을 마우스 오른쪽 단추로 클릭(Windows)하거나 Control 키를 누른 상태에서 클릭(Mac OS)하고 상황에 맞는 메뉴에서 [차원 분리]를 선택합니다.
  • 그래프 편집기 아래쪽에 있는 [차원 분리] 단추 를 클릭합니다.

개별 [위치] 속성의 집합을 여러 구성 요소가 포함된 단일 [위치] 속성으로 재구성하려면 차원을 분리하는 데 사용한 것과 동일한 명령을 사용합니다.  

참고:

여러 개의 개별 [위치] 속성을 단일 [위치] 속성으로 재구성하면, 개별 구성 요소를 나타내는 데 사용되는 여러 베지어 곡선이 각 키프레임에서 단일 베지어 곡선으로 축소되므로 일부 동작 패스 및 속도 정보가 손실됩니다. 차원을 분리할 때는 일부 속도 정보가 손실되지만 동작 패스는 변경되지 않습니다. 사용자는 두 가지 상태 사이를 전환하는 것이 아니라 전체 프로젝트에 대해 각 속성의 개별 차원을 사용하거나 사용하지 않고 작업해야 합니다.

개별 차원의 사용 여부 결정은 수행하려는 작업에 따라 달라집니다. 위치에 하나의 속성을 사용하면 보다 쉽게 매끄러운 동작을 만들 수 있는 장점이 있습니다. 또한 단일 위치 속성을 사용할 경우 균일한 속도를 제공하는 이동 키프레임을 사용할 수 있습니다. 위치에 여러 개별 차원을 사용하여 작업하는 경우에는 동작이 자동으로 매끄럽게 조정되지 않는 대신 공간 애니메이션의 세부적인 제어가 가능합니다. 또한 개별 차원을 사용하면, 레이어에 작동하는 시뮬레이션 힘이 서로 직각(수직)으로 작용할 때와 같은 일부 경우에 보다 쉽게 시뮬레이션을 실행할 수 있습니다.

예를 들어 수평으로 날아갔다가 수직으로 튀는 공에 애니메이션을 적용하려는 경우 차원을 구분하면 보다 쉽게 작업할 수 있습니다. [X 위치] 속성은 시작 지점과 종료 지점에 하나씩 총 2개의 키프레임을 사용하여 애니메이션을 적용할 수 있습니다. 이러한 수평 애니메이션은 공이 날아가는 속도를 나타냅니다. [Y 위치] 속성은 중력으로 인한 가속과 바닥에서 수직으로 튀어오르는 현상을 시뮬레이션하는 단일 표현식으로 애니메이션을 적용할 수 있습니다. 이와 비슷한 예로 바람이 불규칙하게 부는 강 위에서 떠내려 가는 배를 들 수 있습니다.

참고:

After Effects CS3에서는 애니메이션 사전 설정이 강력하지는 않았지만 차원 분리 기능과 유사한 XYZ 위치 분리 애니메이션 사전 설정이 포함되어 있었습니다.

2D 공간에서 레이어 맞춤 및 분포

선택한 레이어를 정렬하거나 고르게 분포시키려면 [맞춤] 패널을 사용합니다. 레이어를 세로 또는 가로로 맞추거나 분포할 수 있습니다.

  1. 맞추거나 분포할 레이어를 선택합니다.
  2. [레이어 맞춤 대상] 메뉴에서 [선택] 또는 [컴포지션]을 선택합니다.

    선택 영역

    선택한 레이어의 레이어 경계를 따라 선택한 레이어를 정렬합니다.

    컴포지션

    컴포지션 프레임의 경계를 따라 선택한 레이어를 정렬합니다.

  3. [맞춤] 패널에서 원하는 맞춤 또는 분포 유형을 나타내는 단추를 클릭합니다.
  • 분포를 수행하려면 레이어를 세 개 이상 선택해야 합니다. [레이어 맞춤 대상] 메뉴에서 [선택]을 선택한 경우 정렬할 레이어를 두 개 이상 선택해야 합니다. [레이어 맞춤 대상] 메뉴에서 [컴포지션]을 선택한 경우 정렬할 레이어를 한 개 이상 선택해야 합니다.

  • [레이어 맞춤 대상] 메뉴에서 [선택]을 선택한 경우 각 정렬 옵션은 새 정렬과 가장 인접한 레이어를 기준으로 선택한 레이어들을 정렬합니다. 예를 들어 [오른쪽 가장자리] 정렬의 경우 선택한 레이어 중에서 가장자리가 가장 오른쪽에 있는 레이어를 기준으로 선택한 모든 레이어가 정렬됩니다.

  • 분포 옵션은 가장 멀리 떨어진 두 레이어 사이의 공간에 선택한 레이어를 고르게 분포시킵니다. 예를 들어 세로 분포 옵션의 경우 선택한 레이어 중 가장 위에 있는 레이어와 가장 아래에 있는 레이어 사이의 공간에 모든 선택된 레이어가 분포됩니다.

  • 서로 다른 크기의 레이어를 분포시킬 경우 레이어 사이의 공간이 다를 수 있습니다. 예를 들어 레이어의 중앙을 기준으로 레이어를 분포시킬 경우 각 레이어의 중심부 간에 동일한 공간이 생기지만 레이어의 크기가 다르면 레이어 사이의 거리가 달라질 수 있습니다.

  • 잠긴 레이어는 맞춤이나 분포 옵션으로 이동할 수 없습니다.

  • [정렬] 패널은 텍스트 레이어 내에 있는 문자의 정렬에는 영향을 주지 않습니다.

참고:

선택한 여러 레이어의 기준점이 현재 보기의 가운데에 위치하도록 해당 레이어를 이동하려면 [레이어] > [변형] > [보기에서 가운데 표시]를 선택하거나 Ctrl+Home(Windows) 또는 Command+Home(Mac OS)을 누릅니다.

Charles Bordenave(nab)는 After Effects Scripts 웹 사이트에서 3D 공간에 레이어를 분포할 수 있는 스크립트를 제공합니다.

레이어 자르기, 확장 또는 슬립 편집

레이어의 지속 시간은 시작 지점에서 시작하여 종료 지점에서 끝납니다. 이 지속 시간에는 시작 지점과 종료 지점 간의 범위가 포함되며 시작 지점에서 종료 지점까지 이어지는 막대가 레이어 지속 시간 표시줄입니다.

레이어 자르기는 레이어의 시작 지점 또는 종료 지점을 수정하여 지속 시간을 변경하는 것을 의미합니다. 움직이는 소스 푸티지를 기반으로 하는 레이어를 자르면 레이어에 표시되는 소스 푸티지 항목의 프레임에 영향을 주게 됩니다. 즉, 시작 지점에 있는 프레임이 제일 먼저 표시되고, 종료 지점에 있는 프레임이 가장 마지막에 표시됩니다. 레이어를 잘라도 푸티지 항목의 프레임은 잘리지 않습니다. 레이어 자르기는 레이어에 대해 재생되는 프레임에만 영향을 줍니다.

타임라인 패널에서 레이어 자르기
타임라인 패널에서 레이어 자르기

A. 원본 시작 지점 B. 스틸 이미지 레이어를 위한 음수 레이어 시간 표시기 C. 원본 시작 지점 D. 동작 푸티지 레이어에서 제외된 프레임을 나타내는 슬립 편집 막대 E. 새로운 시작 지점 

한 푸티지 항목을 여러 레이어의 소스로 사용할 경우 각각 소스의 서로 다른 부분을 표시하도록 레이어를 다르게 자를 수 있습니다. 레이어를 잘라도 푸티지 항목이나 원본 소스 파일은 수정되지 않습니다.

[레이어] 패널 또는 [타임라인] 패널에서 시작 지점 및 종료 지점을 변경하여 레이어를 자를 수 있습니다. 또한 푸티지 항목을 사용하여 레이어를 만들기 전에 푸티지 항목을 자를 수도 있습니다. 푸티지 항목에서 레이어 만들기 또는 레이어 소스 변경을 참조하십시오.

레이어의 시작 지점 , 종료 지점 및 지속 시간 값은 [레이어] 패널 아래에 표시됩니다. [타임라인] 패널에서 모든 레이어의 해당 정보를 표시하려면 [타임라인] 패널의 왼쪽 아래에서 [시작/종료/지속 시간/스트레치] 단추 를 클릭합니다. 선택한 레이어의 지속 시간, 시작 지점 및 종료 지점은 [정보] 패널에도 표시됩니다.

[레이어] 패널에서 시작 지점 및 종료 지점은 레이어 시간으로 표현됩니다. [타임라인] 패널에서 시작 지점 및 종료 지점은 컴포지션 시간으로 표현됩니다. 레이어에 시간 다시 매핑 또는 시간 스트레치를 설정하지 않는 한, 지속 시간은 두 경우 모두 동일합니다.

지속 시간에 관계없이 여러 종류의 레이어를 확장하여 원래 시간보다 길게 시작 지점 및 종료 지점을 확장할 수 있습니다. 이러한 기능은 시간이 다시 매핑된 레이어, 모양 레이어, 스틸 이미지 푸티지 항목 기반 레이어, 카메라 레이어, 조명 레이어 및 텍스트 레이어에 적용됩니다. 레이어가 음수 레이어 시간으로 확장되도록 레이어를 이전 시간으로 확장하면 레이어 막대 아래에 음수 레이어 시간을 나타내는 일련의 해시 표시가 나타납니다. 이러한 표시는 결과를 계산하기 위해 레이어 시간을 사용하는 입자 필드, 균열 등의 효과를 레이어에 적용한 경우 유용합니다.

레이어 자르기, 확장 및 편집 관련 온라인 리소스

Jeff Almasol은 redefinery 웹 사이트에서 레이어 시작 지점, 레이어 종료 지점, 레이어 소스 프레임, 키프레임, 마커 등 다양한 항목 조합을 시간에 따라 이동할 수 있는 컨트롤이 포함된 패널을 만드는 스크립트를 제공합니다.

타임라인 패널에서 레이어 자르기 또는 확장

레이어 지속 시간 표시줄의 종료 지점 드래그
레이어 지속 시간 표시줄의 종료 지점 드래그

  1. [타임라인] 패널에서 하나 이상의 레이어를 선택합니다.
  2. 다음 중 하나를 수행합니다.
    • 레이어 지속 시간 표시줄의 한 쪽 끝을 드래그합니다.

    • 시작 지점 또는 종료 지점을 설정할 시간으로 현재 시간 표시기를 이동합니다. 시작 지점을 현재 시간으로 설정하려면 Alt+[(Windows) 또는 Option+[(Mac OS)를 누릅니다. 종료 지점을 현재 시간으로 설정하려면 Alt+](Windows) 또는 Option+](Mac OS)를 누릅니다.

레이어 패널에서 레이어 자르기 또는 확장

  • [레이어] 패널에서 레이어를 열고 레이어 지속 시간 표시줄의 한 쪽 끝을 드래그합니다.
  • [레이어] 패널에서 푸티지를 시작하거나 종료할 시간으로 현재 시간 표시기를 이동한 다음 [시작] 또는 [종료] 단추 를 클릭하여 시작 지점 또는 종료 지점을 현재 시간으로 설정합니다.

레이어 슬립 편집

움직이는 푸티지를 기반으로 하는 레이어를 자르면 옅은 색상의 슬립 편집 막대로 컴포지션에서 제외할 푸티지 항목의 프레임이 표시됩니다. 스틸 푸티지 항목을 기반으로 하는 잘린 레이어에는 이 옅은 사각형이 표시되지 않습니다. 슬립 편집 막대를 드래그하여 잘린 지속 시간 내에서 재생할 프레임을 선택할 수 있습니다. 레이어의 시작 지점과 종료 지점은 영향을 받지 않습니다.

레이어의 시작 지점 또는 종료 지점만 움직일 경우 키프레임이 움직이지 않습니다. 레이어 지속 시간 표시줄을 드래그하면 모든 키프레임이 이동합니다. 슬립 편집 막대를 드래그하면 선택한 키프레임이 이동하지만 선택하지 않은 키프레임은 이동하지 않습니다.

참고:

슬립 편집을 수행할 때 마스크 키프레임과 같이 일부 소스 푸티지가 있는 키프레임을 이동하고 다른 키프레임은 해당 시간에 그대로 유지하려는 경우에는 Shift+F2를 눌러 키프레임을 선택 해제하고 레이어는 선택한 상태로 두십시오.

  • 슬립 편집 막대를 왼쪽이나 오른쪽으로 드래그합니다.
  • [뒤로 팬(기준점)] 도구를 사용하여 레이어를 왼쪽이나 오른쪽으로 드래그합니다.

레이어의 지속 시간 중 일부 제거

  1. [타임라인] 패널에서 레이어의 지속 시간 중 제거할 부분만 포함하도록 작업 영역을 설정하십시오. 작업 영역의 시작 시간으로 현재 시간 표시기를 이동하고 B 키를 누릅니다. 그런 다음 작업 영역의 종료 시간으로 현재 시간 표시기를 이동하고 N 키를 누릅니다.
  2. 다음 중 하나를 수행합니다.
    • 섹션을 제거할 레이어를 선택합니다.

    • 레이어가 추출 작업의 영향을 받지 않도록 하려면 해당 레이어의 [잠금] 스위치 를 선택합니다. 모든 레이어를 선택 해제하려면 F2 키를 누릅니다.

    참고:

    선택한 레이어가 없는 경우 다음 단계를 수행하면 잠기지 않은 모든 레이어에서 해당 섹션이 제거됩니다.

  3. 다음 중 하나를 수행합니다.
    • 섹션을 제거한 다음 동일한 지속 시간에서 제거된 섹션만큼의 간격을 그대로 두려면 [편집] > [작업 영역 들어올리기]를 선택합니다.

    • 섹션을 제거하려면 [편집] > [작업 영역 추출]을 선택합니다. 간격이 잔물결 삭제 표시로 채워집니다.

시간을 기준으로 레이어 배치 또는 이동

레이어 지속 시간 표시줄은 레이어 지속 시간을 시각적으로 보여 줍니다. [타임라인] 패널의 시작, 종료 및 지속 시간 열에는 레이어 지속 시간이 숫자로 표시됩니다.

참고:

[타임라인] 패널에서 표시할 열을 선택하려면 패널 메뉴에서 [열]을 선택하거나, 열 제목을 마우스 오른쪽 단추로 클릭(Windows)하거나 Control 키를 누른 상태에서 클릭(Mac OS)합니다.

이러한 절차를 수행하면 전체 레이어 시간이 이동합니다.

  • 시작 지점 또는 종료 지점을 숫자로 설정하려면 [타임라인] 패널에서 해당 레이어에 대한 [시작] 또는 [종료] 열의 숫자를 클릭합니다.
  • 시작 지점 또는 종료 지점을 현재 시간으로 이동하려면 [타임라인] 패널에서 해당 레이어에 대한 시작 또는 종료 열에서 Alt 키(Windows) 또는 Option 키(Mac OS)를 누른 상태에서 숫자를 클릭합니다.
  • 선택한 레이어의 시작 지점을 컴포지션의 시작 부분으로 이동하려면 Alt+Home(Windows) 또는 Option+Home(Mac OS)을 누릅니다.
  • 선택한 레이어의 종료 지점을 컴포지션의 끝 부분으로 이동하려면 Alt+End(Windows) 또는 Option+End(Mac OS)를 누릅니다.
  • 선택한 레이어를 한 프레임 뒤로 이동하려면 Alt+Page Down(Windows) 또는 Option+Page Down(Mac OS)을 누릅니다. 선택한 레이어를 10 프레임 뒤로 이동하려면 Alt+Shift+Page Down(Windows) 또는 Option+Shift+Page Down(Mac OS)을 누릅니다.
  • 선택한 레이어를 한 프레임 앞으로 이동하려면 Alt+Page Up(Windows) 또는 Option+Page Up(Mac OS)을 누릅니다. 선택한 레이어를 10 프레임 앞으로 이동하려면 Alt+Shift+Page Up(Windows) 또는 Option+Shift+Page Up(Mac OS)을 누릅니다.
  • 전체 레이어 시간을 드래그하여 이동하려면 레이어 지속 시간 표시줄을 왼쪽이나 오른쪽으로 드래그합니다. 레이어 지속 시간 표시줄을 시간 상 중요한 지점(마커 또는 컴포지션의 시작 지점이나 종료 지점)에 스냅하려면 Shift 키를 누른 상태에서 레이어 지속 시간 표시줄을 드래그합니다.

참고:

[타임라인] 패널에서 레이어를 드래그하면 [정보] 패널에 레이어의 이름, 지속 시간, 변경 시간 및 시작/종료 지점이 표시됩니다.

지속 시간 표시줄을 드래그하기 전과 후
지속 시간 표시줄을 드래그하기 전과 후

Jeff Almasol은 redefinery 웹 사이트에서 해당 그룹을 컴포지션의 특정 시간에 정렬하면서 선택한 레이어를 하나의 그룹으로 이동하는 데 사용할 수 있는 스크립트를 제공합니다.

레이어를 순차적으로 배열

시퀀스 레이어 키프레임 도우미를 사용하여 레이어를 순차적으로 자동 배열할 수 있습니다. 키프레임 도우미를 적용하면 선택한 첫 번째 레이어는 초기 시간에 그대로 유지되고 나머지 선택된 레이어는 [타임라인] 패널에서 선택한 순서에 따라 새로운 시간으로 이동합니다.

타임라인 패널에서 선택된 레이어
타임라인 패널에서 선택한 레이어(위)와 시퀀스 레이어 키프레임 도우미를 적용하여 순차적으로 배열한 레이어(아래)

겹쳐진 레이어
레이어를 겹치면 불투명도 키프레임이 자동으로 설정되어 크로스 디졸브가 만들어집니다.

시퀀스에 넣을 레이어의 경우 다른 레이어를 넣을 수 있도록 해당 레이어의 지속 시간이 컴포지션의 길이보다 짧아야 합니다. (레이어 자르기, 확장 또는 슬립 편집을 참조하십시오.)

  1. [타임라인] 패널에서 Ctrl 키(Windows) 또는 Command 키(Mac OS)를 누른 상태에서 처음 표시할 레이어부터 순차적으로 레이어를 선택합니다.
  2. [애니메이션] > [키프레임 도우미] > [시퀀스 레이어]를 선택합니다.
  3. [시퀀스 레이어] 대화 상자에서 다음 중 하나를 수행합니다.
    • 레이어를 처음부터 끝까지 겹치지 않게 배열하려면 [겹치기] 옵션을 선택 해제합니다.

    • 레이어를 겹치게 하려면 [겹치기] 옵션을 선택하고 겹칠 지속 시간에 대한 [지속 시간] 값을 입력한 다음 전환을 선택합니다. 선택한 레이어의 투명도를 사용하려면 [앞쪽 및 뒤쪽 레이어 크로스 디졸브]를 선택합니다. 그렇지 않은 경우 [앞쪽 레이어 디졸브]를 선택합니다.

    • 레이어 사이에 간격을 두려면 [겹치기]를 선택하고 [지속 시간] 값을 음수로 입력합니다.

레이어 복사 또는 복제

레이어를 복사하면 효과, 키프레임, 표현식 및 마스크와 같은 모든 속성이 복사됩니다.

레이어를 복제하면 명령 한 번으로 간단하게 레이어를 복사하여 붙여넣을 수 있습니다. 트랙 매트가 포함된 레이어를 복제하면 레이어의 상대 순서와 트랙 매트가 유지됩니다.

레이어를 붙여넣으면 복사하기 전에 레이어를 선택한 순서대로 배치됩니다. 선택한 첫 번째 레이어가 가장 마지막에 배치되어 레이어 겹침 순서에서 가장 위에 표시됩니다. 맨 위의 레이어를 가장 먼저 레이어를 선택한 경우 레이어를 붙여넣으면 결국 겹침 순서가 동일해집니다.

참고:

마스크나 키프레임과 같은 레이어의 구성 요소를 선택하여 복사하면 해당 구성 요소만 복사됩니다. 복사하기 전에 Shift+F2 키를 눌러 레이어의 모든 구성 요소를 선택 해제하고 레이어 자체만 선택한 상태로 두십시오.

  • 선택한 레이어를 복사하여 복사본의 시작 지점을 현재 시간에 배치하려면 [편집] > [복사]를 선택한 다음 Ctrl+Alt+V(Windows) 또는 Command+Option+V(Mac OS)를 누릅니다.
  • 선택한 레이어를 복사하여 원본과 동일한 시간에 복사본을 배치하려면 [편집] > [복사]를 선택한 다음 [편집] > [붙여넣기]를 선택합니다.

참고:

[타임라인] 패널에서 원본의 바로 위가 아니라 레이어 스택의 맨 위에 복사본을 배치하려면 붙여넣기 전에 F2 키를 눌러서 원본을 선택 해제합니다.

  • 선택한 레이어를 복제하려면 [편집] > [복제]를 선택하거나 Ctrl+D(Windows) 또는 Command+D(Mac OS)를 누릅니다.

레이어 분할

언제든지 [타임라인] 패널에서 레이어를 분할하여 두 개의 독립된 레이어로 만들 수 있습니다. 레이어를 분할하면 컴포지션 중간에 레이어의 겹침 순서 배치를 바꿔야 하는 경우 레이어를 복제하여 자르는 것보다 빠르게 작업을 수행할 수 있습니다.

참고:

새로 분할된 레이어를 [타임라인] 패널에서 원본 레이어 위에 표시하려면 [원래 레이어 위에 분할 레이어 만들기]([편집] > [환경 설정] > [일반](Windows) 또는 [After Effects] > [환경 설정] > [일반](Mac OS))를 선택합니다. 레이어를 원본 레이어 아래에 표시하려면 이 옵션을 선택 해제합니다.

  1. 하나 이상의 레이어를 선택합니다.
  2. 레이어를 분할할 시간으로 현재 시간 표시기를 이동합니다.
  3. [편집] > [레이어 분할]을 선택합니다.

레이어를 분할할 경우 양쪽 결과 레이어에 기존 위치의 원본 레이어에 있던 모든 키프레임이 포함됩니다. 적용된 모든 트랙 매트에는 레이어 위의 해당 순서가 그대로 유지됩니다.

레이어를 분할하면 원본 레이어의 지속 시간이 분할된 지점에서 끝나고 새로운 레이어가 해당 지점에서 시작됩니다.

레이어를 선택하지 않은 상태에서 [편집] > [레이어 분할]을 선택하면 현재 시간의 모든 레이어가 분할됩니다.

Paul Tuersley는 AE Enhancers 포럼에서 레이어 마커에서 레이어를 분할하는 스크립트를 제공합니다.

Lloyd Alvarez는 After Effects Scripts 웹 사이트에서 푸티지 레이어의 편집 사항을 자동으로 감지하여 각 편집 사항에 대해 별개의 레이어로 분할하거나 각 편집 사항에 레이어 마커를 배치하는 스크립트를 제공합니다.

방향 자동 설정 옵션

각 레이어의 방향 자동 설정 옵션([레이어] > [변형] > [방향 자동 설정])은 동작 패스, 관심 영역 및 카메라에 따라 방향이 설정되는 방식을 지정합니다.

해제

레이어가 동작 패스, 관심 영역 또는 다른 레이어에 관계 없이 자유롭게 회전합니다.

패스 방향으로

레이어의 방향이 동작 패스의 방향을 향하도록 지정됩니다. 예를 들어 이 옵션을 사용하여 운전 중에 전방의 도로를 바라보는 운전자의 시야를 묘사할 수 있습니다.

카메라 방향으로

레이어의 방향이 항상 활성 카메라를 향하도록 지정됩니다. 이 옵션은 3D 레이어에 사용할 수 있으나 2D 레이어, 카메라 또는 조명에는 사용할 수 없습니다. 3D 텍스트 레이어에는 개별 기준점 주위의 각 문자의 방향을 설정하는 [각 문자를 독립적으로 방향 설정]이라는 추가 옵션이 있습니다. [각 문자를 독립적으로 방향 설정]을 선택하면 텍스트 레이어에 대한 문자별 3D 속성이 설정됩니다(아직 설정되지 않은 경우). (문자별 3D 텍스트 속성을 참조하십시오.)

관심 영역 방향으로

카메라 또는 조명이 항상 관심 영역으로 향하도록 지정됩니다. 이 옵션은 카메라 및 조명 이외의 레이어에는 사용할 수 없습니다. (카메라, 조명 및 관심 영역을 참조하십시오.)

참고:

레이어에 방향 자동 설정 옵션을 지정한 다음 레이어의 방향이나 [X 회전], [Y 회전] 또는 [Z 회전] 속성을 변경하면 레이어의 방향이 새로운 값만큼 오프셋됩니다. 예를 들어 카메라를 [패스 방향으로]로 설정하고 카메라를 오른쪽으로 90도 회전하면 움직이는 차 안에서 측면의 창 밖을 바라보는 탑승자의 시야를 묘사할 수 있습니다.

관심 영역을 향하도록 하는 방향 자동 설정은 [회전] 및 [방향] 변환이 적용되기 전에 적용됩니다. [관심 영역 방향으로] 옵션을 이용해서 일시적으로 관심 영역 바깥을 바라보도록 카메라 또는 조명에 애니메이션을 적용하려면 [회전] 및 [방향] 변환 속성에 애니메이션을 적용합니다.

Dan Ebberts는 MotionScript 웹 사이트에서 한 축만 따라 레이어의 방향을 자동으로 설정하는 표현식을 제공합니다. 이 표현식은 위아래 방향은 그대로 두고 문자를 카메라에 따라 옆으로 돌리려는 등의 경우에 유용합니다.

레이어 선택 및 정렬에 대한 추가 리소스

Jeff Almasol은 redefinery 웹 사이트에서 레이어 시작 지점, 레이어 종료 지점, 레이어 소스 프레임, 키프레임, 마커 등 다양한 항목 조합을 시간에 따라 이동할 수 있는 컨트롤이 포함된 패널을 만드는 스크립트를 제공합니다.

이 작업에는 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License의 라이센스가 부여되었습니다.  Twitter™ 및 Facebook 게시물은 Creative Commons 약관을 적용받지 않습니다.

법적 고지 사항   |   온라인 개인 정보 보호 정책