카메라 레이어 만들기 및 카메라 설정 변경

카메라 레이어를 사용하면 어느 각도 및 거리에서나 3D 레이어를 볼 수 있습니다. 실제 세계에서도 장면 자체를 이동하거나 회전하는 것보다 카메라를 한 장면에 걸쳐 또는 장면 주변으로 이동하는 것이 더 쉬운 것처럼, 컴포지션에서도 카메라 레이어를 설정하여 이를 이동함으로써 컴포지션의 여러 가지 뷰를 얻는 것이 더 간편한 경우가 많습니다.

카메라 설정을 수정하거나 애니메이션을 적용하여 카메라를 구성해서 합성할 푸티지를 기록하는 데 사용할 실제 카메라 및 설정에 일치시킬 수 있습니다. 또한 카메라 설정을 사용하여 피사계 심도 흐림 효과부터 팬과 이동 샷까지, 실제 카메라 같은 동작을 애니메이션에 추가할 수 있습니다.

카메라는 [컴포지션 카메라] 특성이 포함된 효과의 3D 레이어 및 2D 레이어에만 영향을 줍니다. [컴포지션 카메라] 특성이 포함된 효과를 사용할 경우 활성 컴포지션 카메라 또는 조명을 사용해서 다양한 각도에서 효과를 보거나 조명을 적용하여 보다 정교한 3D 효과를 시뮬레이션할 수 있습니다.

컴포지션을 볼 때 활성 카메라 또는 이름이 지정된 사용자 정의 카메라를 사용하도록 선택할 수 있습니다. 활성 카메라는 [비디오] 스위치 가 선택된 현재 시간에서 [타임라인] 패널의 맨 위에 있는 카메라입니다. 활성 카메라 보기는 최종 출력 생성 및 컴포지션 중첩을 위해 사용되는 시점입니다. 사용자 정의 카메라를 만들지 않은 경우 활성 카메라는 기본 컴포지션 뷰와 동일합니다.

모든 카메라의 목록이 [컴포지션] 패널 아래쪽에 있는 [3D 보기] 메뉴에 표시되어 언제든지 액세스할 수 있습니다.

사용자 정의 3D 보기 중 하나를 사용할 때 카메라를 조정하는 것이 가장 쉬운 경우가 많습니다. 물론 카메라 자체를 통해 보고 있을 때는 카메라를 조작하기 위해 카메라를 볼 수 없습니다.

카메라 예
카메라 예

A. 관심 영역 B. 프레임 C. 카메라 

카메라 레이어 만들기

  1. [레이어] > [새로 만들기] > [카메라]를 선택하거나 Ctrl+Alt+Shift+C(Windows) 또는 Command+Option+Shift+C(Mac OS)를 누릅니다.

    참고:

    기본적으로 새 레이어는 컴포지션 지속 시간의 시작 부분에서 시작됩니다. [컴포지션 시작 시 레이어 만들기] 환경 설정([편집] > [환경 설정] > [일반](Windows) 또는 [After Effects] > [환경 설정] > [일반](Mac OS))을 선택 해제하여 새 레이어가 현재 시간에서 시작되도록 선택할 수도 있습니다.

카메라 설정 변경

언제든지 카메라 설정을 변경할 수 있습니다.

  1. [타임라인] 패널에서 카메라 레이어를 두 번 클릭하거나 레이어를 선택한 다음 [레이어] > [카메라 설정]을 선택합니다.

참고:

기본적으로 [카메라 설정] 대화 상자에서 [미리 보기] 옵션이 선택되어 있습니다. 이 옵션은 [카메라 설정] 대화 상자에서 항목을 변경할 때 변경 내용을 컴포지션에 표시합니다.

카메라 설정

언제든지 [타임라인] 패널에서 해당 레이어를 두 번 클릭하거나 레이어를 선택하고 [레이어] > [카메라 설정]을 선택하여 카메라 설정을 변경할 수 있습니다.

참고:

대화 상자에서 설정을 수정할 때 [컴포지션] 패널에 결과가 표시되도록 하려면 [카메라 설정] 대화 상자에서 [미리 보기]를 선택합니다.

참고:

피사계 심도에 영향을 주는 세 가지 항목은 초점 거리, 조리개 및 피사체와의 거리입니다. 초점 거리가 길고, 피사체와의 거리가 짧고 조리개 값이 크면(작은 F-스톱) 피사계 심도가 얕습니다(작습니다). 피사계 심도가 얕으면 피사계 심도 흐림이 크게 나타납니다. 얕은 피사계 심도의 반대 경우에는 초점이 깊습니다. 즉, 화면의 많은 부분에 초점이 맞춰지므로 피사계 심도 흐림이 작게 나타납니다.  

카메라 렌즈 흐림 효과 및 모양과 관련된 카메라 속성에는 [조리개 모양], [조리개 회전], [조리개 원형률], [조리개 종횡비], [조리개 에돌이 줄무늬], [밝은 영역 게인], [밝은 영역 임계값], [밝은 영역 채도]가 포함됩니다.

유형

1노드 카메라 또는 2노드 카메라. 1노드 카메라는 그 자체가 카메라 방향의 기준이 되지만, 2노드 카메라는 관심 영역이 있어서 이 지점을 기준으로 카메라 방향을 설정합니다. 카메라를 2노드 카메라로 만드는 것은 카메라의 방향 자동 설정 옵션을 [관심 영역 방향으로]로 설정하는 것과 같습니다([레이어] > [변환] > [방향 자동 설정]). 자세한 내용은 방향 자동 설정 옵션을 참조하십시오.

이름

카메라의 이름입니다. 기본적으로 [카메라 1]은 컴포지션에서 만드는 첫 번째 카메라의 이름이고 이후의 모든 카메라는 오름차순으로 번호가 지정됩니다. 카메라를 쉽게 구분하기 위해서는 여러 카메라에 대해 고유한 이름을 선택하는 것이 좋습니다.

사전 설정

사용할 카메라 설정의 종류입니다. 사전 설정은 초점 거리에 따라 이름이 지정됩니다. 각 사전 설정은 특정 초점 거리의 렌즈가 부착된 35mm 카메라의 동작을 나타냅니다. 따라서 사전 설정은 [보기 각도], [확대/축소], [피사체와의 거리], [초점 거리], [조리개] 값도 설정합니다. 기본 사전 설정은 50mm입니다. 또한 원하는 설정에 새로운 값을 지정하여 사용자 정의 카메라를 만들 수도 있습니다.

확대/축소

렌즈에서 이미지 평면까지의 거리입니다. 즉, [확대/축소] 거리만큼 떨어져 있는 레이어는 전체 크기로 표시되고 확대/축소 거리의 두 배만큼 떨어져 있는 레이어는 길이 및 폭이 절반으로 표시됩니다.

보기 각도

이미지에 넓은 장면이 캡처됩니다. [초점 거리], [필름 크기] 및 [확대/축소] 값은 보기 각도에 영향을 줍니다. 보기 각도가 넓으면 광각 렌즈를 사용하는 것과 동일한 결과를 얻을 수 있습니다.

피사계 심도

[피사체와의 거리], [조리개], [F-스톱], [흐림 레벨] 설정에 대한 사용자 정의 변수를 적용합니다. 이러한 변수를 사용하여 보다 실제와 같은 카메라 초점 효과를 만들 수 있도록 피사계 심도를 조작할 수 있습니다. 피사계 심도는 이미지에 초점이 맞는 거리 범위를 나타냅니다. 해당 거리 범위 바깥에 있는 이미지는 흐리게 표시됩니다.

피사체와의 거리

카메라에서 완벽하게 초점이 맞는 평면까지의 거리입니다.

참고:

관심 영역에 초점이 맞도록 초점면을 카메라의 관심 영역에 잠그려면 [피사체와의 거리] 속성에 length(position, pointOfInterest) 표현식을 추가합니다.

확대/축소 잠금

[피사체와의 거리] 값을 [확대/축소] 값과 일치시킵니다.

참고:

[타임라인] 패널에서 [확대/축소] 또는 [피사체와의 거리] 설정을 변경하면 [확대/축소] 값에서 [피사체와의 거리] 값의 잠금이 해제됩니다. 값을 변경하고 해당 값을 잠긴 상태로 유지하려면 [타임라인] 패널 대신 [카메라 설정] 대화 상자를 사용합니다. 또는 [타임라인] 패널에서 [피사체와의 거리] 속성에 표현식을 추가할 수 있습니다. 이렇게 하려면 [피사체와의 거리] 속성을 선택하고 [애니메이션] > [표현식 추가]를 선택한 다음 표현식 뚝딱 툴을 [확대/축소] 속성으로 드래그합니다. 표현식 기본 사항을 참조하십시오.

조리개

렌즈의 개방 크기입니다. 조리개 설정은 피사계 심도에도 영향을 줍니다. 조리개를 넓히면 피사계 심도의 흐림 효과가 증가합니다. [조리개]를 수정하면 [F-스톱] 값이 그에 맞게 변경됩니다.

참고:

실제 카메라에서는 조리개를 넓히면 빛이 더 많이 들어와서 노출에 영향을 줍니다. 대부분의 3D 합성 및 애니메이션 애플리케이션과 마찬가지로 After Effects에서도 조리개 값의 변화에 따른 이러한 결과를 무시합니다

F-스톱

초점 거리와 조리개 사이의 비율을 나타냅니다. 대부분의 카메라에서는 f-스톱 치수를 사용하여 조리개 크기를 지정합니다. 따라서 많은 사진 작가들은 f-스톱 단위로 조리개 크기를 설정하는 것을 선호합니다. [F-스톱]을 수정하면 [조리개]가 그에 맞게 변경됩니다.

흐림 레벨

이미지에서 피사계 심도의 흐림 정도를 나타냅니다. 100%로 설정하면 카메라 설정에 따른 자연스러운 흐림 효과가 나타납니다. 값을 낮추면 흐림 효과가 줄어듭니다.

필름 크기

필름 노출 영역의 크기로, 컴포지션 크기와 직접적으로 관련되어 있습니다. [필름 크기]를 수정하면 실제 카메라의 원근과 일치하도록 [확대/축소] 값이 변경됩니다.

초점 거리

필름 면에서 카메라 렌즈 사이의 거리입니다. After Effects에서 카메라의 위치는 렌즈의 중심을 나타냅니다. [초점 거리]를 수정하면 실제 카메라의 원근과 일치하도록 [확대/축소] 값이 변경됩니다. 또한 [사전 설정], [보기 각도] 및 [조리개] 값도 그에 따라 변경됩니다.

단위

카메라 설정 값이 표현되는 측정 단위입니다.

필름 크기 측정

필름 크기를 나타내는 데 사용되는 치수입니다.

참고:

최상의 결과를 얻으려면 프로젝트 설정에서 [작업 영역 선형화]를 선택한 상태로 32bpc에서 작업하십시오.

카메라 명령

After Effects 에는 [스테레오 3D 리그 만들기] 기능과 함께 사용하거나 별도로 사용할 수 있는 카메라 명령이 있습니다. 카메라 명령을 사용하려면 카메라 레이어를 선택한 다음 [레이어] > [카메라]를 선택합니다.

[피사체와의 거리]를 [관심 영역]에 연결

선택한 카메라 레이어의 [피사체와의 거리] 속성에 대한 표현식을 만들고, 이 속성의 값을 카메라와 관심 영역 사이의 거리로 설정합니다.

[피사체와의 거리]를 [레이어]에 연결

선택한 카메라 레이어의 [피사체와의 거리] 속성이 카메라의 위치 및 다른 레이어 사이의 거리가 되도록 표현식을 만듭니다. 이 방법을 사용하면 포커스가 다른 레이어를 자동으로 따라가도록 할 수 있습니다.

[피사체와의 거리]를 [레이어]에 설정

현재 [피사체와의 거리] 속성의 값을 카메라와 선택된 레이어 사이의 현재 거리로 설정합니다.

카메라 관련 온라인 리소스

카메라를 만들고 수정하는 방법과 [카메라] 툴을 사용하는 방법을 보여 주는 비디오 튜토리얼은 Adobe 웹 사이트를 참조하십시오.

Dale Bradshaw는 Creative Workflow Hacks 웹 사이트에서 카메라 조작을 자동화하는 스크립트와 샘플 프로젝트를 제공합니다.

Mark Christiansen은 Peachpit Press 웹 사이트에서 After Effects Studio Techniques의 "Virtual Cinematography in After Effects" 장을 통해 카메라 작업에 필요한 팁과 상세한 기법을 제공합니다. 이 장에는 렌즈 왜곡 일치, 카메라 이동, 카메라 프로젝션(카메라 매핑) 수행, 랙 포커스 사용, 보케 흐림 효과 만들기, 그레인 사용 및 이야기 속도와 일치하는 프레임 속도 선택에 대한 정보가 포함되어 있습니다.

Trish와 Chris Meyer는 저서 After Effects Apprentice의 PDF 발췌 문서를 통해 3D 레이어, 조명 및 카메라를 사용하는 데 필요한 튜토리얼을 Focal Press 웹 사이트에서 제공합니다.

Andrew Kramer는 자신의 Video Copilot 웹 사이트에서 기본 카메라 매핑과 카메라 투영에 대해 설명하는 2부로 구성된 비디오 튜토리얼을 제공합니다. 이 튜토리얼에서는 광선 및 광선 투과 속성을 사용하여 3D 레이어에 이미지를 투영하는 방법을 보여 줍니다.

조명 만들기 및 조명 설정 변경

조명 레이어는 조명의 설정 및 3D 레이어의 [질감 옵션] 속성에 따라 조명이 비추는 3D 레이어의 색상에 영향을 줄 수 있습니다. 각 조명은 기본적으로 고유한 관심 영역을 가리킵니다.

조명은 3D 레이어를 비추고 그림자를 만드는 데 사용됩니다. 조명을 이용하여 합성 중인 장면의 조명 조건을 만들거나 보다 흥미로운 시각적인 결과를 만들 수 있습니다. 예를 들어 조명 레이어를 사용하여 스테인드 글래스로 만들어진 것처럼 비디오 레이어를 통과하는 조명을 만들 수 있습니다.

조명 유형 및 [그림자 표시] 속성을 제외한 모든 조명 설정에 애니메이션을 적용할 수 있습니다.

조명 유형: 집중 조명(왼쪽 위), 점(오른쪽 위), 평행광(왼쪽 아래), 주변광(오른쪽 아래)
조명 유형: 집중 조명(왼쪽 위), 점(오른쪽 위), 평행광(왼쪽 아래), 주변광(오른쪽 아래)

A. 관심 영역 B. 조명 아이콘 

조명을 조정 레이어로 지정해서 조명의 영향을 받을 3D 레이어를 지정할 수 있습니다. 이렇게 하려면 [타임라인] 패널에서 조명을 비추려는 레이어 위에 조명을 배치합니다. [타임라인] 패널의 레이어 겹침 순서에서 조명 조정 레이어 위에 있는 레이어는 [컴포지션] 패널의 레이어 위치에 관계 없이 조명을 받지 못합니다.

조명 만들기

  1. [레이어] > [새로 만들기] > [조명]을 선택하거나 Ctrl+Alt+Shift+L(Windows) 또는 Command+Option+Shift+L(Mac OS)을 누릅니다.

    조명을 만들면 조명에 조명 유형의 이름이 포함됩니다. 예를 들어 집중 조명을 추가하면 '집중 조명 1'이라는 이름이 지정됩니다.

    조명 유형을 변경하면 조명 유형의 이름도 자동으로 변경됩니다. 이름이 수정되지 않아도 조명 이름이 변경됩니다([타임라인] 패널에서 조명 유형이 변경되지 않은 경우에만). 예를 들어 '집중 조명 1'을 점광원으로 변경하면 광원의 이름도 자동으로 '점광원 1'로 변경됩니다.

    참고:

    기본적으로 새 레이어는 컴포지션 지속 시간의 시작 부분에서 시작됩니다. [컴포지션 시작 시 레이어 만들기] 환경 설정([편집] > [환경 설정] > [일반](Windows) 또는 [After Effects] > [환경 설정] > [일반](Mac OS))을 선택 해제하여 새 레이어가 현재 시간에서 시작되도록 선택할 수도 있습니다.

조명 설정 변경

  1. [타임라인] 패널에서 조명 레이어를 두 번 클릭하거나 레이어를 선택한 다음 [레이어] > [조명 설정]을 선택합니다.

    참고:

    대화 상자에서 설정을 수정한 대로 [컴포지션] 패널에 결과를 표시하려면 [조명 설정] 대화 상자의 [미리 보기]를 선택합니다.

조명 설정

조명 유형

[평행광]은 태양과 같이 무한하게 멀리 떨어진 광원으로부터 직선의 무제한적 조명을 방출합니다. [집중 조명]은 무대 제작에서 사용되는 플래시나 집중 조명처럼 광원뿔로 제한되는 광원으로부터 조명을 방출합니다. [점]은 전구 하나에서 나오는 광선과 같이 제한되지 않은 전방향 조명을 방출합니다. [주변광]은 광원이 없지만 장면의 전반적인 밝기에 영향을 주고 그림자를 표시하지 않는 조명을 만듭니다.

참고:

[주변광]의 공간 위치는 다른 레이어에 영향을 주지 않기 때문에 [주변광]은 [컴포지션] 패널에 아이콘이 없습니다.

강도

조명의 밝기입니다. 음수 값은 조명을 만들지 않습니다. 빛이 없는 상태에서는 레이어의 색상이 줄어듭니다. 예를 들어 이미 조명이 사용된 레이어에 다시 음수 값의 지향 조명을 비추면 레이어의 해당 영역이 어두워집니다.

색상

빛의 색상입니다.

광원뿔 각도

광원을 둘러싸는 광원뿔의 각도로, 먼 거리에 있는 빔의 폭을 결정합니다. 이 컨트롤은 [조명 유형]으로 [집중 조명]이 선택된 경우에만 활성화됩니다. [집중 조명]의 광원뿔 각도는 [컴포지션] 패널에 조명 아이콘 모양으로 표시됩니다.

참고:

After Effects CS6 이상에서 선택한 집중 조명의 광원뿔은 관심 영역으로 확장될 수 있습니다.

광원뿔 페더

집중 조명 가장자리의 부드러운 정도입니다. 이 컨트롤은 [조명 유형]으로 [집중 조명]이 선택된 경우에만 활성화됩니다.

밝기 감소

평행광, 집중 조명 또는 점광원에 대한 밝기 감소의 유형입니다. 밝기 감소는 거리가 멀어짐에 따라 조명 강도가 약해지는 방식을 묘사합니다.

조명 감소에 대한 세부 설명, 튜토리얼 및 리소스는 Adobe 웹 사이트의 문서를 참조하십시오.

밝기 감소의 유형은 다음과 같습니다.

없음

레이어와 광원 간의 거리가 멀어져도 조명이 줄어들지 않습니다.

매끄럽게

[밝기 감소 시작] 반경에서 시작하여 [밝기 감소 거리]에 지정된 길이만큼 확장되는 매끄러운 선형 밝기 감소를 나타냅니다.

반전 사각형 고정됨

[밝기 감소 시작] 반경에서 시작하여 해당 거리의 반전 사각형에 비례하여 감소하는 물리적으로 정확한 밝기 감소를 나타냅니다.

반경

조명으로부터 밝기 감소의 반경을 지정합니다. 이 거리 안에서 조명은 밝기가 일정합니다. 이 거리를 벗어나면 조명의 밝기가 감소합니다.

밝기 감소 거리

조명으로부터 밝기가 감소하는 거리를 지정합니다.

그림자 표시

광원으로 레이어에 그림자를 표시할 것인지 여부를 지정합니다. 그림자를 허용하려면 레이어에 대해 [그림자 허용] 질감 옵션을 [설정]으로 선택해야 합니다. 이 설정은 기본값입니다. 그림자를 표시하려면 레이어에 대해 [그림자 표시] 질감 옵션을 [설정]으로 선택해야 합니다. 이 설정은 기본값이 아닙니다.

참고:

선택한 레이어의 [그림자 표시]를 전환하려면 Alt+Shift+C(Windows) 또는 Option+Shift+C(Mac OS)를 누릅니다. [타임라인] 패널에서 [질감 옵션] 속성을 보려면 AA를 누릅니다.

그림자 농도

그림자의 농도를 설정합니다. 이 컨트롤은 [그림자 표시]가 선택된 경우에만 활성화됩니다.

그림자 확산

그림자를 표시하는 레이어의 거리에 따라 그림자의 부드러움을 설정합니다. 값이 클수록 그림자가 부드러워집니다. 이 컨트롤은 [그림자 표시]가 선택된 경우에만 활성화됩니다.

조명 관련 온라인 리소스

Eran Stern은 Creative COW 웹 사이트에서 어떤 빛이 어떤 레이어에 영향을 미치는지 정확하게 제어하기 위해 조정 레이어로 빛을 사용하는 방법을 설명하는 비디오 튜토리얼을 제공합니다.

ProVideo Coalition 웹 사이트에서 Chris와 Trish Meyer가 제공하는 문서를 통해 3D의 그림자와 조명에 대한 팁을 확인하십시오.

Trish와 Chris Meyer는 저서 After Effects Apprentice의 PDF 발췌 문서를 통해 3D 레이어, 조명 및 카메라를 사용하는 데 필요한 튜토리얼을 Focal Press 웹 사이트에서 제공합니다.

Chris와 Trish Meyer는 Artbeats 웹 사이트에서 조명 및 3D 레이어를 사용하여 벽과 같은 다른 레이어에 동영상을 투사하는 방법을 보여 주는 튜토리얼을 제공합니다.

3D 보기 조정 또는 카메라, 조명 또는 관심 영역 이동

카메라 레이어 및 조명 레이어에는 각각 카메라 또는 조명이 가리키는 컴포지션의 지점을 나타내는 [관심 영역] 속성이 포함됩니다. 기본적으로 관심 영역은 컴포지션의 가운데입니다. 언제라도 관심 영역을 이동할 수 있습니다.

1노드 카메라에서는 관심 영역이 무시됩니다. 카메라 설정을 참조하십시오.

조명이 관심 영역을 무시하도록 하려면 조명의 [자동 방향 설정] 옵션에서 [관심 영역 방향으로]가 아닌 다른 옵션을 선택합니다. 자세한 내용은 방향 자동 설정 옵션을 참조하십시오.

참고:

모든 속성과 마찬가지로 [타임라인] 패널에서 카메라 또는 조명의 속성을 직접 수정할 수 있습니다.

선택 및 회전 툴로 카메라, 조명 또는 관심 영역 이동

  1. 카메라 또는 조명 레이어를 선택합니다.
  2. [선택] 또는 [회전] 툴을 사용하여 다음 중 하나를 수행합니다.
    • 카메라 또는 조명과 관심 영역을 이동하려면 조정할 축 위로 포인터를 가져간 다음 드래그합니다.

    • 관심 영역을 움직이지 않고 단일 축을 따라 카메라나 조명을 이동하려면 Ctrl 키(Windows) 또는 Command 키(Mac OS)를 누른 상태에서 축을 드래그합니다.

    • 관심 영역을 이동하지 않고 카메라나 조명을 자유롭게 이동하려면 카메라 아이콘 또는 조명 아이콘을 드래그합니다.

    • 관심 영역을 이동하려면 관심 영역 아이콘 을 드래그합니다.

카메라 툴을 사용하여 카메라 또는 작업 중인 3D 보기 이동 또는 조정

[컴포지션] 패널에서 [카메라] 툴을 사용하여 카메라 레이어의 [위치] 및 [관심 영역] 속성을 조정할 수 있습니다.

또한 [카메라] 툴을 사용하여 카메라 레이어와 연결되지 않는 3D 보기인 작업 중인 3D 보기를 조정할 수도 있습니다. 3D 보기는 가상 카메라를 사용하여 컴포지션을 보거나 미리 보는 것과 같습니다. 작업 중인 3D 보기에는 사용자 정의 보기 및 고정 정사영 보기(앞쪽, 왼쪽, 위쪽, 뒤쪽, 오른쪽 또는 아래쪽)가 포함됩니다. 작업 중인 3D 보기는 3D 장면에 요소를 배치하고 미리 보는 데 유용합니다. 카메라 툴을 이용해서 작업 중인 3D 보기를 조정하는 경우 다른 레이어 속성 값은 영향을 받지 않습니다.

3D 보기를 수정한 후 [보기] > [3D 보기 다시 설정]을 선택하여 재설정할 수 있습니다.

고정 정사영 보기에서는 [궤도 카메라] 툴을 이용할 수 없습니다.

3D 보기를 선택하고 사용하는 방법에 대한 자세한 내용은 3D 보기 선택을 참조하십시오.

  1. [컴포지션] 패널 아래에 있는 [3D 보기] 메뉴에서 조정할 카메라 또는 3D 보기를 선택합니다.
  2. 카메라 툴을 활성화합니다.

    [툴] 패널에서 선택하거나 C를 눌러 [카메라] 툴을 전환하여 [카메라] 툴을 활성화할 수 있습니다. 여러 [카메라] 툴 간을 전환하는 가장 간편한 방법은 [통합 카메라] 툴을 선택하고 3버튼 마우스의 버튼을 사용하는 것입니다.

    궤도 카메라

    3D 보기 또는 카메라를 관심 영역 주위로 이동하여 회전합니다. [통합 카메라] 툴이 선택되어 있을 때 [궤도 카메라] 툴을 일시적으로 활성화하려면 마우스 왼쪽 버튼을 누르고 있습니다.

    참고:

    선택된 [통합 카메라 툴]을 Shift 키를 누른 상태로 드래그하면 [궤도 카메라 툴]이 일시적으로 활성화되고 회전이 하나의 축으로 제한됩니다.

    XY 카메라 추적

    3D 보기 또는 카메라를 가로 또는 세로로 조정합니다. [통합 카메라] 툴이 선택되어 있을 때 [XY 카메라 추적] 툴을 임시로 활성화하려면 마우스 가운데 버튼을 누르고 있습니다.

    Z 카메라 추적

    3D 보기 또는 카메라를 관심 영역 선을 따라 조절합니다. 정사영 보기를 사용 중인 경우 이 툴은 해당 보기의 비율을 조정합니다. [통합 카메라] 툴이 선택되어 있을 때 [Z 카메라 추적] 툴을 임시로 활성화하려면 마우스 오른쪽 버튼을 누르고 있습니다.

  3. [컴포지션] 패널에서 드래그합니다. 패널 내에서 드래그를 시작한 다음에는 패널 외부로 드래그를 이어갈 수 있습니다.

3D 보기를 수정한 후 [보기] > [3D 보기 다시 설정]을 선택하여 재설정할 수 있습니다.

카메라 또는 작업 중인 3D 보기를 이동 또는 조정하여 레이어 보기

또한 카메라를 이동하거나 3D 보기를 조정하여 선택한 레이어 또는 모든 레이어를 볼 수 있습니다. After Effects에서는 사용자가 선택한 레이어가 포함되도록 시점 및 보기 방향을 변경합니다.

  • 선택한 레이어를 볼 수 있도록 3D 보기를 조정하거나 카메라를 이동하려면 [보기] > [선택한 레이어 보기]를 선택합니다.
  • 모든 레이어를 볼 수 있도록 3D 보기를 조정하거나 카메라를 이동하려면 [보기] > [모든 레이어 보기]를 선택합니다.

이 명령에 대한 키보드 단축키는 3D 레이어(키보드 단축키)를 참조하십시오.

카메라/조명 이동 및 애니메이션 적용 관련 팁 및 온라인 리소스

카메라를 이동하기 전에 [활성 카메라]가 아닌 다른 보기를 선택합니다. [활성 카메라] 보기를 사용할 경우 카메라를 통해 보게 되므로 관리하기가 어렵습니다.

기본적으로 카메라의 와이어프레임은 카메라가 선택된 경우에만 표시됩니다. 항상 카메라 와이어프레임을 표시하려면 [컴포지션] 패널에 대한 보기 옵션을 설정하십시오([보기] > [보기 옵션]). 자세한 내용은 컴포지션 패널에서 레이어 컨트롤 표시 또는 숨기기를 참조하십시오.

카메라 또는 조명 레이어를 사용한 작업을 수행할 때는 Null 개체 레이어를 만들고 표현식을 사용하여 카메라 또는 조명의 [관심 영역] 속성을 Null 레이어의 [위치] 속성에 연결하십시오. 그러면 Null 개체를 이동해서 [관심 영역] 속성에 애니메이션을 적용할 수 있습니다. 일반적으로 관심 영역을 선택해서 보는 것보다는 Null 개체를 선택해서 보는 것이 더 쉽습니다.

After Effects에는 "Null 궤도 만들기"라는 카메라 명령이 있습니다. 선택한 카메라 레이어를 새로운 null 레이어에 부모로 지정합니다. 새 null 레이어의 이름은 카메라 이름 끝에 Orbit Null을 붙여 다시 지정됩니다.

Trish와 Chris Meyer는 Adobe TV의 이 비디오 튜토리얼에서 [Null 궤도 만들기] 카메라 명령을 사용하는 방법을 설명합니다.

카메라를 만들고 수정하는 방법과 [카메라] 툴을 사용하는 방법을 보여 주는 비디오 튜토리얼은 Adobe 웹 사이트를 참조하십시오.

Trish와 Chris Meyer는 저서 After Effects Apprentice의 PDF 발췌 문서를 통해 3D 레이어, 조명 및 카메라를 사용하는 데 필요한 튜토리얼을 Focal Press 웹 사이트에서 제공합니다.

Mark Christiansen은 Peachpit Press 웹 사이트에서 After Effects Studio Techniques의 "Virtual Cinematography in After Effects" 장을 통해 카메라 작업에 필요한 팁과 상세한 기법을 제공합니다. 이 장에는 렌즈 왜곡 일치, 카메라 이동, 카메라 프로젝션(카메라 매핑) 수행, 랙 포커스 사용, 보케 흐림 효과 만들기, 그레인 사용 및 이야기 속도와 일치하는 프레임 속도 선택에 대한 정보가 포함되어 있습니다.

Rich Young은 자신의 AE Portal 웹 사이트에서 toWorld 메서드를 사용하여 카메라와 조명을 레이어에 링크해 CC Sphere 효과를 적용하는 일련의 표현식을 제공합니다.

Creative Cow의 Andrew Devis는 카메라 애니메이션과 관련하여 다음 3가지 튜토리얼 시리즈를 제작했습니다.

video2brain의 이 비디오에서는 Null 궤도의 새 카메라를 만드는 명령을 설명합니다.

질감 옵션 속성

3D 레이어에는 3D 레이어와 조명 및 그림자의 상호 작용 방식을 결정하는 [질감 옵션] 속성이 있습니다.

그림자 표시

레이어가 다른 레이어에 그림자를 표시하도록 할 것인지 지정합니다. 그림자의 방향 및 각도는 광원의 방향 및 각도에 따라 결정됩니다. 레이어를 숨기고 그림자만 표시하려는 경우 [그림자 표시]를 [그림자 표시만]으로 설정합니다.

참고:

보이지 않는 레이어의 색상을 다른 레이어에 투영하려면 [그림자 표시만] 설정과 0 이외의 [광선 투과] 설정을 사용합니다. Steve Holmes는 Artbeats 웹 사이트에서 3D 장면 내의 특정 모양에 대한 그림자 표시가 [그림자 표시만]으로 설정된 레이어를 사용하는 방법을 설명하는 비디오 튜토리얼을 제공합니다.

광선 투과

레이어를 통과하는 조명의 비율로서, 해당 레이어의 색상을 다른 레이어에 그림자로 표시합니다. 0%로 설정하면 조명이 레이어를 통과하지 못해 검정 그림자가 표시됩니다. 100%로 설정하면 그림자를 표시하는 레이어의 전체 색상 값이 그림자를 허용하는 레이어에 투영됩니다.

참고:

스테인드 글라스 창을 통과하는 빛의 모양을 만들려면 부분 광선 투과를 사용하십시오.

그림자 허용

다른 레이어에 의한 그림자를 레이어에 표시할 것인지 지정합니다. 레이어의 그림자만 렌더링하려는 경우 [그림자 허용] 메뉴에서 [그림자 표시만] 옵션을 사용할 수 있습니다.

조명 허용

레이어에 도달하는 조명이 레이어의 색상에 영향을 미치는지 여부를 지정합니다. 이 설정은 그림자에는 영향을 주지 않습니다.

주변광

레이어 주변광(무지향 조명)의 반사도를 나타냅니다. 100%로 설정하면 가장 높은 반사도가 지정되고 0%로 설정하면 주변광의 반사도가 사용되지 않습니다.

확산

레이어의 확산(전방향 조명) 반사도를 나타냅니다. 레이어에 확산 반사도를 적용하면 레이어 위에 무딘 비닐 종이를 덮어 씌우는 것과 같은 효과를 줍니다. 이 레이어에 떨어지는 조명은 모든 방향으로 고르게 반사됩니다. 100%로 설정하면 가장 높은 반사도가 지정되고 0%로 설정하면 확산 반사도가 사용되지 않습니다.

반사

레이어 반사광(지향 조명)의 반사도를 나타냅니다. 반사광은 거울에서와 같이 레이어에서 반사됩니다. 100%로 설정하면 가장 높은 반사도가 지정되고 0%로 설정하면 반사도가 사용되지 않습니다.

밝기

반사면의 크기를 결정합니다. 이 값은 [반사] 설정이 0보다 큰 경우에만 활성화됩니다. 100%로 설정하면 폭이 좁은 반사면이 지정되고 0%로 설정하면 폭이 넓은 반사면이 지정됩니다.

메탈

반사면의 색상에 레이어 색상이 주는 영향 정도입니다. 100%로 설정하면 반사면의 색상이 레이어의 색상이 됩니다. 예를 들어 [메탈] 값이 100%인 경우 금반지 이미지에서는 금빛 조명이 반사됩니다. 0%로 설정하면 반사면의 색상이 조명 소스의 색상이 됩니다. 예를 들어 [메탈] 값이 0%인 레이어에 흰색 빛을 비추면 흰색 빛이 반사됩니다.

그림자 렌더링에 사용할 해상도 지정

교차하는 3D 레이어가 포함된 컴포지션을 렌더링할 때는 고급 3D 렌더링 플러그인이 사용됩니다. 그림자를 렌더링하기 위해 이 플러그인은 각 광원의 시점에서 렌더링되는 이미지인 그림자 맵을 사용합니다. 일반적으로 그림자 해상도는 컴포지션 해상도 및 레이어의 품질 설정에 따라 자동으로 계산됩니다. 일반적인 해상도로 원하는 품질을 얻을 수 없거나 렌더링 속도가 너무 느리면 그림자 맵 해상도를 조정할 수 있습니다. 예를 들어 그림자가 너무 흐리게 표시되고 [그림자 확산] 질감 옵션이 0으로 설정된 경우 그림자 맵 해상도를 높입니다. 또는 그림자 렌더링 속도가 너무 느린 경우 그림자 맵 해상도를 낮춥니다.

그림자를 표시하는 레이어가 다른 레이어와 교차되는 경우 그림자가 표시될 교차 부분 뒤에 약간의 간격이 발생할 수 있습니다. 이러한 간격의 크기를 줄이려면 그림자 맵 해상도를 높입니다.

입체 3D

Adobe After Effects로 입체 3D 비디오를 만들 수 있습니다.

입체 3D에 대한 세부 설명, 튜토리얼 및 리소스는 Adobe 웹 사이트의 문서를 참조하십시오.

After Effects의 입체 3D 워크플로 개요는 After Effects의 입체 3D 이해를 참조하십시오.

Mark Christiansen은 (Art Beats의 무료 클립을 사용하여) 입체 3D 푸티지를 합성하는방법을 보여 줍니다.

입체 3D 카메라 리그

After Effects 에는 3D 컴포지션을 입체 3D 컴포지션으로 바꿀 수 있는 스테레오 3D 리그 만들기 메뉴 명령이 있습니다. 스테레오 3D 리그는 3D 안경 효과를 비롯해 모든 요소를 만듭니다.

먼저 3D 요소가 있는 컴포지션을 만들어서 입체 3D 카메라 리그를 만드십시오. 3D 축소 프리컴포지션 또는 3D 요소 등의 항목을 컴포지션 자체에 포함하고 있는 컴포지션이 제대로 작동합니다. 이미 사용 중인 카메라가 있는 경우 입체 3D 카메라 리그를 만들 때 선택할 수 있습니다. 선택된 카메라가 없으면 "마스터 카메라"라는 이름의 새 카메라가 만들어집니다. [레이어] > [카메라] > [스테레오 3D 리그 만들기]를 선택하십시오. 리그는 2노드 카메라에서만 작동합니다.

리그는 마스터 카메라를 만들거나 컴포지션에서 기존의 선택된 카메라를 사용하여 생성할 수 있습니다. 왼쪽 시점[왼쪽 시점 비교] 및 오른쪽 시점[오른쪽 시점 비교] 컴포지션이 있습니다. 각 컴포지션에는 마스터 카메라에 연결된 카메라, 그 안에 중첩된 원본 컴포지션 그리고 출력 스테레오 3D 컴포지션[스테레오 3D 비교]이 있습니다. 출력 스테레오 3D 컴포지션은 두 시점 컴포지션을 중첩하며 스테레오 3D 컨트롤이라는 레이어를 포함합니다. 이 레이어에는 리그 제어를 위한 스테레오 3D 컨트롤 효과와 왼쪽 시점 및 오른쪽 시점 컴포지션을 하나의 스테레오 이미지로 결합하는 3D 안경 효과가 포함되어 있습니다. 3D 안경 효과를 참조하십시오.

참고:

스테레오 3D 컨트롤 효과는 스테레오 3D 리그의 일부분으로 생성되는 효과이며 [효과 및 사전 설정] 패널에 들어 있지 않습니다.

스테레오 3D 컨트롤 효과에는 다음과 같은 카메라 분리 및 수렴에 대한 설정이 있습니다.

구성

가운데는 왼쪽 및 오른쪽 카메라를 마스터 카메라의 양쪽에 배치합니다. 주인공 왼쪽은 오른쪽 카메라가 오른쪽에 있는 마스터 카메라와 동일한 지점에 왼쪽 카메라를 배치합니다. 반대로 주인공 오른쪽은 왼쪽 카메라가 왼쪽에 있는 마스터 카메라 위치에 오른쪽 카메라를 배치합니다.

스테레오 장면 심도

카메라 사이의 축 간 분리를 컴포지션 폭의 백분율로 제어합니다. 따라서 컴포지션의 크기가 변경되더라도 분리 수치는 일정합니다. 이 설정은 효과를 미묘하게 유지하기 위해 3%라는 낮은 값에서 시작됩니다. 이상적인 경우 이 값은 합당한 3D 푸티지에 대해 14%-30%보다 더 높아질 필요가 없습니다. 하지만 장면 내용(객체가 서로 매우 가깝게 붙어 있음), 카메라 시야 등에 따라 더 클 수도 있습니다.

참고:

이 값을 변경하면 스테레오 3D 장면에서 안부터 밖까지 가는 심도에 영향을 줍니다. 값을 너무 높게 밀면 눈에 피로감을 줄 수 있습니다.  

카메라 수렴

이 설정을 끄면 카메라는 마스터 카메라와 평행하게 유지되지만 양쪽으로 오프셋됩니다. 이 설정을 켜면 위치가 오프셋으로 남게 됩니다. 하지만 왼쪽 및 오른쪽 카메라의 관심 영역은 다음의 두 속성을 기준으로 하는 위치에 결합됩니다.

수렴 대상 및 수렴 Z 오프셋

3D 안경을 통해 볼 때 화면이 카메라로부터 떨어져서 나타날 Z 거리를 결정합니다. Z 공간에서 멀리 있을수록 화면 안쪽으로 들어가 있는 것처럼 보이고, 가까이 있을수록 화면에서 튀어나온 것처럼 보입니다. 카메라 수렴 확인란을 선택하지 않고 작업 중이며 카메라가 병렬일 때는 장면 수렴을 변경하는 것이 Z 오프셋을 변경하는 것과 같은 효과를 갖습니다. 이 경우에는 차이 모드를 사용하여 장면 대 장면 공간에 서로 다른 요소를 설정하십시오. 3D 안경 효과를 참조하십시오.

입체 3D 시작하기

입체 3D를 사용하여 작업하는 경우 3D TV가 반드시 있어야 하는 것은 아닙니다. 예를 들어 입체 사진(빨강-청록) 3D 안경을 끼고 [컴포지션] 패널에서 직접 3D 입체 푸티지를 볼 수 있습니다. 하지만 3D TV가 있으면 3D TV와 액티브 셔터 안경을 사용하여 실시간 편집을 수행할 수 있습니다. 이러한 워크플로를 시작하려면 다음과 같은 몇 가지가 필요합니다.

  • 3D 입체 보기를 지원하는 모니터 또는 TV
  • 입체 3D TV를 보기 위한 안경

참고:

이 워크플로를 위해서는 액티브 셔터 안경을 사용해야 하고, 이와 함께 방출기가 필요합니다. TV 제조업체에서 권장하는 안경을 사용하십시오.

  • 입체 푸티지 또는 3D 컴포지션

이 모든 것이 준비되었으면 다음을 수행하십시오.

  1. HDMI 케이블을 사용하여 컴퓨터를 3D TV에 연결합니다(HDMI를 사용할 수 없는 경우 DVI 사용 가능).

  2. After Effects에서 3D 컴포지션을 만듭니다. 컴포지션 크기가 출력 모니터의 현재 해상도와 일치하는지 확인합니다.

  3. 스테레오 3D 컴포지션에 대한 새 [컴포지션] 패널을 만듭니다. 컴포지션을 잠근 후에 3D TV 모니터로 드래그합니다.

  4. [컴포지션] 패널이 100%로 설정되어 있는지 확인합니다.

  5. Control + \(백슬래시)를 두 번 입력하여 컴포지션을 3D TV에 대해 전체 화면으로 설정합니다. 컴포지션 및 3D TV의 크기가 동일하도록 설정합니다.

  6. 3D 안경 효과에서 3D 보기를 다음 중 하나로 전환합니다.

    • 스테레오 쌍

    • 위쪽 아래쪽

    • 인터레이스

  7. 3D TV에서 3D 모드를 켜고, 포맷을 3D 안경 효과에 대해 [3D 보기]에서 설정된 항목에 맞춥니다. [스테레오 쌍] 및 [위쪽 아래쪽]은 대다수 3D TV에서 지원됩니다.

  8. 3D 안경을 착용하고 진정한 입체 3D에서 컴포지션을 편집합니다.

입체 3D 팁

  • 3D TV 없이 [컴포지션] 패널에서 3D 입체 푸티지를 사용하는 경우 입체 사진 포맷으로 작업할 수 있습니다. 이 3D 입체 워크플로에는 일반 빨강 및 청록 입체 사진 3D 안경이 가장 적합합니다.

  • 3D 환경이 얼마나 깊이 있게 나타나는지를 변경하려면 [스테레오 장면 심도]를 늘리거나 줄이십시오.

  • 다른 객체를 화면 앞으로 또는 뒤로 이동하려면 [카메라 수렴]을 켜고 [수렴 Z 오프셋]을 변경하십시오. Z 오프셋보다 카메라에 가까운 객체는 화면 앞쪽에 나타나고, 그보다 먼 객체는 뒤에 나타닙니다.

  • 다음 중 하나를 수행하여 컴포지션의 피사계 심도가 입체 카메라의 수렴과 일치하도록 할 수 있습니다.

    • 마스터 카메라에서 “[피사체와의 거리]를 [관심 영역]에 연결”을 사용하고 리그에 대해 수렴 카메라를 사용하는 경우 피사계 심도와 입체 3D 수렴이 일치합니다.

    • 시간이 흐름에 따라 피사계 심도가 변경되도록 하려면 마스터 카메라의 피사체와의 거리에 애니메이션을 적용하면 됩니다. 그런 다음, “카메라 위치”로부터 수렴하도록 수렴 지점을 설정하고 수렴 Z 오프셋을 마스터 카메라의 피사체와의 거리에 연결하는 표현식을 설정합니다

이 작업에는 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License의 라이센스가 부여되었습니다.  Twitter™ 및 Facebook 게시물은 Creative Commons 약관을 적용받지 않습니다.

법적 고지 사항   |   온라인 개인 정보 보호 정책