사용 안내서 취소

알파 채널, 마스크 및 매트

  1. After Effects 사용 안내서
  2. Beta 릴리스
    1. Beta 프로그램 개요
    2. After Effects Beta 홈
    3. Beta의 기능
      1. 속성 패널(Beta)
  3. 시작하기
    1. After Effects 시작하기
    2. After Effects의 새로운 기능 
    3. 릴리스 정보 | After Effects
    4. After Effects 시스템 요구 사항
    5. After Effects 키보드 단축키
    6. 지원하는 파일 형식 | After Effects
    7. 하드웨어 권장 사항
    8. Apple Silicon용 After Effects
    9. 계획 및 설정
    10. 설정 및 설치
  4. 작업 영역
    1. 일반 사용자 인터페이스 항목
    2. After Effects 인터페이스 알아보기
    3. 워크플로우
    4. 작업 영역, 패널, 뷰어
  5. 프로젝트 및 컴포지션
    1. 프로젝트
    2. 컴포지션 기본 사항
    3. 사전 구성, 중첩, 사전 렌더링
    4. 컴포지션 프로파일러를 사용하여 자세한 성능 정보 보기
    5. Cinema 4D 컴포지션 렌더러
  6. 푸티지 가져오기
    1. 스틸 이미지 준비 및 가져오기
    2. After Effects 및 Adobe Premiere Pro에서 가져오기
    3. 비디오와 오디오 가져오기 및 해석
    4. 3D 이미지 파일 준비 및 가져오기
    5. 푸티지 항목 가져오기 및 해석
    6. 푸티지 항목을 사용한 작업
    7. [장면 편집 감지]를 사용하여 편집 지점 감지
    8. XMP 메타데이터
  7. 텍스트 및 그래픽
    1. 텍스트
      1. 문자 서식 지정 및 문자 패널
      2. 텍스트 효과
      3. 텍스트 레이어 만들기 및 편집
      4. 단락 서식 지정 및 단락 패널
      5. 돌출 텍스트 및 모양 레이어
      6. 텍스트에 애니메이션 적용
      7. 텍스트 애니메이션 예제 및 리소스
      8. 라이브 텍스트 템플릿
    2. 모션 그래픽
      1. After Effects에서 모션 그래픽 템플릿을 사용해 작업하기
      2. 표현식을 사용하여 모션 그래픽 템플릿에 드롭다운 목록 만들기
      3. 기본 속성으로 모션 그래픽 템플릿 만들기
      4. 모션 그래픽 템플릿에서 이미지와 비디오 바꾸기 및 기본 속성
  8. 그리기, 페인트, 패스
    1. 모양 레이어, 패스, 벡터 그래픽 개요
    2. 페인트 도구: 브러쉬, 복제 도장, 지우개
    3. 모양 선 테이퍼하는 방법
    4. 모양 레이어의 모양 속성, 페인트 작업, 패스 작업
    5. 오프셋 패스 모양 효과를 통한 모양 변경
    6. 모양 만들기
    7. 마스크 만들기
    8. 내용 인식 채우기 패널로 비디오에서 개체 제거
    9. 로토 브러시와 매트 다듬기
  9. 레이어, 마커, 카메라
    1. 레이어 선택 및 정렬
    2. 혼합 모드와 레이어 스타일
    3. 3D 레이어
    4. 레이어 속성
    5. 레이어 만들기
    6. 레이어 관리
    7. 레이어 마커와 컴포지션 마커
    8. 카메라, 조명 및 관심 영역
  10. 애니메이션, 키프레임, 동작 추적, 키잉
    1. 애니메이션
      1. 애니메이션 기본 사항
      2. 퍼펫 도구를 사용한 애니메이션
      3. 모양 패스와 마스크를 관리하고 애니메이션을 적용하기
      4. After Effects를 사용하여 스케치 및 캡처 모양에 애니메이션 적용하기
      5. 종합 애니메이션 도구
      6. 데이터 기반 애니메이션 작업
    2. 키프레임
      1. 키프레임 보간
      2. 키프레임 설정, 선택 및 삭제
      3. 키프레임 편집, 이동 및 복사
    3. 동작 추적
      1. 동작 추적 및 안정화
      2. 얼굴 추적
      3. 마스크 추적
      4. 마스크 참조
      5. 속도
      6. 시간 스트레치와 시간 다시 매핑
      7. 시간 코드 및 시간 표시 단위
    4. 키잉
      1. 키잉
      2. 키잉 효과
  11. 투명도 및 합성
    1. 합성과 투명도 개요 및 리소스
    2. 알파 채널, 마스크 및 매트
  12. 색상 조정
    1. 색상 기본 사항
    2. Adobe Color 테마 확장 사용
    3. 색상 관리
    4. 색상 교정 효과
  13. 효과 및 애니메이션 사전 설정
    1. 효과 및 애니메이션 사전 설정 개요
    2. 효과 목록
    3. 시뮬레이션 효과
    4. 스타일화 효과
    5. 오디오 효과
    6. 왜곡 효과
    7. 원근 효과
    8. 채널 효과
    9. 생성 효과
    10. 전환 효과
    11. 롤링 셔터 복구 효과
    12. 흐림 및 선명 효과
    13. 3D 채널 효과
    14. 유틸리티 효과
    15. 매트 효과
    16. 노이즈 및 그레인 효과
    17. 세부 사항-확대 유지 효과
    18. 더 이상 사용되지 않는 효과
  14. 표현식 및 자동화
    1. 표현식
      1. 표현식 기본 사항
      2. 표현식 언어 이해
      3. 표현식 컨트롤 사용
      4. JavaScript와 레거시 ExtendScript 표현식 엔진 간 구문 차이
      5. 표현식 편집
      6. 표현식 오류
      7. 표현식 편집기 사용
      8. 표현식을 사용하여 텍스트 속성 편집 및 액세스
      9. 표현식 언어 참조
      10. 표현식 예제
    2. 자동화
      1. 자동화
      2. 스크립트
  15. 몰입형 비디오, VR 및 3D
    1. After Effects에서 VR 환경 만들기
    2. 몰입형 비디오 효과 적용
    3. VR/360 비디오용 합성 툴
    4. 3D 카메라 움직임 추적
    5. 3D 디자인 공간에서 작업하기
    6. 3D 변형 기즈모
    7. 3D 애니메이션을 사용하여 더 많은 작업 수행
    8. 실시간 엔진을 통해 3D 디자인 변경 내용 실시간 미리 보기
    9. 그래픽에 반응형 디자인 추가 
  16. 보기 및 미리 보기
    1. 미리 보기
    2. Mercury Transmit를 사용한 비디오 미리 보기
    3. 보기 수정 및 사용
  17. 렌더링 및 내보내기
    1. 렌더링 및 내보내기 기본 사항
    2. After Effects 프로젝트를 Adobe Premiere Pro 프로젝트로 내보내기
    3. 동영상 변환
    4. 멀티 프레임 렌더링
    5. 자동 렌더링 및 네트워크 렌더링
    6. 스틸 이미지와 스틸 이미지 시퀀스 렌더링 및 내보내기
    7. After Effects에서 GoPro CineForm 코덱 사용
  18. 기타 애플리케이션으로 작업
    1. Dynamic Link 및 After Effects
    2. After Effects 및 기타 애플리케이션으로 작업
    3. After Effects의 설정 동기화
    4. After Effects의 Creative Cloud Libraries
    5. 플러그인
    6. CINEMA 4D 및 Cineware
  19. 공동 작업: Frame.io, Team Projects
    1. Premiere Pro 및 After Effects의 공동 작업
    2. Frame.io
      1. Frame.io 설치 및 활성화
      2. Frame.io를 Premiere Pro 및 After Effects와 함께 사용하기
      3. 자주 묻는 질문
    3. Team Projects
      1. Team Projects 시작 하기
      2. 팀 프로젝트 만들기
      3. Team Projects 공동 작업
  20. 메모리, 저장소, 성능
    1. 메모리 및 저장소
    2. 성능 향상
    3. 환경 설정
    4. After Effects의 GPU 및 GPU 드라이버 요구 사항

알파 채널 및 매트

After Effects의 색상 정보는 빨강(R), 녹색(G), 파랑(B) 세 가지 채널에 들어 있습니다. 또한, 이미지는 알파 채널이라는 보이지 않는 네 번째 채널을 포함할 수 있는데, 이 채널에는 투명도 정보가 들어 있습니다. 이런 이미지의 경우 알파 채널이 포함되어 있다는 것을 나타내기 위해 RGBA 이미지라고 부르기도 합니다.

채널 소개

A. 분리된 색상 채널 B. 회색 명암 이미지로 표현된 알파 채널 C. 투명 영역을 통해 표시되는 배경과 함께 네 개의 채널을 모두 사용한 합성 

Adobe Photoshop, ElectricImage, FLV, TGA, TIFF, EPS, PDF, Adobe Illustrator 등 많은 파일 포맷이 알파 채널을 포함할 수 있습니다. AVI 및 QuickTime(수백만 색상 이상의 비트 심도로 저장)에는 이러한 컨테이너에 저장된 이미지를 생성하는 데 사용되는 코덱(인코더)에 따라 알파 채널이 포함될 수도 있습니다. Adobe Illustrator EPS 및 PDF 파일의 경우 After Effects는 비어 있는 영역을 자동으로 알파 채널로 변환합니다.

출력 이미지에 대한 색상 심도를 지정할 때 더하기 기호(수백만 색상 이상에서와 같이)는 알파 채널을 나타냅니다. 마찬가지로 32bpc(픽셀당 비트 수)로 출력하도록 선택하면 RGBA 네 개 채널의 각 채널에 대한 출력 수준은 8bpc가 됩니다.

일부 프로그램은 한 이미지에 여러 알파 채널을 저장할 수 있지만 After Effects에서는 네 번째 채널만 알파 채널로 해석합니다.

참고:

알파 채널이라는 용어는 기술적으로 RGBA 이미지 파일의 네 번째(A) 채널을 뜻하며 채널이 투명도 정보를 전달하는 데 사용되는지 여부와는 관계 없습니다. 그러나 네 번째 채널이 투명도 정보를 전달하는 데 자주 사용되기 때문에 일반적으로 알파투명도라는 용어는 동의어로 간주됩니다. 그러나 이러한 연관성은 임의적인 것임을 유념해야 합니다. 투명도 정보를 전달하는 데 다른 채널을 사용하는 포맷도 있고 투명도 정보가 아닌 다른 정보에 네 번째 채널을 사용하는 포맷도 있습니다.

Knoll Unmult 플러그인을 사용하여 레이어의 어두운 영역에서 알파 채널을 만들 수 있습니다. 이 기능은 다른 레이어 위에 합성하려는 조명 효과(예: 렌즈 플레어 또는 불)가 있는 레이어에 잘 작동합니다. 자세한 내용은 Red Giant Software 웹사이트를 참조하십시오.

[컴포지션] 패널에서 알파 채널을 보는 경우 흰색은 완전한 불투명도를 나타내고 검정은 완전한 투명도를 나타내며, 회색 음영은 부분적 투명도를 나타냅니다.

매트는 해당 레이어나 다른 레이어의 투명 영역을 정의하는 레이어(또는 레이어의 채널)입니다. 흰색은 불투명 영역을 정의하고 검정은 투명 영역을 정의합니다. 알파 채널이 매트로 자주 사용되지만 알파 채널보다 원하는 투명 영역을 효과적으로 정의하는 채널이나 레이어가 있거나 소스 이미지에 알파 채널이 포함되어 있지 않은 경우 매트를 알파 채널 이외의 용도로 사용할 수 있습니다.

마스크

After Effects의 마스크는 레이어 특성, 효과 및 속성을 수정하는 매개 변수로 사용되는 패스입니다. 마스크는 가장 일반적으로 각 픽셀에서 레이어의 투명도를 결정하는 레이어의 알파 채널을 수정하는 데 사용됩니다. 또한 마스크는 일반적으로 텍스트 애니메이션을 적용하는 패스로도 사용됩니다. 자세한 내용은 패스에 텍스트 만들기 및 애니메이션 적용을 참조하십시오.

일반적인 패스에 대한 자세한 내용은 패스를 참조하십시오.

그려진 마스크의 기본 동작(왼쪽), 반전된 동일한 마스크 (오른쪽)

닫힌 패스의 마스크로 레이어의 투명 영역을 만들 수 있습니다. 열린 패스는 레이어의 투명 영역을 만들 수는 없지만 효과의 매개 변수로 유용하게 사용할 수 있습니다. 열린 마스크 패스나 닫힌 마스크 패스를 입력으로 사용할 수 있는 효과로는 [선], [패스 텍스트], [오디오 파형], [오디오 스펙트럼], [베가스] 등이 있고, 닫힌 마스크(열린 마스크 제외)를 입력으로 사용할 수 있는 효과로는 [칠], [문지르기], [모양 변경], [입자 필드] 및 [내부/외부 키]가 있습니다.

마스크는 특정 레이어에 속합니다. 각 레이어는 여러 개의 마스크를 포함할 수 있습니다.

모양 도구를 사용하여 다각형, 타원, 별 모양 등의 일반적인 기하학적 모양으로 마스크를 그리거나 펜 도구를 사용하여 임의의 패스를 그릴 수 있습니다.

마스크 패스의 편집과 보간을 위한 몇 가지 추가 기능이 있다는 것을 제외하면 마스크 패스를 그리는 것은 모양 레이어에서 모양 패스를 그리는 것과 거의 모든 면에서 동일합니다. 표현식을 사용하면 마스크 패스를 모양 패스에 연결할 수 있습니다. 이렇게 하면 모양 레이어에서 마스크를 이용하거나 마스크에서 모양 레이어를 이용할 수 있습니다. 자세한 내용은 모양 및 마스크 만들기모양 패스와 마스크 편집 및 애니메이션 적용을 참조하십시오.

[타임라인] 패널의 겹침 순서에서 마스크의 위치는 다른 마스크와의 상호 작용 방식에 영향을 줍니다. [타임라인] 패널에서 마스크를 [마스크] 속성 그룹 내의 다른 위치로 드래그할 수 있습니다.

마스크의 [마스크 불투명도] 속성은 마스크 영역 내부의 레이어 알파 채널에 대한 닫힌 마스크의 영향을 결정합니다. [마스크 불투명도] 값이 100%이면 불투명한 내부 영역에 해당합니다. 마스크 외부 영역은 항상 투명합니다. 특정 마스크의 내부와 외부를 반전시키려면 [타임라인] 패널에서 마스크 이름 옆에 있는 [반전]을 선택합니다.

마스크 복사, 잘라내기, 저장, 재사용, 삭제

다른 레이어 및 컴포지션에서 마스크를 다시 사용할 수 있습니다. 이는 오랜 시간에 걸쳐 완성한 베지어 마스크에 특히 유용합니다. 마스크 패스는 프로젝트 파일의 컴포지션 내에 저장됩니다.

마스크 복사, 잘라내기, 복제 또는 붙여넣기

참고:

다른 속성을 포함한 전체 마스크를 사용하는 대신 마스크 패스를 사용하여 작업할 때는 [마스크 패스] 속성을 선택해야 합니다. 이는 마스크 패스를 모양 패스, 동작 패스 등으로 변환할 때 특히 중요합니다.

  • 선택한 마스크를 클립보드로 복사하거나 잘라내려면 [편집] > [복사] 또는 [편집] > [잘라내기]를 선택합니다.
  • 선택한 마스크를 복제하려면 [편집] > [복제]를 선택합니다.
  • 마스크를 레이어에 붙여넣으려면 레이어를 선택한 다음 [편집] > [붙여넣기]를 선택합니다. 마스크를 선택한 상태인 경우 이 작업이 선택되어 있는 마스크 대신 사용됩니다.

마스크 저장

  1. 저장할 레이어와 마스크가 있는 컴포지션의 [타임라인] 패널에서 레이어와 해당 마스크 속성을 확장합니다.
  2. 다음 중 하나를 수행합니다.
    • 애니메이션이 적용된 마스크를 저장하려면 저장할 마스크 키프레임을 선택합니다.
    • 애니메이션이 없는 마스크를 저장하려면 마스크를 선택합니다.
  3. 마스크 또는 키프레임을 복사하여 새 레이어에 마스크 또는 키프레임을 붙여 넣습니다. 새 레이어는 단색으로 지정할 수 있습니다.
참고:

복잡한 마스크를 저장만 하려면 컴포지션이 있는 프로젝트를 만듭니다. 다른 프로젝트의 마스크를 사용하려면 해당 프로젝트를 현재 프로젝트로 가져옵니다.

참고:

마스크를 애니메이션 사전 설정으로 저장할 수도 있습니다. 애니메이션 사전 설정을 참조하십시오.

마스크 재사용

  1. 재사용할 마스크가 들어 있는 컴포지션을 엽니다. 마스크를 다른 프로젝트에 저장한 경우 프로젝트를 가져온 다음 마스크가 포함된 컴포지션을 엽니다.
  2. [타임라인] 패널에서 마스크에 대한 레이어 및 마스크 속성을 확장합니다.
  3. 마스크 또는 키프레임을 선택합니다.
  4. 마스크 또는 키프레임을 복사한 후 마스크를 적용하려는 레이어에 마스크 또는 키프레임을 붙여 넣습니다.

마스크 삭제

  • 마스크 하나를 삭제하려면 [타임라인] 패널에서 마스크를 선택하고 Delete 키를 누릅니다.
  • 모든 마스크를 삭제하려면 삭제하려는 마스크가 들어 있는 레이어를 선택하고 [레이어] > [마스크] > [모든 마스크 제거]를 선택합니다.

마스크 패스 색상 제어

마스크를 쉽게 확인하고 작업할 수 있도록 [컴포지션] 및 [레이어] 패널에 마스크 패스가 색상으로 표시되고 [타임라인] 패널의 해당 마스크 이름 옆에 같은 색상이 표시됩니다. 기본적으로 After Effects는 모든 마스크에 노란색을 사용합니다. 각 마스크를 구분하기 쉽게 만들려면 [타임라인] 패널을 사용하여 마스크의 색상을 수동으로 변경하거나 새 마스크에 일련의 마스크 색상이 순환하여 지정되도록 After Effects를 설정할 수 있습니다.

마스크 패스에 대비 색상 사용 환경 설정(환경 설정 > 모양 아래)이 활성화되면 After Effects에서는 마스크 그리기 시작 지점에서 색상을 분석합니다. 그런 다음에는 After Effects에서 해당 영역의 색상과는 다른 레이블 색상을 선택합니다. 또한 마지막으로 그려진 마스크의 색상은 사용하지 않습니다.

마스크 패스 색상 변경

  1. [타임라인] 패널에서 마스크를 선택합니다.
  2. 마스크 이름 왼쪽에 있는 색상 견본을 클릭하고 새 색상을 선택한 다음 [확인]을 클릭합니다.

마스크 패스의 색상 순환

  1. [편집] > [환경 설정] > [모양]을 선택합니다.
  2. [마스크 색상 반복]을 선택합니다.

마스크 모드

마스크의 혼합 모드(마스크 모드)는 레이어 내에서 마스크가 다른 마스크와 상호 작용하는 방식을 제어합니다. 기본적으로 모든 마스크는 [추가]로 설정됩니다. 이 설정은 동일한 레이어에서 겹치는 모든 마스크의 투명도 값을 결합합니다. 각 마스크에 모드를 적용할 수 있지만 마스크의 모드에 애니메이션을 적용할 수는 없습니다. 즉, 마스크 모드 속성에 키프레임 또는 표현식을 설정하여 시간 경과에 따라 변경되도록 할 수 없습니다.

[타임라인] 패널의 마스크 이름 옆에 있는 메뉴에서 마스크의 마스크 모드를 선택할 수 있습니다.

첫 번째로 만든 마스크가 레이어의 알파 채널과 상호 작용합니다. 해당 채널에서 전체 이미지를 불투명으로 정의하지 않으면 마스크가 레이어 프레임과 상호 작용합니다. 이후에 추가로 만드는 각 마스크는 [타임라인] 패널의 순서에서 위쪽에 있는 마스크와 상호 작용합니다. 마스크 모드의 결과는 순서 상 위쪽에 있는 마스크에 설정된 모드에 따라 달라집니다. 마스크 모드는 동일한 레이어에 있는 마스크 간에만 작동합니다.

마스크 모드를 사용하면 여러 투명 영역으로 복잡한 복합 마스크를 만들 수 있습니다. 예를 들어 마스크 두 개를 결합하는 마스크 모드를 설정하고 두 마스크가 교차하는 영역은 불투명 영역으로 설정할 수 있습니다.

원형 마스크에 서로 다른 모드가 적용된 결과를 보여 주는 복합 마스크입니다. 이 그림의 마스크는 서로 다른 마스크 불투명도 값을 가지고 있습니다.

A. 원본 마스크 B. 없음 C. 더하기 D. 빼기 E. 교차 F. 밝게 G. 어둡게 H. 차이 

없음

이 마스크는 레이어의 알파 채널에 직접적인 영향을 주지 않습니다. [선] 또는 [칠] 같은 효과에 마스크 패스를 사용하거나 모양 패스의 기반으로 마스크 패스를 사용할 경우 이 옵션이 유용합니다.

더하기

마스크가 순서 상 위쪽의 마스크에 추가됩니다. 마스크의 영향은 위쪽 마스크에 누적됩니다.

빼기

마스크의 영향이 상위 마스크에서 제거됩니다. 다른 마스크의 중심에 구멍 모양을 만들려고 할 때 이 옵션이 유용합니다.

교차

마스크가 순서 상 위쪽의 마스크에 추가됩니다. 마스크가 위에 있는 마스크와 겹치는 영역에서는 마스크의 영향이 상위 마스크에 누적됩니다. 마스크가 상위 마스크와 겹치지 않는 영역에서는 결과물이 완전히 불투명해집니다.

밝게

마스크가 순서 상 위쪽의 마스크에 추가됩니다. 여러 마스크가 교차하는 영역에서는 가장 높은 투명도 값이 사용됩니다.

어둡게

마스크가 순서 상 위쪽의 마스크에 추가됩니다. 여러 마스크가 교차하는 영역에서는 가장 낮은 투명도 값이 사용됩니다.

차이

마스크가 순서 상 위쪽의 마스크에 추가됩니다. 마스크가 위에 있는 마스크와 겹치지 않는 영역에서는 마스크가 레이어에 단독으로 있는 것처럼 작동하고, 마스크가 위에 있는 마스크와 겹치는 영역에서는 마스크의 영향이 상위 마스크에서 제거됩니다.

닫힌 마스크를 그리거나 수정하는 중 마스크의 모드를 변경하려면 다음 키보드 단축키를 사용하십시오.

기능

Mac

Windows

없음

N

N

빼기

S

S

더하기

A

A

교차

I

I

어둡게

D

D

차이

F

F

밝게

L

L

참고:

  • 사각형 도구 및 타원 도구 등 모양 도구를 사용하여 새 마스크를 그릴 때는 이 키보드 단축키를 마우스와 함께 누를 수 있습니다.
  • 툴을 사용하여 새 마스크를 그릴 때는 마스크를 닫을 때 키보드 단축키만 누를 수 있습니다. 닫는 정점(일반적으로 첫 번째 정점)에 포인터를 놓으려면 마우스 버튼을 클릭한 상태로 마스크를 닫은 다음 마우스 버튼을 놓기 전에 마스크 모델 키보드 단축키를 누르십시오. 열려 있는 마스크에는 모드가 없습니다. 도구를 사용하여 열린 마스크를 그릴 때는 이 키보드 단축키가 작동하지 않습니다.
  • 닫힌 마스크를 수정할 때는 마우스 버튼을 누른 상태에서 언제든지 키보드 단축키를 누를 수 있습니다.

마스크 가장자리 확장 또는 축소

마스크의 영향을 받는 영역을 확장 또는 축소하려면 [마스크 확장] 속성을 사용합니다.

[마스크 확장]은 알파 채널에 영향을 주지만 기본 마스크 패스에는 영향을 주지 않습니다. 마스크 확장은 본질적으로 알파 채널에 대한 마스크의 영향이 확장되는 거리를 마스크의 패스로부터 픽셀 단위로 결정하는 오프셋입니다.

[마스크] 확장 값을 최대 32,000에서 최소 -32,000까지 지정할 수 있습니다. After Effects의 과거 버전에서는 이 값을 1,000까지 지정할 수 있으며 이보다 낮은 값은 수동으로 입력해야 했습니다.

  1. [타임라인] 패널에서 조정할 레이어의 [마스크] 속성을 확장합니다.
  2. [마스크 확장]에서 밑줄이 있는 값을 드래그합니다.

Todd Kopriva는 Adobe 웹사이트에 있는 자신의 블로그에서 마스크 확장 및 이로 인해 둥근 가장자리가 생성되는 이유에 대해 시각 자료를 보여 주며 상세하게 설명합니다.

마스크 가장자리 부드럽게 하기 (페더링)

페더링은 마스크의 가장자리를 사용자가 정의한 거리만큼 불투명하게 페이드를 적용하여 부드럽게 만드는 기능입니다. [마스크 페더] 속성을 사용하여 마스크 가장자리를 거칠게 또는 부드럽게(페더링됨) 만들 수 있습니다. 기본적으로 페더 폭은 마스크 가장자리에서 절반은 안쪽, 절반은 바깥쪽에 걸쳐 있습니다. 예를 들어 페더 폭을 25로 설정하면 페더링이 마스크 가장자리 안쪽으로 12.5픽셀, 바깥쪽으로 12.5픽셀만큼 확장됩니다.

슬라이더를 사용하여 [마스크 페더] 값을 최대 32,000으로 지정할 수 있습니다.

다양한 마스크 페더 값의 결과

A. 5픽셀 페더를 사용하여 마스크 처리한 레이어 B. 40픽셀 페더를 사용하여 마스크 처리한 레이어 C. 5픽셀 페더를 사용한 결과 D. 40픽셀 페더를 사용한 결과 

또한 마스크 페더링이 나타나는 위치를 제어하는 [마스크 확장] 속성을 사용하여 마스크 가장자리를 확장하거나 축소할 수 있습니다. 마스크 가장자리 확장 또는 축소를 참조하세요.

마스크 페더링은 레이어 치수 내에서만 실행됩니다. 따라서 페더링된 마스크의 패스는 항상 레이어 영역보다 약간 작으며 레이어의 가장자리 끝까지 이동할 수 없습니다. 마스크 페더가 레이어 영역을 초과하여 확장되면 페더링된 가장자리가 갑자기 끝납니다.

  1. 선택한 레이어의 [마스크 페더] 속성을 표시하려면 F 키를 누르세요.
  2. (선택 사항)가로 및 세로 페더 양이 균형 있게 변경되도록 제한하려면 마스크 페더 속성 옆에 있는 비율 제한 스위치 를 선택합니다.
  3. 다른 속성과 같은 방식으로 [마스크 페더] 속성을 수정합니다. 즉, 밑줄이 있는 값을 드래그하거나 밑줄이 있는 값을 클릭하고 텍스트 입력 필드에 양을 입력합니다.
참고:

마스크 페더로 인해 불투명도 값이 가우시안 분포에 따라 달라지기 때문에 페더의 영향을 받는 영역은 실제로 지정된 픽셀 수를 초과하여 확장됩니다. 지정된 페더 범위를 초과하는 페더의 영향력 크기는 매우 작습니다. 이처럼 가우시안 분포에 따른 점진적 감소를 사용하면 선형 감소보다 더 자연스럽게 표현됩니다.

가변 폭 마스크 페더

After Effects의 이전 버전에서는 닫힌 마스크에 페더링된 가장자리를 추가할 수 있지만 마스크를 둘러싼 페더의 폭(확장 범위)은 동일했습니다. [펜] 툴과 동일한 툴 메뉴에서 사용 가능한 새로운 [마스크 페더] 툴로 페더를 추가하면 닫힌 마스크를 따라 폭이 변하는 점을 정의할 수 있습니다.

페더 점을 만드는 방법:

선택한 페더 점의 핸들에는 작은 검은 점이 있습니다.

페더 점은 바깥쪽 페더 경계와 안쪽 페더 경계를 모두 정의합니다. 마스크 내에 페더 확장 핸들이 없으면 안쪽 페더 경계가 마스크 패스입니다. 마스크 페더는 안쪽에서 바깥쪽 페더 경계로 확장됩니다.

여러 페더 점을 선택하는 방법:

[선택] 또는 [마스크 페더] 도구를 사용하여 Shift 키를 누른 상태로 페더 점의 확장 핸들을 클릭합니다.

페더 점의 선택/선택 해제 간을 전환하려면:

Shift 키를 누른 상태로 페더 점을 클릭합니다.

페더 점을 옮기려면 다음 중 하나를 수행합니다.

  • [선택] 또는 [마스크 페더] 도구를 사용하여 페더 확장 핸들을 드래그합니다.

선택한 여러 페더 점 중에 하나를 드래그하여 이들 모두를 함께 이동하거나, 페더 확장 핸들 중 하나를 드래그하여 여러 페더의 폭을 함께 조정할 수 있습니다.

마스크의 모퉁이 점 주변의 페더 점을 "닦아내듯" 이동할 수 있습니다.

  • [마스크 페더] 도구가 활성화된 상태에서 왼쪽 또는 오른쪽 화살표 키를 누르면 패스를 따라 페더가 이동하고, 위쪽 또는 아래쪽 화살표 키를 누르면 페더의 폭이 길어지거나 짧아집니다.

선택한 여러 페더 점을 이동할 수 있으며, Shift 키를 누른 상태로 이동하면 더 먼 거리와 폭으로 이동할 수 있습니다.

페더 점을 마스크 패스에 스냅하는 방법:

마스크 패스를 가로질러 페더 확장 핸들을 드래그합니다. 그러면 핸들이 마스크 패스에서 멈춥니다.

페더의 밝기 감소를 제어하는 방법:

[레이어] > [마스크] > [페더 밝기 감소]를 선택하고 다음 중 하나를 선택합니다.

  • 매끄럽게(기본값)
  • 선형

페더 점을 통해 페더 경계의 압력(매끄러움 또는 곡률)을 조정하는 방법:

Alt 키(Windows) 또는 Option 키(MacOS)를 누른 상태에서 페더 확장 핸들로부터 드래그하여 압력을 조정합니다. [정보] 패널에는 핸들의 현재 압력이 표시됩니다.

페더 점에 대해 [고정] 보간을 설정하는 방법(다음 페더 점까지 페더 반경을 일정하게 유지):

Alt 키(Windows) 또는 Option 키(MacOS)를 누른 상태에서 페더 확장 핸들로부터 드래그하여 압력을 조정합니다. [정보] 패널에는 핸들의 현재 압력이 표시됩니다.

페더 점에 대해 [고정] 보간을 설정하는 방법(다음 페더 점까지 페더 반경을 일정하게 유지):

페더 점 위에 있는 상황에 맞는 메뉴에서 [고정] 옵션을 사용하도록 설정합니다. 페더 점 핸들은 고정 반경의 방향으로 뾰족하게 변합니다.

특정 마스크 선분에 페더 가장자리를 빠르게 만드는 방법:

Shift 키를 누른 상태로 마스크 선분을 클릭합니다. 정점 위가 아닌 정점 사이를 클릭해야 합니다. 이 모드에 있다는 것을 나타내기 위해 포인터가 변합니다. 선분에서 드래그하여 확장 폭을 조정합니다. 다음 동작을 참조하십시오.

  • 마스크 정점을 두 개만 선택한 경우 페더링한 가장자리는 두 정점 사이의 연속 선분이 됩니다.
  • 클릭한 선분의 두 정점을 선택하면, 즉 선분을 선택하면 페더링한 가장자리는 선택한 연속 선분을 포함하도록 확장됩니다.
  • 마스크의 정점을 모두 선택하거나 아예 선택하지 않은 경우 또는 처음 두 조건이 적용되지 않는 경우 페더링한 가장자리는 클릭한 선분에만 적용됩니다.

페더 점을 삭제하는 방법:

[선택] 또는 [마스크 페더] 툴을 사용하여 페더 확장 핸들을 선택한 다음 Delete 키를 누릅니다. 여러 페더 점을 선택하여 삭제할 수 있습니다.

참고:

포인터를 마스크 정점 위에 놓으면 정점 삭제 모드 대신 선택 모드로 변경됩니다.

가변 폭 마스크 페더 팁(마스크 페더 툴)

  • 'G' 단축키를 누르면 [펜] 툴 및 [마스크 페더] 툴 간을 일시적으로 전환할 수 있습니다.

[편집] > [환경 설정] > [일반](Windows) 또는 [After Effects] > [환경 설정] > [일반](macOS)에서 이 동작을 해제할 수 있습니다.

  • [정보] 패널에서 마스크의 페더 점 개수, 페더 폭 길이, 위치, 압력 및 페더 밝기 감소 설정에 대한 정보를 볼 수 있습니다.
  • [보기 옵션] 대화 상자의 "마스크 페더 경계" 옵션을 선택 해제하면 특정 보기에 대해 페더 경계를 숨길 수 있습니다. 페더 경계는 그려져 있는 한, 계속 상호 작용할 수 있습니다. 예를 들어 경계에 새 페더 점을 추가할 수 있습니다.
  • [일반] 환경 설정의 [마스크를 편집할 때 고정 정점 및 페더 수 유지] 옵션을 사용하여 마스크 패스 키프레임 전체에서 페더 점 수를 제어할 수 있습니다.
  • 페더 점에 대해 상황에 맞는 메뉴의 명령을 사용하여 대화 상자에서 페더 점의 압력, 반경 및 모퉁이 각도 값을 변경할 수 있습니다.
    Ctrl 키(Windows) 또는 Cmd 키(mac OS)를 누른 상태에서 마우스 커서를 마스크 정점 위로 가져가면 [선택] 도구 비헤이비어로 전환됩니다.
  • Ctrl 키(Windows) 또는 Cmd 키(Mac OS)를 누른 상태에서 마우스 커서를 접선 핸들 위로 가져가면 [정점 변환] 툴로 전환됩니다.

트랙 매트 및 이동하는 매트

한 레이어에 의해 정의된 구멍을 통해 다른 레이어를 표시하려면 트랙 매트를 설정하십시오. 예를 들어 텍스트 레이어를 비디오 레이어의 트랙 매트로 사용하여 텍스트 문자에 의해 정의된 모양을 통해서만 비디오가 표시되도록 할 수 있습니다. 기본 레이어(칠 레이어)는 트랙 매트 레이어의 특정 채널(알파 채널 또는 픽셀 광도) 값에서 투명도 값을 가져옵니다.

트랙 매트의 픽셀 광도를 기반으로 레이어의 투명도를 정의하는 것은 알파 채널이 없는 레이어 또는 알파 채널을 만들 수 없는 프로그램에서 가져온 레이어를 사용하여 트랙 매트를 만들려는 경우 유용합니다. 알파 채널 매트를 사용하는 경우와 광도 매트를 사용하는 경우 모두 값이 높은 픽셀이 더 투명합니다. 일반적으로 고대비 매트를 사용하면 매트 영역이 완전히 투명하거나 완전히 불투명합니다. 중간 음영은 부드러운 가장자리와 같이 부분적이거나 점진적인 투명도가 필요한 위치에만 나타나야 합니다.

이동하는 매트

A. 트랙 매트 레이어: 루마 매트로 설정된 직사각형 마스크가 있는 단색 레이어. 이 마스크는 화면을 가로질러 이동하도록 애니메이션이 적용되어 있습니다. B. 칠 레이어: 패턴 효과가 적용된 단색 레이어. C. 결과: 트랙 매트 모양에 패턴이 나타납니다. 그런 다음 추가 이미지 레이어 위에 합성됩니다. 

트랙 매트는 바로 아래에 있는 레이어에만 적용됩니다. 트랙 매트를 여러 레이어에 적용하려면 먼저 여러 레이어를 사전 구성한 다음 사전 구성 레이어에 트랙 매트를 적용합니다.

After Effects에서는 레이어를 복제하거나 분할한 이후에도 레이어와 레이어 트랙 매트의 순서를 유지합니다. 복제되거나 분할된 레이어에서 트랙 매트 레이어는 채우기 레이어 위쪽에 유지됩니다. 예를 들어 컴포지션에 레이어 A와 B가 있는데 레이어 A는 트랙 매트이고 B는 채우기 레이어인 경우, 이 두 레이어를 복제하거나 분할하면 레이어 순서는 ABAB가 됩니다.

트랙 매트 레이어의 위치 또는 기타 변형에 애니메이션을 적용하는 경우 해당 매트를 이동하는 매트라고 합니다. 동일한 설정을 사용하여 트랙 매트와 채우기 레이어에 애니메이션을 지정하려면 트랙 매트와 채우기 레이어를 사전 구성하는 것이 좋습니다.

레이어를 트랙 매트로 전환

[TrkMat] 메뉴는 혼합 모드 메뉴와 열을 공유합니다. [TrkMat] 메뉴를 표시하려면 [모드] 열이 표시되는지 확인하십시오. 자세한 내용은 을 참조하십시오.

  1. [타임라인] 패널에서 트랙 매트로 사용할 레이어를 채우기 레이어로 사용할 레이어 바로 위로 드래그합니다.
  2. 칠 레이어의 TrkMat 메뉴에서 다음 옵션 중 하나를 선택하여 트랙 매트의 투명도를 정의합니다.

    트랙 매트 없음

    투명도가 작성되지 않습니다. 다음 상위 레이어가 일반 레이어 역할을 합니다.

    알파 매트

    알파 채널 픽셀 값이 100%이면 불투명합니다.

    알파 반전 매트

    알파 채널 픽셀 값이 0%이면 불투명합니다.

    루마 매트

    픽셀의 광도 값이 100%이면 불투명합니다.

    루마 반전 매트

    픽셀의 광도 값이 0%인 경우 불투명합니다.

[트랙 매트 없음] 이외의 옵션을 선택하는 경우 After Effects가 다음 상위 레이어를 트랙 매트로 변환하고, 트랙 매트 레이어의 비디오를 끈 다음 [타임라인] 패널에서 트랙 매트 레이어의 이름 옆에 트랙 매트 아이콘 을 추가합니다.

참고:

매트 레이어의 비디오가 꺼져 있더라도 레이어를 선택하여 위치를 변경하고, 비율을 조정하고, 회전할 수 있습니다. [타임라인] 패널에서 레이어를 선택한 다음 [컴포지션] 패널에서 레이어의 중심(X 표시가 있는 원으로 나타남)을 드래그합니다.

트랙 매트를 사용하는 것은 [기본 투명도 유지] 옵션을 사용하는 것과 비슷합니다. 이 옵션을 사용할 경우 레이어 겹침 순서에서 아래에 있는 레이어 합성의 투명도에서 레이어의 투명도를 가져옵니다. 자세한 내용은 합성 중에 기본 투명도 유지를 참조하십시오.

매트 추적 작업을 위한 팁

  • [레벨] 효과를 사용하여 매트 레이어의 밝은 부분과 어두운 부분 간의 대비를 높입니다. 그러면 중간 범위 값이 많아져 부분 투명도로 변환되는 문제가 줄어듭니다. 일반적으로 매트는 가장자리를 제외하고 영역을 완전히 투명하거나 완전히 불투명하게 정의할 때 가장 유용합니다.
  • 매트 레이어의 알파 채널 이외의 채널을 매트로 사용하려면 [채널 이동] 효과와 같은 [채널] 효과 중 하나를 사용하여 원하는 채널 값의 경로를 알파 채널로 지정합니다.
  • 트랙 매트에 애니메이션을 적용하여 매트가 적용되는 레이어와 함께 이동하도록 만들려면 트랙 매트를 매트 적용 레이어의 자식 레이어로 만듭니다. 부모 및 자식 레이어를 참조하십시오.

합성 시 기본 투명도 유지

[기본 투명도 유지] 옵션은 레이어가 레이어 스택 순서 상 아래에 있는 레이어의 합성 투명도에서 투명도 값을 가져오도록 만듭니다. 즉, 이 옵션이 선택되어 있는 레이어의 불투명 영역은 기본 레이어의 불투명 영역 위에 배치될 경우에만 표시됩니다. 이러한 동작은 트랙 매트의 동작과 비슷하지만 트랙 매트는 단일 레이어만 될 수 있고 레이어 겹침 순서에서 해당 레이어 위에 있어야 합니다. 자세한 내용은 트랙 매트와 이동하는 매트를 참조하세요.

이 옵션은 광택 표면의 반짝임이나 빛 반사 효과를 만들 때 유용합니다.

[기본 투명도 유지] 옵션이 선택된 레이어의 동작은 Adobe Photoshop의 클리핑 마스크 동작과 비슷합니다.

  1. 레이어의 [모드] 열에서 T 옵션을 선택합니다.

Mocha AE 마스크 작업 리소스

Boris FX의 Mocha AE 플러그인을 평면 추적 및 마스크 작업에 사용할 수 있습니다. 이 플러그인은 평면 추적 워크플로우로 마스크의 모양을 설정합니다. Mocha AE의 스플라인 모양에는 가장자리 흐림 효과를 정밀하게 제어할 수 있도록 다양한 지점 단위 가장자리 페더도 포함되어 있습니다.

이전 버전의 Mocha AE의 경우 마스크 전환 프로세스를 수행하려면 클립보드와 Mocha Shape 플러그인을 사용하여 Mocha AE에서 After Effects로 복사/붙여넣기를 해야 합니다. Mocha AE 플러그인은 Mocha의 모양을 After Effects의 현재 워크플로우에 적용하거나 전환합니다.

자세한 내용은 Mocha AE를 사용한 평면 추적을 참조하세요.

Boris FX 비디오 튜토리얼 섹션에 After Effects에서 Mocha AE로 마스크 작업을 하는 방법을 다룬 비디오 튜토리얼이 있습니다.

Adobe 로고

내 계정 로그인

[Feedback V2 Badge]