사용 안내서 취소

성능 향상

  1. After Effects 사용 안내서
  2. Beta 릴리스
    1. Beta 프로그램 개요
    2. After Effects Beta 홈
    3. Beta의 기능
      1. 속성 패널(Beta)
  3. 시작하기
    1. After Effects 시작하기
    2. After Effects의 새로운 기능 
    3. 릴리스 정보 | After Effects
    4. After Effects 시스템 요구 사항
    5. After Effects 키보드 단축키
    6. 지원하는 파일 형식 | After Effects
    7. 하드웨어 권장 사항
    8. Apple Silicon용 After Effects
    9. 계획 및 설정
    10. 설정 및 설치
  4. 작업 영역
    1. 일반 사용자 인터페이스 항목
    2. After Effects 인터페이스 알아보기
    3. 워크플로우
    4. 작업 영역, 패널, 뷰어
  5. 프로젝트 및 컴포지션
    1. 프로젝트
    2. 컴포지션 기본 사항
    3. 사전 구성, 중첩, 사전 렌더링
    4. 컴포지션 프로파일러를 사용하여 자세한 성능 정보 보기
    5. Cinema 4D 컴포지션 렌더러
  6. 푸티지 가져오기
    1. 스틸 이미지 준비 및 가져오기
    2. After Effects 및 Adobe Premiere Pro에서 가져오기
    3. 비디오와 오디오 가져오기 및 해석
    4. 3D 이미지 파일 준비 및 가져오기
    5. 푸티지 항목 가져오기 및 해석
    6. 푸티지 항목을 사용한 작업
    7. [장면 편집 감지]를 사용하여 편집 지점 감지
    8. XMP 메타데이터
  7. 텍스트 및 그래픽
    1. 텍스트
      1. 문자 서식 지정 및 문자 패널
      2. 텍스트 효과
      3. 텍스트 레이어 만들기 및 편집
      4. 단락 서식 지정 및 단락 패널
      5. 돌출 텍스트 및 모양 레이어
      6. 텍스트에 애니메이션 적용
      7. 텍스트 애니메이션 예제 및 리소스
      8. 라이브 텍스트 템플릿
    2. 모션 그래픽
      1. After Effects에서 모션 그래픽 템플릿을 사용해 작업하기
      2. 표현식을 사용하여 모션 그래픽 템플릿에 드롭다운 목록 만들기
      3. 기본 속성으로 모션 그래픽 템플릿 만들기
      4. 모션 그래픽 템플릿에서 이미지와 비디오 바꾸기 및 기본 속성
  8. 그리기, 페인트, 패스
    1. 모양 레이어, 패스, 벡터 그래픽 개요
    2. 페인트 도구: 브러쉬, 복제 도장, 지우개
    3. 모양 선 테이퍼하는 방법
    4. 모양 레이어의 모양 속성, 페인트 작업, 패스 작업
    5. 오프셋 패스 모양 효과를 통한 모양 변경
    6. 모양 만들기
    7. 마스크 만들기
    8. 내용 인식 채우기 패널로 비디오에서 개체 제거
    9. 로토 브러시와 매트 다듬기
  9. 레이어, 마커, 카메라
    1. 레이어 선택 및 정렬
    2. 혼합 모드와 레이어 스타일
    3. 3D 레이어
    4. 레이어 속성
    5. 레이어 만들기
    6. 레이어 관리
    7. 레이어 마커와 컴포지션 마커
    8. 카메라, 조명 및 관심 영역
  10. 애니메이션, 키프레임, 동작 추적, 키잉
    1. 애니메이션
      1. 애니메이션 기본 사항
      2. 퍼펫 도구를 사용한 애니메이션
      3. 모양 패스와 마스크를 관리하고 애니메이션을 적용하기
      4. After Effects를 사용하여 스케치 및 캡처 모양에 애니메이션 적용하기
      5. 종합 애니메이션 도구
      6. 데이터 기반 애니메이션 작업
    2. 키프레임
      1. 키프레임 보간
      2. 키프레임 설정, 선택 및 삭제
      3. 키프레임 편집, 이동 및 복사
    3. 동작 추적
      1. 동작 추적 및 안정화
      2. 얼굴 추적
      3. 마스크 추적
      4. 마스크 참조
      5. 속도
      6. 시간 스트레치와 시간 다시 매핑
      7. 시간 코드 및 시간 표시 단위
    4. 키잉
      1. 키잉
      2. 키잉 효과
  11. 투명도 및 합성
    1. 합성과 투명도 개요 및 리소스
    2. 알파 채널, 마스크 및 매트
  12. 색상 조정
    1. 색상 기본 사항
    2. Adobe Color 테마 확장 사용
    3. 색상 관리
    4. 색상 교정 효과
  13. 효과 및 애니메이션 사전 설정
    1. 효과 및 애니메이션 사전 설정 개요
    2. 효과 목록
    3. 시뮬레이션 효과
    4. 스타일화 효과
    5. 오디오 효과
    6. 왜곡 효과
    7. 원근 효과
    8. 채널 효과
    9. 생성 효과
    10. 전환 효과
    11. 롤링 셔터 복구 효과
    12. 흐림 및 선명 효과
    13. 3D 채널 효과
    14. 유틸리티 효과
    15. 매트 효과
    16. 노이즈 및 그레인 효과
    17. 세부 사항-확대 유지 효과
    18. 더 이상 사용되지 않는 효과
  14. 표현식 및 자동화
    1. 표현식
      1. 표현식 기본 사항
      2. 표현식 언어 이해
      3. 표현식 컨트롤 사용
      4. JavaScript와 레거시 ExtendScript 표현식 엔진 간 구문 차이
      5. 표현식 편집
      6. 표현식 오류
      7. 표현식 편집기 사용
      8. 표현식을 사용하여 텍스트 속성 편집 및 액세스
      9. 표현식 언어 참조
      10. 표현식 예제
    2. 자동화
      1. 자동화
      2. 스크립트
  15. 몰입형 비디오, VR 및 3D
    1. After Effects에서 VR 환경 만들기
    2. 몰입형 비디오 효과 적용
    3. VR/360 비디오용 합성 툴
    4. 3D 카메라 움직임 추적
    5. 3D 디자인 공간에서 작업하기
    6. 3D 변형 기즈모
    7. 3D 애니메이션을 사용하여 더 많은 작업 수행
    8. 실시간 엔진을 통해 3D 디자인 변경 내용 실시간 미리 보기
    9. 그래픽에 반응형 디자인 추가 
  16. 보기 및 미리 보기
    1. 미리 보기
    2. Mercury Transmit를 사용한 비디오 미리 보기
    3. 보기 수정 및 사용
  17. 렌더링 및 내보내기
    1. 렌더링 및 내보내기 기본 사항
    2. After Effects 프로젝트를 Adobe Premiere Pro 프로젝트로 내보내기
    3. 동영상 변환
    4. 멀티 프레임 렌더링
    5. 자동 렌더링 및 네트워크 렌더링
    6. 스틸 이미지와 스틸 이미지 시퀀스 렌더링 및 내보내기
    7. After Effects에서 GoPro CineForm 코덱 사용
  18. 기타 애플리케이션으로 작업
    1. Dynamic Link 및 After Effects
    2. After Effects 및 기타 애플리케이션으로 작업
    3. After Effects의 설정 동기화
    4. After Effects의 Creative Cloud Libraries
    5. 플러그인
    6. CINEMA 4D 및 Cineware
  19. 공동 작업: Frame.io, Team Projects
    1. Premiere Pro 및 After Effects의 공동 작업
    2. Frame.io
      1. Frame.io 설치 및 활성화
      2. Frame.io를 Premiere Pro 및 After Effects와 함께 사용하기
      3. 자주 묻는 질문
    3. Team Projects
      1. Team Projects 시작 하기
      2. 팀 프로젝트 만들기
      3. Team Projects 공동 작업
  20. 메모리, 저장소, 성능
    1. 메모리 및 저장소
    2. 성능 향상
    3. 환경 설정
    4. After Effects의 GPU 및 GPU 드라이버 요구 사항

컴퓨터 시스템, After Effects, 프로젝트 및 워크플로를 최적화하여 성능을 향상시킬 수 있습니다. 여기에서 제안하는 일부 권장 사항은 렌더링 속도를 높이는 것이 아니라 프로젝트 열기와 같은 다른 작업에 필요한 시간을 줄임으로써 성능을 높이는 것입니다.

참고:

지금까지 전반적인 성능 향상을 위한 최상의 방법은 워크플로 및 출력 파이프라인을 사전에 계획하고 조기에 테스트하여 지금 제공되는 성능이 실제 고객이 원하고 예상한 성능인지 확인하는 것입니다. 자세한 내용은 작업 계획을 참조하십시오.

Lloyd Alvarez는 After Effects Scripts 웹 사이트에서 After Effects에서 작업을 진행하면서 배경에서 컴포지션을 렌더링하고 내보낼 수 있게 하는 BG 렌더러 스크립트를 제공합니다.

After Effects를 시작하기 전에 성능 향상

  • 최신 버전의 After Effects와 사용 가능한 모든 업데이트가 설치되었는지 확인하십시오. 업데이트를 확인하고 설치하려면 [도움말] > [업데이트]를 선택하십시오.
  • 최신 버전의 드라이버 및 플러그인, 특히 비디오 카드 드라이버를 설치했는지 확인하십시오. 드라이버 및 플러그인의 업데이트를 다운로드하려면 해당 공급업체의 웹 사이트를 방문하십시오.
  • 시스템에 RAM이 충분한지 확인하십시오. 최적의 성능을 얻으려면 프로세서 코어당 설치된 RAM 2GB 이상으로 컴퓨터 시스템을 구성해야 합니다. 설치된 RAM 용량을 확인하고 RAM을 설치하는 방법에 대한 자세한 내용은 운영 체제 및 컴퓨터 설명서를 참조하십시오.
  • 작업에 필요하지 않은 응용 프로그램은 종료하십시오. After Effects와 메모리 풀을 공유하지 않는 다른 응용 프로그램에 적당한 메모리를 할당하지 않은 상태로 다른 응용 프로그램을 실행하는 경우 운영 체제에서 RAM을 하드 디스크로 전환하면 성능이 크게 저하될 수 있습니다. (64비트 After Effects의 메모리(RAM) 사용을 참조하십시오.)
  • Adobe Bridge의 비디오 미리 보기와 같이 다른 응용 프로그램에서 실행되는 리소스 사용량이 높은 작업을 중지 또는 일시 중지합니다.
  • 시스템에 OpenGL 2.0 이상을 지원하는 디스플레이 카드가 포함되어 있는지 확인하십시오. 이러한 디스플레이 카드가 없어도 After Effects가 작동할 수 있지만 OpenGL은 미리 보기 화면에 대한 렌더링을 포함하여 여러 가지 유형의 렌더링 속도를 높여줍니다. 자세한 내용은 OpenGL을 사용하여 렌더링을 참조하십시오.
  • 가능하면 빠른 로컬 디스크 드라이브에 프로젝트의 소스 푸티지 파일을 보관하십시오. 소스 푸티지 파일이 느린 디스크 드라이브에 있거나 느린 네트워크를 통해 연결되어 있는 경우에는 성능이 떨어집니다. 이상적으로, 소스 푸티지 파일과 렌더링된 출력에 대해 속도가 빠른 별개의 로컬 디스크 드라이브를 사용합니다.
  • 디스크 캐시 폴더를 별개의 고속 디스크 또는 디스크 배열에 할당하는 것이 가장 좋습니다. SSD는 속도가 빠르므로 이러한 기능에 적합합니다.

메모리, 캐시 및 다중 처리 설정을 최적화하여 성능 향상

  • 다른 응용 프로그램에 대해 적합한 메모리를 할당합니다.
  • [디스크 캐시 사용] 환경 설정을 선택하여 미리 보기에 대해 디스크에 프레임을 캐시합니다. After Effects에서 최고의 성능을 얻으려면 가능한 한 많은 공간을 별도의 고속 드라이브에 있는 디스크 캐시 폴더에 할당해야 합니다. 디스크 캐시를 참조하십시오.

Todd Kopriva는 Adobe 웹 사이트에서 최적의 메모리 및 프로세서 설정에 대한 자세한 정보를 제공합니다.

자세한 내용은 메모리 환경 설정을 참조하십십시오.

글로벌 성능 캐시를 사용하여 성능 개선 | CC, CS6

After Effects 5.5 이하 버전의 프로젝트를 After Effects CS으로 가져와서 전역 성능 캐시를 활용합니다. 자세한 내용은 디스크 캐시를 참조하십시오.

영구 디스크 캐시는 세션 사이에 디스크 캐시에 저장된 프레임을 유지함으로써 동일한 캐시된 프레임을 사용하는 같은 프로젝트나 다른 프로젝트에서 작업할 때 렌더링 시간을 줄여 성능을 향상시킵니다.

프로젝트를 단순화하여 성능 향상

프로젝트를 단순화 및 분할하여 After Effects에서 현재 작업 중이지 않은 요소를 처리하는 데 메모리 및 기타 리소스를 사용하지 못하도록 할 수 있습니다. 또한 After Effects에서 특정 처리 과정을 수행하는 시기를 제어하여 전반적인 성능을 크게 향상시킬 수 있습니다. 예를 들어 한 번만 발생해야 하는 작업을 반복하지 않도록 하거나 편리한 시간까지 특정 작업을 연기할 수 있습니다.

  • 프로젝트에서 사용하지 않는 요소를 삭제합니다. 자세한 내용은 프로젝트에서 항목 제거를 참조하십시오.
  • 복잡한 프로젝트를 여러 간단한 프로젝트로 분할하고 완성된 동영상을 렌더링하기 전에 다시 조합합니다. 프로젝트를 재조합하려면 모든 프로젝트를 단일 프로젝트로 가져옵니다. 자세한 내용은 After Effects 프로젝트 가져오기를 참조하십시오.
  • 렌더링하기 전에 모든 소스 푸티지 파일을 렌더링 및 내보내기에 사용 중인 디스크가 아닌 속도가 빠른 별개의 로컬 디스크에 넣습니다. [파일 수집] 명령을 사용하면 이 작업을 쉽게 수행할 수 있습니다. 자세한 내용은 한 위치에 파일 수집을 참조하십시오.
  • 중첩된 컴포지션을 미리 렌더링합니다. After Effects에서 컴포지션이 표시될 때마다 렌더링을 수행하지 않도록 완성된 컴포지션을 동영상으로 렌더링합니다. 자세한 내용은 중첩된 컴포지션 미리 렌더링을 참조하십시오.
  • 소스 항목을 직접 사용하지 않을 때는 소스 항목을 저해상도 또는 스틸 이미지 프록시로 대체합니다. 자리 표시자 및 프록시를 참조하십시오.
  • 컴포지션의 해상도를 낮춥니다. 자세한 내용은 해상도를 참조하십시오.
  • [단독] 스위치를 사용하여 작업 중인 레이어를 격리시킵니다. 자세한 내용은 레이어 단독화를 참조하십시오.

화면 출력을 수정하여 성능 향상

After Effects에서 프로젝트 데이터를 처리하는 방법에는 영향을 주지 않고 작업 중에 화면에 출력이 표시되는 방식에만 영향을 주는 여러 방식으로 성능을 향상시킬 수 있습니다. 작업 중에 특정 항목과 정보를 표시하는 것이 유용한 경우가 많지만, After Effects에서는 해당 정보를 업데이트하는 데 메모리 및 프로세서 리소스를 사용하므로 작업 중에 표시할 항목을 주의해서 선택하는 것이 좋습니다. 워크 플로의 여러 시점에 따라 확인해야 할 프로젝트 요소가 달라질 수 있으므로 여러 단계의 여러 조합에서 다음과 같은 권장 사항을 따르는 것이 좋습니다.

  • 필요하지 않은 경우에는 표시 색상 관리 및 출력 시뮬레이션을 끕니다. 자세한 내용은 다른 출력 장치에서 색상이 표시되는 방법 시뮬레이션을 참조하십시오. 미리 보기에 대한 색상 관리의 속도 및 품질은 [뷰어 품질] 환경 설정에 의해 제어됩니다. 자세한 내용은 뷰어 품질 환경 설정을 참조하십시오.
  • GPU를 사용하여 화면에 미리 보기를 표시하는 것을 지원하는 미리 보기의 하드웨어 가속화를 사용합니다. [편집] > [환경 설정] > [표시](Windows) 또는 [After Effects] > [환경 설정] > [표시](Mac OS)를 선택하고 [컴포지션, 레이어 및 푸티지 패널 하드웨어 가속화]를 선택합니다.
  • 불필요한 패널을 닫습니다. After Effects에서는 열린 패널을 업데이트하는 데 메모리 및 프로세서 리소스를 사용하므로 다른 열린 패널의 작업 속도가 느려질 수 있습니다.
  • 관심 영역을 만듭니다. 컴포지션의 일부에서 작업을 수행 중인 경우 미리 보기 중에 화면에 렌더링되는 컴포지션을 특정 부분으로 제한하십시오. 자세한 내용은 ROI(관심 영역)를 참조하십시오.
  • [타임라인] 패널 메뉴에서 [캐시 표시기 표시]를 선택 해제하여 After Effects에서 캐시된 프레임을 나타내기 위해 시간 눈금자에 녹색 및 파란색 막대를 표시하지 않도록 설정합니다. 자세한 내용은 캐시: RAM 캐시, 디스크 캐시, 미디어 캐시를 참조하십시오.
  • [정보 패널 및 흐름도에 렌더링 진행률 표시] 환경 설정을 선택 해제하여 각 프레임의 렌더링 작업 세부 정보가 화면에 표시되지 않도록 설정합니다. 자세한 내용은 표시 환경 설정을 참조하십시오.
  • [렌더링 대기열] 패널에서 [현재 렌더링 정보] 옆에 있는 삼각형을 클릭하여 [렌더링 대기열] 패널에서 [현재 렌더링 정보]를 숨깁니다. 자세한 내용은 현재 렌더링 작업에 대해 표시되는 정보를 참조하십시오.
  • Caps Lock 키를 눌러서 After Effects가 [푸티지], [레이어] 또는 [컴포지션] 패널을 업데이트하지 못하도록 설정합니다. 일반적으로 패널에 표시되는 변경을 수행하는 경우 After Effects에서는 패널 아래쪽에 텍스트 알림이 포함된 빨간색 막대를 추가합니다. 동작 패스, 기준점, 마스크 윤곽선 등의 패널 컨트롤을 이동함에 따라 해당 컨트롤이 계속 업데이트됩니다. 패널 업데이트를 다시 시작하고 모든 변경 내용을 표시하려면 Caps Lock 키를 다시 누릅니다.
참고:

Caps Lock 키를 누르면 빨간색 알림 막대가 없더라도 최종 출력용 렌더링 중에도 뷰어에서 미리 보기를 업데이트하지 않습니다(새로 고침 사용 안 함).

  • 레이어의 표시 품질을 [초안]으로 낮춥니다. 레이어 이미지 품질 및 하위 픽셀 배치를 참조하십시오.
  • [타임라인] 패널 메뉴에서 3D 레이어에 표시되는 모든 조명 및 그림자를 해제하는 [초안 3D]를 선택합니다. 그러면 카메라의 피사계 심도 흐림 효과도 해제됩니다.
  • 광선 추적형 3D 컴포지션의 레이아웃을 지정하고 미리 보는 동안 [빠른 미리 보기] 단추에서 "해제" 이외의 옵션을 선택하여 고속 인쇄 모드를 사용합니다.
  • [타임라인] 패널 메뉴에서 [실시간 업데이트]를 선택 해제하여 After Effects가 컴포지션을 동적으로 업데이트하지 못하도록 설정합니다. 자세한 내용은 미리 보기 모드 및 빠른 미리 보기 환경 설정을 참조하십시오.
  • 필요한 경우에만 [타임라인] 패널에서 오디오 파형을 표시합니다. 자세한 내용은 타임라인 패널에서 속성 및 그룹 보기(키보드 단축키)를 참조하십시오.
  • [컴포지션], [레이어] 또는 [푸티지] 패널 아래쪽에서 [픽셀 종횡비 교정 켜기/끄기] 단추 를 클릭하여 픽셀 종횡비 교정을 해제합니다. 픽셀 종횡비 교정 및 기타 미리 보기 비율 조정의 속도 및 품질은 [뷰어 품질] 환경 설정에 의해 제어됩니다. 자세한 내용은 뷰어 품질 환경 설정을 참조하십시오.
  • 외부 비디오 모니터에서 비디오를 미리 볼 때는 [컴퓨터 모니터에 미러링]을 선택 해제합니다. 자세한 내용은 외부 비디오 모니터에서 미리 보기를 참조하십시오.
  • 마스크, 3D 참조 축 및 레이어 핸들과 같은 레이어 컨트롤을 숨깁니다. 자세한 내용은 컴포지션 패널에서 레이어 컨트롤 표시 또는 숨기기를 참조하십시오.
  • 컴포지션의 확대율을 낮춥니다. After Effects에서 [컴포지션], [레이어] 및 [푸티지] 패널을 100% 이상의 확대율로 표시할 경우 화면 다시 그리기 속도가 낮아집니다. 자세한 내용은 미리 보기의 이미지 확대/축소를 참조하십시오.
  • [컴포지션] 패널에서 컴포지션의 [해상도/다운샘플링 요소] 값을 [자동]으로 설정하여 낮은 확대/축소 레벨에서 화면에 표시되지 않는 픽셀의 행 또는 열이 불필요하게 렌더링되지 않도록 합니다. 자세한 내용은 해상도를 참조하십시오.

효과 사용 시 성능 향상

흐림 및 왜곡과 같은 일부 효과의 경우 많은 양의 메모리와 프로세서 리소스가 사용됩니다. 이러한 효과의 사용 시기 및 방법을 선택적으로 조정하면 전반적인 성능을 크게 향상시킬 수 있습니다.

  • 메모리 및 프로세서 사용량이 높은 효과는 나중에 적용하십시오. 메모리 또는 프로세서 사용량이 높아 실시간 미리 보기 속도를 저하할 가능성이 있는 효과(예: 광선, 흐림 등)를 적용하기 전에 레이어에 애니메이션을 적용하거나 실시간 미리 보기가 필요한 기타 작업을 먼저 수행하십시오.
  • 미리 보기 속도를 향상시키려면 효과를 일시적으로 해제합니다. 자세한 내용은 효과 및 애니메이션 사전 설정 삭제 또는 사용 안 함을 참조하십시오.
  • 입자 효과로 생성된 입자의 수를 제한합니다. 자세한 내용은 시뮬레이션 효과를 참조하십시오.
  • 여러 레이어에 동일한 설정의 동일한 효과를 적용하는 대신 조정 레이어에 효과를 적용합니다. 조정 레이어에 효과를 적용하면 한 번에 그 아래에 있는 모든 레이어의 합성에 처리됩니다. 자세한 내용은 조정 레이어 만들기를 참조하십시오.
Adobe 로고

내 계정 로그인