사용 안내서 취소

Dynamic Link 및 After Effects

  1. After Effects 사용 안내서
  2. Beta 릴리스
    1. Beta 프로그램 개요
    2. After Effects Beta 홈
    3. Beta의 기능
      1. 속성 패널(Beta)
  3. 시작하기
    1. After Effects 시작하기
    2. After Effects의 새로운 기능 
    3. 릴리스 정보 | After Effects
    4. After Effects 시스템 요구 사항
    5. After Effects 키보드 단축키
    6. 지원하는 파일 형식 | After Effects
    7. 하드웨어 권장 사항
    8. Apple Silicon용 After Effects
    9. 계획 및 설정
    10. 설정 및 설치
  4. 작업 영역
    1. 일반 사용자 인터페이스 항목
    2. After Effects 인터페이스 알아보기
    3. 워크플로우
    4. 작업 영역, 패널, 뷰어
  5. 프로젝트 및 컴포지션
    1. 프로젝트
    2. 컴포지션 기본 사항
    3. 사전 구성, 중첩, 사전 렌더링
    4. 컴포지션 프로파일러를 사용하여 자세한 성능 정보 보기
    5. Cinema 4D 컴포지션 렌더러
  6. 푸티지 가져오기
    1. 스틸 이미지 준비 및 가져오기
    2. After Effects 및 Adobe Premiere Pro에서 가져오기
    3. 비디오와 오디오 가져오기 및 해석
    4. 3D 이미지 파일 준비 및 가져오기
    5. 푸티지 항목 가져오기 및 해석
    6. 푸티지 항목을 사용한 작업
    7. [장면 편집 감지]를 사용하여 편집 지점 감지
    8. XMP 메타데이터
  7. 텍스트 및 그래픽
    1. 텍스트
      1. 문자 서식 지정 및 문자 패널
      2. 텍스트 효과
      3. 텍스트 레이어 만들기 및 편집
      4. 단락 서식 지정 및 단락 패널
      5. 돌출 텍스트 및 모양 레이어
      6. 텍스트에 애니메이션 적용
      7. 텍스트 애니메이션 예제 및 리소스
      8. 라이브 텍스트 템플릿
    2. 모션 그래픽
      1. After Effects에서 모션 그래픽 템플릿을 사용해 작업하기
      2. 표현식을 사용하여 모션 그래픽 템플릿에 드롭다운 목록 만들기
      3. 기본 속성으로 모션 그래픽 템플릿 만들기
      4. 모션 그래픽 템플릿에서 이미지와 비디오 바꾸기 및 기본 속성
  8. 그리기, 페인트, 패스
    1. 모양 레이어, 패스, 벡터 그래픽 개요
    2. 페인트 도구: 브러쉬, 복제 도장, 지우개
    3. 모양 선 테이퍼하는 방법
    4. 모양 레이어의 모양 속성, 페인트 작업, 패스 작업
    5. 오프셋 패스 모양 효과를 통한 모양 변경
    6. 모양 만들기
    7. 마스크 만들기
    8. 내용 인식 채우기 패널로 비디오에서 개체 제거
    9. 로토 브러시와 매트 다듬기
  9. 레이어, 마커, 카메라
    1. 레이어 선택 및 정렬
    2. 혼합 모드와 레이어 스타일
    3. 3D 레이어
    4. 레이어 속성
    5. 레이어 만들기
    6. 레이어 관리
    7. 레이어 마커와 컴포지션 마커
    8. 카메라, 조명 및 관심 영역
  10. 애니메이션, 키프레임, 동작 추적, 키잉
    1. 애니메이션
      1. 애니메이션 기본 사항
      2. 퍼펫 도구를 사용한 애니메이션
      3. 모양 패스와 마스크를 관리하고 애니메이션을 적용하기
      4. After Effects를 사용하여 스케치 및 캡처 모양에 애니메이션 적용하기
      5. 종합 애니메이션 도구
      6. 데이터 기반 애니메이션 작업
    2. 키프레임
      1. 키프레임 보간
      2. 키프레임 설정, 선택 및 삭제
      3. 키프레임 편집, 이동 및 복사
    3. 동작 추적
      1. 동작 추적 및 안정화
      2. 얼굴 추적
      3. 마스크 추적
      4. 마스크 참조
      5. 속도
      6. 시간 스트레치와 시간 다시 매핑
      7. 시간 코드 및 시간 표시 단위
    4. 키잉
      1. 키잉
      2. 키잉 효과
  11. 투명도 및 합성
    1. 합성과 투명도 개요 및 리소스
    2. 알파 채널, 마스크 및 매트
  12. 색상 조정
    1. 색상 기본 사항
    2. Adobe Color 테마 확장 사용
    3. 색상 관리
    4. 색상 교정 효과
  13. 효과 및 애니메이션 사전 설정
    1. 효과 및 애니메이션 사전 설정 개요
    2. 효과 목록
    3. 시뮬레이션 효과
    4. 스타일화 효과
    5. 오디오 효과
    6. 왜곡 효과
    7. 원근 효과
    8. 채널 효과
    9. 생성 효과
    10. 전환 효과
    11. 롤링 셔터 복구 효과
    12. 흐림 및 선명 효과
    13. 3D 채널 효과
    14. 유틸리티 효과
    15. 매트 효과
    16. 노이즈 및 그레인 효과
    17. 세부 사항-확대 유지 효과
    18. 더 이상 사용되지 않는 효과
  14. 표현식 및 자동화
    1. 표현식
      1. 표현식 기본 사항
      2. 표현식 언어 이해
      3. 표현식 컨트롤 사용
      4. JavaScript와 레거시 ExtendScript 표현식 엔진 간 구문 차이
      5. 표현식 편집
      6. 표현식 오류
      7. 표현식 편집기 사용
      8. 표현식을 사용하여 텍스트 속성 편집 및 액세스
      9. 표현식 언어 참조
      10. 표현식 예제
    2. 자동화
      1. 자동화
      2. 스크립트
  15. 몰입형 비디오, VR 및 3D
    1. After Effects에서 VR 환경 만들기
    2. 몰입형 비디오 효과 적용
    3. VR/360 비디오용 합성 툴
    4. 3D 카메라 움직임 추적
    5. 3D 디자인 공간에서 작업하기
    6. 3D 변형 기즈모
    7. 3D 애니메이션을 사용하여 더 많은 작업 수행
    8. 실시간 엔진을 통해 3D 디자인 변경 내용 실시간 미리 보기
    9. 그래픽에 반응형 디자인 추가 
  16. 보기 및 미리 보기
    1. 미리 보기
    2. Mercury Transmit를 사용한 비디오 미리 보기
    3. 보기 수정 및 사용
  17. 렌더링 및 내보내기
    1. 렌더링 및 내보내기 기본 사항
    2. After Effects 프로젝트를 Adobe Premiere Pro 프로젝트로 내보내기
    3. 동영상 변환
    4. 멀티 프레임 렌더링
    5. 자동 렌더링 및 네트워크 렌더링
    6. 스틸 이미지와 스틸 이미지 시퀀스 렌더링 및 내보내기
    7. After Effects에서 GoPro CineForm 코덱 사용
  18. 기타 애플리케이션으로 작업
    1. Dynamic Link 및 After Effects
    2. After Effects 및 기타 애플리케이션으로 작업
    3. After Effects의 설정 동기화
    4. After Effects의 Creative Cloud Libraries
    5. 플러그인
    6. CINEMA 4D 및 Cineware
  19. 공동 작업: Frame.io, Team Projects
    1. Premiere Pro 및 After Effects의 공동 작업
    2. Frame.io
      1. Frame.io 설치 및 활성화
      2. Frame.io를 Premiere Pro 및 After Effects와 함께 사용하기
      3. 자주 묻는 질문
    3. Team Projects
      1. Team Projects 시작 하기
      2. 팀 프로젝트 만들기
      3. Team Projects 공동 작업
  20. 메모리, 저장소, 성능
    1. 메모리 및 저장소
    2. 성능 향상
    3. 환경 설정
    4. After Effects의 GPU 및 GPU 드라이버 요구 사항

Dynamic Link 정보

이전에는 사후 제작 애플리케이션 간에 미디어 에셋을 공유하려면 한 애플리케이션에서 작업을 렌더링하고 내보낸 후에 다른 애플리케이션에서 가져와야 했습니다. 이 작업 과정은 시간이 많이 소모되고 비효율적이었습니다. 원래 에셋을 변경하기 위해 해당 에셋을 다시 렌더링하고 내보냈습니다. 이로 인해 하나의 에셋에 대한 렌더링 및 내보내기 버전이 여러 개 생성되므로 디스크 공간이 많이 소모될 뿐 아니라 파일 관리에 어려움이 있었습니다.

Dynamic Link는 이 작업 과정의 대안을 제공합니다. After Effects 및 Adobe Premiere Pro 간에 Dynamic Link를 만들 수 있습니다. 동적 링크를 만들려면 다른 유형의 에셋을 가져오기만 하면 됩니다. 동적으로 연결된 에셋은 식별하기 쉽도록 고유의 아이콘과 레이블 색상으로 표시됩니다. 동적 링크는 관련 애플리케이션에서 생성된 프로젝트에 저장됩니다.

Dynamic Link로 After Effects 컴포지션 만들기 및 연결

새로운 After Effects 컴포지션을 만들고 Adobe Premiere Pro에서 동적으로 연결할 수 있습니다. Adobe Premiere Pro의 기존 After Effects 컴포지션으로 동적으로 연결할 수도 있습니다.

Adobe Premiere Pro의 클립에서 컴포지션 만들기

Adobe Premiere Pro에서 선택한 클립을 해당 클립 기반의 동적으로 연결된 After Effects 컴포지션으로 바꿀 수 있습니다. 새 컴포지션은 Adobe Premiere Pro의 시퀀스 설정을 상속받습니다.

  1. Premiere Pro를 열고 바꾸려는 클립을 선택합니다.

  2. 선택한 클립 중 하나를 마우스 오른쪽 단추로 클릭합니다.
  3. After Effects 컴포지션으로 바꾸기를 선택합니다.

    현재 After Effects가 열려 있지 않은 경우 After Effects를 열고 새 연결 컴포지션을 만듭니다.

Adobe Premiere Pro에서 동적으로 연결된 컴포지션 만들기

Adobe Premiere Pro에서 동적으로 연결된 컴포지션을 새로 만들면 After Effects가 실행됩니다. 그런 다음 After Effects에서 원래 프로젝트의 크기, 픽셀 종횡비, 프레임 속도 및 오디오 샘플 속도를 사용하여 프로젝트와 컴포지션을 만듭니다. After Effects가 이미 실행 중인 경우에는 현재 프로젝트에 컴포지션이 만들어집니다. 새 컴포지션의 이름은 Adobe Premiere Pro 프로젝트 이름에 따라 지정되며 뒤에 연결 컴포지션 [x]가 붙습니다.

  1. Adobe Premiere Pro에서 [파일] > [Adobe Dynamic Link] > [새 After Effects 컴포지션]을 선택합니다. Premiere Pro 2014 버전에서는 미디어 브라우저를 사용하여 컴포지션을 가져올 수 있습니다. 자세한 내용은 Premiere Pro에서 다음 섹션을 참조하십시오.

  2. After Effects다른 이름으로 저장 대화 상자가 나타나면 After Effects 프로젝트의 이름과 위치를 입력하고 [저장]을 클릭합니다.

    참고:

    동적으로 연결된 After Effects 컴포지션을 만들 때 컴포지션 지속 시간은 30초로 설정됩니다. 이 지속 시간을 변경하려면 After Effects에서 해당 컴포지션을 선택한 후 컴포지션 > 컴포지션 설정을 선택합니다. 기본 탭을 클릭하고 지속 시간에 새 값을 지정합니다.

최상의 결과를 얻으려면 크기, 픽셀 종횡비, 프레임 속도 등의 컴포지션 설정을 Adobe Premiere Pro의 설정과 동일하게 합니다.

  1. 다음 중 하나를 수행합니다.
    • Adobe Premiere Pro에서 [파일] > [Adobe Dynamic Link] > [새 After Effects 컴포지션]을 선택합니다. After Effects 프로젝트 파일(.aep)을 선택한 다음 한 개 이상의 컴포지션을 선택합니다.

    • Adobe Premiere Pro에서 After Effects 프로젝트 파일을 선택하고 [열기]를 클릭합니다. 그런 다음 표시된 대화 상자에서 컴포지션을 선택하고 [확인]을 클릭합니다.

    • After Effects 프로젝트 패널에서 한 개 이상의 컴포지션을 Adobe Premiere Pro 프로젝트 패널로 드래그합니다.

    • After Effects 프로젝트 파일을 Premiere Pro 프로젝트 패널로 드래그합니다. After Effects 프로젝트 파일에 여러 개의 컴포지션이 들어 있으면 컴포지션 가져오기 대화 상자가 열립니다.

참고:

하나의 Adobe Premiere Pro 프로젝트에서 한 개의 After Effects 컴포지션에 여러 번 연결할 수 있습니다.

After Effects에서 동적으로 연결된 컴포지션 수정

Adobe Premiere Pro에서 원본 편집 명령을 사용하여 연결된 After Effects 컴포지션을 수정할 수 있습니다. 컴포지션을 After Effects에서 연 후에는 원본 편집 명령을 다시 사용하지 않고도 컴포지션을 변경할 수 있습니다.

  1. Adobe Premiere Pro에서 After Effects 컴포지션을 선택하거나 타임라인에서 연결된 클립을 선택한 다음 편집 > 원본 편집을 선택합니다.

  2. After Effects에서 컴포지션을 변경합니다. 그런 다음 다시 Adobe Premiere Pro로 전환하여 변경 내용을 확인합니다.

After Effects에서 변경한 내용이 Adobe Premiere Pro에 나타납니다. Adobe Premiere Pro는 변경하기 전에 클립에 대해 렌더링된 미리 보기 파일 사용을 중지합니다.

참고:

Adobe Premiere Pro에서 동적 링크를 만든 후 After Effects에서 해당 컴포지션의 이름을 변경할 수 있습니다. Adobe Premiere Pro는 [프로젝트] 패널의 연결된 컴포지션 이름을 업데이트하지 않습니다. Adobe Premiere Pro는 동적 링크를 유지합니다.

동적으로 연결된 컴포지션 또는 클립 삭제

프로젝트에 연결된 컴포지션이 사용되더라도 언제든지 Adobe Premiere Pro 프로젝트에서 해당 컴포지션을 삭제할 수 있습니다.

언제든지 Adobe Premiere Pro 시퀀스의 타임라인에서 연결된 클립이나 타임라인을 삭제할 수 있습니다.

  1. Adobe Premiere Pro에서 연결된 컴포지션 또는 클립을 선택하고 Delete 키를 누릅니다.

Adobe Premiere Pro에서 Dynamic Link를 통해 연결된 시퀀스 만들기

After Effects에서 Adobe Premiere Pro 시퀀스를 만들면 Adobe Premiere Pro가 실행됩니다. 그런 다음 Adobe Premiere Pro에서 원래 프로젝트의 크기, 픽셀 종횡비, 프레임 속도 및 오디오 샘플 속도를 사용하여 프로젝트와 시퀀스가 만들어집니다. (Adobe Premiere Pro가 이미 실행 중인 경우에는 현재 프로젝트에 시퀀스가 만들어집니다.)

  1. After Effects에서 파일 > Adobe Dynamic Link > 새 Premiere Pro 시퀀스를 선택합니다.

최상의 결과를 얻으려면 Adobe Premiere Pro에서 크기, 픽셀 종횡비, 프레임 속도 등의 시퀀스 설정 및 프로젝트 설정을 After Effects 프로젝트의 설정과 동일하게 합니다.

다음 중 하나를 수행합니다.

  • After Effects에서 파일 > Adobe Dynamic Link > Premiere Pro 시퀀스 가져오기를 선택합니다. Adobe Premiere Pro 프로젝트를 선택한 다음 한 개 이상의 시퀀스를 선택합니다.

  • Adobe Premiere Pro 프로젝트 패널에서 한 개 이상의 시퀀스를 After Effects 프로젝트 패널로 드래그합니다.

Dynamic Link 성능

연결된 클립이 복잡한 소스 컴포지션을 참조할 수 있습니다. 사용자가 소스 컴포지션에서 수행하는 작업은 복잡도에 따라 추가 처리 시간이 필요합니다. After Effects는 작업을 적용하고 전역 성능 캐시 및 영구 디스크 캐시 기능을 사용하여 최종 데이터를 Adobe Premiere Pro에서 사용할 수 있게 만듭니다. 이러한 기능은 Premiere Pro에서 프레임을 요청할 때 캐시된 프레임을 사용하여 After Effects 성능을 향상합니다.

재생 지연을 줄이려면 다음 작업 중 하나를 수행합니다.

  • 연결된 컴포지션을 오프라인으로 전환

  • 연결된 클립을 비활성화하여 컴포지션 참조를 임시로 중단

  • Premiere Pro에서 렌더링 및 바꾸기 기능(클립 > 렌더링 및 바꾸기)을 사용하여 동적으로 연결된 컴포지션을 렌더링된 파일로 바꿉니다.  

복잡한 소스 컴포지션을 자주 사용하는 경우에는 RAM을 늘리거나 더 빠른 프로세서로 업그레이드합니다.

참고:

연결된 After Effects 컴포지션은 여러 프레임을 동시에 렌더링 다중 처리를 지원하지 않습니다. 메모리, 캐시 및 다중 처리 설정을 최적화하여 성능 개선을 참조하십시오.

Adobe Media Encoder로 내보내기

After Effects 컴포지션을 인코딩하려면 Adobe Media Encoder의 인코딩 대기열에 항목을 추가하고 원하는 인코딩 사전 설정을 선택하거나 렌더링을 위한 사용자 정의 설정을 생성합니다. After Effects에서는 다음 옵션 중 하나를 사용하여 Media Encoder 대기열에 컴포지션을 추가할 수 있습니다.

  • 파일 > 내보내기 > Media Encoder 대기열에 추가
  • 컴포지션 > Media Encoder 대기열에 추가

Adobe Media Encoder 대기열에 컴포지션 또는 프로젝트를 추가할 경우 After Effects는 대기열에 나열된 컴포지션을 사용하여 Adobe Media Encoder를 실행합니다.

인코딩 프로세스는 다음 문서에 설명되어 있습니다.

Adobe 로고

내 계정 로그인

[Feedback V2 Badge]