Creative Cloud Charts (Preview) was introduced in the June 2015 release of Illustrator CC as a technology preview to gather real-world feedback from customers on the new service. Based on customer feedback, the Illustrator team has decided to pause Charts and revisit the design of the feature. The Charts preview won’t be included in Illustrator with the November 2015 release.

After November 30, 2015 when an Illustrator document containing a chart is opened, the Chart will be converted to standard Illustrator vector graphics. Customers who have Chart data they would like to save will have until January 15, 2016 to visit the Creative Cloud Charts service and copy the chart data to a spreadsheet that can be saved to their desktop. Please refer to the Creative Cloud Charts FAQ for more information.

Creative Cloud Charts (CC Charts) — a new Creative Cloud service — allows designers to create compelling charts and infographics.

Illustrator supports the following types of charts:

Scale by Value chart

You can now use any custom art to represent data values in the chart's design. Users now have unprecedented control and flexibility on chart elements – they can be stylized and treated for visual appeal, to create aesthetic charts, without breaking the link to the underlying data.

Column chart

Represent numerical data with column charts (histograms). From the CC Charts web view, you can edit the data or the layout of the chart.

Here's how a typical workflow looks like:

  1. Use the CC Charts tool to create a column chart or drag an available chart from a library in the Libraries panel to the artboard.
  2. (For Scale by Value charts) In Illustrator:
  3. In the Chart object context menu, click Edit on Creative Cloud. A new browser tab or window is opened.
  4. In the browser interface:

Creating a brand new chart
Get Started!

Creative Cloud Charts web view

All the action happens here!

Modifying chart layout 
Move stuff around - customize!

Chart options
Change the layout - customize!

Editing chart appearance
Change the appearance - customize!

Importing/ Defining chart data

Get your numbers in!

Editing chart data
Make your numbers count!

Tell us what you think
A short survey for you to tell us how we're doing.


Creating a new chart

  1. Select the CC Charts tool from the Tools panel (Shortcut key: J).

  2. Click-drag on the artboard to create a chart of the desired size.

    Note:

    If the column chart does not display, use the CC Charts context menu described in the next step to change the chart type to Column Chart.

  3. Click the chart to view the CC Charts context menu.

    CC Charts context menu
    CC Charts context menu

    Use the Charts menu to

    1. Change the chart type.
      Note: Currently, Illustrator supports the Scale by Value  and Columns charts .
    2. Duplicate the current chart .
    3. Edit the chart data and layout in the Creative Cloud Charts web view.

Creative Cloud Charts web view

When you create a column chart object, to work with the layout of the chart, import or modify data, and more, you must edit the chart online in Creative Cloud.

When you edit a chart on Creative Cloud, in addition to modifying the data and the appearance of the chart, you can perform other actions.

  • Details. Click the link to view various details about the chart.
  • Zoom. In the Chart tab, specify a zoom value, choose fit the chart to the available space, or a realistic 1:1 view.
    Note: The zoom value is only for display purposes and does not affect the dimensions of the chart artwork.
  • Share. Click Share > Send Link to forward a link of the image of the chart to a mail recipient.
  • Actions. Choose from these actions:
    • Rename. Provide a new name for the Chart.
    • Delete. Delete the chart.

Context-sensitive column chart options

For the column chart, you can change the layout for the:

  • Complete chart
  • Value (Y) axis
  • Category (X) axis
  • Chart data

The options available for each of the parts of the column chart are specific to the section. These options are described in the next section of this article.

Complete chart

(Default) Click anywhere on the column chart

Value (Y) axis:

Click the Y axis. This includes the axis line or on the values displayed on the axis

Value (Y) axis

Category (X) axis:

Click the X axis. This includes the axis line or on the categories displayed on the axis

Category (X) axis in Illustrator

Chart data:

Click the values of the chart data.

Chart data in Illustrator

Modifying chart layout

  1. In Illustrator, select a chart, and then do one of the following:

    • Click the Chart context widget, and then click Edit on Creative Cloud Charts
    • In the Control Panel, click Edit on Creative Cloud Charts
    • Right-click the chart and then click Edit on Creative Cloud Chart
  2. In the browser window that opens, ensure that you are in the Chart tab.

    Each chart type contains a number of configurable options. Click the respective chart type tab below.

  3. Click Save to retain any modifications to the layout.

Chart options

Scale by Value chart

Options to edit the appearance of the chart:

Scaling
  • Area: Artwork size scales in size according to data.
  • Stretch-to-fit: Artwork stretches in the Direction setting you specify.
Stretch artwork

Option available when Scaling = Stretch-to-fit:

  • Vertically: Artwork stretches in the vertical direction to depict data values.
  • Horizontally: Artwork stretches in the horizontal direction to depict higher data values.
Layout
  • Flow. Artwork is arranged in the order specified using Direction, Align, and Spacing settings.
  • Free-form. Artwork can be manually moved around.  
Direction

Option available when Layout Flow:

  • Left to Right
  • Top to Bottom
Alignment

Option available when Layout Flow:

  • Bottom-aligned:
  • Middle-alighned:
  • Top-aligned:
Spacing

Option available when Layout Flow

Use the slider to alter the spacing between successive artwork.

Column chart

By default, the chart edit options are displayed.

Note:

Some options are common to different parts of the column chart. For conciseness, the common options are not repeated.

Chart Elements

Chart
  • Data Labels: The data labels for each representative column
CATEGORY (X) AXIS
  • Axis Line: The line for the X axis
  • Axis Labels: The labels for the categories displayed on the X axis
  • Tick Marks: Pointers from the X axis to the axis labels 
VALUE (Y) AXIS
  • Major Gridlines: Chart line indicators for the values on the Y axis
  • Minor Gridlines: Chart line indicators for the intermediate values on the Y axis

Spacing

  • Between Columns: Space between the chart columns within a set. The value is a percentage of the width of the chart columns
  • Between Sets: Space between the sets of columns

Chart Size

  • W: Chart width in pixels
  • H: Chart height in pixels
  • : Changing the width or height proportionately updates the other dimension. Choose unlock to change each dimension independent of the other.

To change the Value (Y) or Category (X) axis specific options, click the Y or X axis

Axis Scale (Y axis)

Change the scale for the data and gridlines on the Y axis

OVERRIDE SCALE
  • Min: The minimum value for data on the Y axis
  • Max: The maximum value for data on the Y axis
GRIDLINES
  • Major: The scale for major gridlines on the Y axis
  • Minor: The scale for minor gridlines on the Y axis

Axis Position (Y and X axis)

POSITION
  • Left: (Default) Position Y axis line to the left of the chart
  • Right: Position Y axis line to the right of the chart

Tick Marks (Y and X axis)

POSITION
  • Outside: (Default) Position chart tick marks on the outside of the Y axis
  • Inside: Position chart tick marks on the inside of the Y axis

To change the data label options, click a data label in the chart

Axis Position

POSITION
  • Outside: (Default) Position the data labels above the chart columns
  • Middle: Position the data labels in the center of the chart columns

Label Format

Format

Choose the format of the data labels

  • Number: Display data labels as numeric values. Choose the number of decimal places and the thousand separator
  • Currency: Display data labels as currency. Choose the number of decimal places, the thousand separator, and the currency.
  • Percent: Display data labels as a percentage. Choose the number of decimal places and the thousand separator.
  • Scientific: Display data labels in scientific notation. Choose the number of decimal places.

Editing chart appearance

You can change the appearance of the chart. For example, you can change the artwork in Scale by Value charts or the color of bars in Columns charts.

Scale by Value charts

Replacing chart artwork

  1. In Illustrator, select a chart.

  2. In your document, draw new artwork, or drop any available artwork on the canvas.

    Note:

    Complex artwork such as objects with a gradient mesh, and raster objects are not supported.

    Drag and drop artwork on a chart to replace the current chart objects
    Drag and drop artwork on a chart to replace the current chart objects

Editing chart artwork

  1. In Illustrator, select a chart, and then click the Direct Selection Tool (A).

  2. Select one or more data representations, and modify the appearance of the objects.

    Change the appearance of individual objects to highlight your data points.
    Change the appearance of individual objects to highlight your data points

    Note:

    Some complex appearances such as effects, multiple fills, etc. do not appear while editing the chart on Creative Cloud. However, these appearances are preserved inside Illustrator.

Column charts

You can change the appearance of an entire chart, all the bars on the chart, a bar group, or a single bar. To change the appearance of a specific component of a chart, use the chart selection functionality in column charts.

Chart component selection using the Selection tool

A column chart contains different levels of selection. Illustrator, provides a drill-down functionality that allows you to successively select charts components at different levels.

For the column chart, the drill-down functionality works for the bars in the chart, the grid lines, and the axis lines.

To drill down the bars in a chart:

  1. To select the entire Column chart, click once on a bar on the chart area.
  2. To select all the bars in the chart, click again on a bar.
  3. To select a bar group in the chart, click again on a bar.
  4. To select a single bar, click again on the bar.

To drill down the grid lines:

  1. To select the entire Column chart, click once on the chart area.
  2. To select all the grid line in the chart, click again on a grid line.
  3. To select a single bar, click again on the bar.

To drill down an axis:

  1. To select the entire Column chart, click once on the chart area.
  2. To select an axis and its tick marks, click again on the axis or its tick marks.
  3. To select the axis line, click the axis line.
    OR
    To select a tick mark, click the axis tick mark.

Chart component selection using the Direct Selection tool

The chart drill-down functionality allows you to successively drill down the components in the chart. However, to directly select a component at the lowest level, you can use the Direct Selection tool.

To select a single bar, choose the Direct Selection tool (A), and click the bar.

Similarly, to select a single grid or axis line, choose the Direct Selection tool (A), and click the line.

Change the appearance of the components of column charts

By using the component selection functionality for charts, you can choose to change the appearance specific components of a chart.

To change the color of a group of bars:

  1. Use the drill-down functionality, to select a group of bars.
  2. Using the Illustrator Fill, choose a color to apply to the bars.
Changing the appearance of the components of column charts

Similarly, you can change the colors of the other bar groups. You can also change the appearance of the grid lines.

  1. Again, use the drill-down functionality, to select the grid lines.
  2. Using the Illustrator Stroke, change the lines to dotted lines.
Changing the appearance of the components of column charts

You can also change the appearance (such as font-family, font-size) of the text on the chart.

Select the entire chart.

  1. Open the Character panel (Window > Type > Character).
  2. Choose from the options in the Character panel, to change the text appearance.

To select specific text objects in the chart, you need to use the Direct Selection tool.

Importing/ Defining chart data

Note:

When you change data in the Charts tab, remember to click Apply, and then click Save, to ensure that the chart is updated in Illustrator.

  1. In Illustrator, select a chart, and then do one of the following:

    • Click the Chart pin, and then click Edit on Creative Cloud Charts
    • In the Control Panel, click Edit on Creative Cloud Charts
    • Right-click the chart and then click Edit on Creative Cloud Chart
  2. In the browser window that opens, click the Data tab.

  3. Click Choose File to import data from a Comma Separated Values (.csv) or Microsoft Excel (.xls or .xlsx) file.

    Note:

    Any data you import will always overwrite existing data already available for the chart.

  4. (Important) From the available rows and columns, click and drag the mouse over the data cells to represent in the chart, and then click Apply ().

    The Chart Preview page area is updated with a representation of the values that you have selected for the chart.

  5. Add, modify, and refine your data, and then click Save.

    Each time you click Save, the chart is updated in Illustrator.

    Note:

    The speed at which the chart is updated in Illustrator depends on the speed of internet connectivity. This may vary from as little as nearly-immediately to upto 12-15 seconds.

Editing chart data

Note:

When you change data in the Charts tab, remember to click Apply, and then click Save, to ensure that the chart is updated in Illustrator.

  1. In Illustrator, select a chart, and then do one of the following:

    • Click the Chart pin, and then click Edit on Creative Cloud Charts
    • In the Control Panel, click Edit on Creative Cloud Charts
    • Right-click the chart and then click Edit on Creative Cloud Chart
  2. In the browser window that opens, click the Data tab.

  3. Click any cell that contains data, or select a range of cells.

    A context-sensitive pin () appears.

  4. In the pin, click the three dots () to see the additional options available with the selected data.

  5. Select an option from the context-menu that appears to insert, delete, or sort cells.

    Use options to continue working with imported or available data.
    Use the options to continue working with imported or available data

  6. When done, click Apply, and then click Save, to ensure the changes are available inside Illustrator.

Creative Cloud Charts (Preview) survey

We appreciate feedback. Tell us how we're doing.

Here's a really quick survey that helps us understand your level of satisfaction with the Creative Cloud Charts (Preview) feature. Where possible, please provide as many details as possible. Thanks!

Survey link: https://www.surveymonkey.com/s/CC_Charts_Feedback.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy