Om du vill skapa innehåll av bildspelstyp som ska kunna spelas upp i Flash Player ska du exportera det antingen som en SWF- eller en FLA-fil. Den största skillnaden är att SWF-filer är klara för visning och kan inte redigeras, medan FLA-filer måste redigeras i Adobe Flash Professional för att kunna visas i Adobe Flash Player.

SWF

En exporterad SWF-fil är klar för visning i Adobe Flash Player och kan innehålla interaktiva element, till exempel sidövergångar, hyperlänkar, filmer, ljudklipp, animeringar och navigeringsknappar.

FLA

En exporterad FLA-fil innehåller bara några interaktiva element. FLA-filen kan öppnas i Flash Pro där du eller en Flash-utvecklare kan lägga till avancerade effekter innan den exporteras till SWF.

Exportera till Flash
Exportera till Flash

A. Exportera direkt till SWF B. Exportera till FLA för redigering i Flash Professional 

Skapa interaktiva SWF-filer (Flash) för webben

När du exporterar till SWF skapar du en interaktiv fil som är klar för visning i Adobe Flash Player eller i en webbläsare. SWF-filen kan innehålla knappar, sidövergångar, filmer och ljudfiler, animeringar och hyperlänkar tillagda i InDesign. Att exportera till SWF är ett praktiskt sätt att skapa ett interaktivt bildspel, eller en blädderbok, som baseras på ett InDesign-dokument.

Om du vill redigera dokumentet i Flash Pro innan du skapar SWF-filen exporterar du till FLA i stället för SWF. Se Skapa FLA-filer för webben.

SWF-export
SWF-export

A. Dokument i InDesign före SWF-export B. Interaktiv SWF-fil i webbläsaren 
  1. Skapa eller redigera InDesign-dokumentet för att förbereda det för export till Flash. Mer ingående information om hur du ställer in dokumentet för export finns i Att tänka på vid en Flash-export.

    • Lägg till navigeringsknappar som gör det möjligt för användarna att flytta från sida till sida i den exporterade SWF-filen. Du kan skapa knappar genom att dra ett objekt och konvertera det till en knapp med hjälp av knappanelen (välj Fönster > Interaktivt > Knappar). Du kan också använda panelen Exempelknappar för att dra fördefinierade navigeringsknappar till dokumentet. Se Skapa knappar.

    • Använd panelen Sidövergångar (välj Fönster > Interaktivt > Sidövergångar) om du vill lägga till sidövergångar som svep och lös upp. När du exporterar till SWF kan du också välja alternativet Inkludera interaktiv bläddring, som gör att användarna kan dra i ett sidhörn för att vända sida.

    • Använd animeringspanelen (välj Fönster > Interaktivt > Animering) om du vill lägga in förinställda rörelser. Se Animering.

  2. Om du vill exportera dokumentet till SWF-format väljer du Arkiv > Exportera

  3. Välj Använd InDesign-dokumentnamn som filnamn för utdata om du vill att den exporterade filen har samma namn som dokumentet från nästa export.

  4. Välj Flash Player (SWF) på menyn Filformat (Windows) eller Format (Mac OS) och klicka på Spara.

  5. Ställ in alternativen i dialogrutan Exportera SWF och klickar sedan på OK. Se SWF-exportalternativ.

När du exporterar en SWF-fil skapas separata HTML- och SWF-filer. Om SWF-filen innehåller filmer eller ljudklipp skapas även en resursmapp. Säkerställ att du skickar alla resurser om du vill distribuera eller överföra filerna till webben.

SWF-exportalternativ

Följande alternativ visas på flikarna Allmänt och Avancerat i dialogrutan Exportera SWF.

Exportera

Ange om den aktuella markeringen, alla sidor i dokumentet eller ett sidintervall ska tas med. Att välja Markering är särskilt användbart om du vill spara den exporterade SWF-filen så att den kan användas i en exporterad PDF-fil. Om du väljer Intervall anger du ett sidintervall, till exempel 1–7, 9 om du vill skriva ut sidorna 1 till och med 7 och 9. Se Ange vilka sidor som ska skrivas ut.

Skapa HTML-fil

Markera detta alternativ om du vill skapa en HTML-sida för uppspelning av SWF-filen. Alternativet är speciellt lämpligt för att snabbt förhandsvisa SWF-filen i webbläsaren.

Visa SWF efter export

Markera detta alternativ om du vill visa SWF-filen i standardwebbläsaren. Alternativet är bara tillgängligt om du skapar en HTML-fil.

Storlek (pixlar)

Ange om SWF-filen ska storleksförändras i procent, anpassas till en bildskärmsstorlek som du anger eller enligt de bredd- och höjdvärden du anger.

Bakgrund

Ange om bakgrunden till SWF är genomskinlig eller om den använder aktuell pappersfärg från panelen Färgrutor. Om du väljer Genomskinlig avaktiveras alternativen Sidövergångar och Inkludera interaktiv bläddring.

Interaktivitet och media

Välj Inkludera alla om du vill att filmer, ljud, knappar och animeringar ska kunna vara interaktiva i den exporterade SWF-filen. Välj Endast utseende om du vill inkludera det normala läget för knappar och filmförhandsgranskningar som statiska element. Om Endast utseende markeras exporteras animeringar så som de visas i layouten vid den tidpunkt de exporteras. Endast utseende markeras om du har valt Förenkla genomskinlighet på panelen avancerat.

Sidövergångar

Ange en sidövergång som ska användas på alla sidor under exporten. Om du anger sidövergångar i panelen Sidövergångar ska du välja alternativet Från dokument för att använda dessa inställningar.

Inkludera interaktiv bläddring

Om du markerar det här alternativet kan användare som spelar upp SWF-filen dra i ett hörn för att vända sida, vilket ger en känsla av att man vänder sida i en bok.

Bildrutehastighet

Högre bildrutehastigheter skapar jämnare animeringar, men filstorleken ökar. Uppspelningstiden påverkas inte av bildrutehastigheten.

Text

Ange hur InDesign-text ska visas. Välj Flash Classic-text för att få sökbar text vilket resulterar i mindre filstorlek. Välj Konvertera till konturer för att få text som en serie med mjuka raka linjer, ungefär som att konvertera text till konturer. Välj Konvertera till pixlar för att få texten som en bitmappsbild. Text som har konverterats till pixlar kan visas taggig när du zoomar in den.

Rastrera sidor

Med detta alternativ konverteras alla objekt på InDesign-sidor till bitmapp-bilder. Om du väljer detta alternativ får du en större SWF-fil och sidobjekten kan bli kantiga i konturen när du zoomar in.

Förenkla genomskinlighet

Det här alternativet tar bort live-genomskinlighet från SWF-filen och bevarar det genomskinliga utseendet. All interaktivitet tas emellertid bort från SWF-filen om du väljer det här alternativet.

Komprimering

Välj Auto för att den bästa kvaliteten för färger och gråskalebilder ska väljas automatiskt. För de flesta filer uppnås en tillfredsställande kvalitet med detta alternativ. JPEG (förstörande) används lämpligen för bilder i gråskala eller färg. JPEG-komprimering är förstörande, vilket innebär att bildinformation tas bort, vilket i sin tur kan medföra sämre bildkvalitet. Filstorleken minskas emellertid med så liten informationsförlust som möjligt. Eftersom data tas bort vid en JPEG-komprimering kommer filstorleken att minskas. Om du väljer PNG (icke-förstörande) exporteras filen utan att några data förloras vid komprimeringen.

Obs!

Om du märker att bildkvaliteten försämras i genomskinliga bilder när du exporterar till SWF, ska du förbättra kvaliteten genom att välja PNG (icke-förstörande).

JPEG-kvalitet

Detaljrikedomen i den exporterade bilden anges. Ju bättre kvalitet, desto större filstorlek. Detta alternativ är nedtonat om du väljer PNG (icke-förstörande) för bildkomprimeringen.

Upplösning

Ange upplösning för bitmappsbilder i den exporterade SWF-filen. Det är viktigt att du väljer en hög upplösning så att alla tittare kan zooma in på pixelbaserat innehåll i den exporterade SWF-filen. En hög upplösning ökar filstorleken avsevärt.

Skapa FLA-filer för webben

När du exporterar dina InDesign-dokument till FLA-filer kan du öppna filen i Adobe Flash® CS5 Professional om du vill redigera innehållet. Exportera till FLA i InDesign CS5-format ersätter XFL-export i InDesign CS4. Använd redigeringsmiljön i Flash för att redigera eller lägga till video, ljud, animering och komplex interaktivitet.

Om du vill exportera InDesign-dokumentet direkt till ett format som kan öppnas direkt i en webbläsare, ska du använda SWF-format i stället för FLA. Se Skapa interaktiva SWF-filer (Flash) för webben.

FLA-export
FLA-export

A. Dokument i InDesign före FLA-export B. FLA-fil öppnad i Flash Pro 
  1. Skapa eller redigera InDesign-dokumentet för att förbereda det för export till Flash. Mer ingående information om hur du ställer in dokumentet för export finns i Att tänka på vid en Flash-export.

  2. Om du vill exportera dokumentet till FLA-format väljer du Arkiv > Exportera. Välj Flash CS5 Professional (FLA) på menyn Filformat (Windows) eller Format (Mac OS) och klicka på Spara.

  3. I dialogrutan Exportera Flash CS5 Professional (FLA) anger du alternativen och klickar sedan på OK. Information om exportalternativ finns i FLA-exportalternativ.

  4. Öppna den exporterade FLA-filen i Flash Professional.

FLA-exportalternativ

Följande alternativ visas i dialogrutan Exportera Flash CS5 Professional (FLA).

Exportera

Ange om den aktuella markeringen, alla sidor i dokumentet eller ett sidintervall ska tas med. Om du väljer Intervall anger du ett sidintervall, till exempel 1–7, 9 om du vill skriva ut sidorna 1 till och med 7 och 9. Se Ange vilka sidor som ska skrivas ut.

Rastrera sidor

Med detta alternativ konverteras alla objekt på InDesign-sidor till bitmapp-bilder. Om du väljer detta alternativ får du en större FLA-fil och sidobjekten blir kantiga i konturen när du zoomar in.

Förenkla genomskinlighet

När du väljer detta alternativ görs alla objekt genomskinliga. Det kan vara svårt att animera genomskinliga objekt i Adobe Flash Pro.

Storlek (pixlar)

Ange om FLA-filen ska storleksförändras i procent, anpassas till en bildskärmsstorlek som du anger eller enligt de bredd- och höjdvärden du anger.

Interaktivitet och media

Välj Inkludera alla om du vill att filmer, ljud, knappar och animeringar ska kunna inkluderas i den exporterade FLA-filen. Om dokumentet innehåller ett flerlägesobjekt konverteras det till en filmklippssymbol där varje läge visas i sin egen ram på tidslinjen.

Välj Endast utseende om du vill inkludera det normala läget för knappar och filmförhandsgranskningar som statiska element. Om Endast utseende markeras exporteras animeringar så som de visas i layouten vid den tidpunkt de exporteras. Endast utseende markeras om du har valt Förenkla genomskinlighet.

Text

Ange hur InDesign-text ska visas. Välj Flash TLF-text om du vill utnyttja alla textlayoutattribut som finns i Flash Professional. Om du väljer det här alternativet ska du välja Infoga punkter för mjukt bindestreck. Välj Flash Classic-text för att få sökbar text vilket resulterar i mindre filstorlek. Välj Konvertera till konturer för att få text som en serie med mjuka raka linjer, ungefär som att konvertera text till konturer. Välj Konvertera till pixlar för att få texten som en bitmappsbild. Text som har konverterats till pixlar kan visas taggig när du zoomar in den.

Komprimering

Välj Auto för att den bästa kvaliteten för färger och gråskalebilder ska väljas automatiskt. För de flesta filer uppnås en tillfredsställande kvalitet med detta alternativ. JPEG (förstörande) används lämpligen för bilder i gråskala eller färg. JPEG-komprimering är förstörande, vilket innebär att bildinformation tas bort, vilket i sin tur kan medföra sämre bildkvalitet. Filstorleken minskas emellertid med så liten informationsförlust som möjligt. Eftersom data tas bort vid en JPEG-komprimering kommer filstorleken att minskas. Om du väljer PNG (icke-förstörande) exporteras filen utan att några data förloras vid komprimeringen.

JPEG-kvalitet

Detaljrikedomen i den exporterade bilden anges. Ju bättre kvalitet, desto större filstorlek. Detta alternativ är nedtonat om du väljer PNG (icke-förstörande) för bildkomprimeringen.

Upplösning

Ange upplösning för bitmappsbilder i den exporterade FLA-filen. Det är viktigt att du väljer en hög upplösning så att alla tittare kan zooma in på pixelbaserat innehåll. En hög upplösning ökar filstorleken avsevärt.

Att tänka på vid en Flash-export

Du ska tänka på nedanstående när du skapar InDesign-dokument för SWF- eller FLA-utdata.

Att tänka på vid dokumentinställningar

Hur InDesign-sidor konverteras

När du exporterar till SWF eller FLA blir InDesign-uppslag olika klipp på en tidslinje, ungefär som bilder i ett bildspel. Varje uppslag kopplas till en ny nyckelbildruta. I Flash Player bläddrar du mellan uppslagen i det exporterade dokumentet genom att trycka på piltangenterna eller genom att klicka på de interaktiva knapparna.

Obs!

När du skapar ett dokument som är tänkt för webben, ska du välja Webb på menyn Återgivning i dialogrutan Nytt dokument.

Sidstorlek

När du skapar ett dokument kan du välja en speciell upplösning, till exempel 800 × 600, på menyn Sidstorlek i dialogrutan Nytt dokument. Vid exporten kan du dessutom välja skala eller upplösning för den exporterade SWF- eller FLA-filen.

Funktioner för interaktivitet

Knappar, sidövergångar, hyperlänkar, animering och mediefiler kan inkluderas i exporterade SWF- och FLA-filer.

Knappar

När det finns knappar i den exporterade SWF- eller FLA-filen, är åtgärderna Nästa sida och Föregående sida speciellt viktiga kontroller för uppspelningen i Flash Player. Vissa åtgärder som fungerar i interaktiva PDF-filer har emellertid ingen effekt i Flash Player. När du väljer en åtgärd i knappanelen ska du inte välja något alternativ under Endast PDF.

Obs!

Du kan lägga till navigeringsknappar som är förformaterade med åtgärderna Gå till nästa sida och Gå till föregående sida. Välj Exempelknappar på menyn i knappanelen. Se Lägga till en knapp från panelen Exempelknappar.

Sidövergångar

Alla sidövergångar fungerar bra i Flash Player. Förutom sidövergångar som visas när du vänder sida kan du lägga till interaktiv bläddring vid exporten för att vända sida genom att dra i sidhörnen.

Hyperlänkar

Skapa länkar till webbplatser eller andra sidor i dokumentet. Hyperlänkarna bryts i FLA-filer.

Filmer och ljudklipp

Film- och ljudklipp inkluderas i en exporterad SWF-fil om de finns i ett format som stöds, till exempel SWF, FLV, F4V och MP4 för filmer och MP3 för ljudklipp.

När du exporterar till FLA inkluderas bara förhandsgranskningsbilden i FLA-filen. Mediefiler som stöds visas i en resursmapp som sparas på samma plats som den exporterade FLA-filen.

Att tänka på vid konvertering

Färger

För SWF- och FLA-filer används RGB-färger. När ett dokument exporteras till SWF eller FLA, konverteras alla färger (till exempel CMYK och LAB) automatiskt till sRGB. I InDesign konverteras dekorfärger till motsvarande RGB-bearbetningsfärger.

Du undviker oönskade färgförändringar i genomskinliga teckningar med text genom att välja Redigera > Genomskinlighetsblandning > Dokument-RGB. Om du vill undvika oönskade färgändringar i bilder med genomskinlighet, ska du inte använda förlustgivande komprimering vid exporten.

Text

När du exporterar till SWF eller FLA kan du bestämma om text ska tolkas som Flash-text eller konverteras till konturer eller pixlar. Text som exporteras som Flash Classic-text går att redigera när FLA-filen öppnas i Adobe Flash CS5 Professional och kan sökas i webbläsare när den sparas som SWF-filer.

Bilder

När du exporterar bilder till SWF eller FLA kan du ändra bildkomprimeringen, JPEG-kvaliteten och upplösningsinställningar.

När du exporterar bilder till FLA sparas en bild som monterats flera gånger i ett InDesign-dokument som en enda bildresurs med delad lagringsplats. Observera att ett stort antal vektorbilder i InDesign-dokumentet kan orsaka prestandaproblem i den exporterade filen.

Om du vill minska filstorleken placerar du repeterande bilder på mallsidor och undviker att kopiera och klistra in. Om samma bild placeras flera gånger i dokumentet och den inte omformas eller beskärs, kommer endast en kopia av filen att exporteras i FLA-filen. Bilder som kopieras och klistras in hanteras som separata objekt.

Standard är att en placerad Illustrator-fil hanteras som en enskild bild i FLA-filen, medan en Illustrator-fil som kopieras och klistras in genererar många enskilda objekt. Du får bäst resultat om du placerar Illustrator-bilden som en PDF-fil i stället för att kopiera och klistra in från Illustrator. Kopierings- och inklistringsoperationen resulterar i fler redigeringsbara sökvägar.

Obs!

Du kan ändra inställningarna så att Illustrator-objekten klistras som ett objekt i stället för en samling av ett antal små vektorer. I Illustrator-inställningarna Filhantering och urklipp markerar du PDF och avmarkerar AICB (inget stöd för genomskinlighet). I InDesign-inställningarna för urklippshantering markerar du både Föredra PDF vid inklistring och Kopiera PDF till Urklipp.

Genomskinlighet

Innan du exporterar till SWF ska du kontrollera att genomskinliga objekt inte överlappar andra interaktiva element som exempelvis knappar eller hyperlänkar. Om ett genomskinligt objekt överlappar interaktiva element kan interaktiviteten gå förlorad i samband med exporten. Du kanske vill förenkla genomskinligheten innan du exporterar till FLA.

När du väljer en förlustgivande komprimering kan i vissa fall bildkvaliteten minska på bilder med genomskinlighet. Välj PNG (icke-förstörande) om du vill förbättra kvaliteten vid export.

3D-attribut

3D-attribut stöds inte i exporterade SWF- och FLA-filer.

Denna produkt är licensierad enligt en Creative Commons Erkännande-Ickekommersiell-Dela Lika 3.0 Unported-licens  Twitter™- och Facebook-inlägg omfattas inte av villkoren i Creative Commons-licensen.

Juridiska meddelanden   |   Onlinesekretesspolicy