En tabell består av celler i rader och kolumner. En cell är som en textram där du kan lägga till text, förankrade ramar eller andra tabeller. Du kan skapa tabeller i Adobe InDesign CS5 eller exportera dem från andra program.

Obs!

Se till att du har layoutvyn öppen när du skapar, redigerar och formaterar tabeller i Adobe InCopy.

Skapa tabeller

En tabell består av celler i rader och kolumner. En cell är som en textram där du kan lägga till text, textbundna bilder eller andra tabeller. Du kan skapa tabeller från början eller genom att konvertera befintlig text. Du kan även bädda in en tabell i en annan tabell.

När du skapar en tabell fyller den nya tabellen bredden för behållartextramen. Tabellen infogas på samma rad som insättningspunkten om den är i början av raden, eller på nästa rad om insättningspunkten är i mitten av raden.

Tabeller monteras med omgivande text på samma sätt som textbundna bilder. En tabell flyttas till exempel mellan kopplade ramar när punktstorleken för den text som finns ovanför den ändras eller när text läggs till eller tas bort. Däremot kan inte en tabell visas på en ram med text på bana.

Artikeln Mind Your Table Manners (på engelska) av Michael Murphy handlar om att skapa och formatera tabeller.

Jeff Witchel från Infiniteskills.com visar dig grunderna för att konfigurera tabeller i den här videon.

Skapa en ny tabell

När du skapar en tabell i InDesign har du möjlighet att skapa tabellen i en befintlig textram (Använda alternativet Infoga tabell). Du kan även skapa en tabell och låta InDesign skapa den omgivande textramen (Använda alternativet Skapa tabell).

Använda alternativet Infoga tabell

  1. Du ritar en tabell i en befintlig textram genom att använda textverktyget och placera insättningspunkten där du vill att tabellen ska visas.

  2. Välj Tabell > Infoga tabell.

    Obs!

    Alternativet Skapa tabell är tillgängligt när markören inte befinner sig i en textram.

  3. Ange antal rader och kolumner.
  4. Om innehållet i tabellen ska sträcka sig över flera spalter eller ramar anger du antalet tabellhuvud- och tabellfotsrader som du vill att informationen ska repeteras i.
  5. (Valfritt) Ange ett tabellformat.
  6. Klicka på OK.

    Den nya tabellen fyller ut textramens bredd.

Använda alternativet Skapa tabell

När du använder alternativet Skapa tabell för att skapa en tabell behöver du inte först skapa en textram i ditt dokument. När du ritar tabellen i dokumentet skapar InDesign en textram med samma storlek som tabellen.

  1. Välj Tabell > Skapa tabell.

    Obs!

    Alternativet Infoga tabell är tillgängligt när markören befinner sig i en textram.

  2. Ange antal rader och kolumner.
  3. Om innehållet i tabellen ska sträcka sig över flera spalter eller ramar anger du antalet tabellhuvud- och tabellfotsrader som du vill att informationen ska repeteras i.
  4. (Valfritt) Ange ett tabellformat.
  5. Klicka på OK.
  6. Använd tabellmarkören för att rita tabellen du behöver.

    InDesign skapar en textram i samma storlek som det ritade området och placerar tabellen i textramen.

Radhöjden i en tabell avgörs av det angivna tabellformatet. I ett tabellformat kan det till exempel finnas cellformat som formaterar vissa delar av tabellen. Om något av dessa cellformat innehåller styckeformat kommer styckeformatets värde för radavstånd att ange radhöjden i det området. Om du inte använder något styckeformat anges radhöjden av dokumentets standardinstruktionsmarginal. (Instruktionsmarginalen baseras på värdet för radavståndet. I det här sammanhanget är instruktionsmarginalen den ungefärliga höjden på den framhävda delen av markerad text.)

Skapa en tabell från befintlig text

Se till att du ställt in texten på rätt sätt innan du konverterar texten till en tabell.

  1. Du förbereder text för konvertering genom att infoga tabbar, komman, radbrytningar eller något annat tecken som avgränsare av kolumner. Infoga tabbar, komman, radbrytningar eller ett annat tecken som avgränsare av rader. (I många situationer kan text konverteras till en tabell utan att först redigeras.)
  2. Använd textverktyget  till att markera den text du vill konvertera till en tabell.
  3. Välj Tabell > Konvertera text till tabell.
  4. Ange var de nya raderna och kolumnerna ska börja, för både Kolumnavgränsare och Radavgränsare. Välj Tabb, Komma eller Stycke eller skriv tecknet, till exempel ett semikolon (;), i fältet Kolumnavgränsare och Radavgränsare. (Alla tecken du skriver visas på menyn nästa gång du skapar en tabell från text.)
  5. Om du anger samma avgränsare för både kolumner och rader anger du det antal kolumner som du vill att tabellen ska innehålla.
  6. (Valfritt) Formatera tabellen genom att ange ett tabellformat.
  7. Klicka på OK.

Om en rad har färre objekt än antalet kolumner i en tabell fylls resten av raden ut med tomma celler.

Bädda in en tabell i en annan tabell

  1. Gör något av följande:
    • Markera cellerna eller tabellen du vill bädda in och välj Redigera > Klipp ut eller Kopiera. Placera insättningspunkten i den cell där du vill att tabellen ska visas och välj sedan Redigera > Klistra in.

    • Klicka i en cell och välj Tabell > Infoga tabell, ange antal rader och kolumner och klicka på OK.

  2. Justera cellindraget om det behövs. (Se Formatera text i en tabell.)

Om du skapar en tabell i en cell kan du inte använda musen till att markera någon del av tabellen som döljer cellkanten. Du kan i stället öka rad- eller kolumnstorleken eller placera insättningspunkten i början av raden och sedan flytta insättningspunkten och markera text genom att använda kortkommandon.

Importera tabeller från andra program

När du använder kommandot Montera för att importera ett Microsoft Word-dokument som innehåller tabeller, eller ett Microsoft Excel-kalkylblad, visas importerade data i en redigerbar tabell. Du kan ändra formateringen med hjälp av dialogrutan Importalternativ.

Du kan också klistra in data från ett Excel-kalkylark eller en Word-tabell i ett InDesign- eller InCopy-dokument. Med inställningen Urklippshantering anger du hur text som klistras in från ett annat program ska formateras. Om du markerar Endast text visas informationen som oformaterad tabbavgränsad text som du därefter kan konvertera till en tabell. Om du markerar All information hamnar den inklistrade texten i en formaterad tabell.

Om du klistrar in text från ett annat program i en befintlig tabell måste du infoga tillräckligt med rader och kolumner så att den inklistrade texten får plats. Du måste även markera alternativet Endast text under inställningen Urklippshantering och se till att minst en cell är markerad (om du inte vill bädda in den inklistrade tabellen i en cell).

Importera tabellen med kommandot Montera om du vill ha mer kontroll över hur den importerade tabellen formateras eller om du vill behålla kalkylbladsformateringen. Om du vill skapa en länk till kalkylbladet väljer du Skapa länkar vid montering av text- och kalkylarksfiler i filhanteringsinställningarna.

Obs!

Du kan även kopiera och klistra in tabbavgränsad text över flera tabellceller. Denna teknik är användbar när du vill ersätta innehållet men behålla formateringen. Anta att du vill uppdatera innehållet i en formaterad tabell i en månadstidskrift. Ett sätt är att länka till ett Excel-kalkylark. Om innehållet kommer från olika källor kan du kopiera den tabbavgränsade texten med det nya innehållet, markera ett cellintervall i den formaterade InDesign-tabellen och klistra in.

Lägga till text i en tabell

Du kan lägga till text, förankrade objekt, XML-märkord och andra tabeller i tabellceller. Höjden för en tabellrad ökar så att ytterligare textrader ska få plats, om du inte har angett en fast radhöjd. Du kan inte lägga till fotnoter i tabeller.

  1. Gör något av följande när du använder textverktyget :
    • Placera insättningspunkten i en cell och skriv texten. Tryck på Enter så skapas ett nytt stycke i samma cell. Flytta dig till nästa cell genom att trycka på Tabb (om du trycker på Tabb i den sista cellen infogas en ny rad). Flytta dig bakåt till föregående cell genom att trycka på Skift+Tabb.

    • Kopiera text, placera insättningspunkten i en cell och välj Redigera > Klistra in.

    • Placera insättningspunkten i en cell där du vill lägga till text. Välj Arkiv > Montera och dubbelklicka sedan på en textfil.

Lägga till bilder i en tabell

  1. Placera insättningspunkten i den cell där du vill lägga till bilden.

  2. Gör något av följande:
    • Välj Arkiv > Montera och välj en eller flera grafikfiler.
    • Markera och dra och släpp en eller flera bilder från kategorin Bilder på panelen CC Libraries.

    Bilden eller bilderna är tillgängliga på monteringsverktyget.

  3. Om du vill montera bilden eller bilderna klickar du i varje tabellcell.

  4. Gör något av följande:

Obs!

Det går inte att dra och släppa InDesign-utdrag från kategorin Bilder på panelen CC Libraries.

När du lägger till en bild som är större än cellen ökas höjden på cellen så att bilden får plats. Däremot ökas inte bredden på cellen – bilden kan sträcka sig utanför cellens högra sida. Om raden som bilden placeras på har fast höjd kommer alla bilder som är högre än radhöjden att dölja cellen.

Obs!

Om du vill undvika dolda celler monterar du bilden utanför tabellen, ändrar storlek på bilden och klistrar sedan in den i tabellcellen.

Du kan också montera bilder i tabellceller på följande sätt:

  • Välj Objekt > Förankrat objekt > Infoga och ange inställningarna. Du kan lägga till en bild i det förankrade objektet vid ett senare tillfälle.
  • Kopiera en bild eller ram, placera insättningspunkten och välj Redigera > Klistra in.

Lägga till tabellhuvuden och tabellfötter

När du skapar en lång tabell kan tabellen sträcka sig över flera spalter, ramar eller sidor. Genom att använda huvud- och fotrader kan du upprepa informationen längst upp och längst ned på varje delad del av tabellen.

Du kan lägga till huvud- och fotrader när du skapar tabellen. I dialogrutan Tabellalternativ kan du också lägga till huvud- och fotrader samt ändra deras utseende i tabellen. Du kan konvertera tabellrader till huvud- eller fotrader.

Lägga till tabellhuvuden och tabellfötter
Huvudrader upprepade en gång per ram

Obs!

Om du vill numrera tabeller sekventiellt, till exempel Tabell 1A, Tabell 1B o.s.v., lägger du till en variabel i tabellhuvudet eller tabellfoten. (Se Skapa löpande bildtexter för bilder och tabeller.)

  1. Markera raderna längst upp i tabellen om du vill skapa huvudrader, eller längst ned i tabellen om du vill skapa fotrader.
  2. Välj Tabell > Konvertera rader > Till tabellhuvud eller Till tabellfot.
  1. Placera insättningspunkten i tabellen och välj Tabell > Tabellalternativ > Huvuden och fötter.
  2. Ange antalet huvud- eller fotrader. Tomma rader kan läggas till längst upp eller ned i tabellen.
  3. Ange om informationen i huvudet eller foten ska visas i varje textspalt (om textramarna har flera spalter), en gång per ram eller bara en gång per sida.
  4. Välj Hoppa över första om du inte vill att huvudinformationen ska visas på tabellens första rad. Välj Hoppa över sista om du inte vill att fotinformationen ska visas på tabellens sista rad.

    Alternativet Hoppa över första är särskilt användbart när du vill indikera att sidhuvudet eller sidfoten fortsätter. För t.ex. en tabell som täcker flera sidor kanske du vill att sidhuvudstexten ”Tabell 2 (fortsättning)” ska användas. Eftersom du inte vill att ”(fortsättning)” ska visas på den första tabellsidan, väljer du Hoppa över första och skriver bara Tabell 2 på den första raden i tabellen.

  5. Klicka på OK.

Du kan utföra ett antal funktioner för att skapa liknande rader och kolumner eller duplicera dem. 

Du kan i första hand utföra följande funktioner på raderna och kolumnerna i en tabell:

  • Dra och släppa tabellrader och kolumner från en position till en annan inom samma tabell.
  • Duplicera rader och kolumner.
  • Klistra in rader och kolumner före eller efter en annan rad/kolumn.
  • Kopiera innehållet i en rad till en kolumn eller innehållet i en kolumn till en rad.

Dra och släpp och duplicera rader/kolumner

Du kan flytta tabellrader och kolumner från en position till en annan inom samma tabell. Följ de här stegen för att dra och släppa och duplicera rader/kolumner.

  1. Markera den rad eller kolumn du vill dra och släppa på en annan rad eller kolumn. Kontrollera att hela kolumnen eller raden har markerats. Du kan inte dra och släppa delvis markerade rader eller kolumner.

  2. Om du hovrar över de markerade raderna visas en unik markör som anger att markeringen kan flyttas.

  3. Objektraden kan dras och släppas. Du kan växla kolumner med rader. Om du drar en rad kan du endast släppa den som en rad. Om du drar en kolumn kan du endast släppa den som en kolumn.

    Dra och släppa rader och kolumner
    Dra och släppa rader och kolumner

    När du flyttar en rad från en position förblir det totala antalet rader samma som tidigare, alltså endast tre.

    Obs!

    Du kan bara dra och släppa inom samma tabell.

  4. Om du vill duplicera en rad eller en kolumn, trycker du på eller håller ned Alt- (Windows) eller Opt-tangenten (Mac) när du har markerat en rad eller en kolumn. Flera markerade rader eller kolumner kan dras och släppas samtidigt.

  5. Dra och släpp den markerade raden eller kolumnen på den avsedda positionen. Det totala antalet rader eller kolumner ökar när den markerade entiteten dupliceras.

    Du kan även kopiera innehåll från sidhuvud- och sidfotsrader till tabellrader (genom att trycka på alternativtangenten). Tabellrader kan också dupliceras och konverteras till sidhuvud- och sidfotsrader.

Du kan bara dra och släppa rubrikrader inom sidhuvudavsnitt (gäller endast om du har flera rubrikrader) om du inte väljer alt/opt för att duplicera raderna. Tabellrader kan inte dras och släppas på sidhuvudavsnitt om du inte väljer alt/opt för att duplicera raderna.

Kopiera rader/kolumner och klistra in före/efter

Du kan kopiera och klistra in rader före eller efter en markerad rad. Du kan använda alternativen Klistra in före/efter arbetsflöde för att kopiera rader/kolumner i en tabell och klistra in dem i en annan tabell.

  1. Markera en rad/kolumn.

  2. Markera kolumnen eller raden.

  3. Välj Tabell > Klistra in före/Klistra in efter. 

  1. Gör något av följande:
    • Placera insättningspunkten på huvud- eller fotraden och välj sedan Tabell > Konvertera rader > Tabellkropp.

    • Välj Tabell> Tabellalternativ> Huvuden och fötter och ange sedan ett annat antal huvudrader eller fotrader.

Denna produkt är licensierad enligt en Creative Commons Erkännande-Ickekommersiell-Dela Lika 3.0 Unported-licens  Twitter™- och Facebook-inlägg omfattas inte av villkoren i Creative Commons-licensen.

Juridiska meddelanden   |   Onlinesekretesspolicy