Tutorial em vídeo: Objetos inteligentes vinculados

Tutorial em vídeo: Objetos inteligentes vinculados
Infinite Skills

Entender objetos inteligentes

Objetos inteligentes são camadas que contêm dados de imagens rasterizadas ou vetoriais, como arquivos Photoshop ou Illustrator. Objetos inteligentes preservam o conteúdo de origem da imagem com todas as suas características originais, permitindo que você execute edição não destrutiva à camada.

Na Photoshop CC e CS6, você pode incorporar o conteúdo de uma imagem em um documento do Photoshop. Na Photoshop CC, você também pode criar objetos inteligentes vinculados cujo conteúdo é extraído de arquivos de imagem externos. O conteúdo de um objeto inteligente vinculado é atualizado quando o arquivo de origem é alterado.

Objetos inteligentes vinculados são diferentes dos exemplos duplicados de um objeto inteligente em um documento do Photoshop. Com Objetos inteligentes vinculados, você pode usar um arquivo de origem compartilhado entre vários documentos do Photoshop que é um conceito familiar e de boas-vindas para designers da web.

Benefícios dos objetos inteligentes

Com Objetos inteligentes, é possível:

  • Executar transformações não destrutivas. É possível dimensionar, girar, inclinar, distorcer, transformar a perspectiva ou deformar uma camada sem perder os dados ou a qualidade da imagem original porque as transformações não afetam os dados originais

  • Trabalhar com dados de vetor, como arte final vetorial do Illustrator, que, do contrário, poderiam ser rasterizados no Photoshop.

  • Executar filtragem não destrutiva. É possível editar filtros aplicados a Objetos inteligentes a qualquer hora.

  • Editar um Objeto inteligente e atualizar automaticamente todas as instâncias vinculadas.

  • Aplicar uma máscara de camada vinculada ou desvinculada à camada do Objeto inteligente.

  • Tentar vários designs com imagens de espaço reservado de baixa resolução que posteriormente serão substituídas por versões finais.

Não é possível executar operações que alteram dados de pixel, como pintura, subexposição, superexposição ou clonagem, diretamente em uma camada de Objeto inteligente, a menos que ela seja primeiro convertida em uma camada regular, que será rasterizada. Para executar operações que alteram os dados de pixel, você pode editar os conteúdos de um Objeto inteligente, clonar uma nova camada sobre a camada do Objeto inteligente, editar duplicações do Objeto inteligente ou criar uma nova camada.

Observação:

Quando você transforma um Objeto inteligente que possui um Filtro inteligente aplicado a ele, o Photoshop desativa os efeitos do filtro enquanto a transformação é realizada. Os efeitos de filtro são aplicados novamente quando a transformação é concluída. Consulte Aplicar filtros inteligentes.

Camada regular e Objeto inteligente no painel Camadas. O ícone indica Objeto inteligente.
Camada regular e Objeto inteligente no painel Camadas. O ícone no canto inferior direito da miniatura indica um Objeto inteligente.

(Photoshop CC) Um objeto inteligente vinculado no painel Camadas
(Photoshop CC) Um objeto inteligente vinculado no painel Camadas

Criar objetos inteligentes incorporados

É possível criar objetos inteligentes incorporados usando vários métodos: por meio do comando Abrir como objeto inteligente, inserindo um arquivo (CS6) ou um arquivo como incorporado (CC, CS6), colando dados do Illustrator ou convertendo uma ou mais camadas do Photoshop em objetos inteligentes.

  • Siga um destes procedimentos:
    • (CC) Escolha Arquivo > Inserir incorporado para importar arquivos como objetos inteligentes em um documento do Photoshop aberto.
    • Escolha Arquivo > Abrir como objeto inteligente, selecione um arquivo e clique em Abrir.
    • (CS6) Escolha Arquivo > Inserir para importar arquivos como objetos inteligentes em um documento do Photoshop aberto.

    Observação:

    Embora seja possível inserir arquivos JPEG, é melhor inserir arquivos PSD, TIFF ou PSB, porque você pode adicionar camadas, modificar pixels e salvar novamente o arquivo sem perdas. (Salvar um arquivo JPEG modificado requer o achatamento de novas camadas e a recompactação da imagem, causando a degradação da qualidade da imagem.)

    • Escolha Camada > Objeto inteligente > Converter para Objeto inteligente para converter uma camada selecionada em um Objeto inteligente.
    • No Bridge, escolha Arquivo > Inserir > No Photoshop para importar um arquivo como um objeto inteligente para um documento do Photoshop aberto.

    Observação:

    Uma maneira fácil de trabalhar com arquivos de camera raw é abrindo-os como objetos inteligentes. É possível clicar duas vezes na camada Objeto inteligente contendo o arquivo raw a qualquer hora para ajustar as configurações do Camera Raw.

    Assista ao vídeo Abrir uma imagem como um Objeto inteligente para saber como.

    • Selecione uma ou mais camadas e escolha Camada > Objetos inteligentes > Converter em objeto inteligente. As camadas são agrupadas em um objeto inteligente.

    • Arraste camadas de PDF ou do Adobe Illustrator ou objetos para um documento do Photoshop.

    • Cole a arte-final do Illustrator em um documento do Photoshop, e escolha Objeto inteligente na caixa de diálogo Colar. Para obter o máximo em flexibilidade, ative PDF e AICB (Sem suporte para Transparência) na seção Controle de arquivo e Área de transferência da caixa de diálogo Preferências do Adobe Illustrator.

Criar objetos inteligentes vinculados | Photoshop CC

Observação:

O recurso Objeto inteligente vinculado está disponível nas versões 14.2 do Photoshop (Photoshop CC | janeiro de 2014) e posteriores.

Na Photoshop CC, é possível criar objetos inteligentes vinculados. O conteúdo de objetos inteligentes vinculados será atualizado quando o arquivo da imagem de origem for alterado. Objetos inteligentes vinculados são especialmente úteis para equipes ou nos casos em que os itens podem ser reutilizados em outros projetos.

Siga estas etapas para criar um objeto inteligente vinculado:

  1. Escolha Arquivo> Local vinculado.
  2. Selecione um arquivo apropriado e clique em Inserir.

O objeto inteligente vinculado é criado e exibido no painel Camadascom um ícone de link (
).

Observação:

Você também pode criar um Objeto inteligente vinculado em um documento aberto arrastando e soltando o arquivo adequado enquanto mantém a seguinte tecla pressionada:

(Windows) Tecla Alt
(Mac OS) Tecla Option

Para alterar esse comportamento padrão, desative Preferências > Geral > Sempre criar objetos inteligentes ao inserir.

Economias de tamanhos de arquivos usando objetos inteligentes vinculados

Como os objetos inteligentes vinculados mantêm uma dependência de um arquivo externo em vez de incorporar um arquivo de origem ao documento que os contém, eles geralmente resultam em tamanhos de arquivos muito menores. Quando objetos inteligentes vinculados não armazenam o arquivo original no documento que os contém, ainda assim armazenam uma versão achatada e redimensionada de dados do arquivo original. Em alguns casos, o tamanho desses dados pode ser muito maior que o tamanho do arquivo original, tornando Salvar tamanho do arquivo parecer insignificante.

Atualizar objetos inteligentes vinculados

Se um arquivo de origem externa for alterado quando um documento do Photoshop que o referencia é aberto, o objeto inteligente vinculado relevante será atualizado automaticamente. Entretanto, quando você abre um documento do Photoshop que contém objetos inteligentes vinculados fora de sincronia, pode atualizar os objetos inteligentes:

  • Clique com o botão direito em uma camada de Objeto inteligente vinculado e escolha Atualizar conteúdo modificado.
  • Escolha Camada > Objetos inteligentes > Atualizar conteúdo modificado.

Objetos inteligentes vinculados cujas imagens de origem foram alteradas são destacados visualmente no painel Camadas:

Objetos inteligentes vinculados fora de sincronia destacados no painel Camadas
Objetos inteligentes vinculados fora de sincronia são destacados no painel Camadas.

Observação:

É possível atualizar todos os Objetos inteligentes vinculados no documento atual do Photoshop escolhendo Camada > Objetos inteligentes > Atualizar todo o conteúdo modificado.

Objetos inteligentes vinculados sem arquivos de origem externos destacados no painel Camadas
Objetos inteligentes vinculados sem arquivos de origem externos são destacados no painel Camadas.

Observação:

Ao detectar alterações em Objetos inteligentes vinculados ou ao atualizar um Objeto inteligente vinculado, o Photoshop só procura o arquivo vinculado imediato. Links aninhados em objetos inteligentes não são atualizados.

Resolver um link rompido de objeto inteligente

Para resolver um objeto inteligente vinculado a uma origem externa ausente, siga estas etapas:

  1. Clique com o botão direito do mouse no ícone da camada Objeto inteligente vinculado e escolha Resolver link rompido.
  2. Navegue até o novo local do objeto ausente.
  3. Clique em Inserir.

Exibir propriedades de objeto inteligente vinculado

Com uma camada de objeto inteligente vinculado selecionada no painel Camadas, escolha Janela > Propriedades.

As seguintes propriedades são exibidas:

  • O caminho do arquivo de origem externa do objeto inteligente vinculado
  • O tamanho do objeto inteligente vinculado e as coordenadas posicionais (X, Y)

É possível realizar as seguintes ações diretamente do painel Propriedades:

  • Editar o conteúdo do arquivo de imagem externo. Se necessário, o Photoshop abre um aplicativo externo que possa processar o arquivo de imagem de origem. Por exemplo, o Photoshop abre o Adobe Illustrator se a imagem de origem externa for um arquivo .ai.
  • Integre o objeto inteligente vinculado ao documento atual.

Incorporar objetos inteligentes vinculados

Siga um destes procedimentos:

  • Clique com o botão direito do mouse em uma camada do objeto inteligente vinculado no painel Camadas e escolha Incorporar vinculados.
  • Escolha Camada > Objetos inteligentes > Incorporar vinculados.
  • No painel Propriedades, clique em Incorporar.

Observação:

Escolha Camada > Objetos inteligentes > Incorporar todos os vinculados para incorporar todos os objetos inteligentes vinculados ao documento do Photoshop.

Empacotar objetos inteligentes vinculados

É possível empacotar objetos inteligentes vinculados em um documento do Photoshop, de forma que os arquivos de origem sejam salvos em uma pasta no computador. Uma cópia do documento do Photoshop é salva com os arquivos de origem na pasta.

  1. Escolha Arquivo > Pacote.
  2. Selecione o local onde deseja colocar os arquivos de origem e uma cópia do documento do Photoshop.

Todos os objetos inteligentes de áudio ou vídeo vinculados no documento são incluídos também.

Observação:

É preciso salvar o arquivo antes de embalar os objetos inteligentes vinculados que ele contém.

Como o Photoshop encontra arquivos vinculados

O Photoshop busca sempre arquivos vinculados no último local relacionado conhecido. Se o arquivo vinculado não for encontrado nesse local, o Photoshop irá procurar por ele:

  • no último local absoluto conhecido
  • usando um alias salvo (somente Mac OS)
  • na mesma pasta do documento que o contém

Esse recurso permite mover, copiar e compartilhar pastas e arquivos do projeto com um risco mínimo de localizar links quebrados.

Observação:

A caixa de diálogo Resolver itens ausentes sempre exibe o último caminho absoluto conhecido de arquivos de origem ausentes.

Converter um objeto inteligente incorporado em um objeto inteligente vinculado

É possível converter um objeto inteligente incorporado em um objeto inteligente vinculado. Transformações, filtros e outros efeitos aplicados ao objeto inteligente incorporado são preservados quando ele é convertido.

Faça o seguinte:

  1. Selecione uma camada de objeto inteligente incorporado no documento do Photoshop.
  2. Escolha Camada > Objeto inteligente > Converter em vinculado.
  3. Selecione o local no computador em que deseja salvar o arquivo de origem. Digite um nome para o arquivo, incluindo uma extensão suportada. Por exemplo, link_file.jpg.

Filtrar o painel Camadas por objetos inteligentes | Photoshop CC

  1. No painel Camadas, selecione Objeto inteligente no menu pop-up de filtragem.
Filtrar camadas por objetos inteligentes
Filtrar camadas por objetos inteligentes

  1. Clique em um dos seguintes ícones:
  •     Filtro para objetos inteligentes vinculados atualizados
  •     Filtro para objetos inteligentes vinculados fora de sincronia
  •     Filtro para objetos inteligentes vinculados ausentes
  •     Filtro para objetos inteligentes incorporados

Observação:

É possível usar o botão de alternância () para desativar a filtragem de camada.

Duplicar um objeto inteligente incorporado

  • No painel Camadas, selecione uma camada de objeto inteligente e siga um destes procedimentos:
    • Para criar um Objeto inteligente duplicado vinculado ao original, selecione Camada > Nova > Camada via cópia ou arraste a camada Objeto inteligente para o ícone Criar uma nova camada, na parte inferior do painel Camadas. As edições feitas no documento original afetam a cópia e vice-versa.

    • Para criar um objeto inteligente duplicado que não esteja vinculado ao original, escolha Camada > Objetos Inteligentes > Novo objeto inteligente por cópia. As edições feitas no documento original não afetam a cópia.

    Um novo objeto inteligente aparece no painel Camadas, com o mesmo nome do original e tendo como sufixo “cópia”.

Editar o conteúdo de um objeto inteligente

Quando você edita um objeto Inteligente, o conteúdo de origem é aberto no Photoshop (se o conteúdo for um arquivo de dados raster ou de camera raw) ou o aplicativo que processa o formato inserido por padrão (por exemplo, Adobe Illustrator ou Adobe Acrobat). Ao salvar alterações no conteúdo de origem, as edições aparecem em todas as instâncias vinculadas do objeto inteligente no documento do Photoshop.

  1. Selecione o objeto inteligente no painel Camadas e siga um destes procedimentos:
    • Escolha Camada > Objeto inteligente > Editar conteúdo.
    • Clique duas vezes na miniatura de Objetos inteligentes, no painel Camadas.
    • No painel Propriedades, clique em Editar conteúdo.
  2. Clique em OK para fechar a caixa de diálogo.
  3. Faça edições no arquivo de conteúdo de origem e, em seguida, escolha Arquivo > Salvar.

    O Photoshop atualiza o Objeto Inteligente para refletir as atualizações feitas. (Caso você não veja as alterações, torne ativo o documento do Photoshop que contém o objeto inteligente.)

Substituir o conteúdo de um objeto inteligente

É possível substituir os dados da imagem em um objeto inteligente ou em várias instâncias vinculadas. Esse recurso permite que você atualize rapidamente um design visual ou substitua imagens de espaço reservado de baixa resolução por versões finais.

Observação:

Quando você substitui um objeto inteligente, qualquer dimensionamento, alteração ou efeitos aplicados ao primeiro objeto inteligente são mantidos.

  1. Selecione o Objeto Inteligente, e escolha Camada > Objetos Inteligentes > Substituir conteúdo.
  2. Navegue até o arquivo que deseja usar e clique em Inserir.
  3. Clique em OK.

    O novo conteúdo é inserido no objeto inteligente.

Converter um objeto inteligente incorporado ou vinculado em uma camada

A conversão de um objeto Inteligente em uma camada normal rasteriza o conteúdo para o tamanho atual. Só converta um objeto inteligente em uma camada normal se você não precisar mais editar os dados do objeto inteligente. Transformações, alterações e filtros aplicados a um objeto inteligente não são mais editáveis depois que o objeto inteligente é rasterizado.

  • Selecione o objeto inteligente e escolha Camada > Objetos inteligentes > Rasterizar.  

Observação:

Para recriar o objeto inteligente, selecione novamente suas camadas originais e recomece o processo. O novo objeto inteligente não manterá as transformações aplicadas ao objeto inteligente original.

Exportar o conteúdo de um objeto inteligente incorporado

  1. Selecione o Objeto inteligente no painel Camadas e escolha Camada > Objetos inteligentes > Exportar conteúdo.
  2. Escolha um local para o conteúdo do objeto inteligente e clique em Salvar.

    O Photoshop exporta o objeto inteligente em seu formato inserido original (JPEG, AI, TIF, PDF ou outros formatos). Se o objeto inteligente tiver sido criado a partir de camadas, ele será exportado no formato PSB.

Esta obra está licenciada sob uma licença não adaptada da Creative Commons Attribution-Noncommercial-Share Alike 3.0  As publicações do Twitter™ e do Facebook não são cobertas pelos termos do Creative Commons.

Avisos legais   |   Política de privacidade online