Příručka uživatele Zrušit

Úpravy textu

  1. Příručka uživatele aplikace InDesign
  2. Seznámení se s aplikací InDesign
    1. Úvod do aplikace InDesign
      1. Co je v aplikaci InDesign nového
      2. Systémové požadavky
      3. Běžné dotazy
      4. Používání knihoven Creative Cloud
    2. Pracovní plocha
      1. Základy práce s pracovní plochou
      2. Panel nástrojů
      3. Nastavení předvoleb
      4. Dotyková pracovní plocha
      5. Výchozí klávesové zkratky
      6. Obnovení dokumentu a vrácení akce
      7. Rozšíření Capture
  3. Vytváření a rozložení dokumentů
    1. Dokumenty a stránky
      1. Vytváření dokumentů
      2. Práce se vzorovými stránkami
      3. Práce se stránkami dokumentu
      4. Nastavení velikosti stránky, okrajů a spadávky
      5. Práce se soubory a šablonami
      6. Vytváření souborů knih
      7. Přidání základního číslování stran
      8. Číslování stránek, kapitol a oddílů
      9. Převod dokumentů QuarkXPress a PageMaker
      10. Sdílení obsahu
      11. Základy práce se spravovanými soubory
      12. Ukládání dokumentů
    2. Mřížky
      1. Mřížky
      2. Formátování mřížek
    3. Pomůcky k rozvržení
      1. Pravítka
  4. Přidání obsahu
    1. Text
      1. Přidání textu do rámečků
      2. Zřetězení textu
      3. Arabské a hebrejské funkce v aplikaci InDesign
      4. Vytvoření textu na cestě
      5. Odrážky a číslování
      6. Glyfy a speciální znaky
      7. Sazba textu
      8. Textové proměnné
      9. Vytváření kódů QR
      10. Úpravy textu
      11. Zarovnání textu
      12. Obtékání textu kolem objektů
      13. Ukotvené objekty
      14. Připojený obsah
      15. Formátování odstavců
      16. Formátování znaků
      17. Hledání a nahrazování
      18. Kontrola pravopisu a jazykové slovníky
    2. Typografie
      1. Používání písem v aplikaci InDesign
      2. Vyrovnání párů a prostrkání
    3. Formátování textu
      1. Formátování textu
      2. Tabulátory a odsazení
    4. Kontrola textu
      1. Sledování a posouzení změn
      2. Přidání redakčních poznámek v aplikaci InDesign
      3. Import poznámek souboru PDF
    5. Přidání odkazů
      1. Vytváření tabulky obsahu
      2. Poznámky pod čarou
      3. Vytvoření rejstříku
      4. Poznámky na konci
      5. Popisky
    6. Styly
      1. Odstavcové a znakové styly
      2. Styly objektů
      3. Iniciály a vnořené styly
      4. Práce se styly
      5. Proklad
    7. Tabulky
      1. Formátování tabulek
      2. Vytváření tabulek
      3. Styly tabulek a buněk
      4. Výběr a úpravy tabulek
      5. Tahy a výplně tabulky
    8. Interaktivita
      1. Hypertextové odkazy
      2. Dynamické dokumenty PDF
      3. Záložky
      4. Tlačítka
      5. Formuláře
      6. Animace
      7. Křížové odkazy
      8. Struktura souborů PDF
      9. Přechody stránky
      10. Filmy a zvuky
      11. Formuláře
    9. Grafika
      1. Cesty a tvary
      2. Kreslení nástrojem tužka
      3. Kreslení nástrojem pero
      4. Použití nastavení čar (tahů) 
      5. Složené cesty a tvary
      6. Úpravy cest
      7. Ořezové cesty
      8. Změna vzhledu rohu
      9. Zarovnání a rozmístění objektů
      10. Propojená a vložená grafika
      11. Integrace datových zdrojů AEM
    10. Barvy a průhlednost
      1. Použití barvy
      2. Použití barev z importované grafiky
      3. Práce se vzorky barev
      4. Míchání tiskových barev
      5. Odstíny
      6. Přímé a výtažkové barvy
      7. Prolnutí barev
      8. Přechody
      9. Sloučení průhledné kresby
      10. Použití efektů průhlednosti
  5. Sdílení
    1. Sdílení a spolupráce        
    2. Sdílení kvůli hodnocení
    3. Recenze sdíleného dokumentu aplikace InDesign
    4. Správa zpětné vazby 
  6. Publikování
    1. Export a publikování
      1. Publish Online
      2. Export obsahu do formátu EPUB
      3. Možnosti Adobe PDF
      4. Exportování obsahu do HTML
      5. Export do Adobe PDF
      6. Export do formátu JPEG
      7. Export do formátu HTML
      8. Přehled řešení DPS a AEM Mobile
    2. Tisk
      1. Tisk brožur
      2. Tiskové značky a spadávky
      3. Tisk dokumentů
      4. Tiskové barvy, výtažky a hustota rastru
      5. Přetisk
      6. Vytváření souborů PostScript a EPS
      7. Kontrola souborů před výstupem používaná před předáním souborů
      8. Tisk miniatur a dokumentů nadměrné velikosti
      9. Příprava souborů PDF pro poskytovatele služeb
      10. Příprava tisku barevných výtažků
  7. Rozšíření aplikace InDesign
    1. Automatizace
      1. Sloučení dat
      2. Zásuvné moduly
      3. Rozšíření Capture v aplikaci InDesign
      4. Skriptování
Poznámka:

Spravedlivý jazyk: Od verze InDesign 2022 (verze 17.0) nahrazujeme neinkluzivní jazyk tak, aby ten nový vyjadřoval základní hodnoty inkluzivity ve společnosti Adobe. Jakýkoli odkaz na Master page (vzorovou stránku) je v našich článcích nápovědy pro anglické, dánské, maďarské, španělské, italské, brazilské, portugalské a japonské národní prostředí nahrazen pojmem Parent page (vzorová stránka).

Výběr textu

  1. Pomocí nástroje text proveďte jeden z následujících úkonů:
    • Znak, slovo či celý textový blok vyberete přetažením kurzoru nad daný prvek.
    • Dvojitým kliknutím vyberte slovo. Mezery vedle slova se nevyberou.
    • Trojím kliknutím kdekoliv v řádku vyberte řádek. Pokud v předvolbách není vybraná volba Trojí kliknutí vybere řádek, vybere trojí kliknutí celý odstavec.

    • Pokud je vybraná volba Trojí kliknutí vybere řádek, čtyřnásobné kliknutí kdekoliv v odstavci vybere celý odstavec.

    • Pětinásobným kliknutím vyberete celý článek, případně můžete kliknout kamkoli v článku a zvolit Úpravy > Vybrat vše.

Poznámka:

Pokud s použitím výše uvedených postupů vyberete text obsahující kotvu poznámky, poznámka a její obsah se také vybere.

Pokud nemůžete vybrat text v rámečku, textový rámeček je pravděpodobně v zamčené vrstvě nebo na vzorové stránce. Zkuste odemknout vrstvu nebo přejít na vzorovou stránku. Textový rámeček může být také umístěn za jiným rámečkem nebo průhledným objektem. Viz Vybírání textu v zakrytém rámečku.

Změna funkce trojího kliknutí

  1. Zvolte Úpravy > Předvolby > Text (Windows) nebo InDesign > Předvolby > Text (Mac OS).
  2. Vyberte volbu Trojí kliknutí vybere řádek, chcete-li, aby se trojím kliknutím vybral řádek (to je výchozí nastavení). Odznačte tuto volbu, pokud chcete, aby se trojím kliknutím vybral odstavec.

Vybírání textu v zakrytém rámečku

  1. Použijte nástroj pro výběr , přidržte klávesu Ctrl (Windows) nebo Command (Mac OS) a kliknutím vyberte textový rámeček.
  2. Vyberte nástroj text a pak klikněte uvnitř textového rámečku nebo vyberte text.

Zobrazení skrytých (netištěných) znaků

  1. Zvolte Text > Zobrazovat skryté znaky.
  2. Pokud se skryté znaky přesto nezobrazí, vypněte režim náhledu. Vyberte Zobrazit > Režim zobrazení > Normální a odznačte volbu výběrem Zobrazit > Náhled přetisků.

Zobrazí se netištěné znaky, jako jsou mezery, tabulátory, konce odstavců, rejstříkové značky a konce článků. Tyto speciální znaky jsou viditelné pouze v okně dokumentu a v okně editoru článku; nelze je vytisknout ani poslat do výstupních formátů, jako je PDF a XML. Skryté znaky se zobrazí ve stejné barvě, jako má vrstva.

Netištěné znaky skryté (nahoře) a viditelné (dole)

Anne Marie Concepcion publikovala komplexní seznam speciálních znaků na stránce Free Guide to InDesign Special Characters.

Seznam skrytých znaků

Skrytý znak

Co představuje

Konec odstavce

Měkké zalomení řádku

Mezera

Konec článku

Neviditelný rozdělovník

Nerozdělitelný rozdělovník

Tabulátor

Tabulátor odsazení zprava

Odsadit sem

Konec vnořeného stylu zde

Rozdělovač

Ideografická mezera

Em mezera

En mezera

Nerozdělitelná mezera

Nerozdělitelná mezera (pevná šířka)

Vlasová mezera

Šestinová mezera

Tenká mezera

Čtvrtinová mezera

Třetinová mezera

Interpunkční mezera

Číslicová mezera

Zarovnávací mezera

Nový sloupec

Nový rámeček

Nová stránka

Nová lichá stránka

Nová sudá stránka

Vynucené zalomení řádku

Poznámka InCopy

Poznámka InCopy (v editoru článků)

Značka umístění (pouze InCopy)

Značka rejstříku

Značka rejstříku (v editoru článků)

Skrytý podmíněný text

Skrytý podmíněný text (v editoru článků)

Záložka nebo značka cíle záložky (často textová kotva)

Značka cíle záložky nebo hypervazby (v editoru článků)

Cíl hypervazby (v editoru článků)

Odstavec s křížovým odkazem

Křížový odkaz (v editoru článků)

Ukotvený objekt

Ukotvený objekt (v editoru článků)

Tag XML

Tag XML (v editoru článků)

Poznámka pod čarou (v editoru článků)

Tabulka (v editoru článků)

Proměnná (v editoru článků)

Značka rejstříku (v editoru článků)

Vložení přechodu do nového sloupce, rámečku nebo na novou stránku

Vložením speciálních oddělovacích znaků do textu můžete nastavit přechod do nového sloupce, rámečku nebo stránky.

  1. Kliknutím nástrojem text umístěte textový kurzor do místa, kde chcete mít zalomení.
  2. Zvolte Text > Vložit znak rozdělení a pak z podnabídky zvolte volbu zalomení.
Poznámka:

Zalomení můžete také vytvořit pomocí klávesy Enter na numerické klávesnici. Chcete-li přejít do nového sloupce, stiskněte Enter; do nového rámečku Shift+Enter a na novou stránku Ctrl+Enter (Windows) nebo Command+Enter (Mac OS).

Chcete-li odstranit znak zalomení, zvolte Text > Zobrazovat skryté znaky, abyste netištěné znaky viděli, a pak oddělovací znak vyberte a odstraňte.

Poznámka:

Pokud vytvoříte zalomení změnou nastavení odstavce (v dialogovém okně Volby rozdělování), zalomení se vloží před odstavec, který obsahuje nastavení. Pokud vytvoříte zalomení pomocí speciálního znaku, zalomení se použije hned za speciálním znakem.

Volby rozdělování

Nabídka Text > Vložit znak rozdělení obsahuje následující volby:

Nový sloupec

Text natéká do dalšího sloupce v platném textovém rámečku. Pokud má rámeček pouze jeden sloupec, text přeteče do následujícího zřetězeného rámečku.

Nový rámeček

Text natéká do následujícího zřetězeného textového rámečku bez ohledu na nastavení sloupců platného textového rámečku.

Nová stránka

Text natéká na následující stránku s textovým rámečkem, který je zřetězený s platným textovým rámečkem.

Nová lichá stránka

Text natéká na následující lichou stránku s textovým rámečkem, který je zřetězený s platným textovým rámečkem.

Nová sudá stránka

Text natéká na následující sudou stránku s textovým rámečkem, který je zřetězený s platným textovým rámečkem.

Konec odstavce

Vloží konec odstavce (stejný jako stisknutí Enter nebo Return).

Vynucené zalomení řádku

Vynutí rozdělení řádku v místě, kde je tento znak vložený, a začne další řádek bez začátku nového odstavce (stejného efektu dosáhnete stiskem kláves Shift+Enter nebo Shift+Return). Vynucené zalomení řádku se také označuje jako měkké konec odstavce.

Podmíněné zalomení řádku

Určuje, kde by mělo dojít k zalomení textu, pokud je řádek nutné zalomit. Libovolné zalomení řádku se podobá libovolnému rozdělovníku, po zalomení řádku však nedojde k přidání rozdělovníku.

Související volby rozdělování jsou dostupné v dialogovém okně Volby rozdělování a v dialogovém okně Volby stylu odstavců.

Práce s editorem článku

Text můžete v aplikaci InDesign upravovat buď přímo na stránkách nebo v okně editoru článku. Při psaní a úpravách v okně editoru článku se celý článek zobrazí s písmem, velikostí písma a mezerami, které vyberete v předvolbách, bez rušivého formátování a grafického rozvržení. Editor článku je také místem, kde můžete zobrazit sledování změn textu.

Každý článek se objeví v samostatném okně editoru článku. V editoru článku se objeví celý text článku, včetně přesahujícího textu. Můžete otevřít více oken editoru článku současně, včetně více oken pro stejný článek. Svislé hloubkové pravítko ukazuje, do jaké míry vyplňuje text rámeček, a čára označuje místo, kde text přesahuje.

Když upravujete článek, změny se projeví i v okně s rozvržením stránky. Otevřené články jsou uvedené v nabídce Okna. V okně editoru článku nemůžete vytvořit nový článek.

Okno Editor článku

A. Styly odstavců B. Rozdělovač, jehož přetažením lze nastavit šířku sloupce C. Svislé hloubkové pravítko D. Indikátor přesahujícího textu 

Můžete zobrazit nebo upravovat tabulky v editoru článků, který usnadňuje úpravy zobrazováním textu v po sobě jdoucích sloupcích a řádcích. Tabulky můžete rychle rozbalit nebo sbalit a rozhodnout, zda je zobrazovat po řádcích nebo po sloupcích.

Editor článku také zobrazuje text, který byl přidán, odstraněn nebo upraven se zapnutou volbou Sledovat změny. Viz Sledování a posouzení změn.

Otevření editoru článku

  1. Vyberte textový rámeček, kliknutím umístěte textový kurzor do textového rámečku nebo vyberte více rámečků z různých článků.
  2. Zvolte Úpravy > Upravit v editoru článku.
Poznámka:

Chcete-li zobrazit další instanci stejného okna editoru článku, nastavte okno editoru článku jako aktivní a zvolte Okna > Uspořádat > Nové okno.

Návrat do okna rozvržení

  1. V editoru článku proveďte jeden z následujících úkonů:
    • Zvolte Úpravy > Upravit v rozvržení. Když použijete tuto metodu, zobrazí se v okně rozvržení stejný výběr textu nebo poloha textového kurzoru jako v editoru článku a okno článku zůstane otevřené, ale přesune se za okno rozvržení.

    • Klikněte do okna rozvržení. Okno článku zůstane otevřené, ale posune se za okno rozvržení.

    • Zavřete okno editoru článku.

    • Zvolte název dokumentu z konce nabídky Okna.

Zobrazení nebo skrytí položek editoru článku

Můžete zobrazit nebo skrýt sloupec s názvem stylu a hloubkové pravítko, rozbalit nebo sbalit poznámky pod čarou a zobrazit nebo skrýt znaky konců odstavců, které určují začátek nového odstavce. Tato nastavení ovlivní všechna otevřená okna editoru článku i další okna, která následně otevřete.

  • S aktivním editorem článku zvolte Zobrazit > Editor článku > Zobrazovat sloupec s názvy stylů nebo Skrýt sloupec s názvy stylů. Můžete také nastavit šířku sloupce s názvy stylů přetažením svislého rozdělovacího pruhu. Další okna editoru článku budou mít stejnou šířku sloupce.
  • S aktivním editorem článku zvolte Zobrazit > Editor článku > Zobrazovat hloubkové pravítko nebo Skrýt hloubkové pravítko.
  • S aktivním editorem článku zvolte Zobrazit > Editor článku > Rozbalit všechny poznámky pod čarou nebo Sbalit všechny poznámky pod čarou.
  • S aktivním editorem článku zvolte Zobrazit > Editor článku > Zobrazit znaky konců odstavců nebo Skrýt znaky konců odstavců.

Předvolby editoru článku

Ke změně vzhledu editoru článku použijte předvolby Zobrazení editoru článku. Přestože editor článku potlačuje všechny atributy stylu textu kromě těch nejzákladnějších, některé objekty a atributy reprezentovány jsou, včetně následujících:

Atribut

Ikona

Tabulka

Včleněné objekty

XML tagy

Proměnné

Zdroje hypervazeb

Kotvy hypervazeb

Křížový odkaz

Skrytý podmíněný text

Poznámka

Poznámky pod čarou

Rejstříkové značky

Odstraněný text

Přidaný text

Přesunutý text

 

Volby zobrazení textu

Zvolte písmo pro zobrazení, velikost, řádkování, barvu textu a pozadí. Můžete také určit jiné téma, například vyberte Klasický systém, chcete-li zobrazit žlutý text na černém pozadí. Tato nastavení ovlivňují pouze zobrazení textu v okně editoru článku, ne jeho vzhled v okně rozvržení.

Zapnout vyhlazení

Vyhladí zubaté okraje textu podle zvolené volby Typ vyhlazení: Optimalizované pro LCD, Měkké nebo Výchozí nastavení, které používá k vyhlazení textu stupně šedi. Optimalizované pro LCD používá při vyhlazování textu barvy místo stupňů šedi a funguje nejlépe pro pozadí ve světlé barvě s černým textem. Měkké používá stupně šedi, ale dává světlejší rozostřenější vzhled než volba Výchozí.

Volby kurzoru

Změní vzhled textového kurzoru. Vyberte například Blikající, pokud chcete, aby kurzor blikal.

Text z rámečků včleněných do textu se neobjeví v okně editoru článku pro vzorový článek, ale může se objevit v samostatném okně editoru článku.

Použití Editoru textů (Beta)

Při práci s textem v dokumentech InDesign můžete zaznamenat během úprav částí textu jisté zpoždění. Zpoždění bude patrnější, když v dokumentu zpracováváte velké množství textu nebo když jsou povoleny další funkce aplikace. Editor textů (Beta) je v takových případech jednoduchou alternativou, která může psaní textu zrychlit. Stačí při psaní v textovém poli spustit Editor textů (Beta) a pokračovat v psaní v novém okně, nyní už bez dalšího zpoždění. 

Okno Editor textů (Beta) můžete spustit pomocí jedné z těchto možností:

  1. Klikněte na Úpravy > Upravit v Editoru textů (Beta).
  2. Alternativně můžete také spustit Editor textů (Beta) pomocí místní nabídky v textovém poli. Klikněte pravým tlačítkem do textového pole a vyberte možnost Upravit v Editoru textů (Beta).
Kliknutí pravým tlačítkem, Editor textů

 3.    Windows: Použijte klávesovou zkratku Alt+Shift+Y.

        macOS: Použijte klávesovou zkratku Opt+Shift+Y.

V okně Editor textů (Beta) můžete pokračovat v psaní textu. Po provedení změn v původním rozepsaném textu klikněte na Hotovo
.

Dialogové okno Editor textů
Okno Editor textů (Beta)

 Editor textů (Beta) umožňuje upravovat pouze obsah textu, jeho formátování ani styly nepodporuje. Editor textů (Beta) se otevře v novém okně. Abyste se vrátili do dokumentu, musíte toto okno zavřít.

Editor textů (betaverze) představuje experimentální funkci, která je k dispozici ve vybraných zeměpisných oblastech a pro vybranou skupinu uživatelů. 

Používání podmíněného textu

Podmíněný text představuje způsob, jak vytvářet různé verze stejného dokumentu. Po vytvoření podmínek je použijte na textové rozsahy. Potom můžete vytvářet různé verze dokumentů pomocí zobrazování nebo skrytí podmínek. Například, pokud vytváříte uživatelskou příručku pro počítač, můžete vytvořit oddělené podmínky pro Mac OS a Windows. Předtím než vytisknete verzi uživatelské příručky pro Mac OS, můžete zobrazit všechen text, na který se vztahuje podmínka „Mac“ a skrýt veškerý text, na který se vztahuje podmínka „Windows“. Při tisku uživatelské příručky pro Windows budete postupovat opačně.

Zobrazuje se podmíněný text

A. Zobrazují se všechny podmínky B. Indikátory podmíněného textu 

Podmíněný text je skrytý

A. Podmínka „Mac“ je skrytá B. Symboly podmínek jsou skryté 

Podmínky lze použít pouze na text. Lze vytvářet podmíněné ukotvené objekty, pouze však pomocí výběru značky ukotveného objektu. Podmínky lze použít na text v buňkách tabulky, nelze je však použít na buňky tabulky, sloupce nebo řádky. Podmínky nelze použít na text v zamknutých článcích InCopy.

Plánování podmíněných dokumentů

Při plánování projektu s podmíněným textem, zjistěte povahu materiálu a zvažte, jak může více lidí spolupracovat na zadaném dokumentu. Naplánujte si konzistentní zpracování podmíněného textu, aby byl dokument snadno použitelný a upravovatelný. Řiďte se následujícími pokyny.

Počet verzí

Definujte, kolik verzí bude výsledný projekt obsahovat. Pokud například vytváříte příručku, která popisuje program, který lze provozovat na platformách Windows a Mac OS, budete nejspíše potřebovat vytvořit alespoň dvě verze: verzi pro systém Windows a verzi pro systém Mac OS. Pokud chcete vytvořit tyto verze s redakčními poznámkami vloženými do textu v průběhu procesu kontroly, budete nejspíše potřebovat ještě více verzí: verzi pro Mac OS s komentáři, verzi pro Mac OS bez komentářů, verzi pro Windows s komentáři a verzi pro Windows bez komentářů.

V případě dokumentů s mnoha podmínkami můžete definovat sadu podmínek, které je možné použít na dokument a vytvářet tak rychlé verze.

Počet požadovaných tagů podmínek

Rozhodněte se, kolik tagů podmínek bude potřeba k vytvoření požadovaných verzí. Verze dokumentu je definována jedinečnou sadou tagů podmínek. Například verze dokončené uživatelské příručky pro systém Windows může být definována jako zobrazený tag podmínky Windows, skrytý tag podmínky Mac OS a skrytý tag podmínky Poznámky. V tomto případě se musíte rozhodnout, zda se použije jeden tag podmínky pro poznámky k verzi Windows a další pro poznámky k verzi Mac OS, nebo zda se použije jeden tag podmínky pro oba druhy poznámek.

Organizace obsahu

Odhadněte rozsah podmíněnosti dokumentu a způsob organizace materiálu, aby se zjednodušilo vytváření a úpravy. Například můžete organizovat knihu tak, aby byl podmíněný text omezen na několik dokumentů. Nebo se můžete rozhodnout uchovávat verze určité kapitoly v oddělených souborech místo vytváření podmíněného textu a potom použít jiný soubor knihy pro každou verzi knihy.

V některých případech, například při práci s více jazyky, je vhodné vytvořit oddělené vrstvy, které můžete zobrazit nebo skrýt místo toho, abyste používali podmínky, přičemž každá vrstva bude obsahovat text v jiném jazyce.

Strategie vytváření tagů

Určete nejmenší jednotku podmíněného textu Například, pokud se bude dokument překládat do jiného jazyka, měla by být nejmenší jednotkou podmíněného textu celá věta. Protože se v průběhu překládání často mění pořadí slov, nastavení podmíněného textu na části vět by mohlo komplikovat překlad.

Nekonsistentní používání podmínek u mezer a interpunkce může mít za následek nadbytečné mezery v textu nebo nesprávně napsaná slova. Rozhodněte, zda budou mezery a interpunkce podmíněné. Pokud podmíněný text začíná nebo končí interpunkcí, nastavte interpunkci také jako podmíněnou. Tím se usnadní čtení textu při práci s více než jednou verzí dokumentu.

Chcete-li se vyhnout potížemi s mezerami, například pokud za nepodmíněnou mezerou následuje podmíněná mezera, nastavte pravidla pro zpracování mezer, které následují po podmíněném textu (vždy podmíněné nebo vždy nepodmíněné).

Chcete-li předejít nejasnostem, určete pořadí, ve kterém se bude podmíněný text zobrazovat a používat v dokumentu.

Rejstříky a křížové odkazy

Při vytváření rejstříku dokumentu dbejte na to, zda jsou rejstříkové značky umístěny uvnitř nebo vně podmíněného textu. Mějte na paměti, že rejstříkové značky ve skrytém podmíněném textu nejsou zahrnuty ve vytvářeném rejstříku.

Pokud vytváříte křížový odkaz na podmíněný text, ujistěte se, že zdrojový text obsahuje stejnou podmínku. Například, pokud přidáte křížový odkaz v odstavci „Windows“ a textová kotva se nachází v podmínce „Mac“, křížový odkaz bude nevyřešen v případě, že bude podmínka „Mac“ skrytá. U křížového odkazu v panelu Hypervazby se zobrazuje „HT“.

Pokud vytváříte křížový odkaz na odstavec, ve kterém je některý text podmíněný a potom změníte nastavení viditelnosti této podmínky, aktualizujte křížový odkaz.

Vytvoření podmínek

Podmínky, které vytvoříte, se ukládají pouze v aktuálním dokumentu. Pokud při vytváření podmínky není otevřený žádný dokument, tato podmínka bude součástí všech nových dokumentů.

Podmíněný text lze snadno identifikovat pomocí indikátorů podmínek, například vlnité červené podtržení.

  1. Zvolte Okna > Text a tabulky > Podmíněný text, aby se zobrazil panel Podmíněný text.
  2. Zvolte Nová podmínka z panelu Podmíněný text a zadejte název podmínky.
  3. Ve skupině Indikátor, určete viditelnost indikátoru, na který se podmínka použije.

    Ve výchozím nastavení indikátory (např. vlnité červené podtržení), jsou nastaveny, aby se zobrazovaly v dokumentu, ale aby se netiskly nebo nebyly obsaženy ve výstupu. V nabídce Indikátory v panelu Podmíněný text můžete nastavit podmínku určující, zda se indikátory skryjí, budou se tisknout nebo budou obsaženy ve výstupu, což je užitečné pro účely kontroly.

  4. Klikněte na tlačítko OK.

Aplikování podmínek na text

Na stejný text můžete použít více podmínek. Ve výchozím nastavení indikátory podmínky označují podmíněný text. Pokud jsou však indikátory skryté, můžete použít panel Podmíněný text k určení, které podmínky byly použity na daný text. Plné zaškrtnutí označuje podmínku, která se použije na aktuální text. Ztmavené zaškrtnutí označuje podmínku, která se použije na část výběru.

  1. Vyberte text, na který chcete aplikovat podmínku.
  2. V panelu Podmíněný text (Okna > Text a tabulky > Podmíněný text) proveďte libovolný z následujících úkonů:
    • Chcete-li použít podmínku, klikněte na podmínku nebo klikněte na pole u názvu podmínky.

    • Chcete-li použít podmínku a odstranit jiné podmínky použité na text, přidržte Alt (Windows) nebo Option (Mac OS) a klikněte na podmínku.

    • Chcete-li odstranit podmínku, zrušte kliknutím na pole u názvu podmínky její zaškrtnutí. Nebo kliknutím na [Nepodmíněné] odstraňte všechny podmínky z vybraného textu.

Poznámka:

Na určité podmínky nelze použít klávesové zkratky. Podmínky však lze použít pomocí funkce Rychle aplikovat.

Zobrazení nebo skrytí podmínek

Při skrytí podmínky se skryje všechen text, na který je podmínka použita. Skrytí podmínek obvykle způsobí změnu číslování stránek dokumentu nebo knihy. Můžete použít funkci Inteligentní přeformátování textu k automatickém odstranění stránek při skrytí a zobrazení podmínek.

Skrytý podmíněný text je v dokumentu obvykle ignorován. Skrytý text se například nevytiskne nebo neexportuje, rejstříkové značky ve skrytém podmíněném textu nebudou zahrnuty do vytvářeného rejstříku a skrytý podmíněný text nebude zahrnut do vyhledávání nebo kontroly pravopisu.

Pokud skryjete podmínku, skrytý text se uloží se symbolem skryté podmínky . Vyberete-li text obsahující symbol skryté podmínky a pokusíte se jej odstranit, aplikace InDesign vás vyzve k potvrzení odstranění skrytého podmíněného textu. Na skrytý podmíněný text nelze použít jiné podmínky, styly nebo formátování.

Pokud se na text vztahuje více podmínek a alespoň jedna z podmínek se zobrazuje, zatímco ostatní jsou skryté, text nebude skrytý.

  • Chcete-li skrýt nebo zobrazit individuální podmínky, klikněte na pole pro nastavení viditelnosti u názvu podmínky. Ikona oka určuje, že se podmínka zobrazuje.
  • Chcete-li zobrazit nebo skrýt všechny podmínky, zvolte Zobrazit vše nebo Skrýt vše z nabídky panelu Podmíněný text.

Použití sad podmínek

Sada podmínek zachovává nastavení viditelnosti pro všechny podmínky. Lze tak rychle použít různé verze dokumentu. Například předpokládejme, že máte komplexní dokument s podmínkami pro platformy Mac OS, Windows XP, Vista, UNIX, jazykovými podmínkami pro angličtinu, francouzštinu, němčinu a španělštinu a redakčními podmínkami, například redakční kontrola a interní poznámky. Chcete-li kontrolovat verzi Vista ve francouzštině, můžete vytvořit sadu, ve které se zobrazují pouze podmínky Vista, francouzština a redakční kontrola a jsou skryté všechny ostatní.

Přestože pro tuto operaci není nutné používat sady, pomohu vám rychle a spolehlivě přepínat mezi různými nastaveními viditelnosti podmínek.

  1. Podle potřeby použijte podmínky na text.
  2. Pokud se v panelu Podmíněný text nezobrazuje nabídka Sada, zvolte Zobrazit volby z nabídky panelu Podmíněný text.
  3. V panelu Podmíněný text nastavte podle potřeby viditelnost podmínek.
  4. Z nabídky Sada zvolte Vytvořit novou nabídku, zadejte název nabídky a klikněte na OK.

    Nová sada se stane aktivní sadou.

  5. Proveďte libovolný z následujících úkonů:
    • Chcete-li použít sadu podmínek na dokument, zvolte název sady podmínek z nabídky panelu Sada.

    • Chcete-li změnit sadu podmínek, vyberte sadu podmínek, kterou chcete nastavit jako aktivní a změňte nastavení viditelnosti některé podmínky. U sady podmínek se objeví znak plus (+). Chcete-li odstranit změny, znovu vyberte sadu podmínek. Chcete-li aktualizovat sadu podmínek novým nastavením viditelnosti, zvolte Předefinovat „[Sada podmínek]“.

    • Chcete-li odstranit sadu podmínek, vyberte sadu podmínek a zvolte Odstranit „[Sada podmínek]“. Odstraněním sady podmínek nedojde k odstranění podmínek dané sady ani k odebrání podmínek z míst, kde jsou použity.

Správa podmínek

  1. Proveďte libovolný z následujících úkonů:

    Odstranění podmínky

    Vyberte podmínku a klikněte na ikonu Odstranit podmínku ve spodní části panelu Podmíněný text. Vyberte podmínku, která nahradí odstraněnou podmínku, a klikněte na OK. Podmínka, kterou určíte, se použije na všechen text, na který byla použita odstraněná podmínka.

    Chcete-li odstranit více podmínek, podržte tlačítko Shift a vyberte souvislé podmínky, nebo podržte Ctrl (Windows) nebo Command (Mac OS) a vyberte nesouvislé podmínky a klikněte na ikonu Odstranit podmínku.

    Odstranění podmínky z textu

    Odstranění značky podmínky z textu se liší od odstranění značky z dokumentu. Při odstranění značky z textu zůstane značka v dokumentu a lze ji později znovu použít.

    Chcete-li odstranit podmínku z textu, vyberte text a kliknutím na pole u podmínky odstraňte její zaškrtnutí, nebo kliknutím na [Nepodmíněné] odstraňte všechny podmínky z vybraného textu.

    Načtení (import) podmínek

    Vyberte Načíst podmínky (načtení jednotlivých podmínek) nebo Načíst podmínky a sady z nabídky panelu Podmíněný text. Vyberte dokument aplikace InDesign, ze kterého chcete importovat podmínky, a klikněte na Otevřít. Načtené podmínky a sady podmínek nahradí všechny podmínky a sady podmínek s identickým názvem.

    Podmínky nelze načíst ze souboru aplikace InCopy do aplikace InDesign, lze však načíst podmínky ze souboru aplikace InDesign do aplikace InCopy a InDesign.

    Načtené sady ignorují nastavení viditelnosti podmínek, které se aktuálně nachází v panelu Podmíněný text.

    Synchronizace podmínek v knize

    Chcete-li zajistit použití stejných podmínek ve všech dokumentech v knize, vytvořte podmínky, které bude obsahovat dokument zdroje stylů, vyberte volbu Nastavení podmíněného textu v dialogovém okně Volby synchronizace a pak spusťte synchronizaci knihy.

    Zobrazení nebo skrytí indikátorů podmínek

    Zvolením volby Zobrazit nebo Skrýt z nabídky Indikátory v panelu Podmíněný text a zobrazte nebo skryjte indikátory podmínek. Pokud se pracujete s jednou verzí a chcete vidět, které oblasti jsou podmíněné, zobrazte indikátory podmínek. Pokud vás budou indikátory podmínek řešit při práci, skryjte je. Pokud chcete tisk a výstup identifikátorů podmínek, vyberte možnost Zobrazit a vytisknout.

    Změna názvu podmínky

    V panelu Podmíněný text klikněte na podmínku, chvíli počkejte a klikněte na vyberte název podmínky. Zadejte nový název podmínky.

    Úprava indikátorů podmínky

    V panelu Podmíněný text dvojitě klikněte na podmínku, nebo vyberte podmínku a zvolte Volby podmínek z nabídky panelu. Určete nastavení indikátoru a klikněte na OK.

Hledání a nahrazování podmíněného textu

Pomocí dialogového okna Hledat a nahradit můžete vyhledat text, na který byla použita jedna nebo více podmínek, a vybrat jiné podmínky.

  1. Zobrazte podmíněný text, který chcete zahrnout do vyhledávání.

    Skrytý text se při hledání vynechá.

  2. Zvolte Úpravy > Hledat a nahradit.
  3. Pokud se nezobrazí pole Hledat formát a Změnit formát ve spodní části dialogového okna, klikněte na Více voleb.
  4. Kliknutím do pole Hledat formát zobrazte dialogové okno Najít nastavení formátu. V části Podmínky můžete zvolením [libovolná podmínka] vyhledávat v textu, na který byla použita libovolná podmínka, zvolením [nepodmíněný], vyhledávat v textu, na který nebyla použita žádná podmínka, nebo vybrat konkrétní podmínku nebo podmínky určující text, který se má vyhledat. Klikněte na tlačítko OK.

    Tato funkce vyhledá text, který přesně vyhovuje vybraným podmínkám. Například, pokud vyberete současně podmínku 1 a podmínku 2, nebude nalezen text, na který se vztahuje jedna z podmínek, a ani text, na který se vztahují tyto dvě podmínky a další podmínka.

  5. Kliknutím do pole Změnit formát zobrazte dialogové okno Změnit nastavení formátu. Zadejte odlišnou volbu formátování, například podmínku nebo styl formátování, a pak klikněte na tlačítko OK.

    Pokud vyberete oddíl Podmínky v dialogovém okně Změnit nastavení formátu, volba [libovolná podmínka] neprovede žádné změny v nalezeném podmíněném textu. Tato volba je užitečná v případě, že chcete použít různé formátování, například styl odstavce. Vyberte volbu [Nepodmíněné], pokud chcete odstranit všechny podmínky v nalezeném textu. Pokud vyberete určitou podmínku, určete, zda má tato podmínka nahradit všechny podmínky v nalezeném textu, nebo zda se má přidat k textu.

  6. Klikněte na Hledat a pak podmínku nahraďte pomocí tlačítek Nahradit, Nahradit a hledat nebo Nahradit vše.
Logo Adobe

Přihlaste se ke svému účtu.