Export obsahu z aplikace InDesign

Export obsahu z aplikace InDesign do InCopy vytvoří vazbu mezi těmito dvěma aplikacemi. Textové a grafické rámečky aplikace InDesign a jejich obsah můžete exportovat do InCopy pomocí jedné ze dvou metod:

  • Vytvořte kontejnerový soubor (*.icma) – nazývaný úloha – a přidejte do úlohy příslušná seskupení položek dokumentu (například text a grafiky článku), aby na nich bylo možné pracovat společně. Obsah v rámci úloh se exportuje jako soubory *.icml.

  • Textové a grafické rámečky exportujte samostatně (včetně vyhrazených rámečků) pomocí příkazů nabídky Úpravy > InCopy > Exportovat. Exportovaný obsah se uloží jako soubory *.icml.

Po provedení exportu obsahu se v levém horním rohu exportovaných rámečků v aplikacích InDesign a InCopy a v panelech Úlohy zobrazí malé ikony. Vazba na exportovaný soubor se zobrazuje na panelu Vazby. Tyto ikony zobrazují stav spravovaných rámečků a odlišují spravované rámečky od rámečků, které nejsou součástí pracovního postupu. Veškerý exportovaný obsah se zobrazí v panelu Úlohy. Obsah exportovaný pomocí příkazů nabídky Exportovat se zobrazí v sekci Nepřiřazený obsah InCopy v seznamu panelu Úlohy. I když obě metody vytvoří řízené spojení mezi obsahem InCopy a dokumentem aplikace InDesign, primární metodou je použití souborů úloh.

Exportem zpřístupníte obsah uživatelům, aby si ho mohli vyhradit, a přitom zachováte vazbu na původní dokument aplikace InDesign. (Tato vazba se vytváří z aplikace InDesign; nemůžete ji vytvořit z InCopy).

Jakmile obsah vyexportujete, uživatelé InCopy si mohou zobrazit (ale ne změnit) rozvržení stránky, styly a podobně, jak vypadají v dokumentu aplikace InDesign.

Poznámka:

Také můžete vytvořit text nebo ukotvené grafiky pomocí InCopy a pak je umístit do aplikace InDesign.

Panel Úlohy – přehled

Primárním nástrojem pro práci s úlohami je panel Úlohy (Okna > Úlohy v aplikaci InCopy, Okna > Redakce > Úlohy v aplikaci InDesign). Panel Úlohy zobrazuje soubory exportované z aktivního dokumentu aplikace InDesign a ikona označuje jejich stav. Nabídka panelu Úlohy obsahuje také příkazy, které řídí import verzí a funkce správy souborů mezi aplikacemi InCopy a InDesign. Při otevření úlohy v InCopy se název úlohy a její obsah objeví v panelu Úlohy. Dvojitým kliknutím na textové a grafické rámečky v panelu Úlohy vyberete tyto rámečky v okně dokumentu.

Poznámka:

Veškerý obsah exportovaný do InCopy nebo přidaný do úlohy je zároveň uveden v panelu Vazby. Přestože můžete v tomto panelu provádět některé úkoly správy pracovního postupu, například vyhrazení nebo zpřístupnění obsahu, doporučuje se provádět tyto úkoly pomocí panelu Úlohy.

Panel Úlohy v aplikaci InDesign
Panel Úlohy v aplikaci InDesign

A. Názvy obsahu InCopy B. Název dokumentu aplikace InDesign C. Stav úlohy Neaktuální D. Stav Upravovaný a aktuální text E. Stav Používaný a neaktuální textový obsah F. Stav Upravovaný a aktuální textový obsah G. Nepřiřazený obsah H. Jméno uživatele I. Tlačítko Aktualizovat obsah J. Tlačítko Vyhradit si/Zpřístupnit výběr K. Tlačítko Nová úloha L. Tlačítko Odstranit vybrané úlohy/Odstranit 
Panel Úlohy v InCopy
Panel Úlohy v InCopy

A. Názvy obsahu InCopy B. Stav úlohy Neaktuální C. Název úlohy D. Stav Upravovaný a aktuální text E. Stav Používaný a neaktuální textový obsah F. Stav Upravovaný a aktuální textový obsah G. Jméno uživatele H. Tlačítko Aktualizovat vzhled I. Tlačítko Aktualizovat obsah J. Tlačítko Vyhradit si/Zpřístupnit výběr 

Soubory úloh

Soubory úloh v aplikaci InDesign jsou kontejnery pro uspořádání kolekcí položek stránky. Můžete například vybrat všechny položky v článku (titulek, podtitulek, číslo, grafiku a popisky) a pak je přiřadit jednomu uživateli InCopy. Přidání těchto položek do úlohy představuje pro uživatele InCopy praktický způsob přístupu pouze k obsahu, za který jsou zodpovědní. Soubory úloh (*.icma) se zobrazují v souborovém systému, v pruhu článků InCopy a ve stavových zprávách. Soubory úloh mohou vytvářet pouze uživatelé aplikace InDesign; otevřít je mohou pouze uživatelé InCopy.

Při vytvoření úlohy se standardně vytvoří složka ve stejném umístění jako dokument aplikace InDesign. Tato složka úlohy obsahuje soubory úlohy *.icma a podsložku obsahu, která obsahuje veškeré exportované soubory článků InCopy (ve formátu .icml), které jsou součástí obrazů nebo jiných zdrojů. Jakmile je úloha vytvořena, uložte složku projektu v místě, kde k ní mají přístup všichni uživatelé, nebo vytvořte a distribuujte balíček úlohy. Pokud se obsah exportuje před tím, než se přidá do úlohy, nepřesunou se soubory na disku do složky obsahu příslušného souboru úlohy.

Soubory úloh obsahují následující:

  • Vazby nebo ukazatele na související položky stránky, včetně vyhrazených rámečků. Tyto prvky umožňují uživateli InCopy otevřít v InCopy jeden soubor a mít možnost redakčně upravovat více položek na stránce.

  • Všechny transformace grafiky v úloze, jako je posunutí, změna měřítka, otočení nebo zkosení.

  • Geometrii stránky umožňující uživatelům InCopy zobrazit rozvržení rámečku, jehož obsah upravují, bez nutnosti otevírat celý soubor aplikace InDesign.

  • Barevné kódování přiřazených rámečků v dokumentu.

     

Stránka v InCopy se zobrazením geometrie stránky a barevného kódování
Stránka v InCopy se zobrazením geometrie stránky a barevného kódování

Vytváření úloh a přidávání obsahu (InDesign)

Vytvářet úlohy a přidávat do nich obsah mohou pouze uživatelé aplikace InDesign. Existuje několik způsobů, jak vytvořit úlohy. Vybraná metoda obvykle závisí na tom, zda při vytváření úlohy již máte obsah, který chcete přidat.

  • Vytvořte prázdné soubory úloh. Z dokumentu aplikace InDesign můžete vytvořit řadu prázdných úloh, které slouží jako předlohy pro obsah, který přidáte později.

  • Vytvořte úlohy a zároveň do nich vložte obsah.

  • Přidejte obsah do existujícího souboru úlohy. Můžete přidat připojený obsah – text a grafiky, které již byly exportovány jako obsah InCopy – nebo můžete jako připojený obsah InCopy přidat vybrané položky stránky. Pokud již jeden nebo více vybraných rámečků obsahuje soubory obsahu InCopy a žádný z nich není součástí úlohy, můžete je přidat do nového nebo existujícího souboru úlohy.

Standardně se vytvořená složka úlohy uloží do stejné složky jako dokument aplikace InDesign. Tuto složku pak můžete umístit na server nebo můžete vytvořit a odeslat balíček.

Poznámka:

Pokud nechcete, aby uživatelé InCopy umísťovali a přizpůsobovali grafiky, nepřidávejte do úlohy grafické rámečky.

Vytváření prázdných souborů úloh (InDesign)

  1. V aplikaci InDesign uložte dokument.
  2. V panelu Úlohy zvolte Nová úloha z nabídky panelu.
  3. V dialogovém okně Nová úloha nastavte volby souboru úlohy a klikněte na OK.

Současné vytváření úloh a přidávání obsahu (InDesign)

  1. V aplikaci InDesign vytvořte dokument obsahující jeden nebo více textových rámečků, grafických rámečků nebo položek vyhrazených míst, a pak dokument uložte.
  2. Vyberte textové a grafické rámečky, které chcete přidat.
  3. Proveďte jeden z následujících úkonů:
    • Z nabídky panelu Úlohy zvolte Přidat do úlohy a pak vyberte Nová.

    • Zvolte Úpravy > InCopy > Přidat [volba] k úloze > Nová.

  4. V dialogovém okně Nová úloha nastavte volby souboru úlohy a klikněte na OK.

Nově vytvořený soubor úlohy bude obsahovat všechny rámečky, které byly vybrané v okně dokumentu.

Přidání obsahu do existující úlohy (InDesign)

  1. Uložte dokument aplikace InDesign.
  2. Vyberte textové a grafické rámečky, které chcete přidat.
  3. Proveďte jeden z následujících úkonů:
    • Z nabídky panelu Úlohy zvolte Přidat do úlohy a pak vyberte úlohu.

    • Přetáhněte obsah ze sekce Nepřiřazený obsah InCopy v panelu Úlohy do stávající úlohy.

    • Pomocí nástroje pro výběr vyberte položky stránky a přetáhněte je do stávající úlohy v panelu Úlohy.

    • Zvolte Úpravy > InCopy > Přidat [volba] k úloze a pak vyberte úlohu.

  4. Chcete-li nastavit všechny soubory obsahu jako dostupné pro uživatele InCopy, z nabídky panelu Úlohy zvolte Aktualizovat všechny úlohy.

Poznámka:

Obsah můžete přidat pouze k úlohám ve stejném dokumentu. Můžete ale importovat stejný obsah do více dokumentů a přidat ho do úlohy v každém z těchto dokumentů.

Volby souboru úlohy (InDesign)

Při vytváření nebo úpravách souboru úlohy můžete nastavit následující volby:

Název úlohy

Jednoznačná identifikace úlohy v panelu Úlohy, například „Článek o oceánu“. Tento název musí odpovídat konvencím pro názvy souborů příslušného operačního systému.

Přiřazený

Jednoznačná identifikace uživatele přiřazeného k souborům. Jméno uživatele se zobrazí v závorkách za názvem úlohy v panelu Úlohy. Jméno se zde zadává pouze pro informaci; uživateli nepřiděluje žádná zvláštní práva ani oprávnění.

Barva

Zobrazuje seznam barev, jejichž pomocí můžete v okně dokumentu zvýraznit rámečky aktuální úlohy a názvy úloh v panelu Úlohy. Toto barevné kódovaní odlišuje rámečky patřící do jedné úlohy od rámečků patřících do jiné úlohy a od nepřiřazených rámečků. Chcete-li přepnout zobrazení tohoto barevného kódování, zvolte Zobrazení > Zobrazovat netištěné > Zobrazovat/skrýt přiřazené rámečky. V InCopy je barevné kódování viditelné pouze v zobrazení rozvržení.

Poznámka:

Pokud během přepínání zobrazení přiřazených rámečků dojde k neočekávaným výsledkům, je možné, že rámečky mají tagy pro XML a je zapnuta možnost Zobrazit > Struktura > Zobrazit tagované rámečky. Nemůžete zároveň zobrazovat přiřazené rámečky i tagované rámečky.  

Změnit

Klikněte na tlačítko Změnit, abyste určili umístění složky úloh. Standardně se složka úlohy vytvoří ve stejném místě jako soubor aplikace InDesign.

Vyhrazené rámečky

Umožňuje uživatelům InCopy vidět text a grafické rámečky v úloze a zároveň obdélníky (nebo jiné tvary) představující všechny ostatní rámečky na příslušných stránkách aplikace InDesign. Všechny rámečky a vyhrazená místa mají přesně stejnou velikost, tvar a umístění jako jejich originály v aplikaci InDesign. Vyhrazené rámečky jsou prázdné tvary, které v dokumentu aplikace InDesign nezobrazují žádný obsah. Volba Vyhrazené rámečky nabízí nejnižší úroveň věrnosti a proto zajišťuje nejrychlejší výkon. V aplikaci InCopy jsou zástupné prázdné rámečky viditelné jen v zobrazení rozvržení. Uživatelé InCopy si nemohou vyhradit a upravovat vyhrazené rámečky.

Přiřazené dvojstránky

Umožňuje uživatelům InCopy zobrazit všechny přiřazené rámečky a celý obsah ostatních rámečků, které nejsou součástí úlohy, na jedné dvojstránce. V InCopy nelze obsah v rámečcích mimo úlohu upravit a je viditelný pouze v zobrazení rozvržení.

Všechny dvojstránky

Exportuje do souboru úlohy veškerý obsah dokumentu aplikace InDesign. Tato volba nabízí nejvyšší úroveň věrnosti; poskytuje ale také nejpomalejší výkon, protože soubor úlohy zobrazuje návrh a rozvržení každé stránky, včetně stránek, které nejsou důležité pro sekci, kterou uživatel právě upravuje.

Připojené obrazové soubory při sbalení

Zahrne kopie připojených obrazů do balíčku úlohy. Výběr této volby umožní uživatelům InCopy přístup k obrazům, ale zvětší velikost souboru balíčku. Uživatelé InCopy mohou zahrnout obrazy při vrácení balíčku.

Export obsahu ve formě samostatných souborů InCopy (InDesign)

Pokud vaše pracovní skupina dává přednost práci se samostatnými soubory před prací s úlohami, můžete exportovat obsah InCopy bez použití souboru úlohy. Tato metoda, na rozdíl od vytvoření jednoho souboru úlohy s odkazy na více souborů obsahu a informace o rozvržení, vytvoří samostatný soubor (.icml) pro každý textový a grafický rámeček, který v dokumentu určíte. Chcete-li vidět kontext upravovaného obsahu, musíte také otevřít příslušný dokument aplikace InDesign (.indd).

Vyberte dokument InDesign, který vyhovuje potřebám vašeho pracovního postupu. Pokud např. chcete exportovat všechny komentáře editora do jediného souboru, vytvořte vrstvu pro vytváření komentářů editora. Pak lze exportovat veškerý obsah do vybrané vrstvy.

Poznámka:

Rychlým způsobem exportu obsahu jako samostatného souboru InCopy je přetažení vybraných rámečků pomocí nástroje pro výběr na položku Nepřiřazený obsah InCopy v panelu Úlohy.

  1. V aplikaci InDesign vytvořte dokument s jedním nebo více textovými rámečky, grafickými rámečky nebo položkami pro vyhrazená místa.
  2. Proveďte jeden z následujících úkonů:
    • Vyberte textový nebo grafický rámeček jednoho článku nebo kliknutím se stisknutou klávesou Shift vyberte více rámečků.

    • Kliknutím umístěte textový kurzor do článku nebo vyberte úsek textu v textovém rámečku.

  3. Zvolte Úpravy > InCopy > Exportovat a pak vyberte jednu z následujících voleb:

    Výběr

    Exportuje všechny vybrané textové a grafické rámečky.

    Vrstva

    Exportuje veškerý obsah vybrané vrstvy.

    Všechny články

    Exportuje všechny články, které ještě nebyly exportovány.

    Všechny grafiky

    Exportuje všechny grafiky, která ještě nebyly exportovány.

    Všechny grafiky a články

    Exportuje všechny články a grafiky, které ještě nebyly exportovány.

    Poznámka:

    Pokud exportujete celý obsah dokumentu a pak do tohoto dokumentu přidáte další textové nebo grafické rámečky, můžete ušetřit čas při exportu nových článků, když použijte znovu příkaz Exportovat > Všechny články (nebo Všechny grafiky nebo Všechny grafiky a články). InDesign exportuje pouze nový obsah.

  4. Zadejte název a umístění souborů a pak klikněte na Uložit.

    Zadaný název souboru se použije jako prefix pro identifikaci každého exportovaného souboru obsahu v souborovém systému. Při exportu více textových rámečků se prvních několik znaků textu automaticky připojí k názvu souboru, například „můj článek-Příští cyklistická akce.icml“. V případě více grafických rámečků se vytvoří názvy souborů ve tvaru „můjčlánek-grafika“, „můjčlánek-grafika-1“ a tak dále. Název souboru se zobrazuje v souborovém systému, v pruhu článků InCopy a ve stavových zprávách.

  5. Po výzvě uložte také soubor aplikace InDesign.

Obsah InCopy je nyní spravovaný a mohou si ho vyhradit a upravovat ostatní uživatelé v pracovním postupu.

Sdílený obsah se zobrazuje v panelu Vazby stejně jako importované grafiky. Pokud přemístíte sdílený soubor ručně, můžete k aktualizaci jeho vazby použít panel Vazby.

Poznámka:

Když obsah vyexportujete, uvidíte ikonu Dostupný na textovém rámečku (v aplikaci InDesign a v InCopy) a v panelu Úlohy (InCopy). V pruhu článků (InCopy) se zobrazí slovo [Upravovaný].

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online