Vytvoření souboru knihy

Soubor knihy je kolekce dokumentů, která může mít společné styly, vzorníky, vzorové stránky a další položky. Stránky v dokumentech knihy můžete postupně číslovat, můžete tisknout vybrané dokumenty z knihy nebo je exportovat do PDF. Jeden dokument může patřit do více souborů knihy.

Jeden z dokumentů přidaných do souboru knihy je zdroj stylů. Zdroj stylů je standardně první dokument v knize, ale kdykoliv můžete vybrat nový zdroj stylů. Když synchronizujete dokumenty v knize, určené styly a vzorníky ze zdroje stylů nahradí styly a vzorníky v ostatních dokumentech knihy.

Michael Murphy publikoval výukový videokurz o tvorbě knih na stránce Book Basics.

  1. Zvolte Soubor > Nový > Kniha.
  2. Zadejte název knihy, určete její umístění a pak klikněte na Uložit.

    Objeví se panel Kniha. Soubor knihy se uloží s příponou názvu souboru .indb.

  3. Přidejte dokumenty do souboru knihy.

Přidávání dokumentů do souboru knihy

Když vytvoříte soubor knihy, otevře se v panelu Kniha. Panel Kniha je pracovní plocha souboru knihy, kde přidáváte, odstraňujete nebo uspořádáváte dokumenty.

  1. Zvolte Přidat dokument v nabídce panelu Kniha nebo klikněte na tlačítko plus dole v panelu Kniha.
  2. Vyberte dokument nebo dokumenty Adobe InDesign, které chcete přidat, a klikněte na tlačítko Otevřít.

    Poznámka:

    Soubory můžete přetáhnout do panelu Kniha z okna Průzkumníku (Windows) nebo z okna Finderu (Mac OS). Dokument můžete přetáhnout i z jedné knihy do jiné. Chcete-li dokument zkopírovat, podržte při tom stisknutou klávesu Alt (Windows) nebo Option (Mac OS).

  3. Pokud jste zahrnuli dokumenty vytvořené v dřívějších verzích aplikace InDesign, budou po přidání do knihy převedeny do formátu Adobe InDesign CS5. V dialogovém okně Uložit jako zadejte nový název pro převedený dokument (nebo ponechte původní název) a pak klikněte na Uložit.

    Poznámka:

    Dokumenty aplikace Adobe PageMaker nebo QuarkXPress musíte převést před jejich přidáním do souboru knihy.

  4. Podle potřeby změňte v panelu pořadí dokumentů přetažením nahoru nebo dolů do příslušné polohy v seznamu.
  5. Chcete-li označit dokument jako zdroj stylů, klikněte v panelu na pole vedle názvu dokumentu.

Chcete-li otevřít dokument v souboru knihy, dvojitě klikněte na název dokumentu v panelu Kniha.

Správa souborů knih

Každý otevřený soubor knihy se v panelu Kniha zobrazí ve vlastní záložce. Pokud je současně otevřeno více knih, klikněte na záložku, abyste tuto knihu posunuli do popředí a získali přístup k její nabídce panelu.

Ikony v panelu Kniha udávají aktuální stav dokumentu, například otevřený , chybí (dokument byl přesunut, přejmenován nebo odstraněn), změněný (dokument byl upraven nebo se změnila čísla stránek či oddílů v době, kdy kniha byla zavřena), nebo používaný (pokud někdo jiný otevřel dokument v řízeném pracovním postupu). U zavřených dokumentů se nezobrazuje žádná ikona.

Poznámka:

Abyste zobrazili cestu k souboru jakéhokoliv dokumentu v knize, podržte ukazatel myši nad názvem dokumentu, dokud se nezobrazí tip. Nebo zvolte Informace o dokumentu z nabídky panelu Kniha.

Uložení souboru knihy

Soubory knihy jsou oddělené od souborů dokumentů. Když například zvolíte příkaz Uložit knihu, InDesign uloží změny do knihy, ne do dokumentů v knize.

  1. Proveďte jeden z následujících úkonů:
    • Chcete-li uložit knihu pod novým názvem, zvolte Uložit knihu jako z nabídky panelu Kniha, určete umístění a název souboru a klikněte na Uložit.

    • Chcete-li uložit existující knihu se stejným názvem, zvolte Uložit knihu z nabídky panelu Kniha nebo klikněte na tlačítko Uložit dole v panelu Kniha.

Poznámka:

Pokud sdílíte soubory knihy přes server, měli byste používat systém správy souborů, abyste náhodně nepřepsali změny jiných uživatelů.

Zavření souboru knihy

  • Chcete-li zavřít jednu knihu, zvolte Zavřít knihu z nabídky panelu Kniha.
  • Chcete-li zavřít všechny otevřené knihy seskupené v jednom panelu, klikněte na zavírací tlačítko v titulním pruhu panelu Kniha.

Odstranění dokumentů knihy

  1. Vyberte dokument v panelu Kniha.
  2. V nabídce panelu Kniha zvolte Odstranit dokument.

Odstranění dokumentu ze souboru knihy neodstraní soubor na disku, dokument se odstraní pouze ze souboru knihy.

Nahrazování dokumentů knihy

  1. Vyberte dokument v panelu Kniha.
  2. V nabídce panelu Kniha zvolte Nahradit dokument, najděte dokument, kterým ho chcete nahradit, a pak klikněte na Otevřít.

Otevření souboru knihy v Exploreru nebo ve Finderu

  1. V panelu knih zvolte dokument.

  2. V nabídce panelu knih vyberte Najít v Exploreru (Windows) nebo Najít ve Finderu (Mac OS).

Otevře se okno prohlížeče a zobrazí vybraný soubor.

Synchronizace dokumentů knihy

Když synchronizujete dokumenty v knize, vámi stanovené položky – styly, proměnné, vzorové stránky, přednastavení přesahů, formáty křížových odkazů, nastavení podmíněného textu, číslované seznamy a vzorníky – se zkopírují ze zdroje stylů do určených dokumentů knihy a nahradí položky se stejnými názvy.

Pokud se položky zdroje stylů v synchronizovaných dokumentech nenajdou, přidají se do nich. Položky, které zdroj stylů neobsahuje, zůstanou v synchronizovaných dokumentech beze změny.

Výběr položek pro synchronizaci

  1. Zvolte Volby synchronizace z nabídky panelu Kniha.
  2. Vyberte položky, které chcete zkopírovat ze zdroje stylů do ostatních dokumentů knihy.

    Nezapomeňte vybrat všechny styly zahrnuté v definici dalších stylů. Objektový styl může například obsahovat odstavcové a znakové styly a ty zase zahrnovat položky vzorníku.

  3. Výběrem možnosti Skupiny automaticky přiřazovaných stylů lze zamezit zdvojování jedinečných názvů stylů, které byly přesunuty do skupin stylů nebo ze skupin stylů.

    Předpokládejme, že zdroj stylu obsahuje znakový styl ve skupině stylů a synchronizované dokumenty obsahují tentýž znakový styl mimo skupinu stylů. Pokud bude zaškrtnuta tato možnost, znakový styl se přesune do skupiny stylů v synchronizovaných dokumentech.

    Pokud tato možnost nebude zaškrtnuta, vytvoří se ve skupině stylů druhý znakový styl s vlastnostmi odpovídajícími zdroji stylu. Znakový styl mimo skupinu stylů se nezmění.

    Poznámka:

    Pokud dokument obsahuje styly se shodným názvem (např. Znakový styl 1 ve skupině stylů a Znakový styl 1 mimo skupinu stylů), program InDesign se chová, jako by možnost nebyla zaškrtnuta. Nejlepších výsledků se dosáhne vytvářením stylů s jedinečnými názvy.

  4. Klikněte na OK.

Synchronizace dokumentů v souboru knihy

Knihu můžete synchronizovat, i když jsou její dokumenty zavřené. InDesign otevře zavřené dokumenty, provede změny a pak dokumenty uloží a zavře. Dokumenty, které byly při synchronizaci otevřené, se změní, ale neuloží.

  1. V panelu Kniha klikněte na prázdné pole vedle dokumentu, který chcete použít jako zdroj stylů; ikona zdroje stylu označuje, který dokument je zdroj stylů.
    Vybraný zdroj stylů
    Vybraný zdroj stylů

  2. Vyberte položky, které chcete zkopírovat ze zdroje stylů, v dialogovém okně Volby synchronizace.
  3. V panelu Kniha vyberte dokumenty, které chcete synchronizovat s dokumentem zdroje stylů. Pokud není vybraný žádný dokument, bude se synchronizovat celá kniha.

    Poznámka:

    Abyste zajistili, že nejsou vybrané žádné dokumenty, klikněte do prázdné šedé plochy pod dokumenty knihy – možná budete muset posunout obsah nebo změnit velikost panelu Kniha. Abyste odznačili vybraný dokument, můžete také podržet Ctrl (Windows) nebo Command (Mac OS) a kliknout na vybraný dokument.

  4. Zvolte Synchronizovat vybrané dokumenty nebo Synchronizovat knihu z nabídky panelu Kniha, nebo klikněte na tlačítko Synchronizovat dole v panelu Kniha.

Poznámka:

Když zvolíte Úpravy > Zpět, vrátí se zpět změny pouze v dokumentech, které byly v době synchronizace otevřené.

Synchronizace vzorových stránek

Vzorové stránky se synchronizují stejným způsobem jako ostatní položky — vzorové stránky se stejným názvem (například Vzor A) jako vzorové stránky ve zdroji stylů se nahradí. Synchronizování vzorů je užitečné pro dokumenty, které používají stejné elementy návrhu, například průběžná záhlaví a zápatí. Pokud ale chcete zachovat položky stránky na vzorové stránce v jiných dokumentech než je zdroj stylů, buď nesynchronizujte vzorové stránky nebo vytvořte vzorové stránky s jinými názvy.

Jakékoli položky vzorové stránky, které jsou lokálně přepsány na stránkách dokumentu poté, co poprvé synchronizujete vzory, se odpojí od vzoru. Proto pokud chcete synchronizovat vzorové stránky ve vaší knize, je vhodné synchronizovat všechny dokumenty ve vaší knize na začátku procesu návrhu. Tímto způsobem si lokálně změněné položky vzorových stránek zachovají své připojení ke vzorové stránce a budou se nadále aktualizovat podle změněných položek vzorových stránek ve zdroji stylů.

Je také vhodné synchronizovat vzorové stránky s použitím pouze jednoho zdroje stylů. Pokud synchronizujete z jiného zdroje stylů, lokálně změněné položky vzorových stránek se mohou odpojit od vzorové stránky. Pokud potřebujete synchronizovat s použitím jiného zdroje stylů, před provedením synchronizace zrušte výběr volby Vzorové stránky v dialogovém okně Volby synchronizace.

Převedení souborů knih z předcházejících verzí aplikace InDesign

Soubor knihy vytvořený v dřívější verzi aplikace InDesign lze převést otevřením a uložením souboru v aplikaci InDesign CS5. Při synchronizaci aktualizujte číslování, tisk, sbalení nebo export konvertované knihy, obsažené dokumenty budou rovněž převedeny do formátu InDesign CS5. Můžete se rozhodnout, zda chcete původní soubory dokumentů přepsat nebo zachovat.

Převedení souboru knihy pro použití s aplikací InDesign CS5

  1. V aplikaci InDesign CS5 zvolte Soubor > Otevřít.
  2. Vyberte soubor knihy vytvořený v předcházející verzi aplikace InDesign a klikněte na OK.

    Pokud soubor knihy obsahuje dokumenty uložené ve formátu předcházející verze programu InDesign, objeví se výstraha.

  3. Zvolte Uložit knihu jako z nabídky panelu Kniha. Zadejte nový název pro převedený soubor knihy a klikněte na Uložit.

Převod dokumentů ze souboru knihy

  1. Soubor knihy otevřete v aplikaci InDesign CS5.
  2. V nabídce panelu Kniha:
    • Pokud chcete, aby se původní dokumenty během převodu přepsaly, vyberte Automatický převod dokumentů.

    • Pokud chcete zachovat původní dokumenty a uložit převedené dokumenty s novými názvy, zrušte výběr volby Automatický převod dokumentu. (Seznam knihy se bude aktualizovat tak, aby obsahoval převedené soubory a ne originály.)

  3. Abyste převedli dokumenty, proveďte kterýkoliv z následujících úkonů:
    • Zvolte Synchronizovat knihu z nabídky panelu Kniha. (Viz téma Synchronizace dokumentů knihy.)

    • Z nabídky panelu Kniha zvolte Aktualizovat číslování > Aktualizovat všechna čísla.

  4. Pokud není vybraná volba Automatický převod dokumentů, InDesign vás vyzve k uložení každého převedeného dokumentu s novým názvem.

Poznámka:

Dokumenty se také převedou, když knihu vytisknete nebo exportujete do Adobe PDF.

Číslování stránek, kapitol a odstavců v knize

Můžete určit, jak se v knize číslují stránky, kapitoly a odstavce. V souboru knihy jsou styly číslování a počáteční čísla stránek a kapitol určeny nastavením každého dokumentu v dialogovém okně Volby číslování a oddílu. nebo dialogovém okně Možnosti číslování dokumentu. Tato dialogová okna lze otevřít volbou možností Formát > Volby číslování a oddílu dokumentu nebo zvolíte Volby číslování dokumentu z nabídky panelu Kniha.

Informace o přidávání základního číslování stránek do dokumentu najdete v tématu Přidání základního číslování stran.

Číslování odstavců (například seznamů obrázků) je určeno definicí stylu číslovaného seznamu, která je obsažena v odstavcovém stylu.

Vedle názvu každého dokumentu v panelu Kniha se zobrazí rozsah stránek. InDesign standardně aktualizuje čísla stránek a oddílů v panelu Kniha, když vložíte nebo odstraníte stránky v dokumentech knihy, nebo když změníte soubor knihy, například změníte pořadí, vložíte nebo odstraníte dokumenty. Pokud nastavení automatické aktualizace čísel stránek a oddílů vypnete, číslování v knize aktualizovat ručně.

Jestliže po aktualizaci knihy zjistíte nesprávné číslování, jde pravděpodobně o to, že v Obecných předvolbách se namísto čísel oddílů zobrazují absolutní číselné hodnoty. Viz téma Zobrazení absolutního číslování nebo číslování oddílu v panelu Stránky.

Pokud dokument chybí nebo ho nelze otevřít, rozsah stránek se zobrazí jako „?“ od místa, kde má být chybějící dokument, do konce knihy, aby bylo jasné, že není znám správný rozsah stránek. Před aktualizací číslování chybějící dokument odstraňte nebo nahraďte. Pokud se objeví ikona Používaný , má dokument ve spravovaném prostředí otevřený někdo na jiném počítači; tato osoba musí před aktualizací číslování dokument zavřít.

Změny voleb číslování stránek a kapitol pro jednotlivé dokumenty

  1. Vyberte dokument v panelu Kniha.
  2. Zvolte Volby číslování dokumentu z nabídky panelu Kniha, nebo dvojitě klikněte na čísla stránek dokumentu v panelu Kniha.
  3. Určete volby číslování stránek, oddílů a kapitol. (Viz téma Volby číslování dokumentu.)
  4. klikněte na OK.

Poznámka:

Pokud v dokumentu knihy určíte číslo počáteční stránky místo výběru volby Automatické číslování stránek, začne dokument knihy na určené stránce a všechny následující dokumenty knihy se odpovídajícím způsobem přečíslují.

Nastavení začátku číslování na liché nebo sudé stránce

Číslování dokumentu v dokumentech knihy může začínat na lichých nebo sudých stránkách.

  1. Z nabídky panelu Kniha zvolte Volby číslování stránek knihy.
  2. Zvolte Pokračovat následující lichou stránkou nebo Pokračovat následující sudou stránkou.
  3. Vyberte Vložit prázdnou stránku, chcete-li přidat prázdnou stránku na konec každého dokumentu, pro který musí následující dokument začínat sudou nebo lichou stránkou, a pak klikněte na OK.

Vypnutí automatického číslování stránek v knize

  1. Z nabídky panelu Kniha zvolte Volby číslování stránek knihy.
  2. Zrušte výběr volby Automaticky aktualizovat čísla stránek a oddílů a pak klikněte na OK.
  3. Chcete-li aktualizovat číslování stránek ručně, zvolte Aktualizovat číslování > Aktualizovat všechna čísla z nabídky panelu Kniha.

    Můžete také aktualizovat pouze čísla stránek a oddílů nebo pouze čísla kapitol a odstavců.

Použití postupného číslování odstavců v knihách

Chcete-li použít postupné číslování odstavců pro seznamy obrázků, tabulek nebo jiných položek, nejdříve definujte číslovaný seznam, který se použije v odstavcovém stylu. Číslovaný seznam, který nadefinujete, určuje, zda číslování odstavců zachová postupné číslování v dokumentech knihy.

  1. Otevřete dokument, který používáte jako zdroj stylů knihy.
  2. Zvolte Text > Seznamy s odrážkami a číslované seznamy > Definovat seznamy.
  3. klikněte na Nový, chcete-li definovat seznam, nebo vyberte stávající seznam a zvolte Upravit.
  4. Vyberte Pokračovat v číslování přes články i Pokračovat v číslování z předcházejícího dokumentu v knize.
  5. klikněte na OK.
  6. Definujte odstavcový styl, který používá číslovaný seznam, a aplikujte ho na text ve všech dokumentech, které obsahují seznam. (Viz téma Vytvoření odstavcového stylu pro průběžné seznamy.)

Poznámka:

Chcete-li zajistit, aby se stejná nastavení číslovaného seznamu použila ve všech dokumentech knihy, vyberte volby Odstavcové styly a Číslované seznamy v dialogovém okně Volby synchronizace a pak spusťte synchronizaci knihy.

Jednou z výhod používání souboru knihy je to, že můžete použít jeden příkaz pro výstup – pro tisk, kontrolu před výstupem, sbalení nebo export do EPUB či PDF – vybraných dokumentů knihy nebo celé knihy.

  1. V panelu Kniha proveďte jeden z následujících úkonů:
    • Chcete-li vytvořit výstup z určitých dokumentů, vyberte je.

    • Chcete-li vytvořit výstup z celé knihy, zkontrolujte, že nejsou vybrané žádné dokumenty.

  2. Zvolte příkaz pro výstup (například Tisknout knihu nebo Tisknout vybrané dokumenty) z nabídky panelu Kniha.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online