Tabulka obsahuje buňky uspořádané do řádků a sloupců. Buňka se chová podobně jako textový rámeček, do kterého lze vkládat text, ukotvené rámečky nebo jiné tabulky. Vytvářejte tabulky v aplikaci Adobe InDesign CS5 nebo je exportujte z jiných aplikací.

Poznámka:

Chcete-li vytvářet, upravovat a formátovat tabulky v Adobe InCopy, ujistěte se, zda jste v zobrazení Rozvržení.

Vytváření tabulek

Tabulka obsahuje buňky uspořádané do řádků a sloupců. Buňka se chová podobně jako textový rámeček, do kterého lze vkládat text, grafiky nebo jiné tabulky. Tabulky můžete vytvářet úplně od začátku nebo převedením existujícího textu. Můžete také vložit tabulku dovnitř jiné tabulky.

Když vytváříte tabulku, vyplní nová tabulka šířku textového rámečku, ve kterém ji vytváříte. Když je textový kurzor na začátku řádku, tabulka se vloží do stejného řádku; když je kurzor uprostřed řádku, vloží se tabulka do následujícího řádku.

Tabulky se pohybují spolu s okolním textem stejně jako včleněné grafiky. Tabulka se bude například pohybovat zřetězenými rámečky, když změníte velikost textu nad ní nebo když přidáte nebo odstraníte text. Tabulka se ale nemůže objevit v rámečku textu na cestě.

Michael Murphy publikoval článek o vytváření a formátování tabulek na stránce Mind Your Table Manners.

Jeff Witchell ze společnosti InfiniteSkills.com připravil videopřehled základů nastavení tabulek.

Vytvoření nové tabulky

Při vytváření tabulky v aplikaci InDesign máte možnost vytvořit tabulku ve stávajícím textovém rámečku (Použití volby Vložit tabulku). Jinak lze vytvořit tabulku a aplikaci InDesign umožnit vytvoření ohraničujícího textového rámečku (Použití volby Vytvořit tabulku).

Použití volby Vložit tabulku

  1. Chcete-li nakreslit tabulku ve stávajícím textovém rámečku, použijte Textový nástroj a bod vložení umístěte tam, kde se má tabulka zobrazit.

  2. Zvolte Tabulka > Vložit tabulku.

    Poznámka:

    Není-li kurzor aktuálně v textovém rámečku, je k dispozici možnost Vytvořit tabulku.

  3. Zadejte požadovaný počet řádků a sloupců.
  4. Pokud bude obsah tabulky pokračovat přes více než jeden sloupec nebo rámeček, určete počet řádků záhlaví nebo zápatí, ve kterých se budou informace opakovat.
  5. (Volitelně) Určete styl tabulky.
  6. Klikněte na OK.

    Nová tabulka vyplní šířku textového rámečku.

Použití volby Vytvořit tabulku

Použijete-li k vytvoření tabulky volbu Vytvořit tabulku, není nutné v dokumentu nejprve vytvořit textový rámeček. Jakmile v dokumentu nakreslíte tabulku, aplikace InDesign vytvoří textový rámeček velikosti nakreslené tabulky.

  1. Zvolte Tabulka > Vytvořit tabulku.

    Poznámka:

    Není-li kurzor aktuálně v textovém rámečku, k dispozici je volba Vložit tabulku.

  2. Zadejte požadovaný počet řádků a sloupců.
  3. Pokud bude obsah tabulky pokračovat přes více než jeden sloupec nebo rámeček, určete počet řádků záhlaví nebo zápatí, ve kterých se budou informace opakovat.
  4. (Volitelně) Určete styl tabulky.
  5. Klikněte na OK.
  6. Pomocí kurzoru Tabulka nakreslete požadovanou tabulku.

    Aplikace InDesign vytvoří textový rámeček velikosti nakreslené oblasti a tabulku umístí do textového rámečku.

Zvolený styl tabulky určuje výšku řádku tabulky. Styl tabulky například může použít styly buněk pro formátování různých částí tabulky. Pokud libovolný z těchto stylů buněk obsahuje odstavcové styly, výšku řádku této oblasti určuje hodnota prokladu z odstavcových stylů. Pokud nepoužijete žádný odstavcový styl, výšku řádku tabulky určuje výška výchozího řádkového pruhu. (Výška řádkového pruhu vychází z hodnoty prokladu. Výška řádkového pruhu je v tomto kontextu přibližně výška zvýraznění ve vybraném textu).

Vytvoření tabulky z existujícího textu

Než převedete text na tabulku, přesvědčte se, zda je text správně nastaven.

  1. Když připravujete text pro převod, zadejte jako oddělovače sloupců tabulátory, čárky, konce odstavců nebo jiné znaky. Jako oddělovače řádků zadejte tabulátory, čárky, konce odstavců nebo jiné znaky. (V mnoha případech je možné text převést na tabulku bez nutnosti úprav.)
  2. Textovým nástrojem vyberte text, který chcete převést na tabulku.
  3. Zvolte Tabulka > Převést text na tabulku.
  4. V polích Oddělovač sloupců a Oddělovač řádků označte, kde mají začínat nové řádky a sloupce. Zvolte Tabulátor, Čárka nebo Odstavec, nebo zadejte znak, například středník (;), do pole Oddělovač sloupců nebo Oddělovač řádků. (Zadaný znak se objeví v nabídce při příštím vytváření tabulky z textu.)
  5. Pokud určíte stejný oddělovač pro sloupce i řádky, zadejte počet sloupců, které má tabulka obsahovat.
  6. (Volitelně) Určete styl tabulky, kterým se bude tabulka formátovat.
  7. Klikněte na OK.

Pokud má některý řádek méně položek než je v tabulce sloupců, doplní se řádek prázdnými buňkami.

Vložení tabulky do tabulky

  1. Proveďte jeden z následujících úkonů:
    • Vyberte buňky nebo tabulku, kterou chcete vložit, a zvolte Úpravy > Vyjmout nebo Kopírovat. Umístěte textový kurzor do buňky, kde chcete tabulku zobrazit, a zvolte Úpravy > Vložit.

    • Klikněte do buňky, zvolte Tabulka > Vložit tabulku, zadejte počet řádků a sloupců a pak klikněte na OK.

  2. Upravte podle potřeby odsazení v rámci buňky. (Viz článek Formátování textu v tabulce.)

Pokud vytvoříte tabulku uvnitř buňky, nemůžete pomocí myši vybrat části tabulky, které přesahují za hranice buňky. V takovém případě musíte rozšířit řádek nebo sloupec; nebo umístit textový kurzor do první části tabulky a pomocí klávesových zkratek přesunout textový kurzor a vybrat text.

Import tabulek z jiných aplikací

Když k importu dokumentu aplikace Microsoft Word obsahujícího tabulky nebo tabulky aplikace Microsoft Excel použijete příkaz Umístit, data se importují jako upravitelná tabulka. Formátování můžete nastavit pomocí dialogového okna Volby importu.

Také můžete vkládat data z tabulek aplikace Excel nebo Word do dokumentu aplikace InDesign nebo InCopy. Nastavení předvoleb Zpracování schránky určuje, jak se bude formátovat text vložený z jiné aplikace. Pokud je vybraná volba Pouze text, informace se zobrazí jako neformátovaný text s tabulátory, který pak můžete převést na tabulku. Pokud je vybraná volba Všechny informace, vložený text se zobrazí ve formátované tabulce.

Pokud vkládáte text z jiné aplikace do existující tabulky, vložte dostatečný počet řádků a sloupců, aby se do nich vešel vkládaný text, v předvolbách Zpracování schránky vyberte volbu Pouze text a zkontrolujte, že je vybraná alespoň jedna buňka (pokud nechcete umístit vkládanou tabulku do buňky).

Pokud vyžadujete větší kontrolu nad formátováním importované tabulky, nebo pokud chcete zachovat formátování tabulky, použijte k importu tabulky příkaz Umístit. Pokud chcete zachovat odkaz na tabulku, zvolte v nastavení předvoleb Zpracování souborů volbu Vytvářet vazby při umístění textového nebo tabulkového souboru.

Poznámka:

Rovněž lze zkopírovat a vložit text oddělený tabulátorem do výběru buněk tabulky. Tento postup je skvělý pro nahrazení obsahu se zachováním formátování. Předpokládejme, že chcete aktualizovat obsah formátovací tabulky v měsíčně publikovaném časopisu. Jednou možností je propojení na list tabulky Excel. Pokud však obsah pochází z jiného zdroje, lze zkopírovat text oddělený tabulátorem obsahující nový obsah, vybrat oblast buněk ve formátované tabulce InDesign a vložit text.

Přidávání textu do tabulky

Do buněk tabulky můžete vložit text, ukotvené objekty, tagy XML a další tabulky. Pokud jste nenastavili pevnou výšku řádku, přizpůsobí se výška řádku tabulky podle počtu řádků textu. Do tabulek nemůžete přidat poznámky pod čarou.

  1. S textovým nástrojem proveďte libovolný z následujících úkonů:
    • Umístěte textový kurzor do buňky a napište text. Stisknutím klávesy Enter nebo Return vytvoříte ve stejné buňce nový odstavec. Pro přechod mezi buňkami dopředu stiskněte tabulátor (stisknutím tabulátoru v poslední buňce vložíte nový řádek). Pro přechod mezi buňkami dozadu stiskněte klávesy Shift+Tab.

    • Zkopírujte text, umístěte textový kurzor do buňky a pak zvolte Úpravy > Vložit.

    • Umístěte textový kurzor do buňky, do které chcete přidat text, zvolte Soubor > Umístit a pak dvojitě klikněte na textový soubor.

Přidávání grafik do tabulky

  1. Umístěte textový kurzor do buňky tabulky, do které chcete obraz přidat.

  2. Proveďte libovolný z následujících úkonů:
    • Zvolte příkaz Soubor > Umístit a vyberte jeden nebo více souborů grafiky.
    • Vyberte a přetáhněte jeden nebo více souborů grafiky z kategorie Grafika na panelu CC knihovny.

    Obraz nebo obrazy jsou dostupné na umísťovacím kurzoru.

  3. Obraz nebo obrazy můžete umístit kliknutím do jednotlivých buněk tabulky.

  4. Proveďte libovolný z následujících úkonů:

Poznámka:

Výstřižky aplikace InDesign nemůžete přetáhnout z kategorie Grafika na panelu CC knihovny.

Když přidáte grafiku, která je větší než buňka, výška buňky se přizpůsobí velikosti grafiky, šířka buňky se ale nezmění – grafika může přesahovat pravý okraj buňky. Pokud má řádek, do kterého je umístěna grafika, pevnou výšku, pak grafika, která je vyšší než řádek, způsobí přesah obsahu buňky.

Poznámka:

Chcete-li zabránit přesahování buňky, umístěte obraz mimo tabulku, změňte velikost obrazu a pak ho vložte do buňky tabulky.

Obrazy můžete do buněk v tabulce umístit také následujícími způsoby:

  • Vyberte příkaz Objekt > Ukotvený objekt > Vložit a poté určete nastavení. Později můžete do ukotveného objektu přidat grafiku.
  • Zkopírujte grafiku nebo rámeček, umístěte textový kurzor a pak zvolte Úpravy > Vložit.

Přidání záhlaví a zápatí tabulky

Pokud vytvoříte dlouhou tabulku, může se tabulka zalomit přes více než jeden sloupec, rámeček nebo stránku. K opakování informací na začátku nebo na konci každé rozdělené části tabulky můžete použít záhlaví nebo zápatí.

Řádky záhlaví a zápatí můžete přidat při vytváření tabulky. Řádky záhlaví a zápatí můžete také přidat a změnit jejich vzhled v tabulce pomocí dialogového okna Volby tabulky. Na řádky záhlaví nebo zápatí můžete změnit řádky hlavního textu.

Přidání záhlaví a zápatí tabulky
Řádky záhlaví opakující se jednou v každém rámečku

Poznámka:

Chcete-li tabulky postupně číslovat, jako například tabulka 1A, tabulka 1B, vložte proměnnou do záhlaví nebo zápatí tabulky. (Viz článek Vytváření průběžných titulků pro čísla a tabulky.)

  1. Vyberte řádky na horním okraji tabulky, chcete-li vytvořit řádky záhlaví, nebo na dolním okraji tabulky, chcete-li vytvořit řádky zápatí.
  2. Zvolte Tabulka > Převést řádky > Na záhlaví nebo Na zápatí.
  1. Umístěte textový kurzor do tabulky a pak zvolte Tabulka > Volby tabulky > Záhlaví a zápatí.
  2. Určete počet řádků záhlaví nebo zápatí. Na začátek nebo konec tabulky můžete přidat prázdné řádky.
  3. Určete, zda se informace v záhlaví nebo zápatí objeví v každém sloupci textu (pokud mají textové rámečky více než jeden sloupec), jednou v každém rámečku nebo jednou na každé stránce.
  4. Vyberte Přeskočit první, pokud nechcete, aby se informace záhlaví objevily v prvním řádku tabulky. Vyberte Přeskočit poslední, pokud nechcete, aby se informace zápatí objevily v posledním řádku tabulky.

    Volba Vynechat první se hodí zejména v případě, že chcete upozornit na pokračování záhlaví nebo zápatí. Například u tabulky, která pokračuje na dalších stránkách můžete zobrazit text záhlaví „Tabulka 2 (pokračování)“. Výraz „pokračování“ by se neměl objevit na začátku tabulky, proto zvolte Vynechat první a do prvního řádku tabulky jednoduše zadejte Tabulka 2.

  5. Klikněte na OK.

K vytvoření podobných řádků a sloupců nebo jejich duplikování lze použít řadu funkcí.

U řádků a sloupců tabulek lze použít především následující funkce:

  • Přetažení řádků a sloupců tabulky z jednoho místa na druhé v téže tabulce.
  • Duplikování řádků a sloupců.
  • Vkládání řádků a sloupců před nebo za jiný řádek/sloupec
  • Kopírování obsahu řádku do sloupce nebo obsahu sloupce do řádku.

Přetažení a duplikování řádků/sloupců

Řádky a sloupce tabulky lze přesouvat z jednoho místa na druhé v téže tabulce. Chcete-li řádky/sloupce přetáhnout nebo duplikovat, postupujte následovně.

  1. Vyberte řádek nebo sloupec, který chcete přesunout do jiného řádku či sloupce. Zkontrolujte, zda byl vybrán celý řádek či sloupec. Částečně vybrané řádky či sloupce přetáhnout nelze.

  2. Jakmile přejedete myší nad vybrané řádky, zobrazí se jedinečný kurzor naznačující, že daný výběr lze přesunout.

  3. Řádek položek lze přetáhnout. Sloupce lze prohodit s řádky. Přetažený řádek se zobrazí pouze jako řádek a přetažený sloupec pouze jako sloupec.

    Přetažení řádků a sloupců
    Přetažení řádků a sloupců

    Při přesunu řádku z jednoho místa na druhé zůstává počet řádků stejný jako předtím: pouze tři.

    Poznámka:

    Přetažení je možné pouze v rámci téže tabulky.

  4. Chcete-li řádek či sloupec duplikovat, po výběru řádku či sloupce stiskněte a přidržte klávesu Alt (Win) nebo Opt (Mac). Přetáhnout lze souvisle vybrané řádky nebo sloupce.

  5. Vybraný řádek nebo sloupec přetáhněte na požadované místo. Celkový počet řádků či sloupců se při duplikování vybrané entity zvyšuje.

    Také je možné kopírovat obsah řádků záhlaví či zápatí do řádků hlavního textu (stiskem klávesy Alt/Opt). Obdobně je rovněž možné řádky hlavního textu duplikovat a převádět do řádků záhlaví či zápatí.

Řádky záhlaví v oddílu záhlaví lze přetáhnout (pouze máte-li více řádků záhlaví) jen tehdy, nepoužijete-li klávesu Alt/Opt k duplikování řádků. Řádky hlavního textu do oddílu záhlaví přetáhnout nelze, nepoužijete-li k duplikování řádků klávesu Alt/Opt.

Kopírování řádků/sloupců a jejich vložení před/za

Řádky lze kopírovat a vložit před nebo za vybraný řádek. Pomocí funkce Vložit před/za lze kopírovat řádky/sloupce z tabulky a vložit je i do jiné tabulky.

  1. Výběr řádku/sloupce.

  2. Vyberte řádek nebo sloupec.

  3. Zvolte možnost Tabulka > Vložit před/Vložit za.

  1. Proveďte libovolný z následujících úkonů:
    • Umístěte textový kurzor do řádku záhlaví nebo zápatí a pak zvolte Tabulka > Převést řádky > Na hlavní text.

    • Zvolte Tabulka > Volby tabulky > Záhlaví a zápatí a pak určete jiný počet řádků záhlaví nebo zápatí.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online