Vytvoření dynamického dokumentu je vhodným způsobem, jak vytvořit interaktivní prezentaci. Můžete vytvářet interaktivní dokumenty s tlačítky, filmy a zvukovými klipy, hypervazbami, záložkami a přechody stránky. Můžete také zakládat dokumenty v InDesign, které lze převádět na formuláře v aplikaci Acrobat.

Vytváření interaktivních dokumentů pro formát PDF

Můžete exportovat dokumenty Adobe PDF, které zahrnují následující interaktivní funkce.

Záložky

Záložky, které vytvoříte v dokumentu InDesign, se objeví v panelu Záložky na levé straně okna aplikace Adobe Acrobat nebo Adobe Reader. Každá záložka směruje na stránku, text nebo grafiku v exportovaném souboru PDF. Viz Záložky

Filmové a zvukové klipy

Do dokumentu můžete přidat filmy a zvukové klipy nebo můžete vytvořit vazbu na streamované video soubory na internetu. Tyto filmové a zvukové klipy lze v exportovaném souboru PDF přehrávat. Viz Filmy a zvuky.

Hypervazby

Kliknutím na hypertextový odkaz v exportovaném dokumentu PDF přejdete na jiné umístění ve stejném dokumentu, do jiného dokumentu nebo na web. Viz Hypervazby.

Křížové odkazy

Křížový odkaz odkazuje čtenáře z jedné části dokumentu na jinou v exportovaném souboru PDF. Křížové odkazy jsou obzvlášť užitečné v uživatelských příručkách a referenčních příručkách. Pokud je dokument s křížovými odkazy exportován do souboru PDF, fungují křížové odkazy jako interaktivní hypervazby. Viz Křížové odkazy.

Přechody stránky

Přechody stránek použijí dekorativní efekt, jako je rozpuštění nebo setření při převrácení stránky v exportovaném souboru PDF během zapnutého režimu Na celou obrazovku. Viz Přechody stránek.

  1. Zvolte Soubor > Exportovat.

  2. Zadejte název a umístění souboru.

  3. Chcete-li, aby měl exportovaný dokument PDF stejný název jako dokument z dalšího exportu, vyberte možnost Použít název dokumentu InDesign jako název výstupního souboru.

  4. V nabídce Uložit jako typ (Windows) nebo Formát (Mac OS) zvolte Adobe PDF (Interaktivní) a klikněte na Uložit.

  5. V dialogovém okně Exportovat do interaktivního formátu PDF určete volby a potom klikněte na OK.

Export do interaktivního formátu PDF – volby

Následující volby se zobrazí v dialogovém okně Exportovat do interaktivního formátu PDF.

Karta Obecné

Stránky

Uveďte, zda budou zahrnuty všechny stránky v dokumentu nebo rozsah stran. Pokud zvolíte Rozsah, uveďte rozsah stran, například 1-7, 9 pro tisk stran 1 až 7 a strany 9. Viz Určení tištěných stránek.

Exportovat jako

Určuje, zda chcete exportovat dokument jako stránky nebo dvojstránky.

Vytvořit samostatné soubory PDF

Tuto možnost vyberte, pokud chcete vytvořit samostatné soubory PDF pro každou stránku nebo dvojstránku.

Zobrazení

Úvodní nastavení zobrazení dokumentu PDF při otevření.

Rozvržení

Úvodní rozvržení zobrazení dokumentu PDF při otevření.

Prezentace

Chcete-li dokument PDF v aplikaci Adobe Acrobat nebo Adobe Reader zobrazit bez nabídek nebo panelů, vyberte volbu Otevřít v celoobrazovkovém režimu. Chcete-li automaticky přecházet ze stránky na stránku, vyberte Otáčet stránky každé a zadejte počet sekund mezi otočením strany.

Zobrazit po exportu

Otevře nově vytvořený soubor PDF ve výchozí aplikaci pro prohlížení PDF.

Přechody stránky

Určete jeden přechod stránky, který se během exportu aplikuje na všechny stránky. Jestliže pro určení přechodů použijete panel Přechody stránky, vyberte volbu z dokumentu, aby se toto nastavení použilo.

Formuláře a média

Volbou Zahrnout vše povolíte interaktivitu filmů, zvuků a tlačítek v exportovaném souboru PDF. Volbou Pouze vzhled přidáte normální stav tlačítek a titulní obrazy videa jako statické prvky.

Vložit miniatury stránek

Vloží náhled miniatury pro každou stránku souboru PDF, což zvětší velikost souboru. Vypněte tuto volbu, jestliže budou soubor PDF prohlížet a tisknout uživatelé verze Acrobat 5.0 a novějších verzí, ve kterých jsou miniatury vytvářeny dynamicky při každém kliknutí do panelu Stránky.

Vytvořit vrstvy Acrobatu

Uloží každou vrstvu aplikace InDesign jako vrstvu aplikace Acrobat uvnitř PDF. Vrstvy lze plně ovládat, což umožní uživatelům aplikace Acrobat 6.0 a novějších verzí generovat více verzí souboru z jednoho PDF.

Vytvořit tagované PDF

Během exportu automaticky taguje elementy v článku na základě podmnožiny tagů aplikace Acrobat, které InDesign podporuje. To zahrnuje rozpoznávání odstavců, základního formátování textu, seznamů a tabulek. (Tagy můžete také vložit do dokumentu a nastavit před exportem do PDF. Viz Přidávání struktury do PDF.)

Použít strukturu pro pořadí polí

Při exportování použije určené pořadí polí pomocí volby Objekt > Interaktivní > Nastavit pořadí polí. Tato volba je k dispozici jen pro tagované soubory PDF.

Karta Komprese

Komprese

Volbou JPEG (ztrátová komprese) odstranit data obrazu a případně snížíte kvalitu obrazu. Velikost souboru se však sníží s minimální ztrátou informací. Volbou JPEG 2000 (bezztrátová komprese) vyexportujete soubor bez ztrátové komprese. Pokud vyberete volbu Automaticky, aplikace InDesign sama určí nejlepší kvalitu barev a stupně šedi u obrázků.

Kvalita JPEG

Určuje množství detailů v exportovaném obrazu. Čím vyšší kvalita, tím větší bude velikost souboru. Tato volba není k dispozici, pokud pro kompresi vyberete JPEG 2000 (bezztrátová komprese).

Rozlišení

Určete rozlišení bitmapových obrazů v exportovaném souboru PDF. Volba vysokého rozlišení je zejména důležitá, pokud chcete uživatelům umožnit v exportovaném souboru PDF zvětšovat obsah založený na obrazových bodech. Volba vysokého rozlišení může výrazně zvětšit velikost souboru.

Karta Další volby

Zobrazit název

Vyberte, co se má zobrazit v záhlaví aplikace Acrobat při otevření PDF. Dostupné možnosti jsou Název dokumentu a Název souboru.

Jazyk

Vyberte jazyk dokumentu pro soubor PDF. Určí se tím výchozí jazyk pro exportovaný soubor PDF. Pokud požadovaný jazyk není v seznamu, zapište standardní kód jazyka ISO.

Karta Zabezpečení

Vyžadovat heslo při otevření dokumentu

Vyberte tuto volbu, aby se od uživatelů vyžadovalo zadání hesla, které určíte pro otevření dokumentu.

Heslo pro otevření dokumentu

Určete heslo, které uživatelé musí zadat, aby mohli soubor PDF otevřít.

Použít heslo k omezení tisku, úprav a dalších úkonů

Omezí přístup k nastavení zabezpečení souboru PDF. Pokud se soubor otevře v aplikaci Adobe Acrobat, uživatel si může soubor prohlížet, ale musí zadat určené heslo pro práva, aby mohl změnit nastavení zabezpečení a práv. Pokud se soubor otevírá v aplikaci Illustrator, Photoshop nebo InDesign, musí uživatel zadat heslo pro práva, protože v těchto programech není možné otevřít soubor v režimu pouze pro prohlížení.

Heslo pro práva

Určete heslo vyžadované ke změně nastavení práv. Tato volba je dostupná pouze v případě, že je vybraná předcházející volba.

Povolený tisk

Určuje úroveň tisku povolenou uživatelům pro dokument PDF.

Žádný

Zabrání uživatelům vytisknout soubor.

Nízké rozlišení (150 dpi)

Umožní uživatelům tisk s rozlišením nejvýše 150 dpi. Tisk může být pomalejší, protože každá stránka se tiskne jako bitmapový obraz.

Vysoké rozlišení

Umožní uživatelům tisk s jakýmkoli rozlišením, s kvalitním vektorovým výstupem na postscriptových a jiných tiskárnách, které podporují rozšířené možnosti kvalitního tisku.

Povolené změny

Určuje, které úpravy jsou v dokumentu PDF povolené.

Žádný

Zabrání uživatelům provádět jakékoliv změny dokumentu, které jsou uvedené v nabídce Povolené změny, jako je vyplňování polí formulářů a přidávání poznámek.

Vložení, odstranění a natočení stránek

Umožní uživatelům vkládat, odstraňovat a otáčet stránky a vytvářet záložky a miniatury.

Vyplnění polí formulářů a podepsání

Umožní uživatelům vyplňovat formuláře a přidávat digitální podpisy. Tato volba nedovoluje přidávat poznámky ani vytvářet pole formulářů.

Přidání poznámek, vyplnění polí formulářů a podepsání

Umožní uživatelům přidávat poznámky a digitální podpisy a vyplňovat formuláře. Tato volba uživatelům nedovolí přemísťovat objekty stránek ani vytvářet pole formulářů.

Vše kromě vyjmutí stránek

Umožní uživatelům upravovat dokument, vytvářet a vyplňovat pole formulářů a přidávat poznámky a digitální podpisy.

Povolit kopírování textu, obrazů a dalšího obsahu

Dovolí uživatelům vybrat a zkopírovat obsah PDF.

Povolit přístup k textu zařízením pro čtení z obrazovky pro slabozraké

Umožní slabozrakým uživatelům číst dokument pomocí programů pro čtení z obrazovky, ale nedovolí jim kopírovat nebo vyjmout obsah dokumentu.

Povolit textová metadata

Umožní uživatelům kopírovat a vyjmout obsah z PDF. Tato volba umožní archivačním a prohledávacím systémům a vyhledávacím službám přístup k metadatům uloženým v dokumentu.  

Vytváření formulářů PDF (CS5.5 a CS5)

Aplikace InDesign neobsahuje nástroje pro přidávání formulářových polí, avšak aplikace Adobe Acrobat je obsahuje. Můžete vytvořit formulář v aplikaci InDesign, který obsahuje vyhrazená místa jako přepínací tlačítka, zaškrtávací pole a textová pole. Potom můžete vyexportovat soubor do formátu PDF a použít program Acrobat pro převod vyhrazených míst na formulářová pole.

  1. V aplikaci InDesign vytvořte dokument, který chcete použít pro formulář. Pomocí tabulek a textových polí vytvořte vyhrazená místa pro pole.

    V aplikaci InDesign také můžete přidat interaktivní tlačítka.

  2. Exportujte dokument do Adobe PDF.

  3. Spusťte průvodce vytvářením formulářů a převeďte zástupné symboly na formulářová pole. Pomocí nástrojů pro formuláře můžete rozšířit a upravit formulář. Další informace najdete v dokumentaci k aplikaci Adobe Acrobat.

    • Průvodce vytvářením formulářů v aplikaci Acrobat X spustíte výběrem položek Nástroje > Formuláře > Vytvořit.

    • V aplikaci Adobe Acrobat 9 vyberte položky Formuláře > Spustit průvodce vytvářením formulářů.

Doplňkové zdroje

Tým produktu Acrobat zveřejnil článek Návrh formulářů pro automatickou detekci polí v aplikaci Adobe Acrobat.

Michael Murphy publikoval výukový videokurz o vytváření formulářů na stránce Acrobat Friendly Form Design.

Bob Bringhurst publikoval článek o navrhování formulářů na stránce Creating PDF Forms in InDesign.

Náhled interaktivních dokumentů

Pomocí panelu Náhled můžete zobrazit náhled interaktivity a animace aktuálního výběru, aktuální dvojstránky nebo celého dokumentu. Můžete změnit velikost panelu Náhled, můžete panel ukotvit nebo z něj vytvořit plovoucí panel, případně jej můžete přesunout na druhý monitor.

  1. Vyberte Okna > Interaktivní > Náhled.

  2. Chcete-li zobrazit náhled interaktivity a animace, proveďte libovolný z následujících úkonů:

    • Kliknutím na tlačítko Nastavit režim náhledu výběru zobrazíte náhled aktuálního výběru.

    • Kliknutím na tlačítko Nastavit režim náhledu dvojstránky zobrazíte náhled aktuální volby.

    • Kliknutím na tlačítko Nastavit režim náhledu dokumentu zobrazíte náhled aktuálního dokumentu.

  3. Kliknutím na tlačítko Spustit náhled zobrazíte náhled výběru, dvojstránky nebo dokumentu. Podle potřeby v panelu Náhled kliknutím otestujte interaktivní položky jako například tlačítka.

    Když zobrazujete náhled dokumentu, můžete přesunovat po stránkách kliknutím na šipky Jít na předchozí stránku a Jít na další stránku v dolní části panelu.

Poznámka:

Když upravujete dokument, můžete obnovit náhled kliknutím na tlačítko Spustit náhled v panelu Náhled.

Náhled dokumentu ve webovém prohlížeči

  1. V nabídce panelu Náhled vyberte příkaz Testovat v prohlížeči.

  2. Otestujte kliknutím interaktivní položky v dokumentu.

Úpravy nastavení náhledu

  1. V nabídce panelu Náhled zvolte příkaz Upravit nastavení náhledu.

    Dialogové okno Nastavení náhledu zobrazuje aktuální nastavení dialogového okna Export SWF.

  2. Podle potřeby upravte nastavení. Viz Možnosti exportu do formátu SWF.

Použití režimu prezentace

Režim prezentace zobrazuje aktivní dokument InDesign jako prezentaci. V režimu prezentace jsou panely, nabídka aplikace, vodítka a okraje rámů skryté. Oblast pozadí má ve výchozím nastavení tmavou barvu pro případ, že se velikost dokumentu liší od aktuálních rozměrů monitoru.

Režim prezentace výborně doplňuje funkci Adobe Connect. Příkazem Soubor > Sdílet mou obrazovku můžete spustit webové setkání. Jakmile se spustí sdílení obrazovky, můžete svůj dokument InDesign přepnout do režimu prezentace.

  1. Vyberte Zobrazení > Režim zobrazení > Prezentace.

  2. Použijte libovolnou z následujících kláves.

    Akce

    Jak funguje

    Kliknutí myši, Šipka doprava nebo Šipka dolů

    Další dvojstránka

    Shift a kliknout, kliknout pravým tlačítkem myši, Šipka doleva nebo Šipka nahoru

    Předchozí dvojstránka

    Esc

    Ukončit režim prezentace

    Domovská stránka

    První dvojstránka

    Konec

    Poslední dvojstránka

    B

    Změnit barvu pozadí na černou

    W

    Změnit barvu pozadí na bílou

    G

    Změnit barvu pozadí na šedou

Poznámka:

V režimu prezentace nelze upravovat dokument. Na duálním monitoru však můžete otevřít dvě okna stejného dokumentu a jedno z nich přepnout do režimu prezentace. Tímto způsobem můžete upravovat dokument v okně nastaveném na normální zobrazení a ihned vidíte výsledky v okně nastaveném na režim prezentace.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online