Příručka uživatele Zrušit

Tlačítka

  1. Příručka uživatele aplikace InDesign
  2. Seznámení se s aplikací InDesign
    1. Úvod do aplikace InDesign
      1. Co je v aplikaci InDesign nového
      2. Systémové požadavky
      3. Běžné dotazy
      4. Používání knihoven Creative Cloud
    2. Pracovní plocha
      1. Základy práce s pracovní plochou
      2. Panel nástrojů
      3. Nastavení předvoleb
      4. Dotyková pracovní plocha
      5. Výchozí klávesové zkratky
      6. Obnovení dokumentu a vrácení akce
      7. Rozšíření Capture
  3. Vytváření a rozložení dokumentů
    1. Dokumenty a stránky
      1. Vytváření dokumentů
      2. Práce se vzorovými stránkami
      3. Práce se stránkami dokumentu
      4. Nastavení velikosti stránky, okrajů a spadávky
      5. Práce se soubory a šablonami
      6. Vytváření souborů knih
      7. Přidání základního číslování stran
      8. Číslování stránek, kapitol a oddílů
      9. Převod dokumentů QuarkXPress a PageMaker
      10. Sdílení obsahu
      11. Základy práce se spravovanými soubory
      12. Ukládání dokumentů
    2. Mřížky
      1. Mřížky
      2. Formátování mřížek
    3. Pomůcky k rozvržení
      1. Pravítka
  4. Přidání obsahu
    1. Text
      1. Přidání textu do rámečků
      2. Zřetězení textu
      3. Arabské a hebrejské funkce v aplikaci InDesign
      4. Vytvoření textu na cestě
      5. Odrážky a číslování
      6. Glyfy a speciální znaky
      7. Sazba textu
      8. Textové proměnné
      9. Vytváření kódů QR
      10. Úpravy textu
      11. Zarovnání textu
      12. Obtékání textu kolem objektů
      13. Ukotvené objekty
      14. Připojený obsah
      15. Formátování odstavců
      16. Formátování znaků
      17. Hledání a nahrazování
      18. Kontrola pravopisu a jazykové slovníky
    2. Typografie
      1. Používání písem v aplikaci InDesign
      2. Vyrovnání párů a prostrkání
    3. Formátování textu
      1. Formátování textu
      2. Tabulátory a odsazení
    4. Kontrola textu
      1. Sledování a posouzení změn
      2. Přidání redakčních poznámek v aplikaci InDesign
      3. Import poznámek souboru PDF
    5. Přidání odkazů
      1. Vytváření tabulky obsahu
      2. Poznámky pod čarou
      3. Vytvoření rejstříku
      4. Poznámky na konci
      5. Popisky
    6. Styly
      1. Odstavcové a znakové styly
      2. Styly objektů
      3. Iniciály a vnořené styly
      4. Práce se styly
      5. Proklad
    7. Tabulky
      1. Formátování tabulek
      2. Vytváření tabulek
      3. Styly tabulek a buněk
      4. Výběr a úpravy tabulek
      5. Tahy a výplně tabulky
    8. Interaktivita
      1. Hypertextové odkazy
      2. Dynamické dokumenty PDF
      3. Záložky
      4. Tlačítka
      5. Formuláře
      6. Animace
      7. Křížové odkazy
      8. Struktura souborů PDF
      9. Přechody stránky
      10. Filmy a zvuky
      11. Formuláře
    9. Grafika
      1. Cesty a tvary
      2. Kreslení nástrojem tužka
      3. Kreslení nástrojem pero
      4. Použití nastavení čar (tahů) 
      5. Složené cesty a tvary
      6. Úpravy cest
      7. Ořezové cesty
      8. Změna vzhledu rohu
      9. Zarovnání a rozmístění objektů
      10. Propojená a vložená grafika
      11. Integrace datových zdrojů AEM
    10. Barvy a průhlednost
      1. Použití barvy
      2. Použití barev z importované grafiky
      3. Práce se vzorky barev
      4. Míchání tiskových barev
      5. Odstíny
      6. Přímé a výtažkové barvy
      7. Prolnutí barev
      8. Přechody
      9. Sloučení průhledné kresby
      10. Použití efektů průhlednosti
  5. Sdílení
    1. Sdílení a spolupráce        
    2. Sdílení kvůli hodnocení
    3. Recenze sdíleného dokumentu aplikace InDesign
    4. Správa zpětné vazby 
  6. Publikování
    1. Export a publikování
      1. Publish Online
      2. Export obsahu do formátu EPUB
      3. Možnosti Adobe PDF
      4. Exportování obsahu do HTML
      5. Export do Adobe PDF
      6. Export do formátu JPEG
      7. Export do formátu HTML
      8. Přehled řešení DPS a AEM Mobile
    2. Tisk
      1. Tisk brožur
      2. Tiskové značky a spadávky
      3. Tisk dokumentů
      4. Tiskové barvy, výtažky a hustota rastru
      5. Přetisk
      6. Vytváření souborů PostScript a EPS
      7. Kontrola souborů před výstupem používaná před předáním souborů
      8. Tisk miniatur a dokumentů nadměrné velikosti
      9. Příprava souborů PDF pro poskytovatele služeb
      10. Příprava tisku barevných výtažků
  7. Rozšíření aplikace InDesign
    1. Automatizace
      1. Sloučení dat
      2. Zásuvné moduly
      3. Rozšíření Capture v aplikaci InDesign
      4. Skriptování
Poznámka:

Spravedlivý jazyk: Od verze InDesign 2022 (verze 17.0) nahrazujeme neinkluzivní jazyk tak, aby ten nový vyjadřoval základní hodnoty inkluzivity ve společnosti Adobe. Jakýkoli odkaz na Master page (vzorovou stránku) je v našich článcích nápovědy pro anglické, dánské, maďarské, španělské, italské, brazilské, portugalské a japonské národní prostředí nahrazen pojmem Parent page (vzorová stránka).

Poznámka:

Počínaje aplikací InDesign verze 15.0 již nejsou k dispozici formáty souborů Flash (.FLV, .F4V a .SWF). Všechny možnosti týkající se těchto formátů byly z příslušných panelů odstraněny. Další podrobnosti najdete v tématu Přehrávač Flash Player končí | Dopad na aplikaci InDesign.

Vytvoření tlačítek

Můžete vytvořit tlačítka, která provedou určitou akci, když je dokument exportován do formátu EPUB s pevným rozvržením, PDF nebo SWF. Například lze vytvořit tlačítko, které skočí na jinou stránku nebo otevře webovou stránku.

Nastavení tlačítka na přehrávání filmu v exportovaném souboru PDF

Po vytvoření tlačítka můžete provést následující úkony:

Poznámka:

Při práci s tlačítky a navrhování dynamických dokumentů vyberte pracovní plochu Interaktivně pro PDF.

Vytvoření tlačítka

  1. Pomocí nástroje Pero nebo nástroje kreslení, jako je například nástroj Obdélník nebo nástroj Elipsa, nakreslete tvar tlačítka. Pokud je to nutné, přidejte pomocí nástroje text k tlačítku text, například „Další“ nebo „Nákup“.
    Poznámka:

    Když vytváříte navigační tlačítka (například Další stránka nebo Předcházející stránka), která se zobrazí na více stránkách, přidejte je do vzorové stránky, abyste je nemuseli znovu vytvářet na každé stránce dokumentu. Tato tlačítka se zobrazují na všech stránkách dokumentů, na nichž je použit vzor.

  2. Nástrojem pro výběr  vyberte obraz, tvar nebo textový rámeček, který chcete převést.

    Na tlačítko nemůžete změnit film, zvuk ani jejich titulní obraz.

  3. Klikněte na ikonu Převést na tlačítko na panelu Tlačítka a formuláře (vyberte možnost Okna > Interaktivně > Tlačítka a formuláře). Případně zvolte možnost Objekt > Interaktivně > Převést na tlačítko.

    Převést na tlačítko

  4. V panelu Tlačítka a formuláře proveďte následující:

    • Vyberte tlačítkoz rozevírací nabídky Typ.
    • V textovém poli Název zadejte název tlačítka, který jej odliší od ostatních vytvořených tlačítek.
    • Uveďte událost,která aktivuje požadovanou akci.
    • Zadáním jedné nebo více akcítlačítka určete, co se stane při aktivaci události v exportovaném souboru EPUB s pevným rozvržením, PDF nebo SWF. Viz Nastavení interaktivních tlačítek.
    • Aktivujte dalšístavy vzhledu a změnou jejich vzhledu určete, jak bude tlačítko vypadat, pokud pomocí myši přejdete na tlačítko nebo na ně kliknete v exportovaném souboru EPUB s pevným rozvržením, PDF nebo SWF. Viz část Změna vzhledu tlačítka pro přejetí myší a kliknutí.
  5. Pomocí panelu Náhled (Okna > Interaktivně > Náhled interaktivity EPUB / Náhled SWF) vyzkoušíte tlačítko před exportováním dokumentu do interaktivního souboru EPUB s pevným rozvržením, PDF nebo SWF. Svůj dokument můžete také publikovat online pomocí možnosti Publikovat online.

Přidání tlačítka z panelu Vzorová tlačítka

Panel Vzorová tlačítka zahrnuje řadu předem vytvořených tlačítek, která můžete do dokumentu přetáhnout. Tato vzorová tlačítka zahrnují efekty, jako jsou přechody a stínování s mírně odlišným vzhledem pro vzhled Myš nad. Vzorovým tlačítkům jsou také přiřazeny akce. Vzorovým tlačítkům se šipkami jsou například předem přiřazeny akce Přejít na další stránku nebo Přejít na předchozí stránku. Tato tlačítka můžete upravit tak, aby odpovídala vašim potřebám.

Panel Vzorová tlačítka je knihovna objektů. Stejně jako u knihovny objektů můžete na panel přidávat tlačítka a odebírat tlačítka, která nechcete používat. (Viz Použití knihoven objektů.) Vzorová tlačítka jsou uložena v souboru ButtonLibrary.indl, který je umístěn ve složce Presets/Button ve složce aplikace InDesign.

  1. Výběrem možnosti Vzorová tlačítka a formuláře z nabídky na panelu Tlačítka a formuláře otevřete panel Vzorová tlačítka a formuláře.

    Otevření panelu Vzorová tlačítka a formuláře

  2. Přetáhněte tlačítko z panelu Vzorová tlačítka a formuláře do dokumentu. Chcete-li navigační tlačítka zobrazit na každé stránce, přidejte tlačítka do vzorové stránky.

    Vzorová tlačítka a formuláře
    Panel Vzorová tlačítka a formuláře

  3. Vyberte tlačítko pomocí nástroje Výběr a pak podle potřeby upravte tlačítko pomocí panelu Tlačítka a formuláře.

    Při úpravě vzorových tlačítek mějte na paměti následující skutečnosti:

    • Pokud k tlačítku přidáte text, nezapomeňte jej zkopírovat a vložit ze stavu tlačítka Normální do stavu Myš nad. Jinak se přidaný text nezobrazí při umístění ukazatele myši na tlačítko v souboru EPUB s pevným rozvržením, PDF nebo SWF.

    • Máte možnost změnit velikost tlačítek. Pokud přetáhnete dvojici tlačítek se šipkami další stránka / předchozí stránka, změňte velikost prvního tlačítka a pak vyberte druhé tlačítko a vyberte možnost Objekt > Transformovat znovu > Transformovat znovu.

  4. Pomocí panelu Náhled (Okna > Interaktivně > Náhled interaktivity EPUB / Náhled SWF) vyzkoušíte tlačítko před exportováním dokumentu do interaktivního souboru EPUB s pevným rozvržením, PDF nebo SWF. Svůj dokument můžete také publikovat online pomocí možnosti Publikovat online.

Převod tlačítka na objekt

Při převodu tlačítka na objekt zůstane obsah tlačítka na stránce bez vlastností tlačítka. Je odebrán také veškerý obsah spojený s dalšími stavy tlačítka.

  1. Nástrojem pro výběr  vyberte tlačítko.
  2. Vyberte možnost Objekt > Interaktivně > Převést na objekt.

Nastavení tlačítek jako interaktivních

V aplikaci InDesign můžete vytvořit, upravit a řídit interaktivní efekty. Když exportujete dokument do formátu EPUB s pevným rozvržením, PDF nebo SWF, mohou být tyto interaktivní akce aktivní.

Předpokládejme například, že chcete vytvořit tlačítko, které způsobí přehrávání zvuku v dokumentu PDF. Můžete umístit zvukový soubor do dokumentu aplikace InDesign a pak vytvořit tlačítko, které způsobí přehrávání zvuku, když na toto tlačítko kliknete v dokumentu PDF.

V tomto příkladu je kliknutí tlačítkem myši událost a přehrávání zvuku je akce.

Toto tlačítko je nastavené tak, aby po kliknutí přehrávalo zvuk.

Poznámka:

Některé akce jsou podporované v souborech PDF a SWF/EPUB, jiné akce jsou podporované pouze v PDF nebo v SWF/EPUB. Pokud exportujete do formátu SWF nebo EPUB s pevným rozvržením, při výběru se vyhýbejte akci podporované pouze v PDF. Při exportu do PDF se pak vyhýbejte výběru akce podporované pouze v SWF/EPUB.

Přidání akcí k tlačítkům

Akci můžete přiřadit k různým událostem. V exportovaném souboru PDF můžete například určit, že se přehraje zvuk, když se ukazatel myši posune do oblasti tlačítka, a když se klikne tlačítkem myši, začne se přehrávat film. Můžete také ke stejné události přiřadit více akcí. Můžete například vytvořit akci, která spustí film a nastaví zvětšení zobrazení na skutečnou velikost.

  1. Nástrojem pro výběr  vyberte tlačítko, které jste vytvořili.
  2. Na panelu Tlačítka a formuláře zvolte událost, například Při uvolnění, která určuje způsob aktivace akcí.

  3. Klikněte na tlačítko plus vedle položky Akce a zvolte akci pro přiřazení k události.
  4. Určete nastavení akce.

    Pokud například zvolíte akci Přejít na první stránku, určete zvětšení. Pokud zvolíte akci Přejít na adresu URL, zadejte webovou adresu. Některé akce, například Přejít na následující zobrazení, nemají další nastavení.

  5. Pokud je to nutné, přidejte tolik akcí, kolik je třeba pro jakoukoli událost.
  6. Chcete-li otestovat tlačítko, exportujte dokument do souboru EPUB s pevným rozvržením, PDF nebo SWF a zobrazte exportovaný soubor. Pokud exportujete do souboru PDF, musí být vybrána možnosti Interaktivní elementy. Pokud exportujete do souboru SWF, musí být vybráno tlačítko Včetně tlačítek.

Typy událostí

Události určují, jak se akce tlačítek aktivují, když se dokument exportuje do formátu EPUB, PDF nebo SWF. (V aplikaci Acrobat se události nazývají spouštění.)

Při uvolnění nebo kliknutí

Když se po kliknutí uvolní tlačítko myši. To je nejčastěji používaná událost, protože dává uživateli poslední možnost, aby ještě přesunul kurzor mimo tlačítko, a akci neaktivoval.

Při kliknutí

Když se klikne na tlačítko myši (bez uvolnění tlačítka). Pokud nemáte specifický důvod pro použití události Při kliknutí, je lepší použít událost Při uvolnění, aby měl uživatel šanci chování zrušit.

Při přejetí přes

Když se ukazatel myši posune do oblasti tlačítka určené ohraničovacím rámečkem tlačítka.

Při sjetí z

Když ukazatel myši opustí oblast tlačítka.

Při aktivování (PDF)

Když se tlačítko v souboru PDF aktivuje, buď akcí myší, nebo stisknutím tabulátoru.

Při rozostření (PDF)

Když se ohnisko přesune na jiné tlačítko nebo pole formuláře v souboru PDF.

Typy akcí

Při vytváření akce označíte, co se stane při zadané události – obvykle při kliknutí na tlačítko. Můžete přiřadit následující akce, které se provedou, když se aktivuje příslušná událost:

Jít na cíl

Přejde na určenou textovou kotvu vytvořenou pomocí panelu Záložky nebo Hypervazby. Viz Vytvoření přechodů na textovou kotvu.

Přejít na první/poslední/další/předchozí stránku

Přejde na první, poslední, předchozí nebo další stránku v souboru EPUB s pevným rozvržením, PDF nebo SWF. Vyberte volbu v nabídce Zvětšení, určující způsob zobrazení cílové stránky.

Jít na URL

Otevře webovou stránku se zadanou adresou URL.

Zobrazit/skrýt tlačítka a formuláře

Slouží k přepínání mezi zobrazením a skrytím zadaných tlačítek v exportovaném souboru EPUB s pevným rozvržením, PDF nebo SWF. Jestliže například chcete zobrazit určité tlačítko v okamžiku, když najedete kurzorem myši na jiné tlačítko, můžete cílové tlačítko skrýt, dokud se neaktivuje, a vytvořit akci, která při přejetí myši nad tlačítkem zobrazí skryté tlačítko. Viz Zobrazení jiného tlačítka při přejetí myši.

Zvuk

Umožňuje spustit, pozastavit, ukončit nebo pokračovat v přehrávání vybraného zvukového klipu. V nabídce Zvuk se objeví pouze zvukové klipy, které jste přidali do dokumentu.

Video

Umožňuje spustit, pozastavit, ukončit nebo pokračovat v přehrávání vybraného filmu. V nabídce Video se objeví pouze filmy, které jste přidali do dokumentu.

Animace (SWF/EPUB)

Umožňuje spustit, pozastavit, ukončit nebo pokračovat v přehrávání vybrané animace. V nabídce Animace se objeví pouze animace, které jste přidali do dokumentu.

Jít na stránku (SWF/EPUB)

Přejde na stránku v zadaném souboru SWF.

Jít na stav (SWF/EPUB)

Umožňuje přejít na určitý stav v objektu s několika stavy. Příklad: Jestliže objekt s několika stavy má jako stavy několik různých obrazů, můžete tuto akci použít pro zobrazení určitého obrazu.

Jít na další/předchozí stav (SWF/EPUB)

Přejde na další nebo předchozí stav v objektu s několika stavy. Tyto volby jsou zejména užitečné pro procházení prezentace klikáním. Viz část Vytváření vícestavových objektů.

Smazat formulář (PDF)

Vymaže všechna data uvedená v polích formuláře a uvede formulář do původního stavu.

Jít na další zobrazení (PDF)

Vrátí se na stránku po přechodu na předcházející zobrazení. Stejně jako je tlačítko Dopředu ve webovém prohlížeči dostupné až po kliknutí na tlačítko Zpět, je i tato volba dostupná pouze v případě, že uživatel přeskočil na předcházející zobrazení.

Jít na předcházející zobrazení (PDF)

Přeskočí na naposledy zobrazenou stránku v dokumentu PDF nebo se vrátí k posledně použitému měřítku zvětšení.

Otevřít soubor (PDF)

Spustí a otevře soubor, který určíte. Pokud určíte soubor, který není PDF, bude uživatel potřebovat k jeho úspěšnému otevření původní aplikaci. Určete absolutní cestu souboru (například c:\docs\vzor.pdf).

Tisk formuláře (PDF)

Otevře dialogové okno pro tisk a vytiskne formulář.

Odeslat formulář (PDF)

Odešle data uvedená v polích formuláře na zadanou adresu URL. Do pole URL je nutné zadat příkaz mailto: následovaný e-mailovou adresou, na kterou chcete odeslat vyplněný formulář. Ujistěte se, že se před a za dvojtečkou (:) nenachází mezera.

Nastavit zvětšení (PDF)

Zobrazí stránku s volbou zvětšení, kterou vyberete. Můžete změnit úroveň zvětšení stránky (například Skutečná velikost), rozvržení stránky (například Průběžně-protilehlé) nebo natočení stránky.

Úprava nebo odstranění akcí tlačítek

  1. Nástrojem pro výběr  vyberte tlačítko.
  2. V panelu Tlačítka a formuláře proveďte libovolný z následujících úkonů:

    • Chcete-li deaktivovat akce, zrušte zaškrtnutí políčka vedle položky. Zablokování (deaktivace) událostí a akcí může být užitečné pro účely testování.
    • Chcete-li změnit pořadí, přetáhněte akce.
    • Chcete-li odstranit akci, vyberte akci v poli se seznamem a klikněte na tlačítko Odstranit vybranou akci .
    • Chcete-li upravit akci, zvolte událost, k níž je přiřazena, vyberte akci v poli se seznamem a změňte nastavení. Pokud potřebujete změnit akci pro existující událost, odstraňte akci, a pak přidejte pro událost novou akci.

Vytvoření přechodů na textovou kotvu

Pokud v dokumentu aplikace InDesign vytvoříte kotvu textu, můžete nastavit tlačítko, aby přeskočilo na tuto kotvu, a to i z jiného dokumentu aplikace InDesign. Chcete-li přidat kotvy textu, použijte panel Záložky a panel Hypervazby. Na záložky, které nejsou kotvami textu, nelze vytvářet přechody z tlačítek.

Poznámka:

Pokud na tlačítku nastavíte cíl hypertextového odkazu, nebude mít hypertextový odkaz v exportovaném dokumentu EPUB s pevným rozvržením, PDF nebo SWF žádný efekt.

  1. Nástrojem pro výběr  vyberte tlačítko.
  2. Na panelu Tlačítka a formuláře vyberte událost, například Při uvolnění, která vyvolá přeskočení.

  3. Klikněte na znak plus vedle tlačítka Akce a pak zvolte možnosti Přejít na cíl.
  4. V nabídce Dokumenty vyberte jeden z otevřených dokumentů InDesign nebo klikněte na ikonu složky v pravé části nabídky a zadejte soubor.
  5. Určete kotvu, která byla vytvořena pomocí panelu Záložky nebo panelu Hypervazby.
  6. Vyberte volbu v nabídce Zvětšení, určující způsob zobrazení cílové stránky.
Poznámka:

Pokud určíte kotvu v jiném dokumentu, nezapomeňte exportovat tento cílový dokument do PDF, a použít stejný název souboru jako má dokument aplikace InDesign pouze s příponou PDF místo INDD. Dokumenty PDF uložte také do stejné složky, abyste zajistili, že vazby v aplikacích Acrobat a Reader zůstanou platné.

Změna vzhledu tlačítka pro přejetí myší a kliknutí

Tlačítko sestává ze skupiny jednotlivých objektů, z nichž každý představuje vzhled tlačítka (někdy se nazývá „stav“). Každé tlačítko může mít až tři stavy: Normální, Myš nad a Kliknutí. Vzhled Normální se v exportovaném souboru zobrazuje, dokud není kurzor myši umístěn nad oblastí (Myš nad) nebo není stlačené tlačítko myši v oblasti tlačítka (Kliknutí). Každý vzhled může být jiný, a poskytovat tak vizuální zpětnou vazbu.

Standardně je každé tlačítko, které vytvoříte, definované se stavem Normální a toto tlačítko obsahuje text nebo obraz tlačítka. Když aktivujete nový vzhled, zkopíruje se vzhled Normální. Chcete-li vzhled odlišit od jiných vzhledů, můžete změnit barvu nebo přidat text nebo obrázek.

Stavy tlačítka

A. Ukazatel není v oblasti tlačítek (Normální) B. Kurzor se přesunul nad oblast tlačítka (Myš nad) C. Ukazatel kliká (Kliknutí) 

Poznámka:

Oblast, v níž lze používat kliknutí, neboli oblast tlačítek je čtvercový ohraničovací rámeček největšího stavu u tlačítka. Kruhové tlačítko má například čtvercovou oblast tlačítek.

Změna vzhledů tlačítka

Když vytváříte tlačítko s několika vzhledy (Normální, Myš nad a Kliknutí), je vhodné dokončit návrh tlačítka ještě předtím, než aktivujete jiné vzhledy. Když aktivujete vzhled Myš nad nebo vzhled Kliknutí, vzhled Normální se zkopíruje.

Některé změny mají vliv pouze na vybrané vzhledy, zatímco jiné změny ovlivní všechny aktivní vzhledy. Pokud vyberete vzhled a použijete u něho jinou barvu pozadí nebo upravíte text, má změna vliv pouze na vybraný vzhled. Jestliže k přesunutí nebo změně tlačítka použijete nástroj pro výběr, změna bude mít vliv na všechny vzhledy.

  1. Výběrem možnosti Okna > Interaktivně > Tlačítka a formuláře otevřete panel Tlačítka a formuláře.

  2. Nástrojem pro výběr  vyberte v rozvržení tlačítko, které chcete upravit.
  3. Kliknutím na položku [Myš nad] aktivujte vzhled při přejetí myši.

    Do vzhledu Myš nad se zkopíruje vzhled Normální.

  4. S vybranou volbou Myš nad změňte vzhled tlačítka.
    • Chcete-li změnit barvu, vyberte barevný vzorek v nabídce Tah nebo Výplň v ovládacím panelu.
    • Chcete-li do vzhledu umístit obraz, vyberte stávající obraz pomocí nástroje pro přímý výběr nebo dvakrát klikněte na stávající obraz tlačítka. Poté zvolte příkaz Soubor > Umístit a dvakrát klikněte na soubor.
    • Chcete-li vložit obraz do textového rámečku, zkopírujte ho do schránky, vyberte vzhled v panelu Tlačítka a pak vyberte možnost Úpravy > Vložit dovnitř.
    • Chcete-li zadat text, vyberte nástroj Text, klikněte na tlačítko a zadejte text. Vložený textový rámeček můžete také zkopírovat výběrem možností Upravit > Vložit dovnitř.
  5. Chcete-li přidat vzhled Kliknutí, aktivujte jej kliknutím na položku [Kliknutí] a stejným postupem změňte jeho vzhled.
  6. Jiné vzhledy tlačítka můžete otestovat pomocí panelu Náhled.
Poznámka:

Chcete-li změnit velikost miniatur Vzhled stavu na panelu Tlačítka, vyberte v nabídce panelu Tlačítka a formuláře možnost Volby panelu, zvolte požadovanou možnost a pak klikněte na tlačítko OK.

Odstranění a zakázání vzhledů

  1. Vyberte vzhled na panelu Tlačítka a formuláře.

  2. Proveďte libovolný z následujících úkonů:
    • Chcete-li vzhled Myš nad nebo Kliknutí smazat, klikněte na ikonu Odstranit v dolní části panelu. Odstranění vzhledu je obzvlášť užitečné, pokud vzhled Normální výrazně upravujete a rozhodnete se, že vzhled Myš nad nebo Kliknutí založíte na novém vzhledu Normální.
    • Chcete-li vzhled zakázat, aniž byste jej odstranili, klikněte na ikonu oka vedle vzhledu a zrušte její označení. Zakázané stavy se do souboru EPUB s pevným rozvržením, PDF nebo SWF neexportují.
Poznámka:

Stav Normální nemůžete odstranit ani zakázat.

Vytváření vícestavových objektů

Pomocí panelu Stavy objektu můžete vytvářet různé verze objektu. Stav je verze položky stránky. Objekt s několika stavy se nazývá vícestavový objekt.

Panel Stavy objektu nijak neomezuje počet stavů, které lze pro objekt vytvořit. Pokaždé, když vytvoříte stav, vygeneruje se další verze položky stránky. Na stránce se v danou chvíli zobrazí vždy pouze jeden stav. V konečném tiskovém výstupu a ve výstupu do PDF se zobrazí pouze aktivní stav.

Vytváření prezentace z vícestavových objektů

Jedním z nejběžnějších způsobů využití vícestavového objektu je prezentace, v níž mohou uživatelé souboru SWF klikáním procházet sadu obrazů. Můžete například vytvořit prezentaci 20 obrazů, aniž byste museli obrazy umísťovat na 20 různých stránek.

  1. Vložte obrazy, které budou součástí prezentace.

    Optimálních výsledků dosáhnete, pokud budou rámečky obrazů stejné velikosti.

    Stavem nemusí být jediná položka: stavem může být i kolekce položek.

  2. Obrazy nastohujete tak, že je vyberete a v ovládacím panelu zvolíte příkaz Zarovnat vodorovné středy  a Zarovnat svislé středy .

  3. Ponechte obrazy vybrané, otevřete panel Stavy (Okna > Interaktivní > Stavy objektu) a klikněte na tlačítko Převést výběr na vícestavový objekt .

    Obrazy se zobrazí jako stavy v panelu Stavy objektu, a kolem vybraných obrazů se vytvoří okraje přerušovanou čárou.

    Převést výběr na vícestavový objekt

  4. Vytvořte navigační tlačítka, která spustí akce Jít na další stav a Jít na předchozí stav při uvolnění tlačítka myši. Viz Vytvoření tlačítek

  5. Pomocí panelu Náhled (Okna > Interaktivně > Náhled interaktivity EPUB / Náhled SWF) vyzkoušíte navigační tlačítka.

  6. Export dokumentu do formátu SWF. Viz Interaktivní dokumenty.

Úpravy vícestavového objektu

  1. Vyberte vícestavový objekt.

  2. V panelu Stavy objektu proveďte libovolný z následujících úkonů:

    • Chcete-li upravit stav, vyberte stav v panelu Stavy objektu a potom upravte objekt. Můžete například přidat tah nebo výplň nebo změnit velikost objektu.

    • Chcete-li přidat objekt do existujícího stavu, vyberte jak tento objekt tak i vícestavový objekt a potom klikněte na tlačítko Přidat objekty do viditelného stavu .

    • Chcete-li přidat stávající vícestavový objekt do nového stavu, vyberte daný objekt i vícestavový objekt a potom klikněte na tlačítko Převést výběr na vícestavový objekt .

    • Chcete-li duplikovat stav, vyberte stav, na kterém bude založen nový stav, a potom v nabídce panelu vyberte Nový stav. Můžete přidávat, odstraňovat nebo upravovat obsah stavu.

    • Chcete-li vložit objekty do existujícího stavu, vyjměte nebo zkopírujte jedeno nebo více objektů, vyberte vícestavový objekt, vyberte stav v panelu Stavy objektu a zvolte příkaz Vložit do stavu v nabídce panelu Stavy objektu.

    • Chcete-li převést vícestavový objekt zpět na sérii nezávislých objektů, vyberte stav v panelu Stavy objektů a v nabídce panelu zvolte příkaz Uvolnit stav na objekt. Chcete-li převést všechny stavy ve vícestavovém objektu na objekty, zvolte Uvolnit všechny stavy na objekty.

    • Chcete-li odstranit stav a smazat jeho obsah, vyberte stav a v nabídce panelu zvolte příkaz Odstranit stav.

    • Chcete-li skrýt vícestavový objekt v exportovaném souboru, dokud nebude spuštěn tlačítkem, zvolte v nabídce panelu příkaz Skrýt do spuštění.

    • Chcete-li obnovit všechny vícestavové objekty v dokumentu do prvního stavu, zvolte v nabídce panelu příkaz Obnovit všechny vícestavové objekty do prvního stavu. Když vyberete stav, objekt zůstane v tomto stavu, i když zavřete a znovu otevřete dokument. Touto volbou můžete rychle obnovit všechny vícestavové objekty.

Vytvoření citlivých oblastí tlačítka

V některých případech budete chtít oblast tlačítek (zvanou „citlivá oblast“ nebo „citlivá vazba“) zneviditelnit, dokud nad ní není kurzor myši. Když například kurzor umístíte na tlačítko v mapě, může se zobrazit mapa příslušného regionu, která zase zmizí, když posunete kurzor jinam.

Když v exportovaném souboru PDF podržíte kurzor na aktivním bodu, objeví se obraz.

Zobrazení skrytého obrazu při přejetí myši

Jedním způsobem, jak dosáhnout efektu „citlivé oblasti“, je použít obraz ve stavu Myš nad v panelu Tlačítka. Postup je následující: vytvořte tlačítko, které ve stavu [Myš nad] zobrazí obraz, ale ve stavu [Normální] nezobrazí obraz.

  1. Vyberte obraz, který chcete použít jako citlivou oblast. Zkontrolujte, že rámeček obrazu nemá okraj ani pozadí.

  2. Vybraný obraz převeďte na tlačítko kliknutím na vzhled [Normální] na panelu Tlačítka a formuláře (vyberte možnost Okna > Interaktivně > Tlačítka a formuláře).

  3. Aktivujte jej kliknutím na vzhled [Myš nad] v panelu Tlačítka a formuláře.

  4. Klikněte znovu na vzhled [Normální]. Potom vyberte obraz pomocí nástroje pro přímý výběr a odstraňte obraz.

    Zkontrolujte, zda opravdu odstraňujete obraz (obsah rámečku) a nikoli rámeček s obsahem. Odstraněním rámečku odstraníte celé tlačítko.

  5. Pomocí panelu Náhled můžete zobrazit náhled efektu citlivé oblasti.

Zobrazení jiného tlačítka při přejetí myši

Můžete vytvořit citlivou oblast, v níž se při kliknutí nebo přejetí myši přes objekt zobrazí jiný objekt. Postup je následující: vytvořte dvě tlačítka, jedno z nich skryjte a pomocí akce Zobrazit/skrýt tlačítko nechte cílové tlačítko zobrazovat nebo skrývat.

  1. Vytvořte objekt, který se použije jako zdrojové tlačítko. Klikněte na ikonu Převést objekt na tlačítko na panelu Tlačítka a formuláře.

  2. Vložte obraz, který chcete použít jako cílové tlačítko, a převeďte jej na tlačítko.
  3. V dolní části panelu Tlačítka a formuláře vyberte cílový obraz a vyberte možnost Skrytý do spuštění.

    Obraz musí v exportovaném dokumentu zůstat skrytý, aby se mohl zobrazit při kliknutí na zdrojové tlačítko.

  4. Vyberte zdrojové tlačítko a vytvořte dvě různé akce, jednu pro zobrazení cílového obrazu a druhou pro skrytí cílového obrazu.

    Chcete-li obraz nechat zobrazit při přejetí myši přes zdrojové tlačítko, použijte události Při přejetí a Při vyjetí. Chcete-li obraz nechat zobrazit při kliknutí na zdrojové tlačítko a skrýt při uvolnění tlačítka, použijte události Při kliknutí a Při uvolnění. V obou případech můžete pro zobrazení a skrytí cílového tlačítka použít akci Zobrazit/skrýt tlačítko. Viz Nastavení interaktivních tlačítek.

  5. Tlačítka můžete otestovat pomocí panelu Náhled.

Změna voleb PDF pro tlačítka

  1. Nástrojem pro výběr  vyberte tlačítko.
  2. V nabídce panelu Tlačítka a formuláře vyberte položku Možnosti PDF.

  3. Zadejte popis, který také poslouží jako alternativní text pro slabozraké uživatele.
  4. Uveďte, zda se má tlačítko v dokumentu PDF tisknout, a pak klikněte na tlačítko OK.

Nastavení pořadí procházení tlačítek

Pořadí procházení určuje následující (nebo předcházející) pole, které se stane aktivní, když uživatel v dokumentu PDF nebo SWF stiskne tabulátor (nebo Shift+tabulátor). Pořadí zahrnuje tlačítka na skrytých vrstvách, ale ne tlačítka na vzorových stránkách.

  1. Přejděte na stránku obsahující tlačítka.
  2. Vyberte možnost Objekt > Interaktivně > Nastavit pořadí polí.

  3. Vyberte každé tlačítko, které chcete přemístit a přetáhněte ho na nové místo nebo klikněte na tlačítko Posunout nahoru nebo Posunout dolů. Po dokončení klikněte na OK.

Pokud pomocí aplikace Acrobat upravujete soubor PDF a přidáte na stránku další tlačítka nebo pole formuláře, budete možná muset nastavit pořadí procházení polí v aplikaci Acrobat.

Související témata

Vytváření a publikování elektronických knihbrožurletákůpohlednicplakátůinteraktivních rozložení stránek a mnohé další s aplikací Adobe InDesign.

Logo Adobe

Přihlaste se ke svému účtu.