Pracovní postupy formulářů

V aplikaci InDesign můžete navrhovat formuláře a exportovat je přímo do formátu PDF. Aplikace InDesign nyní podporuje pole formulářů a další akce s formuláři. Knihovna Tlačítka a formuláře (Okno > Interaktivní > Tlačítka a formuláře) obsahuje položky formulářů, které můžete použít při návrhu interaktivních formulářů.

Pomocí aplikace InDesign můžete vytvářet jednoduché formuláře, aniž by bylo nutné upravovat dokument PDF v aplikaci Acrobat po publikování. Na stránkách můžete přidávat jednoduché prvky formuláře. Jsou podporovány běžné typy polí, například textová pole, přepínací tlačítka, zaškrtávací pole a podpisy. Můžete také přidat akce pro odeslání formuláře e-mailem nebo pro jeho vytisknutí.

Kromě základního návrhu můžete využít kreativní schopnosti aplikace InDesign a dodat formuláři nádech originality.

  • Přidejte do polí formuláře PDF plné tahy a výplně.
  • Přidejte vlastní stavy Zapnuto, Vypnuto a Kurzor-nad pro tlačítka, zaškrtávací políčka a přepínací tlačítka.
  • Určete velikost písma pro pole zadání textu.

Chcete-li například získávat informace o kreditních kartách, můžete použít ikony kreditních karet jako přepínače s různým obrázkem pro vybraný stát.

Pro pokročilé pracovní postupy formulářů lze exportovat základní formulář a pokračovat v úpravách v aplikaci Adobe Acrobat.

Přidání pole formuláře

Pomocí panelu Tlačítka a formuláře můžete do rozvržení přidávat pole formuláře. Postupy přidávání polí interaktivních formulářů jsou stejné jako postupy přidávání tlačítek, takže se nemusíte učit nové postupy. Můžete vytvořit formulář fungující v aplikaci Adobe Reader nebo Adobe Acrobat. Pomocí aplikace InDesign můžete vytvářet zajímavé formuláře, které nelze běžně vytvořit pomocí aplikace Acrobat.

Panel Tlačítka a formuláře
Panel Tlačítka a formuláře

  1. Umístěte rámeček do místa, kam chcete umístit pole formuláře.

  2. Otevřete panel Tlačítka a formuláře (Okna > Interaktivní > Tlačítka a formuláře)

  3. V seznamu Typ vyberte rámeček a zvolte typ elementu formuláře. Můžete také kliknout pravým tlačítkem na rámeček a vybrat možnost Interaktivní > Převést do [...].

  4. Zadejte název pro pole formuláře. Aby bylo možné vytvořit skupinu přepínacích tlačítek, musejí mít jednotlivá přepínací tlačítka stejný název.

  5. Vyberte událost a přidejte akce, které s ní chcete asociovat. Byly přidány akce jako Smazat formulář, Tisk formuláře a Odeslat formulář. U akce Odeslat formulář zadejte adresu URL jako „mailto:xyz@priklad.cz“.

  6. V případě přepínacího tlačítka, zaškrtávacího pole nebo tlačítek: nastavte atributy vzhledu pro různé stavy. Aplikace InDesign přidá výchozí grafiku pro různé stavy, ale vy můžete přidat svoji vlastní.

  7. Vyberte rodinu, typ a velikost písma pro pole seznamu, pole se seznamem nebo textové pole.

  8. Určete volby PDF:

    • Popis – Zadaná hodnota se zobrazí jako špička nástroje a použije se k vytváření formulářů s usnadněním přístupu
    • Hodnota tlačítka – Tato hodnota odpovídá hodnotě exportu v aplikaci Acrobat a lze ji použít k určení přepínače ve skupině v dostupném formuláři.

Určení pořadí polí

Abyste mohli vytvořit uživatelsky příjemné a přístupné formuláře, musíte přiřadit použitelné pořadí polí. Uživatelé mohou procházet pole formuláře bez použití ukazovacího zařízení. Stisknutí klávesy Tab posune ohnisko do následujícího logického pole.

Existují dvě metody určení pořadí polí v tagovaných souborech PDF:

  • Pomocí panelu Články (Okna > Článek) můžete určit vlastní pořadí polí
  • Zvolte možnost Objekt > Interaktivní > Nastavit pořadí polí.

Určete pořadí polí pomocí panelu Články

Použití panelu Články k určení pořadí polí
Použití panelu Články k určení pořadí polí

  1. Otevřete panel Články (Okno > Články).

  2. Přetáhněte pole formuláře do panelu Články.

  3. Na panelu Články přetažením uspořádejte pořadí polí.

Poznámka:

Aby mohly čtečky obrazovky používat určené pořadí, aktivujte v nabídce panelu Články možnost Použít pro pořadí čtení v tagovaných PDF. Při exportu PDF nezapomeňte aktivovat volbu Vytvořit tagované PDF.

Určete pořadí polí pomocí panelu Struktura

  1. Zvolte možnost Objekt > Interaktivní > Nastavit pořadí polí.

  2. Kliknutím na možnost Posunout nahoru nebo Posunout dolů uspořádáte položky v požadovaném pořadí polí.

Při exportování do interaktivního PDF povolte možnost Použít strukturu pro pořadí polí v dialogovém okně Exportování PDF.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online