Při umístění grafiky se v rozvržení obsah souboru zobrazuje v rozlišení obrazovky, aby byla grafika vidět a dala se přesně umístit. Vlastní soubor grafiky však může být připojený nebo vložený.

  • Připojená grafika je navázaná, ale zůstává nezávislá na dokumentu, výsledkem je pak menší dokument. Připojené grafiky můžete modifikovat pomocí transformačních nástrojů a efektů; nemůžete ale vybrat a upravit jednotlivé komponenty v grafice. Připojenou grafiku můžete použít mnohokrát, aniž by se výrazně zvětšila velikost dokumentu; můžete také aktualizovat všechny vazby najednou. Když exportujete nebo tisknete, načte se původní grafika a konečný výstup se vytvoří z originálů v plném rozlišení.

  • Vložená grafika se zkopíruje do dokumentu v plném rozlišení a výsledkem je větší dokument. Můžete sledovat verze a kdykoli soubor aktualizovat; pokud je grafika vložená, dokument je nezávislý.

Chcete-li zjistit, zda je grafika připojená nebo vložená, nebo změnit její stav z jednoho na druhý, použijte panel Vazby.

Pokud má umísťovaný bitmapový obraz velikost 48 KB nebo menší, InDesign automaticky vloží do rozvržení obraz v plném rozlišení místo verze v rozlišení obrazovky. InDesign zobrazuje tyto obrazy v panelu Vazby, takže můžete sledovat verze a kdykoli soubor aktualizovat; vazba ale není pro optimální výstup nezbytná.

Poznámka:

Když přesunete dokument do jiné složky nebo na jiný disk (například pokud ho odnesete k poskytovateli služeb), musíte přesunout také připojené soubory grafik, protože nejsou uloženy uvnitř dokumentu. Všechny připojené soubory můžete zkopírovat automaticky pomocí funkcí Kontrola před výstupem a Sbalit.

Všechny soubory umístěné v dokumentu se zobrazují v panelu Vazby. Platí to jak pro lokální soubory (na disku) tak i pro datové zdroje, které jsou spravované na serveru. Ale soubory vložené z webových stránek otevřených v aplikaci Internet Explorer se v tomto panelu nezobrazují.

Panel Vazby v aplikaci InCopy také zobrazuje připojené články. Když v panelu Vazby zvolíte připojený článek, v části Informace o vazbě se zobrazí údaje například o počtu poznámek, stavu zpracování a stavu sledovaných změn.

Panel Vazby
Panel Vazby

A. Sloupce kategorií B. Zobrazit/skrýt informace o vazbě C. Ikona: Jedna nebo více instancí bylo změněno D. Ikona: Změněno E. Ikona chybějící vazby F. Ikona vložené vazby 

Pokud se stejná grafika bude v dokumentu zobrazovat vícekrát, vazby se zkombinují pod popisným trojúhelníkem v panelu Vazby. Pokud připojená grafika EPS nebo dokument aplikace InDesign obsahuje vazby, vazby se rovněž zkombinují pod popisným trojúhelníkem.

Připojený soubor se může zobrazit v panelu Vazby jedním z následujících způsobů:

Aktuální

Aktuální soubor má prázdný stav ve sloupci Stav.

Změněné

Tato ikona označuje, že verze souboru na disku je novější než verze v dokumentu. Zobrazí se například tehdy, když importujete do grafiku z aplikace Photoshop do aplikace InDesign a pak někdo upraví a uloží původní grafiku v aplikaci Photoshop.

Mírně odlišná verze ikony Změněno se zobrazuje v případě, že je grafika změněna a jedna nebo více instancí je aktualizována, zatímco ostatní aktualizovány nejsou.

Chybějící

Grafika již není v místě, ze kterého byla importována, ačkoliv může existovat někde jinde. Chybějící vazby se mohou vyskytnout v případě, že někdo odstraní původní soubor nebo jej přesune do jiné složky nebo serveru poté, co byl soubor importován. Nelze zjistit, zda je chybějící soubor aktuální, dokud se nenajde jeho originál. Když tisknete nebo exportujete dokument a je zobrazena tato ikona, soubor se nemusí vytisknout nebo exportovat v plném rozlišení.

Vložené

Vložení obsahu připojeného souboru pozastaví operace správy této vazby. Pokud na vybrané vazbě právě probíhají „úpravy na místě“, tato volba není dostupná. Zrušením vložení souboru obnovíte operace správy vazby pro tuto vazbu.

Pokud se připojený text nezobrazuje na určité stránce dokumentu, budou následující kódy indikovat, kde se objekt zobrazuje: PB (pracovní plocha), MP (vzorová stránka), OV (přesahující text) a HT (skrytý text).

Výukový videokurz o použití panelu Vazby najdete na stránce www.adobe.com/go/lrvid4027_id_cz.

Videocast o tipech a způsobech práce s panelem Vazby najdete na stránce InDesign Secrets: Saving time with the Links panel.

  • Chcete-li zobrazit panel Vazby, zvolte Okna > Vazby. Každý připojený soubor a automaticky vložený soubor je označen svým názvem.
  • Chcete-li vybrat a zobrazit připojenou grafiku, vyberte vazbu v panelu Vazby a klikněte na tlačítko Najít vazbu , klikněte na číslo stránky vazby ve sloupci Stránka nebo zvolte Najít vazbu z nabídky panelu Vazby. InDesign vystředí zobrazení vybrané grafiky. Chcete-li zobrazit skrytý objekt, zobrazte si vrstvu (nebo podmínku, pokud se jedná o ukotvený objekt).
  • Chcete-li rozbalit nebo sbalit vnořené vazby, klikněte na ikonu trojúhelníku vlevo od vazby. Vnořené vazby se vyskytují v případě, že se stejná grafika v dokumentu zobrazuje vícekrát nebo pokud připojená grafika EPS nebo dokument aplikace InDesign obsahují vazby.
  • Chcete-li seřadit vazby v panelu, kliknutím na název kategorie v horní části panelu Vazby zvolíte řazení dle této kategorie. Dalším kliknutím na stejnou kategorii obrátíte pořadí položek. Pokud například kliknete na kategorii Stránka, vazby se zobrazí v pořadí od první po poslední stránku. Pokud kliknete znovu na sloupec Stránka, vazby se seřadí od poslední po první stránku. Pomocí nabídky Volby panelu můžete přidávat sloupce do panelu Vazby.

V panelu Vazby můžete zobrazit další kategorie, například Datum vytvoření a Vrstva, a zobrazit tak více informací o grafice. Pro každou kategorii lze určit, zda se informace budou zobrazovat jako sloupec v panelu Vazby a v části Informace o vazbě v panelu Vazby.

  1. Zvolte Volby panelu z nabídky panelu Vazby.
  2. Zapnutím zaškrtávacích políček pod volbou Zobrazit sloupec přidáte sloupce do panelu Vazby.

    Složka 0 je složka obsahující připojený soubor, Složka 1 obsahuje Složku 0, atd.

  3. Zapnutím zaškrtávacích políček pod volbou Zobrazit v informacích o vazbě nastavíte zobrazení informací v části Informace o vazbě panelu Vazby.
  4. Klikněte na OK.

Pořadí sloupců lze změnit uchopením a přetažením slupce na jiné místo. Šířku sloupce změníte tažením za jeho okraj. Kliknutím na název kategorie seřadíte vazby dle této kategorie ve vzestupném pořadí. Dalším kliknutím seřadíte položky v sestupném pořadí.

  1. Zvolte Volby panelu z nabídky panelu Vazby.
  2. Velikost řádku můžete vybrat z možností: Malé řádky, Normální řádky nebo Velké řádky.
  3. Pro miniatury lze určit, zda se miniatury grafiky budou zobrazovat ve sloupci Název a v části Informace o vazbě v panelu Vazby.
  4. Klikněte na OK.

V části Informace o vazbě panelu Vazby se zobrazují informace o vybraném připojeném souboru.

Poznámka:

Chcete-li změnit informace, které se zobrazují v části Informace o vazbě v panelu Vazby, zvolte Volby panelu z nabídky panelu Vazby a označte zaškrtávací pole ve sloupci Zobrazit v informacích o vazbě.

  1. Dvojitě klikněte na vazbu nebo vyberte vazbu a klikněte na ikonu Zobrazit/skrýt informace o vazbě (trojúhelník na levé straně panelu).

Pokud připojený nebo vložený soubor obsahuje metadata, můžete tato metadata prohlížet pomocí panelu Vazby. Metadata spojená s provázaným souborem nelze upravit ani vyměnit.

  1. Vyberte soubor v panelu Vazby a z nabídky panelu zvolte možnosti Pomůcky > Informace o souboru XMP.

Vložení obrazu do dokumentu

Místo připojení souboru, který jste umístili do dokumentu, můžete soubor vložit (nebo uložit) do dokumentu. Když soubor vložíte, přerušíte vazbu s originálem. Bez vazby nezobrazí panel Vazby upozornění při změně originálu a soubor nemůžete automaticky aktualizovat.

Vložení souboru zvětší velikost souboru dokumentu.

Vložení připojeného souboru

  1. Vyberte soubor v panelu Vazby.
  2. Proveďte libovolný z následujících úkonů:
    • Zvolte Vložit vazbu z nabídky panelu Vazby.

    • Pokud existuje více instancí souboru, zvolte Vložit všechny výskyty [Název souboru] z nabídky panelu Vazby. Chcete-li vložit pouze jednu instanci, vyberte ji a zvolte Vložit vazbu.

Soubor zůstane v panelu Vazby označený ikonou vložené vazby .

Poznámka:

Pro textový soubor, který se zobrazí v panelu Vazby, vyberte Odpojit v nabídce panelu Vazby. Když vložíte textový soubor, jeho název se automaticky odstraní z panelu Vazby.

Vyjmutí připojeného souboru

  1. Vyberte jeden nebo více vložených souborů v panelu Vazby.
  2. Proveďte jeden z následujících úkonů:
    • Vyberte Vyjmout vazbu v nabídce panelu Vazby. Pokud existuje více instancí souboru, zvolte Vyjmout všechny výskyty [Název souboru] z nabídky panelu Vazby.

    • Klikněte na tlačítko Změnit vazbu nebo vyberte Změnit vazbu v nabídce panelu Vazby.

  3. Zvolte, zda chcete soubor připojit na původní soubor nebo na složku, kterou InDesign vytvoří z vložených dat, uložených v dokumentu.

Použijte panel Vazby, chcete-li zkontrolovat stav libovolné vazby nebo nahradit soubory aktualizovanými nebo jinými soubory.

Když aktualizujete nebo znovu vytvoříte (změníte) vazbu na soubor, všechny transformace provedené v aplikaci InDesign se zachovají (pokud v předvolbách Zpracování souborů zvolíte Při změně vazby se zachovají rozměry). Pokud například importujete čtvercovou grafiku a otočíte ji o 30° a pak změníte vazbu na neotočenou grafiku, aplikace InDesign ji otočí o 30° tak, aby odpovídala rozvržení grafiky, kterou nahrazuje.

Poznámka:

Umístěné soubory EPS mohou obsahovat vazby OPI, které se objeví v panelu Vazby. Neměňte vazby OPI na jiné soubory než na ty, které určil autor souboru EPS; pokud to uděláte, může to mít za následek problémy se zaváděním písem a separacemi barev.

Volba změny velikosti grafiky v závislosti na změně vazby

Při změně vazby a nahrazení některé grafiky jiným zdrojovým souborem můžete ponechat rozměry obrazu souboru, který je nahrazován, nebo můžete zobrazit vstupní soubor v jeho skutečných rozměrech.

  1. Zvolte Úpravy > Předvolby > Zpracování souborů (Windows) nebo InDesign > Předvolby > Zpracování souborů (Mac OS).

  2. Pokud chcete, aby se nové obrázky zobrazovaly ve stejné velikosti jako původní obrázky zvolte Zachovat rozměry obrazů při obnově vazby. Pokud zrušíte označení této volby, budou se nově připojené obrázky zobrazovat ve skutečné velikosti.

InDesign nejprve hledá chybějící vazbu ve složce, v níž se v aktuální relaci měnila vazba jiného souboru. Potom hledá vazbu ve stejné složce, v níž se nachází dokument. Jestliže nemůže vazbu nalézt, hledá v nadřazené složce dokumentu.

Změněné vazby se také nazývají neaktuální vazby.

  1. V panelu Vazby proveďte jeden z následujících úkonů:
    • Chcete-li aktualizovat určité vazby, vyberte jednu nebo více vazeb označených ikonou změněné vazby . Potom klikněte na tlačítko Aktualizovat vazbu , nebo zvolte Aktualizovat vazbu z nabídky panelu Vazby.

    • Chcete-li aktualizovat odkazy, vyberte možnost Aktualizovat všechny vazby z nabídky panelu Vazby, nebo vyberte změněný odkaz a kliknutím na klávesu Alt (Windows) nebo Option (Mac OS) stiskněte tlačítko Aktualizovat vazbu.

    • Chcete-li aktualizovat pouze jednu vazbu na grafiku, která se zobrazuje v několika místech v dokumentu, vyberte pouze podvazbu a zvolte Aktualizovat vazbu. Pokud vyberete „nadřazenou“ vazbu, můžete aktualizovat všechny vazby na změněnou grafiku.

  1. Vyberte vazbu v panelu Vazby a klikněte na tlačítko Změnit vazbu nebo zvolte Změnit vazbu z nabídky panelu Vazby. Pokud je vybrána „nadřazená“ vazba více instancí, zvolte Změnit vazbu pro všechny výskyty [Název souboru] z nabídky panelu Vazby.

    Funkce obnovení vazby není dostupná ve spravovaném článku, pokud článek není vyhrazený.

  2. V dialogovém okně, které se zobrazí, zvolte Hledat chybějící vazby v této složce, pokud chcete, aby aplikace InDesign vyhledala ve složce soubory, které mají stejný název jako ostatní chybějící připojené soubory. Pokud tato volba není vybrána, bude změněna vazba pouze vybraného obrázku.
  3. Zapnutá volba Zobrazit volby importu umožňuje řídit způsob importu nového zdrojového souboru.
  4. Najděte nový zdrojový soubor a dvojitě klikněte na něj.
  5. Zvolte volby importu, pokud jste zaškrtli Zobrazit volby importu. (Viz Volby importu pro grafiky.)
  1. Chcete-li obnovit chybějící vazbu, vyberte vazbu označenou ikonou chybějící vazby v panelu Vazby a klikněte na tlačítko Změnit vazbu .
  2. V dialogovém okně, které se zobrazí, zvolte Hledat chybějící vazby v této složce, pokud chcete, aby se změnily vazby chybějících souborů v dané složce. Vyhledejte soubor a dvojitě klikněte na něj.

Aplikace InDesign standardně kontroluje chybějící vazby a pokouší se je při otevření dokumentu vyřešit. Dvě možnosti předvoleb umožňují aplikaci InDesign kontrolovat a vyhledávat chybějící vazby automaticky při otevření dokumentu.

Překontrolovat vazby před otevřením dokumentu

Pokud tuto volbu vypnete, aplikace InDesign otevře okamžitě dokument a stav vazeb zůstane nevyřešený, dokud nebude zjištěno, zda jsou vazby aktuální, chybějící nebo změněné. Pokud zapnete tuto možnost, aplikace InDesign bude zjišťovat změněné nebo chybějící vazby.

Najít chybějící vazby před otevřením dokumentu

Pokud tuto volbu vypnete, aplikace InDesign se nepokusí vyřešit chybějící vazby. Tuto volbu je vhodné vypnout, pokud vazby snižují výkon spojení se serverem nebo v případě výskytu neočekávaných vazeb. Tato volba není k dispozici, pokud je vypnuta volba Překontrolovat vazby před otevřením dokumentu.

Hledat chybějící vazby

Příkaz Hledat chybějící vazby použijte k vyhledání a vyřešení chybějících vazeb v dokumentu. Tento příkaz je užitečný, pokud jste v nastavení vypnuli možnost Najít chybějící vazby před otevřením dokumentu a nyní máte chybějící vazby. Tento příkaz je také užitečný, pokud připojujete server, na kterém se ukládají obrázky po otevření dokumentu.

  • Chcete-li změnit nastavení vazeb, otevřete část Zpracování souborů v dialogovém okně Předvolby, kde můžete zapnout možnost Překontrolovat vazby před otevřením dokumentu a Najít chybějící vazby před otevřením dokumentu.
  • Pokud chcete, aby aplikace InDesign vyřešila chybějící vazby, zvolte v nabídce panelu Vazby příkaz Pomůcky > Hledat chybějící vazby.

    Tento příkaz je nedostupný, pokud dokument neobsahuje chybějící vazby.

  1. V dialogu Předvolby zvolte Zpracování souborů.
  2. Z nabídky Výchozí složka pro obnovu vazby zvolte libovolnou z následujících voleb a pak klikněte na OK:

    Poslední složka pro obnovu vazby

    Tato volba zobrazí poslední použitou složku vybranou při obnově vazby, která odpovídá chování aplikace InDesign CS3.

    Původní složka vazeb

    Tato volba zobrazí původní umístění připojeného souboru, který odpovídá chování aplikace InDesign verze CS2 a starší.

Použijte příkaz Kopírovat vazby do k zkopírování souborů grafiky do jiné složky a přesměrování vazeb na zkopírované soubory. Tento příkaz je zejména užitečný pro přesun souborů do jiné jednotky, například při přesunu souborů z disku DVD na pevný disk.

  1. Vyberte vazby na soubory, které chcete kopírovat a z nabídky panelu Vazby zvolte Pomůcky > Kopírovat vazby do.
  2. Určete složku, do které se zkopírují připojené soubory, a klikněte na Vybrat.

Pokud použijete příkaz Znovu navázat na složku, můžete nastavit vazbu na složku, která obsahuje soubory se stejnými názvy jako mají neaktuální vazby. Například pokud stávající vazby odkazují na obrázky v nízkém rozlišení, můžete určit odlišnou složku, která obsahuje obrázky ve vysokém rozlišení. Můžete určit odlišnou příponu souborů: můžete například změnit příponu připojených souborů z .jpg na .tiff.

Příkaz Znovu navázat na složku není dostupný ve spravovaném článku InCopy, pokud článek není vyhrazený.

  1. V panelu Vazby vyberte jednu nebo více vazeb.
  2. V nabídce panelu Vazby zvolte Znovu navázat na složku.
  3. Vyberte umístění nové složky.
  4. Chcete-li použít odlišnou příponu, zvolte Sjednotit stejné názvy souborů až na tuto koncovku a zadejte novou příponu (například AI, TIFF nebo PSD).
  5. Klikněte na Vybrat.

Příkaz Změnit vazbu přípony souboru umožňuje umístit obrazy na základě přípon souboru. Máte-li například v dokumentu různé obrazy JPEG, můžete je nahradit soubory PSD. Soubory s jinými příponami musí být ve stejné složce jako nahrazované soubory s vazbou.

  1. Zkontrolujte, zda se soubory s jinými příponami souboru zobrazují ve stejné složce jako původní soubory.
  2. V panelu Vazby vyberte jednu nebo více vazeb.
  3. V nabídce panelu Vazby zvolte Změnit příponu souboru vazby.
  4. Určete, které přípony souboru mají nahradit vybrané soubory a klikněte na možnost Změnit vazbu.

Nahrazení importovaného souboru pomocí příkazu Umístit

  1. Proveďte jeden z následujících úkonů:
    • Chcete-li nahradit obsah grafického rámečku, například importovanou grafiku, vyberte rámeček nástrojem pro výběr .

      Chcete-li nahradit obsah grafického rámečku, například importovanou grafiku, vyberte rámeček nástrojem poloha.

    • Chcete-li nahradit obsah textového rámečku, klikněte textovým nástrojem do textového rámečku, aby se zobrazil textový kurzor, a zvolte Úpravy > Vybrat vše.

  2. Zvolte Soubor > Umístit.
  3. Najděte a vyberte nový soubor.
  4. Zkontrolujte, že je vybraná volba Nahradit vybranou položku, a pak klikněte na Otevřít.
  5. Klikněte na Otevřít.

Můžete kopírovat celou cestu připojeného obrázku nebo cestu ve stylu platformy. Kopírování celé cesty k obrázku je užitečné, pokud chcete oznámit členům týmu, kde se obrázek nachází. Například můžete zkopírovat úplnou cestu a vložit ji do e-mailové zprávy. Kopírování cesty v rámci platformy je užitečné pro skriptování nebo pro určení polí obrázků při sloučení dat.

  1. Vyberte vazbu v panelu Vazby.
  2. Z nabídky panelu Vazby vyberte možnost Kopírovat informace > Kopírovat celou cestu nebo Kopírovat cestu stylu platformy.
  3. Vložte cestu.

Úpravy původní kresby

Pomocí příkazu Upravit originál můžete otevřít většinu grafik v aplikaci, ve které jste je vytvořili, takže je pak můžete podle potřeby upravit. Jakmile uložíte původní soubor, dokument, ve kterém je tento soubor připojený, se aktualizuje s použitím nové verze.

Poznámka:

Pokud si v InDesignu vyhradíte a vyberete rámeček spravované grafiky (takový, který byl exportován do InCopy) místo výběru samotné grafiky, tato grafika se otevře v InCopy.

Úpravy původní kresby pomocí výchozí aplikace

Aplikace InDesign standardně volí aplikaci, která se použije k otevření souboru, dle informací operačního systému.

  1. Na stránce nebo v panelu Vazby zvolte jeden nebo více obrazů.
  2. Proveďte libovolný z následujících úkonů:
    • V panelu Vazby klikněte na tlačítko Upravit originál .

    • Vyberte Úpravy > Upravit originál.

  3. Po provedení změn v původní aplikaci soubor uložte.

Úpravy původní kresby pomocí jiné aplikace

  1. Vyberte obraz.
  2. Zvolte Úpravy > Upravit v a určete aplikaci, kterou chcete použít k otevření souboru. Pokud se aplikace nezobrazí, zvolte Jiné a vyhledejte aplikaci.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online