Kun haluat luoda Flash Playerillä toistettavaa diaesitys-tyyppistä sisältöä, voit viedä sen joko SWF- tai FLA-muotoon. Suurin ero on siinä, että SWF-tiedostot ovat valmiita katseltaviksi eikä niitä voi muokata siinä missä FLA-tiedostoja täytyy muokata Adobe Flash Professionalissa, jotta niitä voi katsella Adobe Flash Playerissä.

SWF

Viety SWF-tiedosto on valmis katseltavaksi Adobe Flash Playerissä, ja se saattaa sisältää vuorovaikutteisia elementtejä, kuten sivusiirtymiä, hyperlinkkejä, elokuvia, äänitiedostoja, animaatioita ja navigointipainikkeita.

FLA

Viety FLA-tiedosto sisältää vain muutamia vuorovaikutteisia elementtejä. FLA-tiedosto voidaan avata Flash Prossa, missä Flash-kehittäjä voi lisätä edistyneitä tehosteita, ennen kuin tiedosto viedään SWF-muotoon.

Vieminen Flash-muotoon
Vieminen Flash-muotoon

A. Vieminen suoraan SWF-muotoon B. Vieminen FLA-muodossa muokattavaksi Flash Professionalissa 

Luo vuorovaikutteisia SWF (Flash) -tiedostoja web-käyttöön

Kun viet SWF-muodossa, luot vuorovaikutteisen tiedoston, jota voit katsella Adobe Flash Playerissä tai web-selaimessa. SWF-tiedosto saattaa sisältää InDesignissa lisättyjä painikkeita, sivusiirtymiä, elokuva- ja äänitiedostoja, animaatioita ja hyperlinkkejä. SWF-muodossa vieminen on hyvä tapa luoda InDesign-julkaisuun perustuva vuorovaikutteinen diaesitys tai animaatio.

jos haluat muokata julkaisua Flash Prossa, ennen kuin luot SWF-tiedoston, vie se FLA-muodossa SWF:n sijasta. Lisätietoja: Luo FLA-tiedostoja web-käyttöön.

SWF-vienti
SWF-vienti

A. Julkaisu InDesignissa ennen SWF-vientiä B. Vuorovaikutteinen SWF-tiedosto Web-selaimessa 
  1. Luo tai muokkaa InDesign-julkaisua valmistellaksesi sen Flash-vientiä varten. Yksityiskohtaisia lisätietoja julkaisun valmistelusta vientiä varten on osoitteessa Flash-viennin ongelmat.

    • Lisää navigointipainikkeet, joilla käyttäjät voivat siirtyä sivulta toiselle viedyssä SWF-tiedostossa. Voit luoda painikkeet piirtämällä objektin ja muuntamalla sen painikkeeksi Painikkeet-paneelissa (valitse Ikkuna > Vuorovaikutteinen > Painikkeet). Voit myös käyttää Näytepainikkeet-paneelia ja vetää esimääritettyjä navigointipainikkeita julkaisuun. Katso Painikkeiden luominen.

    • Sivun siirtymät -paneelista (valitse Ikkuna > Vuorovaikutteinen > Sivusiirtymät) voit lisätä sivusiirtymiä, kuten pyyhkäisyjä ja ristikuvia. Kun viet SWF-muodossa voit myös valita Sisällytä interaktiivinen sivun kääntö -asetuksen, jolla katselijat voivat voivat kääntää sivua vetämällä sivun kulmasta.

    • Animaatio-paneelista (valitse Ikkuna > Vuorovaikutteinen > Animaatio) voit lisätä liikkeen esimäärityksiä. Katso Animaatio.

  2. Vie julkaisu SWF-muodossa valitsemalla Tiedosto > Vie

  3. Valitse Käytä InDesign-dokumentin nimeä tulostustiedoston nimenä, jos haluat antaa viedylle tiedostolle saman nimen kuin seuraavan viennin dokumentille.

  4. Valitse Tallennusmuoto-luettelosta (Windows) tai Muoto-luettelosta (Mac OS) Flash Player (SWF) ja napsauta Tallenna-painiketta.

  5. Määritä Vie SWF -valintaikkunassa seuraavat asetukset ja valitse sitten OK. Katso SWF-vientiasetukset.

Kun viet SWF-tiedoston, luodaan erilliset HTML- ja SWF-tiedostot. Jos SWF-tiedostossa on videota tai äänileikkeitä, luodaan myös Resurssit-kansio. Kun siirrät tai lataat tiedostoja Internetiin, muista siirtää kaikki materiaali.

SWF-vientiasetukset

SWF-vientiasetukset-valintaikkunan Yleiset- ja Lisäasetukset-välilehdillä on seuraavat asetukset.

Vie

Ilmaisee, viedäänkö valinta, kaikki julkaisun sivut vai sivualue. Valinta on erityisen kätevä, jos haluat tallentaa viedyn SWF-tiedoston käytettäväksi viedyssä PDF-tiedostossa. Jos valitset Alueen, määritä sivualue kuten 1-7, 9, jos haluat tulostaa sivut yhdestä seitsemään ja sivun yhdeksän. Lisätietoja: Tulostettavien sivujen määrittäminen.

Luo HTML-tiedosto

Valitse tämä asetus, kun haluat luoda SWF-tiedoston toistavan HTML-sivun. Tätä asetusta kannattaa käyttää erityisesti silloin, kun on tarpeen nopeasti esikatsella SWF-tiedosto Web-selaimessa.

Näytä SWF viennin jälkeen

Valitse tämä asetus, kun haluat toistaa SWF-tiedoston Web-oletusselaimessa. Tämä asetus on käytettävissä vain, jos luot HTML-tiedoston.

Koko (pikseleinä)

Määritä, skaalataanko SWF-tiedosto prosenttiosuuden mukaan, sovitetaanko se määritettyyn näytön kokoon vai määritetäänkö sille leveys- ja korkeusarvo.

Tausta

Määritä onko SWF:n tausta läpinäkyvä vai käyttääkö se Värimallit-paneelissa valittuna olevaa paperin väriä. Jos valitset Läpinäkyvän, sivusiirtymät ja interaktiivinen sivun kääntö -asetukset eivät ole käytettävissä.

Vuorovaikutteisuus ja väline

Jos haluat sallia vuorovaikutteiset elokuvat, äänet, painikkeet ja animaatiot viedyssä SWF-tiedostossa, valitse Sisällytä kaikki. Jos haluat sisällyttää painikkeiden normaalitilan ja elokuvien julistekuvat pysyvinä elementteinä, valitse Vain ulkoasu. Jos Vain ulkoasu on valittuna, animaatiot viedään sellaisina, kuin ne näkyvät asettelussa viennin aikana. Vain ulkoasu on valittuna, jos valitset Lisäasetukset-paneelista Yhdistä läpinäkyvyys -asetuksen.

Sivun siirtymät

Määritä jokin sivusiirtymä, jota käytetään kaikissa sivuissa viennin aikana. Jos määrität siirtymät Sivun siirtymät -paneelista, käytä kyseisiä asetuksia valitsemalla Julkaisusta-vaihtoehdon.

Sisällytä interaktiivinen sivun kääntö

Jos tämä asetus on valittu, käyttäjät voivat SWF-tiedostoa toistaessaan kääntää sivua vetämällä sivun kulmaa. Tämä toiminto näyttää aivan oikean kirjan sivun kääntämiseltä.

Kuvataajuus

Korkeampi kuvataajuus luo tasaisemman animaation, mutta saattaa kasvattaa tiedoston kokoa. Kuvataajuuden muuttaminen ei vaikuta toiston kestoon.

Teksti

Määritä, miten InDesign-teksti tuotetaan. Valitse Flash Classic -teksti, jos haluat luoda haettavaa tekstiä, joka tuottaa pienikokoisen tiedoston. Valitse Muunna ääriviivoiksi, jos haluat muuntaa tekstin tasoitettujen suorien viivojen sarjaksi, aivan kuten muunnettaessa tekstiä ääriviivoiksi. Valitse Muunna pikseleiksi, jos haluat muuntaa tekstin bittikarttakuvaksi. Pikseleiksi muunnettu teksti saattaa näyttää rosoiselta zoomattaessa.

Rasteroi sivut

Tämä asetus muuntaa InDesign-sivun kaikki objektit bittikartaksi. Jos valitset tämän asetuksen, SWF-tiedoston koko kasvaa ja sivun objektit näkyvät rosoisina zoomattaessa lähemmäksi.

Yhdistä läpinäkyvyys

Tämä asetus poistaa läpinäkyvyyden SWF-tiedostosta, mutta säilyttää läpinäkyvän ulkoasun. Kaikki vuorovaikutteisuus kuitenkin poistetaan viedystä SWF-tiedostosta, jos tämä asetus on valittuna.

Pakkaus

Jos valitset Automaattinen-asetuksen, InDesign määrittää väri- ja harmaasävykuvien parhaan laadun. Useimmilla tiedostoilla tämä asetus tuottaa tyydyttävän tuloksen. JPEG (häviöllinen) sopii harmaasävy- ja värikuville. JPEG-pakkaus on häviöllinen eli se poistaa kuvatietoja ja voi heikentää kuvalaatua. Se kuitenkin pyrkii pienentämään tiedoston kokoa ja minimoimaan tietojen häviämisen. Koska JPEG-pakkaus poistaa tietoja, tiedosto pakkautuu huomattavasti pienemmäksi. Valitse PNG (häviötön), jos haluat viedä tiedoston ilman häviöllistä pakkausta.

Huomautus:

Jos havaitset läpinäkyvien kuvien laadun heikkenemistä vietäessä SWF-muotoon, paranna laatua valitsemalla pakkaustavaksi PNG (häviötön).

JPEG-laatu

Määrittää viedyn kuvan yksityiskohtien määrän. Mitä korkeampi laatu, sitä suurempi tiedosto. Tämä asetus on himmennetty, jos pakkaustavaksi on valittu PNG (häviötön).

Resoluutio

Määritä bittikarttakuvien resoluutio viedyssä SWF-tiedostossa. Korkean resoluution valinta on erityisen tärkeää, jos haluat antaa katsojien zoomata pikselipohjaista sisältöä viedyssä SWF-tiedostossa. Korkean resoluution valita voi kasvattaa merkittävästi tiedoston kokoa.

Luo FLA-tiedostoja web-käyttöön

Kun viet InDesign-julkaisun FLA-tiedostomuotoon, voit avata tiedoston Adobe Flash® CS5 Professionalissa ja muokata sen sisältöä. FLA-vienti InDesign CS5 -muodossa korvaa XFL-viennin InDesign CS4:ssä. Voit käyttää Flash-muokkausympäristöä videon, äänen, animaation ja monimutkaisten vuorovaikutteisuusominaisuuksien lisäämiseen tai muokkaamiseen.

Jos haluat viedä InDesign-julkaisun suoraan sellaiseen muotoon, joka voidaan avata suoraan web-selaimessa, käytä SWF-muotoa FLA:n sijasta. Lisätietoja: Luo vuorovaikutteisia SWF (Flash) -tiedostoja web-käyttöön.

FLA-vienti
FLA-vienti

A. Julkaisu InDesignissa ennen FLA-vientiä B. Flash Prolla avattu FLA-tiedosto 
  1. Luo tai muokkaa InDesign-julkaisua valmistellaksesi sen Flash-vientiä varten. Yksityiskohtaisia lisätietoja julkaisun valmistelusta vientiä varten on osoitteessa Flash-viennin ongelmat.

  2. Vie julkaisu FLA-muodossa valitsemalla Tiedosto > Vie. Valitse Tallennusmuoto-luettelosta (Windows) tai Muoto-luettelosta (Mac OS), Flash CS5 Professional (FLA) ja napsauta Tallenna-painiketta.

  3. Määritä seuraavat asetukset Vie Flash CS5 Professional (FLA) -tiedostoon -valintaikkunassa ja valitse sitten OK. Jos haluat lisätietoja vientiasetuksista, katso FLA-viennin asetukset.

  4. Avaa viety FLA-tiedosto Flash Professionalissa.

FLA-vientiasetukset

Vie Flash CS5 Professional (FLA) -tiedostoon -valintaikkunassa on seuraavat asetukset.

Vie

Ilmaisee, viedäänkö valinta, kaikki julkaisun sivut vai sivualue. Jos valitset Alueen, määritä sivualue kuten 1-7, 9, jos haluat tulostaa sivut yhdestä seitsemään ja sivun yhdeksän. Lisätietoja: Tulostettavien sivujen määrittäminen.

Rasteroi sivut

Tämä asetus muuntaa InDesign-sivun kaikki objektit bittikartaksi. Jos valitset tämän asetuksen, FLA-tiedoston koko kasvaa ja sivun objektit voivat näkyä rosoisina zoomattaessa lähemmäksi.

Yhdistä läpinäkyvyys

Jos valitset tämän asetuksen, kaikki objektit yhdistetään ja käytetään läpinäkyvyyttä. Yhdistettyjen objektien animointi voi olla vaikeaa Adobe Flash Prossa.

Koko (pikseleinä)

Määritä, skaalataanko FLA-tiedosto prosenttiosuuden mukaan, sovitetaanko se määritettyyn näytön kokoon vai määritetäänkö sille leveys- ja korkeusarvo.

Vuorovaikutteisuus ja väline

Jos haluat sallia elokuvien, äänien, painikkeiden ja animaatioiden sisällyttämisen vietyyn FLA-tiedostoon, valitse Sisällytä kaikki. Jos julkaisu sisältää useissa tiloissa olevan objektin, se muunnetaan elokuvasymboliksi, jossa jokainen tila näkyy omana kehyksenä aikajanalla.

Jos haluat sisällyttää painikkeiden normaalitilan ja elokuvien julistekuvat pysyvinä elementteinä, valitse Vain ulkoasu. Jos Vain ulkoasu on valittuna, animaatiot viedään sellaisina, kuin ne näkyvät asettelussa viennin aikana. Vain ulkoasu on valittuna, jos valitset Yhdistä läpinäkyvyys -asetuksen.

Teksti

Määritä, miten InDesign-teksti tuotetaan. Valitse Flash TLF -teksti, jos haluat käyttää Flash Professionalin laajaa tekstiasettelun määrevalikoimaa. Jos tämä asetus on valittu, ota tavutus käyttöön valitsemalla Lisää tavutusvihjepisteet. Valitse Flash Classic -teksti, jos haluat luoda haettavaa tekstiä, joka tuottaa pienikokoisen tiedoston. Valitse Muunna ääriviivoiksi, jos haluat muuntaa tekstin tasoitettujen suorien viivojen sarjaksi, aivan kuten muunnettaessa tekstiä ääriviivoiksi. Valitse Muunna pikseleiksi, jos haluat muuntaa tekstin bittikarttakuvaksi. Pikseleiksi muunnettu teksti saattaa näyttää rosoiselta zoomattaessa.

Pakkaus

Jos valitset Automaattinen-asetuksen, InDesign määrittää väri- ja harmaasävykuvien parhaan laadun. Useimmilla tiedostoilla tämä asetus tuottaa tyydyttävän tuloksen. JPEG (häviöllinen) sopii harmaasävy- ja värikuville. JPEG-pakkaus on häviöllinen eli se poistaa kuvatietoja ja voi heikentää kuvalaatua. Se kuitenkin pyrkii pienentämään tiedoston kokoa ja minimoimaan tietojen häviämisen. Koska JPEG-pakkaus poistaa tietoja, tiedosto pakkautuu huomattavasti pienemmäksi. Valitse PNG (häviötön), jos haluat viedä tiedoston ilman häviöllistä pakkausta.

JPEG-laatu

Määrittää viedyn kuvan yksityiskohtien määrän. Mitä korkeampi laatu, sitä suurempi tiedosto. Tämä asetus on himmennetty, jos pakkaustavaksi on valittu PNG (häviötön).

Resoluutio

Määritä bittikarttakuvien resoluutio viedyssä FLA-tiedostossa. Korkean resoluution valinta on erityisen tärkeää, jos haluat antaa katsojien zoomata pikselipohjaista sisältöä. Korkean resoluution valita voi kasvattaa merkittävästi tiedoston kokoa.

Flash-viennin ongelmat

Ota huomioon seuraavat asiat, kun suunnittelet InDesign-julkaisua SWF- tai FLA-tulostusta varten.

Julkaisun asetukset

InDesign-sivujen muunnos

Kun viet julkaisun SWF- tai FLA-muotoon, InDesign-aukeamat muunnetaan aikajanan erillisiksi leikkeiksi. Ne muistuttavat diaesityksen dioja. Kukin aukeama osoittaa uuteen avainkuvaan. Voit Flash Playerissä siirtyä viedyn julkaisun aukeamalta toiselle painamalla nuolinäppäimiä tai napsauttamalla vuorovaikutteisia painikkeita.

Huomautus:

Kun luot web-käyttöön tarkoitetun julkaisun, valitse Uusi julkaisu -valintaikkunan Peruste-valikosta Web.

Sivukoko

Kun luot uuden julkaisun, voit Uusi julkaisu -valintaikkunan Sivukoko-valikosta valita haluamasi resoluution, kuten 800 x 600. Voit viennin aikana säätää SWF- tai FLA-tiedoston skaalausta tai resoluutiota.

Vuorovaikutteisuusominaisuudet

Viedyt SWF- ja FLA-tiedostot saattavat sisältää painikkeita, sivusiirtymiä, hyperlinkkejä, animaatioita ja mediatiedostoja.

Painikkeet

Kun katselet vietyä SWF- tai FLA-tiedostoa Flash Playerillä, voit Seuraava sivu- ja Edellinen sivu -toimintojen avulla toistaa tiedoston sisältöä. Ota huomioon, että osa vuorovaikutteisissa PDF-tiedostoissa toimivista toiminnoista ei näy Flash Playerissä. Kun valitset toimintoa Painikkeet-paneelista, älä valitse asetusta Vain PDF -osiosta.

Huomautus:

Voit lisätä navigointipainikkeita, joille on esimääritetty Siirry seuraavalle sivulle- tai Siirry edelliselle sivulle -toiminto. Valitse Painikkeet-paneelivalikosta Näytepainikkeet. Katso Painikkeen lisääminen Näytepainikkeet-paneelista.

Sivun siirtymät

Kaikki sivun siirtymät toimivat oikein Flash Playerissä. Sivun siirtymät näkyvät, kun käännät sivua. Näiden siirtymien lisäksi voit sisällyttää vientiin vuorovaikutteisen sivunkäännön. Tällöin voit kääntää sivua vetämällä sivun kulmaa.

Hyperlinkit

Luo linkkejä Web-sivustoihin tai julkaisun toisille sivuille. Hyperlinkit eivät toimi FLA-tiedostoissa.

Elokuvat ja äänileikkeet

Elokuvat ja äänileikkeet sisällytetään vietyyn SWF-tiedostoon, jos ne ovat tuetussa muodossa, kuten SWF, FLV, F4V ja MP4 elokuville ja MP3 äänileikkeille.

Kun viet FLA-muodossa, vain julistekuva sisällytetään FLA-tiedostoon. Tuetut mediatiedostot näkyvät resurssikansiossa, joka on tallennettu samaan kansioon kuin viety FLA-tiedosto.

Muunto-ongelmat

Väri

SWF- ja FLA-tiedostot käyttävät RGB-värejä. Kun julkaisu viedään SWF- tai FLA-muotoon, InDesign muuntaa kaikki väriavaruudet (esim. CMYK ja Lab) sRGB-väriavaruuksiksi. InDesign muuntaa spottivärit vastaaviksi RGB-prosessiväreiksi.

Voit välttää ei-toivotut värinmuutokset läpinäkyvää tekstiä sisältävissä kuvissa valitsemalla Muokkaa > Läpinäkyvyyden sekoitustila > RGB-julkaisu. Jos haluat välttää ei-toivotut värinmuutokset läpinäkyvyyttä käyttävissä kuvissa, vältä häviöllisen pakkauksen käyttöä viennissä.

Teksti

Kun viet SWF- tai FLA-muodossa, voit määrittää tulostetaanko teksti Flash-tekstinä vain muunnetaanko se ääriviivoiksi tai pikseleiksi. Flash-tekstinä vietyä tekstiä voi muokata, kun FLA-tiedosto avataan Adobe Flash CS5 Professionalissa. Kun tällainen teksti tallennetaan SWF-tiedostoon, tekstiä voidaan hakea Web-selaimissa.

Kuvat

Kun viet kuvia SWF- tai FLA-muotoon, voit muuttaa kuvan pakkauksen, JPEG-laadun ja käyrän laadun asetuksia viennin aikana.

Kun viet kuvia FLA-muotoon, InDesign-julkaisuun useita kertoja sijoitettu kuva tallennetaan yhtenä kuvatiedostona, jolla on jaettu sijainti. Huomaa, että jos InDesign-julkaisussa on runsaasti vektorikuvia, saatat havaita suorituskykyongelmia viedyssä tiedostossa.

Voit pienentää tiedoston kokoa sijoittamalla toistuvat kuvat sivupohjaan. Tällöin kuvia ei tarvitse kopioida ja liittää. Jos sama kuva sijoitetaan julkaisuun useita kertoja eikä kuvaa muunneta tai rajata, vain yksi tiedoston kopio viedään FLA-tiedostoon. Kopioituja ja liitettyjä kuvia käsitellään erillisinä objekteina.

Oletusarvon mukaan sijoitettua Illustrator-tiedostoa käsitellään yksittäisenä kuvana FLA-tiedostossa, kun taas kopioitu ja liitetty Illustrator-tiedosto luo useita yksittäisiä objekteja. Saat aikaan parhaan tuloksen, kun sijoitat Illustrator-kuvan PDF-tiedostona sen sijaan, että kopioisit ja liittäisit sen Illustratorista. Kuvien kopioiminen ja liittäminen tuottaa useita muokattavia polkuja.

Huomautus:

Voit asetuksia muuttamalla varmistaa, että Illustrator-objektit liitetään yhtenä objektina eikä pienten vektorien kokoelmana. Valitse Illustratorin tiedoston käsittelyn ja leikepöydän asetuksista PDF ja poista AICB:n valinta (ei läpinäkyvyyden tukea). Valitse InDesignin Leikepöydän käsittely -asetuksista sekä Käytä sijoitettaessa ensisijaisesti PDF-muotoa että Kopioi PDF leikepöydälle.

Läpinäkyvyys

Ennen kuin viet julkaisun SWF-muotoon, varmista, että läpinäkyvät objektit eivät ole painikkeiden, hyperlinkkien tai muiden vuorovaikutteisten elementtien päällä. Jos läpinäkyvyyttä käyttävä objekti on päällekkäin vuorovaikutteisen elementin kanssa, vuorovaikutteisuus voi kadota viennin aikana. Läpinäkyvyys kannattaa ehkä yhdistää, ennen kuin julkaisu viedään FLA-muotoon.

Joissakin tapauksissa häviöllisen pakkauksen valinta heikentää läpinäkyvyyttä käyttävien kuvien laatua. Jos haluat parantaa laatua, valitse vientiin PNG (häviötön).

3D-määritteet

3D-määritteitä ei tueta viedyissä SWF- ja FLA-tiedostoissa.

Lisensoitu Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License -lisenssin mukaan.  Creative Commons -lisenssien ehdot eivät koske Twitter™- ja Facebook-viestejä.

Lakisääteiset ilmoitukset   |   Online-tietosuojakäytäntö