Knapper

  1. Brukerhåndbok for InDesign
  2. Bli kjent med InDesign
    1. Innføring i InDesign
      1. Nyheter i InDesign
      2. Systemkrav
      3. Vanlige spørsmål
      4. Bruke Creative Cloud Libraries
    2. Arbeidsområde
      1. Grunnleggende om arbeidsområdet
      2. Verktøykassen
      3. Angi innstillinger
      4. Berøringsbasert arbeidsområde
      5. Standard tastatursnarveier
      6. Gjenoppretting og angring for dokumenter
  3. Opprette og sette opp dokumenter
    1. Dokumenter og sider
      1. Opprette dokumenter
      2. Jobbe med malsider
      3. Arbeide med dokumentsider
      4. Angi sidestørrelse, marger og utfallende
      5. Arbeide med filer og maler
      6. Opprette bokfiler
      7. Legge til enkel sidenummerering
      8. Nummerere sider, kapitler og seksjoner
      9. Konvertere QuarkXPress- og PageMaker-dokumenter
      10. Dele innhold
      11. Forstå en grunnleggende arbeidsflyt for styrte filer
      12. Lagre dokumenter
    2. Rutenett
      1. Rutenett
      2. Formatere rutenett
    3. Layouthjelpemidler
      1. Linjaler
  4. Legge til innhold
    1. Tekst
      1. Legge til tekst i rammer
      2. Koble tekst
      3. Arabiske og hebraiske funksjoner i InDesign
      4. Opprette tekst langs en bane
      5. Punktmerking og nummerering
      6. Tegnvarianter og spesialtegn
      7. Tekstjustering
      8. Tekstvariabler
      9. Generere QR-koder
      10. Redigere tekst
      11. Justere tekst
      12. Tekstflyt rundt objekter
      13. Forankrede objekter
      14. Tilknyttet innhold
      15. Formatere avsnitt
      16. Formatere tegn
      17. Finn/endre
      18. Stavekontroll og ordlister
    2. Typografi
      1. Bruke skrifter i InDesign
      2. Utligning og tegnavstand
    3. Formatere tekst
      1. Formatere tekst
      2. Tabulatorer og innrykk
    4. Gjennomgå tekst
      1. Spore og gjennomgå endringer
      2. Legge til redigeringsmerknader i InDesign
      3. Importere PDF-kommentarer
    5. Legge til referanser
      1. Opprette en innholdsfortegnelse
      2. Fotnoter
      3. Opprette et stikkordregister
      4. Sluttnoter
      5. Bildetekster
    6. Stiler
      1. Avsnitts- og tegnstiler
      2. Objektmaler
      3. Initialer og kjedede maler
      4. Arbeide med maler
      5. Linjeavstand
    7. Tabeller
      1. Formatere tabeller
      2. Opprette tabeller
      3. Tabell- og cellemaler
      4. Velge og redigere tabeller
      5. Streker og fyll i tabeller
    8. Interaktivitet
      1. Hyperkoblinger
      2. Dynamiske PDF-dokumenter
      3. Bokmerker
      4. Knapper
      5. Skjemaer
      6. Animasjon
      7. Kryssreferanser
      8. Strukturere PDF-dokumenter
      9. Sideoverganger
      10. Filmer og lyder
      11. Skjemaer
    9. Grafikk
      1. Forstå baner og former
      2. Tegne med blyantverktøyet
      3. Tegne med pennverktøyet
      4. Bruke innstillinger for linjer (streker) 
      5. Sammensatte baner og former
      6. Redigere baner
      7. Beskjæringsbaner
      8. Endre utseende på hjørner
      9. Justere og fordele objekter
      10. Koblet og innebygd grafikk
      11. Integrere AEM Assets
    10. Farge og gjennomsiktighet
      1. Bruke farger
      2. Bruke farger fra importert grafikk
      3. Arbeide med fargekart
      4. Blande trykkfarger
      5. Nyanser
      6. Forstå spotfarger og prosessfarger
      7. Blande farger
      8. Forløpninger
      9. Slå sammen gjennomsiktig grafikk
      10. Legge til effekter for gjennomsiktighet
  5. Deling med andre
    1. Dele og samarbeide        
    2. Dele for gjennomgang
    3. Gå gjennom et delt InDesign-dokument
    4. Administrere tilbakemeldinger 
  6. Publisere
    1. Eksportere og publisere
      1. Publish Online
      2. Eksportere innhold for EPUB
      3. Adobe PDF-valg
      4. Eksportere innhold til HTML
      5. Eksportere til Adobe PDF
      6. Eksportere til JPEG-format
      7. Eksportere HTML
      8. Oversikt over DPS og AEM Mobile
    2. Skrive ut
      1. Skrive ut hefter
      2. Merker og utfallende
      3. Skrive ut dokumenter
      4. Trykkfarger, separasjon og rasterfrekvens
      5. Overtrykk
      6. Opprette PostScript- og EPS-filer
      7. Forhåndskontrollere filer før levering
      8. Skrive ut miniatyrer og dokumenter som er for store
      9. Forberede PDF-filer for trykkerier
      10. Forberede utskrift av separasjoner
  7. Utvide InDesign
    1. Automatisering
      1. Fletting
      2. Plugin-moduler
      3. Skript
Merk:

Fra og med InDesign versjon 15.0 er Flash-filformater (FLV, F4V og SWF) ikke lenger tilgjengelige. Alle alternativer knyttet til disse formatene, er fjernet fra de respektive panelene. Hvis du vil ha mer informasjon, kan du se Flash Player når livssyklusslutt | Innvirkning på InDesign.

Opprette knapper

Du kan opprette knapper som utfører en handling når dokumentet eksporteres til EPUB for fast layout, PDF- eller SWF-format. Du kan for eksempel opprette en knapp som går til en annen side eller åpner et Internett-område.

Knapp definert til å spille av film i et eksportert PDF-dokument

Når du har opprettet en knapp, kan du gjøre følgende:

Merk:

Velg arbeidsområdet Interaktiv for PDF når du arbeider med knapper og utformer dynamiske dokumenter.

Opprette en knapp

  1. Bruk pennverktøyet eller et tegneverktøy, for eksempel rektangel- eller ellipseverktøyet, til å tegne knappeformen. Om nødvendig kan du bruke tekstverktøyet til å legge til tekst på knappen, for eksempel Neste eller Kjøp.
    Merk:

    Når du skal opprette navigasjonsknapper (for eksempel Neste side eller Forrige side) som vises på flere sider, legger du dem til på en malside slik at du ikke trenger å opprette dem på nytt på hver side i dokumentet. Disse knappene vises på alle dokumentsider som malen brukes på.

  2. Bruk markeringsverktøyet  til å markere bildet, formen eller tekstrammen du vil konvertere.

    Du kan ikke konvertere en film, en lyd eller et plakatbilde til en knapp.

  3. Klikk på Konverter til en knapp-ikonet  i Knapper og skjema-panelet (velg Vindu > Interaktiv > Knapper og skjema). Du kan også velge Objekt > Interaktiv > Konverter til knapp.

    Konverter til knapp

  4. Gjør følgende i Knapper og skjema-panelet:

    • Velg Knappfra Type-rullegardinmenyen.
    • I tekstboksen Navn angir du et navn for knappen for å skille den fra andre knapper du har opprettet.
    • Spesifiser hendelsensom skal utløse ønsket handling.
    • Angi én eller flere handlingerfor knappen for å bestemme hva som skjer når hendelsen utløses i den eksporterte EPUB-, PDF- eller SWF-filen med fast layout. Se Gjøre knapper interaktive.
    • Aktiver flere tilstander og endre utseendetpå dem for å finne ut hvordan knappen ser ut når du holder musen over knappen eller klikker på knappen i den eksporterte EPUB-, PDF- eller SWF-filen med fast layout. Se Endre knappeutseendet for berøring og klikking.
  5. Bruk Forhåndsvisning-panelet (Vindu > Interaktiv > Forhåndsvisning for EPUB-interaktivitet / Forhåndsvisning av SWF) for å teste knappen før du eksporterer dokumentet til EPUB, PDF eller SWF med interaktiv fast layout. Du kan også publisere dokumentet ditt på nettet ved å bruke Publish Online.

Legge til en knapp fra Eksempelknapper-panelet

Eksempelknapper-panelet inneholder en rekke forhåndsopprettede knapper som du kan dra inn i dokumentet. Disse eksempelknappene inkluderer effekter som uttoningsforløpning og skygge, med et litt annerledes utseende for Berøring-utseendet. Eksempelknappene tildeles også handlinger. Eksempelpilknappene er for eksempel forhåndsinnstilt med handlingene Gå til neste side eller Gå til forrige side. Du kan redigere disse knappene etter dine behov.

Eksempelknapper-panelet er et objektbibliotek. I likhet med alle objektbiblioteker kan du legge til knapper i panelet og fjerne de du ikke ønsker å bruke. (Se Bruke objektbiblioteker.) Eksempelknappene arkiveres i ButtonLibrary.indl-filen, som ligger i mappen Presets/Button Library i InDesign-programmappen.

  1. Velg Eksempelknapper og -skjemaer fra Knapper og skjema-panelmenyen for å åpne panelet Eksempelknapper og -skjemaer.

    Åpne panelet Eksempelknapper og -skjemaer

  2. Dra en knapp fra Eksempelknapper og -skjemaer-panelet til dokumentet. Hvis du vil vise navigasjonsknapper på hver side, legger du til knappene på en malside.

    Eksempelknapper og -skjemaer
    Eksempelknapper og -skjemaer-panelet

  3. Velg knappen ved hjelp av markeringsverktøyet, og rediger deretter knappen etter behov ved hjelp av Knapper og skjemaer-panelet.

    Når du redigerer eksempelknapper, bør du tenke på følgende:

    • Hvis du legger til tekst på en knapp, må du huske å kopiere og lime inn teksten fra Normal-knappetilstanden til Berøring-knappetilstanden. Ellers vil ikke teksten du legger til, vises når musen holdes over knappen i EPUB-, PDF- eller SWF-filen med fast layout.

    • Du kan endre størrelsen på knapper. Hvis du drar et par pilknapper for neste side / forrige side, må du endre størrelsen på den første knappen og deretter markere den andre knappen og velge Objekt > Transformer på nytt > Transformer på nytt.

  4. Bruk Forhåndsvisning-panelet (Vindu > Interaktiv > Forhåndsvisning for EPUB-interaktivitet / Forhåndsvisning av SWF) for å teste knappen før du eksporterer dokumentet til EPUB, PDF eller SWF med interaktiv fast layout. Du kan også publisere dokumentet ditt på nettet ved å bruke Publish Online.

Konvertere en knapp til et objekt

Når du konverterer en knapp til et objekt, forblir innholdet i knappen på siden uten knappeegenskapene. Alt innhold som er knyttet til knappens andre tilstander, fjernes også.

  1. Bruk markeringsverktøyet  til å markere knappen.
  2. Velg Objekt > Interaktiv > Konverter til objekt.

Gjøre knapper interaktive

Du kan opprette, redigere og styre interaktive effekter i InDesign. Når dokumentet eksporteres til EPUB, PDF eller SWF med fast layout, kan disse interaktive handlingene være aktive.

Sett at du for eksempel vil opprette en knapp som gjør at en lyd spilles av i et PDF-dokument. Du kan montere lydfilen i et InDesign-dokument og deretter opprette en knapp som får lyden til å bli spilt av når du klikker på knappen i PDF-dokumentet.

I dette eksemplet er museklikkingen hendelsen, og avspilling av lyden er handlingen.

Denne knappen er definert til å spille av en lyd når museknappen klikkes.

Merk:

Noen handlinger støttes både i PDF- og SWF/EPUB-filer, mens andre handlinger bare støttes i PDF- eller SWF/EPUB-filer. Når du velger en handling, må du ikke velge en ren PDF-handling hvis du eksporterer til SWF eller EPUB for fast layout. Unngå også å velge en ren SWF/EPUB-handling hvis du eksporterer til PDF.

Legge til handlinger for knappene

Du kan tilordne handlinger til ulike hendelser. I en eksportert PDF-fil kan du for eksempel angi at det skal spilles av en lyd når musepekeren kommer inn i knappeområdet, og at det skal spilles av en film når museknappen klikkes på og slippes. Du kan også tilordne flere handlinger til samme hendelse. Du kan for eksempel opprette en handling som spiller av en film og setter visningszoomen til Faktisk størrelse.

  1. Bruk markeringsverktøyet  til å markere knappen du opprettet.
  2. I Knapper og skjemaer-panelet velger du en hendelse, for eksempel Ved slipp opp, som avgjør hvordan handlinger aktiveres.

  3. Klikk på plusstegnknappen  ved siden av Handlinger, og velg handlingen du vil tilordne hendelsen.
  4. Angi innstillingene til handlingen.

    Hvis du for eksempel velger Gå til første side, angir du zoominnstillingen. Hvis du velger Gå til URL-adresse, angir du adressen til Internett-siden. Noen handlinger, for eksempel Gå til neste visning, har ikke ekstra innstillinger.

  5. Om nødvendig kan du fortsette å legge til så mange handlinger du vil, i en hendelse.
  6. Hvis du vil teste knappen, eksporterer du dokumentet til EPUB for fast layout, PDF eller SWF og viser den eksporterte filen. Hvis du eksporter til PDF, må du kontrollere at valget Interaktive objekter er angitt. Hvis du eksporterer til SWF, må du kontrollere at Inkluder knapper er valgt.

Hendelsestyper

Hendelser bestemmer hvordan handlinger aktiveres for knapper når du eksporterer dokumentet til EPUB, PDF eller SWF. (I Acrobat kalles hendelser aktivering.)

Når museknappen slippes eller trykkes

Når du slipper museknappen etter et klikk. Dette er den hendelsen som brukes mest, fordi det gir brukeren en siste sjanse til å dra markøren av knappen og ikke aktivere handlingen.

Ved klikk

Når du trykker ned museknappen (uten å slippe den). Hvis ikke du har en bestemt grunn til å bruke Ved klikk, bør du bruke Ved slipp opp, slik at brukerne har en mulighet til å avbryte handlingen.

Ved rull over

Når musepekeren kommer inn i knappeområdet som er definert av knappens markeringsramme.

Ved rull av

Når musepekeren går ut av knappeområdet.

Inn i fokus (PDF)

Når knappen i en PDF-fil får fokus, enten gjennom en musehandling eller ved at du trykker på tabulatortasten.

Ut av fokus (PDF)

Når fokus flyttes til en annen knapp eller et annet skjemafelt i PDF-filen.

Handlingstyper

Når du oppretter en handling, indikerer du hva som skjer når den angitte hendelsen finner sted – vanligvis når noen klikker på knappen. Du kan angi at følgende handlinger skal brukes når hendelsestypen aktiveres:

Gå til mål

Hopper til det angitte tekstankeret du har opprettet ved hjelp av Bokmerker- eller Hyperkoblinger-panelet. Se Opprette koblinger til tekstankere.

Gå til første/siste/neste/forrige side

Hopper til første, siste, forrige eller neste side i EPUB-, PDF- eller SWF-filen med fast layout. Marker et valg på Zoom-menyen for å bestemme hvordan siden skal vises.

Gå til URL-adresse

Åpner Internett-siden til den angitte URL-adressen.

Vis/skjul knapper og skjemaer

Veksler mellom å vise og skjule bestemte knapper i den eksporterte EPUB-, PDF- eller SWF-filen med fast layout. Hvis du for eksempel vil at en knapp skal vises når du flytter musepekeren over til en annen knapp, kan du skjule målknappen til den utløses, og opprette en handling som viser den skjulte knappen når du holder musepekeren over. Se Vise en annen knapp når musepekeren holdes over.

Lyd

Brukes til å spille av lydklippet, sette det på pause, stoppe det eller fortsette avspillingen. Bare lydklipp som er lagt til i dokumentet, vises i Lyd-menyen.

Video

Brukes til å spille av filmen, sette den på pause, stoppe den eller fortsette avspillingen. Bare filmer som er lagt til i dokumentet, vises på Video-menyen.

Animasjon (SWF/EPUB)

Brukes til å spille av, ta pause i, stoppe eller fortsette avspillingen av valgt animasjon. Bare animasjoner som er lagt til i dokumentet, vises på Animasjon-menyen.

Gå til side (SWF/EPUB)

Hopper til siden i den angitte SWF-filen.

Gå til tilstand (SWF/EPUB)

Hopper til en bestemt tilstand i et objekt med flere tilstander. Hvis for eksempel et objekt med flere tilstander inneholder flere forskjellige bilder som tilstander, kan du bruke denne handlingen til å vise et bestemt bilde.

Gå til neste/forrige tilstand (SWF/EPUB)

Hopper til neste eller forrige tilstand i et objekt med flere tilstander. Disse alternativene er spesielt nyttige når du klikker gjennom en lysbildefremvisning. Se Opprette objekter med flere tilstander.

Tøm skjema (PDF)

Fjerner alle data som er fylt ut i skjemafeltene, og tilbakestiller skjemaet til opprinnelig tilstand.

Gå til neste visning (PDF)

Hopper til en side etter at den har gått til forrige visning. På samme måte som Fremover-knappen bare er tilgjengelig i en nettleser etter at noen har valgt Tilbake-knappen, er dette valget bare tilgjengelig hvis brukeren har gått til en tidligere visning.

Gå til forrige visning (PDF)

Går til den siden i PDF-dokumentet som sist ble vist, eller går tilbake til den forrige zoomstørrelsen som ble brukt.

Åpne fil (PDF)

Starter og åpner filen du angir. Hvis du angir en fil som ikke er PDF, behøver leseren det opprinnelige programmet for å kunne åpne den. Angi et absolutt banenavn (for eksempel c:\docs\sample.pdf).

Skriv ut skjema (PDF)

Åpner utskriftsdialogen for å skrive ut skjemaet.

Send inn skjema (PDF)

Sender data fylt ut i skjemafeltene til den oppgitte nettadressen. Du må skrive inn mailto: i nettadressefeltet og deretter e-postadressen etter det for å sende et utfylt skjema til den oppgitte e-posten. Pass på at det ikke er noen mellomrom før og etter kolonet (:).

Vis zoom (PDF)

Viser siden i henhold til zoomvalget du angir. Du kan endre zoomnivået for siden (for eksempel Faktisk størrelse), sidelayouten (for eksempel Kontinuerlig - Motstående), eller rotasjonsretningen.

Redigere eller slette knappehandlinger

  1. Bruk markeringsverktøyet  til å markere knappen.
  2. Gjør ett av følgende i Knapper og skjema-panelet:

    • Hvis du vil deaktivere handlinger, fjerner du avmerkingen ved siden av dem. Deaktivering av hendelser og handlinger kan være nyttig av hensyn til testing.
    • Hvis du vil endre rekkefølgen, drar og slipper du handlinger.
    • Hvis du vil slette en handling, markerer du handlingen i listen og klikker på knappen Slett valgt handling .
    • Hvis du vil redigere en handling, velger du hendelsen som handlingen skal tilordnes, velger handlingen i listen og endrer innstillingene. Hvis du må erstatte en handling for en eksisterende hendelse, sletter du den og legger til den nye handlingen i hendelsen.

Opprette koblinger til tekstankere

Hvis du oppretter et tekstanker i et InDesign-dokument, kan du angi at en knapp skal hoppe til dette ankeret, selv om ankeret er i et annet InDesign-dokument. Bruk Bokmerker-panelet og Hyperkoblinger-panelet til å legge til tekstankere. Du kan ikke opprette hopp fra knapper til bokmerker som ikke er tekstankere.

Merk:

Hvis du angir et hyperkoblingsmål for en knapp, fungerer ikke hyperkoblingen i det eksporterte EPUB-, PDF- eller SWF-dokumentet med fast layout.

  1. Bruk markeringsverktøyet  til å markere knappen.
  2. I Knapper og skjema-panelet velger du en hendelse som Ved slipp opp, som vil aktivere koblingen.

  3. Klikk plussknappen ved siden av Handlinger, og velg Gå til mål.
  4. Velg ett av de åpne InDesign-dokumentene på Dokumenter-menyen, eller klikk på mappeikonet til høyre for menyen, og angi filen.
  5. Angi et anker som ble opprettet ved hjelp av Bokmerker-panelet eller Hyperkoblinger-panelet.
  6. Marker et valg på Zoom-menyen for å bestemme hvordan siden skal vises.
Merk:

Hvis du angir et anker i et annet dokument, må du huske å eksportere dette måldokumentet til en PDF-fil, og bruke samme filnavn som for InDesign-dokumentet, men bytte ut INDD-filtypen med PDF. Du må også arkivere PDF-dokumentene i samme mappe for å sikre at koblingene fremdeles er gyldige i Acrobat eller Reader.

Endre knappeutseendet for berøring og klikking

En knapp består av en gruppe enkeltobjekter som hver representerer et knappeutseende (kalles noen ganger en "tilstand"). Hver knapp kan ha tre utseender: Normal, Berøring og Klikk. I den eksporterte filen brukes Normal-utseendet så lenge du ikke flytter musepekeren inn i området (Berøring) eller ikke klikker museknappen i knappeområdet (Klikk). Du kan angi at hvert utseende skal være forskjellig.

Som standard blir alle knapper du oppretter, definert med Normal-utseendet som inneholder knappeteksten eller -bildet. Når du aktiverer et nytt utseende, kopieres Normal-utseendet. Hvis du vil skille et utseende fra de andre, kan du endre fargen eller legge til tekst eller et bilde.

Knappetilstander

A. Peker utenfor knappeområdet (Normal) B. Peker inne i knappeområdet (Berøring) C. Peker klikker (Klikk) 

Merk:

Det klikkbare området, eller aktiveringspunktet, til knappen er den firkantede markeringsrammen til den største tilstanden i knappen. En rund knapp har for eksempel et firkantet aktiveringspunkt.

Endre knappeutseender

Hvis du oppretter en knapp med flere utseender (Normal, Berøring og Klikk), bør du fullføre knappeutformingen før du aktiverer andre utseender. Når du aktiverer Berøring- eller Klikk-utseendet, kopieres Normal-utseendet.

Noen endringer påvirker bare det valgte utseendet, mens andre endringer påvirker alle aktive utseender. Hvis du velger et utseende og bruker en annen bakgrunnsfarge eller redigerer teksten, påvirker endringen bare det valgte utseendet. Hvis du bruker markeringsverktøyet til å flytte eller endre størrelse på knappen, påvirker endringen alle utseender.

  1. Velg Vindu > Interaktiv > Knapper og skjema for å åpne Knapper og skjema-panelet.

  2. Bruk markeringsverktøyet  til å markere knappen i layouten du vil redigere.
  3. Klikk [Berøring] for å aktivere Berøring-utseendet.

    Normal-utseendet kopieres til Berøring.

  4. Endre utseendet til knappen mens Berøring fortsatt er valgt.
    • Hvis du vil endre fargen, velger du en fargeprøve på Strek- eller Fyll-menyen i kontrollpanelet.
    • Hvis du vil montere et bilde i utseendet, markerer du bildet med segmentmarkøren eller dobbeltklikker det eksisterende knappebildet, og deretter velger du Fil > Monter og dobbeltklikker på en fil.
    • Hvis du vil lime inn et bilde i en tekstramme, kopierer du bildet til utklippstavlen, markerer utseendet i Knapper-panelet og velger Rediger > Lim inn i.
    • Hvis du vil skrive inn tekst, velger du tekstverktøyet, klikker på knappen og skriver inn teksten. Du kan også velge Rediger > Lim inn i for å kopiere en innlimt tekstramme.
  5. Hvis du vil legge til Klikk-utseendet, klikker du [Klikk] for å aktivere det, og deretter følger du den samme fremgangsmåten for å endre utseendet.
  6. Test de forskjellige knappeutseendene i Forhåndsvisning-panelet.
Merk:

Hvis du vil endre størrelsen på Tilstandsutseende-miniatyrene i Knapper-panelet, velger du Panelvalg på panelmenyen for Knapper og skjema, velger et alternativ og klikker deretter på OK.

Slette og deaktivere utseender

  1. Marker utseendet i Knapper og skjema-panelet.

  2. Gjør ett av følgende:
    • Hvis du vil slette Berøring- eller Klikk-utseendet, klikker du Slett-ikonet nederst i panelet. Det er spesielt nyttig å kunne slette et utseende hvis du ofte redigerer Normal-utseendet og ønsker å basere Berøring eller Klikk på det nye Normal-utseendet.
    • Hvis du vil deaktivere et utseende uten å slette det, klikker du på øyeikonet ved siden av utseendet for å fjerne merkingen av det. Deaktiverte tilstander blir ikke eksportert til EPUB-, PDF- eller SWF-filen med fast layout.
Merk:

Du kan ikke slette eller deaktivere Normal-tilstanden.

Opprette objekter med flere tilstander

Med Objekttilstander-panelet kan du opprette flere versjoner av et objekt. En tilstand er en versjon av et sideobjekt. Et objekt som inneholder flere versjoner, kalles et objekt med flere tilstander.

Du kan opprette så mange tilstander du vil for et objekt ved hjelp av Objekttilstander-panelet. For hver tilstand du oppretter, genereres det en ny versjon av sideobjektet. Bare én tilstand er synlig på siden til enhver tid. I den endelige utgaven av utskriften eller PDF-filen vises bare den aktive tilstanden.

Opprette en lysbildefremvisning for et objekt med flere tilstander

En av de vanligste måtene å bruke et objekt med flere tilstander på, er i en lysbildefremvisning der brukerne kan klikke gjennom et sett med bilder i en SWF-fil. Du kan for eksempel opprette en lysbildefremvisning med 20 bilder uten å måtte montere bildene på 20 forskjellige sider.

  1. Monter bildene som skal vises i lysbildefremvisningen.

    Resultatet blir best hvis bilderammene har samme størrelse.

    En tilstand trenger ikke å være et enkeltobjekt, men kan være en samling med objekter.

  2. Du kan stable bildene ved å markere dem og deretter klikke Juster horisontale midtpunkter  eller Juster vertikale midtpunkter  i kontrollpanelet.

  3. La bildene være markert, åpne Objekttilstander-panelet (Vindu > Interaktiv > Objekttilstander) og klikk knappen Konverter merket område til objekt med flere tilstander .

    Bildene vises som tilstander i Objekttilstander-panelet, med en stiplet rammekant rundt de markerte bildene.

    Konvertere merket område til objekt med flere tilstander

  4. Opprett navigasjonsknapper som utløser handlingen Gå til neste tilstand eller Gå til forrige tilstand når brukeren slipper museknappen. Se Opprette knapper.

  5. Bruk Forhåndsvisning-panelet (Vindu > Interaktiv > Forhåndsvisning for EPUB-interaktivitet / Forhåndsvisning av SWF) for å teste navigeringsknappene.

  6. Eksporter dokumentet til SWF-format. Se Interaktive dokumenter.

Redigere et objekt med flere tilstander

  1. Marker et objekt med flere tilstander.

  2. Gjør ett av følgende i Objekttilstander-panelet:

    • Hvis du vil redigere en tilstand, markerer du tilstanden og redigerer objektet. Du kan for eksempel legge til strek eller fyll eller endre størrelsen på objektet.

    • Hvis du vil legge til et objekt i en eksisterende tilstand, markerer du både objektet og objektet med flere tilstander og klikker deretter knappen Legg til objekter i synlig tilstand .

    • Hvis du vil legge til et objekt i et eksisterende objekt med flere tilstander, markerer du både objektet og objektet med flere tilstander og klikker deretter knappen Konverter merket område til objekt med flere tilstander .

    • Hvis du vil duplisere en tilstand, markerer du tilstanden som den nye tilstanden skal baseres på, og deretter velger du Ny tilstand på panelmenyen. Legg til, fjern eller rediger innholdet for tilstanden.

    • Hvis du vil lime inn objekter i en eksisterende tilstand, klipper du ut eller kopierer ett eller flere objekter, markerer objektet med flere tilstander, markerer tilstanden og velger Lim inn i tilstand på panelmenyen.

    • Hvis du vil konvertere et objekt med flere tilstander tilbake til et sett med uavhengige objekter, markerer du tilstanden og velger Frigi tilstand til objekter på panelmenyen. Hvis du vil konvertere alle tilstander i objektet med flere tilstander til uavhengige objekter, velger du Frigi alle tilstander til objekter.

    • Hvis du vil slette en tilstand og fjerne innholdet i den, markerer du tilstanden og velger Slett tilstand på panelmenyen.

    • Hvis du vil skjule objektet med flere tilstander i den eksporterte filen inntil den aktiveres av en knapp, velger du Skjult til utløst på panelmenyen.

    • Hvis du vil tilbakestille alle objekter med flere tilstander i dokumentet til den første tilstanden, velger du Tilbakestill alle objekter med flere tilstander til første tilstand på panelmenyen. Når du markerer en tilstand, forblir objektet i den tilstanden, også når du lukker dokumentet og åpner det på nytt. Dette er en rask måte å tilbakestille alle objekter med flere tilstander på.

Opprette aktiveringspunkt for knapp

I enkelte tilfeller vil du kanskje at knappeområdet (kalt et aktiveringspunkt eller en aktiveringskobling) skal være usynlig til musepekeren holdes over området. Når du holder pekeren over en knapp på et kart, kan det for eksempel vises et bilde fra en region, og bildet kan forsvinne når du flytter pekeren bort fra regionen.

Når du holder pekeren over et aktiveringspunkt i den eksporterte PDF-filen, vises det et bilde.

Vise et skjult bilde når musepekeren holdes over

Én måte å få til denne aktiveringspunkteffekten på, er å bruke et bilde på Berøring-tilstanden i Knapper-panelet. Det gjør du ved å opprette en knapp der [Berøring]-tilstanden viser et bilde, mens [Normal]-tilstanden ikke viser bildet.

  1. Marker bildet du vil bruke som aktiveringspunkt. Kontroller at rammen på bildet ikke har kantlinje eller bakgrunn.

  2. Klikk på [Normal]-utseendet i Knapper og skjema-panelet (velg Vindu > Interaktiv > Knapper og skjema) for å konvertere det valgte bildet til en knapp.

  3. Klikk på [Berøring]-utseendet i Knapper og skjema-panelet for å aktivere det.

  4. Klikk [Normal]-utseendet igjen. Marker deretter bildet med segmentmarkøren , og slett bildet.

    Pass på at du sletter bildet (innholdet i rammen), ikke rammen og innholdet. Hvis du sletter rammen, slettes hele knappen.

  5. Forhåndsvis aktiveringspunkteffekten i Forhåndsvisning-panelet.

Vise en annen knapp når musepekeren holdes over

Du kan opprette et aktiveringspunkt som viser et annet objekt når du klikker eller holder musepekeren over et objekt. Det gjør du ved å opprette to knapper, skjule den ene og bruke handlingen Vis/skjul knapper til å vise og skjule målknappen.

  1. Opprett et objekt som skal brukes som kildeknapp. Klikk på ikonet for Konverter objektet til en knapp i Knapper og skjema-panelet.

  2. Monter bildet du vil bruke som målknapp, og konverter det til en knapp.
  3. Marker målbildet, og velg Skjult til utløst nederst i Knapper og skjema-panelet.

    Bildet må være skjult i det eksporterte dokumentet for at det skal kunne vises når noen klikker på kildeknappen.

  4. Marker kildeknappen og opprett to forskjellige handlinger, én som viser målbildet, og én som skjuler målbildet.

    Hvis du vil at bildet skal vises når du holder musepekeren over kildeknappen, bruker du hendelsene Ved rull over og Ved rull av. Hvis du vil at bildet skal vises når du klikker kildeknappen og forsvinne når du slipper knappen, bruker du hendelsene Ved klikk og Ved slipp opp. Du må i alle tilfeller bruke handlingen Vis/skjul knapper til å vise og skjule målknappen. Se Gjøre knapper interaktive.

  5. Test knappene i Forhåndsvisning-panelet.

Endre PDF-valg for knapper

  1. Bruk markeringsverktøyet  til å markere knappen.
  2. Velg PDF-valg på menyen i Knapper og skjema-panelet.

  3. Skriv inn en beskrivelse som skal brukes som alternativ tekst for synshemmede brukere.
  4. Angi om knappen skal skrives ut i PDF-filen, og klikk deretter OK.

Angi tabulatorrekkefølgen for knapper

Tabulatorrekkefølgen bestemmer neste (eller forrige) felt som skal få fokus når en bruker trykker på Tab (eller Skift+Tab) i PDF- eller SWF-dokumentet. Tabulatorrekkefølgen omfatter knapper i skjulte lag, men ikke knapper på malsider.

  1. Gå til siden som inneholder knappene.
  2. Velg Objekt > Interaktiv > Angi tabulatorrekkefølge.

  3. Marker hver knapp du vil flytte, og dra den til den nye plasseringen, eller velg knappene Flytt opp og Flytt ned. Når du er ferdig, velger du OK.

Hvis du bruker Acrobat til å redigere PDF-dokumentet og legge til flere knapper eller skjemafelt på siden, må du kanskje angi en ny tabulatorrekkefølge i Acrobat.

Relaterte emner

Lag og publiser e-bøkerbrosjyrerflygebladerpostkortplakaterinteraktive sidelayouter og mye mer, med Adobe InDesign.

Adobe-logoen

Logg på kontoen din