Zaznaczanie tekstu

  1. Wybierz narzędzie Tekst i wykonaj jedną z następujących czynności:
    • Przeciągnij kursor w kształcie „I” nad znakiem, słowem lub całym blokiem tekstu, aby go zaznaczyć.
    • Dwukrotnie kliknij słowo, aby je zaznaczyć. Spacje otaczające to słowo nie zostaną zaznaczone.
    • Trzykrotnie kliknij gdziekolwiek w wierszu, aby zaznaczyć wiersz. Jeżeli opcja preferencji Potrójne kliknięcie zaznacza wiersz jest wyłączona, potrójne kliknięcie zaznacza cały akapit.

    • Jeżeli opcja Potrójne kliknięcie zaznacza wiersz jest włączona, czterokrotne kliknięcie w dowolnym miejscu akapitu zaznacza cały akapit.

    • Kliknij pięciokrotnie, aby zaznaczyć cały wątek. Możesz też kliknąć poza wątkiem i wybrać polecenie Edycja > Zaznacz wszystko.

Uwaga:

Zaznaczenie tekstu z zakotwiczeniem notatki przy pomocy jednego z opisanych wyżej sposobów powoduje zaznaczenie samej notatki i jej zawartości.

Jeżeli tekst w ramce nie daje się zaznaczyć, to być może ramka tekstowa jest na zablokowanej warstwie lub na stronie wzorcowej. Spróbuj odblokować warstwę lub przejść na stronę wzorcową. Pod ramką tekstową może również znajdować się kolejna ramka tekstowa lub obiekt przeźroczysty. Zobacz Zaznaczanie tekstu w ramce zasłoniętej.

Zmiany wprowadzane przez potrójne kliknięcia

  1. Wybierz polecenie Edycja > Preferencje > Tekst (Windows) albo InDesign > Preferencje > Tekst (Mac OS).
  2. Zaznaczyć opcję Potrójne kliknięcie zaznacza wiersz, aby włączyć zaznaczanie wiersza potrójnym kliknięciem (ustawienie domyślne). Usuń zaznaczenie z tej opcji, jeżeli potrójne kliknięcie ma zaznaczać akapit.

Zaznaczanie tekstu w ramce zasłoniętej

  1. Wybierz narzędzie Zaznaczenie , a następnie naciśnij klawisz Ctrl (Windows) lub Command (Mac OS) i kliknij, aby zaznaczyć ramkę tekstową.
  2. Wybierz narzędzie Tekst, a następnie kliknij wewnątrz ramki tekstowej lub zaznacz tekst.

Wyświetlanie znaków ukrytych (niedrukowalnych)

  1. Wybierz polecenie Tekst > Pokaż ukryte znaki.
  2. Jeśli znaki ukryte nadal są niewidoczne, wyłącz tryb podglądu. Aby go odznaczyć, wybierz Widok > Tryb ekranu > Normalny i wybierz Widok > Podgląd nadruku.

Pojawią się znaki niedrukowalne, np. rozmaite spacje, tabulatory, znaki końca akapitu, znaczniki indeksu i znaki końca wątku. Te znaki specjalne są widoczne tylko w oknie dokumentu; nie są one drukowane ani eksportowane na formaty takie jak PDF czy XML. Znaki ukryte wyświetlane są w kolorze warstwy.

Znaki niedrukowalne ukryte (u góry) i widoczne (u dołu)
Znaki niedrukowalne ukryte (u góry) i widoczne (u dołu)

Anne-Marie Concepcion udostępniła zbiorczą listę znaków specjalnych – Bezpłatny przewodnik po znakach specjalnych programu InDesign.

Lista ukrytych znaków

Ukryty znak

Co określa

Koniec akapitu

Miękki koniec (łamanie wiersza)

Znak spacji

Koniec wątku

Dywiz miękki

Dywiz twardy

Zakładka

Tabulator wcięcia z prawej

Wcięcie dotąd

Zakończenie zagnieżdżonego stylu

Nie łącznik

Spacja ideograficzna

Spacja firetowa

Spacja półfiretowa

Spacja twarda

Spacja twarda (stała szerokość)

Spacja włoskowa

Jedna szósta firetu

Chuda spacja

Jedna czwarta firetu

Jedna trzecia firetu

Spacja interpunkcyjna

Spacja cyfrowa

Spacja justująca

Podział kolumny

Podział ramki

Podział strony

Podział strony nieparzystej

Podział strony parzystej

Wymuszone łamanie wiersza

Notatka w programie InCopy

Notatka w programie InCopy (w edytorze wątków)

Znacznik pozycji (tylko InCopy)

Znacznik indeksu

Znacznik indeksu (w edytorze wątków)

Ukryty tekst warunkowy

Ukryty tekst warunkowy (w Edytorze wątków)

Znacznik zakładki lub docelowego hiperłącza (często zakotwiczenie tekstu)

Znacznik zakładki lub docelowego hiperłącza (w edytorze wątków)

Miejsce docelowe hiperłącza (w Edytorze wątków)

Akapit z odsyłaczami

Hiperłącze z odsyłaczami (w Edytorze wątków)

Zakotwiczony obiekt

Zakotwiczony obiekt (w edytorze wątków)

znacznik XML

znacznik XML (w edytorze wątków)

Przypis dolny (w edytorze wątków)

Tabela (w edytorze wątków)

Zmienna (w edytorze wątków)

Znacznik indeksu (w edytorze wątków)

Dodawanie kolumn, ramek i miejsc zakończenia strony

Łamaniem kolumn, ramek i stron można sterować, wstawiając w tekście specjalne znaki końca.

  1. Wybierz narzędzie Tekst i kliknij, aby umieścić punkt wstawiania w miejscu, gdzie ma nastąpić łamanie.
  2. Wybierz polecenie Tekst > Wstaw znak łamania, a następnie wybierz znak końca z podmenu.

Uwaga:

Znaki końca można również wprowadzać za pomocą klawisza Enter na klawiaturze numerycznej. Aby wprowadzić koniec łamu, naciśnij Enter; dla końca ramki — Shift+Enter; dla końca strony — Ctrl+Enter (Windows) lub Command+Enter (Mac OS).

Aby usunąć znak łamania, wybierz polecenie Tekst > Pokaż znaki ukryte, aby znaki niedrukowalne stały się widoczne. Następnie zaznacz i usuń znak łamania.

Uwaga:

Jeżeli wprowadzi się łamanie, zmieniając ustawienia akapitu (np. w oknie dialogowym Opcje przenoszenia), to zostanie ono zastosowane na początku akapitu zawierającego to ustawienie. Jeżeli wprowadzi się łamanie wstawiając znak specjalny, to przenoszenie następuje bezpośrednio po znaku specjalnym.

Opcje łamania

W menu Tekst > Wstaw znak łamania dostępne są następujące opcje:

Koniec kolumny 

Przenosi tekst do następnej kolumny w bieżącej ramce tekstowej. Jeżeli ramka ma tylko jedną kolumnę, tekst przechodzi do następnej ramki powiązanej.

Koniec ramki 

Przenosi tekst do następnej powiązanej ramki tekstowej, niezależnie od ustawień łamów bieżącej ramki.

Koniec strony 

Przenosi tekst na następną stronę, zawierającą ramkę powiązaną z bieżącą ramką tekstową.

Koniec strony nieparzystej 

Przenosi tekst na następną stronę nieparzystą, zawierającą ramkę powiązaną z bieżącą ramką tekstową.

Koniec strony parzystej 

Przenosi tekst na następną stronę parzystą, zawierającą ramkę powiązaną z bieżącą ramką tekstową.

Koniec akapitu 

Wstawia znak końca akapitu (tak samo jak naciśnięcie klawisza Enter lub Return).

Wymuszone łamanie wiersza 

Wymusza łamanie wiersza w miejscu wstawienia znaku, co powoduje rozpoczęcie nowej linii bez rozpoczynania nowego akapitu (to samo można uzyskać, naciskając Shift+Enter lub Shift+Return). Wymuszone łamanie wiersza zwane jest również miękkim końcem wiersza.

Miękki koniec wiersza 

Wskazuje miejsce, gdzie wiersz ma zostać przełamany, jeśli zajdzie potrzeba złamania wiersza. Miękki koniec wiersza jest podobny do dywizu miękkiego, z tą jednak różnicą, iż w miejscu łamania wiersza dywiz nie jest dodawany.

Podobne opcje łamania są dostępne w oknie dialogowym Opcje przenoszenia i Opcje stylu akapitowego.

Korzystanie z edytora wątków

W programie InDesign tekst można edytować w układzie (na stronie) albo w oknie edytora wątków. Pisanie i edytowanie tekstu w edytorze wątków umożliwia wyświetlanie całego wątku czcionką o wybranym kroju, rozmiarze i odstępach określonych w preferencjach. Uwagi użytkownika nie rozpraszają tutaj elementy układu i formatowania. W Edytorze wątków można również przeglądać zmiany wprowadzone do tekstu.

Każdy wątek pojawia się w innym oknie edytora wątków. W edytorze wyświetlany jest cały tekst wątku, łącznie z tekstem zakrytym. Jednocześnie można otwierać wiele okien edytora wątków, w tym nawet wiele okien zawierających kolejne instancje tego samego wątku. Pionowa miarka wskazuje, ile tekstu wypełnia ramkę, a linia oznacza miejsce, od którego tekst zostaje zakryty.

Zmiany wprowadzane w czasie edycji wątku pojawiają się w oknie dokumentu. Otwarte wątki są widoczne w menu Okno. W oknie edytora wątków nie można utworzyć nowego wątku.

Okno edytora wątków
Okno edytora wątków

A. Style akapitowe B. Przeciągnięcie podziałki umożliwia zmianę szerokości kolumny C. Miarka pionowa D. Wskaźnik tekstu zakrytego 

Można przeglądać i edytować tabele w Edytorze wątków, w którym tekst wyświetlany jest w kolumnach i wierszach dla łatwiejszej edycji. W prosty sposób możesz rozwijać i zwijać tabele oraz decydować o sposobie ich wyświetlania.

Edytor wątków wyświetla również tekst, który został dodany, usunięty lub zmodyfikowany, jeśli Monitorowanie zmian było włączone. Zobacz Monitorowanie i recenzowanie zmian.

Otwieranie Edytora wątków

  1. Zaznacz ramkę tekstową, kliknij wybrany punkt wstawiania w ramce tekstowej, albo zaznacz wiele ramek z różnych wątków.
  2. Wybierz polecenie Edycja > Edytuj w edytorze wątków.

Uwaga:

Aby otworzyć okno edytora wątków z inną instancją tego samego wątku, uaktywnij edytor wątków i wybierz polecenie Okno > Ułóż > Nowe okno.

Powrót do okna układu

  1. Wykonaj jedną z następujących czynności w oknie edytora wątków:
    • Wybierz polecenie Edycja > Edytuj w układzie. Gdy użyje się tej metody, w widoku układu zachowane zostanie zaznaczenie tekstu i pozycja punktu wstawiania z edytora wątków. Okno wątku pozostanie otwarte, ale przesunie się pod okno układu.

    • Kliknij w oknie układu. Okno wątku pozostanie otwarte, ale przesunie się pod okno układu.

    • Zamknij okno edytora wątków.

    • Wybierz nazwę dokumentu u dołu menu Okno.

Wyświetlanie lub ukrywanie pozycji edytora wątków

Możesz pokazywać lub ukrywać kolumnę nazwy stylu i miarkę głębokości, rozwijać lub zwijać przypisy oraz pokazywać lub ukrywać znaki dzielenia akapitu, aby wskazać początek nowych akapitów. Ustawienia te dotyczą wszystkich otwartych okien edytora wątków, a także wszystkich okien, które zostaną otwarte później.

  • Przy aktywnym edytorze wątków wybierz polecenie Widok > Edytor wątków > Pokaż kolumnę nazwy stylów lub Ukryj kolumnę nazwy stylów. Szerokość kolumny z nazwami stylów można także modyfikować przez przeciąganie pionowego paska. Nowo otwarte okna edytora wątków będą używały tej samej szerokości kolumny.
  • Przy aktywnym edytorze wątków wybierz polecenie Widok > Edytor wątków > Pokaż miarkę głębi lub Ukryj miarkę głębi.
  • Przy aktywnym Edytorze wątków wybierz polecenie Widok > Edytor wątków > Rozwiń wszystkie przypisy dolne lub Zwiń wszystkie przypisy dolne.
  • Przy aktywnym Edytorze wątków wybierz polecenie Widok > Edytor wątków > Pokaż znaki dzielenia akapitu lub Ukryj znaki dzielenia akapitu.

Preferencje edytora wątków

Preferencje wyświetlania edytora wątków określają wygląd edytora wątków. Chociaż edytor wątków wyłącza większość atrybutów formatowania tekstu poza najbardziej podstawowymi, niektóre obiekty i atrybuty są w nim przedstawiane, np.:

Atrybut

Ikona

Tabela

Obiekty w wierszu

Znaczniki XML

Zmienne

Źródła hiperłącz

Zakotwiczenia hiperłącz

Odsyłacz

Ukryty tekst warunkowy

Notatka

Przypisy dolne

Znaczniki indeksu

Tekst usunięty

Tekst dodany

Tekst przeniesiony

 

Opcje wyświetlania tekstu

Wybierz wyświetlaną czcionkę, rozmiar, odstępy między wierszami, kolor tekstu i tło. Na tym etapie możesz określić także inny temat, na przykład System klasyczny do wyświetlania żółtego tekstu na czarnym tle. Ustawienia te wpływają na sposób pokazywania tekstu w edytorze wątków, a nie na wygląd tekstu w układzie.

Włącz wygładzanie

Wygładź nierówne krawędzie tekstu i wybierz rodzaj wygładzania: Dla monitorów LCD, Gładkie lub Domyślne, które wygładza tekst używając odcieni szarości. Natomiast opcja Dla monitorów LCD wygładza tekst używając kolorów, a nie odcieni szarości. Najlepiej sprawdza się w przypadku jasnego tła i czarnego tekstu. Opcja Gładkie używa odcieni szarości, ale daje jaśniejsze i bardziej rozmyte efekty niż opcja Domyślne.

Opcje kursora

Zmień wygląd kursora tekstowego. Na przykład, zaznacz opcję Migotanie, jeżeli kursor ma być migający.

Tekst z ramek w wierszu nie pojawia się w oknie edytora wątku macierzystego, ale może być wyświetlany we własnym oknie edytora wątków.

Korzystanie z tekstu warunkowego

Dzięki tekstowi warunkowemu możesz tworzyć różne wersje tego samego dokumentu. Po stworzeniu warunków należy je zastosować do danego przedziału tekstu. Pokazując i ukrywając warunki możesz tworzyć różne wersje swoich dokumentów. Na przykład tworząc instrukcję komputerową możesz stworzyć osobne warunki dla systemów Mac OS oraz Windows. Przed wydrukowaniem wersji podręcznika dla systemu Mac OS możesz pokazać cały tekst z zastosowanym warunkiem „Mac” i ukryć tekst z zastosowanym warunkiem „Windows”. Następnie możesz wykonać odwrotną operację, aby wydrukować podręcznik dla systemu Windows.

Tekst warunkowy
Tekst warunkowy pokazany

A. Wszystkie warunki są pokazane B. Wskaźniki warunkowe 
Tekst warunkowy ukryty
Tekst warunkowy ukryty

A. Warunek „Mac” ukryty B. Symbole warunku ukrytego 

Warunki mogą być stosowane wyłącznie do tekstu. Można stworzyć warunek dla zakotwiczonego obiektu, ale tylko poprzez zaznaczenie znacznika zakotwiczonego obiektu. Można stworzyć warunek dla tekstu w komórkach tabeli, ale nie można go stworzyć dla kolumn, wierszy czy samych komórek tabeli. Można stosować warunki dla tekstu w zablokowanych wątkach programu InCopy.

Planowanie dokumentów warunkowych

Podczas planowania projektu warunkowego należy zastanowić się nad tym, jakiego rodzaju ma to być materiał oraz jak inni ludzie mogą kolejno nad nim pracować, jeśli dokument zostanie przekazany dalej. Należy odpowiednio zaplanować tekst pod względem spójności, aby był on łatwiejszy w użyciu. W tym celu można skorzystać z następujących wskazówek.

Liczba wersji

Określ ile wersji będzie zawierał finalny projekt. Na przykład, jeśli opracowujesz podręcznik opisujący program działający zarówno na platformie Windows jak i Mac OS, możesz potrzebować co najmniej dwóch wersji: dla systemu Windows oraz dla Mac OS. Jeśli chcesz opracować każdą wersję z dodatkowymi komentarzami rozmieszczonymi w tekście dla procesu recenzyjnego, możesz potrzebować nawet więcej wersji: dla Mac OS z komentarzami, dla Mac OS bez komentarzy, dla Windows z komentarzami i dla Windows bez komentarzy.

W przypadku dokumentów z wieloma warunkami możesz określić zestawy warunków, które w szybki sposób mogą zostać zastosowane do dokumentu.

Liczba potrzebnych znaczników warunkowych

Określ ile znaczników warunkowych będzie potrzebnych do utworzenia wszystkich wersji. Wersja dokumentu określana jest przez indywidualny zestaw znaczników warunkowych. Na przykład ukończona wersja podręcznika dla systemu Windows zawierać może pokazany znacznik warunkowy Windows, ukryty znacznik warunkowy Mac OS oraz ukryty znacznik warunkowy Komentarze. W tym przypadku należałoby zdecydować, czy użyć osobnego znacznika warunkowego dla komentarzy dla systemu Windows i osobnego dla komentarzy dla systemu Mac OS, czy jednego znacznika dla komentarzy dla obydwu systemów.

Organizacja zawartości

Oceń w jakim stopniu dokument ma być warunkowy i jak najlepiej ułożyć materiał, aby ułatwić i usprawnić jego uzupełnianie oraz utrzymanie. Na przykład możesz zorganizować księgę tak, aby tekst warunkowy ograniczał się tylko do kilku dokumentów. Możesz też zachować różne wersje danego rozdziału w osobnych plikach, a nie jako tekst warunkowy, a następnie korzystać z tych plików dla każdej z wersji księgi.

W niektórych przypadkach, jak na przykład podczas pracy nad różnymi wersjami językowymi, łatwiej jest stworzyć osobne warstwy dla każdego z języków zamiast korzystać z warunków.

Sposób oznakowania

Określ najmniejszą jednostkę tekstu warunkowego. Na przykład, jeśli dokument ma być tłumaczony na inny język, najmniejszą ilością tekstu warunkowego powinno być jedno zdanie. Jako, że podczas tłumaczenia często zmienia się porządek wyrazów, użycie fragmentu zdania jako tekstu warunkowego skomplikowałoby proces.

Niekonsekwencja w stosowaniu warunków wobec odstępów i znaków interpunkcyjnych możesz prowadzić do powstania dodatkowych odstępów lub błędów w słowach. Zdecyduj, czy odstępy i znaki interpunkcyjne również mają być warunkowe. W przypadku, gdy tekst warunkowy zaczyna się i kończy znakiem interpunkcyjnym, znak ten również powinien być warunkowy. Ułatwi to odczytanie tekstu podczas wyświetlania więcej niż jednej wersji.

Aby zapobiec problemom z odstępami, takim jak przypadki, gdy odstęp warunkowy poprzedzony jest odstępem bez warunków, ustaw standardy obsługi odstępów następujących po tekście warunkowym (zawsze warunkowe lub zawsze bez warunków).

Aby ułatwić pogląd tekstu, określ kolejność, w jakiej tekst warunkowy będzie wyświetlany i korzystaj z tej kolejności w całym dokumencie.

Indeksy i odsyłacze

Podczas indeksowania dokumentu zwróć uwagę, czy znaczniki indeksu umieszczane są wewnątrz, czy na zewnątrz tekstu warunkowego. Należy pamiętać, że znaczniki indeksu znajdujące się w ukrytym tekście warunkowym nie są brane pod uwagę podczas generowania indeksu.

Podczas tworzenia odsyłacza do tekstu warunkowego, upewnij się czy tekst źródłowy posiada ten sam warunek. Na przykład jeśli dodasz odsyłacz do akapitu warunku „Windows”, a zakotwiczenie tekstu znajduje się w warunku „Mac”, to odsyłacz nie będzie działać po ukryciu warunku „Mac”. Oznaczenie „HT” pojawi się obok odsyłacza w panelu Hiperłącza.

Po stworzeniu odsyłacza do akapitu, w którym część tekstu jest warunkowa i zmianie ustawień widoczności dla tego warunku należy uaktualnić odsyłacz.

Tworzenie warunków

Utworzone warunki są zapisywane w aktualnym dokumencie. Jeśli podczas tworzenia warunku żaden dokument nie jest otwarty, warunek ten pojawi się we wszystkich nowych dokumentach, które zostaną utworzone.

Można ułatwić identyfikację tekstu warunkowego stosując różne wskaźniki warunku, np. czerwone faliste podkreślenie.

  1. Wybierz polecenie Okno > Tekst i tabele > Tekst warunkowy, aby wyświetlić panel Tekst warunkowy.
  2. Wybierz polecenie Nowy warunek z menu panelu Tekst warunkowy i wpisz nazwę warunku.
  3. W grupie Wskaźnik określ wygląd wskaźnika, do którego zastosowany jest warunek.

    Domyślnie wskaźniki (np. czerwone faliste podkreślenia) są wyświetlane w dokumencie, ale nie zostają drukowane. Można wybrać specjalne opcje z menu Wskaźniki w panelu Tekst warunkowy, aby ukryć wskaźniki lub zezwolić na ich drukowanie, co może przydać się do celów recenzyjnych.

  4. Kliknij OK.

Stosowanie warunków do tekstu

Można stosować wiele warunków do tego samego tekstu. Domyślnie do identyfikacji tekstu warunkowego używane są wskaźniki warunku. Jeśli jednak wskaźniki są ukryte, możesz wykorzystać panel Tekst warunkowy do określenia, które warunki zostały zastosowane w aktualnym tekście. Ciemniejszy znaczek wskazuje, że warunek zastosowany jest do aktualnego tekstu. Jaśniejszy znaczek wskazuje, że warunek zastosowany jest tylko do części zaznaczenia.

  1. Zaznacz tekst, do którego ma być zastosowany warunek.
  2. W panelu Tekst warunkowy (Okno > Tekst i tabele > Tekst warunkowy) wykonaj jedną z następujących czynności:
    • Aby zastosować warunek, kliknij warunek lub pole obok nazwy warunku.

    • Aby zastosować warunek i usunąć inne warunki zastosowane do tekstu, kliknij odpowiedni warunek z wciśniętym klawiszem Alt (Windows) lub z wciśniętym klawiszem Option (Mac OS).

    • Aby usunąć warunek, kliknij pole obok nazwy warunku. Możesz też kliknąć opcję [Bez warunków], aby usunąć wszystkie warunki z zaznaczonego tekstu.

Uwaga:

Nie można stosować skrótów klawiaturowych dla określonych warunków. Można jednak stosować warunki za pomocą funkcji Szybkie stosowanie.

Wyświetlanie lub ukrywanie warunków

Po ukryciu warunku cały tekst, dla którego warunek ten był zastosowany zostaje ukryty. Ukrycie warunków często powoduje zmianę numeracji stron w dokumencie lub księdze. Można skorzystać z funkcji Inteligentne ponowne wlanie tekstu, aby automatycznie dodawać i usuwać strony podczas ukrywania oraz pokazywania warunków.

Ukryty tekst warunkowy nie jest brany pod uwagę w dokumencie. Na przykład ukryty tekst nie jest drukowany ani eksportowany, znaczniki indeksu w ukrytym tekście warunkowym nie są brane pod uwagę podczas generowania indeksu oraz tekst ten jest ignorowany podczas korzystania z funkcji szukania i sprawdzania pisowni.

Po ukryciu warunku, ukryty tekst przechowywany jest w symbolu ukrytego warunku . Jeśli zaznaczysz tekst zawierający symbol ukrytego warunku i spróbujesz go usunąć, program zapyta, czy chcesz usunąć ukryty tekst warunkowy. Do ukrytego tekstu warunkowego nie można stosować innych warunków, stylów ani formatowania.

Jeśli do tekstu zastosowanych jest kilka warunków i co najmniej jeden z nich jest pokazany, tekst nie jest traktowany jako ukryty.

  • Aby pokazać lub ukryć poszczególne warunki, kliknij pole widoczności obok nazwy warunku. Ikona oka wskazuje, że warunek jest widoczny.
  • Aby pokazać lub ukryć wszystkie warunki, wybierz polecenie Pokaż wszystkie lub Ukryj wszystkie z menu panelu Tekst warunkowy.

Korzystanie z zestawów warunków

Zestaw warunków zawiera ustawienia widoczności dla wszystkich warunków, ułatwiając przedstawianie różnych wersji dokumentu. Na przykład możesz mieć skomplikowany dokument z zastosowanymi warunkami dotyczącymi platformy (Mac OS, Windows XP, Vista, UNIX), języka (angielski, francuski, niemiecki, hiszpański) oraz redakcji tekstu (Recenzja i Komentarze wewnętrzne). Do celów recenzowania francuskiej wersji dla systemu Vista, możesz stworzyć zestaw pokazujący tylko warunki Vista, francuski i Recenzja, a ukrywający wszystkie pozostałe.

Zestawy nie są niezbędne, ale znacznie ułatwiają zmienianie ustawień widoczności warunków.

  1. Zastosuj odpowiednie warunki do tekstu.
  2. Jeśli menu Zestaw nie jest widoczne w panelu Tekst warunkowy, wybierz polecenie Pokaż opcje z menu panelu Tekst warunkowy.
  3. W panelu Tekst warunkowy możesz pokazywać lub ukrywać warunki zgodnie z aktualną potrzebą.
  4. Wybierz polecenie Utwórz nowy zestaw z menu panelu Zestaw, określ nazwę zestawu i kliknij OK.

    Nowy zestaw staje się aktywnym zestawem.

  5. Wykonaj dowolną z następujących czynności:
    • Aby zastosować zestaw warunków do dokumentu, wybierz nazwę zestawu z menu Zestaw.

    • Aby zakryć ustawienia zestawu warunków, zaznacz zestaw, a następnie zmień ustawienia widoczności dla dowolnego warunku. Obok zestawu warunków pojawi się znak plus (+). Ponownie wybierz zestaw warunków, aby wrócić do poprzednich ustawień. Wybierz polecenie Zmień definicję „[Zestawu warunków]”, aby wprowadzić nowe ustawienia widoczności dla zestawu.

    • Aby usunąć zestaw warunków, zaznacz go, a następnie wybierz polecenie Usuń „[Zestaw warunków]”. Usunięcie zestawu warunków nie usuwa warunków zestawu, ani nie usuwa warunków z miejsc, gdzie zostały zastosowane.

Zarządzanie warunkami

  1. Wykonaj dowolną z następujących czynności:

    Usuń warunek

    Zaznacz warunek i kliknij ikonę Usuń warunek u dołu panelu Tekst warunkowy. Określ, który warunek ma zastąpić warunek wykasowany, a następnie kliknij OK. Wybrany warunek zostanie zastosowany do całego tekstu, do którego zastosowany był wykasowany warunek.

    Aby usunąć kilka warunków, kliknij z wciśniętym klawiszem Shift zaznaczając kolejne warunki z listy lub kliknij z wciśniętym klawiszem Ctrl (Windows) lub z wciśniętym klawiszem Command (Mac OS), zaznaczając warunki z różnych miejsc listy, a następnie kliknij ikonę Usuń warunek.

    Usuń warunek z tekstu

    Usuwanie znacznika warunku z tekstu różni się od kasowania znacznika z dokumentu. Po usunięciu znacznika z tekstu, pozostaje on wciąż w dokumencie do ponownego zastosowania.

    Aby usunąć warunek z tekstu, zaznacz tekst i kliknij pole obok warunku lub kliknij opcję [Bez warunków], usuwając wszystkie warunki z zaznaczonego tekstu.

    Załaduj (importuj) warunki

    Wybierz polecenie Załaduj warunki (aby załadować wyłącznie warunki) lub Załaduj warunki i zestawy z menu panelu Tekst warunkowy. Zaznacz dokument programu InDesign, z którego mają być zaimportowane warunki, a następnie kliknij Otwórz. Załadowane warunki i zestawy zastąpią swoje odpowiedniki o identycznych nazwach.

    Nie można załadować warunków z pliku programu InCopy do programu InDesign, ale można je załadować z pliku programu InDesign zarówno do programu InDesign, jak i InCopy.

    Załadowane zestawy ignorują ustawienia widoczności warunków znajdujących się w panelu Tekst warunkowy.

    Synchronizuj warunki w księdze

    Aby się upewnić, że we wszystkich dokumentach księgi stosowane są te same warunki, utwórz żądane warunki w dokumencie źródła stylu, wybierz Ustawienia tekstu warunkowego w oknie dialogowym Opcje synchronizacji, a następnie zsynchronizuj księgę.

    Pokaż lub ukryj wskaźniki warunku

    Wybierz polecenie Pokaż lub Ukryj z menu Wskaźniki w panelu Tekst warunkowy, aby pokazać lub ukryć wskaźniki. Jeśli chcesz zobaczyć, które obszary są warunkowe w danej wersji, pokaż znaczniki warunku. Jeśli wskaźniki warunku przeszkadzają w przeglądaniu układu, ukryj wskaźniki warunku. Wybierz Pokaż i Drukuj, jeśli chcesz, aby wskaźniki warunku zostały wydrukowane.

    Zmień nazwę warunku

    W panelu Tekst warunkowy kliknij warunek, odczekaj chwilę, a następnie kliknij nazwę warunku. Wpisz inną nazwę.

    Edytuj wskaźniki warunku

    W panelu Tekst warunkowy kliknij podwójnie warunek lub zaznacz warunek i wybierz polecenie Opcje warunku z menu panelu. Określ ustawienia wskaźnika i kliknij OK.

Wyszukiwanie i zastępowanie tekstu warunkowego

Użyj okna dialogowego Znajdź/Zastąp, aby znaleźć tekst z co najmniej jednym zastosowanym warunkiem i zastąp go co najmniej jednym innym warunkiem.

  1. Uwzględnij dowolny tekst warunkowy podczas szukania.

    Ukryty tekst nie jest jednak brany pod uwagę podczas szukania.

  2. Wybierz polecenie Edycja > Znajdź/Zastąp.
  3. Jeśli na dole okna dialogowego nie pokazały się pola Znajdź format i Zamień format, kliknij Więcej opcji.
  4. Kliknij pole Znajdź format, aby wyświetlić okno dialogowe Ustawienia wyszukiwania formatu. W części Warunki zaznacz opcję [Dowolny warunek] (aby odszukać tekst z zastosowanym dowolnym warunkiem), [Brak warunków] (aby odszukać tekst bez zastosowanego warunku) lub zaznacz konkretny warunek lub warunki, które chcesz odszukać. Kliknij OK.

    Funkcja ta znajduje tekst spełniający wszystkie wybrane warunki wyszukiwania. Na przykład po zaznaczeniu Warunku 1 i Warunku 2 tekst, do którego jest zastosowany tylko jeden z tych warunków nie zostanie znaleziony, podobnie jak tekst, do którego zastosowany jest jeszcze inny warunek oprócz tych dwóch.

  5. Kliknij pole Zmień format, aby wyświetlić okno dialogowe Ustawienia zmiany formatu. Określ inną opcję formatowania, jak na przykład warunek lub styl znakowy, a następnie kliknij OK.

    Jeśli zaznaczysz sekcję Warunki w oknie dialogowym Ustawienia zmiany formatu, opcja [Dowolny warunek] nie wprowadzi żadnych zmian do znalezionego tekstu warunkowego. Opcja ta przydaje się do zastosowania innego formatowania (na przykład stylu znakowego). Zaznacz opcję [Brak warunków], aby usunąć wszystkie warunki ze znalezionego tekstu. Po zaznaczeniu określonego warunku możesz zdecydować, czy ma on zastąpić warunek zastosowany do znalezionego tekstu, czy też ma być do niego dodany.

  6. Kliknij Znajdź, a następnie przycisk Zmień, Zmień/Znajdź albo Zmień wszystkie, aby zastąpić warunek.

Ta zawartość jest licencjonowana na warunkach licencji Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Posty z serwisów Twitter™ i Facebook nie są objęte licencją Creative Commons.

Informacje prawne   |   Zasady prywatności online