Podczas umieszczania grafiki w układzie widoczna jest wersja pliku w rozdzielczości ekranowej. Umożliwia to podgląd i odpowiednie umieszczenie grafiki. Jednak ostateczny plik graficzny może być połączonylub osadzony.

  • Kompozycja połączona jest związana z dokumentem, lecz mimo to pozostaje od niego niezależna, co daje w efekcie mniejszy dokument. Kompozycję połączoną można modyfikować przy użyciu narzędzi do przekształcania oraz efektów, nie można jednak zaznaczać i edytować poszczególnych jej elementów. Po połączeniu grafiki można ją wykorzystać wiele razy, nie zwiększając znacząco rozmiaru dokumentu; można także jednocześnie uaktualnić wszystkie łącza. Podczas eksportowania lub drukowania odtwarzana jest grafika oryginalna, a na efekt końcowy składa się pełna rozdzielczość oryginalnych.elementów.

  • Kompozycja osadzona jest kopiowana do dokumentu w pełnej rozdzielczości, czego wynikiem jest większy dokument. Wersje kompozycji można kontrolować i uaktualniać w dowolnym momencie. Dopóki kompozycja jest osadzona, dokument jest samowystarczalny.

Aby ustalić, czy kompozycja jest połączona, czy osadzona lub też zmienić jej status należy skorzystać z panelu Łącza.

Jeżeli rozmiar umieszczanego obrazu bitmapowego nie przekracza 48K, InDesign automatycznie osadza grafikę w pełnej rozdzielczości, zamiast tworzyć dla potrzeb układu podgląd w rozdzielczości ekranowej. InDesign wyświetla te obrazy w panelu Łącza, tak aby można było kontrolować ich wersje i uaktualniać je w razie potrzeby. Jednak łącze to nie jest niezbędne do uzyskania optymalnego wydruku.

Uwaga:

Jeżeli przeniesie się dokument do innego folderu lub na inny dysk (np. zanosząc go do usługodawcy), należy pamiętać o przeniesieniu również plików graficznych; nie są one bowiem zapisywane wewnątrz dokumentu. Korzystając z funkcji Inspekcja wstępna i Pakiet można automatycznie skopiować wszystkie potrzebne pliki.

Wszystkie pliki umieszczone w dokumencie wykazywane są w panelu Łącza. Dotyczy to zarówno zasobów lokalnych (na dysku) jak i zasobów zarządzanych na serwerze. Niemniej jednak pliki wklejone ze strony WWW wyświetlanej w przeglądarce Internet Explorer nie pojawiają się w panelu.

W programie InCopy panel Łącza wyświetla również wątki połączone. Gdy wybierzesz wątek połączony w panelu Łącza, w części Informacje o łączu wyświetlone zostaną notatki, takie jak liczba uwag, stan zarządzanego i stan śledzonych zmian.

Panel Łącza
Panel Łącza

A. Kolumny kategorii B. Pokaż/ukryj informacje o łączu C. Ikona jednej lub więcej zmodyfikowanych instancji D. Ikona Zmodyfikowane E. Ikona łącza brakującego F. Ikona łącza osadzonego 

Jeśli ta sama grafika pojawia się kilka razy w jednym dokumencie, łącza zostają wyświetlone na liście pod rozwijanym trójkątem w panelu Łącza. Jeśli połączona grafika EPS lub dokument InDesign zawiera łącza, są one również wyświetlane na liście pod rozwijanym trójkątem.

Połączony plik może się wyświetlać w panelu Łącza na kilka różnych sposobów podanych poniżej.

Aktualny

Aktualny plik ma pustą kolumnę Status.

Zmodyfikowane

Ikona ta oznacza, że wersja pliku na dysku jest nowsza niż wersja, która została wprowadzona do dokumentu. Ikona ta pojawi się na przykład po zaimportowaniu grafiki programu Photoshop do programu InDesign, która zostanie później zmieniona i zapisana w programie Photoshop.

Nieco odmienna wersja ikony Zmodyfikowany pojawi się, gdy grafika zostanie zmodyfikowana i część instancji zostanie uaktualniona, a część nie.

Brak

Obrazu nie ma już w miejscu, z którego został zaimportowany, aczkolwiek może wciąż znajdować się w pamięci programu. Brakujące łącza oznaczają, że oryginalny plik został wykasowany lub przeniesiony do innego folderu lub serwera po zaimportowaniu. Nie da się ustalić, czy brakujący plik jest aktualny, dopóki nie odnajdzie się oryginału. Jeżeli wydrukuje się lub wyeksportuje dokument w sytuacji, gdy wyświetlona jest ta ikona, plik może nie uzyskać pełnej rozdzielczości.

Osadzone

Osadzenie zawartości pliku połączonego powoduje zawieszenie operacji zarządzania tym łączem. Jeżeli bieżące łącze podlega obecnie operacji „edycji w miejscu”, opcja ta nie jest dostępna. Usunięcie osadzenia pliku przywraca operacje zarządzania łączem.

Następujące kody wskazują gdzie znajduje się połączony obiekt, jeśli nie pojawił się on na określonej stronie dokumentu: PB (stół montażowy), MP (strona wzorcowa), OV (tekst nie mieszczący się), HT (ukryty tekst).

Samouczek wideo przedstawiający korzystanie z panelu Łącza można obejrzeć na stronie internetowej www.adobe.com/go/lrvid4027_id_pl.

InDesign Secrets udostępnia przekaz wideo zawierający wskazówki i techniki korzystania z panelu Łącza – Oszczędzanie czasu z pomocą panelu Łącza.

  • Aby wyświetlić panel Łącza, należy wybrać polecenie Okno > Łącza. Każdy plik połączony, a także każdy plik osadzony automatycznie posiada własną nazwę.
  • Aby uzyskać podgląd połączonej grafiki, zaznacz łącze w panelu Łącza, a następnie kliknij przycisk Idź do łącza  lub kliknij numer strony łącza w kolumnie Strona lub wybierz polecenie Idź do łącza z menu panelu Łącza. Program InDesign wyśrodkowuje wyświetlanie wokół zaznaczonej grafiki. Aby wyświetlić ukryty obiekt zaznacz warstwę (lub warunek, jeśli obiekt jest zakotwiczony).
  • Aby rozwinąć lub zwinąć listę zagnieżdżonych łączy, kliknij ikonę trójkąta z lewej strony łącza. Zagnieżdżone łącza pojawiają się, jeśli ta sama grafika występuje w dokumencie kilka razy lub gdy połączona grafika EPS lub dokument InDesign także zawierają łącza.
  • Aby posortować łącza w panelu, kliknij tytuł kategorii na górze panelu Łącza, a elementy zostaną posortowane według kategorii. Ponowne kliknięcie tej samej kategorii odwraca porządek sortowania. Na przykład, kliknięcie kategorii Strona spowoduje, że łącza wyświetlą się w kolejności od pierwszej do ostatniej strony. Ponowne kliknięcie kategorii Strona spowoduje, że łącza zostaną posortowane od ostatniej do pierwszej strony. Skorzystaj z Opcji panelu, aby dodać kolumny do panelu Łącza.

W panelu Łącza można też wyświetlić dodatkowe kategorie, jak np. Data utworzenia lub Warstwa, aby uzyskać więcej informacji o grafice. Dla każdej kategorii można określić, czy informacja ma pojawiać się jako kolumna w panelu Łącza i jako sekcja Informacje o łączu na dole panelu.

  1. Wybierz polecenie Opcje panelu z menu panelu Łącza.
  2. Zaznacz pola wyboru w części Pokaż kolumnę, aby dodać kolumny do panelu Łącza.

    Folder 0 zawiera połączony plik; Folder 1 zawiera Folder 0 itd.

  3. Zaznacz pola wyboru w części Pokaż w informacjach o łączu, aby wyświetlić informacje w sekcji Informacje o łączu na dole panelu Łącza.
  4. Kliknij OK.

Można zmienić kolejność kolumn poprzez wybranie jednej kolumny i przeciągnięcie jej w inne miejsce. Rozciągnij granice kolumny, aby zmienić jej szerokość. Kliknij tytuł kategorii, aby posortować łącza według tej kategorii w kolejności rosnącej. Kliknij ponownie, aby posortować w kolejności malejącej.

  1. Wybierz polecenie Opcje panelu z menu panelu Łącza.
  2. Aby określić Rozmiar wiersza, zaznacz Małe wiersze, Zwykłe wiersze lub Duże wiersze.
  3. W przypadku Miniaturek, określ czy reprezentacja grafiki ma być wyświetlona w kolumnie Nazwa i w sekcji Informacje o łączu na dole panelu Łącza.
  4. Kliknij OK.

Sekcja Informacje o łączu w panelu Łącza zawiera informacje o połączonym pliku, który aktualnie jest zaznaczony.

Uwaga:

Aby zdecydować, które informacje mają być wyświetlane w sekcji Informacje o łączu w panelu Łącza, wybierz polecenie Opcje panelu z menu panelu Łącza i zaznacz odpowiednie pola wyboru w kolumnie Pokaż w informacjach o łączu.

  1. Kliknij dwukrotnie łącze lub zaznacz łącze i kliknij ikonę Pokaż/ukryj informacje o łączu (ikona trójkąta z lewej strony panelu).

Jeżeli plik połączony lub umieszczony, zawiera metadane, można je wyświetlać za pomocą panelu Łącza. Nie możliwości edycji lub zmiany metadanych skojarzonych z powiązanym plikiem.

  1. Wybierz plik w panelu Łącza, a następnie z menu panelu wybierz polecenie Narzędzia > Informacje o pliku XMP.

Osadzanie obrazu w dokumencie

Zamiast tworzyć łącze do umieszczonego pliku, można taki plik osadzić (czyli zapisać) w dokumencie. Osadzenie pliku powoduje zerwanie łącza z oryginałem. Panel Łącza nie ostrzega wówczas, że oryginał uległ zmianie. Nie można też automatycznie uaktualnić pliku.

Osadzenie pliku zwiększa rozmiar pliku dokumentu.

Osadzenie połączonego pliku

  1. Zaznacz plik w panelu Łącza.
  2. Wykonaj jedną z następujących czynności:
    • Wybierz polecenie Osadź łącze z menu panelu Łącza.

    • Jeśli plik ma wiele instancji, wybierz polecenie Osadź wszystkie instancje [Nazwa pliku] z menu panelu Łącza. Aby osadzić tylko jedną instancję, zaznacz ją i wybierz polecenie Osadź łącze.

Plik pozostanie w panelu Łącza i oznaczony będzie ikoną pliku osadzonego .

Uwaga:

W przypadku pliku tekstowego wymienionego w panelu Łącza, należy wybrać polecenie Odłącz z menu panelu. Gdy osadzi się plik tekstowy, jego nazwa jest usuwana z panelu Łącza.

Usuwanie osadzenia pliku połączonego

  1. Zaznacz jeden lub więcej plików osadzonych w panelu Łącza.
  2. Wykonaj jedną z następujących czynności:
    • Wybierz polecenie Usuń osadzenie łącza z menu panelu Łącza. Jeśli plik ma wiele instancji, wybierz polecenie Usuń osadzenie wszystkich instancji [Nazwa pliku] z menu panelu Łącza.

    • Kliknij przycisk Łącz ponownie  lub wybierz równorzędne polecenie z menu panelu Łącza.

  3. Połącz plik z plikiem oryginalnym lub z folderem tworzonym przez InDesign z danych osadzonych, zapisanych w dokumencie.

Za pomocą panelu Łącza można sprawdzać status dowolnego łącza lub zastępować pliki wersjami uaktualnionymi lub innymi plikami.

Po uaktualnieniu lub odtworzeniu (ponownym nawiązaniu) łącza z plikiem zachowywane są wszystkie przekształcenia wykonane w programie InDesign (jeśli wybrana zostanie opcja Po ponownym połączeniu zachowaj wymiary w preferencjach Obsługi plików). Gdy na przykład zaimportuje się obraz w kształcie kwadratu i obróci go o 30°, a następnie połączy go z grafiką oryginalną, program InDesign dokona analogicznego obrotu, aby dopasować układ zastępowanej grafiki.

Uwaga:

Umieszczone pliki EPS mogą zawierać łącza OPI, które pojawiają się w panelu Łącza. Nie należy ponownie nawiązywać łączy OPI do plików innych niż zamierzone przez twórcę pliku EPS, gdyż może to spowodować problemy z pobieraniem czcionek i rozbarwianiem.

Wybór skalowania grafiki ponownie połączonej

Przy ponownym nawiązywaniu łącza do pliku, zastępując grafikę innym plikiem źródłowym, można zachować rozmiary obrazu pliku zastępowanego lub też wyświetlić plik w jego aktualnych wymiarach.

  1. Wybierz polecenie Edycja > Preferencje > Obsługa plików (Windows) lub InDesign > Preferencje > Obsługa plików (Mac OS).

  2. Wybierz opcję Zachowaj wymiary obrazów podczas ponownego łączenia jeśli chcesz, aby pojawiające się obrazy miały ten sam rozmiar, co obrazy przez nie zastępowane. Wyłącz tę opcję jeśli ponownie połączone obrazy mają pojawiać się w oryginalnych rozmiarach.

Program InDesign szuka najpierw brakującego łącza w folderze, w którym w bieżącej sesji ponownie połączono kolejny plik. Następnie szuka łącza w folderze, w którym znajduje się dany dokument. Jeśli nadal nie może go znaleźć, szuka w folderze nadrzędnym dokumentu.

Zmodyfikowane łącza nazywane są także łączami „nieaktualnymi”.

  1. Wykonaj jedną z następujących czynności w panelu Łącza:
    • Aby uaktualnić konkretne łącza, należy zaznaczyć jedną lub kilka pozycji oznaczonych ikoną łącza zmodyfikowanego . Następnie kliknij przycisk Uaktualnij łącze  lub wybierz równorzędne polecenie z menu panelu Łącza.

    • Aby uaktualnić wszystkie zmodyfikowane łącza, wybierz polecenie Uaktualnij wszystkie łącza z menu panelu Łącza lub zaznacz zmodyfikowane łącze i kliknij z wciśniętym klawiszem Alt (Windows) lub Option (Mac OS) przycisk Uaktualnij łącze.

    • Aby uaktualnić tylko jedno łącze do grafiki, która pojawia się w kilku miejscach dokumentu, zaznacz tylko to łącze podrzędne i wybierz polecenie Uaktualnij łącze. Wybranie łącza „nadrzędnego” uaktualni wszystkie łącza do zmodyfikowanej grafiki.

  1. Zaznacz dowolne łącze w panelu Łącza i kliknij przycisk Łącz ponownie  lub wybierz równorzędne polecenie z menu panelu Łącza. Jeśli zaznaczone jest łącze „nadrzędne” wielu instancji, wybierz polecenie Łącz ponownie wszystkie instancje [Nazwa pliku] z menu panelu Łącza.

    Opcja ponownego łączenia jest nieaktywna w przypadku zarządzanych wątków do czasu pobrania wątku.

  2. W nowym oknie dialogowym zaznacz opcję Szukaj brakujących łączy w tym folderze, jeśli chcesz, by program InDesign zlokalizował w folderze pliki o tej samej nazwie co inne pliki o brakujących łączach. Jeśli ta opcja nie jest zaznaczona, tylko aktualnie zaznaczony obraz jest łączony ponownie.
  3. Aby kontrolować sposób importowania nowego pliku źródłowego, wybierz opcję Pokaż opcje importu.
  4. Odszukaj i dwukrotnie kliknij nowy plik źródłowy
  5. Po kliknięciu opcji Pokaż opcje importu, wybierz opcje importu. (Zobacz Opcje importowania grafiki).
  1. Aby odtworzyć łącze brakujące, zaznacz w panelu dowolne łącze oznaczone ikoną łącza brakującego , po czym kliknij przycisk Łącz ponownie .
  2. W nowym oknie dialogowym wybierz opcję Szukaj brakujących łączy w tym folderze, aby ponownie połączyć każdy z brakujących plików znajdujących się w określonym folderze. Znajdź plik i dwukrotnie go kliknij.

Zaraz po otwarciu dokumentu program InDesign domyślnie szuka brakujących łączy i próbuje je rozpoznać. Dwie opcje preferencji umożliwiają programowi InDesign automatyczne przeszukiwanie i znajdowanie brakujących łączy zaraz po otwarciu dokumentu.

Sprawdź łącza przed otwarciem dokumentu

Po wyłączeniu tej opcji program InDesign będzie od razu otwierać dokument, a status łączy pozostanie nieokreślony do czasu, gdy łącza zostaną oznaczone jako aktualne, brakujące lub zmodyfikowane. Po włączeniu tej opcji program InDesign będzie sprawdzał, czy w dokumencie znajdują się jakieś zmodyfikowane lub brakujące łącza.

Znajdź brakujące łącza przed otwarciem dokumentu

Po wyłączeniu tej opcji program InDesign nie będzie próbować rozpoznawać brakujących łączy. Lepiej wyłączyć tę opcję jeśli powoduje ona słabszą wydajność serwera lub gdy nastąpią nieoczekiwane połączenia. Ta opcja nie jest aktywna jeśli opcja Sprawdź łącza przed otwarciem dokumentu jest wyłączona.

Wyszukiwanie brakujących łączy

Użyj polecenia Wyszukiwanie brakujących łączy, aby rozpoznać brakujące łącza w dokumencie. Polecenie to jest przydatne zwłaszcza wtedy, gdy w dokumencie pojawiły się brakujące łącza, a opcja preferencji umożliwiająca sprawdzanie brakujących łączy w trakcie otwierania dokumentu jest wyłączona. Przydaje się ona również wtedy, gdy po otwarciu dokumentu przyłączony został serwer, na którym przechowywane są obrazy.

  • Aby zmienić ustawienia łączy, otwórz sekcję Obsługa plików w oknie dialogowym Preferencje i sprawdź, czy zaznaczone są opcje Sprawdź łącza przed otwarciem dokumentu i Znajdź brakujące łącza przed otwarciem dokumentu.
  • Aby program InDesign rozpoznawał brakujące łącza, wybierz polecenie Narzędzia > Wyszukiwanie brakujących łączy z menu panelu Łącza.

    Polecenie to nie będzie aktywne jeśli dokument nie zawiera brakujących łączy.

  1. W oknie dialogowym Preferencje, wybierz sekcję Obsługa plików.
  2. Z menu Domyślny folder ponownego łączenia wybierz jedną z następujących opcji, a następnie kliknij OK:

    Ostatnio używany folder ponownego łączenia

    Opcja ta wyświetla ostatnio używany folder wybrany podczas ponownego łączenia, podobnie jak w programie InDesign CS3.

    Pierwotny folder łączenia

    Opcja ta wyświetla pierwotną lokalizację połączonego pliku, podobnie jak w programie InDesign w wersji CS2 i wcześniejszych.

Użyj polecenia Skopiuj łącza do, aby skopiować pliki graficzne do innego folderu i przekierować łącza do skopiowanych plików. Polecenie to przydaje się szczególnie podczas przenoszenia plików na inny nośnik, jak np. z płyty DVD na dysk twardy.

  1. Zaznacz łącza do plików, które chcesz skopiować i wybierz polecenie Narzędzia > Skopiuj łącza do z menu panelu Łącza.
  2. Określ folder, do którego mają być skopiowane połączone pliki i wybierz Zaznacz (Windows) lub Wybierz (Mac OS).

Korzystając z polecenia Łącz ponownie z folderem możesz wskazać folder zawierający pliki o tych samych nazwach, co nieaktualne łącza. Na przykład jeśli aktualne łącza wskazują na obrazy w niskiej rozdzielczości, możesz wybrać inny folder zawierający te same obrazy w wysokiej rozdzielczości. Możesz też wybrać różne rozszerzenia plików, co umożliwia np. zmianę łączy z plików .jpg na .tiff.

Polecenie Łącz ponownie z folderem jest nieaktywne dla zarządzanego wątku programu InCopy do czasu, aż wątek nie zostanie pobrany.

  1. Zaznacz przynajmniej jedno łącze w panelu Łącza.
  2. Wybierz polecenie Łącz ponownie z folderem z menu panelu Łącza.
  3. Określ lokalizację nowego folderu.
  4. Aby użyć innego rozszerzenia, zaznacz opcję Użyj tej samej nazwy pliku, ale z innym rozszerzeniem, a następnie określ nowe rozszerzenie (np. AI, TIFF lub PSD).
  5. Kliknij przycisk Zaznacz (Windows) lub Wybierz (Mac OS).

Polecenie Łącz ponownie rozszerzenia plików pozwala zastępować obrazy, bazując na rozszerzeniach plików. Na przykład, jeśli w dokumencie znajduje się kilkanaście obrazów JPEG, możesz zastąpić je plikami PDF. Pliki o innych rozszerzeniach muszą znajdować się w tych samych folderach, co zastępowane połączone pliki.

  1. Upewnij się, że pliki o innych rozszerzeniach umieszczone są w tym samym folderze, co pliki oryginalne.
  2. Zaznacz przynajmniej jedno łącze w panelu Łącza.
  3. Wybierz polecenie Łącz ponownie rozszerzenia plików z menu panelu Łącza.
  4. Określ rozszerzenie, które ma być zastąpione w zaznaczonych plikach i kliknij Łącz ponownie.

Zastępowanie zaimportowanego pliku za pomocą polecenia Umieść

  1. Wykonaj jedną z następujących czynności:
    • Aby zastąpić zawartość ramki graficznej, a więc np. grafikę importowaną, należy wybrać narzędzie Zaznaczanie  , a następnie zaznaczyć ramkę.

      Aby zastąpić zawartość ramki graficznej, a więc np. grafikę importowaną, należy wybrać narzędzie Położenie, a następnie zaznaczyć obraz.

    • Aby zastąpić zawartość ramki tekstowej, wybierz narzędzie Tekst i umieść punkt wstawiania w ramce, a następnie wybierz polecenie Edycja > Zaznacz wszystko.

  2. Wybierz polecenie Plik > Umieść.
  3. Odszukaj i zaznacz nowy plik.
  4. Sprawdź, czy jest zaznaczona opcja Zastąp zaznaczony element, a następnie kliknij opcję Otwórz.
  5. Kliknij przycisk Otwórz.

Można skopiować pełną ścieżkę połączonego obrazu lub ścieżkę stylu platformy. Kopiowanie pełnej ścieżki obrazu przydaje się do powiadamiania innych członków zespołu o miejscu położenia grafiki. Na przykład możesz skopiować pełną ścieżkę i wkleić ją do wiadomości e-mail. Kopiowanie ścieżki stylu platformy przydaje się podczas tworzenia skryptów lub określania pól obrazów w czasie scalania danych.

  1. Zaznacz łącze w panelu Łącza.
  2. Z menu panelu Łącza wybierz polecenie Kopiuj informacje > Kopiuj pełną ścieżkę lub Kopiuj ścieżkę stylu platformy.
  3. Wklej ścieżkę.

Edycja oryginalnej kompozycji

Polecenie Edytuj oryginał umożliwia edytowanie większości obrazów w aplikacji, w której powstały. Po zapisaniu oryginalnego pliku, dokument w którym jest on osadzony, zostanie uaktualniony nową wersją pliku.

Uwaga:

Jeśli w programie InDesign zamiast grafiki pobierze się do edycji i zaznaczy zarządzaną ramkę graficzną (wyeksportowaną uprzednio do InCopy), to dana grafika otworzy się w programie InCopy.

Edycja oryginalnej ilustracji przy użyciu domyślnej aplikacji

Program InDesign domyślnie korzysta z ustawień systemu operacyjnego podczas określania, za pomocą której aplikacji ma być otwierany oryginalny plik.

  1. Zaznacz jeden lub więcej obrazów na stronie lub w panelu Łącza.
  2. Wykonaj dowolną z następujących czynności:
    • W panelu Łącza kliknij przycisk Edycja oryginału .

    • Wybierz polecenie Edycja > Edycja oryginału.

  3. Po wprowadzeniu zmian w oryginalnej aplikacji, zapisz plik.

Edycja oryginalnej ilustracji przy użyciu innej aplikacji

  1. Zaznacz obraz.
  2. Wybierz polecenie Edycja > Edytuj przy użyciu, a następnie określ, która aplikacja ma być użyta do otwarcia pliku. Jeśli żądana aplikacja nie figuruje w spisie, wybierz polecenie Inne i znajdź odpowiednią aplikację.

Ta zawartość jest licencjonowana na warunkach licencji Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Posty z serwisów Twitter™ i Facebook nie są objęte licencją Creative Commons.

Informacje prawne   |   Zasady prywatności online