Pisząc podręcznik lub dokument referencyjny warto stosować odsyłacze odnoszące czytelnika z jednego fragmentu dokumentu do innego. Przykład: Aby uzyskać więcej informacji, zobacz rozdział „Myszy polne” na stronie 249. Możesz ustalić, czy odsyłacz ma pochodzić od stylu akapitowego, jak np. styl nagłówka, czy od utworzonego zakotwiczonego tekstu. Możesz także określić format odsyłacza, np. Tylko numer strony lub Cały akapit i numer strony.

Wstawianie odsyłaczy

Aby wstawić odsyłacze do dokumentu, skorzystaj z panelu Odsyłacze. Aby otworzyć panel, wybierz Okno > Tekst i tabele > Odsyłacze.

Panel Odsyłacze
A. Aby przejść do miejsca docelowego, kliknij zielony wskaźnik. B. Kliknij numer strony, aby wybrać źródło. C. Kliknij ikonę, aby utworzyć odsyłacz. 

Tekst, do którego odnosi się odsyłacz to tekst docelowy. Tekst wygenerowany z tekstu docelowego to odsyłacz źródłowy.

Wstawiając odsyłacz do dokumentu możesz wybrać z kilku gotowych formatów lub stworzyć własny format. Możesz zastosować styl znakowy dla całego źródła odsyłacza lub do tekstu w samym odsyłaczu. Formaty odsyłaczy mogą być zsynchronizowane w całej księdze.

Tekst źródła odsyłacza można edytować i przenosić do następnych wierszy.

Uwaga:

Aby odsyłacze były umieszczane w eksportowanych plikach Adobe PDF, należy zaznaczyć opcję Hiperłącza w oknie dialogowym Eksport Adobe PDF w programie InDesign. Aby odsyłacze były umieszczane w eksportowanych plikach SWF, należy zaznaczyć opcję Dołącz hiperłącza w oknie dialogowym Eksportuj plik SWF.

Wstawianie odsyłaczy
Wstawianie odsyłaczy
  1. Umieść punkt wstawiania w miejscu, w którym ma być umieszczony odsyłacz.
  2. Wykonaj jedną z następujących czynności, aby otworzyć okno dialogowe Nowy odsyłacz.

    • Wybierz kolejno Tekst > Hiperłącza i odsyłacze > Wstaw odsyłacz.

    • Wybierz kolejno Okno > Tekst i tabele > Odsyłacze, a następnie z menu panelu wybierz polecenie Wstaw odsyłacz.

    • W panelu kliknij przycisk Utwórz nowy odsyłacz.

  3. W oknie dialogowym, z menu Połącz z wybierz opcję Akapit lub Zakotwiczenie tekstu.

    Po wybraniu opcji Akapit możesz utworzyć odsyłacz do dowolnego akapitu w określonym dokumencie.

    Po wybraniu opcji Zakotwiczenie tekstu możesz utworzyć odsyłacz do dowolnego tekstu, w którym utworzone zostało miejsce docelowe hiperłącza. (Zobacz Tworzenie miejsca docelowego hiperłącza). Utworzenie zakotwiczenia tekstu jest szczególnie przydatne, gdy chcesz użyć tekstu innego, niż obecny akapit docelowy.

  4. W polu Dokument wybierz dokument zawierający miejsce docelowe hiperłącza. Wyskakujące menu zawiera wszystkie otwarte dokumenty, które zostały zapisane. Jeżeli potrzebny dokument nie jest otwarty, wybierz opcję Przeglądaj, odszukaj odpowiedni plik, a następnie kliknij przycisk Otwórz.
  5. W polu po lewej kliknij styl akapitowy, aby zawęzić wybór, a następnie zaznacz akapit, dla którego ma być zastosowany styl. (W przypadku, gdy zaznaczona została opcja Zakotwiczenie tekstu, należy wybrać zakotwiczenie).
    Możesz także wyszukać konkretny akapit na liście akapitów za pomocą paska wyszukiwania. Obsługiwane są następujące typy wyszukiwania:

    • Wyszukaj od początku – znajduje sekwencję od początku akapitu.
    • Wyszukaj wszędzie – znajduje sekwencję z dowolnego miejsca w akapicie.
  6. Z menu Format wybierz format odsyłacza, który ma być użyty.

    Możesz edytować te formaty odsyłaczy lub stworzyć własne. Zobacz Korzystanie z formatów odsyłaczy.

  7. Skonfiguruj opcje wyglądu odsyłacza w pliku PDF.

  8. Kliknij OK.

Po wstawieniu odsyłacza na początku akapitu docelowego pojawi się znacznik zakotwiczenia tekstu . Znacznik ten stanie się widoczny po wybraniu polecenia Tekst > Pokaż znaki ukryte. Jeśli znacznik ten zostanie przeniesiony lub usunięty, odsyłacz będzie nierozpoznany.

Korzystanie z formatów odsyłaczy

W oknie dialogowym Nowy format odsyłacza domyślnie pojawia się kilkanaście formatów odsyłaczy. Te formaty można edytować, kasować lub tworzyć własne.

Uwaga:

Jeśli w Twoim dokumencie formaty odsyłaczy zostały wykasowane lub edytowane i chcesz powrócić do formatów domyślnych, możesz wybrać polecenie Wczytaj formaty odsyłaczy z menu panelu i otworzyć dokument z formatami, które nie poddano edycji. Możesz także zsynchronizować formaty odsyłaczy w księdze.

Tworzenie i edycja formatów odsyłaczy

W przeciwieństwie do innych ustawień predefiniowanych, formaty odsyłaczy mogą być edytowane lub usuwane. Podczas edytowania formatu odsyłacza każdy odsyłacz źródłowy korzystający z tego formatu jest automatycznie aktualizowany.

  1. Wykonaj dowolną z następujących czynności.
    • Z menu panelu Odsyłacze wybierz polecenie Zdefiniuj formaty odsyłaczy.

    • Podczas tworzenia lub edytowania odsyłacza kliknij przycisk Utwórz lub edytuj formaty odsyłaczy .

  2. W oknie dialogowym Formaty odsyłaczy wykonaj jedną z następujących czynności:
    • Aby edytować format, zaznacz go po lewej stronie.

    • Aby utworzyć format, zaznacz format na którym ma bazować nowy format, a następnie kliknij przycisk Utwórz format . Stworzony zostanie duplikat zaznaczonego formatu.

  3. W polu Nazwa określ nazwę formatu.
  4. W polu tekstowym Definicja możesz dodawać lub usuwać tekst, w zależności od potrzeb. Kliknij ikonę bloku podstawy , aby wstawić z menu bloki podstawy. Kliknij ikonę znaków specjalnych , aby wybrać myślniki, spacje, znaki zapytania lub inne znaki specjalne.
  5. Aby zastosować styl znakowy dla całego odsyłacza, wybierz Styl znakowy dla odsyłacza, a następnie utwórz styl znakowy lub wybierz go z menu.

    Możesz także użyć bloku podstawy stylu znakowego, aby zastosować styl znakowy do tekstu odsyłacza.

  6. Kliknij przycisk Zapisz, aby zapisać zmiany. Kliknij OK po zakończeniu.

Bloki podstawy odsyłacza

Blok podstawy

Efekt

Przykład

Numer strony

Wstawia numer strony.

na stronie <pageNum/>

na stronie 23

Numer akapitu

Wstawia numer akapitu w odsyłaczu do listy numerowanej.

Zobacz <paraNum/>

Zobacz 1

W tym przykładzie został użyty tylko numer „1” z akapitu „1. Zwierzęta”.

Tekst akapitu

Wstawia tekst akapitu bez numeru akapitu w odsyłaczu do listy numerowanej.

Zobacz „<paraText/>”

Zobacz „Zwierzęta”

W tym przykładzie został użyty tylko tekst „Zwierzęta” z akapitu „1. Zwierzęta”.

Cały akapit

Wstawia cały akapit wraz numerem i tekstem.

Zobacz „<fullPara/>”

Zobacz „1. Zwierzęta”

Akapit częściowy

Pozwala na tworzenie odsyłacza do pierwszej części akapitu do określonego ogranicznika, np. dwukropka lub pauzy.

Zobacz <fullPara delim=”:”includeDelim=”false”/>

Zobacz Rozdział 7

W tym przykładzie z tytułu „Rozdział 7: Psy i koty” została użyta tylko część „Rozdział 7”.

Określ rodzaj ogranicznika (np. „:”, jak w tym przykładzie) i zdecyduj, czy ogranicznik ma być wyłączony („false” lub „0”), czy włączony („true” lub „1”) do odsyłacza źródłowego.

Zobacz Tworzenie odsyłaczy do akapitów częściowych.

Nazwa zakotwiczenia tekstu

Wstawia nazwę zakotwiczenia tekstu. Zakotwiczenia tekstu można utworzyć wybierając z menu panelu Hiperłącza polecenie Nowe miejsce docelowe hiperłącza.

Zobacz <txtAnchrName/>

Zobacz Rysunek 1

Numer rozdziału

Wstawia numer rozdziału.

w rozdziale <chapNum/>

w rozdziale 3

Nazwa pliku

Wstawia nazwę pliku dokumentu docelowego.

w pliku <fileName/>

w pliku newsletter.indd

Styl znakowy

Stosuje styl znakowy do tekstu odsyłacza.

Zobacz <cs name=”bold”><fullPara/></cs> na stronie <pageNum>

Zobacz Zwierzęta na stronie 23.

Określ nazwę stylu znakowego i wprowadź tekst, do którego ma być zastosowany ten styl w miejscu pomiędzy znacznikami <cs name=””> i </cs>.

Zobacz Stosowanie stylów znakowych w odsyłaczu.

Tworzenie odsyłaczy do akapitów częściowych

Możesz sprawić, aby format odsyłacza zawierał tylko pierwszą część akapitu. Na przykład, jeśli nagłówek Twojego dokumentu zawiera tekst w stylu „Rozdział 7—Od Granady do Barcelony”, możesz stworzyć odsyłacz odnoszący się tylko do części „Rozdział 7”.

Odsyłacz do akapitu częściowego
Odsyłacz do akapitu częściowego

A. Źródło odsyłacza kończy się na znaku pauzy (^_) B. Argument „false” wyklucza znak pauzy ze źródła 

Wstawiając blok podstawy Akapitu częściowego należy pamiętać o dwóch rzeczach. Po pierwsze, aby określić ogranicznik między znakami cytatu. Ogranicznik jest znakiem kończącym akapit. Najczęstsze typy ograniczników to dwukropki (Rozdział 7: Granada), kropki (Rozdział 7. Granada) i myślniki (Rozdział 7—Granada). Aby wstawić znaki specjalne, np. znak pauzy (^_), spację firetową (^m) lub znaki punktora (^8), kliknij ikonę Znaki specjalne i z wyświetlonego menu wybierz odpowiednią opcję.

Po drugie, zdecyduj czy znak ogranicznika ma być zawarty w odsyłaczu (Rozdział 7—) lub nie (Rozdział 7). Użyj argumentu includeDelim=”false”, aby wykluczyć ogranicznik lub includeDelim=”true”, aby umieścić go w odsyłaczu. Zamiast argumentów „false” i „true” możesz użyć odpowiednio „0” i „1”.

Stosowanie stylów znakowych w odsyłaczu

Jeśli chcesz uwydatnić jakąś część tekstu odsyłacza, możesz skorzystać z bloku podstawy Stylu znakowego. Blok ten składa się z dwóch znaczników. Znacznik <cs name=”stylename”> określa, który styl jest stosowany, a znacznik </cs> określa koniec stylu znakowego. Każdy tekst lub blok podstawy znajdujący się pomiędzy tymi znacznikami zostanie sformatowany według określonego stylu.

Stosowanie stylu znakowego
Stosowanie stylu znakowego do fragmentu odsyłacza

A. Ten znacznik stosuje styl znakowy o nazwie „Czerwony”. B. Ten znacznik wskazuje koniec formatowania stylu znakowego. C. Styl znakowy „Pogrubiony” stosowany jest do reszty źródła odsyłacza. 
  1. Utwórz styl znakowy, który chcesz użyć.
  2. W oknie dialogowym Formaty odsyłaczy utwórz lub edytuj format, który chcesz zastosować.
  3. W polu Definicja wybierz tekst i bloki podstawy, do których chcesz zastosować styl znakowy.
  4. Z menu po prawej stronie listy definicji wybierz Styl znakowy.
  5. Między znakami cytatu wpisz nazwę stylu znakowego, dokładnie taką jaka widnieje w panelu Style znakowe.

    Przy wpisywaniu nazwy stylu brana jest pod uwagę wielkość liter. Jeśli styl znakowy znajduje się w grupie, wpisz nazwę grupy zakończoną dwukropkiem, a następnie nazwę stylu znakowego, np. Grupa stylów 1: Czerwony.

  6. Kliknij przycisk Zapisz, aby zapisać format, a następnie kliknij OK.

Wczytywanie (importowanie) formatów odsyłaczy

Podczas wczytywania formatów odsyłaczy z innego dokumentu nowe formaty zastępują wcześniejsze formaty o tej samej nazwie.

W programie InCopy można importować formaty odsyłaczy tylko w dokumentach samodzielnych. Nie można importować formatów z dokumentu InCopy do dokumentu InDesign. Jeśli po odłożeniu wątku nastąpi konflikt między nowym lub zmodyfikowanym formatem programu InCopy a formatem programu InDesign, to format InDesign jest traktowany jako ważniejszy.

  1. Z menu panelu Odsyłacze wybierz polecenie Wczytaj formaty odsyłaczy.

  2. Dwukrotnie kliknij dokument zawierający formaty odsyłaczy, które mają być zaimportowane.

Możesz też udostępniać formaty odsyłaczy dla wszystkich dokumentów podczas synchronizacji księgi.

Usuwanie formatów odsyłaczy

Nie można usunąć formatu odsyłacza, który został zastosowany do odsyłaczy w dokumencie.

  1. W oknie dialogowym Formaty odsyłaczy zaznacz format, który ma zostać usunięty.
  2. Kliknij przycisk Usuń format .

Zarządzanie odsyłaczami

Po wstawieniu odsyłacza na panelu Odsyłacze widoczny będzie jego status. Przykładowo ikony wskazują, czy tekst docelowy znajduje się na stole montażowym , na stronie wzorcowej , na warstwie ukrytej , wśród tekstu nie mieszczącego się lub wśród tekstu ukrytego . Odsyłacze odnoszące się do tych obszarów docelowych będą nierozpoznane. Panel informuje także o tym, czy akapit docelowy był edytowany (inaczej nieaktualny) lub czy go brakuje . Tekst docelowy jest brakujący, jeśli sam tekst lub plik, który go zawiera, nie może być znaleziony. Najedź kursorem na dowolną ikonę, aby wyświetlić jej krótki opis.

W programie InCopy można zarządzać odsyłaczami wyłącznie w wątkach pobranych do edycji.

Uaktualnienie odsyłaczy

Ikona aktualizacji informuje, że tekst docelowy odsyłacza został zmieniony lub edytowany został tekst źródła odsyłacza. Odsyłacz można w prosty sposób uaktualnić. Jeśli miejsce docelowe zostanie przeniesione na inną stronę, odsyłacz jest uaktualniany automatycznie.

Przy uaktualnianiu odsyłacza jakiekolwiek zmiany w formatowaniu tekstu źródła zostaną usunięte.

Przy drukowaniu pojawi się komunikat informujący o nieaktualnych lub nierozpoznanych odsyłaczach, jeśli zostaną wykryte.

Uwaga:

W celu informowania o nieaktualnych lub nierozpoznanych odsyłaczach można też skorzystać z panelu Inspekcja wstępna. Podczas definiowania profilu, w części Tekst wybierz Odsyłacze. Zobacz Definiowanie profilów inspekcji wstępnej.

  1. Zaznacz jeden lub więcej nieaktualnych odsyłaczy. Aby uaktualnić wszystkie odsyłacze, upewnij się, że żaden nie jest zaznaczony.
  2. Wykonaj dowolną z następujących czynności:
    • W panelu Odsyłacze kliknij przycisk Uaktualnij odsyłacze .

    • W menu panelu Odsyłacze wybierz polecenie Uaktualnij odsyłacze.

    • Wybierz kolejno Tekst > Hiperłącza i odsyłacze > Uaktualnij odsyłacze.

Aby uaktualnić wszystkie odsyłacze w księdze, z menu panelu księgi wybierz polecenie Uaktualnij wszystkie odsyłacze. Pojawi się komunikat informujący o wszelkich nierozpoznanych odsyłaczach.

Jeśli brakujący tekst docelowy został przeniesiony do innego dokumentu lub gdy została zmieniona nazwa dokumentu zawierającego tekst docelowy, możesz dokonać ponownego łączenia odsyłacza. Przy ponownym łączeniu zmiany w odsyłaczu źródłowym zostaną usunięte.

  1. W panelu Odsyłacze wybierz odsyłacz, który chcesz ponownie połączyć.

  2. Z menu panelu wybierz polecenie Łącz ponownie odsyłacz.

  3. Znajdź dokument, w którym pojawia się tekst docelowy, a następnie kliknij Otwórz.

Jeśli w danym dokumencie pojawia się więcej tekstów docelowych, możesz ponownie połączyć pozostałe odsyłacze.

Edycja odsyłaczy

Aby zmienić wygląd odsyłacza źródłowego lub określić inny format, należy edytować odsyłacz. W przypadku edycji odsyłacza łączącego z innym dokumentem, dokument ten zostanie automatycznie otwarty.

  1. Wykonaj dowolną z następujących czynności:
    • Wybierz kolejno Tekst > Hiperłącza i odsyłacze > Opcje odsyłaczy.

    • W panelu Odsyłacze dwukrotnie kliknij odsyłacz, który chcesz edytować.

    • W menu panelu Odsyłacze zaznacz odsyłacz i wybierz polecenie Opcje odsyłaczy.

  2. Zmodyfikuj odsyłacz, a następnie kliknij OK.

Usuwanie odsyłaczy

Przy usuwaniu odsyłacza, odsyłacz źródłowy zostanie przekonwertowany do tekstu.

  1. W panelu Odsyłacze wybierz odsyłacze, które mają zostać usunięte.

  2. W menu panelu kliknij ikonę Usuń lub wybierz polecenie Usuń odsyłacz.

  3. Kliknij przycisk Tak, aby zatwierdzić usunięcie.

Aby zupełnie usunąć odsyłacz, możesz także zaznaczyć jego źródło i je usunąć.

Edycja tekstu źródła odsyłacza

Tekst źródła odsyłacza można edytować. Zaletą edytowania tekstu odsyłacza jest możliwość zmiany światła i odstępów między wierszami na potrzeby dopasowania układu lub dokonywanie innych zmian. Wadą jest to, że podczas uaktualniania lub ponownego łączenia odsyłacza, lokalne zmiany formatowania zostaną usunięte.

Ta zawartość jest licencjonowana na warunkach licencji Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Posty z serwisów Twitter™ i Facebook nie są objęte licencją Creative Commons.

Informacje prawne   |   Zasady prywatności online