Podręcznik użytkownika Anuluj

Przyciski

  1. Podręcznik użytkownika programu InDesign
  2. Poznaj program InDesign
    1. Wprowadzenie do programu InDesign
      1. Co nowego w programie InDesign
      2. Wymagania systemowe
      3. Często zadawane pytania
      4. Korzystanie z bibliotek Creative Cloud
    2. Przestrzeń robocza
      1. Podstawy pracy z przestrzenią roboczą
      2. Toolbox
      3. Ustawianie preferencji
      4. Dotykowa przestrzeń robocza
      5. Domyślne skróty klawiaturowe
      6. Odzyskiwanie dokumentów i cofanie zmian
      7. Rozszerzenie Capture
  3. Tworzenie dokumentów i projektowanie ich układu
    1. Dokumenty i strony
      1. Tworzenie dokumentów
      2. Praca ze stronami wzorcowymi
      3. Praca ze stronami dokumentu
      4. Ustawianie rozmiaru strony, marginesów i spadów
      5. Praca z plikami i szablonami
      6. Tworzenie plików księgi
      7. Dodawanie podstawowej numeracji stron
      8. Numerowanie stron, rozdziałów i sekcji
      9. Konwertowanie dokumentów QuarkXPress i PageMaker
      10. Udostępnianie zawartości
      11. Podstawy zarządzania obiegiem pracy
      12. Zapisywanie dokumentów
    2. Siatki
      1. Siatki
      2. Formatowanie siatek
    3. Narzędzia pomocnicze do tworzenia układu
      1. Miarki
  4. Dodawanie zawartości
    1. Tekst
      1. Dodawanie tekstu do ramek
      2. Wątkowanie tekstu
      3. Obsługa języka arabskiego i hebrajskiego w programie InDesign
      4. Tworzenie tekstu na ścieżce
      5. Punktowanie i numerowanie
      6. Glify i znaki specjalne
      7. Składanie tekstu
      8. Zmienne tekstowe
      9. Generowanie kodów QR
      10. Edycja tekstu
      11. Wyrównywanie tekstu
      12. Oblewanie tekstem wokół obiektów
      13. Zakotwiczone obiekty
      14. Zawartość połączona
      15. Formatowanie akapitów
      16. Formatowanie znaków
      17. Znajdowanie i zastępowanie
      18. Słowniki ortograficzne i językowe
    2. Typografia
      1. Korzystanie z czcionek w programie InDesign
      2. Kerning i światło
    3. Formatowanie tekstu
      1. Formatowanie tekstu
      2. Tabulatory i wcięcia
    4. Recenzowanie tekstu
      1. Śledzenie i przeglądanie zmian
      2. Dodawanie notatek redaktorskich w programie InDesign
      3. Importowanie komentarzy z pliku PDF
    5. Dodawanie odwołań
      1. Tworzenie spisu treści
      2. Przypisy dolne
      3. Tworzenie indeksu
      4. Przypisy końcowe
      5. Podpisy
    6. Style
      1. Style akapitowe i znakowe
      2. Style obiektowe
      3. Inicjały i style zagnieżdżone
      4. Praca ze stylami
      5. Interlinia
    7. Tabele
      1. Formatowanie tabel
      2. Tworzenie tabel
      3. Style tabeli i komórki
      4. Zaznaczanie i edycja tabel
      5. Obrysy i wypełnienia tabel
    8. Interaktywność
      1. Hiperłącza
      2. Dynamiczne dokumenty PDF
      3. Zakładki
      4. Przyciski
      5. Formularze
      6. Animacja
      7. Odsyłacze
      8. Pliki PDF ze strukturą
      9. Przejścia stron
      10. Filmy i dźwięki
      11. Formularze
    9. Grafika
      1. Informacje o ścieżkach i kształtach
      2. Rysowanie narzędziem Ołówek
      3. Rysowanie narzędziem Pióro
      4. Stosowanie ustawień linii (obrysów)
      5. Ścieżki i kształty złożone
      6. Edycja ścieżek
      7. Ścieżki przycinające
      8. Zmiana wyglądu narożnika
      9. Wyrównywanie i rozmieszczanie obiektów
      10. Grafika połączona i osadzona
      11. Integrowanie zasobów z systemu AEM
    10. Kolory i przezroczystość
      1. Stosowanie koloru
      2. Używanie kolorów z grafiki importowanej
      3. Praca z próbkami
      4. Mieszanie farb
      5. Tinty
      6. Informacje o kolorach dodatkowych i podstawowych
      7. Mieszanie kolorów
      8. Gradienty
      9. Spłaszczanie grafiki zawierającej przezroczystość
      10. Dodawanie efektów przezroczystości
  5. Udostępnianie
    1. Udostępniaj i współpracuj        
    2. Udostępnianie do recenzji
    3. Recenzja udostępnionego dokumentu InDesign
    4. Zarządzanie opiniami 
  6. Publikuj
    1. Eksportowanie i publikowanie
      1. Funkcja Publish Online
      2. Eksport zawartości do formatu EPUB
      3. Opcje Adobe PDF
      4. Eksport zawartości do formatu HTML
      5. Eksportowanie do formatu Adobe PDF
      6. Eksportowanie do formatu JPEG
      7. Eksportowanie do formatu HTML
      8. Omówienie rozwiązań DPS i AEM Mobile
    2. Drukowanie
      1. Drukowanie broszur
      2. Znaczniki drukarskie i spady
      3. Drukowanie dokumentów
      4. Farby, rozbarwienia i liniatura rastra
      5. Nadruk
      6. Tworzenie plików PostScript i EPS
      7. Inspekcja wstępna plików przed przekazaniem
      8. Drukowanie miniaturek i bardzo dużych dokumentów
      9. Przygotowywanie plików PDF dla usługodawców
      10. Przygotowanie do drukowania rozbarwień
  7. Rozszerzanie programu InDesign
    1. Automatyzacja
      1. Scalanie danych
      2. Wtyczki
      3. Rozszerzenie Capture w programie InDesign
      4. Tworzenie skryptów
Uwaga:

Równy język: począwszy od wersji programu InDesign 2022 (wersja 17.0), zmieniamy wykluczającą terminologię, aby odzwierciedlić podstawowe wartości Adobe dotyczące integracji. Wszelkie odniesienia do strony „nadrzędnej” są zamienione na stronę „wzorcową” w naszych artykułach Pomocy w następujących językach: angielskim, duńskim, węgierskim, hiszpańskim, włoskim, brazylijskim, portugalskim i japońskim.

Uwaga:

W programie InDesign od wersji 15.0 nie są już dostępne formaty plików związane z programem Flash (.FLV i .F4V). Wszystkie opcje dotyczące tych formatów zostały usunięte z odpowiednich paneli. Szczegółowe informacje: Zakończenie obsługi programu Flash Player | Wpływ na program InDesign.

Tworzenie przycisków

W dokumencie można utworzyć przyciski, które będą wykonywać określone zadania po wyeksportowaniu tego dokumentu do formatów EPUB z układem stałym lub PDF. Możesz na przykład utworzyć przycisk przenoszący na inną stronę dokumentu lub otwierający stronę internetową.

Ustawienia przycisku do odtwarzania filmu w wyeksportowanym pliku PDF.

Podczas tworzenia przycisku można:

Uwaga:

Podczas pracy nad przyciskami i dokumentami dynamicznymi wybierz przestrzeń roboczą PDF — Interaktywność.

Tworzenie przycisku

  1. Użyj narzędzia Pióro lub narzędzia rysowania, takiego jak Prostokąt lub Elipsa, aby narysować kształt przycisku. W razie konieczności użyj narzędzia Tekst, aby dodać do przycisku tekst, np. „Dalej” lub „Zakup”.
    Uwaga:

    Jeśli tworzysz przyciski nawigacyjne (takie jak Następna strona lub Poprzednia strona), które występują na wielu stronach, dodaj je do strony wzorcowej, tak aby nie trzeba było tworzyć ich ponownie na każdej stronie dokumentu. Przyciski te pojawią się na wszystkich stronach dokumentu, do których zastosowany jest wzorzec.

  2. Za pomocą narzędzia Zaznaczanie  zaznacz obraz, kształt lub ramkę tekstową do przekonwertowania.

    Na przycisk nie można przekonwertować filmu, dźwięku ani plakatu.

  3. Na panelu Przyciski i formularze kliknij ikonę Konwertuj na przycisk . (Aby otworzyć ten panel, wybierz polecenie Okno > Interaktywne > Przyciski i formularze). Można również wybrać polecenie Obiekt > Interaktywny > Konwertuj na przycisk.

    Konwertuj na przycisk

  4. Wykonaj jedną z następujących czynności na panelu Przyciski i formularze:

    • Z menu rozwijanego Rodzaj wybierz opcję Przycisk.
    • W polu tekstowym Nazwa podaj nazwę przycisku, aby odróżnić go od innych tworzonych przycisków.
    • Określ zdarzenie,które wyzwoli pożądane działanie.
    • Wybierz operację wykonywaną przez przycisk, aby zdefiniować, co się stanie po wyzwoleniu zdarzenia w wyeksportowanym pliku EPUB o układzie stałym lub PDF. Zobacz Wprowadzanie interaktywności do przycisków.
  5. Zanim wyeksportujesz dokument do interaktywnego formatu EPUB o układzie stałym lub PDF, przetestuj przycisk za pomocą panelu Podgląd (Okno > Interaktywne > Podgląd interaktywności EPUB). Dokument można również opublikować w Internecie za pomocą funkcji Publikuj online.

Dodawanie przycisku z panelu Przykładowe przyciski

Panel Przykładowe przyciski zawiera kilka gotowych przycisków, które możesz przeciągnąć i umieścić w swoim dokumencie. Wśród nich znajdują się takie efekty, jak pióra gradientu czy cienie, z nieco zmienionym wyglądem dla wyglądu Rollover. Przykładowym przyciskom jest także przypisane działanie. Przykładowo przyciskom strzałek przypisane jest działanie Przejdź do następnej strony lub Przejdź do poprzedniej strony. Przyciski te mogą być odpowiednio zmodyfikowane.

Panel Przykładowe przyciski jest biblioteką obiektów. Podobnie jak w przypadku innych bibliotek obiektów możliwe jest dodawanie przycisków do panelu lub usuwanie tych nieprzydatnych. (Zobacz Korzystanie z bibliotek obiektów). Przykładowe przyciski przechowywane są w pliku ButtonLibrary.indl, znajdującym się w podfolderze Presets/Button Library w folderze aplikacji InDesign.

  1. Wybierz opcję Przykładowe przyciski i formularze z menu panelu Przyciski i formularze, aby otworzyć panel Przykładowe przyciski i formularze.

    Otwieranie panelu Przykładowe przyciski i formularze

  2. Przeciągnij przycisk z panelu Przykładowe przyciski i formularze do dokumentu. Jeśli chcesz, aby przyciski nawigacyjne były obecne na każdej stronie, dodaj je do strony wzorcowej.

    Przykładowe przyciski i formularze
    Panel Przykładowe przyciski i formularze

  3. Zaznacz przycisk za pomocą narzędzia Zaznaczanie, a następnie zmodyfikuj go stosownie do potrzeb za pomocą panelu Przyciski i formularze.

    Edytując przykładowe przyciski należy pamiętać o następujących kwestiach:

    • Dodając tekst do przycisku pamiętaj, aby skopiować i wkleić tekst ze stanu Zwykły do stanu Rollover. W przeciwnym razie tekst przycisku w pliku EPUB o układzie stałym lub PDF będzie znikać, gdy przycisk taki zostanie wskazany myszą.

    • Rozmiar przycisków można zmieniać. Jeśli przeciągniesz parę przycisków strzałek Następna strona / Poprzednia strona i zmienisz rozmiar pierwszego z nich, zaznacz drugi przycisk i wybierz kolejno polecenia Obiekt > Przekształć ponownie > Przekształć ponownie.

  4. Zanim wyeksportujesz dokument do interaktywnego formatu EPUB o układzie stałym lub PDF, przetestuj przycisk za pomocą panelu Podgląd (Okno > Interaktywne > Podgląd interaktywności EPUB). Dokument można również opublikować w Internecie za pomocą funkcji Publikuj online.

Konwersja przycisku na obiekt

Podczas konwertowania przycisku na obiekt jego zawartość pozostaje na stronie bez właściwości typowych dla przycisku. Cała zawartość powiązana z innymi stanami przycisku również zostanie usunięta.

  1. Wybierz narzędzie Zaznaczanie  i zaznacz przycisk.
  2. Wybierz polecenie Obiekt > Interaktywne > Konwertuj na obiekt.

Wprowadzanie interaktywności do przycisków

Przycisk powoduje odtwarzanie dźwięku
Ten przycisk skonfigurowano tak, aby odtwarzał dźwięk po kliknięciu przycisku myszy.

Program InDesign umożliwia tworzenie i edytowanie efektów interaktywnych oraz zarządzanie nimi. Takie efekty mogą pozostać aktywne po wyeksportowaniu dokumentu w formacie EPUB z układem stałym lub PDF.

Załóżmy na przykład, że chcemy utworzyć przycisk powodujący odtworzenie dźwięku w dokumencie PDF. Plik dźwiękowy umieszczamy w dokumencie programu InDesign. Potem tworzymy przycisk, który spowoduje odtworzenie tego dźwięku, gdy zostanie kliknięty w dokumencie PDF.

W tym przykładzie kliknięcie przyciskiem myszy jest zdarzeniem, natomiast odtworzenie dźwięku jest operacją.

Uwaga:

Niektóre operacje obsługiwane są zarówno przez pliki PDF, jak i EPUB, inne tylko przez pliki PDF lub EPUB. Podczas eksportowania do formatu EPUB z układem stałym nie należy zaznaczać opcji Tylko PDF. Nie powinno się również wybierać opcji Tylko EPUB, jeśli dokument jest eksportowany do formatu PDF.

Dodawanie operacji do przycisków

Operacje można przypisywać do różnych zdarzeń. Na przykład w wyeksportowanym pliku PDF, po przesunięciu wskaźnika myszy w obszar przycisku może być odtwarzany dźwięk, a po wciśnięciu i zwolnieniu przycisku myszy - film. Do jednego zdarzenia można przypisać wiele operacji. Na przykład można utworzyć operację, która odtwarza film i ustawia skalę powiększenia na rzeczywistą wielkość.

  1. Wybierz narzędzie Zaznaczanie i zaznacz utworzony przycisk.
  2. Na panelu Przyciski i formularze wybierz zdarzenie (np. Po zwolnieniu przycisku), aby określić sposób aktywowania operacji.

  3. Kliknij przycisk ze znakiem plus obok sekcji Operacje, a następnie przypisz operację do danego zdarzenia.
  4. Określ ustawienia operacji.

    Na przykład wybierając Przejdź do pierwszej strony należy określić powiększenie. Wybierając Przejdź do adresu URL należy określić adres strony internetowej. Niektóre operacje (np. Przejdź do następnego widoku) nie mają dodatkowych ustawień.

  5. W razie konieczności możesz dodawać dowolną liczbę operacji do danego zdarzenia.
  6. Aby przetestować dany przycisk, wyeksportuj dokument do pliku EPUB z układem stałym lub PDF i otwórz wyeksportowany plik. Eksportując do pliku PDF upewnij się, że zaznaczona jest opcja Elementy interaktywne.

Typy zdarzeń

Zdarzenia decydują o tym, w jaki sposób operacje przycisków uaktywniają się po wyeksportowaniu dokumentu do pliku EPUB z układem stałym lub PDF. (W programie Acrobat zdarzenia nazywane są wyzwalaczami.)

Po zwolnieniu lub dotknięciu

Gdy użytkownik zwalnia przycisk myszy po kliknięciu. Jest to najczęściej używane zdarzenie, ponieważ daje użytkownikowi ostatnią szansę przesunięcia kursora z obszaru przycisku i uniknięcia aktywowania operacji.

Po kliknięciu

Gdy użytkownik wciśnie przycisk myszy (bez zwalniania). Jeżeli nie ma konkretnego powodu przemawiającego za użyciem stanu Efekt kliknięcia, lepiej jest używać stanu Efekt zwolnienia przycisku, który daje użytkownikom ostatnią szansę na rezygnację z aktywowania operacji.

Po przesunięciu wskaźnika

Gdy wskaźnik myszy wkracza w obszar przycisku, definiowany przez jego obwiednię.

Po opuszczeniu przez wskaźnik

Gdy wskaźnik myszy opuszcza obszar przycisku.

On Focus (PDF)

Gdy przycisk w pliku PDF zostanie wybrany — za pomocą myszy albo przez naciśnięcie klawisza Tab.

On Blur (PDF)

Gdy wybór przenosi się na inny przycisk lub pole formularza w pliku PDF.

Typy operacji

Tworząc operację decydujesz, jaki ma być efekt wystąpienia określonego zdarzenia (najczęściej kliknięcia przycisku). W programie InDesign można przypisać do zdarzeń następujące operacje:

Idź do miejsca docelowego

Przechodzi do określonego zakotwiczenia tekstu przy użyciu panelu Zakładki lub Hiperłącza. Zobacz Tworzenie przeskoków do zakotwiczeń tekstu.

Przejdź do pierwszej/ostatniej/następnej/poprzedniej strony

Przechodzi na pierwszą, ostatnią, poprzednią lub następną stronę w pliku EPUB o układzie stałym lub PDF. Opcje z menu Powiększenie pozwalają określić sposób wyświetlania strony.

Przejdź do adresu URL

Otwiera stronę internetową pod podanym adresem URL.

Pokaż/Ukryj przyciski i formularze

Przełącza pomiędzy wyświetlaniem lub ukrywaniem określonych przycisków w wyeksportowanym pliku EPUB z układem stałym lub PDF. Na przykład, aby dany przycisk był wyświetlany po wskazaniu myszą innego przycisku, możesz ukryć przycisk docelowy do czasu jego uruchomienia i utworzyć operację, która wyświetli ukryty przycisk przy najeździe. Zobacz Wyświetlanie innego przycisku przy najeździe.

Dotyczy tylko formatu EPUB i funkcji Publish Online

Animacja

Umożliwia odtwarzanie, pauzę, zatrzymywanie lub wznawianie wybranej animacji. W menu Animacja pojawiają się tylko animacje dodane do dokumentu.

Przejdź do strony

Przechodzi do określonej strony pliku EPUB.

Przejdź do stanu

Przechodzi do określonego stanu w obiekcie o wielu stanach. Na przykład, jeśli obiekt o wielu stanach zawiera kilka obrazów, będących różnymi stanami, można użyć tej operacji, aby wyświetlić wybrany obraz.

Przejdź do następnego/poprzedniego stanu

Przechodzi do następnego lub poprzedniego stanu w obiekcie o wielu stanach. Opcje te przydają się szczególnie do klikania w pokazie slajdów. Zobacz Tworzenie obiektów o wielu stanach.

Dźwięk

Umożliwia odtwarzanie, pauzę, zatrzymywanie lub wznawianie pliku dźwiękowego. W menu Dźwięk pojawiają się tylko dźwięki dodane do dokumentu.

Wideo

Umożliwia odtwarzanie, pauzę, zatrzymywanie lub wznawianie wybranego filmu. W menu Wideo pojawiają się tylko filmy dodane do dokumentu.

Dotyczy tylko formatu PDF

Wyczyść formularz

Czyści wszystkie dane wstawione w polach formularza i przywraca formularz do pierwotnego stanu.

Przejdź do następnego widoku

Przechodzi na stronę oglądaną przed przejściem do poprzedniego widoku. Podobnie jak przycisk Dalej w przeglądarkach internetowych jest dostępny tylko wtedy, gdy ktoś wcześniej nacisnął przycisk Wstecz, ta opcja jest dostępna tylko wtedy, gdy użytkownik wcześniej przeszedł do poprzedniego widoku.

Przejdź do poprzedniego widoku

Przechodzi na ostatnio oglądaną stronę w dokumencie PDF lub powraca do ostatnio używanej wartości powiększenia.

Otwórz plik

Uruchamia i otwiera podany plik. Jeżeli określi się plik inny niż dokument PDF, to czytnik musi znać aplikację źródłową tego pliku, aby móc go otworzyć. Ścieżki należy podawać w formacie bezwzględnym (np. C:\docs\przykład.pdf).

Drukuj formularz

Otwiera okno dialogowe drukowania, umożliwiając wydrukowanie formularza.

Prześlij formularz

Wysyła dane wstawione w polach formularza na podany adres URL. Aby wysłać wypełniony formularz na adres e-mail, trzeba wpisać w polu URL frazę mailto: i odpowiedni adres. Przed i po dwukropku (:) nie może być żadnych spacji.

Powiększenie widoku

Wyświetla stronę przy podanym powiększeniu. Można zmieniać poziom powiększenia (np. na rozmiar rzeczywisty), układ strony (np. ciągłe – sąsiadujące) albo obrót.

Edytowanie lub usuwanie operacji przycisków

  1. Wybierz narzędzie Zaznaczanie  i zaznacz przycisk.
  2. Wykonaj dowolną z następujących czynności na panelu Przyciski i formularze:

    • Wyłącz operacje, usuwając znaki wyboru obok ich nazw. Wyłączanie zdarzeń i operacji jest przydatne podczas testowania.
    • Przeciągnij i upuść poszczególne operacje, aby zmienić ich kolejność.
    • Aby usunąć operację, wybierz ją z pola listy i kliknij przycisk Usuń zaznaczoną operację .
    • Aby edytować operację, zaznacz zdarzenie, do którego jest przypisana, wybierz ją z pola listy, a następnie zmień jej ustawienia. Aby zastąpić operację skojarzoną z bieżącym zdarzeniem, najpierw usuń operację, a potem dodaj nową.

Tworzenie przeskoków do zakotwiczeń tekstu

Jeżeli w dokumencie programu InDesign utworzono tekst zakotwiczony, to można skonfigurować przycisk tak, aby przechodził do tego zakotwiczenia - nawet jeżeli znajduje się ono w innym dokumencie. Zakotwiczenia tekstu dodaje się za pomocą paneli Zakładki oraz Hiperłącza. Nie można utworzyć przejść z przycisków do zakładek, które nie są zakotwiczeniami tekstu.

Uwaga:

Jeżeli do przycisku przypisane zostanie miejsce docelowe hiperłącza, hiperłącze to nie będzie działać w wyeksportowanym pliku EPUB z układem stałym lub PDF.

  1. Wybierz narzędzie Zaznaczanie  i zaznacz przycisk.
  2. Na panelu Przyciski i formularze wybierz zdarzenie (np. Po puszczeniu przycisku), które będzie wyzwalać przeskok.

  3. Kliknij przycisk ze znakiem plus obok sekcji Operacje i wybierz Idź do miejsca docelowego.
  4. Z menu Dokumenty wybierz jeden z otwartych dokumentów programu InDesign lub kliknij ikonę folderu po prawej stronie menu i określ plik.
  5. Wybierz zakotwiczenie utworzone uprzednio za pomocą panelu Zakładki lub Hiperłącza.
  6. Opcje z menu Powiększenie pozwalają określić sposób wyświetlania strony.
Uwaga:

Jeżeli wybierze się zakotwiczenie w innym dokumencie, należy pamiętać o wyeksportowaniu tego docelowego dokumentu do formatu format PDF pod tą samą nazwą, której użyto dla dokumentu programu InDesign (zastępując rozszerzenie INDD rozszerzeniem PDF). Oba pliki PDF muszą znajdować się w tym samym dokumencie, w przeciwnym razie łącze nie będzie funkcjonować w programach Acrobat lub Reader.

Zmiana wyglądu przycisków dla najazdów i kliknięć

Przycisk składa się z grupy pojedynczych obiektów, z których każdy przedstawia wygląd przycisku (czasami nazywany „stanem"). Każdy przycisk może mieć trzy rodzaje wyglądu: Zwykły, Rollover i Kliknięcie. W wyeksportowanym pliku wygląd Zwykły trwa tak długo, dopóki nad przyciskiem nie pojawi się wskaźnik myszy (stan Rollover) lub dopóki użytkownik nie kliknie przyciskiem myszy w obszarze przycisku (stan Kliknięcie). Każdy wygląd może prezentować się inaczej w celu dostarczenia informacji graficznej.

Domyślnie wszystkie utworzone przyciski definiowane są w wyglądzie Zwykły, zawierającym tekst lub obraz przycisku. Przy aktywacji nowego wyglądu kopiowany jest wygląd Zwykły. Aby odróżnić jeden wygląd od pozostałych, możesz zmienić jego kolor albo dodać tekst lub obraz.

Stany przycisków

A. Wskaźnik nie znajduje się nad obszarem przycisku (Zwykły) B. Wskaźnik wkracza w obszar przycisku (Rollover) C. Kliknięcie przyciskiem myszy (Kliknięcie) 

Uwaga:

Kwadratowa obwiednia największego stanu przycisku stanowi obszar kliknięcia przycisku (inaczej punkt aktywny). Na przykład okrągły przycisk ma kwadratowy punkt aktywny.

Zmiana wyglądów przycisków

Jeśli tworzysz przycisk o wielu wyglądach (Zwykły, Rollover i Kliknięcie), dobrym pomysłem jest zakończenie projektowania danego przycisku przed aktywowaniem pozostałych wyglądów. Gdy aktywujesz wygląd Rollover lub Kliknięcie, wygląd Zwykły jest kopiowany.

Część zmian ma wpływ tylko na zaznaczony wygląd, podczas gdy inne mają wpływ na wszystkie aktywne wyglądy. Jeśli zaznaczysz wygląd i zastosujesz do niego inny kolor tła lub zmienisz tekst, to zmiana będzie mieć wpływ tylko na ten zaznaczony wygląd. Jeśli za pomocą narzędzia Zaznaczanie przesuniesz przycisk lub zmienisz jego rozmiar, to zmiana wpłynie na wszystkie jego wyglądy.

  1. Wybierz polecenie Okno Interaktywne Przyciski i formularze, aby wyświetlić panel Przyciski i formularze.

  2. Wybierz narzędzie Zaznaczanie  i zaznacz w układzie przycisk, który ma być edytowany.
  3. Kliknij [Rollover], aby aktywować wygląd Rollover.

    Wygląd Zwykły kopiowany jest do wyglądu Rollover.

  4. Mając wciąż zaznaczony stan Rollover, zmień wygląd przycisku.
    • Aby zmienić kolor, w panelu Sterowanie wybierz próbkę z menu Obrys lub Wypełnienie.
    • Aby w ramach wyglądu umieścić obraz, zaznacz istniejący obraz przycisku za pomocą narzędzia Zaznaczanie bezpośrednie lub dwukrotnego kliknięcia, a następnie wybierz polecenie Plik > Umieść i dwukrotnie kliknij odpowiedni plik.
    • Aby wkleić obraz do ramki tekstowej, skopiuj go do schowka, zaznacz odpowiedni wygląd na panelu Przyciski, a następnie wybierz polecenie Edycja > Wklej do.
    • Aby wpisać tekst, wybierz narzędzie Tekst, kliknij przycisk i wpisz tekst. Można także użyć polecenia Edycja > Wklej do, aby wkleić skopiowaną uprzednio ramkę tekstową.
  5. Aby dodać wygląd Kliknięcie, wybierz [Kliknięcie], a następnie postępuj jak powyżej, aby zmienić jego wygląd.
  6. Użyj panelu Podgląd do przetestowania różnych wyglądów przycisku.
Uwaga:

Aby zmienić rozmiar miniaturek wyglądu stanu na panelu Przyciski, wybierz polecenie Opcje panelu z menu panelu Przyciski i formularze, wybierz odpowiednią opcję i kliknij przycisk OK.

Usuwanie i wyłączanie wyglądów

  1. Zaznacz wygląd na panelu Przyciski i formularze.

  2. Wykonaj dowolną z następujących czynności:
    • Aby usunąć wyglądy Rollover lub Kliknięcie, kliknij ikonę Usuń na dole panelu. Opcja usuwania wyglądu przydaje się szczególnie wtedy, gdy wygląd „Zwykły” zostanie znacznie zmodyfikowany i chcesz utworzyć stany Po przesunięciu wskaźnika lub Po kliknięciu właśnie w oparciu o ten nowy wygląd stanu zwykłego.
    • Aby wyłączyć wygląd bez jego usuwania, kliknij ikonę oka obok nazwy wyglądu. Nieaktywne stany nie są eksportowane do pliku EPUB z układem stałym lub PDF.
Uwaga:

Stanu zwykłego nie można usunąć ani wyłączyć.

Tworzenie obiektów o wielu stanach

Panel Stan obiektu pozwala tworzyć wiele wersji danego obiektu. Stan to wersja elementu strony. Obiekt zawierający wiele stanów nazywany jest obiektem o wielu stanach.

Panel Stan obiektu nie narzuca żadnych ograniczeń co do liczby stanów, jakie można utworzyć dla danego obiektu. Utworzenie każdego stanu generuje kolejną wersję elementu strony. W danym momencie na stronie widoczny jest tylko jeden stan. W przypadku wyjściowego materiału do druku i pliku PDF pojawia się tylko aktywny stan.

Tworzenie pokazów slajdów obiektów o wielu stanach

Jednym z najczęściej spotykanych zastosowań obiektów o wielu stanach jest pokaz slajdów, który pozwala osobom oglądającym plik EPUB klikać, przeglądając kolejne zestawy obrazów. Na przykład, możesz utworzyć pokaz slajdów składający się z 20 obrazów bez konieczności umieszczania ich na 20 różnych stronach.

  1. Umieść obrazy, które mają być wyświetlone w pokazie slajdów.

    W celu uzyskania najlepszych wyników upewnij się, że ramki obrazów mają taki sam rozmiar.

    Stan nie musi być pojedynczym elementem - może to być zbiór elementów.

  2. Aby zgromadzić obrazy w stos, zaznacz je, a następnie na panelu Sterowanie kliknij opcję Wyrównaj do środka w poziomie  i Wyrównaj do środka w pionie .

  3. Nadal mając zaznaczone obrazy, otwórz panel Stany obiektów (Okno > Interaktywne > Stany obiektów) i kliknij przycisk Przekształć zaznaczenie w obiekt wielostanowy.

    Obrazy zostaną wyświetlone jako stany na panelu Stany obiektów. Zaznaczone obrazy otaczać będzie kreskowana ramka.

    Przekształcanie zaznaczenia w obiekt wielostanowy

  4. Utwórz przyciski nawigacyjne aktywujące operacje Przejdź do następnego stanu i Przejdź do poprzedniego stanu w momencie zwolnienia przycisku myszy. Zobacz Tworzenie przycisków.

  5. Aby przetestować przyciski nawigacyjne, skorzystaj z panelu Podgląd (Okno > Interaktywne > Podgląd interaktywności EPUB).

  6. Wyeksportuj dokument do formatu EPUB. Zobacz Dokumenty interaktywne.

Edycja obiektu o wielu stanach

  1. Zaznacz obiekt o wielu stanach.

  2. W panelu Stan obiektu wykonaj dowolną z następujących czynności:

    • Aby zmodyfikować stan, zaznacz go w panelu Stan obiektu, a następnie zmodyfikuj dany obiekt. Na przykład, możesz dodać obrys lub wypełnienie albo zmienić rozmiar obiektu.

    • Aby dodać obiekt do istniejącego stanu, zaznacz zarówno dany obiekt, jak i obiekt o wielu stanach, a następnie kliknij przycisk Dodaj obiekty do widocznego stanu .

    • Aby dodać obiekt do istniejącego obiektu o wielu stanach, zaznacz zarówno dany obiekt, jak i obiekt o wielu stanach, a następnie kliknij przycisk Przekształć zaznaczenie w obiekt o wielu stanach .

    • Aby powielić stan, zaznacz stan, na którym bazował będzie nowy stan i z menu panelu wybierz polecenie Nowy stan. Dodaj, usuń lub zmodyfikuj zawartość tego stanu.

    • Aby wkleić obiekty do istniejącego stanu, wytnij lub skopiuj jeden lub więcej obiektów, zaznacz obiekt o wielu stanach, zaznacz stan w panelu Stan obiektu i z jego menu wybierz polecenie Wklej do stanu.

    • Aby przekształcić obiekt o wielu stanach z powrotem do zestawu niezależnych obiektów, zaznacz stan w panelu Stan obiektu i z jego menu wybierz polecenie Zwolnij stan do obiektu. Aby przekształcić wszystkie stany w obiekcie o wielu stanach w obiekty, wybierz polecenie Zwolnij wszystkie stany do obiektów.

    • Aby usunąć stan i usunąć jego zawartość, zaznacz dany stan i z menu panelu wybierz polecenie Usuń stan.

    • Aby ukryć obiekt o wielu stanach w eksportowanym pliku do czasu jego aktywowania przez przycisk, z menu panelu wybierz polecenie Ukryj do czasu aktywacji.

    • Aby ustawić wszystkie obiekty o wielu stanach w danym dokumencie w ich pierwszym stanie, z menu panelu wybierz polecenie Przywróć pierwszy stan wszystkim obiektom o wielu stanach. Podczas zaznaczania stanu dany obiekt pozostanie w tym stanie, nawet jeśli zamkniesz i ponownie otworzysz dokument. Jest to szybki sposób na wyzerowanie wszystkich obiektów o wielu stanach.

Tworzenie miejsc aktywnych przycisku

Niekiedy warto utworzyć taki obszar przycisku (tzw. „punkt aktywny” lub „aktywne łącze" ), który pozostanie niewidoczny dopóki użytkownik nie przesunie nad niego wskaźnika myszy. Na przykład po przesunięciu wskaźnika myszy nad przyciskiem na mapie może pojawiać się obraz przedstawiający konkretny region. Obraz ten będzie znikać po odsunięciu wskaźnika myszy od tego regionu.

Przytrzymanie wskaźnika myszy nad punktem aktywnym w wyeksportowanym pliku PDF powoduje wyświetlenie obrazu.

Wyświetlanie ukrytego obrazu przy najeździe

Jeden ze sposobów osiągnięcia efektu „punktu aktywnego” polega między innymi na wykorzystaniu stanu Rollover, który przypisuje się za pomocą panelu Przyciski. Aby to wykonać, należy utworzyć przycisk, w którym stan [Rollover] wyświetla jakiś obraz, natomiast stan [Zwykły] nie wyświetla tego obrazu.

  1. Wybierz obraz, który zostanie użyty w roli punktu aktywnego. Upewnij się, że ramka obrazu nie posiada krawędzi ani tła.

  2. Na panelu Przyciski i formularze (Okno > Interaktywny > Przyciski i formularze) kliknij wygląd [Zwykły], aby przekształcić wybrany obraz w przycisk.

  3. Na panelu Przyciski i formularze kliknij wygląd [Po przesunięciu wskaźnika], aby go aktywować.

  4. Kliknij ponownie wygląd [Zwykły]. Następnie zaznacz obraz, korzystając z narzędzia Zaznaczanie bezpośrednie  i usuń obraz.

    Upewnij się, że usuwasz obraz (zawartość ramki), a nie ramkę i zawartość. Usunięcie ramki powoduje usunięcie całego przycisku.

  5. Użyj panelu Podgląd, by uzyskać podgląd efektu punktu aktywnego.

Wyświetlanie innego przycisku przy najeździe

Możesz utworzyć punkt aktywny, w którym kliknięcie lub najechanie kursorem na dany obiekt powoduje wyświetlenie innego obiektu. Aby to wykonać, należy utworzyć dwa przyciski, ukryć jeden z nich i użyć operacji Pokaż/Ukryj przycisk, aby pokazać i ukryć przycisk docelowy.

  1. Utwórz obiekt, który zostanie użyty jako przycisk źródłowy. Na panelu Przyciski i formularze kliknij ikonę Konwertuj obiekt na przycisk.

  2. Umieść obraz, który chcesz wykorzystać jako przycisk źródłowy, i przekształć go w przycisk.
  3. Zaznacz obraz docelowy i wybierz polecenie „Ukryty do czasu aktywacji” na dole panelu Przyciski i formularze.

    Obraz musi pozostać ukryty w eksportowanym dokumencie, tak aby mógł zostać wyświetlony, gdy przycisk źródłowy zostanie kliknięty.

  4. Wybierz przycisk źródłowy i utwórz dwie różne operacje - jedną, by pokazać obraz docelowy i drugą, by go ukryć.

    Jeśli chcesz, aby obraz pojawiał się, gdy nad przyciskiem źródłowym umieszczony zostanie kursor myszy, użyć zdarzeń Po najechaniu i Po Roll Off. Jeśli chcesz, aby obraz pojawiał się w momencie kliknięcia przycisku źródłowego i znikał, gdy go zwolnisz, użyj zdarzeń Po kliknięciu i Po zwolnieniu. W obydwu przypadkach użyj operacji Pokaż/Ukryj przyciski, aby wyświetlić i ukryć przycisk docelowy. Zobacz Wprowadzanie interaktywności do przycisków.

  5. Do przetestowania przycisków użyj panelu Podgląd.

Zmiana opcji PDF dla przycisków

  1. Wybierz narzędzie Zaznaczanie  i zaznacz przycisk.
  2. Z menu panelu Przyciski i formularze wybierz polecenie Opcje PDF.

  3. Wpisz opis, który pełni rolę tekstu zastępczego dla użytkowników niewidomych i niedowidzących.
  4. Zaznacz, czy przycisk ma być drukowany w pliku PDF, a następnie kliknij przycisk OK.

Ustawianie kolejności przechodzenia tabulatorem do przycisków

Kolejność tabulatorów decyduje o następnym (lub poprzednim) polu, które zostanie uaktywnione po naciśnięciu klawisza Tab (lub Shift+Tab) w dokumencie PDF. Kolejność tabulatorów obejmuje przyciski na warstwach ukrytych, ale nie przyciski na stronach wzorcowych.

  1. Przejdź na stronę zawierającą przyciski.
  2. Wybierz polecenie Obiekt > Interaktywny > Ustaw kolejność tabulatorów.

  3. Zaznacz każdy przycisk, który ma zostać przeniesiony, po czym przeciągnij go na nowe miejsce. Możesz także posłużyć się przyciskami Przenieś w górę i Przenieś w dół. Po zakończeniu kliknij przycisk OK.

Jeżeli w programie Acorbat edytuje się plik PDF lub doda się więcej przycisków lub pól formularzy, to trzeba będzie określić w tym programie również nową kolejność wybierania.

Powiązane tematy

Program Adobe InDesign umożliwia tworzenie i publikowanie ebooków, broszur, ulotek, pocztówek, plakatów, interaktywnych układów stron i innych rodzajów treści.

Logo Adobe

Zaloguj się na swoje konto