Tabela składa się z wierszy i kolumn komórek. Komórka przypomina ramkę tekstową, do której można dodawać tekst, zakotwiczone ramki lub inne tabele. Tabele twórz w programie Adobe InDesign CS5 lub eksportuj je z innych aplikacji.

Uwaga:

Aby tworzyć, edytować i formatować tabele w programie Adobe InCopy, upewnij się, że jest włączony widok Układ.

Tworzenie tabel

Tabela składa się z wierszy i kolumn komórek. Komórka przypomina ramkę tekstową, w której można dodawać tekst, grafikę w wierszu lub inne tabele. Możesz utworzyć tabele od podstaw lub przez konwersję z istniejącego tekstu. Możesz także osadzić tabelę w tabeli.

Po utworzeniu nowej tabeli wypełnia ona całą szerokość ramki tekstowej. Tabela jest wstawiana w tym samym wierszu, jeżeli punkt wstawiania jest na początku wiersza, albo w następnym wierszu, gdy punkt wstawiania jest w środku wiersza.

Tabele przepływają wraz z otaczającym je tekstem, analogicznie do grafiki w wierszu. Na przykład, po zmianie wielkości czcionki tekstu nad tabelą albo po dodaniu lub usunięciu tam tekstu, tabela będzie przepływać do kolejnych powiązanych ramek tekstowych. Tabela nie może jednak pojawiać się w ramce typu tekst na ścieżce.

Michael Murphy udostępnił artykuł poświęcony tworzeniu i formatowaniu tabel: Ostrożnie z tabelami.

Jeff Witchel współpracujący z serwisem Infiniteskills.com przedstawia film instruktażowy poświęcony podstawom konfiguracji tabel.

Tworzenie tabeli od podstaw

Podczas tworzenia tabeli w programie InDesign istnieje możliwość stworzenia tabeli wewnątrz istniejącej ramki tekstowej (Korzystanie z opcji Wstaw tabelę). Ewentualnie można też utworzyć tabelę i pozwolić programowi InDesign na stworzenie otaczającej jej ramki tekstowej (Korzystanie z opcji Utwórz tabelę).

Korzystanie z opcji Wstaw tabelę

  1. Aby narysować tabelę wewnątrz istniejącej ramki tekstowej skorzystaj z narzędzia Tekst i umieść punkt wstawiania w miejscu, gdzie chcesz utworzyć tabelę.

  2. Wybierz polecenie Tabela > Wstaw tabelę.

    Uwaga:

    Jeżeli kursor znajduje się poza ramką tekstową, dostępna jest opcja Utwórz tabelę.

  3. Podaj liczbę wierszy i kolumn.
  4. Jeżeli zawartość tabeli ma zajmować więcej niż jedną kolumnę lub ramkę, podaj liczbę wierszy nagłówka lub stopki, w których informacje będą powtarzane.
  5. (Opcjonalnie) Określ styl tabeli.
  6. Kliknij OK.

    Nowa tabela wypełnia szerokość ramki tekstowej.

Korzystanie z opcji Utwórz tabelę

Podczas korzystania z opcji Utwórz tabelę w celu stworzenia tabeli nie trzeba wcześniej tworzyć ramki tekstowej w dokumencie. Zaraz po narysowaniu tabeli w dokumencie program InDesign tworzy ramkę tekstową o wymiarach narysowanej tabeli.

  1. Wybierz polecenie Tabela > Utwórz tabelę.

    Uwaga:

    Jeżeli kursor znajduje się w ramce tekstowej, dostępna jest opcja Wstaw tabelę.

  2. Podaj liczbę wierszy i kolumn.
  3. Jeżeli zawartość tabeli ma zajmować więcej niż jedną kolumnę lub ramkę, podaj liczbę wierszy nagłówka lub stopki, w których informacje będą powtarzane.
  4. (Opcjonalnie) Określ styl tabeli.
  5. Kliknij OK.
  6. Użyj kursora tabeli, aby narysować żądaną tabelę.

    Program InDesign utworzy ramkę tekstową o wymiarach narysowanego obszaru i umieści w niej tabelę.

Wysokość wiersza tabeli zależy od określonego stylu tabeli. Na przykład, styl tabeli może wykorzystywać style komórki do formatowania różnych części tabeli. Jeśli żaden ze stylów komórki nie zawiera stylów akapitowych, wówczas wartość interlinii stylu akapitowego określa wysokość wierszy tego obszaru. Jeśli brak stylu akapitowego, wysokość wierszy określają domyślne informacje o pracy dokumentu. (Informacja o pracy opiera się na wartości interlinii. W tym kontekście, Informacja o pracy jest przybliżoną wysokością podświetlania w zaznaczonym tekście).

Tworzenie tabeli z istniejącego tekstu

Przed przekonwertowaniem tekstu na tabelę sprawdź, czy jest on odpowiednio sformatowany.

  1. Przygotuj tekst do konwersji, wstawiając tabulatory, przecinki, znaki końca akapitu albo inne znaki, które rozdzielą kolumny. Rozdziel wiersze, wstawiając tabulatory, przecinki, znaki końca akapitu albo inne znaki. (Często można przekonwertować tekst na tabelę bez potrzeby edytowania go).
  2. Wybierz narzędzie Tekst  i zaznacz tekst, który ma zostać przekształcony w tabelę.
  3. Wybierz polecenie Tabela > Konwertuj tekst na tabelę.
  4. W menu Separator kolumn i Separator wierszy określ miejsce rozpoczynania nowych wierszy i nowych kolumn. Można wybrać tabulator, przecinek lub akapit, albo wpisać odpowiedni znak, np. średnik (;) w pole Separator kolumn i w pole Separator wierszy. (Wpisany tu znak będzie się pojawiał w menu przy następnej konwersji tekstu na tabelę).
  5. Jeżeli poda się taki sam separator dla kolumn i wierszy, podaj liczbę kolumn, jaka ma się znaleźć w tabeli.
  6. (Opcjonalnie) Określ styl tabeli do jej formatowania.
  7. Kliknij OK.

Jeżeli w wierszu znajduje się mniej pozycji, niż jest kolumn w tabeli, to zostanie on wypełniony pustymi komórkami.

Osadzanie tabeli w tabeli

  1. Wykonaj jedną z następujących czynności:
    • Zaznacz komórki lub tabelę, która ma zostać osadzona, a następnie wybierz polecenie Edycja > Wytnij lub Kopiuj. Umieść punkt wstawiania w komórce, w której ma się pojawić tabela, a następnie wybierz polecenie Edycja > Wklej.

    • Kliknij wewnątrz komórki, wybierz polecenie Tabela > Wstaw tabelę, podaj liczbę wierszy i kolumn, a następnie kliknij OK.

  2. Stosownie do potrzeb zmodyfikować wewnętrzny margines komórki. (Zobacz Formatowanie tekstu w tabeli).

Jeżeli utworzy się tabelę w komórce, nie można będzie zaznaczyć myszą żadnej części tej tabeli, która zakryje krawędzie komórki. Aby je zaznaczyć, trzeba poszerzyć wiersz lub kolumnę, albo umieścić punkt wstawiania w pierwszej części tabeli i użyć skrótów klawiaturowych do przenoszenia punktu wstawiania i zaznaczania tekstu.

Importowanie tabel z innych aplikacji

Kiedy użyjesz polecenia Umieść, aby zaimportować dokument Microsoft Word zawierający tabele, lub arkusz Microsoft Excel, zaimportowane dane są tabelą, którą można edytować. Aby sterować formatowaniem ustaw parametry w oknie dialogowym Opcje importu.

Możesz również wklejać dane z arkusza kalkulacyjnego Excela lub tabeli Worda do dokumentu InDesign lub InCopy. Ustawienia preferencji Obsługi schowka określają sposób sformatowania tekstu wklejonego z innej aplikacji. Jeśli zaznaczysz Tylko tekst, informacja pojawi się jako niesformatowany tekst tabulowany, który możesz konwertować na tabelę. Jeśli wybierzesz opcję Wszystkie informacje wówczas wklejony tekst pojawi się w sformatowanej tabeli.

Jeśli wklejasz tekst z innej aplikacji do istniejącej tabeli, wstaw wystarczającą ilość wierszy i kolumn, aby pomieścić wklejany tekst; z preferencji Obsługa schowka wybierz opcję Tylko tekst i upewnij się, że przynajmniej jedna komórka jest zaznaczona (chyba, że chcesz osadzić tabelę w komórce).

Jeśli chcesz lepiej kontrolować proces formatowania zaimportowanej tabeli, lub jeśli chcesz utrzymać formatowanie arkusza kalkulacyjnego, do importowania tabeli użyj polecenia Umieść. Jeśli chcesz utrzymać łącze do arkusza kalkulacyjnego, wybierz opcję Tworzenie łączy przy umieszczaniu plików tekstowych i arkuszy kalkulacyjnych w ustawieniach preferencji obsługi plików.

Uwaga:

Możesz również skopiować i wkleić tekst tabulowany do zaznaczonych komórek tabeli. Ta metoda przydaje się szczególnie do zastępowania zawartości przy zachowaniu formatowania. Przykładowo, może zaistnieć potrzeba zaktualizowania zawartości sformatowanej tabeli w ukazującym się co miesiąc czasopiśmie. Jedną z możliwości jest umieszczenie łącza do arkusza programu Excel. Jeśli jednak zawartość pochodzi z innego źródła, można skopiować tekst tabulowany zawierający nową treść, zaznaczyć zakres komórek w sformatowanej tabeli InDesign i wkleić tekst.

Dodawanie tekstu do tabeli

W komórkach tabeli można dodawać tekst, obiekty zakotwiczone, znaczniki XML oraz inne tabele. Wysokość wiersza tabeli zwiększa się, aby pomieścić dodatkowe fragmenty tekstu, o ile nie ustawi się stałej wysokości wiersza. W tabelach nie można dodawać przypisów dolnych.

  1. Wybierz narzędzie Tekst  i wykonaj jedną z następujących czynności:
    • Umieść punkt wstawiania w komórce, a następnie wpisz tekst. Naciśnij Enter lub Return, aby utworzyć nowy akapit w tej samej komórce. Naciśnij klawisz Tab, aby przesuwać się do przodu przez kolejne komórki (naciśnięcie Tab w ostatniej komórce spowoduje wstawienie nowego wiersza). Naciśnij Shift+Tab, aby przesuwać się do tyłu przez kolejne komórki.

    • Skopiuj tekst, umieść punkt wstawiania w komórce, a następnie wybierz polecenie Edycja > Wklej.

    • Umieść punkt wstawiania w komórce, gdzie ma zostać dodany tekst, wybierz polecenie Plik > Umieść, a następnie dwukrotnie kliknij plik tekstowy.

Dodawanie grafiki do tabeli

  1. Umieść punkt wstawiania w komórce tabeli, w której chcesz dodać obraz.

  2. Wykonaj dowolną z następujących czynności:
    • Wybierz Plik > Umieść, a następnie wybierz co najmniej jeden plik graficzny.
    • Wybierz, a następnie przeciągnij i upuść co najmniej jedną grafikę z kategorii Grafika w panelu Biblioteki CC.

    Obrazy są dostępne w module umieszczania.

  3. Aby umieścić obrazy, kliknij wewnątrz każdej komórki tabeli.

  4. Wykonaj dowolną z następujących czynności:

Uwaga:

Nie można przeciągać i upuszczać urywków InDesign z kategorii Grafika w panelu Biblioteki CC.

Jeżeli dodana grafika jest większa niż komórka, to wysokość komórki zwiększa się odpowiednio, ale jej szerokość pozostaje bez zmian - grafika może wystawać poza prawą krawędź komórki. Jeżeli wiersz, w którym umieszczono grafikę, ma stałą wysokość, to zbyt wysoka grafika spowoduje, że komórka nie zmieści się.

Uwaga:

Aby uniknąć problemu niemieszczącej się komórki, umieść obraz na zewnątrz tabeli, zmień jego rozmiar, a następnie wklej go do komórki tabeli.

Możesz również umieścić obrazy w komórkach tabeli przy użyciu poniższych metod.

  • Wybierz Obiekt > Obiekt zakotwiczony > Wstaw, a następnie określ ustawienia. Do obiektu zakotwiczonego można potem dodać grafikę.
  • Kopiuj grafikę lub ramkę, umieść punkt wstawienia, a następnie wybierz polecenie Edycja > Wklej.

Dodawanie nagłówków i stopek tabeli

Długa tabela może ciągnąć się przez więcej niż jeden łam, ramkę lub stronę. Wiersze nagłówka lub stopki umożliwiają powtarzanie informacji umieszczonych na początku lub końcu każdego z podzielonych fragmentów tabeli.

Wiersze nagłówka i stopki można dodawać podczas tworzenia tabeli, a także za pomocą okna dialogowego Opcje tabeli. Okno to umożliwia ponadto zmianę wyglądu wierszy nagłówka i stopki w tabeli. Podstawowe wiersze tabeli można konwertować na wiersze nagłówka lub stopki.

Dodawanie nagłówków i stopek tabeli
Wiersze nagłówka powtórzone jednokrotnie w każdej ramce

Uwaga:

Aby sekwencyjnie ponumerować tabele, np. Tabela 1A, Tabela 1B itd., dodaj zmienną to nagłówka lub stopki tabeli. (Zobacz Tworzenie wpuszczonych podpisów obrazów i tabel).

  1. Zaznacz wiersze na górze tabeli, aby utworzyć wiersze nagłówka, albo wiersze na dole tabeli, aby utworzyć wiersze stopki.
  2. Wybierz polecenie Tabela > Konwertuj wiersze > Do nagłówka lub Do stopki.
  1. Umieść punkt wstawiania w tabeli i wybierz polecenie Tabela > Opcje tabeli > Nagłówki i stopki.
  2. Określ liczbę wierszy nagłówka lub stopki. Na początku lub końcu tabeli mogą zostać dodane puste wiersze.
  3. Określ, czy informacje zawarte w nagłówku lub stopce mają się pojawiać w każdym łamie tekstu (jeżeli ramki tekstowe mają więcej niż jeden łam), po jednym razie na ramkę, czy tylko raz na stronę.
  4. Zaznacz opcję Pomiń pierwszy, jeżeli informacje nagłówka mają się nie pojawiać w pierwszym wierszu tabeli. Zaznacz opcję Pomiń ostatni, jeżeli informacje stopki mają się nie pojawiać w ostatnim rzędzie tabeli.

    Opcja Pomiń pierwszy jest szczególnie przydatna, gdy chcesz wskazać, że nagłówek lub stopka jest kontynuowana. Na przykład, w przypadku tabeli, która rozciąga się na wiele stron, można użyć nagłówka o treści „Tabela 2 (ciąg dalszy)." Jeśli nie chcesz, aby „(ciąg dalszy)" pojawiło się na początku tabeli, wybierz opcję Pomiń pierwszy i po prostu wpisz Tabela 2 w pierwszym jej rzędzie.

  5. Kliknij OK.

Istnieje kilka funkcji pozwalających na tworzenie podobnych wierszy i kolumn lub ich powielanie. 

Na wierszach i kolumnach można wykorzystywać poniższe funkcje:

  • Przeciąganie i upuszczanie wierszy i kolumn z jednego do drugiego położenia w ramach tej samej tabeli.
  • Powielanie wierszy i kolumn.
  • Wklejanie wierszy i kolumn przed lub za wierszem/kolumną
  • Kopiowanie zawartości wiersza do kolumny lub kolumny do wiersza.

Przeciąganie i upuszczanie wierszy/kolumn oraz ich powielanie

Możesz przeciągać i upuszczać wiersze i kolumny z jednego do drugiego położenia w ramach tej samej tabeli. Aby przeciągać i upuszczać wiersze/kolumny oraz powielać je wykonaj poniższe czynności.

  1. Zaznacz wiersz lub kolumnę, którą chcesz przeciągnąć i upuścić w innym wierszu lub kolumnie. Upewnij się, że zaznaczono całą kolumnę lub wiersz. Częściowo zaznaczone wiersze lub kolumny nie mogą zostać przeciągnięte i upuszczone.

  2. Umieść wskaźnik nad wybranymi wierszami, a pojawi się odrębny kursor informujący o tym, że można przesunąć zaznaczenie.

  3. Wiersz elementu może zostać przeciągnięty i upuszczony. Kolumny można zamienić miejscem z wierszami. Przeciągnięty wiersz można upuścić tylko jako wiersz, a kolumnę tylko jako kolumnę.

    Przeciąganie i upuszczanie wierszy i kolumn
    Przeciąganie i upuszczanie wierszy i kolumn

    W tym przypadku przesunięcie wiersza z jednego miejsca w drugie powoduje zachowanie tej samej liczby wierszy wynoszącej 3.

    Uwaga:

    Przeciąganie i upuszczanie jest możliwe tylko w ramach tej samej tabeli.

  4. Aby powielić wiersz lub kolumnę, należy nacisnąć lub przytrzymać klawisz Alt (system operacyjny Windows) lub Option (system operacyjny Mac) po zaznaczeniu wiersza lub kolumny. Istnieje możliwość przeciągania i upuszczania wielu kolejnych zaznaczonych wierszy.

  5. Przeciąganie i upuszczanie wiersza lub kolumny do żądanego położenia. Całkowita liczba wierszy i kolumn zwiększa się wraz z ich powielaniem.

    Można również kopiować zawartość wierszy nagłówka i stopki do wierszy treści (naciskając klawisz Alt/Opt). W podobny sposób, można teraz powielać i przekształcać wiersze treści na wiersze nagłówka i stopki.

Wiersze nagłówka można przeciągać i upuszczać tylko w sekcji nagłówka (jeżeli istnieje wiele wierszy nagłówka), chyba że wciśnięto klawisz Alt/Option w celu powielania wierszy. Wiersze treści można przeciągać i upuszczać w sekcji nagłówka, jeżeli nie wciśnięto klawisza Alt/Option w celu powielania wierszy.

Kopiowanie wierszy/kolumn i wklejanie ich przed/za

Wiersze można kopiować i wklejać przed lub za zaznaczonym wierszem. Za pomocą opcji Wklej Przed/Za można również kopiować wiersze/kolumny z jednej tabeli do drugiej.

  1. Zaznacz wiersz/kolumnę.

  2. Zaznacz kolumnę lub wiersz.

  3. Wybierz polecenia Tabela > Wklej Przed/Wklej Za. 

  1. Wykonaj dowolną z następujących czynności:
    • Umieść punkt wstawiania w wierszu nagłówka lub stopki, a następnie wybierz polecenie Tabela > Konwertuj wiersze > Do tekstu podstawowego.

    • Wybierz polecenie Tabela > Opcje tabeli > Nagłówki i stopki, a następnie podaj inną liczbę wierszy nagłówka lub stopki.

Ta zawartość jest licencjonowana na warunkach licencji Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Posty z serwisów Twitter™ i Facebook nie są objęte licencją Creative Commons.

Informacje prawne   |   Zasady prywatności online