Czym jest funkcja Publish Online?

Funkcja Publish Online pozwala teraz zmieniać przeznaczenie wydrukowanych dokumentów poprzez ich publikację w Internecie. Można opublikować wersję cyfrową dokumentu programu InDesign działającą na wszystkich urządzeniach i we wszystkich nowoczesnych przeglądarkach internetowych, bez konieczności instalowania wtyczek.

Aby zapewnić pełniejsze wrażenia podczas przeglądania dokumentu, można opublikować interaktywny dokument programu InDesign zawierający przyciski, pokazy slajdów, animacje, pliki dźwiękowe i filmy, korzystając z funkcji tworzenia elementów interaktywnych dostępnych w programie InDesign CC.

Po opublikowaniu dokumentów można podać adres URL dokumentu dowolnej osobie, aby mogła w elegancki, a zarazem prosty sposób odczytać dokument na dowolnym urządzeniu lub na dowolnej platformie. Można także za pomocą jednego kliknięcia udostępniać dokument online na portalach społecznościowych, takich jak Facebook i Twitter lub poprzez pocztę elektroniczną. Dokument można również osadzić na dowolnej stronie lub blogu za pomocą kodu osadzenia, który jest dostępny po kliknięciu opcji Osadź dostępnej w układzie wyświetlania.

Oto dwa przykładowe dokumenty interaktywne opublikowane za pomocą programu InDesign CC 2015.

Strona wzorcowa z wieloma stronami

Możesz utworzyć dokument programu InDesign zawierający strony widzące składające się z więcej niż dwóch stron. Opublikowany dokument będzie wyświetlać wiele stron na stronie widzącej w taki sam sposób, w jaki są one wyświetlane w programie InDesign.

Publikowanie dokumentów o zróżnicowanych rozmiarach stron

Publikuj dokumenty, które zawierają strony o różnych rozmiarach. Opublikowany dokument zachowuje rozmiar poszczególnych stron i prawidłowo wyświetla zawartość na odpowiednich stronach.

Hiperłącza w tekście

Opublikowany dokument obsługuje hiperłącza w tekście. Program InDesign zachowuje wszystkie rodzaje hiperłączy w opublikowanym dokumencie:

  • Adresy URL
  • Adresy e-mail
  • Strony docelowe
  • Znaczniki spisu treści
  • Znaczniki indeksu
  • Odsyłacze

Rozdzielczość obrazu

Rozdzielczość obrazu opublikowanego dokumentu wynosi 96 ppi i jest wartością domyślną, zapewniającą lepszą jakość obrazu dokumentów.

Przeglądanie na urządzeniach mobilnych i tabletach Jeszcze lepsze wrażenia z wyświetlania opublikowanych dokumentów programu InDesign na urządzeniach mobilnych.

  • Płynniejsze przejścia stron z poprawionymi gestami przesuwania.
  • Okno dialogowe udostępniania wyświetla się na pełnym ekranie.
  • Układ miniaturek zoptymalizowany pod kątem urządzeń mobilnych zapewnia lepsze wyświetlanie i szerszą dostępność.

W widoku na tablet zastosowano prosty w obsłudze, przewijalny widok miniatur.

Widoki na urządzenia mobilne i tablety
Widoki na urządzenia mobilne i tablety

Opcje udostępniania

Możesz udostępniać opublikowane dokumenty na Twitterze i przez pocztę elektroniczną. Możesz również umożliwić użytkownikom pobieranie dokumentu w formacie PDF.

Opcje udostępniania

Możliwość udostępniania opublikowanych dokumentów na Twitterze i przez pocztę elektroniczną.

Efekt przezroczystości

Dokumenty opublikowane online obsługują przezroczystość i inne efekty z trybami mieszania. Wyjątek stanowią ramki tekstowe, grupy, przyciski i obiekty z animacjami oraz obiekty MSO nakładające się z obiektami z przezroczystością.

Zaktualizuj opublikowane dokumenty

Możesz zaktualizować opublikowany dokument, wprowadzając zmiany w dokumencie źródłowym i ponownie go publikując.

Publikowanie dokumentu InDesign w Internecie

  1. Aby opublikować bieżący dokument w Internecie, kliknij przycisk Publish Online na pasku aplikacji lub wybierz opcję Plik > Publish Online.

    Wyświetlone zostanie okno dialogowe opcji funkcji Publish Online.

  2. W zakładce Ogólne w oknie dialogowym funkcji Publish Online wprowadź następujące informacje:

    Tytuł

    Tytuł udostępnianego dokumentu.

    Nazwa ta jest wyświetlana jako tytuł strony opublikowanego dokumentu w przeglądarce.

    Tytuł jest również wyświetlany w menu Niedawno opublikowane (PlikNiedawno opublikowane) i w internetowym pulpicie funkcji Publish Online.

    Opis

    Opis udostępnianego dokumentu.

    Wyświetla się w internetowym pulpicie funkcji Publish Online w serwisie Facebook, o ile dokument został tam udostępniony.

    Strony

    Wybierz opcję eksportu wszystkich stron z dokumentu lub tylko pewnego zakresu.

    Eksportuj jako

    Określ, w jaki sposób strony będą wyświetlane w przeglądarce internetowej.

    Pojedyncza strona

    Wyświetla w przeglądarce jedną stronę na raz

    Strony widzące

    Wyświetla w przeglądarce dwie strony na raz.

    Zezwól przeglądającym na pobranie dokumentu w formacie PDF (wydruk)

    Zaznacz tę opcję, jeśli chcesz, aby użytkownicy mogli pobrać Twój dokument w formacie PDF (Wydruk).

    Ukryj opcje Udostępnij i Osadź w opublikowanym dokumencie

    Wybierz tę opcję, jeśli nie chcesz, aby czytelnicy dokumentu widzieli przyciski Udostępnij lub Osadź w opublikowanym dokumencie.

    Jeśli ponownie publikujesz istniejący dokument, kliknij Aktualizuj istniejący dokument i wybierz odpowiednią nazwę dokumentu z listy rozwijanej Wybierz istniejący dokument do zaktualizowania. Zmień ustawienia publikowania online.

  3. W zakładce Zaawansowane wprowadź następujące informacje:

    Wybierz miniaturę

    Wybierz okładkę publikowanego dokumentu. Podczas przesyłania ta miniatura jest wyświetlana w oknie dialogowym funkcji Publish Online wraz z tytułem i opisem. Ta miniatura wyświetla się również w przypadku udostępniania dokumentu na Facebooku.

    Pierwsza strona

    Określ, że pierwsza strona dokumentu InDesign ma być stosowana jako miniatura okładki.

    Wybrana strona

    Wybierz stronę z dokumentu programu InDesign, która ma być używana jako miniatura okładki.

    Wybierz obraz

    Wybierz zewnętrzny obraz na miniaturę okładki.

    Ustawienia obrazu

    Określ, w jaki sposób zostaną wyeksportowane obrazy w dokumentach.

    Automatycznie **zalecane**

    Program InDesign zdecyduje, w jaki sposób obrazy dokumentu powinny zostać wyeksportowane, mając na uwadze optymalizację wydajności. Dostępne typy plików to JPEG, GIF i PNG.

    Rozdzielczość

    Należy określić rozdzielczość obrazów. Można wybrać między opcjami Standard (zoptymalizowana pod kątem programu InDesign) i HiDPi (zoptymalizowana pod kątem programu InDesign w wysokiej rozdzielczości).

    Uwaga! Obrazy HiDPi mogą zwiększyć czas wczytywania stron oraz ilość danych do pobrania przez użytkowników.

    Jakość obrazu JPEG

    Kiedy wybrany format obrazu to JPEG, opcja ta zapewnia wiele ustawień jakości obrazu.

    Paleta opcji GIF

    Kiedy wybrany format obrazu to GIF, opcja ta zapewnia wiele ustawień renderowania plików GIF.

  4. Kliknij przycisk Opublikuj, aby opublikować dokument w Internecie.

    Wyświetlone zostanie okno dialogowe Publish Online:

    • Miniatura, tytuł i opis są wyświetlane po lewej stronie okna dialogowego.
    • Postęp jest wyświetlany po prawej stronie.
    Okno dialogowe funkcji Publish Online
    Okno dialogowe funkcji Publish Online

  5. W oknie dialogowym funkcji Publish Online kliknij przycisk Anuluj przesyłanie, aby zatrzymać i cofnąć proces wysyłania.

  6. Kliknij przycisk Zamknij, aby zminimalizować okno dialogowe do przycisku Publish Online na pasku aplikacji.

    Uwaga:

    Minimalizacja okna dialogowego funkcji Publish Online nie powoduje zatrzymania postępu publikacji. Można kontynuować pracę na bieżącym lub jakimkolwiek innym dokumencie InDesign.

  7. Kliknij przycisk Publish Online na pasku aplikacji, aby otworzyć okno dialogowe funkcji Publish Online.

  8. Po opublikowaniu dokumentu w Internecie należy wybrać następujące opcje w oknie dialogowym funkcji Publish Online.

    Pomyślnie opublikowany dokument
    Pomyślnie opublikowany dokument

    Pokaż dokument

    Otwórz opublikowany dokument w domyślnej przeglądarce internetowej.

    Kopiuj

    Skopiuj adres URL opublikowanego dokumentu.

    Udostępnij na Facebooku

    Udostępnij adres URL dokumentu na stronie serwisu Facebook.

    Udostępnij na Twitterze

    Wpisz adres URL do dokumentu w tweet.

    Wyślij adres URL w wiadomości e-mail

    Udostępnij dokument za pomocą domyślnego klienta poczty.

Opcje wyjściowe opublikowanych dokumentów

Opublikowany dokument zapewnia wiele opcji wyświetlania i udostępniania.

Opcje przeglądania i udostępniania
Opcje przeglądania i udostępniania dokumentów opublikowanych online

A (Przełącz miniatury)

Pokaż/Ukryj stos miniatur, który wyświetla miniatury wszystkich stron w opublikowanym dokumencie wyjściowym.

B (Powiększ)

Powiększanie bieżącej strony.

C (Zmniejsz)

Zmniejszanie bieżącej strony.

D (Tryb pełnoekranowy)

Wyświetlanie bieżącej strony w trybie pełnoekranowym.

E (Udostępnij)

Otwarcie okna dialogowego opcji udostępniania opublikowanego dokumentu. To okno dialogowe zawiera opcje udostępniania pozwalające skopiować adres URL bieżącego dokumentu (i udostępnić go za pośrednictwem poczty e-mail) lub udostępnić dokument w serwisie Facebook.

F (Osadź)

Skopiuj kod potrzebny do osadzenia zawartości na Twojej stronie. Możesz także określić stronę startową dla swojego dokumentu. Gdy to zrobisz, osadzona zawartość zostanie otwarta na wybranej stronie. Wybierz opcję Wyłącz tryb pełnoekranowy dla okna osadzania, jeśli nie chcesz, aby użytkownicy przeglądali dokument w trybie pełnoekranowym.

Uwaga:

(E i F) Opcje Udostępnij i Osadź są niedostępne w przypadku wyboru opcji Ukryj opcje Udostępnij i Osadź w opublikowanym dokumencie w trakcie publikowania dokumentu. 

G (Pobierz PDF)

Pobierz dokument w formacie PDF (Wydruk).

H (Wyłącz głośność)

Wyciszanie wszystkich dźwięków i filmów w bieżącym dokumencie.

I (Zgłoś nadużycie)

Otwarcie okna dialogowego Zgłoś nadużycie. To okno dialogowe zawiera opcje dotyczące rodzaju nadużyć oraz dotyczących ich szczegółów.

Niedawno opublikowane dokumenty

Menu Niedawno opublikowane wyświetla listę ostatnich pięciu opublikowanych dokumentów.

Kliknij dokument na liście, aby otworzyć opublikowany dokument wyjściowy w domyślnej przeglądarce.

  1. Aby wyświetlić listę ostatnio opublikowanych dokumentów, wybierz pozycję Plik > Niedawno opublikowane.

Korzystanie z pulpitu funkcji Publish Online

Program InDesign zapewnia pulpit funkcji Publish Online, z poziomu której jest możliwy dostęp do wszystkich opublikowanych dokumentów. Aby wyświetlić pulpit funkcji Publish Online programu InDesign, wybierz opcję Plik > Pulpit funkcji Publish Online. Na pulpicie nawigacyjnym znajdują się dwie karty.

Publikacje

Na karcie Publikacje wyświetlana jest lista opublikowanych przez Ciebie dokumentów.

Pulpit funkcji Publish Online
Pulpit funkcji Publish Online

Udostępnianie

Otwarcie okna dialogowego opcji udostępniania opublikowanego dokumentu. To okno dialogowe zawiera opcje udostępniania pozwalające skopiować adres URL bieżącego dokumentu (i udostępnić go za pośrednictwem poczty e-mail) lub udostępnić dokument w serwisie Facebook.

Osadź

Skopiuj kod potrzebny do osadzenia zawartości na Twojej stronie. Możesz także określić stronę startową dla swojego dokumentu. Gdy to zrobisz, osadzona zawartość zostanie otwarta na wybranej stronie. Wybierz znajdujące się w opcjach osadzania polecenie Wyłącz tryb pełnoekranowy dla okna osadzania, jeśli nie chcesz, aby użytkownicy przeglądali dokument w trybie pełnoekranowym.

Usuń

Usuń opublikowany dokument.

Analiza ruchu internetowego

Opis ogólny

Ta karta stanowi źródło informacji na temat wszystkich opublikowanych przez Ciebie dokumentów.

Dane analityczne funkcji Publish Online
Analiza ruchu internetowego

Wyświetlenia

Liczba wyświetleń opublikowanych dokumentów.

Czytelnicy

Liczba użytkowników, którzy wyświetlili opublikowane dokumenty.

Średni Czas czytania

Średnia ilość czasu spędzonego przez użytkownika na interakcji z opublikowanym dokumentem na wyświetlenie.

Łączny czas czytania

Łączny czas spędzony przez wszystkich użytkowników na aktywnym przeglądaniu opublikowanych dokumentów.

Wyświetl na urządzeniach

Rozkład wszystkich wyświetleń między komputery, urządzenia mobilne i tablety.

Trendy dokumentów

Ta karta stanowi źródło danych analitycznych na temat poszczególnych opublikowanych przez Ciebie dokumentów.

Trendy dokumentów
Trendy dokumentów

Wyświetlenia

Liczba wyświetleń opublikowanego dokumentu.

Czytelnicy

Liczba użytkowników, którzy wyświetlili opublikowany dokument.

Wyłączanie lub włączanie funkcję Publish Online

Funkcja Publish Online jest domyślnie dostępna po zainstalowaniu programu InDesign 2015. Można jednak usunąć jej odnośniki z interfejsu programu InDesign.

  1. Aby otworzyć okno dialogowe Preferencje, wybierz pozycję Edycja > Preferencje > Ogólne.

  2. W oknie dialogowym Preferencje wybierz kartę funkcji Publish Online.

  3. Aby usunąć odnośniki z interfejsu użytkownika, cofnij zaznaczenie opcji Publish Online i kliknij przycisk OK.

Ta zawartość jest licencjonowana na warunkach licencji Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Posty z serwisów Twitter™ i Facebook nie są objęte licencją Creative Commons.

Informacje prawne   |   Zasady prywatności online