Získejte další informace o pracovní ploše aplikace Dreamweaver, jednotlivých dostupných zobrazeních a pracovních plochách a různých panelech a panelech nástrojů v aplikaci Dreamweaver.

Úvodní nastavení aplikace Dreamweaver

Po instalaci aplikace Dreamweaver se při jejím prvním spuštění na obrazovce otevře nabídka Rychlý start, která obsahuje tři otázky, které vám pomohou s přizpůsobením pracovní plochy aplikace Dreamweaver podle vašich potřeb.

Na základě vašich odpovědí na tyto otázky se v aplikaci Dreamweaver otevře pracovní plocha pro vývojáře (minimální rozvržení zaměřené na psaní kódu) nebo standardní pracovní plocha (rozdělení rozložení s vizuálními nástroji a náhledem při psaní kódu v rámci aplikace). 

Po volbě pracovní plochy vyberte barevný motiv, který vám bude nejpříjemnější. Nyní už můžete začít.

Poznámka:

Tyto předvolby pracovní plochy můžete kdykoli později změnit pomocí dialogového okna Upravit > Předvolby.

Vylepšená domovská obrazovka

Domovská obrazovka aplikace Dreamweaver nabízí rychlý přístup k naposled použitým souborům, typům souborů a počátečním předlohám.

Podle stavu vašeho předplatného se na úvodní pracovní ploše také může zobrazovat obsah šitý na míru vašim požadavkům.

Aplikace Dreamweaver zobrazí úvodní obrazovku při spuštění nebo pokaždé, když nejsou otevřené žádné dokumenty.

Úvodní pracovní plocha v aplikaci Dreamweaver
Úvodní pracovní plocha v aplikaci Dreamweaver

Možnosti úvodního prostředí v aplikaci Dreamweaver

Učte se

Kliknutím na Učte se přejdete z této obrazovky rovnou k výukovým lekcím k aplikaci Dreamweaver.

Rychlý Start

Vytváření dokumentů v aplikaci Dreamweaver kliknutím na některý z uvedených typů souborů.

Počáteční předlohy

Otevření některé z počátečních předloh zahrnutých v aplikaci Dreamweaver. 

Domovská stránka

Kliknutím na Domovskou stránku se vrátíte na úvodní obrazovku. 

Na úvodní obrazovce uvidíte soubory, na kterých jste v poslední době pracovali. Pokud žádné nedávno otevřené soubory nemáte, tato karta bude prázdná.

Pomocí ikony Hledat v pravé horní části této obrazovky můžete využít také funkci hledání. Pokud zadáte hledaný výraz, aplikace zobrazí naposledy otevřené soubory, Creative Cloud zdroje, odkazy na nápovědu a obrázky odpovídající parametrům vyhledávání.

Poznámka:

Tato úvodní obrazovka je ve výchozím nastavení aktivní a otevřená. 

Pokud tuto úvodní obrazovku nepotřebujete, zrušte označení pole Zobrazit úvodní obrazovku v dialogovém okně Předvolby > Obecné.

Po kliknutí na Vytvořit nový můžete začít vytvářet nové soubory aplikace Dreamweaver. Pokud už ve svém systému nějaké soubory máte, klikněte na tlačítko Otevřít. Další informace o vytváření a otevírání dokumentů v aplikaci Dreamweaver najdete v tématu Vytvoření a otevření souborů.

Pracovní plocha – přehled

Pracovní plocha aplikace Dreamweaver umožňuje zobrazovat dokumenty a vlastnosti objektů. Na pracovní ploše je také většina běžných operací umístěna v panelech nástrojů, takže můžete rychle provádět změny svých dokumentů.

Pracovní plocha aplikace Dreamweaver (CC)
Pracovní plocha aplikace Dreamweaver

A. Aplikační panel B. Panel nástrojů Dokument C. Okno dokumentu D. Přepínač pracovní plochy E. Panely F. Zobrazení kódu G. Stavový řádek H. Selektor tagů I. Živé zobrazení J. Panel nástrojů 

Přehled elementů pracovní plochy

Pracovní plocha obsahuje následující elementy:

Aplikační pruh

Nachází se v horní části okna aplikace a obsahuje přepínač pracovní plochy, nabídky (pouze systém Windows) a další ovládací prvky aplikace.

Panel nástrojů dokumentu

Naleznete zde tlačítka, která nabízejí možnosti pro různá zobrazení okna dokumentu (jako například zobrazení návrhu, živé zobrazení a zobrazení kódu).

Panel nástrojů Standardní

Chcete-li zobrazit panel nástrojů Standardní, vyberte možnost Okno > Panely nástrojů > Standardní. Panel nástrojů obsahuje tlačítka pro běžné operace nabídek SouborÚpravy: Nový, Otevřít, Uložit, Uložit vše, Tisk kódu, Vyjmout, Kopírovat, Vložit, ZpětZnovu.

Panel nástrojů

Nachází se na levé straně okna aplikace a obsahuje tlačítka specifická pro aktuální zobrazení.

Okno dokumentu

Zde se zobrazí aktuální dokument, jakmile jej vytvoříte, zobrazí se také jeho případné úpravy.

Inspektor vlastností

Umožňuje zobrazovat a měnit různé vlastnosti vybraného objektu nebo textu. Každý objekt má jiné vlastnosti.

Selektor tagů

Je umístěn ve Stavovém řádku v dolní části okna Dokument. Zobrazuje hierarchii tagů, které jsou spojeny s aktuálním výběrem. Kliknutím na libovolný tag v hierarchii vyberete tento tag a veškerý jeho obsah.

Panely

Pomáhají monitorovat a upravovat práci. Mezi příklady patří panel Vložit, panel CSS Designer a panel Soubory. Panel zobrazte poklepáním na jeho záložku.

Panel Extract

Umožňuje odesílat a prohlížet soubory PSD ve službě Creative Cloud. Prostřednictvím tohoto panelu můžete získávat prvky CSS, text, obrázky, písma, barvy, přechody a míry z kompozic souboru PSD přímo pro svůj dokument.

Panel Vložit

Obsahuje tlačítka pro vkládání různých typů objektů, například obrazů, tabulek a elementů médií do dokumentu. Všechny objekty jsou kusem HTML kódu, které vám při vkládání umožňují nastavit různé atributy. Například kliknutím na tlačítko Tabulka na panelu Vložit můžete vložit tabulku. Pokud chcete, můžete objekty vkládat pomocí nabídky Vložit místo panelu Vložit.

Panel Soubory

Umožňuje spravovat soubory a složky, které jsou součástí webu aplikace Dreamweaver nebo se nachází na vzdáleném serveru. Panel Soubory vám rovněž umožňuje přístup ke všem souborům na lokálním disku. Další informace najdete v tématu Správa souborů a složek.

Panel Výstřižky

Umožňuje uložit a opakovaně používat výstřižky kódu na různých webových stránkách, různých webech a různých instalacích aplikace Dreamweaver (s použitím nastavení synchronizace). Další informace najdete v tématu Opakované použití kódu v podobě výstřižků.

Panel CSS Designer

představuje Inspektor vlastností CSS, který umožňuje „vizuálně“ vytvářet styly CSS, soubory, nastavovat vlastnosti a definovat multimediální dotazy.

Poznámka:

Aplikace Dreamweaver nabízí mnoho dalších panelů, inspektorů a oken. Chcete-li panely, inspektory a okna otevřít, použijte nabídku Okna.

Okno dokumentu – přehled

V okně dokumentu se zobrazuje aktuální dokument. Pokud budete chtít přepnout zobrazení dokumentu, použijte možnosti zobrazení na panelu nástrojů dokumentu. 

Podle potřeby můžete také přepínat zobrazení pomocí možností Zobrazit v nabídce Zobrazit.

Živé zobrazení

nabízí realističtější náhled na to, jak by dokument vypadal v prohlížeči, a umožňuje interakci s dokumentem snadnou jako v prohlížeči. Přímo v Živém zobrazení je možné měnit elementy HTML a okamžitě prohlížet náhled změn. Další informace o úpravě v Živém zobrazení najdete v tématu Úprava elementů HTML v Živém zobrazení.

Zobrazení návrhu

je návrhové prostředí pro vizuální rozvržení stránky, vizuální úpravy a rychlý vývoj aplikací. V tomto zobrazení aplikace Dreamweaver zobrazuje plně upravitelnou vizuální reprezentaci dokumentu podobnou tomu, co byste viděli při zobrazení stránky v prohlížeči.

Zobrazení kódu

je prostředí pro ruční programování pro zápis a úpravy kódu HTML, JavaScript a jakéhokoli jiného typu kódu.

Kód – kód

je rozdělená verze zobrazení kódu, která umožňuje přecházení na různé části dokumentu současně. 

Kód – živě

umožňuje vidět zobrazení kódu i živé zobrazení pro stejný dokument v jednom okně.

Kód – návrh

umožňuje vidět zobrazení kódu i zobrazení návrhu pro stejný dokument v jednom okně.

Živý kód

obsahuje skutečný kód, který prohlížeč použije k vykreslení stránky a který se při interakci se stránkou v živém zobrazení dynamicky mění.

Když je okno Dokument maximalizované (výchozí zobrazení), na horním okraji okna Dokument se objeví záložky zobrazující názvy všech otevřených dokumentů. Aplikace Dreamweaver zobrazí za názvem souboru hvězdičku, pokud jste provedli změny, které zatím nejsou uloženy.

Aplikace Dreamweaver také zobrazí panel nástrojů Související soubory pod záložkou dokumentu (nebo pod pruhem titulků dokumentu, pokud dokumenty zobrazujete v samostatných oknech). Související dokumenty jsou dokumenty spojené s aktuálním souborem, například soubory CSS nebo JavaScript. Chcete-li otevřít jeden z těchto souvisejících souborů v okně Dokument, klikněte na jeho název souboru na panelu nástrojů Související soubory.

Přepínání mezi zobrazeními

Panel nástrojů dokumentu umožňuje rychlé přepínání mezi různými zobrazeními. Další informace najdete v tématu Přehled panelu nástrojů dokumentu.

Podle potřeby můžete také přepínat mezi zobrazeními pomocí následujících možností v nabídce Zobrazit:

  • Pouze zobrazení kódu: Vyberte kód.
  • Rozdělené zobrazení: Vyberte možnost Rozdělit a vyberte některou z možností rozdělení.
  • Režim zobrazení: Přepínání mezi živým zobrazením a zobrazením návrhu.
  • Přepnutí zobrazení: Přepínání zobrazení z jednoho na jiné.
Přepínání mezi zobrazeními pomocí možností v nabídce Zobrazit
Přepínání mezi zobrazeními pomocí možností v nabídce Zobrazit

Stupňovité/dlaždicové zobrazení nebo změna pořadí u oken dokumentu

Pokud máte otevřeno mnoho dokumentů zároveň, můžete je zobrazit dlaždicově nebo stupňovitě.

Uspořádání oken stupňovitě: Vyberte možnost Okno > Uspořádat > Stupňovitě.

Dlaždicové zobrazení oken dokumentu: 

  • (systém Windows) Vyberte možnost Okno > Uspořádat > Dlaždicově vodorovně nebo Dlaždicově svisle.
  • (systém Macintosh) Vyberte možnost Okno > Uspořádat > Dlaždicově.

Při otevření více než jednoho souboru jsou okna dokumentu označena značkami. Chcete-li změnit pořadí oken dokumentu označených značkami, přetáhněte záložku okna do nového umístění ve skupině.

Změna velikosti okna dokumentu

Stavový řádek zobrazuje aktuální rozměry okna dokumentu v obrazových bodech. Pokud chcete stránku navrhnout tak, aby vypadala co nejlépe v určité velikosti, můžete nastavit okno dokumentu na některou z přednastavených velikostí, upravit tyto velikosti nebo vytvořit nové velikosti.

Pokud změníte velikost zobrazení v návrhu nebo v Živém zobrazení, změní se pouze rozměry zobrazení. Velikost dokumentu zůstane nezměněna.

Kromě předem nastavených a vlastních velikostí budou v aplikaci Dreamweaver uvedeny také velikosti zadané v multimediálním dotazu. Pokud vyberete velikost odpovídající multimediálnímu dotazu, aplikace Dreamweaver použije k zobrazení stránky multimediální dotaz. Také můžete změnit orientaci stránky k zobrazení náhledu stránky v mobilních zařízeních, kde se rozložení stránky mění podle způsobu držení zařízení.

Pokud budete chtít změnit velikost okna dokumentu, vyberte některou velikost v rozbalovací nabídce Velikost okna v dolní části okna dokumentu.

Možnosti změny velikosti dokumentu
Možnosti změny velikosti dokumentu

Zobrazená velikost okna vyjadřuje vnitřní rozměry okna prohlížeče bez okrajů; velikost monitoru nebo mobilních zařízení je uvedena vpravo.

Poznámka:

Méně přesné změny velikosti dosáhnete při použití standardních metod změny velikosti oken v operačním systému, například tažením pravého dolního rohu okna.

Poznámka:

(Pouze systém Windows) Dokumenty v okně dokumentu jsou ve výchozím nastavení maximalizované a v takovém případě nelze změnit jejich velikost. Chcete-li zrušit maximalizaci dokumentu, klikněte na tlačítko pro zrušení maximalizace v pravém horním rohu dokumentu.

Změna hodnot uvedených v rozbalovací nabídce Velikost okna

  1. V rozbalovací nabídce Velikost okna vyberte volbu Upravit velikosti.

  2. Klikněte na některou z hodnot šířky nebo výšky v seznamu Velikosti okna a zadejte novou hodnotu. Pokud budete chtít, aby se okno dokumentu přizpůsobilo pouze ve směru šířky (tedy ponechat výšku beze změny), vyberte hodnotu výšky a smažte ji.

  3. Klikněte na textové pole Popis a zadejte popisný text o určité velikosti.

Přidání nové velikosti do rozbalovací nabídky Velikost okna

  1. V rozbalovací nabídce Velikost okna vyberte volbu Upravit velikosti.

    Přidání velikostí okna do rozbalovací nabídky Velikost okna
    Přidání velikostí okna do rozbalovací nabídky Velikost okna

  2. Klikněte na prázdné místo pod poslední hodnotou ve sloupci Šířka.

  3. Zadejte hodnoty Šířka a Výška.

    Pokud chcete nastavit pouze šířku nebo výšku, nechte druhé pole prázdné.

  4. Klepněte na pole Popis a zadejte popis přidané velikosti.

    Můžete například zadat hodnotu SVGA nebo průměrné PC vedle položky pro monitor s rozlišením 800 x 600 obrazových bodů a hodnotu 17palcový Mac vedle položky pro monitor s rozlišením 832 x 624 obrazových bodů. Většina monitorů dokáže zobrazit různé rozměry v obrazových bodech.

  5. Klikněte na tlačítko Použít a dialogové okno zavřete.

    Vámi zadaná nová velikost okna bude nyní k dispozici v rozbalovací nabídce Velikost okna.

Přehled panelu nástrojů dokumentu

Panel nástrojů Dokument obsahuje tlačítka umožňující rychlé přepínání mezi různými zobrazeními dokumentu. Panel nástrojů také obsahuje některé běžné příkazy a volby související se zobrazením dokumentu a jeho přenosem mezi vzdálenými a lokálními webovými stránkami.

Panel nástrojů Dokument (CC)
Panel nástrojů Dokument

v panelu nástrojů Dokument se zobrazují následující volby:

Zobrazení kódu

Zobrazí v okně Dokument pouze zobrazení kódu.

Rozdělené zobrazení

Rozdělí okno Dokument na zobrazení kódu a živé zobrazení / zobrazení návrhu. Možnost zobrazení návrhu není pro dokumenty s plovoucí mřížkou k dispozici.

Živé zobrazení

Jedná se o interaktivní náhled, který přesně vykresluje projekty HTML5 a aktualizuje v reálném čase vámi provedené změny. Elementy HTML lze také měnit přímo v Živém zobrazení. Rozevírací seznam v blízkosti živého zobrazení umožňuje přecházet mezi živým zobrazením a zobrazením návrhu. Tento rozevírací seznam není k dispozici pro dokumenty s plovoucí mřížkou.

Zobrazení návrhu

Zobrazí reprezentaci dokumentu, ve které je vidět, jak se dokument zobrazí uživateli ve webovém prohlížeči. 

Přehled panelu nástrojů Standardní

Panel nástrojů Standardní

Chcete-li zobrazit panel nástrojů Standardní, vyberte možnost Okno > Panely nástrojů > Standardní. Panel nástrojů obsahuje tlačítka pro běžné operace nabídek SouborÚpravy: Nový, Otevřít, Uložit, Uložit vše, Tisk kódu, Vyjmout, Kopírovat, Vložit, ZpětZnovu.

Přehled panelu nástrojů Navigace v prohlížeči

Panel nástrojů Navigace v prohlížeči se aktivuje v okně živého zobrazení (v případě, že jste to povolili výběrem možnosti Okno->Panely nástrojů->Standardní) a zobrazí adresu právě sledované stránky v okně Dokument. Okno Živé zobrazení slouží jako běžný prohlížeč, takže i když přejdete na stránku mimo váš místní web (například http://www.adobe.com/cz), aplikace Dreamweaver načte tuto stránku v okně Dokument.

Panel nástrojů Navigace v prohlížeči (CC)
Panel nástrojů Navigace v prohlížeči

A. Ovládací prvky prohlížeče B. Rámeček pro adresu 

Ve výchozím nastavení nejsou odkazy v okně Živé zobrazení aktivní. Neaktivní odkazy umožňují vybrat nebo kliknout na text odkazu v okně Dokument, aniž byste přecházeli na danou stránku. Chcete-li otestovat odkazy v okně živého zobrazení, můžete povolit jednorázové kliknutí nebo trvalé klikání zvolením možností Zobrazit > Možnosti živého zobrazení > Sledovat odkazy (Ctrl + kliknutí na odkaz) nebo Sledovat odkazy nepřetržitě.

Přehled panelu nástrojů

Panel nástrojů je umístěn svisle na levé straně okna dokumentu a je viditelný v každém ze zobrazení, tedy v Živém zobrazení a zobrazení kódu/návrhu. Tlačítka na panelu nástrojů mají funkce specifické pro konkrétní zobrazení a viditelná jsou pouze tehdy, pokud je lze použít pro zobrazení, ve kterém právě pracujete. Například pokud pracujete v Živém zobrazení, možnosti pro zobrazení kódu, jako je Formátovat zdrojový kód, se nezobrazí. 

Přizpůsobit panel nástrojů

Podle potřeby můžete tento panel nástrojů přizpůsobit přidáním nebo odebráním možností nabídky z panelu nástrojů.

Panel nástrojů můžete přizpůsobit následujícím způsobem:

  1. Kliknutím na ikonu na panelu nástrojů otevřete dialogové okno Přizpůsobit panel nástrojů.

    Přizpůsobit panel nástrojů
    Přizpůsobit panel nástrojů

  2. Vyberte nebo zrušte výběr možností nabídky, které chcete, resp. nechcete mít na panelu nástrojů k dispozici, a kliknutím na tlačítko Hotovo panel nástrojů uložte.

Jestliže budete chtít tlačítka na panelu nástrojů obnovit, klikněte v dialogovém okně Přizpůsobit panel nástrojů na možnost Obnovit výchozí.

Přehled stavového řádku

Stavový řádek na dolním okraji okna Dokument poskytuje další informace o dokumentu, který vytváříte.

Stavový řádek (CC)
Stavový řádek

A. Selektor tagů B. Panel Výstup C. Barevné zvýraznění kódu D. Přepínání režimu vkládání a přepisování E. Číslo řádku a sloupce 

Selektor tagů

Zobrazuje hierarchii tagů, které jsou spojeny s aktuálním výběrem. Kliknutím na libovolný tag v hierarchii vyberete tento tag a veškerý jeho obsah. Kliknutím na text <body> vyberete celý základní obsah dokumentu. Chcete-li nastavit atributy class nebo ID pro tag v selektoru tagů, klikněte na tag pravým tlačítkem (Windows) nebo se stisknutou klávesou Ctrl (Macintosh) a vyberte třídu nebo identifikátor z kontextové nabídky.

Panel Výstup

Kliknutím na tuto ikonu zobrazíte panel Výstup, ve kterém jsou uvedeny chyby v kódu pro váš dokument.

Barevné zvýraznění kódu

(k dispozici pouze v zobrazení kódu)

Výběrem jednoho z programovacích jazyků v této rozbalovací nabídce upravíte barevné zvýraznění kódu podle daného programovacího jazyka.

Přepínání režimu vkládání a přepisování

(k dispozici pouze v zobrazení kódu)

Umožňuje při práci v zobrazení kódu přepínat mezi režimem vložení a přepsání.

Číslo řádku a sloupce

(k dispozici pouze v zobrazení kódu)

Zobrazí číslo řádku a sloupce, na kterém se kurzor nachází.

Přehled inspektoru vlastností

Inspektor vlastností (Okno > Vlastnosti) umožňuje prohlížení a úpravy většiny běžných vlastností aktuálně vybraného elementu stránky, například textu nebo vloženého objektu.

Obsah Inspektoru vlastností se mění podle vybraného elementu. Pokud například vyberete na stránce obraz, Inspektor vlastností se změní a zobrazí vlastnosti pro obraz (jako je cesta souboru obrazu, šířka a výška obrazu, okraj kolem obrazu, pokud existuje, a podobně).

Inspektor vlastností (CC)
Inspektor vlastností

Inspektor vlastností se ve výchozím nastavení nachází na dolním okraji pracovní plochy, ale můžete zrušit jeho ukotvení a učinit z něj plovoucí panel v pracovním prostoru.

Poznámka:

Inspektor tagů se používá k zobrazení a úpravám všech atributů spojených s danými vlastnostmi tagu.

Chcete-li použít nápovědu pro konkrétní Inspektor vlastností, klikněte na tlačítko Nápověda v pravém horním rohu inspektoru Vlastnosti nebo vyberte možnost Nápověda v nabídce Možnosti inspektoru Vlastnosti.

Zobrazení a změna vlastností elementu stránky

  1. Vyberte element stránky v okně dokumentu.

    Možná budete muset Inspektor vlastností rozšířit, abyste viděli všechny vlastnosti vybraného elementu.

  2. Změňte požadované vlastnosti v inspektoru Vlastnosti.

    Poznámka:

    Chcete-li získat informace o jednotlivých vlastnostech, vyberte element v okně dokumentu a pak klikněte na ikonu Nápověda v pravém horním rohu inspektoru Vlastnosti.

  3. Pokud se změny neaplikují v okně dokumentu okamžitě, aplikujte změny jedním z následujících způsobů:

    • Klikněte mimo textová pole pro úpravy vlastností.
    • Stiskněte klávesu Enter (Windows) nebo Return (Macintosh).
    • Přejděte na další vlastnost stiskem klávesy Tab.

Kontextové nabídky

Kontextové nabídky nabízí pohodlný přístup k nejužitečnějším příkazům a vlastnostem souvisejícím s objektem nebo oknem, se kterým pracujete. Kontextové nabídky uvádějí pouze příkazy, které se týkají aktuálního výběru.

Pokud budete chtít kontextovou nabídku otevřít, klikněte pravým tlačítkem (Windows) nebo s klávesou Ctrl (Mac) na část kódu v zobrazení kódu, nebo na objekt v Živém zobrazení / zobrazení návrhu.

Změna pořadí panelů v aplikaci Dreamweaver

Umístění a vzhled všech panelů v aplikaci Dreamweaver můžete přizpůsobit podle svých požadavků.

Ukotvení panelů a zrušení ukotvení

  • Chcete-li panel ukotvit, přetáhněte ho za jeho záložku do zásuvky, nad, pod nebo mezi ostatní panely.
  • Chcete-li ukotvit skupinu panelů, přetáhněte ji za její titulní pruh (prázdný pruh nad záložkami) do zásuvky.
  • Chcete-li odstranit panel nebo skupinu panelů, přetáhněte je mimo zásuvku za záložku nebo titulní pruh. Můžete ho přetáhnout do jiné zásuvky nebo ho můžete změnit na volně plovoucí.

Přemísťování panelů

Při přemísťování panelů uvidíte modře zvýrazněné cílové zóny přetažení, což jsou oblasti, kam můžete panel přemístit. Můžete například posunout panel nahoru nebo dolů v zásuvce jeho přetažením do úzké modré cílové zóny přetažení nad nebo pod jiným panelem. Pokud ho přetáhnete do oblasti, která není cílovou zónou přetažení, panel bude plovoucí na pracovní ploše.

  • Chcete-li panel přesunout, přetáhněte jej za jeho záložku.
  • Chcete-li přesunout skupinu panelů, přetáhněte ji za titulní pruh.

Poznámka:

Stiskněte klávesu Ctrl (Windows) nebo Command (Mac OS), pokud nechcete, aby se panel při přemísťování ukotvil. Při přesouvání panelu zrušíte tuto operaci stisknutím klávesy ESC.

Přidání a odebrání panelů

Pokud odstraníte všechny panely ze zásuvky, tato zásuvka zmizí. Ukotvení můžete vytvořit přesunutím panelů na pravou stranu pracovního prostoru, dokud se nezobrazí zóna pro umístění panelu.

  • Chcete-li panel odebrat, klikněte na něj pravým tlačítkem myši (Windows), nebo podržte stisknutou klávesu Control (Mac) a klikněte na jeho záložku a pak vyberte tlačítko Zavřít, nebo zrušte výběr z nabídky Okno.
  • Chcete-li přidat panel, vyberte jej z nabídky Okno a ukotvěte jej na libovolné místo.

Manipulace se skupinami panelů

  • Chcete-li přesunout panel do skupiny, přetáhněte záložku panelu do zvýrazněné cílové zóny přetažení ve skupině.
  • Chcete-li změnit uspořádání panelů ve skupině, přetáhněte záložku panelu do nového místa ve skupině.
  • Chcete-li odstranit panel ze skupiny tak, aby byl plovoucí, přetáhněte panel za jeho záložku ven ze skupiny.
  • Chcete-li přesunout skupinu, přetáhněte ji za titulní pruh (oblast nad záložkami).

Svázání plovoucích panelů

Když přetahujete panel mimo ukotvení, ale jinam než do cílové zóny přetažení, panel volně plave. Plovoucí panel lze umístit kdekoli na pracovní ploše. Plovoucí panely nebo skupiny panelů můžete svázat, aby se při přetažení horního titulního pruhu pohybovaly jako jeden celek.

  • Chcete-li svázat plovoucí panely, přetáhněte panel za záložku do cílové zóny přetažení na dolním okraji jiného panelu.
  • Chcete-li změnit pořadí ve svazku, přetáhněte panel nahoru nebo dolů za jeho záložku.
  • Chcete-li odstranit panel nebo skupinu panelů ze svazku, aby byla volně plovoucí, přetáhněte ji ven za její záložku nebo titulní pruh.

Změna velikosti panelů

  • Poklepejte na záložku, chcete-li minimalizovat nebo maximalizovat panel, skupinu panelů nebo svázané panely. Můžete také poklepat na oblast záložky (prázdný prostor vedle záložek).
  • Chcete-li změnit velikost panelu, přetáhněte jeho libovolnou stranu. 

Sbalení a rozbalení ikon panelu

Panely můžete sbalit do ikon a omezit tím přeplnění pracovní plochy. V některých případech jsou panely sbaleny do ikon již ve výchozí pracovní ploše.

  • Chcete-li sbalit nebo rozbalit všechny ikony panelů ve sloupci, klikněte na dvojitou šipku nahoře v ukotvení.
  • Chcete-li rozbalit ikonu jednoho panelu, klikněte na ni.
  • Chcete-li změnit ikony panelů tak, aby se zobrazovaly pouze ikony (a nikoli popisky), upravte šířku ukotvení, dokud text nezmizí. Chcete-li text ikony znovu zobrazit, nastavte ukotvení jako širší.
  • Chcete-li sbalit rozbalený panel zpátky do ikony, klikněte na jeho záložku, ikonu nebo na dvojitou šipku v titulním pruhu panelu.

Vytvoření vlastních pracovních ploch

Svoji pracovní plochu můžete přizpůsobit přidáním nebo odebráním panelů podle vašich požadavků. Poté můžete tyto změny ve vaší pracovní ploše uložit pro pozdější použití prostřednictvím Přepínače pracovní plochy na panelu nástrojů dokumentu.

Když uložíte stávající velikost a polohu panelů jako pojmenovanou pracovní plochu, můžete obnovit tuto pracovní plochu i v případě, že přesunete nebo zavřete některý panel.

Postup uložení vlastní pracovní plochy:

  1. Klikněte na položky Okno > Rozvržení pracovní plochy > Nová pracovní plocha.
  2. Zadejte název pracovní plochy.

Pracovní plocha se uloží a bude viditelná v nabídce Přepínač pracovní plochy na panelu nástrojů dokumentu.

Postup odstranění vlastní pracovní plochy:

V přepínači pracovní plochy na pruhu Aplikace vyberte položku Správa pracovních ploch a otevřete tak dialogové okno Spravovat pracovní plochy. Vyberte pracovní plochu a klikněte na tlačítko Odstranit.

Zobrazení nebo přepínání mezi pracovními plochami

V přepínači pracovních ploch na panelu nástrojů dokumentu vyberte pracovní plochu.

Přizpůsobení aplikace Dreamweaver ve víceuživatelských systémech

Aplikaci Dreamweaver můžete přizpůsobit tak, aby vyhovovala vašim potřebám, dokonce i ve víceuživatelských operačních systémech, jako jsou Windows XP nebo Mac OS X.

Aplikace Dreamweaver zabrání tomu, aby přizpůsobená konfigurace některého uživatele ovlivnila přizpůsobenou konfiguraci kteréhokoli jiného uživatele. K dosažení výše uvedeného si aplikace Dreamweaver při prvním spuštění v jednom z rozpoznaných víceuživatelských systémů vytvoří kopie konfiguračních souborů. Tyto uživatelské konfigurační soubory se uloží do složky, která patří aktuálnímu uživateli.

Pokud aplikaci Dreamweaver přeinstalujete nebo upgradujete, automaticky si vytvoří záložní kopie stávajících konfiguračních souborů uživatele, takže pokud jste tyto soubory ručně přizpůsobili, budete mít stále přístup k těmto provedeným změnám.

Zobrazení dokumentů se záložkami (pouze v systému Mac)

V jednom okně dokumentu můžete zobrazit více dokumentů s použitím záložek pro identifikaci jednotlivých dokumentů. Můžete je také zobrazit jako součást plovoucí pracovní plochy, ve které se každý dokument zobrazí ve vlastním okně.

Otevření dokumentu v záložce v samostatném okně

Klikněte na záložku se stisknutou klávesou Ctrl a z kontextové nabídky vyberte možnost Přesunout do nového okna.

Změna výchozího nastavení dokumentů se záložkami

  1. Vyberte možnost Dreamweaver > Předvolby a pak vyberte kategorii Všeobecné.
  2. Vyberte nebo odznačte možnost Otevírat dokumenty v záložkách a klikněte na tlačítko OK.

Aplikace Dreamweaver při změně předvoleb nezmění zobrazení aktuálně otevřených dokumentů. Dokumenty otevřené po výběru nové předvolby se ale zobrazí podle této předvolby.

Úvodní obrazovka se objeví, když spustíte aplikaci Dreamweaver nebo když nejsou otevřené žádné dokumenty. Úvodní obrazovku můžete skrýt a pak později znovu zobrazit. Když je úvodní obrazovka skrytá a nejsou otevřené žádné dokumenty, okno Dokument je prázdné.

Běžné panely aplikace Dreamweaver

v aplikaci Dreamweaver budete pracovat s celou řadou panelů. Některé běžně používané panely jsou popsány zde.

Přehled panelu Vložit

Panel Vložit (Okno > Vložit) obsahuje tlačítka pro vytváření a vkládání objektů, jako jsou tabulky, obrázky a odkazy. Tlačítka jsou uspořádána do několika kategorií, mezi nimiž můžete přepínat výběrem požadované kategorie z rozevíracího seznamu v horní části.

Panel Vložit
Panel Vložit

Některé kategorie mají tlačítka s rozbalovacími nabídkami. Když vyberete volbu z rozbalovací nabídky, stane se z ní výchozí akce tohoto tlačítka. Pokud například z rozbalovací nabídky tlačítka Znak vyberete možnost Zalomení řádku, při dalším kliknutí na tlačítko Znak vloží aplikace Dreamweaver zalomení řádku. Pokaždé, když vyberete novou volbu z rozbalovací nabídky, výchozí akce tlačítka se změní.

Panel Vložit je uspořádán do následujících kategorií:

HTML

Umožňuje vytvářet a vkládat nejběžněji používané elementy HTML, jako např. tagy div, a objekty, jako jsou obrázky a tabulky.

Formulář

Obsahuje tlačítka pro vytváření formulářů a vkládání prvků formuláře, jako např. hledání, měsíc nebo heslo.

Předlohy

Umožňuje uložit dokument jako předlohu a umožnit úpravu určitých oblastí nebo je označit za volitelné, opakující se nebo volitelně upravitelné.

Komponenty nástroje Bootstrap

Obsahuje komponenty Bootstrap, které umožňují používat navigaci, kontejnery, rozbalovací nabídky a další položky používané u responzivních projektů.

jQuery Mobile

Obsahuje tlačítka pro vytváření webů, které používají rozhraní jQuery Mobile.

jQuery UI

Umožňuje vkládat elementy jQuery UI, jako např. Accordion, posuvníky nebo tlačítka.

Oblíbené

Umožňuje seskupit a uspořádat tlačítka z panelu Vložit, která nejčastěji používáte, na jednom společném místě.

Poznámka:

 Pokud pracujete s určitými typy souborů (například XML, JavaScript, Java a CSS), jsou panel Vložit a možnost zobrazení návrhu ztlumené, protože do těchto souborů kódu nelze vkládat položky.

Vložit objekt

Postup vložení objektu pomocí panelu Vložit:

  1. Vyberte odpovídající kategorii z rozbalovací nabídky Kategorie v panelu Vložit.

  2. Proveďte jeden z následujících úkonů:

    • Klikněte na tlačítko objektu nebo přetáhněte ikonu tlačítka do okna Dokument (v zobrazení návrhu, kódu nebo v Živém zobrazení).

    • Klepněte na šipku na tlačítku a v nabídce vyberte volbu.

      Podle objektu se může zobrazit odpovídající okno pro vložení objektu s výzvou, abyste přešli na soubor nebo zadali parametry objektu. Aplikace Dreamweaver také umožňuje do dokumentu vložit kód nebo otevřít editor tagů nebo panel k zadání informací před vložením kódu.

      U některých objektů se při vložení v zobrazení Návrh nezobrazí žádné dialogové okno, ale při vložení v zobrazení Kód se zobrazí editor tagů. Při vkládání některých objektů v zobrazení Návrh se aplikace Dreamweaver před vložením přepne do zobrazení kódu.

Úprava předvoleb panelu Vložit

  1. Vyberte možnost Úpravy > Předvolby (Windows) nebo Dreamweaver > Předvolby (Macintosh).

  2. V kategorii Všeobecné v dialogovém okně Předvolby odznačte možnost Při vkládání objektů zobrazit dialog, abyste potlačili zobrazování dialogových oken při vkládání objektů, jako jsou obrázky, tabulky, skripty a elementy hlavičky, nebo při vytváření těchto objektů podržte stisknutou klávesu Ctrl (Windows) nebo Alt (Macintosh).

Poznámka:

Když vložíte objekt a tato volba je vypnutá, objektu se přidělí výchozí hodnoty atributů. Vlastnosti objektu po jeho vložení změníte pomocí Inspektoru vlastnosti.

Přidání, odstranění a správa položek v kategorii Oblíbené v panelu Vložit

  1. V panelu Vložit vyberte libovolnou kategorii.

  2. Klikněte pravým tlačítkem (Windows) nebo se stisknutou klávesou Ctrl (Macintosh) do oblasti s tlačítky a poté vyberte možnost Upravit oblíbené.

  3. V dialogovém okně Upravit oblíbené objekty proveďte nezbytné změny a klikněte na tlačítko OK.

    Chcete-li přidat objekt, vyberte některý z objektů v dílčím panelu Dostupné objekty na levé straně a pak klikněte na šipku mezi dvěma dílčími panely nebo poklikejte na objekt v dílčím panelu Dostupné objekty.

    Přizpůsobení oblíbených položek na panelu Vložit
    Přizpůsobení oblíbených položek na panelu Vložit

    Poznámka:

    Najednou můžete přidat pouze jeden objekt. Nemůžete vybrat název kategorie, například Běžné, a přidat do seznamu oblíbených položek celou kategorii.

    • Chcete-li odstranit objekt nebo oddělovač, vyberte objekt v dílčím panelu Oblíbené objekty na pravé straně a poté klikněte na tlačítko Odstranit vybraný objekt ze seznamu oblíbených objektů nad tímto dílčím panelem.
    • Chcete-li objekt přemístit, vyberte objekt v dílčím panelu Oblíbené objekty na pravé straně a poté klikněte na tlačítko se šipkou nahoru nebo dolů nad tímto dílčím panelem.
    • Chcete-li pod objekt přidat oddělovač, vyberte objekt v dílčím panelu Oblíbené objekty na pravé straně a poté klikněte na tlačítko Přidat oddělovač pod tímto dílčím panelem.
  4. Pokud nejste v kategorii Oblíbené na panelu Vložit, vyberte tuto kategorii, abyste viděli provedené změny.

Přehled panelu Soubory

Panel Soubory se používá k zobrazování a správě souborů webu aplikace Dreamweaver.

Panel Soubory vám umožní zobrazit soubory a složky, když jsou i když nejsou připojené k webovému místu aplikace Dreamweaver, a provádí standardní operace údržby, například otevírání a přesouvání souborů.

Panel Soubory také pomáhá spravovat a přenášet soubory ze vzdáleného serveru a na tento server. 

Panel Soubory
Panel Soubory

Další informace o všech možnostech práce s panelem Soubory najdete v tématu Správa souborů a složek.

CSS Designer

Panel CSS Designer (Okna > CSS Designer) představuje Inspektora vlastností CSS, který umožňuje vizuálně vytvářet soubory styly CSS, soubory, nastavovat vlastnosti a definovat multimediální dotazy.

Pomocí kombinace kláves Ctrl/Cmd + Z můžete vrátit a pomocí kláves Ctrl/Cmd + Y znovu provést všechny akce provedené v nástroji CSS Designer. Změny se automaticky projeví v Živém zobrazení i souvisejícím souboru CSS. Aby bylo patrné, že se související soubor změnil, jeho karta se na několik okamžiků rozsvítí (přibližně na 8 sekund).

Panel CSS Designer (CC)
Panel CSS Designer

Panel CSS Designer je tvořen z následujících podoken a možností:

Vše Uvedeny jsou všechny prvky CSS, multimediální dotazy a selektory přiřazené v aktuálním dokumentu. Podle potřeby můžete filtrovat požadovaná pravidla CCS a měnit vlastnosti. Tento režim můžete použít také v případě, chcete-li začít vytvářet selektory nebo multimediální dotazy.

Tento režim se nepřizpůsobuje výběru. To znamená, že pokud vyberete na stránce element, přiřazený selektor, multimediální dotaz ani kód CSS nebudou zvýrazněny v panelu CSS Designer.

Současný Uvedeny jsou všechny vypočítané styly pro každý vybraný prvek v zobrazení návrhu nebo živém zobrazení aktuálního dokumentu. Pokud použijete tento režim pro soubor CSS v Zobrazení kódu, budou zobrazeny všechny vlastnosti pro aktivní selektor.

Tento režim se přizpůsobuje aktuálnímu obsahu. Pomocí této možnosti můžete upravit vlastnosti selektoru přiřazené k vybraným elementům v dokumentu.

Zdroje Obsahuje všechny seznamy stylů CSS přiřazené k dokumentu. Pomocí tohoto podokna můžete vytvářet a připojit prvky CSS k dokumentu nebo určit jeho styl.

@Média Seznam všech multimediálních dotazů ze zdroje vybraného v podokně Zdroje. Pokud nevyberete konkrétní prvek CSS, toto podokno bude obsahovat všechny multimediální dotazy související s daným dokumentem.

Selektory Seznam všech selektorů ze zdroje vybraného v podokně Zdroje. Jestliže vyberete současně také multimediální dotaz, toto podokno bude obsahovat seznam selektorů pro daný multimediální dotaz. Pokud nevyberete konkrétní prvek CSS ani multimediální dotaz, toto podokno bude obsahovat všechny selektory dokumentu.

Pokud v podokně @Média vyberete možnost Globálně, zobrazí se všechny selektory, které nejsou součástí multimediálního dotazu pro vybraný zdroj.

Vlastnosti Vlastnosti, které můžete u daného selektoru měnit. Další informace najdete v tématu Nastavení vlastností.

Pokud panely v nástroji CSS Designer sbalíte nebo rozbalíte, upravená velikost těchto panelů bude uložena po celou dobu trvání relace. Panely Zdroje a Média si zapamatují upravenou velikost až do její další úpravy.

Poznámka: Při výběru prvku stránky se v podokně Selektory vybere nejvhodnější selektor. Pokud budete chtít zobrazit vlastnosti daného selektoru, klikněte v podokně na jeho název.

Budete-li chtít zobrazit všechny selektory, vyberte v podokně Zdroje možnost Všechny zdroje. Selektory, které nejsou součástí žádných multimediálních dotazů ve vybraném zdroji, zobrazíte kliknutím na možnost Globálně v podokně @Média.

Přehled vizuálních pomůcek

Aplikace Dreamweaver poskytuje několik typů vizuálních pomůcek, které vám pomohou navrhovat dokumenty a přibližně předvídat, jak se zobrazí v prohlížečích. Můžete provést libovolný z následujících úkonů:

  • Okamžitě přepínat okno Dokument do požadované velikosti, abyste viděli, jak se elementy vejdou na stránku.

  • Používat obkreslovaný obraz jako pozadí stránky, které pomáhá duplikovat návrh vytvořený v ilustraci nebo aplikaci pro úpravu obrazů, jako je Adobe® Photoshop® nebo Adobe® Fireworks®.

  • Používat pravítka a vodítka jako vizuální pomůcku pro přesné umísťování a nastavení velikosti elementů stránky.

  • Používat mřížku pro přesné umísťování a nastavení velikosti absolutně polohovaných elementů (AP elementů).

    Značky mřížky na stránce vám pomohou zarovnat AP elementy, a když je zapnuté přitahování, AP elementy se při přemísťování nebo změně velikosti automaticky přitáhnou na nejbližší bod mřížky. (Ostatní objekty, například obrazy a odstavce, se na mřížku nepřitahují.) Přitahování funguje bez ohledu na to, zda je mřížka viditelná.

Zvětšení a zmenšení stránky

Aplikace Dreamweaver v okně dokumentu umožňuje zvětšit zobrazení, takže můžete kontrolovat přesnost obrazových bodů grafiky, snáze vybírat malé položky, navrhovat stránky s malým textem, navrhovat velké stránky a tak dále.

Ke zvětšení nebo zmenšení stránky můžete použít nabídku Zobrazit > Možnosti zobrazení návrhu > Zvětšení a vybrat zde některou z nabízených možností zvětšení.

Vybírat můžete z řady možností zvětšení. Také můžete vybrat následující:

  • Přizpůsobit výběr – po označení objektu nebo textu můžete pomocí této možnosti vyplnit okno dokumentu daným výběrem.
  • Přizpůsobit vše – vyplnění okna dokumentu celou stránkou
  • Podle šířky – vyplnění okna dokumentu celou šířkou stránky

Poznámka:

Zvětšit zobrazení můžete i bez použití nástroje lupa – stisknutím kláves Ctrl += (Windows) nebo Cmd += (Macintosh). Zmenšovat můžete i bez použití nástroje lupa stiskem kláves Ctrl +- (Windows) nebo Cmd +- (Macintosh).

Nastavení všeobecných předvoleb aplikace Dreamweaver

  1. Vyberte volbu Úpravy > Předvolby (Windows) nebo Dreamweaver > Předvolby (Macintosh).

  2. Nastavte libovolné z následujících voleb:

    Otevírat dokumenty v záložkách Otevře všechny dokumenty v jednom okně se záložkami, které umožňují přepínat mezi dokumenty (pouze Mac).

    Zobrazit úvodní obrazovku Zobrazí úvodní obrazovku aplikace Dreamweaver, když aplikaci Dreamweaver spustíte nebo když nejsou otevřené žádné dokumenty.

    Při spuštění znovu otevřít dokumenty Otevře všechny dokumenty, které byly otevřené, když jste aplikaci Dreamweaver ukončili. Pokud tuto možnost nevyberete, v aplikaci Dreamweaver se po spuštění zobrazí úvodní obrazovka nebo prázdná obrazovka (v závislosti na nastavení Zobrazit úvodní obrazovku).

    Upozornit při otevírání souborů pouze ke čtení Upozorní vás, když otevřete soubor pouze ke čtení (zamknutý). Můžete zvolit, že chcete soubor odemknout/vyhradit, zobrazit nebo otevírání zrušit.

    Povolit související soubory Umožňuje zobrazit, které soubory jsou připojeny k aktuálnímu dokumentu (například soubory CSS nebo JavaScript). Aplikace Dreamweaver zobrazí tlačítko pro každý související soubor v horní části dokumentu a otevře soubor po klepnutí na tlačítko.

    Vyhledat dynamicky související soubory Umožní vám vybrat, zda se dynamicky související soubory zobrazí v panelu nástrojů Související soubory automaticky, nebo po manuální interakci. Můžete se také rozhodnout zjišťování dynamicky souvisejících souborů zakázat.

    Aktualizovat odkazy při přemísťování souborů Určuje, co se stane, když přemístíte, přejmenujete nebo odstraníte dokument uvnitř svého webového místa. Tuto předvolbu můžete nastavit tak, aby se odkazy vždy automaticky aktualizovaly, nikdy se neaktualizovaly nebo aby se zobrazila výzva upozorňující na provedení aktualizace. (Viz Automatická aktualizace odkazů.)

    Při vkládání objektů zobrazit dialogové okno Určuje, zda se v aplikaci Dreamweaver zobrazí výzva k zadání dalších informací při vkládání obrázků, tabulek, filmů Shockwave nebo některých dalších objektů pomocí nabídky nebo panelu Vložit. Pokud je tato volba vypnutá, dialogové okno se neobjeví a k určení zdrojového souboru pro obraz, počtu řádek v tabulce a podobně musíte použít inspektor Vlastnosti. U obrazů s efekty přechodu myši a souborů HTML aplikace Fireworks se při vložení objektu dialogové okno zobrazí vždy bez ohledu na nastavení této volby. (Chcete-li toto nastavení dočasně změnit, klepněte při vytváření a vkládání objektů se stisknutou klávesou Ctrl (Windows) nebo Apple (Macintosh).)

    Povolit inline vstup dvoubytových znaků Umožňuje zadávat dvoubytový text přímo do okna dokumentu, pokud používáte vývojové prostředí nebo jazykovou sadu, která podporuje dvoubytový text (například japonské znaky). Když tato možnost není vybraná, objeví se okno pro zadávání a převod dvoubytového textu; text se objeví v okně dokumentu až po potvrzení.

    Po nadpisu přepnout na prostý odstavec Určuje, že v zobrazení návrhu nebo živém zobrazení vytvoří stisknutí klávesy Enter (Windows) nebo Return (Macintosh) na konci odstavce nadpisu nový odstavec označený tagem p. (Odstavec nadpisu je jeden z odstavců označených tagem nadpisu, například h1 nebo h2.) Když je tato volba vypnutá, stisknutí klávesy Enter nebo Return na konci odstavce nadpisu vytvoří nový odstavec označený stejným tagem nadpisu (to vám umožní napsat více nadpisů za sebou a pak se vrátit a doplnit podrobnosti).

    Povolit více mezer za sebou Určuje, že zápis dvou nebo více mezer v zobrazení návrhu nebo živém zobrazení vytvoří pevné mezery, které se v prohlížeči zobrazí jako více mezer. (Můžete například chtít psát dvě mezery mezi větami jako na psacím stroji.) Tato volba je určena převážně pro lidi, kteří jsou zvyklí psát v textových editorech. Když je tato volba vypnutá, více mezer se považuje za jednu mezeru (protože prohlížeče zpracují více mezer za sebou stejně jako jednu mezeru).

    Používat <strong> a <em> místo <b> a <i> Určuje, že aplikace Dreamweaver využije tag strong při každém provedení akce, která by běžně aplikovala tag b, a využije tag em při každém provedení akce, která by běžně aplikovala tag i. Mezi takové akce patří kliknutí na tlačítka Tučné (Bold) nebo Kurzíva (Italic) v inspektoru Vlastnosti pro text v režimu HTML nebo výběr voleb Formát > Styl > Tučné nebo Formát > Styl > Kurzíva. Chcete-li ve svých dokumentech používat tagy b a i, tuto možnost odznačte.

    Poznámka: Sdružení W3C (World Wide Web Consortium) nedoporučuje používání tagů b a i; tagy strong a em poskytují více sémantických informací než tagy b a i.

    Upozornění při umísťování upravitelných oblastí uvnitř tagů <p> nebo <h1> – <h6> Určuje, zda se zobrazí výstražná zpráva při ukládání předlohy aplikace Dreamweaver, která má upravitelnou oblast uvnitř tagu odstavce nebo nadpisu. Tato zpráva vám řekne, že uživatelé v této oblasti nebudou moci vytvořit více odstavců. Tato volba je standardně zapnutá.

    Omezení počtu akcí, které lze vrátit v aktivním dokumentu Omezuje počet akcí, které lze vrátit v právě upravovaném dokumentu. Například pokud upravujete soubor CSS, můžete vrátit změny provedené pouze v daném souboru CSS.

    Pokud ale označení tohoto políčka zrušíte, zdroj HTML a všechny související soubory CSS budou sdílet jednotnou historii vrácení změn, takže můžete vracet změny bez ohledu na to, jestli pracujete s kódem HTML nebo v souvisejícím souboru CSS.

    Maximální počet kroků historie Určuje počet kroků, které si aplikace Dreamweaver zapamatuje. (Pro většinu uživatelů by měla stačit výchozí hodnota.) Pokud se přesáhne daný počet kroků, nejstarší kroky se vypustí.

    Slovník pro kontrolu pravopisu Uvádí seznam dostupných slovníků pro kontrolu pravopisu. Pokud slovník obsahuje více dialektů nebo pravopisných konvencí (například americká angličtina a britská angličtina), tyto dialekty jsou v rozbalovací nabídce uvedeny samostatně.

Nastavení předvoleb Písma pro dokumenty v aplikaci Dreamweaver

Kódování dokumentu určuje jeho vzhled v prohlížeči. Předvolby písma aplikace Dreamweaver umožňují zobrazit dané kódování s použitím preferovaného písma a velikosti. Písma vybraná v dialogovém okně Předvolby písem však mají vliv pouze na způsob, jakým se zobrazují písma v aplikaci Dreamweaver, nemají vliv na způsob zobrazení dokumentu v prohlížeči návštěvníka. Chcete-li změnit způsob, jakým se písma zobrazují v prohlížeči, je nutné změnit text pomocí inspektoru Vlastnosti nebo pomocí pravidla CSS.

Informace o nastavení výchozího kódování pro nové dokumenty najdete v tématu Vytváření a otevírání dokumentů.

  1. Vyberte možnost Upravit > Předvolby (Windows) nebo Dreamweaver > Předvolby (Mac).

  2. Ze seznamu Kategorie na levé straně vyberte možnost Písma (Font).

  3. Ze seznamu Nastavení písma vyberte typ kódování (například Středoevropské nebo Japonské).

    Poznámka:

    Chcete-li zobrazovat některý asijský jazyk, musíte používat operační systém, který podporuje dvoubytová písma.

  4. Vyberete písmo a velikost pro každou kategorii vybraného kódování.

    Poznámka:

    Aby se písmo objevilo v rozbalovací nabídce písem, musí být nainstalované na vašem počítači. Například pro zobrazování japonského textu musíte mít nainstalované japonské písmo.

    Proporcionální písmo

    Písmo, které aplikace Dreamweaver používá k zobrazení normálního textu (například textu v odstavcích, nadpisech a tabulkách). Výchozí nastavení závisí na písmech nainstalovaných v systému. Pro většinu amerických systémů je například výchozí písmo Times New Roman velikosti 12 bodů. (Medium) v systému Windows a Times velikosti 12 bodů v systému Mac OS.

    Pevné písmo

    Písmo, které aplikace Dreamweaver používá k zobrazení textu uvnitř tagů pre, code a tt. Výchozí nastavení závisí na písmech nainstalovaných v systému. Pro většinu amerických systémů je například výchozí písmo Courier New velikosti 10 bodů. (Small) v systému Windows a Monaco velikosti 12 bodů v systému Mac OS.

    Zobrazení kódu

    Písmo, které se použije pro všechen text, který se objeví v zobrazení Kód a v inspektoru Kód. Výchozí nastavení závisí na písmech nainstalovaných v systému.

Přizpůsobení barev zvýraznění aplikace Dreamweaver

Předvolby Zvýraznění se používají k přizpůsobení barev, které v aplikaci Dreamweaver označují oblasti předloh, položky knihovny, tagy od jiných dodavatelů, elementy rozvržení a kód.

  1. Vyberte možnost Úpravy > Předvolby a vyberte kategorii Zvýraznění.

  2. Klikněte na pole barvy vedle objektu, jehož barvu zvýraznění chcete změnit, a pak v okně pro výběr barvy vyberte novou barvu nebo zadejte hexadecimální hodnotu.

  3. Pokud chcete aktivovat nebo deaktivovat konkrétní možnost, označte nebo odznačte příslušnou možnost Zobrazit.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online