Příručka uživatele Zrušit

Provádění transformace XSL na straně serveru v aplikaci Dreamweaver

  1. Příručka uživatele aplikace Dreamweaver
  2. Úvod
    1. Základy navrhování responzivních webů
    2. Co je nového v aplikaci Dreamweaver
    3. Vývoj webu v aplikaci Dreamweaver – přehled
    4. Dreamweaver / Běžné otázky
    5. Klávesové zkratky
    6. Systémové požadavky aplikace Dreamweaver
    7. Přehled funkcí
  3. Dreamweaver a Creative Cloud
    1. Synchronizace nastavení aplikace Dreamweaver ve službě Creative Cloud
    2. Knihovny Creative Cloud v aplikaci Dreamweaver
    3. Používání souborů Photoshop v aplikaci Dreamweaver
    4. Práce s aplikací Adobe Animate a Dreamweaver
    5. Extrahujte soubory SVG optimalizované pro web z knihoven
  4. Pracovní plochy a zobrazení aplikace Dreamweaver
    1. Pracovní plocha aplikace Dreamweaver
    2. Optimalizace pracovní plochy aplikace Dreamweaver pro vizuální vývoj
    3. Hledání souborů podle názvu nebo obsahu | Mac OS
  5. Nastavení webů
    1. O webech aplikace Dreamweaver
    2. Nastavení lokální verze webu
    3. Připojení k publikačnímu serveru
    4. Nastavení testovacího serveru
    5. Import a export nastavení webu aplikace Dreamweaver
    6. Přenos stávajících webových stránek ze vzdáleného serveru do kořenové složky lokálního webového místa
    7. Funkce usnadnění přístupu v aplikaci Dreamweaver
    8. Rozšířená nastavení
    9. Nastavení předvoleb webového místa pro přenos souborů
    10. Úprava nastavení serveru proxy v aplikaci Dreamweaver
    11. Synchronizace nastavení aplikace Dreamweaver ve službě Creative Cloud
    12. Používání systému Git v aplikaci Dreamweaver
  6. Správa souborů
    1. Vytváření a otevírání souborů
    2. Správa souborů a složek
    3. Získání souborů ze serveru a odeslání souborů na server
    4. Zpřístupnění/vyhrazení souborů
    5. Synchronizace souborů
    6. Porovnání souborů a nalezení rozdílů
    7. Maskování souborů a složek ve webu aplikace Dreamweaver
    8. Povolení poznámek k návrhu pro weby Dreamweaver
    9. Předcházení potenciálnímu zneužití modulu Gatekeeper
  7. Rozvržení a návrh
    1. Používání vizuálních pomůcek pro rozvržení
    2. O používání souborů CCS k rozvržení stránky
    3. Navrhování responzivních webů pomocí nástroje Bootstrap
    4. Vytvoření a používání multimediálních dotazů v aplikaci Dreamweaver
    5. Zobrazení obsahu pomocí tabulek
    6. Barvy
    7. Responzivní návrh s využitím rozvržení s plovoucí mřížkou
    8. Funkce Extrakt v aplikaci Dreamweaver
  8. CSS
    1. Vysvětlení kaskádových seznamů stylů
    2. Rozvržení stránek pomocí panelu CSS Designer
    3. Použití preprocesorů CSS v aplikaci Dreamweaver
    4. Postup nastavení předvoleb stylu CSS v aplikaci Dreamweaver
    5. Přesunutí pravidel CSS v aplikaci Dreamweaver
    6. Převedení inline CSS na pravidlo CSS v aplikaci Dreamweaver
    7. Práce s tagy div
    8. Použití přechodů na pozadí
    9. Vytváření a úprava efektů přechodů v aplikaci Dreamweaver
    10. Formátování kódu
  9. Obsah stránky a datové zdroje
    1. Nastavení vlastností stránky
    2. Nastavení vlastností nadpisů CSS a vlastností odkazu CSS
    3. Práce s textem
    4. Vyhledání a nahrazení textu, tagů a atributů
    5. Panel DOM
    6. Úpravy v živém zobrazení
    7. Kódování dokumentů v aplikaci Dreamweaver
    8. Výběr a zobrazení elementů v okně dokumentu
    9. Nastavení vlastností textu v Inspektoru vlastností
    10. Kontrola pravopisu webové stránky
    11. Pomocí vodorovných linek v aplikaci Dreamweaver
    12. Přidání a úprava kombinací písma v aplikaci Dreamweaver
    13. Práce s datovými zdroji
    14. Vložení a aktualizace dat v aplikaci Dreamweaver
    15. Vytvoření a správa oblíbených datových zdrojů v aplikaci Dreamweaver
    16. Vložení a úprava obrázků v aplikaci Dreamweaver
    17. Přidání multimediálních objektů
    18. Přidání videa v aplikaci Dreamweaver
    19. Vložení videa HTML 5
    20. Vložit soubory SWF
    21. Přidání zvukových efektů
    22. Vložte zvuk HTML5 v aplikaci Dreamweaver
    23. Práce s položkami knihoven
    24. Používání arabského a hebrejského textu v aplikaci Dreamweaver
  10. Odkazy a navigace
    1. O odkazech a navigaci
    2. Vytváření odkazů
    3. Obrazové mapy
    4. Odstraňování problémů s odkazy
  11. Ovládací prvky a efekty jQuery
    1. Používání widgetů jQuery UI a jQuery Mobile v aplikaci Dreamweaver
    2. Používání efektů jQuery v aplikaci Dreamweaver
  12. Kódování webových stránek
    1. Informace o psaní kódu v aplikaci Dreamweaver
    2. Prostředí pro psaní kódu v aplikaci Dreamweaver
    3. Nastavení předvoleb kódování
    4. Přizpůsobení barevného zvýraznění kódu
    5. Psaní a úprava kódu
    6. Našeptávání kódu a dokončování kódu
    7. Sbalení a rozbalení kódu
    8. Opakované použití kódu v podobě výstřižků
    9. Linting kódu
    10. Optimalizace kódu
    11. Úprava kódu v zobrazení Návrh
    12. Práce s obsahem hlavičky stránek
    13. Vložení zahrnutí na straně serveru v aplikaci Dreamweaver
    14. Používání knihoven tagů v aplikaci Dreamweaver
    15. Import vlastních tagů do aplikace Dreamweaver
    16. Práce s funkcemi JavaScriptu (obecné pokyny)
    17. Použití vestavěných chování jazyka JavaScript
    18. O XML a XSLT
    19. Provádění transformace XSL na straně serveru v aplikaci Dreamweaver
    20. Provádění transformace XSL na straně klienta v aplikaci Dreamweaver
    21. Přidání entit znaku pro XSLT v aplikaci Dreamweaver
    22. Formátování kódu
  13. Pracovní postupy pro různé produkty
    1. Instalace a používání rozšíření v aplikaci Dreamweaver
    2. Aktualizace v rámci aplikace v aplikaci Dreamweaver
    3. Vkládání dokumentů sady Microsoft Office v aplikaci Dreamweaver (jen ve Windows)
    4. Práce s aplikacemi Fireworks a Dreamweaver
    5. Úprava obsahu na webech Dreamweaver za pomoci aplikace Contribute
    6. Integrace mezi aplikacemi Dreamweaver a Business Catalyst
    7. Vytváření e-mailových kampaní na míru
  14. Šablony
    1. O předlohách aplikace Dreamweaver
    2. Rozpoznání předloh a dokumentů založených na předloze
    3. Vytvoření předlohy aplikace Dreamweaver
    4. Vytváření upravitelných oblastí v šablonách
    5. Vytváření opakovaných oblastí a tabulek v aplikaci Dreamweaver
    6. Použijte volitelné oblasti v předlohách
    7. Definování upravitelných atributů tagu v aplikaci Dreamweaver
    8. Postup vytvoření vnořených šablon v aplikaci Dreamweaver
    9. Úprava, aktualizace nebo odstranění předloh
    10. Export a import obsahu XML v aplikaci Dreamweaver
    11. Aplikace nebo odstranění předlohy z existujícího dokumentu.
    12. Úprava obsahu v předlohách Dreamweaver
    13. Pravidla syntaxe pro tagy předloh v aplikaci Dreamweaver
    14. Nastavení předvoleb zvýraznění pro oblasti předlohy
    15. Výhody používání předloh v aplikaci Dreamweaver
  15. Mobilní zařízení a zařízení s více displeji
    1. Vytvoření multimediálních dotazů
    2. Změna orientace stránky pro mobilní zařízení
    3. Vytvoření webových aplikací pro mobilní zařízení pomocí aplikace Dreamweaver
  16. Dynamické weby, stránky a webové formuláře
    1. Informace o webových aplikacích
    2. Nastavení počítače pro vývoj aplikací
    3. Řešení problémů s připojením databází
    4. Odstranění skriptů připojení v aplikaci Dreamweaver
    5. Návrh dynamických stránek
    6. Přehled zdrojů dynamického obsahu
    7. Definice zdrojů dynamického obsahu
    8. Přidání dynamického obsahu na stránky
    9. Změna dynamického obsahu v aplikaci Dreamweaver
    10. Zobrazení záznamů databáze
    11. Zajišťování a řešení potíží s živými daty v aplikaci Dreamweaver
    12. Přidání uživatelského chování serveru v aplikaci Dreamweaver
    13. Vytváření formulářů pomocí aplikace Dreamweaver
    14. Shromažďování informací od uživatelů pomocí formulářů
    15. Vytváření a povolení formulářů ColdFusion v aplikaci Dreamweaver
    16. Vytváření webových formulářů
    17. Rozšířená podpora formátu HTML5 pro elementy formuláře
    18. Vytváření formuláře pomocí aplikace Dreamweaver
  17. Vizuální vytváření aplikací
    1. Vytváření hlavních a podrobných stránek v aplikaci Dreamweaver
    2. Vytváření vyhledávacích stránek a stránek s výsledky
    3. Vytvoření stránky vložení záznamu
    4. Vytvoření stránky pro aktualizaci záznamu v aplikaci Dreamweaver
    5. Budování stránek pro odstranění záznamu v aplikaci Dreamweaver
    6. Používání příkazů ASP k úpravě databáze v aplikaci Dreamweaver
    7. Vytvoření registrační stránky
    8. Vytvoření přihlašovací stránky
    9. Vytvoření stránky, na kterou mají přístup pouze autorizovaní uživatelé
    10. Zabezpečení složek ve službě ColdFusion pomocí aplikace Dreamweaver
    11. Používání komponent ColdFusion v aplikaci Dreamweaver
  18. Testování, náhled a publikování webových stránek
    1. Náhled stránek
    2. Náhled webových stránek Dreamweaver na více zařízeních
    3. Testování webu aplikace Dreamweaver

 

Naučte se provádět transformace XSL na straně serveru v aplikaci Dreamweaver. Vytvářejte stránky XSLT a převádějte HTML na stránky XSLT.

Poznámka:

Uživatelské rozhraní v aplikaci Dreamweaver CC a jejích novějších verzích bylo zjednodušeno. Výsledkem je skutečnost, že některé možnosti uvedené v tomto článku nemusí být v aplikaci Dreamweaver CC a jejích novějších verzích k dispozici. Další informace najdete v tomto článku.

Pracovní postup pro provádění transformací XSL na straně serveru

Transformace XSL můžete provádět na straně serveru. Před vytvářením stránek, které zobrazují data XML, si přečtěte o transformacích XSL na straně klienta a na straně serveru a o používání XML a XSL ve webových stránkách.

Poznámka:

Transformaci na straně serveru lze provádět, jen pokud je server správně nakonfigurován. Další informace vám poskytne správce serveru.

Obecný postup při transformaci XSL na straně serveru je následující(jednotlivé kroky jsou popsány v samostatných tématech):

1. Vytvořte web aplikace Dreamweaver.

2. Vyberte technologii serveru a nastavte aplikační server.

3. Otestujte aplikační server.

Vytvořte například stránku, která vyžaduje zpracování, a zkontrolujte, zda ji aplikační server zpracuje.

4. Vytvořte fragment nebo stránku XSLT, nebo převeďte stránku HTML na stránku XSLT.

  • Ve webovém místě aplikace Dreamweaver vytvořte fragment nebo celou stránku XSLT.

  • Převeďte stávající stránku HTML na celou stránku XSLT.

5. Připojte ke stránce zdroj dat XML.

6. Zobrazte data XML navázáním dat na fragment nebo celou stránku XSLT.

7. Pokud je to vhodné, přidejte do tabulky nebo řádku tabulky, který obsahuje vyhrazená místa pro data XML, objekt Opakovaná oblast XSLT.

8. Vložte odkazy.

  • Odkazy do fragmentu XSLT v dynamické stránce vložíte pomocí serverového chování Transformace XSL.

  • Pokud chcete do dynamické stránky vložit odkaz na celou stránku XSLT, odstraňte z dynamické stránky veškerý kód HTML a pak použijte serverové chování Transformace XSL.

9. Odešlete stránku a fragment.

Dynamickou stránku i fragment XSLT (nebo celou stránku XSLT) pošlete na aplikační server. Pokud používáte lokální soubor XML, musíte poslat i ten.

10. Zobrazte dynamickou stránku v prohlížeči.

Aplikační server přitom transformuje data XML, vloží je do dynamické stránky a ta se zobrazí v prohlížeči.

Vytvoření stránky XSLT

Můžete vytvářet stránky XSLT, které umožní zobrazení dat XML na webových stránkách. Můžete vytvářet celé stránky XSLT – stránky XSLT, které obsahují tagy <body><head> – nebo jen fragmenty XSLT. Když vytvoříte fragment XSLT, vytvoříte nezávislý soubor, který neobsahuje tagy body ani head – jednoduchý kus kódu, který se později vloží do dynamické stránky.

Poznámka:

Pokud začínáte od existující stránky XSLT, musíte k ní připojit zdroj dat XML.

  1. Vyberte volbu Soubor > Nový.
  2. V kategorii Prázdná stránka v dialogovém okně Nový dokument vyberte ve sloupci Typ stránky jednu z následujících voleb:
    • Vyberte volbu XSLT (celá stránka), pokud chcete vytvořit celou stránku XSLT.

    • Vyberte volbu XSLT (fragment), pokud chcete vytvořit fragment XSLT.

  3. Klepněte na tlačítko Vytvořit a pak v dialogovém okně Najít zdroj XML proveďte jeden z následujících úkonů:
    • Vyberte volbu Připojit lokální soubor, klepněte na tlačítko Procházet, vyhledejte lokální soubor XML v počítači a klikněte na tlačítko OK.
    • Vyberte volbu Připojit vzdálený soubor, zadejte adresu URL souboru XML umístěného na Internetu (například pocházejícího z kanálu RSS) a klikněte na tlačítko OK.
    Poznámka:

    Klepnutím na tlačítko Zrušit vytvoříte novou stránku XSLT bez připojeného zdroje dat XML.

    v panelu Svázání se zobrazí schéma zdroje dat XML

    Panel Svázání

    Následující tabulka nabízí vysvětlení různých elementů, které se ve schématu mohou objevit:

    Element

    Představuje

    Podrobnosti

    <>

    Povinný neopakující se element XML

    Element, který se v rodičovském uzlu objeví přesně jednou

    <>+

    Opakující se element XML

    Element, který se v rodičovském uzlu objeví jednou nebo vícekrát

    <>+

    Volitelný element XML

    Element, který se v rodičovském uzlu objeví nulakrát nebo vícekrát

    Uzel elementu psaný tučným písmen

    Aktuální element kontextu

    Obvykle opakující se element, pokud je kurzor v opakované oblasti

    @

    Atribut XML

     

     

  4. Novou stránku uložte (Soubor > Uložit) s příponou .xsl nebo .xslt (.xsl je výchozí nastavení).

Převod stránek HTML na stránky XSLT

Máte také možnost převádět stávající stránky HTML na stránky XSLT. Pokud například již máte navrženou statickou stránku, do které chcete přidat data XML, můžete ji převést na stránku XSLT místo vytváření stránky XSLT od začátku.

  1. Otevřete stránku HTML, kterou chcete převést.
  2. Vyberte volbu Soubor > Převést > XSLT 1.0.

    V okně dokumentu se otevře kopie stránky. Nová stránka je seznam stylů XSL, uložený s příponou .xsl.

Připojení zdrojů dat XML

Pokud při vytváření nové stránky XSLT začínáte z existující stránky XSLT nebo pokud nepřipojíte data XML při vytváření nové stránky pomocí aplikace Dreamweaver, musíte zdroj dat XML připojit pomocí panelu Svázání.

  1. v panelu Svázání (Okna > Svázání) klikněte na tlačítko Odkaz XML.
    Na panelu Svázání klikněte na tlačítko XML

    Poznámka:

    Pokud chcete přidat zdroj dat XML, můžete také klepnout na odkaz Zdroj v pravém horním rohu panelu Svázání.

  2. Proveďte jeden z následujících úkonů:
    • Vyberte volbu Připojit lokální soubor, klepněte na tlačítko Procházet, vyhledejte lokální soubor XML v počítači a klikněte na tlačítko OK.

    • Vyberte volbu Připojit vzdálený soubor a zadejte adresu URL souboru XML na Internetu (například z kanálu RSS).

  3. Klepnutím na tlačítko OK zavřete dialogové okno Najít zdroj XML.

    v panelu Svázání se zobrazí schéma zdroje dat XML.

Zobrazení dat XML na stránkách XSLT

Po vytvoření stránky XSLT a připojení zdroje dat XML můžete data navázat na stránku. Na stránku přidejte vyhrazené místo pro data XML a pak pomocí okna Vytváření výrazu XPath nebo inspektoru Vlastnosti nastavte formát vybraných dat, která budou na stránce zobrazena.

  1. Otevřete stránku XSLT s připojeným zdrojem dat XML.
  2. (Volitelně) Výběrem volby Vložit > Tabulka přidejte na stránku tabulku. Tabulka pomáhá uspořádat data XML.
    Poznámka:

    Ve většině případů využijete k zobrazení opakujících se prvků XML na stránce objekt Opakovaná oblast XSLT. V tom případě možná budete chtít vytvořit tabulku s jedním řádkem a jedním nebo více sloupci nebo tabulku se dvěma řádky, pokud chcete použít hlavičku tabulky.

  3. v panelu Svázání vyberte element XML a přetáhněte ho na stránku na místo, kam chcete vložit data.
    Výběr elementu XML v panelu Svázání

    Na stránce se objeví vyhrazené místo pro data XML. Vyhrazené místo je zvýrazněno a ve složených závorkách. K popisu hierarchické struktury schématu XML se využívá syntax XPath (jazyk XML Path). Pokud například na stránku přetáhnete dceřiný element title a tento element je potomkem elementů rss, channelitem, bude syntaxe vyhrazeného místa pro vložení dynamického obsahu {rss/channel/item/title}.

    Poklepáním na vyhrazené místo pro data XML na stránce otevřete okno Vytváření výrazů XPath. Okno Vytváření výrazů XPath umožňuje formátovat vybraná data nebo vybrat jiné položky ze schématu XML.

  4. (Volitelně) Aplikujte na data XML styly výběrem vyhrazeného místa pro data XML a aplikováním stylů na toto místo stejně jako byste je aplikovali na libovolnou jinou položku obsahu pomocí inspektoru Vlastnosti nebo panelu Styly CSS. Nebo můžete styly na fragmenty XLST aplikovat pomocí kaskádové styly pro fázi návrhu. Každá z těchto metod má výhody i omezení.
  5. Zobrazte si náhled vaší práce v prohlížeči (Soubor > Náhled v prohlížeči).
    Poznámka:

    Při náhledu své práce funkcí Náhled v prohlížeči provádí vnitřní převod XSL aplikace Dreamweaver bez použití aplikačního serveru.

Zobrazení opakovaných elementů XML

Objekt Opakovaná oblast XSLT umožňuje zobrazit na webové stránce opakující se elementy ze zdroje dat XML. Pokud například zobrazujete titulky a popisy článků z kanálu novinek, který obsahuje 10 až 20 článků, každý titulek a popis v souboru XML bude nejspíš dceřiným elementem opakujícího se elementu.

Jakoukoli oblast v zobrazení Návrh obsahující vyhrazené místo pro data XML lze změnit na opakovanou oblast. Nejrozšířenějšími oblastmi opakování ale jsou tabulky, řádky tabulek a řady řádků tabulek.

  1. V zobrazení Návrh vyberte oblast, která obsahuje vyhrazené místo nebo místa pro data XML.

    Výběrem může být cokoliv včetně celé tabulky, řádku tabulky nebo dokonce odstavce textu.

    Zobrazení Návrh

    Poznámka:

    K přesnému výběru oblasti na stránce můžete využít selektor tagů v levém dolním rohu okna dokumentu. Pokud je oblastí například tabulka, klepněte do tabulky na stránce a pak klepněte na tag v selektoru tagů.

  2. Proveďte jeden z následujících úkonů:
    • Vyberte volbu Vložit > Objekty XSLT > Opakovaná oblast.

    • V kategorii XSLT na panelu Vložit klepněte na tlačítko Opakovaná oblast.

  3. V Tvůrci výrazů XPath vyberte opakovaný element označený malým znaménkem plus.
    Vytváření výrazů XPath

  4. Klikněte na tlačítko OK.

    V okně dokumentu se okolo oblasti opakování objeví tenký šedý obrys. Při náhledu stránky v prohlížeči (Soubor > Náhled v prohlížeči) šedý obrys zmizí a výběr se zvětší, aby zobrazil opakované elementy ze souboru XML.

    Když na stránku přidáte objekt Opakovaná oblast XSLT, vyhrazené místo pro data XML v okně dokumentu bude zkrácené. To proto, že aplikace Dreamweaver zkrátí výraz XPath pro vyhrazené místo pro data XML tak, aby byl relativní k cestě opakovaného elementu.

Nastavení vlastností Opakované oblasti (XSL)

V inspektoru Vlastnosti můžete vytvořit oblast opakování výběrem jiného uzlu XML.

  1. V poli Výběr zadejte nový uzel a pak klepněte na ikonu blesku a vyberte uzel ze schématu XML, který se objeví.

Úpravy objektu Opakovaná oblast XSLT

Po přidání objektu Opakovaná oblast XSLT do oblasti ho můžete upravovat v inspektoru Vlastnosti.

  1. Vyberte objekt klepnutím na šedý rámeček okolo regionu.
  2. V inspektoru Vlastnosti (Okna > Vlastnosti) klepněte na ikonu dynamiky u textového pole Výběr.
  3. V Tvůrci výrazů XPath proveďte požadované změny a klikněte na tlačítko OK.

Vložení fragmentů XSLT do dynamických stránek

Po vytvoření fragmentu XSLT ho můžete vložit na dynamickou webové stránku pomocí serverového chování transformace XSL. Při přidání serverového chování na stránku a zobrazení stránky v prohlížeči provede aplikační server transformaci, která zobrazí data XML z vybraného fragmentu XSLT. Aplikace Dreamweaver podporuje transformace XSL na stránkách ColdFusion, ASP nebo PHP.

Poznámka:

Pokud chcete na dynamickou stránku vložit obsah celé stránky XSLT, postup je úplně stejný. Dříve než použijete serverové chování transformace XSL k vložení celé stránky XSLT, odstraňte z dynamické stránky veškerý kód HTML.

  1. Otevřete existující stránku ColdFusion, ASP, nebo PHP.
  2. V zobrazení Návrh umístěte kurzor do místa, kam chcete vložit fragment XSLT.
    Poznámka:

    Při vkládání fragmentů XSLT byste měli po umístění textového kurzoru na stránku vždy klepnout na tlačítko Zobrazit zobrazení Kód a Návrh, abyste mohli ověřit, že kurzor je umístěný ve správném místě. Pokud není, může být nutné klepnout jinam v zobrazení Kód, abyste kurzor umístili, kam potřebujete.

  3. v panelu Serverová chování (Okna > Serverová chování) klepněte na tlačítko plus (+) a vyberte volbu Transformace XSL.
    Panel Serverová chování

  4. V dialogovém okně Transformace XSL klikněte na tlačítko Procházet a vyhledejte fragment XSLT nebo kompletní stránku XSLT.

    Aplikace Dreamweaver do sousedního textového pole vloží cestu k souboru nebo adresu URL souboru XML, který je připojen k určenému fragmentu. Pokud chcete tento údaj změnit, klepněte na tlačítko Procházet a vyhledejte jiný soubor.

  5. (Volitelně) Klepnutím na tlačítko plus (+) přidejte parametr XSLT.
  6. Klepnutím na tlačítko OK vložte na stránku odkaz na fragment XSLT. Fragment nelze upravovat. Poklepáním na fragment otevřete jeho zdrojový soubor a můžete ho upravovat.

    Současně je v kořenové složce webového místa vytvořena složka includes/MM_XSLTransform/, v níž je soubor knihovny nutné k běhu. Aplikační server využívá funkce definované v tomto souboru k provedení transformace.

  7. Nahrajte dynamickou stránku na server (Webové místo > Odeslat) a klepnutím na tlačítko Ano přidejte i závislé soubory. Na serveru musí být soubor, který obsahuje fragment XSLT, soubor XML, který obsahuje data, a vygenerovaná knihovna pro běh, jinak se stránka nezobrazí správně. (Pokud jste jako zdroj dat vybrali vzdálený soubor XML, musí být tento soubor umístěn jinde na Internetu.)

Odstranění fragmentů XSLT z dynamických stránek

Fragment XSLT můžete ze stránky odstranit smazáním serverového chování Transformace XSL, které jste použili k vložení fragmentu. Odstraněním serverového chování odstraníte pouze fragment XSLT – nevymažete připojený soubor XML, XSLT ani soubory run-time knihoven.

  1. v panelu Serverová chování (Okna > Serverová chování) vyberte serverové chování Transformace XSL, které chcete odstranit.
  2. Klepněte na tlačítko minus (-).
    Poznámka:

    Serverová chování vždy odstraňujte tímto způsobem. Ručním odstraněním vygenerovaného kódu odstraníte serverové chování jen částečně, i když serverové chování možná zmizí z panelu Serverová chování.

Úpravy serverového chování Transformace XSL

Po přidání fragmentu XSLT na dynamickou webovou stránku můžete serverové chování Transformace XSL kdykoli upravit.

  1. v panelu Serverová chování (Okna > Serverová chování) poklepejte na serverové chování Transformace XSL, které chcete upravit.
  2. Proveďte změny a klikněte na tlačítko OK.

Vytvoření dynamického odkazu

Můžete vytvořit dynamický odkaz na stránku XSLT, která odkazuje na určitou adresu URL, když uživatel klikne na zadané slovo nebo skupinu slov z dat XML. Podrobné pokyny najdete v části Chyby v aplikaci Dreamweaver na adrese www.adobe.com/go/dw_documentation_cz.

Aplikování stylů na fragmenty XSLT

Při vytvoření celé stránky XSLT (stránky XSLT, která obsahuje tagy <body><head>) můžete na stránce zobrazit data XML a pak je formátovat jako kterýkoli jiný element obsahu pomocí inspektoru Vlastnosti nebo panelu Styly CSS. Při vytvoření fragmentu XSLT, který budete vkládat na dynamickou stránku (například na stránku ASP, PHP nebo Cold Fusion), je ale vykreslení stylů ve fragmentu a na dynamické stránce komplikovanější. I když na fragmentu XSLT pracujete odděleně od práce na dynamické stránce, je důležité nezapomínat na to, že je fragment určen k použití na dynamické stránce a že výstup z fragmentu XSLT nakonec bude umístěn mezi tagy <body> dynamické stránky. S ohledem na tento postup je důležité neuvádět ve fragmentech XSLT prvky <head> (například definice stylu nebo odkazy na vnější kaskádové styly). Pokud byste to udělali, aplikační server je vloží mezi tagy <body> dynamické stránky a tím vznikne neplatný tag.

Můžete například chtít vytvořit fragment XSLT určený k vložení na dynamickou stránku a zformátovat fragment pomocí stejného vnějšího kaskádového stylu, který využívá dynamická stránka. Pokud k fragmentu připojíte stejný kaskádový styl, výsledná stránka HTML bude obsahovat duplicitní odkaz na kaskádový styl (jeden v sekci <head> a druhý v sekci <body> dynamické stránky, kam je vložen obsah fragmentu XSLT). Místo popisovaného postupu používejte k odkazu na vnější kaskádový styl kaskádové styly pro fázi návrhu.

Pro formátování obsahu fragmentů XSLT využijte následující postup:

  • Nejdříve k dynamické stránce připojte externí kaskádové styly. (To je nejlepší způsob, jak aplikovat styl na obsah jakékoli webové stránky.)

  • Pak připojte stejný externí kaskádový styl k fragmentu XSLT jako kaskádový styl pro fázi návrhu. Jak vyplývá z názvu, kaskádové styly pro fázi návrhu fungují jen v zobrazení Návrh v aplikaci Dreamweaver.

    Po dokončení výše uvedených dvou kroků můžete ve fragmentu XSLT vytvářet nové styly pomocí stejného kaskádového stylu, který jste připojili k dynamické stránce. Výstup HTML bude čistší (protože odkaz na kaskádový styl platí jen při práci v aplikaci Dreamweaver), a fragment bude v zobrazení Návrh přesto zobrazovat správné styly. Navíc budou při zobrazení dynamické stránky v zobrazení návrh nebo prohlížení v dynamické stránky v prohlížeči všechny styly při náhledu dynamické stránky v prohlížeči uplatněny na fragment i na dynamickou stránku.

Poznámka:

Pokud zobrazujete náhled fragmentu XSLT v prohlížeči, prohlížeč styly nezobrazí. Místo toho zobrazujte náhled dynamické stránky v prohlížeči, abyste fragment XSLT zobrazili v kontextu dynamické stránky.

Používání parametrů transformací XSL

Při přidávání serverového chování Transformace XSL na webovou stránku můžete definovat parametry transformace XSL. Parametr určuje, jak probíhá zpracování a zobrazení dat XML. Například pomocí parametru můžete určit a vypsat konkrétní článek z kanálu novinek. Při načtení stránky do prohlížeče se zobrazí jen článek určený pomocí parametru.

Přidání parametru XSLT do transformace XSL

  1. Otevřete dialogové okno Transformace XSL. Můžete poklepat na serverové chování Transformace XSL v panelu Serverová chování (Okna > Serverová chování) nebo přidat nové serverové chování Transformace XSL.
  2. V dialogovém okně Transformace XSL klepněte na tlačítko plus (+) u volby Parametry XSLT.
    Dialogové okno Transformace XSL

  3. V dialogovém okně Přidat parametry zadejte název parametru do rámečku Název. Název smí obsahovat jen alfanumerické znaky. Název nesmí obsahovat mezery.
  4. Proveďte jeden z následujících úkonů:
    • Pokud chcete použít statickou hodnotu, zadejte ji do rámečku Hodnota.

    • Pokud chcete použít dynamickou hodnotu, klikněte na ikonu dynamiky vedle rámečku Hodnota, vyplňte údaje v dialogovém okně Dynamická data a klikněte na tlačítko OK. Více informací získáte klepnutím na tlačítko Nápověda v dialogovém okně Dynamická data.

  5. V rámečku Výchozí hodnota zadejte hodnotu parametru, kterou chcete použít, pokud stránka neobdrží parametr za běhu, a klikněte na tlačítko OK.

Úpravy parametru XSLT

  1. Otevřete dialogové okno Transformace XSL. Můžete poklepat na serverové chování Transformace XSL v panelu Serverová chování (Okna > Serverová chování) nebo přidat nové serverové chování Transformace XSL.
  2. Vyberte parametr ze seznamu parametrů XSLT.
  3. Klepněte na tlačítko Upravit.
  4. Proveďte změny a klikněte na tlačítko OK.

Odstranění parametru XSLT

  1. Otevřete dialogové okno Transformace XSL. Můžete poklepat na serverové chování Transformace XSL v panelu Serverová chování (Okna > Serverová chování) nebo přidat nové serverové chování Transformace XSL.
  2. Vyberte parametr ze seznamu parametrů XSLT.
  3. Klepněte na tlačítko minus (-).

Vytváření a úpravy podmíněných oblastí XSLT

Na stránce XSLT můžete vytvářet jednoduché nebo vícenásobně podmíněné oblasti. Můžete buď vybrat element v zobrazení Návrh a pak na výběr aplikovat podmínku, nebo vložit podmíněnou oblast v místě kurzoru kdekoli v dokumentu.

Pokud například chcete zobrazit slovo „Nedostupný“ vedle ceny položky, když tato položka není dostupná, zadejte na stránce text „Nedostupný“, vyberte ho a pak na vybraný text aplikujte podmíněnou oblast. Aplikace Dreamweaver okolo výběru vloží tagy <xsl:if> a slovo „Nedostupný“ se na stránce zobrazí jen když jsou splněny podmínky podmíněného výrazu.

Aplikování podmíněné oblasti XSLT

Můžete vytvořit jednoduchý podmíněný výraz a pak ho vložit do stránky XSLT. Pokud je při otevření dialogového okna Podmíněná oblast vybrán obsah, bude uzavřen mezi tagy <xsl:if>. Pokud není vybrán obsah, budou tagy <xsl:if> přidány v místě kurzoru na stránce. Je dobré používat zpočátku dialogové okno a pak podmíněný výraz upravovat v zobrazení Kód.

Element <xsl:if> se podobá elementu if v jiných jazycích. Tento element umožňuje testování podmínky a provedení akce v závislosti na výsledku. Element <xsl:if> umožňuje testovat, zda má výraz hodnotu true nebo false.

  1. Vyberte volbu Vložit > Objekty XSLT > Podmíněná oblast nebo v kategorii XLST na panelu Vložit klepněte na ikonu Podmíněná oblast.
  2. V dialogovém okně Podmíněná oblast zadejte podmíněný výraz pro oblast.

    V následujícím příkladu chcete testovat, zda má atribut @available kontextového uzlu hodnotu true.

    Dialogové okno Podmíněná oblast

  3. Klikněte na tlačítko OK.

    Do stránky XSLT bude vložen následující kód:

    <xsl:if test="@available=&apos;true&apos;"> 
        Content goes here 
    </xsl:if>
    Poznámka:

    Řetězcové hodnoty, například true, musíte uzavřít do uvozovek. Aplikace Dreamweaver uvozovky zakóduje (&apos;), takže jsou vloženy jako platný XHTML.

    Kromě testování hodnot uzlů můžete v libovolném podmíněném výrazu použít libovolnou z podporovaných funkcí XSLT. Podmínka se ověřuje pro aktuální uzel v souboru XML. V následujícím příkladu chcete testovat poslední uzel množiny výsledků:

    Test posledního uzlu v sadě výsledků

    Další informace o psaní podmíněných výrazů i s příklady naleznete v sekci <xsl:if> na panelu Odkazy (Nápověda > Odkazy).

Aplikování vícenásobně podmíněných oblastí XSLT

Můžete vytvořit jednoduchý podmíněný výraz a pak ho vložit do stránky XSLT. Pokud je při otevření dialogového okna Podmíněná oblast vybrán obsah, je obsah uzavřen mezi tagy <xsl:choose>. Pokud není vybrán obsah, jsou tagy <xsl:choose> přidány v místě kurzoru na stránce. Je dobré používat zpočátku dialogové okno a pak podmíněný výraz upravovat v zobrazení Kód.

Element <xsl:choose> se podobá prvku case v jiných jazycích. Tento element umožňuje testování podmínky a provedení akce v závislosti na výsledku. Element <xsl:choose> umožňuje testování více podmínek.

  1. Vyberte volbu Vložit > Objekty XSLT > Vícenásobně podmíněná oblast nebo v kategorii XLST na panelu Vložit klepněte na ikonu Vícenásobně podmíněná oblast.
  2. V dialogovém okně Vícenásobně podmíněná oblast zadejte první podmínku.

    V následujícím příkladu chcete zjistit, zda je podelement price kontextového uzlu menší než 5.

    Dialogové okno Vícenásobně podmíněná oblast

  3. Klikněte na tlačítko OK.

    V tomto příkladu se do stránky XSLT vloží následující kód:

    <xsl:choose> 
        <xsl:when test="price&lt;5"> 
            Content goes here 
        </xsl:when> 
        <xsl:otherwise> 
            Content goes here 
        </xsl:otherwise> 
    </xsl:choose>
  4. Pokud chcete vložit další podmínku, umístěte kurzor v zobrazení Kód mezi tagy <xsl:when> nebo těsně před tag <xsl:otherwise> a pak vložte podmíněnou oblast (Vložit > Objekty XSLT > Podmíněná oblast).

    Po zadání podmínky a klepnutí na tlačítko OK je vložen další tag <xsl:when> do stávajícího bloku <xsl:choose>.

    Další informace o vytváření podmíněných výrazů i s příklady naleznete v sekci <xsl:choose> na panelu Odkazy (Nápověda > Odkazy).

Nastavení vlastností podmíněné oblasti (If)

Účelem inspektoru Nastavit vlastnost podmíněného regionu je změna podmínky podmíněné oblasti na stránce XSL. Podmíněná oblast testuje splnění podmínky a rozhoduje podle výsledku.

  1. V rámečku Testovat zadejte novou podmínku a pak stiskněte klávesu Enter.

Nastavení podmíněných vlastností (When)

Účelem inspektoru Nastavit vlastnost podmíněné oblasti je změna podmínky vícenásobně podmíněné oblasti ve stránce XSL. Vícenásobně podmíněná oblast zjišťuje splnění podmínky a rozhoduje podle výsledku.

  1. V rámečku Testovat zadejte novou podmínku a pak stiskněte klávesu Enter.

Vložení komentářů XSL

Do dokumentu můžete vkládat tagy komentářů XSL nebo výběr zabalit do tagů komentáře XSL.

Přidání tagů komentáře XSL do dokumentu

  1. Proveďte jeden z následujících úkonů:
    • V zobrazení Návrh vyberte volbu Vložit > Objekty XSLT > Komentář XSL, zadejte obsah komentáře (nebo nechte rámeček prázdný) a klikněte na tlačítko OK.

    • V zobrazení Kód vyberte volbu Vložit > Objekty XSLT > Komentář XSL.

    Poznámka:

    Můžete také klepnout na ikonu Komentář XSL v kategorii XSLT na panelu Vložit.

Zabalení výběru do tagů komentáře XSL

  1. Přepněte na zobrazení Kód (Zobrazení > Kód).
  2. Vyberte kód, který chcete okomentovat.
  3. V pruhu nástrojů Kódování klepněte na tlačítko Aplikovat komentář a vyberte volbu Aplikovat komentář <xsl:comment></xsl:comment>.

Používání okna Vytváření výrazů XPath k přidávání výrazů pro data XML

Jazyk XPath (XML Path Language) je ne-XML syntaxe umožňující adresování částí dokumentu XML. Používá se hlavně jako dotazovací jazyk pro data XML, podobně jako se jazyk SQL využívá k dotazování v databázích. Více informací o jazyku XPath viz specifikace jazyka XPath na webu W3C na adrese www.w3.org/TR/xpath.

Vytváření výrazů XPath je funkce aplikace Dreamweaver umožňující vytváření jednoduchých výrazů XPath používaných k identifikaci specifických uzlů dat a pro opakované oblasti. Výhodou použití této metody místo přetažení hodnot ze stromu schématu XML je možnost formátovat zobrazené hodnoty. Aktuální kontext je identifikován podle polohy textového kurzoru v souboru XSL při otevření dialogového okna Vytváření výrazů XPath. Aktuální kontext je ve stromu schématu XML zobrazen tučným písmem. Při výběrech v tomto dialogovém okně jsou generovány správné výrazy XPath relativní vůči aktuálnímu kontextu. To začátečníkům i zkušeným uživatelům zjednodušuje psaní správných výrazů XPath.

Poznámka:

Tato funkce byla navržena tak, aby pomáhala vytvářet jednoduché výrazy XPath identifikující konkrétní uzel nebo oblast opakování. Neumožňuje ruční úpravy výrazů. Pokud potřebujete vytvářet složité výrazy, začněte pomocí okna Vytváření výrazů XPath a pak výrazy upravte v zobrazení Kód nebo v inspektoru Vlastnosti.

Vytvoření výrazu XPath identifikujícího konkrétní uzel

  1. Poklepáním na vyhrazené místo pro data XML na stránce otevřete okno Vytváření výrazů XPath.
  2. V dialogovém okně Vytváření výrazů XPath (Dynamický text) vyberte ve stromu schématu XML kterýkoli uzel.

    V rámečku Výraz se objeví správný výraz XPath, který identifikuje tento uzel.

    Poznámka:

    Pokud ve stromu schématu XML vyberete jiný uzel, výraz se změní podle toho, jaký uzel jste vybrali.

    V následujícím příkladu chcete zobrazit podřízený prvek price uzlu item:

    Dialogové okno Vytváření výrazů XPath (dynamický text)

    Tento výběr by vedl k vložení následujícího kódu do stránky XSLT:

    <xsl:value-of select="price"/>
  3. (Volitelně) Z rozbalovací nabídky Formát vyberte volbu formátování.

    Formátování výběru je užitečné, pokud hodnota uzlu vrací číslo. Aplikace Dreamweaver nabízí předdefinovaný seznam formátovacích funkcí. Kompletní seznam dostupných formátovacích funkcí i s příklady najdete v panelu Reference.

    V následujícím příkladu chcete podřízený prvek price formátovat jako měnu se dvěma desetinnými místy:

    Formátování podelementu ceny jako měny se dvěma desetinnými místy

    Tyto možnosti umožňují vložit následující kód na vaši stránku XSLT:<xsl:value-of select="format-number(provider/store/items/item/price,'$#.00')"/>

    <xsl:value-of select="format-number(provider/store/items/item/price,'$#.00')"/>
  4. Klikněte na tlačítko OK.
  5. Pokud chcete zobrazit hodnoty všech uzlů v souboru XML, aplikujte opakovanou oblast na element, který obsahuje dynamický text (například řádek tabulky HTML nebo odstavec).

    Více informací o výběru uzlů za účelem vrácení hodnoty i s příklady najdete v sekci <xsl:value-of/> v panelu Reference.

Výběr uzlu, který chcete opakovat

Můžete vybrat uzel, který chcete opakovat, a volitelně také filtrovat výsledky. V dialogovém okně Vytváření výrazů XPath bude vybraný obsah vložen v bloku <xsl:for-each>. Pokud jste nevybrali obsah, budou tagy <xsl:for-each> vloženy v místě kurzoru.

  1. Poklepáním na vyhrazené místo pro data XML na stránce otevřete okno Vytváření výrazů XPath.
  2. V dialogovém okně Vytváření výrazů XPath (Opakovaná oblast) vyberte ve stromu schématu XML položku, kterou chcete opakovat.

    V rámečku Výraz se objeví správný výraz XPath, který identifikuje tento uzel.

    Poznámka:

    Opakované položky jsou ve stromu schématu XML označeny symbolem Plus (+).

    V následujícím příkladu chcete opakovat každý uzel item v souboru XML.

    Dialogové okno Vytváření výrazů XPath (opakovaná oblast)

    Po klepnutí na tlačítko OK se do stránky XSLT vloží následující kód:

    <xsl:for-each select="provider/store/items/item"> 
     Content goes here 
    </xsl:for-each>

    Někdy chcete pracovat jen s podmnožinou opakovaných uzlů – například jen s položkami, jejichž atribut má určitou hodnotu. V tom případě musíte vytvořit filtr.

Filtrování opakovaných dat

Pomocí filtru identifikujete opakované uzly s konkrétními hodnotami atributu.

  1. Ve stromu schématu XML vyberte opakovaný uzel.
  2. Klepněte na tlačítko Vytvořit filtr.
  3. Klepnutím na tlačítko plus (+) vytvořte prázdný filtr.
  4. Zadejte kritéria filtru do následujících polí:

    Filtrovat podle

    Určuje opakovaný uzel, který obsahuje data, podle kterých chcete filtrovat. Rozbalovací nabídka obsahuje seznam nadřízených uzlů uzlu vybraného ve stromu schématu XML.

    Kde

    Určuje atribut nebo podelement uzlu Filtrovat podle, který bude použit k omezení výsledků. Atribut nebo podelement můžete vybrat z rozbalovací nabídky nebo můžete do tohoto pole zadat vlastní výraz XPath, a identifikovat tak potomky hlouběji ve stromu schématu.

    Operátor

    Určuje operátor porovnání použitý ve výrazu filtru.

    Hodnota

    Určuje hodnotu kontrolovanou v uzlu Filtrovat podle. Zadejte hodnotu. Pokud jsou pro stránku XSLT definovány dynamické parametry, můžete jeden z nich vybrat z rozbalovací nabídky.

  5. Pokud chcete zadat další filtr, znovu klepněte na tlačítko plus (+).

    Při zadávání hodnot nebo provádění výběrů v rozbalovacích nabídkách se mění výraz XPath v rámečku Výraz.

    V následujícím příkladu chcete sadu výsledků omezit jen na ty uzly item, u nichž má atribut @available hodnotu true.

    Omezení výsledků jen na ty uzly položek, u nichž má atribut @available hodnotu „pravda“

    Po kliknutí na tlačítko OK se na stránku XSLT vloží následující kód:<xsl:for-each select="provider/store/items/item[@available = &apos;true&apos;]"> Prostor pro obsah </xsl:for-each>

    <xsl:for-each select="provider/store/items/item[@available = &apos;true&apos;]"> 
          Content goes here 
    </xsl:for-each>
    Poznámka:

    Řetězce, například true, musíte uzavřít do uvozovek. Aplikace Dreamweaver uvozovky zakóduje (&apos;), takže jsou vloženy jako platný XHTML.

    Můžete vytvářet složitější filtry, které umožní zadání rodičovských uzlů jako kritérií filtru. V následujícím příkladu chcete sadu výsledků omezit jen na ty uzly item, u nichž má uzel store atribut @id s hodnotou 1 a pro uzel item je hodnota price větší než 5.

    Omezení výsledků jen na ty uzly položky, u nichž má atribut obchodu @id hodnotu 1 a u kterých má uzel ceny položky hodnotu větší než 5

    Po kliknutí na tlačítko OK se na stránku XSLT vloží následující kód:<xsl:for-each select="provider/store[@id = 1]/items/item[price &gt; 5]"> Prostor pro obsah </xsl:for-each>

    Více informací o opakovaných oblastech i s příklady najdete v sekci <xsl:for-each> v panelu Reference.

    <xsl:for-each select="provider/store[@id = 1]/items/item[price &gt; 5]"> 
        Content goes here 
    </xsl:for-each>
Logo Adobe

Přihlaste se ke svému účtu.