Seznamte se s výchozími klávesovými zkratkami v aplikaci Dreamweaver a naučte se je přizpůsobit.

Klávesové zkratky aplikace Dreamweaver vám pomáhají pracovat rychleji. Řadu klávesových zkratek najdete u názvů příkazů v nabídkách.

Poznámka:

Následující seznam obsahuje nejužitečnější klávesové zkratky. V aplikaci Dreamweaver si můžete upravit klávesové zkratky. Viz Přizpůsobení klávesových zkratek.

Klávesové zkratky ke stažení

Stáhněte si a vytiskněte přehled těchto klávesových zkratek určený k tisku.

  Windows – část 1

  Windows – část 2

  Mac – klávesové zkratky pro kódování

  Mac – část 2


Zde najdete seznam klávesových zkratek v aplikaci Dreamweaver. Chcete-li si prohlédnout klávesové zkratky pro konkrétní úkon, panel nebo pracovní postup, použijte níže uvedené filtry.

Klávesové zkratky pro kódování

Akce Mac Windows
Rychlá úprava Command + E Ctrl + E
Rychlý dokument Command + K Ctrl+ K
Otevřít / Přidat čáru nad Command + Shift + Enter Ctrl + Shift + Enter
Zobrazit rady k parametrům Ctrl + ,
Ctrl + ,
Sloupec s více kurzory / obdélníkový výběr Opt + kliknutí + přetažení Alt + kliknutí + přetažení
Výběr nesousedících oblastí více kurzory Command + kliknutí Ctrl + kliknutí
Zobrazit rady při psaní kódu

Ctrl + mezerník

Ctrl + mezerník

Výběr podřízené položky 

Command + ]

Ctrl + ]

Jít na řádek

Command + ,

Ctrl + G

Vybrat rodičovský tag

Command + [ Ctrl + [

Sbalit výběr

Command + Shift + C

Ctrl + Shift + C

Sbalit vše vně výběru

Command + Opt + C

Ctrl + Alt + C

Rozbalit výběr

Command + Shift + E

Ctrl + Shift + E

Sbalit celý tag 

Command + Shift + J

Ctrl + Shift + J

Sbalit celý vnější tag

Command + Opt + J

Ctrl + Alt + J

Rozbalit vše

Command + Opt + E

Ctrl + Alt + E

Odsadit kód 

Command + Shift + >

Ctrl + Shift + >

Odsadit kód doleva 

Command + Shift + <

Ctrl + Shift + <

Vyvážit závorky 

Command + '

Ctrl + '

Navigace v kódu

Command + Opt + N

Ctrl + Alt + N

Odstranit slovo vlevo

Command + Delete Ctrl + Backspace

Odstranit slovo vpravo

Command + Fn + Delete

Ctrl + Delete

Vybrat řádek nahoru

Shift + nahoru

Shift + nahoru

Vybrat řádek dolů

Shift + dolů

Shift + dolů

Vybrat znak vlevo

Shift + doleva

Shift + doleva

Vybrat znak vpravo

Shift + doprava

Shift + doprava

Vybrat stránku nahoru

Shift + Fn + PgUp Shift + PgUp

Vybrat stránku dolů

Shift + Fn + PgDn

Shift + PgDn

Přejít o slovo doleva

Opt + doleva

Ctrl + doleva

Přejít o slovo doprava

Opt + doprava

Ctrl + doprava

Přejít na začátek aktuálního řádku

Command + doleva

Alt + doleva

Přejít na konec aktuálního řádku

Command + doprava

Alt + doprava
Přepnout komentář na řádku Command + / Ctrl + /
Přepnout komentář v bloku (pro soubory PHP a JS) Command + Opt + / Ctrl + Shift + /
Výběr duplicitního řádku Command + D Ctrl + D
Odstranit řádek/řádky Command + Shift + D Ctrl + Shift + D
Přejít na definici (soubory JS) Command + J Ctrl + J
Vybrat slovo vpravo Opt + Shift + doprava Ctrl + Shift + doprava
Vybrat slovo vlevo Opt + Shift + doleva Ctrl + Shift + doleva
Přejít na začátek souboru Command + Fn + doleva Ctrl + Home
Přejít na konec souboru Command + Fn + doprava Ctrl + End
Vybrat do začátku souboru Command + Shift + Fn + doleva Ctrl + Shift + Home
Vybrat do konce souboru Command + Shift + Fn + doprava Ctrl + Shift + End
Přejít na zdrojový kód Command + Opt + ` Ctrl + Alt + `
Celá obrazovka Command + Ctrl + F Nelze
Zavřít okno Command + W Ctrl + W
Ukončit aplikaci Command + Q Ctrl + Q
Rychlý editor tagů Command + T Ctrl + T
Jít na následující slovo Command + doprava Ctrl + doprava
Jít na předcházející slovo Command + doleva Ctrl + doleva
Jít na předchozí odstavec (zobrazení návrhu) Command + nahoru Ctrl + nahoru
Jít na následující odstavec (zobrazení návrhu) Command + dolů Ctrl + dolů
Vybrat do dalšího slova Command + Shift + doprava Ctrl + Shift + doprava
Vybrat od předcházejícího slova Command + Shift + doleva Ctrl + Shift + doleva
Vybrat od předcházejícího odstavce Command + Shift + nahoru Ctrl + Shift + nahoru
Vybrat do dalšího odstavce Command + Shift + dolů Ctrl + Shift + dolů
Přejít na další panel vlastností Command + Opt + Fn + dolů Ctrl + Alt + PgDn
Přejít na předchozí panel vlastností Command + Opt + Fn + nahoru Ctrl + Alt + PgUp
Nový ve stejném okně Command + Shift + N Ctrl + Shift + N
Ukončit odstavec Command + Enter Ctrl + Enter
Následující dokument Command + ` Ctrl + Tab
Předcházející dokument Command + Shift + ` Ctrl + Shift + Tab
Ohraničit # Command + Shift + 3 Ctrl + Shift + 3

Refaktorování zkratek

Akce Mac Windows
Přejmenovat Command + Opt + R Ctrl + Alt + R
Extrahovat do proměnné Command + Alt + V Ctrl + Alt + V
Extrahovat do funkce Command + Alt + M Ctrl + Alt + M

Klávesové zkratky panelu Soubory

Akce Mac Windows
Nový soubor Command + Shift + N Ctrl + Shift + N
Nová složka Command + Opt + Shift + N Ctrl + Alt + Shift + N

Klávesové zkratky pro hledání a nahrazení

Akce Mac Windows
Hledat v aktuálním dokumentu Command + F
Ctrl + F
Hledat a nahradit v souborech Command + Shift + F Ctrl + Shift + F
Nahradit v aktuálním dokumentu Apple+Alt+F Ctrl + H
Hledat další Command + G F3
Najít předchozí Command + Shift + G Shift + F3
Najít všechny a označit Command + Ctrl + G Ctrl + Shift + F3
Přidat další shodu do výběru Ctrl + Command + R Ctrl + R
Přeskočit a přidat další shodu do výběru Ctrl + Command + Opt + R Ctrl + Alt + R

Klávesové zkratky pro vkládání

Akce Mac Windows
Vložit obraz Command + Opt + I Ctrl + Alt + I
Vložit video HTML5 Command + Opt + Shift + V Ctrl + Alt + Shift + V
Vložit sazbu s animací Command + Opt + Shift + E Ctrl + Alt + Shift + E
Vložit animaci Flash SWF Command + Opt + F Ctrl + Alt + F
Vložit zalomení řádku Shift + Enter Shift +Enter
Nerozdělitelná mezera (&nbsp) Command + Shift + Space Ctrl + Shift + Space

Klávesové zkratky pro CSS

Akce Mac Windows
Kompilovat preprocesory CSS F9 F9
Přidat selektor nebo vlastnost CSS v závislosti na označeném panelu Command + Opt + Shift + = Ctrl + Alt + Shift + =
Přidat selektor CSS Command + Opt + S Ctrl + Alt + S
Přidat vlastnost CSS Command + Opt + P Ctrl + Alt + P

Klávesové zkratky pro vodítka, mřížky a pravítka (v zobrazení návrhu)

Akce Mac Windows
Zobrazovat vodítka Command + ; Ctrl + ;
Zamknout vodítka Command + Opt + ; Ctrl + Alt + ;
Přitahovat na vodítka Command + Shift + ; Ctrl + Shift + ;
Přitahovat vodítka na elementy Command + Shift + G Ctrl + Shift + G
Zobrazovat mřížku Command + Opt + G Ctrl + Alt + G
Přitahovat na mřížku Command + Opt + Shift + G Ctrl + Alt + Shift + G
Zobrazit pravítka Command + Opt + R Ctrl + Alt + R

Klávesové zkratky náhledu

Akce Mac Windows
Náhled v primárním prohlížeči v reálném čase Opt + F12 F12
Náhled v sekundárním prohlížeči Shift + F12 Shift + F12

Klávesové zkratky specifické pro jednotlivá zobrazení

Akce Mac Windows
Zmrazit JavaScript (živé zobrazení) F6 F6
Skrýt živé zobrazení Ctrl + Command + H Ctrl + Alt + H
Přepnout zobrazení Ctrl + ` Ctrl + `
Inspekce (živé zobrazení) Opt + Shift + 11 Alt + Shift + F11
Skrýt všechny vizuální pomůcky (zobrazení návrhu) Command + Shift + I Ctrl + Shift + I
Přepínání mezi zobrazením návrhu a živým zobrazením Command + Shift + F11 Ctrl + Shift + F11

Klávesové zkratky pro okna

Akce Mac Windows
Předvolby Command + U Ctrl + U
Zobrazit panely F4 F4
Chování Shift + F4 Shift + F4
Inspektor kódu Opt + F10 F10
CSS Designer Command + F11 Shift + F11
DOM Command + F7 Ctrl + F7
Soubory F8 F8
Vložit Command + F2 Ctrl + F2
Vlastnosti Command + F3 Ctrl + F3
Výstup Shift + F6 Shift + F6
Hledání F7 F7
Výstřižky Nelze Shift + F9
Nápověda online k aplikaci Dreamweaver F1 F1

Klávesové zkratky pro text

Akce Mac Windows
Odsazení Command + Opt + ] Ctrl + Alt + ]
Odsadit doleva Command + Opt + [ Ctrl + Alt + [
Tučné Command + B Ctrl + B
Kurzíva Command + I Ctrl + I
Kontrola pravopisu Shift + F7 Shift + F7
Odstranit odkaz Command + Shift + L Ctrl + Shift + L

Klávesové zkratky pro lupu

Akce Mac Windows
Zvětšit zobrazení (zobrazení návrhu a živé zobrazení) Command + = Ctrl + =
Zmenšit zobrazení (zobrazení návrhu a živé zobrazení) Command + – Ctrl + –
100 % Command + 0 Ctrl + 0
50 % Command + Opt + 5 Ctrl + Alt + 5
200 % Command + Opt + 2 Ctrl + Alt + 2
300 % Command + Opt + 3 Ctrl + Alt + 3
Přizpůsobit výběr Command + Opt + 0 Ctrl + Alt + 0
Přizpůsobit vše Command + Shift + 0 Ctrl + Shift + 0
Podle šířky Command + Opt + Shift + 0 Ctrl + Alt + Shift + 0
Zvětšit velikost písma Command + + Ctrl + +
Zmenšit velikost písma Command + – Ctrl + –
Obnovit velikost písma Command + 0 Ctrl + 0

Klávesové zkratky pro tabulku

Akce Mac Windows
Vložit tabulku Command + Opt + T Ctrl + Alt + T
Sloučit buňky Command + Opt + M Ctrl + Alt + M
Rozdělit buňku Command + Opt + Shift + T Ctrl + Alt + Shift + T
Vložit řádek Command + M Ctrl + M
Vložit sloupec Command + Shift + A Ctrl + Shift + A
Odstranit řádek Command + Shift + M Ctrl + Shift + M
Odstranit sloupec Command + Shift + – Ctrl + Shift + –
Zvětšit rozmezí sloupců Command + Shift + ] Ctrl + Shift + ]
Zmenšit rozmezí sloupců Command + Shift + [ Ctrl + Shift + [

Klávesové zkratky pro správu webu

Akce Mac Windows
Získat soubor Cmd + Shift + B  Ctrl + Alt + D
Vyhradit si soubor Opt + Shift + Command + D Ctrl + Alt + Shift + D
Odeslat soubor Cmd + Shift + U Ctrl + Shift + U
Zpřístupnit soubor Opt + Shift + Command + U Ctrl + Alt + Shift + U
Zkontrolovat odkazy na celém webu Command + F8 Ctrl + F8
Zobrazit tituly stránek Command + Shift + T Ctrl + Shift + T

Vytvoření referenčního seznamu pro aktuální sadu zkratek

Referenční seznam je záznamem aktuální sady zkratek. Informace se uloží ve formátu tabulky HTML. Referenční seznam můžete zobrazit ve webovém prohlížeči nebo ho můžete vytisknout.

  1. Vyberte položky Úpravy > Klávesové zkratky (Windows) nebo Dreamweaver > Klávesové zkratky (Macintosh).
  2. Klepněte na tlačítko Exportovat sadu jako HTML, což je třetí tlačítko v sadě čtyř tlačítek nahoře v dialogovém okně.
  3. V dialogovém okně Uložit, které se objeví, zadejte název referenčního seznamu a vyberte umístění pro uložení souboru.

Přizpůsobení klávesových zkratek

Pomocí Editoru klávesových zkratek můžete vytvářet vlastní klávesové zkratky, včetně zkratek pro výstřižky kódu. V Editoru klávesových zkratek můžete také odstranit zkratky, upravit stávající zkratky a vybrat předem nastavenou sadu zkratek.

Vytvoření klávesové zkratky

Vytvoření vlastních klávesových zkratek, úpravy stávajících zkratek nebo výběr předem nastavené sady zkratek.

  1. Vyberte položky Úpravy > Klávesové zkratky (Windows) nebo Dreamweaver > Klávesové zkratky (Macintosh).
  2. Nastavte libovolné z následujících voleb a klikněte na tlačítko OK:

    Aktuální sada:

    Umožňuje vybrat sadu předem definovaných zkratek, dodávaných s aplikací Dreamweaver, nebo libovolnou vlastní sadu, kterou jste definovali. Předem definované sady jsou uvedeny na začátku nabídky. Pokud například znáte zkratky používané v programech HomeSite nebo BBEdit, můžete používat tyto zkratky, když zvolíte odpovídající předem definovanou sadu.

    Příkazy:

    Umožňuje vybrat kategorii příkazů, které chcete upravit. Můžete například upravit příkazy nabídky, například příkaz Otevřít, nebo příkazy pro úpravy kódu, například Vyvážit závorky.

    Poznámka:

    Chcete-li přidat nebo upravit klávesovou zkratku pro výstřižek kódu, vyberte volbu Výstřižek z rozbalovací nabídky Příkazy.

    Seznam příkazů:

    Zobrazuje příkazy spojené s kategorií, kterou jste vybrali z rozbalovací nabídky Příkazy, spolu s přiřazenými zkratkami. Kategorie Příkazy nabídky zobrazuje tento seznam jako stromové zobrazení, které odpovídá struktuře nabídek. Pro ostatní kategorie se zobrazuje seznam příkazů podle názvů (například Ukončit aplikaci).

    Zkratky:

    Zobrazuje všechny zkratky přiřazené k vybranému příkazu.

    Přidat položku (+):

    Přidá zkratku k aktuálnímu příkazu. Kliknutím na toto tlačítko přidáte prázdný řádek do rámečku Zkratky. Zadejte novou kombinaci kláves a klikněte na tlačítko Změnit, abyste přidali klávesovou zkratku pro tento příkaz. Pro každý příkaz můžete přiřadit dvě různé klávesové zkratky; pokud jsou již k příkazu přiřazeny dvě zkratky, tlačítko Přidat položku neudělá nic.

    Odstranit položku (–):

    Odstraní vybranou zkratku ze seznamu zkratek.

    Stiskněte klávesy:

    Zobrazí kombinaci kláves, kterou zadáte při přidávání nebo změně zkratky.

    Změna:

    Přidá kombinaci kláves zobrazenou v rámečku Stiskněte klávesy do seznamu zkratek nebo změní vybranou zkratku na určenou kombinaci kláves.

    Duplikovat sadu:

    Duplikuje aktuální sadu. Pojmenujte novou sadu; výchozí název je název aktuální sady s přidaným slovem kopie.

    Přejmenovat sadu:

    Přejmenuje aktuální sadu.

    Exportovat jako soubor HTML:

    Uloží aktuální sadu ve formátu tabulky HTML pro snadné zobrazení a tisk. Soubor HTML můžete otevřít v prohlížeči a vytisknout si zkratky pro získání přehledu.

    Odstranit sadu:

    Odstraní sadu. (Aktivní sadu nelze odstranit.)

Odstranění zkratky z příkazu

  1. Vyberte položky Úpravy > Klávesové zkratky (Windows) nebo Dreamweaver > Klávesové zkratky (Macintosh).
  2. Z rozbalovací nabídky Příkazy vyberte kategorii příkazů.
  3. V seznamu Příkazy vyberte příkaz a pak vyberte zkratku.
  4. Klepněte na tlačítko Odstranit položku (–).

Přidání zkratky k příkazu

  1. Vyberte položky Úpravy > Klávesové zkratky (Windows) nebo Dreamweaver > Klávesové zkratky (Macintosh).
  2. Z rozbalovací nabídky Příkazy vyberte kategorii příkazů.
  3. V seznamu Příkazy vyberte příkaz.

    Poznámka:

    Chcete-li přidat klávesovou zkratku pro výstřižek kódu, vyberte volbu Výstřižek z rozbalovací nabídky Příkazy.

    Zkratky přiřazené k příkazu se objeví v rámečku Zkratky.

  4. Připravte se na přidání zkratky jedním z následujících úkonů:
    • Pokud jsou k příkazu přiřazeny méně než dvě zkratky, klepněte na tlačítko Přidat položku (+). V rámečku Zkratky se objeví nový prázdný řádek a textový kurzor se přemístí do pole Stiskněte klávesy.

    • Pokud jsou již k příkazu přiřazené dvě zkratky, vyberte jednu z nich (tato zkratka se nahradí novou zkratkou). Pak klepněte do rámečku Stiskněte klávesy.

  5. Stiskněte kombinaci kláves. Kombinace kláves se objeví v rámečku Stiskněte klávesy.

    Poznámka:

    Pokud se vyskytne problém s kombinací kláves (například pokud tato kombinace kláves je již přiřazena k jinému příkazu), hned pod rámečkem Zkratky se objeví vysvětlující zpráva a nemusí být možné zkratku přidat nebo upravit.

  6. Klepněte na tlačítko Změnit. Nová kombinace kláves se přiřadí k příkazu.

Úprava stávající zkratky

  1. Vyberte položky Úpravy > Klávesové zkratky (Windows) nebo Dreamweaver > Klávesové zkratky (Macintosh).
  2. Z rozbalovací nabídky Příkazy vyberte kategorii příkazů.
  3. V seznamu Příkazy vyberte příkaz a pak vyberte zkratku, kterou chcete změnit.
  4. Klepněte do rámečku Stiskněte klávesy a zadejte novou kombinaci kláves.
  5. Chcete-li zkratku změnit, klikněte na tlačítko Změnit.

    Poznámka:

    Pokud se vyskytne problém s kombinací kláves (například pokud tato kombinace kláves je již přiřazena k jinému příkazu), hned pod polem Zkratky se objeví vysvětlující zpráva a nemusí být možné zkratku přidat nebo upravit.

O klávesových zkratkách a jiných než amerických klávesnicích

Výchozí klávesové zkratky aplikace Dreamweaver fungují primárně na standardní americké klávesnici. Klávesnice pro jiné země (včetně klávesnic vyráběných ve Velké Británii) nemusí poskytovat funkčnost potřebnou pro využití těchto zkratek. Pokud vaše klávesnice nepodporuje určité zkratky pro aplikaci Dreamweaver, aplikace Dreamweaver jejich funkci zablokuje.

Informace o přizpůsobení klávesových zkratek tak, aby fungovaly s neamerickou klávesnicí, viz část „Změna mapování klávesových zkratek“ v příručce Rozšíření aplikace Dreamweaver.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online