Rezervace souborů a zrušení jejich rezervace na lokálních a vzdálených serverech pomocí systému zpřístupnění/vyhrazení aplikace Dreamweaver, WebDAV nebo Subversion.

Pokud pracujete v prostředí týmové spolupráce, můžete zpřístupnit nebo vyhradit soubory z lokálních nebo vzdálených serverů. Pokud jste jediná osoba pracující na vzdáleném serveru, můžete použít příkazy Získat a Odeslat bez vyhrazení nebo zpřístupnění souborů.

Poznámka:

Pro testovací server můžete použít funkce Získat a Odeslat, ale nemůžete použít systém zpřístupnění/vyhrazení.

Vyhrazení souboru odpovídá prohlášení „na tomto souboru teď pracuji, nedotýkejte se ho“. Když je soubor vyhrazen, jméno osoby, která si ho vyhradila, se zobrazí v panelu Soubory spolu s červeným zaškrtnutím (pokud si soubor vyhradil člen týmu) nebo zeleným zaškrtnutím (pokud jste si vyhradili soubor vy) vedle ikony souboru.

Zpřístupnění souboru umožní ostatním členům týmu si soubor vyhradit a upravovat ho. Když soubor po úpravách zpřístupníte, lokální verze souboru bude pouze pro čtení a v panelu Soubory se za souborem zobrazí symbol zámku, abyste v tomto souboru neprováděli změny.

Aplikace Dreamweaver vyhrazené soubory na vzdáleném serveru nenastavuje na pouze pro čtení. Pokud přenášíte soubory pomocí jiné aplikace než aplikace Dreamweaver, můžete vyhrazené soubory přepsat. V jiných aplikacích než aplikace Dreamweaver je proto v souborové struktuře viditelný vedle vyhrazeného souboru soubor LCK, aby se zamezilo možnosti takových situací.

Nastavení systému zpřístupnění/vyhrazení

Před použitím systému zpřístupnění/vyhrazení musíte přiřadit webové místo ke vzdálenému serveru.

  1. Vyberte volbu Webové místo > Správa webových míst.
  2. Vyberte webové místo a klikněte na tlačítko Upravit.
  3. V dialogovém okně Nastavení webového místa vyberte kategorii Servery a proveďte jednu z následujících možností:
    • Klikněte na tlačítko Přidat nový server a přidejte nový server.

    • Vyberte existující server a klikněte na tlačítko Upravit existující server.

  4. Upřesněte Základní možnosti, je-li třeba, a poté klikněte na tlačítko Další volby.
  5. Pokud pracujete v týmovém prostředí (nebo pracujete sami, ale z více různých počítačů), vyberte možnost Zapnout vyhrazování souborů. Pokud chcete ve webovém místě zakázat zpřístupňování a vyhrazování souborů, odznačte tuto volbu.

    Tato volba se hodí k tomu, abyste dali ostatním vědět, že jste si vyhradili soubor pro úpravy, nebo upozornili sami sebe, že máte novější verzi souboru na jiném počítači.

    Pokud nevidíte volby zpřístupnění/vyhrazení, znamená to, že nemáte nastavený vzdálený server.

  6. Pokud chcete automaticky vyhradit soubory, když na ně v panelu Soubory dvakrát kliknete pro otevření, vyberte volbu Vyhrazovat soubory při otevření.

    Při otevření souboru výběrem voleb Soubor > Otevřít si soubor nevyhradíte, i když je tato volba vybraná.

  7. Nastavte zbývající volby:

    Jméno pro vyhrazování

    Jméno pro vyhrazování se zobrazí v panelu Soubory u vyhrazených souborů; členové týmu tak mohou kontaktovat toho, kdo si příslušný soubor vyhradil.

    Poznámka:

    Pokud pracujete sami na více různých počítačích, použijte na každém počítači pro vyhrazení jiné jméno (například PetrR-DomaMac a PetrR-KancelarPC), abyste věděli, kde je nejnovější verze souboru, pokud ho zapomenete zpřístupnit.

    E-mailová adresa

    Pokud zadáte e-mailovou adresu, když vyhrazujete soubor, vaše jméno se zobrazí v panelu Soubory vedle daného souboru jako odkaz (modré a podtržené). Pokud klikne člen týmu na tento odkaz, jeho výchozí e-mailový program se otevře s novou zprávou obsahující vaši e-mailovou adresu a předmět odpovídající názvu souboru a webového místa.

Zpřístupnění a vyhrazení souborů ve vzdálené složce

Po nastavení systému zpřístupnění/vyhrazení můžete na vzdáleném serveru pomocí panelu Soubory nebo z okna dokumentu zpřístupňovat a vyhrazovat soubory.

Vyhrazení souborů pomocí panelu Soubory

  1. V panelu Soubory (Okna > Soubory) vyberte soubory ze vzdáleného serveru, které si chcete vyhradit.

    Poznámka:

    Soubory můžete vybrat v zobrazení Lokální nebo v zobrazení Vzdálené, ne ale v zobrazení Testovací server.

    Červené zaškrtnutí značí, že soubor si vyhradil jiný člen týmu, a symbol zámku značí, že soubor je pouze pro čtení (Windows) nebo zamknutý (Macintosh).

  2. Jedním z následujících úkonů si soubory vyhradíte:
    • V panelu nástrojů panelu Soubory klikněte na tlačítko Vyhradit.

    • Klikněte pravým tlačítkem (Windows) nebo s klávesou Ctrl (Macintosh) a z kontextové nabídky vyberte volbu Vyhradit.

  3. Chcete-li stáhnout závislé soubory patřící k vybraným souborům, klikněte v dialogovém okně Závislé soubory na Ano, nebo klikněte na tlačítko Ne. Standardně se závislé soubory nestahují. Tuto volbu můžete nastavit prostřednictvím položky Úpravy > Předvolby > Web.

    Poznámka:

    Obvykle je vhodné stáhnout závislé soubory při vyhrazování nového souboru, ale pokud jsou již poslední verze závislých souborů na lokálním disku, není je nutné znovu stahovat.

    Za ikonou lokálního souboru se zobrazí zelené zaškrtnutí naznačující, že jste si soubor vyhradili.

    Poznámka:

    Pokud jste vyhradili právě aktivní soubor, aktuálně otevřená verze tohoto souboru se přepíše novou vyhrazenou verzí.

Zpřístupnění souborů pomocí panelu Soubory

  1. V panelu Soubory (Okna > Soubory) vyberte vyhrazené nebo nové soubory.

    Poznámka:

    Soubory můžete vybrat v zobrazení Lokální nebo v zobrazení Vzdálené, ne ale v zobrazení Testovací server.

  2. Jedním z následujících úkonů soubory zpřístupníte:
    • V panelu nástrojů v panelu Soubory klikněte na tlačítko Zpřístupnit.

    • Klikněte pravým tlačítkem (Windows) nebo s klávesou Ctrl (Macintosh) a z kontextové nabídky vyberte volbu Zpřístupnit.

  3. Chcete-li odeslat závislé soubory patřící k vybraným souborům, klikněte na tlačítko Ano, nebo klikněte na tlačítko Ne, pokud závislé soubory nechcete odeslat. Standardně se závislé soubory neodesílají. Tuto volbu můžete nastavit prostřednictvím položky Úpravy > Předvolby > Webové místo.

    Poznámka:

    Obvykle je vhodné odeslat závislé soubory při zpřístupňování nového souboru, ale pokud jsou poslední verze závislých souborů stále na vzdáleném serveru, není je nutné znovu odesílat.

    Za ikonou lokálního souboru se zobrazí symbol zámku značící, že soubor je nyní pouze pro čtení.

    Poznámka:

    Pokud zpřístupňujete právě aktivní soubor, může se před zpřístupněním automaticky uložit, podle nastavení příslušné předvolby.

Zpřístupnění otevřeného souboru z okna dokumentu

  1. Ujistěte se, že soubor, který chcete zpřístupnit, je otevřený v okně dokumentu.

    Poznámka:

    Současně můžete zpřístupnit pouze jeden otevřený soubor.

  2. Proveďte jeden z následujících úkonů:
    • Vyberte volbu Webové místo > Zpřístupnit.

    • V panelu nástrojů okna dokumentu klikněte na ikonu Správa souborů a z nabídky vyberte volbu Zpřístupnit.

      Pokud není aktuální soubor součástí aktivního webu v panelu Soubory, aplikace Dreamweaver se pokusí určit, ke kterému lokálně definovanému webu aktuální soubor náleží. Pokud aktuální soubor patří do jiného webového místa, než které je aktivní v panelu Soubory, aplikace Dreamweaver otevře toto webové místo a provede operaci zpřístupnění.

    Poznámka:

    Pokud zpřístupňujete právě aktivní soubor, může se před zpřístupněním automaticky uložit, podle nastavení příslušné předvolby.  

Zrušení vyhrazení souboru

Pokud vyhradíte soubor a poté se rozhodnete ho neupravovat (nebo se rozhodnete zrušit provedené změny), můžete zrušit operaci vyhrazení souboru a soubor vrátit do původního stavu.

Chcete-li zrušit vyhrazení souboru, proveďte jeden z následujících úkonů:

  • Otevřete soubor v okně dokumentu a vyberte volbu Webové místo > Zrušit vyhrazení.

  • V panelu Soubory (Okna > Soubory) klikněte pravým tlačítkem (Windows) nebo s klávesou Ctrl (Macintosh) a vyberte volbu Zrušit vyhrazení.

    Lokální kopie souboru se stane kopií pouze pro čtení a provedené změny budou ztraceny.

Používání WebDAV pro zpřístupnění a vyhrazení souborů

Aplikace Dreamweaver se umí připojit k serveru pomocí WebDAV (Web-based Distributed Authoring and Versioning), což je soubor rozšíření protokolu HTTP, který umožňuje uživatelům spolupracovat při úpravách a správě souborů na vzdálených webových serverech. Více informací najdete na adrese www.webdav.org.

  1. Pokud jste to ještě neudělali, definujte webové místo aplikace Dreamweaver určující lokální složku, kterou používáte pro ukládání souborů projektu.
  2. Vyberte volbu Webové místo > Správa webových míst a v seznamu dvakrát klikněte na webové místo.
  3. V dialogovém okně Nastavení webového místa vyberte kategorii Servery a proveďte jednu z následujících možností:
    • Klikněte na tlačítko Přidat nový server a přidejte nový server.

    • Vyberte existující server a klikněte na tlačítko Upravit existující server.

  4. V základní obrazovce zvolte v rozbalovací nabídce Připojit pomocí možnost WebDAV a doplňte zbytek voleb na obrazovce, je-li třeba.
  5. Klikněte na tlačítko Další volby.
  6. Vyberte volbu Zapnout vyhrazování souborů a zadejte následující údaje:
    • Do pole Jméno pro vyhrazování zadejte jméno, které vás identifikuje ostatním členům týmu.

    • Do pole E-mailová adresa zadejte vaši e-mailovou adresu.

      Jméno a e-mailová adresa se používá k identifikaci vlastnictví na serveru WebDAV a pro kontaktní účely se zobrazí v panelu Soubory.

  7. Klikněte na tlačítko Uložit.

    Aplikace Dreamweaver zkonfiguruje webové místo pro přístup pomocí WebDAV. Když použijete pro některý soubor ve webovém místě příkazy Zpřístupnit nebo Vyhradit, soubor se přenese pomocí WebDAV.

    Poznámka:

    WebDAV nemusí být schopen správně vyhradit všechny soubory s dynamickým obsahem, například tagy PHP nebo SSI, protože příkaz HTTP GET tyto tagy při vyhrazení souboru nahradí.

Používání dílčí verze (SVN) k získání a zpřístupnění souborů

Poznámka:

V aplikaci Dreamweaver CC 2017 a jejích novějších verzích je odebrána podpora produktu Subversion (SVN).

Aplikace Dreamweaver se umí připojit k serveru využívajícímu dílčí verze (SVN), systému řízení verzí, který umožňuje uživatelům upravovat a spravovat soubory na vzdálených webových serverech. Aplikace Dreamweaver není plným klientem SVN, ale umožňuje uživatelům získat nejnovější verze souborů, provádět změny a potvrzovat soubory.

Poznámka:

Aplikace Dreamweaver CS5 používá klientskou knihovnu Subversion 1.6.6 a aplikace Dreamweaver CS5.5 používá klientskou knihovnu 1.6.9. Novější verze klientské knihovny Subversion nejsou zpětně kompatibilní. Provedete-li aktualizaci klientské aplikace od jiného dodavatele (např. TortoiseSVN), aby pracovala s novější verzi knihovny Subversion, aktualizovaná aplikace knihovny Subversion provede aktualizaci místních metadat Subversion a aplikace Dreamweaver již s knihovnou Subversion nebude moci komunikovat. Tento problém nezpůsobují aktualizace serveru Subversion, protože tyto aktualizace jsou zpětně kompatibilní. Provedete-li aktualizaci klientské aplikace od jiného dodavatele, která pracuje s knihovnou Subversion 1.7 nebo s novější verzí, bude nutné zkontrolovat dostupnost aktualizací softwaru Adobe, než bude možné používat znovu knihovnu Subversion společně s aplikací Dreamweaver. Bližší informace o tomto problému najdete na adrese www.adobe.com/go/dw_svn_en.

Společnost Adobe doporučuje používat při práci se soubory kontrolovanými verzí SVN nástroj pro porovnávání souboru od jiného výrobce. Při porovnávání rozdílů souborů můžete přesně zjistit, jaké druhy úprav na těchto souborech provedli ostatní uživatelé. Další informace o nástrojích pro porovnání souborů najdete pomocí webového vyhledávače, například Google Search, hledáním nástrojů pro „porovnání souborů“ nebo „diff“. Produkt Dreamweaver spolupracuje s většinou nástrojů jiných výrobců.

Video s přehledem o práci s SVN a aplikací Dreamweaver najdete na adrese www.adobe.com/go/lrvid4049_dw.

Nastavení připojení SVN

Než použijete knihovnu Subversion (SVN) jako systém správy verzí pro aplikaci Dreamweaver, je třeba nastavit připojení k serveru SVN. Připojení k serveru SVN lze nastavit v kategorii Správa verzí v dialogovém okně Definice webového místa.

Server SVN je úložiště souborů, které vám a ostatním uživatelům umožňuje získávat a potvrzovat soubory. Liší se od vzdáleného serveru, který běžně používáte v aplikaci Dreamweaver. Při použití systému SVN zůstává vzdálený server tzv. „live“ serverem pro vaše webové stránky a server SVN slouží k poskytování úložiště pro soubory, u nichž chcete udržovat správu verzí. Typický pracovní postup zahrnuje získávání a potvrzování souborů pomocí serveru SVN a jejich následné publikování na vzdáleném serveru prostřednictvím aplikace Dreamweaver. Nastavení vzdáleného serveru je zcela oddělené od nastavení serveru SVN.

Než začnete provádět nastavení, musíte mít přístup k serveru SVN a k úložišti SVN. Bližší informace o systému SVN najdete na webových stránkách Subversion na adrese http://subversion.apache.org/.

Připojení SVN nastavte pomocí následujících kroků:

  1. Klikněte na položky Webová místa > Správa webových míst, vyberte místo, pro které chcete správu verzí nastavit, a klikněte na tlačítko Upravit.

    Poznámka:

    Pokud jste pro web aplikace Dreamweaver zatím nenastavili lokální a vzdálenou složku, bude před dalším pokračováním nutné nastavit alespoň lokální web. (Vzdálený web není v této fázi vyžadován, ale později jej bude nutné nastavit, aby bylo možné publikovat soubory na web.) Další informace najdete v tématu Práce s weby aplikace Dreamweaver.

  2. V dialogovém okně Nastavení webového místa vyberte kategorii Správa verzí.

  3. V místní nabídce Přístup vyberte volbu Subversion.

  4. Volby přístupu nastavte takto:

    • V místní nabídce Protokol vyberte požadovaný protokol. Dostupné protokoly jsou HTTP, HTTPS, SVN a SVN+SSH.

    Poznámka:

    Použití protokolu SVN+SSH vyžaduje zvláštní konfiguraci. Další informace naleznete na adrese www.adobe.com/go/learn_dw_svn_ssh_en.

    • Do textového pole Adresa serveru zadejte adresu serveru SVN (obvykle ve formě. názevserveru.doména.com).

    • Do textového pole Cesta k úložišti zadejte cestu ke svému úložišti na serveru SVN (obvykle způsobem /svn/váš_kořenový_adresář. Pojmenování kořenové složky úložiště SVN je záležitostí správce serveru.)

    • (Volitelné) Chcete-li použít jiný než výchozí port serveru, vyberte volbu Nevýchozí a do textového pole zadejte číslo portu.

    • Zadejte své uživatelské jméno a heslo na serveru SVN.

  5. Klikněte na tlačítko Testovat, chcete-li připojení otestovat, nebo klikněte na tlačítko OK, chcete-li dialogové okno zavřít. Následně zavřete dialogové okno Správa webových míst kliknutím na tlačítko Hotovo.

Jakmile je připojení k serveru nastaveno, můžete úložiště SVN zobrazit pomocí panelu Soubory. Chcete-li úložiště zobrazit, vyberte v místní nabídce Zobrazit položku Zobrazení úložiště nebo v rozbaleném panelu Soubory klikněte na tlačítko Soubory úložiště .

Získání nejnovějších verzí souborů

Při získání nejnovější verze souboru z úložiště SVN sloučí aplikace Dreamweaver obsah tohoto souboru s obsahem jeho lokální kopie. (Jinými slovy, pokud soubor někdo aktualizoval od doby, kdy jste ho naposledy potvrdili, sloučí se tyto aktualizace do lokální verze souboru na vašem počítači.) Pokud soubor na lokálním pevném disku ještě neexistuje, aplikace Dreamweaver jej získá.

Poznámka:

Při prvotním získávání souborů z úložiště byste měli pracovat s místním adresářem, který je prázdný, nebo neobsahuje soubory se stejným názvem jako soubory v úložišti. Aplikace Dreamweaver nebude zavádět soubory úložiště na lokální disk napoprvé, pokud disk obsahuje soubory, jejichž názvy se shodují s názvy souborů ve vzdáleném úložišti.

  1. Ujistěte se, že máte správně nastavené připojení SVN.

  2. Proveďte jeden z následujících úkonů:

    • Zobrazte lokální verze souborů SVN na panelu Soubory vybráním volby Lokální zobrazení v místní nabídce Zobrazit. (Pracujete-li s rozbaleným panelem Soubory, Lokální zobrazení je použito automaticky.) Poté klikněte pravým tlačítkem (Windows) nebo klikněte se stisknutou klávesou Ctrl (Macintosh) na požadovaný soubor nebo složku a vyberte možnosti Správa verzí > Získat aktuální verze.

    • Zobrazte soubory úložiště SVN vybráním položky Zobrazení úložiště v místní nabídce Zobrazit na panelu Soubory nebo kliknutím na tlačítko Soubory úložiště v rozbaleném panelu Soubory. Poté klikněte pravým tlačítkem (Windows) nebo klikněte se stisknutou klávesou Ctrl (Macintosh) na požadovaný soubor nebo složku a vyberte volbu Získat aktuální verze.

Poznámka:

Nejnovější verzi můžete získat také buď kliknutím pravým tlačítkem na soubor a výběrem volby Vyhradit z kontextové nabídky, nebo výběrem souboru a kliknutím na tlačítko Vyhradit. Jelikož však systém SVN proces vyhrazení nepodporuje, nezpůsobí tato akce vyhrazení souborů v klasickém smyslu.

Potvrzení souborů

  1. Ujistěte se, že máte správně nastavené připojení SVN.

  2. Proveďte jeden z následujících úkonů:

    • Zobrazte lokální verze souborů SVN na panelu Soubory vybráním volby Lokální zobrazení v místní nabídce Zobrazit. (Pracujete-li s rozbaleným panelem Soubory, Lokální zobrazení je použito automaticky.) Poté vyberte soubor, který chcete potvrdit, a klikněte na tlačítko Zpřístupnit.

    • Zobrazte soubory úložiště SVN vybráním položky Zobrazení úložiště v místní nabídce Zobrazit na panelu Soubory nebo kliknutím na tlačítko Soubory úložiště v rozbaleném panelu Soubory. Poté klikněte pravým tlačítkem (Windows) nebo klikněte se stisknutou klávesou Ctrl (Macintosh) na soubor, který chcete potvrdit, a vyberte volbu Zpřístupnit.

  3. Zkontrolujte akce v dialogovém okně Potvrdit, podle potřeby proveďte změny a klikněte na tlačítko OK.

    Chcete-li akce změnit, vyberte konkrétní soubor, jehož akci chcete změnit, a klikněte na jedno z tlačítek ve spodní části dialogového okna Potvrdit. K dispozici jsou dvě volby: potvrdit a ignorovat.

Poznámka:

Zelená značka zatržení vedle souboru na panelu Soubory označuje změněný soubor, který zatím nebyl potvrzen v úložišti.

Aktualizace stavu souborů a složek v úložišti

Můžete aktualizovat stav SVN samostatného souboru nebo složky. Aktualizace neobnoví celé zobrazení.

  1. Ujistěte se, že máte správně nastavené připojení SVN.

  2. Zobrazte soubory úložiště SVN vybráním položky Zobrazení úložiště v místní nabídce Zobrazit na panelu Soubory nebo kliknutím na tlačítko Soubory úložiště v rozbaleném panelu Soubory.

  3. Klikněte pravým tlačítkem (Windows) nebo klikněte se stisknutou klávesou Ctrl (Macintosh) na libovolný soubor nebo složku v úložišti a vyberte volbu Aktualizovat stav.

Aktualizace stavu lokálního souboru nebo složek

Můžete aktualizovat stav SVN samostatného souboru nebo složky. Aktualizace neobnoví celé zobrazení.

  1. Ujistěte se, že máte správně nastavené připojení SVN.

  2. Zobrazte lokální verze souborů SVN na panelu Soubory vybráním volby Lokální zobrazení v místní nabídce Zobrazit. (Pracujete-li s rozbaleným panelem Soubory, Lokální zobrazení je použito automaticky.)

  3. Klikněte pravým tlačítkem (Windows) nebo klikněte se stisknutou klávesou Ctrl (Macintosh) na libovolný soubor nebo složku na panelu Soubory a vyberte volbu Aktualizovat stav.

Zobrazení revizí souboru

  1. Ujistěte se, že máte správně nastavené připojení SVN.

  2. Proveďte jeden z následujících úkonů:

    • Zobrazte lokální verze souborů SVN na panelu Soubory vybráním volby Lokální zobrazení v místní nabídce Zobrazit. (Pracujete-li s rozbaleným panelem Soubory, Lokální zobrazení je použito automaticky.) Poté klikněte pravým tlačítkem (Windows) nebo klikněte se stisknutou klávesou Ctrl (Macintosh) na soubor, u nějž chcete zobrazit revize, a vyberte možnost Správa verzí > Zobrazit revize.

    • Zobrazte soubory úložiště SVN vybráním položky Zobrazení úložiště v místní nabídce Zobrazit na panelu Soubory nebo kliknutím na tlačítko Soubory úložiště v rozbaleném panelu Soubory. Poté klikněte pravým tlačítkem (Windows) nebo klikněte se stisknutou klávesou Ctrl (Macintosh) na soubor, u nějž chcete zobrazit revize, a vyberte volbu Zobrazit revize.

  3. V dialogovém okně Historie revizí vyberte požadované revize a proveďte jednu z následujících akcí:

    • Chcete-li porovnat vybranou revizi s lokální verzí souboru, klikněte na tlačítko Porovnat s lokálním.

    Poznámka:

    Než budete moci porovnávat soubory, je třeba nainstalovat nástroj pro porovnávání souboru od jiného výrobce. Další informace o nástrojích pro porovnání souborů najdete pomocí webového vyhledávače, například Google Search, hledáním nástrojů pro „porovnání souborů“ nebo „diff“. Produkt Dreamweaver spolupracuje s většinou nástrojů jiných výrobců.

    • Chcete-li porovnat dvě vybrané revize, klikněte na tlačítko Porovnat. Chcete-li vybrat dvě revize současně, použijte kliknutí při stisknuté klávese Ctrl.

    • Vybranou revizi zobrazíte kliknutím na položku Zobrazit. Tato akce nezpůsobí přepsání aktuální lokální kopie téhož souboru. Vybranou revizi můžete uložit na pevný disk stejným způsobem jako kterýkoli jiný soubor.

    • Chcete-li vybranou revizi nastavit jako nejaktuálnější revizi v úložišti, klikněte na tlačítko Zvýšit.

Uzamykání a odemykání souborů

Uzamknutí souboru v úložišti SVN dává ostatním uživatelům vědět, že se souborem pracujete. Ostatní uživatelé stále mohou soubor lokálně upravovat, ale nebudou schopni jej potvrdit, dokud jej neodemknete. Pokud soubor v úložišti uzamknete, zobrazí se vedle něj ikona otevřeného zámku. Ostatní uživatelé vidí zcela zamknutou ikonu.

  1. Ujistěte se, že máte správně nastavené připojení SVN.

  2. Proveďte jeden z následujících úkonů:

    • Zobrazte soubory úložiště SVN vybráním položky Zobrazení úložiště v místní nabídce Zobrazit na panelu Soubory nebo kliknutím na tlačítko Soubory úložiště v rozbaleném panelu Soubory. Poté klikněte pravým tlačítkem (Windows) nebo klikněte se stisknutou klávesou Ctrl (Macintosh) na požadovaný soubor a vyberte volbu Zamknout nebo Odemknout.

    • Zobrazte lokální verze souborů SVN na panelu Soubory vybráním volby Lokální zobrazení v místní nabídce Zobrazit. (Pracujete-li s rozbaleným panelem Soubory, Lokální zobrazení je použito automaticky.) Poté klikněte pravým tlačítkem (Windows) nebo klikněte se stisknutou klávesou Ctrl (Macintosh) na požadovaný soubor a vyberte volbu Zamknout nebo Odemknout.

Přidání souboru do úložiště

Modrá značka plus vedle souboru na panelu Soubory znamená, že soubor zatím není v úložišti SVN.

  1. Ujistěte se, že máte správně nastavené připojení SVN.

  2. Na panelu Soubory vyberte soubor, který chcete přidat do úložiště, a klikněte na tlačítko Zpřístupnit.

  3. V dialogovém okně Potvrdit se ujistěte, že je soubor vybrán k potvrzení, a klikněte na tlačítko OK.

Přesunutí, kopírování, odstranění nebo obnovení souborů

  • Chcete-li přesunout soubor, přetáhněte jej do cílové složky na lokálním webu.

    Když přesunujete soubor, aplikace Dreamweaver jej označí v novém umístění pomocí značky Přidat s historií a soubor ve starém umístění označí značkou Odstranit. Při potvrzení těchto souborů soubor ze starého umístění zmizí.

  • Chcete-li zkopírovat soubor, vyberte soubor, zkopírujte jej (Úpravy > Kopírovat) a vložte (Úpravy > Vložit) do nového umístění.

    Při kopírování a vkládání souboru aplikace Dreamweaver soubor označí v novém umístění značkou Přidat s historií.

  • Chcete-li odstranit soubor, vyberte jej a stiskněte klávesu Delete.

    Aplikace Dreamweaver vám nabídne, zda chcete odstranit jen lokální verzi souboru nebo lokální verzi a verzi na serveru SVN. Pokud se rozhodnete odstranit jen lokální verzi, na soubor na serveru SVN to nebude mít žádný vliv. Pokud se rozhodnete odstranit i verzi na serveru SVN, lokální verze bude označena značkou Odstranit. Aby odstranění mohlo být provedeno, soubor je třeba potvrdit.

  • Chcete-li vrátit zkopírovaný nebo přesunutý soubor do původního umístění, pravým tlačítkem myši klikněte na soubor a vyberte možnost Správa verzí > Obnovit.

Řešení konfliktních souborů

Pokud je váš soubor v konfliktu s jiným souborem na serveru, můžete jej upravit a poté označit jako vyřešený. Pokud se například pokusíte zpřístupnit soubor, který je v konfliktu se změnami jiného uživatele, SVN vám nedovolí soubor potvrdit. Můžete získat nejnovější verzi souboru z úložiště, manuálně zachovat změny vaší pracovní kopie a poté soubor označit jako vyřešený, abyste jej mohli potvrdit.

  1. Ujistěte se, že máte správně nastavené připojení SVN.

  2. Zobrazte lokální verze souborů SVN na panelu Soubory vybráním volby Lokální zobrazení v místní nabídce Zobrazit. (Pracujete-li s rozbaleným panelem Soubory, Lokální zobrazení je použito automaticky.)

  3. Klikněte pravým tlačítkem (Windows) nebo klikněte se stisknutou klávesou Ctrl (Macintosh) na soubor, který chcete vyřešit, a vyberte možnosti Správa verzí > Označit jako vyřešené.

Přechod do režimu offline

Během ostatních aktivit souvisejících s přenosem souborů může být užitečné přejít do režimu offline a zabránit tak přístupu k úložišti. Aplikace Dreamweaver se znovu připojí k úložišti SVN, jakmile vyvoláte aktivitu, která připojení vyžaduje (získání nejnovějších verzí, potvrzení apod.).

  1. Ujistěte se, že máte správně nastavené připojení SVN.

  2. Zobrazte lokální verze souborů SVN na panelu Soubory vybráním volby Lokální zobrazení v místní nabídce Zobrazit. (Pracujete-li s rozbaleným panelem Soubory, Lokální zobrazení je použito automaticky.)

  3. Klikněte pravým tlačítkem (Windows) nebo klikněte se stisknutou klávesou Ctrl (Macintosh) na libovolný soubor nebo složku na panelu Soubory a vyberte možnosti Správa verzí > Režim offline.

Vyčištění lokálního místa SVN

Tento příkaz umožňuje odstraňovat zámky souborů, abyste mohli pokračovat v nedokončených operacích. Tento příkaz byste měli použít k odstranění starých zámků, pokud obdržíte chyby „pracovní kopie uzamknuta“.

  1. Ujistěte se, že máte správně nastavené připojení SVN.

  2. Zobrazte lokální verze souborů SVN na panelu Soubory vybráním volby Lokální zobrazení v místní nabídce Zobrazit. (Pracujete-li s rozbaleným panelem Soubory, Lokální zobrazení je použito automaticky.)

  3. Klikněte pravým tlačítkem (Windows) nebo klikněte se stisknutou klávesou Ctrl (Macintosh) na soubor, který chcete vyčistit, a vyberte možnosti Správa verzí > Vyčistit.

Informace o přesouvání souborů a složek na webových místech řízených systémem Subversion

Pokud přesunete lokální verzi souboru nebo složky na webovém místě řízeném systémem Subversion, můžete tak způsobit problémy jiným uživatelům, kteří provádí synchronizaci s úložištěm SVN. Přesunete-li například soubor lokálně a po několik následujících hodin jej nepotvrdíte v úložišti, jiný uživatel se může pokusit získat nejnovější verzi souboru z jeho starého umístění. Z tohoto důvodu byste měli soubory vždy potvrzovat na serveru SVN ihned poté, co je lokálně přesunete.

Soubory a složky zůstávají na serveru SVN, dokud je ručně neodstraníte. I když tedy přesunete soubor do jiné lokální složky a potvrdíte ho, stará verze souboru zůstane na serveru v předchozím umístění. Možným komplikacím zabráníte tím, že budete odstraňovat staré kopie přesunutých souborů a složek.

Při lokálním přesunu souboru a jeho následném potvrzení na serveru SVN dochází ke ztrátě historie verzí souboru.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online