Exportujte a importujte editovatelný obsah XML v aplikaci Dreamweaver. Naučte se exportovat obsah založený na předloze z jednoho webu na druhý.

Dokument založený na předloze si můžete představit tak, že obsahuje data, představovaná páry název-hodnota. Každý pár se skládá z názvu upravitelné oblasti a obsahu takové oblasti.

Dvojice název-hodnota lze exportovat do souboru XML, a pracovat tak s daty mimo aplikaci Dreamweaver (např. v editoru XML, v textovém editoru či v databázové aplikaci). Naopak pokud máte dokument XML, který je strukturován správně, můžete z něj importovat data do dokumentu založeného na předloze aplikace Dreamweaver.

Export upravitelných oblastí dokumentu jako XML

  1. Otevřete dokument založený na předloze, který obsahuje upravitelné oblasti.
  2. Vyberte volbu Soubor > Exportovat > Data předlohy jako XML.
  3. Vyberte jednu z voleb Notace:
    • Pokud předloha obsahuje opakované oblasti nebo parametry předlohy, vyberte volbu Použít standardní tagy XML aplikace Dreamweaver.

    • Pokud předloha neobsahuje opakované oblasti ani parametry předlohy, vyberte volbu Použít názvy upravitelných oblastí jako tagy XML.

  4. Klikněte na tlačítko OK.
  5. V dialogovém okně, které se objeví, vyberte umístění složky, zadejte název souboru XML a pak klepněte na tlačítko Uložit.

    Vytvoří se soubor XML, který obsahuje materiál z parametrů dokumentu a upravitelných oblastí, včetně upravitelných oblastí uvnitř opakovaných oblastí nebo volitelných oblastí. Tento soubor XML obsahuje název původní předlohy a název a obsah každé oblasti předlohy.

    Poznámka:

    Obsah v neupravitelných oblastech se do souboru XML neexportuje.

Import obsahu XML

  1. Vyberte volbu Soubor > Import > Importovat XML do předlohy.
  2. Vyberte soubor XML a klepněte na tlačítko Otevřít.

    Aplikace Dreamweaver vytvoří nový dokument založený na předloze určené v souboru XML. Vyplní obsah každé upravitelné oblasti v tomto dokumentu pomocí dat ze souboru XML. Výsledný dokument se objeví v novém okně dokumentu.

    Poznámka:

    Pokud váš soubor XML není nastaven přesně tak, jak očekává aplikace Dreamweaver, nebude možné importovat data. Jedním z řešení tohoto problému je exportovat z aplikace Dreamweaver prázdný soubor XML, a získáte tak soubor XML se správnou strukturou. Pak zkopírujte data z vašeho původního souboru XML do tohoto exportovaného souboru XML. Výsledkem je soubor XML se správnou strukturou, který obsahuje správná data a je připravený k importu.

Export webu bez značek předlohy

Můžete exportovat dokumenty založené na předloze z jednoho webového místa do jiného webového místa bez zahrnutí značek předlohy.

  1. Vyberte možnost Nástroje > Předlohy > Exportovat bez značek.

  2. V poli Složka zadejte cestu do složky, do které chcete soubor exportovat, nebo klepněte na tlačítko Procházet a vyberte složku.

    Poznámka:

    Musíte vybrat složku, která je mimo aktuální webové místo.

  3. Pokud chcete uložit XML verzi exportovaných dokumentů založených na předloze, vyberte volbu Zachovat soubory dat předlohy.
  4. Pokud chcete aktualizovat změny ve dříve exportovaných souborech, vyberte volbu Vyjmout pouze změněné soubory a klikněte na tlačítko OK.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online