Získejte další informace o tom, jak můžete vyčistit kód v aplikaci Dreamweaver, zkontrolovat kompatibilitu prohlížeče, ověřit dokumenty XML a vytvořit kompatibilní stránky XHTML.

Vyčištění kódu

Podle potřeby můžete automaticky odstraňovat prázdné tagy, kombinovat vnořené tagy font a i jinak zlepšovat neuspořádaný nebo nečitelný kód HTML nebo XHTML.

Informace, jak vyčistit kód HTML vygenerovaný z dokumentu aplikace Microsoft Word, naleznete v tématu Otevření a úpravy existujících dokumentů.

  1. V otevřeném dokumentu vyberte možnost Nástroje > Vyčistit HTML.

  2. V dialogovém okně, které se objeví, vyberte některou z voleb a klepněte na tlačítko OK.

    Poznámka:

    V závislosti na velikosti dokumentu a počtu vybraných voleb, může dokončení vyčištění zabrat několik vteřin.

    Odstranit prázdné kontejnerové tagy

    Odstraní všechny tagy, které nemají mezi sebou žádný obsah. Například <b></b><font color="#FF0000"></font> jsou prázdné tagy, ale tag <b> v případě <b>nějaký text</b> prázdný není.

    Odstranit přebytečné vnořené tagy

    Odstraní všechny přebytečné instance tagu. Například v kódu <b>Tohle je to, co jsem <b>opravdu</b> chtěl říci</b>, jsou tagy b obklopující slovo opravdu nadbytečné a budou smazány.

    Odstranit komentáře HTML nevytvořené v aplikaci Dreamweaver

    Odstraní veškeré komentáře, které nebyly vloženy pomocí aplikace Dreamweaver. Například <!‑‑začátek základního textu--> bude odstraněn, ale <!‑‑TemplateBeginEditable name="titul dokumentu"‑‑> nebude, protože je to poznámka aplikace Dreamweaver, která označuje začátek editovatelné oblasti v předloze.

    Odstranit speciální značky aplikace Dreamweaver

    Odstraní komentáře, které aplikace Dreamweaver přidává do kódu, aby umožnila dokumentům automatickou aktualizaci, když jsou aktualizovány položky předloh a knihoven. Pokud vyberete tuto volbu při čištění kódu v dokumentu založeném na předloze, dokument bude od předlohy odpojen. Více informací viz část Odpojení dokumentu od předlohy.

    Odstranit určité tagy

    Odstraní tagy zadané v sousedním textovém rámečku. Použijte tuto volbu k odstranění vlastních tagů vložených jinými vizuálními editory a jiných tagů, které nechcete, aby se objevovaly ve stránce (například blink). Oddělte vícenásobné tagy čárkami (například font,blink).

    Kombinovat vnořené tagy <font>, kde je to možné

    Sloučí dva nebo více tagů font, když nastavují stejný rozsah textu. Například <font size="7"><font color="#FF0000">velký červený</font></font> se změní na <font size="7" color="#FF0000">velký červený</font>.

    Po dokončení zobrazit zprávu

    Zobrazí po vyčištění výstražné okno s podrobnostmi o změnách, které byly v dokumentu provedeny.

Kontrola vyvážení tagů a závorek

Můžete provést kontrolu, abyste se ujistili, zda jsou tagy, závorky (( )), složené závorky ({ }) a hranaté závorky ([ ]) ve stránce vyvážené. Vyváženost znamená, že každý počáteční tag, závorka, složená závorka nebo lomená závorka má také odpovídající zavírací závorku a naopak.

Kontrola vyváženosti tagů

  1. Otevřete dokument v zobrazení Kód.
  2. Umístěte textový kurzor do vnořeného kódu, který chcete zkontrolovat.
  3. Vyberte volbu Úpravy > Vybrat rodičovský tag.

    V kódu se vyberou odpovídající obklopující tagy (a jejich obsah). Pokud budete dále vybírat možnost Úpravy > Vybrat rodičovský tag a tagy budou vyvážené, aplikace Dreamweaver nakonec vybere zcela vnější tagy html/html.

Kontrola vyváženosti kulatých, složených nebo hranatých závorek

  1. Otevřete dokument v zobrazení Kód.
  2. Umístěte textový kurzor do kódu, který chcete zkontrolovat.
  3. Vyberte možnost Úpravy > Kód > Vyvážit závorky.

    Vybere se veškerý kód mezi kulatými, složenými nebo hranatými závorkami. Zvolení možnosti Úpravy > Kód > Vyvážit závorky znovu vybere veškerý kód mezi kulatými, složenými nebo hranatými závorkami, které uzavírají nový výběr.

Kontrola kompatibility s prohlížečem

Funkce Kontrola kompatibility s prohlížečem vám pomůže najít kombinace HTML a CSS, které mohou způsobit problémy při vykreslování v prohlížeči. Tato funkce také testuje kód ve vašich dokumentech a hledá vlastnosti nebo hodnoty CSS, které cílové prohlížeče nepodporují.

Ověřování dokumentů XML

Můžete nastavit předvolby pro nástroj Ověření, konkrétní problémy, které by mělo Ověření kontrolovat, a typy chyb, o kterých by mělo Ověření podat zprávu.

  1. Proveďte jeden z následujících úkonů:
    • Pro soubory XML nebo XHTML vyberte volbu Soubor > Ověřit > Jako XML.

    • Záložka Ověření v panelu Výsledky zobrazí zprávu „Žádné chyby nebo varování“ nebo seznam chyb syntaxe, které funkce Ověření našla.

  2. Poklepejte na chybové hlášení, abyste zvýraznili chybu v dokumentu.
  3. Chcete-li uložit zprávu jako XML soubor, klepněte na tlačítko Uložit zprávu.
  4. Chcete-li zobrazit zprávu v primárním prohlížeči (který vám umožní zprávu vytisknout), klepněte na tlačítko Procházet zprávu.

Ověření dokumentů pomocí nástroje Ověření platnosti W3C

Aplikace Dreamweaver pomáhá při vytváření webových stránek kompatibilních se standardy díky integrované podpoře nástroje Ověření platnosti W3C. Nástroj Ověření platnosti W3C slouží k ověření dokumentů HTML a XML, zda vyhovují standardům HTML, XHTML nebo XML. Ověřit můžete otevřené dokumenty i soubory odeslané na živý server.

K opravě chyb v souboru použijte hlášení vygenerované po ověření.

Poznámka:

V předvolbách aplikace Dreamweaver můžete určit analyzátor, který se má používat k ověření dokumentů. Tato předvolba slouží jako záložní nastavení pro případ, kdy není automaticky zjištěn typ DOCTYPE.

Ověření otevřeného dokumentu

  1. Panel Ověření můžete otevřít výběrem možností Okno > Výsledky > Ověření. Na tomto panelu naleznete výsledky ověření.

  2. Vyberte možnost Soubor > Ověřit > Aktuální dokument (W3C).

Ověření živého dokumentu

U živých dokumentů ověřuje aplikace Dreamweaver kód přijatý prohlížečem. Tento kód se zobrazí po klepnutí pravým tlačítkem myši do prohlížeče a výběru možnosti zobrazení zdrojového kódu. Ověřování živých dokumentů je užitečné především při ověřování dynamických stránek pomocí PHP, JSP apod.

Možnost Ověřit živý dokument je aktivní, pouze pokud adresa URL ověřované stránky začíná textem http.

  1. Panel Ověření můžete otevřít výběrem možností Okno > Výsledky > Ověření. Na tomto panelu naleznete výsledky ověření.

  2. Klikněte na možnost Živé zobrazení.

  3. Vyberte možnost Soubor > Ověřit > Živý dokument (W3C).

U živých dokumentů se po poklepání na chybu na panelu ověření W3C otevře samostatné okno. V okně se zobrazí kód generovaný prohlížečem a řádek s chybou se zvýrazní.

Přizpůsobení nastavení ověřování

  1. Panel Ověření můžete otevřít výběrem možností Okno > Výsledky > Ověření.

  2. Na panelu Ověření pomocí služby W3C klepněte na ikonu Ověření pomocí služby W3C (Spustit). Vyberte položku Nastavení.

  3. Pokud nebyl DOCTYPE výslovně pro daný dokument určen, vyberte DOCTYPE, který chcete ověřit.

  4. Pokud nechcete, aby se zobrazovaly chyby a varování, zrušte výběr těchto možností.

  5. Klepněte na možnost Spravovat, chcete-li odstranit všechna varování nebo chyby, které jste skryli pomocí panelu Ověřování pomocí služby W3C. Pokud varování a chyby odstraníte, nebudou se zobrazovat, i když vyberete možnost Zobrazit vše na panelu Ověřování pomocí služby W3C.

  6. Pokud nechcete na začátku ověřování otevřít dialogové okno s oznámení ověření platnosti službou W3C, vyberte možnost „Dialog oznámení o ověření platnosti službou W3C příště nezobrazovat“.

Práce se zprávami o ověření

Po dokončení ověření se na panelu Ověřování pomocí služby W3C zobrazí zprávy o ověření.

  • Chcete-li zobrazit další informace o chybě nebo varování, vyberte chybu/varování na panelu Ověřování pomocí služby W3C. Klepněte na možnost Více informací.

  • Chcete-li uložit zprávu jako soubor XML, klikněte na tlačítko Uložit zprávu.

  • Chcete-li zobrazit celou zprávu ve formátu HTML, klepněte na tlačítko Procházet zprávu. Zpráva HTML nabízí úplný seznam chyb a varování a jejich přehled.

  • Chcete-li přejít do umístění v kódu, které obsahuje chybu, vyberte chybu na panelu Ověřování pomocí služby W3C. Klepněte na tlačítko Možnosti a vyberte položku Jít na řádek.

  • Chcete-li chyby/varování skrýt, vyberte chybu/varování. Klepněte na tlačítko Možnosti a vyberte položku Skrýt chybu.

  • Chcete-li zobrazit všechny chyby a varování včetně skrytých chyb, klepněte na tlačítko Možnosti. Vyberte možnost Zobrazit vše. Žádné skryté chyby a varování, které jste odstranili v dialogu Předvolby, nebudou uvedeny.

  • Chcete-li všechny výsledky na panelu Ověřování pomocí služby W3C vymazat, klepněte na tlačítko Možnosti. Vyberte možnost Vymazat výsledky.

Nastavení předvoleb Ověření platnosti

Aplikace Dreamweaver kromě standardního nástroje Ověření platnosti W3C podporuje také externí nástroje pro ověření platnosti kódu instalované jako rozšíření. Jakmile nainstalujete rozšíření pro externí ověřování, aplikace Dreamweaver uvede seznam svých předvoleb v kategorii Ověření platnosti W3C v dialogovém okně Předvolby.

  1. Vyberte možnost Úpravy > Předvolby (systém Windows) nebo Dreamweaver > Předvolby (systém Macintosh).
  2. Ze seznamu kategorií na levé straně vyberte možnost Ověření platnosti W3C.

  3. Vyberte knihovny tagů, proti kterým se má ověřovat.

    Nelze vybrat několik verzí stejné knihovny tagů nebo jazyka. Například v případě, že vyberete jazyk HTML 4.01, nelze vybrat také jazyk HTML 5. Vyberte nejstarší verzi, kterou chcete použít k ověření. Pokud třeba dokument obsahuje platný kód HTML 4.01, bude se také jednat o platný kód HTML 5.

  4. Vyberte možnosti Zobrazení pro typy chyb a varování, které chcete zahrnout ve zprávě funkce Ověření.
  5. Kliknutím na tlačítko Použít potvrďte změny a kliknutím na tlačítko Zavřít zavřete dialogové okno Předvolby.

Změny stránek vyhovujících XHTML

Když vytváříte stránku, můžete ji vytvořit tak, aby vyhovovala XHTML. Můžete také převést stávající dokument HTML na dokument vyhovující XHTML.

Vytváření dokumentů vyhovujících XHTML

  1. Vyberte volbu Soubor > Nový.
  2. Vyberte kategorii a typ stránky, kterou chcete vytvořit.
  3. Vyberte jednu z definic typu dokumentu (DTD) XHTML z rozbalovací nabídky Typ dokumentu zcela vpravo v dialogovém okně a klepněte na tlačítko Vytvořit.

    V rozbalovací nabídce můžete například vybrat možnost „XHTML 1.0 přechodný“ nebo „XHTML 1.0 přísný“ a změnit tím dokument HTML tak, aby vyhovoval XHTML.

    Poznámka:

    Ne všechny typy dokumentů mohou být vytvořeny tak, aby vyhovovaly XHTML.

Vytváření dokumentů vyhovujících XHTML standardně

  1. Vyberte možnost Úpravy > Předvolby nebo Dreamweaver > Předvolby (systém Mac OS X) a vyberte kategorii Nový dokument.
  2. Vyberte výchozí dokument a vyberte jednu z XHTML definic typu dokumentu z rozbalovací nabídky Výchozí typ dokumentu (DTD) a klepněte na tlačítko OK.

    V rozbalovací nabídce můžete například vybrat možnost „XHTML 1.0 přechodný“ nebo „XHTML 1.0 přísný“ a změnit tím dokument HTML tak, aby vyhovoval XHTML.

Vytvoření dokumentu vyhovujícího XHTML z existujícího dokumentu HTML

  1. Otevřete dokument a proveďte jeden z následujících úkonů:

    • V případě dokumentu bez rámců vyberte volbu možnost Soubor > Převést a pak vyberte jednu z definic typu dokumentu XHTML.

      V rozbalovací nabídce můžete například vybrat možnost „XHTML 1.0 přechodný“ nebo „XHTML 1.0 přísný“ a změnit tím dokument HTML tak, aby vyhovoval XHTML.

    • V případě dokumentu s rámci vyberte rámec, vyberte možnost Soubor > Převést a nakonec vyberte jednu z definic typu dokumentu XHTML.

  2. Pokud budete chtít převést celý dokument, opakujte tento krok pro každý rámec a dokument sady rámců.

Poznámka:

Nelze převést instanci předlohy, protože ta musí být ve stejném jazyce jako předloha, ze které je odvozena. Například dokument odvozený od předlohy XHTML bude vždycky v XHTML a dokument odvozený od předlohy HTML nevyhovující XHTML bude vždycky HTML a nelze ho převést na XHTML ani žádný jiný jazyk.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online