Tento článek popisuje, jak v aplikaci Dreamweaver CC spravovat soubory i zdrojový kód pomocí systému Git.

Aplikace Dreamweaver CC podporuje open source distribuovaný systém pro řízení verzí Git, s pomocí kterého můžete spravovat zdrojový kód. Díky integraci systému Git s aplikací Dreamweaver můžete pracovat nezávisle na svém kódu prakticky odkudkoli, přičemž provedené změny můžete později sloučit v centrálním úložišti Git. Systém Git také uchovává informace o všech změnách provedených v daném souboru, díky čemuž se můžete kdykoliv vrátit k předchozí verzi.

Úložiště Git jsou užitečná také při týmové práci vzhledem k tomu, že systém Git umožňuje snadné vytváření a spravování větví. Například pokud jako návrhář chcete pracovat na změně návrhu webu, zatímco jiný člen týmu provádí změny podle požadavků ve stejném webu, můžete díky systému Git pracovat oba současně. V takovém případě můžete vytvořit větvení nezávisle a provést své změny v příslušném místním úložišti. Místní úložiště obsahuje celou historii všech vámi provedených změn ve zdroji. Kdykoli budete chtít, můžete provedené změny pozastavit a sloučit v centrálním úložišti. Tím zajistíte, že centrální úložiště bude vždy obsahovat nejnovější kód po obou změnách.

Následující text obsahuje informace o tom, jak začít s používáním systému Git v aplikaci Dreamweaver.

Začínáme se systémem Git v aplikaci Dreamweaver

Pokud jste novým uživatelem systému Git, musíte nejprve stáhnout klienta Git a vytvořit si účet Git. Klient Git je nezbytný v době, než začnete používat systém Git v aplikaci Dreamweaver.

Pokud již účtem Git disponujete, přihlaste se k němu. Nezapomeňte do svého počítače stáhnout klienta Git. 

Následující kroky vám pomohou začít se systémem Git v aplikaci Dreamweaver:

  1. Stáhněte si klienta Git pro váš operační systém.

  2. Ve vašem klientovi Git vytvořte účet.

    Pokud již účet Git máte, pomocí přihlašovacích údajů se přihlaste ke klientovi Git.

Doporučujeme nainstalovat klienta Git s výchozím nastavením konfigurace. Aplikace Dreamweaver poté automaticky vybere cestu ke spustitelnému souboru.

Nyní již můžete spustit aplikaci Dreamweaver a přiřadit svůj web k úložišti Git.

Panel systému Git

Aplikace Dreamweaver podporuje příkazy systému Git prostřednictvím panelu systému Git (Okna > Git). Z pozice uživatele aplikace Dreamweaver můžete pomocí tohoto panelu provádět běžné příkazy systému Git, jako jsou například příkazy Potvrdit, Odeslat, Vyžádat, Načíst a další.

Poznámka:

Tento panel si můžete v aplikaci Dreamweaver zobrazit až poté, co si do počítače stáhnete klienta systému Git.

Panel systému Git v aplikaci Dreamweaver CC
Panel systému Git v aplikaci Dreamweaver

A. Potvrdit B. Načíst všechny vzdálené servery a obnovit počítadla C. Vyžádání Git D. Odesílání Git E. Zobrazit historii úložiště F. Zobrazit historii souboru G. Vytvořit tag H. Otevřete konzoli pro bash/terminál I. Další akce J. Hledání K. Rozdíl L. Vrátit soubor 

Přiřazení webového místa k systému Git

Než bude možné začít používat systém Git v aplikaci Dreamweaver, je nutné nejprve přiřadit web aplikace Dreamweaver k úložišti Git. Úložiště Git je jako složka, kterou vytvoříte proto, aby vám pomáhala sledovat změny v souborech. V počítači můžete mít libovolný počet úložišť Git. Každé úložiště ve vašem systému je nezávislé. To znamená, že změny uložené v jednom úložišti Git nemají vliv na obsah v jiném.

Po přiřazení webové stránky k úložišti můžete buď vytvořit nové úložiště nebo klonovat úložiště stávající. Po inicializaci nebo vytvoření nového úložiště se v aktuálním pracovním adresáři vytvoří prázdné úložiště Git a v jeho složce se vytvoří soubor .gitignore.

Pokud však klonujete stávající úložiště Git, všechny soubory z vašeho nadřazeného úložiště budou naklonovány do místního systému.

Přečtěte si, jak inicializovat úložiště Git nebo vytvořit kopii úložiště.

Inicializace úložiště Git

Než začnete pracovat v aplikaci Dreamweaver s úložištěm Git, může být vhodné nejdříve vytvořit nové úložiště. Po inicializaci úložiště Git pro váš web vytvořte nové úložiště Git, kde můžete přidat soubory spojené s webem aplikace Dreamweaver.

  1. Jako uživatel aplikace Dreamweaver můžete začít buď s novým webem, nebo můžete použít existující web, který chcete přiřadit k úložišti Git. Bez ohledu na vaši volbu postupujte podle těchto pokynů a inicializujte úložiště Git.

    • Nový web aplikace Dreamweaver přiřadíte kliknutím na možnost Web > Nový web.
    • Existující web aplikace Dreamweaver přiřadíte kliknutím na možnost Web > Správa webů. V dialogovém okně Správa webů dvakrát klikněte na web, který chcete přiřadit k úložišti Git.
  2. Pokud vytváříte nový web, zadejte jeho název.

    Pokud máte složku se soubory souvisejícími s webem, přejděte do této složky v poli Místní složka webu.

    Zadejte název a umístění složky pro nový web Dreamweaver.
    Zadejte název a umístění složky pro nový web Dreamweaver.

    Pokud budete chtít přiřadit nové webové místo ke stávajícímu úložišti Git, ujistěte se, že místní složka webu odkazuje na odpovídající úložiště Git.

  3. Označte pole Přiřadit úložiště Git k tomuto webu. Poté vyberte možnost Inicializovat jako úložiště Git.

    Inicializace úložiště Git v aplikaci Dreamweaver
    Inicializace úložiště Git pro váš nový web Dreamweaver
  4. Klikněte na tlačítko Uložit.

    Všimněte si, že soubory z místní složky jsou nyní viditelné na panelu Soubory (Zobrazení Git). Soubory jsou v nesledovaném stavu. To znamená, že tyto soubory nejsou ještě potvrzeny v úložišti Git.

    Můžete pokračovat v práci se soubory a potvrdit je později, nebo můžete otevřít panel Git (Okno > Git) a soubory v úložišti potvrdit. Postup potvrzení souborů v úložišti Git naleznete v tématu Sledování a potvrzení změn.

Klonování stávajícího úložiště

Pokud již pracujete s existujícím úložištěm Git hostovaným na serveru Github, Bitbucket nebo v jiné oblíbené službě pro hostování, můžete v aplikaci Dreamweaver následujícím postupem vytvořit kopii úložiště. Při klonování stávajícího úložiště vytváříte kopii cílového úložiště v místním systému.

  1. Klikněte na možnost Web > Nový web.

  2. V dialogovém okně Nastavení webu označte pole Přiřadit úložiště Git k tomuto webovému místu. Následně vyberte možnost Klonovat stávající úložiště Git pomocí adresy URL.

  3. Zadejte adresu URL úložiště, které chcete klonovat.

    Ujistěte se, že zadaná adresa URL cílového úložiště ve formátu HTTPS je platná. Pokud budete chtít otestovat, zda je adresa URL platná, klikněte na tlačítko Test v tomto dialogovém okně. Neplatná adresa URL způsobí chybu při klonování a provádění akce, jako je Přenesení nebo Vyžádání Git.

    Klonování úložiště Git z aplikace Dreamweaver
    Klonování úložiště Git z aplikace Dreamweaver

    Poznámka:

    Klonování adresy URL pomocí klíče SSH s heslem není v současné době v aplikaci Dreamweaver podporováno. Pole uživatelské jméno a heslo nejsou dostupná.

  4. Pokud chcete uložit zadané přihlašovací údaje, označte pole Uložit přihlašovací údaje. Tato akce vám umožní vyhnout se potřebě zadávat přihlašovací údaje pokaždé, když používáte vzdálené akce, jako je Odesílání Git nebo Vyžádání Git.

  5. Klikněte na tlačítko Uložit.

    Po naklonování úložiště se vytvoří místní kopie původního úložiště. Místní soubory můžete prohlížet a upravovat v aplikaci Dreamweaver.

    Kopie původního úložiště, které je klonováno, se zobrazí v pravém horním rohu na panelu Git > Původní.

    Povšimněte si původního úložiště na panelu Git.
    Povšimněte si původního úložiště na panelu Git.

Používání systému Git pro správu verzí

Po přiřazení webu Dreamweaver k úložišti Git můžete tyto soubory sledovat v systému Git skrze panel Soubory (zobrazení Git). Systém Git kategorizuje soubory ve vašem místním úložišti následovně:

  • Nesledované soubory: soubory, které jste zatím k úložišti Git ani jednou nepřipojili. Po inicializaci úložiště Git budou soubory považované za nesledované, dokud je nepotvrdíte.
  • Neupravené soubory: soubory, které nebyly upraveny.
  • Upravené soubory: soubory, které byly upraveny.
  • Připravené soubory: soubory, které byly upraveny a připraveny na potvrzení.

Pomocí systému Git můžete sledovat úpravy prováděné na souborech. Po úpravě souborů v místním systému se upravené soubory na panelu Soubory zobrazí jinou barvou. Po dvojitém kliknutí a otevření souboru v zobrazení kódu uvidíte také značku u řádků, které byly upraveny. Poté můžete pokračovat a potvrzením upravených souborů v systému Git synchronizovat změny.

Po potvrzení souborů vám úložiště Git umožní vytvořit zprávu protokolu ke každému potvrzenému souboru a prohlédnout si změny za použití funkce „diff“. Podle potřeby můžete také zobrazit historii verzí každého souboru, stejně jako celého úložiště.

Přečtěte si pokyny ke sledování úprav v aplikaci Dreamweaver a potvrzení změn v systému Git.

Sledování úprav v systému Git

Na panelu Soubory v aplikaci Dreamweaver se můžete povšimnout ikony Git, díky které lze přepínat mezi zobrazení FTP a zobrazením Git. Kliknutím na ikonu Git přejdete na zobrazení Git.

Pokud jste inicializovali úložiště Git a soubory zatím nepotvrdili, soubory budou i nadále nesledované. Pokud jste však soubory po inicializaci úložiště potvrdili, systém Git soubory rozezná.

Zobrazení všech nesledovaných souborů na panelu Soubory
Zobrazení všech nesledovaných souborů na panelu Soubory
Soubory po potvrzení v úložišti Git
Zobrazení potvrzených souborů, které systém Git rozeznal

V případě naklonování všech souborů z jiného úložiště je úložiště Git opět rozezná.

Pokud soubor upravíte a klikněte na tlačítko Uložit, upravené soubory se na panelu Soubory zobrazí jinou barvou. Dvojitým kliknutím na upravený soubor zobrazíte konkrétní změny v zobrazení kódu.

Všimněte si symbolu v zobrazení kódu
Všimněte si symbolu v zobrazení kódu

Řádky, u kterých byly změny provedeny, jsou označeny symbolem. Zelená značka označuje nový přidaný kód. Žlutá značka označuje upravený kód a bílá značka v červeném označuje řádek kódu, který byl odstraněn.

Pokud budete chtít vidět změny v kódu v aplikaci Dreamweaver, stačí si jednoduše prohlédnout značku
Pokud budete chtít vidět změny v kódu, stačí si jednoduše prohlédnout značku

Po kliknutí na žlutou značku se v aplikaci zobrazí odstraněný řádek kódu červeně a kód, který jste nově přidali, zeleně.

Všimněte si symbolu R v levém horním rohu odstraněného řádku kódu. Kliknutím na tento symbol R přidáte odstraněný kód zpět do souboru.

Kliknutím na symbol R přidáte odstraněný kód do systému Git aplikace Dreamweaver
Kliknutím na symbol R přidáte odstraněný kód

Před potvrzením změn v úložišti Git můžete pomocí značky zobrazit rozdíl a zkontrolovat provedené změny.

Zobrazení rozdílů u upravených souborů

Při otevření panelu systému Git uvidíte seznam upravených souborů. Kliknutím na soubor v seznamu můžete zobrazit změny provedené v souboru od předchozího potvrzení (funkce Diff). Rozdíly v souboru zobrazíte pomocí jedné z následujících funkcí panelu Git:

  • Kliknutím na jednotlivé soubory uvidíte provedené změny. Červené zvýraznění označuje předchozí verzi, zatímco zelené zvýraznění označuje změnu, kterou jste právě provedli.
  • Vyberte soubor, u kterého chcete zobrazit rozdíly. Klikněte na ikonu (ikona Diff). Otevře se dialogové okno Git Diff, ve kterém jsou změny zvýrazněny červeně a zeleně.
Zobrazení rozdílů u upravených souborů
Zobrazení rozdílů u upravených souborů

Potvrzení změn

Pokud budete chtít zaznamenat všechny změny v místním úložišti, je třeba potvrdit změny provedené v rámci souborů. Postup potvrzení změn v systému Git:
  1. Na panelu Git vyberte soubor nebo soubory, které chcete potvrdit.

    Postup potvrzení změn v místním úložišti Git
    Postup potvrzení změn v místním úložišti Git
  2. Klikněte na ikonu (ikona Potvrdit).

    Po kliknutí na tlačítko Potvrdit systém zobrazí dialogové okno Potvrdit Git. V tomto dialogovém okně se zobrazují soubory, ve kterých byly provedeny změny.

    Než budete pokračovat k potvrzení souborů, můžete kliknutím na jednotlivé soubory zobrazit provedené změny.

  3. Až budete chtít soubory potvrdit, do pole zprávy zadejte zprávu o potvrzení a klikněte na tlačítko OK.

    Po potvrzení souborů dojde zároveň k vymazání souborů z panelu Git.

    Uložení změn v systému Git
    Uložení změn v systému Git

Vrácení změn

Pokud jste již změny potvrdili a chcete se vrátit k předchozí verzi souboru, postupujte následovně:

  1. Na panelu Git vyberte soubor nebo soubory, které chcete vrátit.

  2. Klikněte na ikonu vrstev na panelu Git a vyberte možnost Vrátit změny od posledního potvrzení.

    V místním úložišti se obnoví předchozí verze těchto souborů. Obnovené soubory můžete zobrazit na panelu Soubory.

    Vrácení změn po potvrzení souborů
    Vrácení změn po potvrzení souborů

    Poznámka:

    Pokud budete chtít vrátit soubor po jeho potvrzení, je třeba soubor potvrdit alespoň dvakrát.

  3. Budete-li chtít vrátit změny před potvrzením, postupujte následovně:

    Pokud si přejete zachovat potvrzenou verzi souboru před potvrzením souboru, postupujte takto:

    1. Otevřete panel Git.
    2. Vyberte soubor, který chcete zachovat, a klikněte na ikonu Obnovit.
    3. V dialogovém okně s potvrzením klikněte na tlačítko OK.

    Soubor, který jste vybrali, se ze seznamu upravených souborů odstraní a obnoví se předchozí verze souboru.

    Vrácení změn v souboru před potvrzením v systému Git
    Vrácení změn v souboru před jejich potvrzením

Vytvoření tagů

Při každém potvrzení změn v systému Git můžete vytvořit tagy. Tyto tagy označují důležité potvrzení souborů. Například vrácení kvůli rozsáhlé změně vyžadované vaším klientem. Tagy slouží jako ukazatel na konkrétní potvrzení.

  1. Pokud budete chtít tyto tagy vytvořit, klikněte na panelu Git na ikonu (ikona Vytvořit tag).

  2. V dialogovém okně Vytvořit tag zadejte název tagu. Klikněte na tlačítko OK.

    Vytvoření tagu pro potvrzení změn
    Vytvoření tagu pro potvrzení změn

    Tag, který jste vytvořili, je spojen s vaším potvrzením.

    Pokud vytvoříte tag až po potvrzení, tag bude automaticky přiřazen k nejnovějšímu potvrzení.

Zobrazení historie souboru

Při každém potvrzení soubor v úložišti Git můžete zobrazit historii souboru společně s podrobnostmi o potvrzení. Tato funkce vám pomáhá určit důležitá potvrzení a tagy přiřazené k potvrzení.

  1. V panelu Git proveďte jeden z následujících úkonů:
  • Vyberte požadovaný soubor a klikněte na ikonu (ikona Zobrazit historii souboru).
  • Klikněte pravým tlačítkem na soubor v panelu Soubory a vyberte možnost Historie souboru.

Systém pro vybraný soubor zobrazí jeho historii v systému Git. Ve stejném dialogovém okně můžete také zobrazit podrobnosti o potvrzení tohoto souboru.

Zobrazení historie souboru v systému Git
Zobrazení historie souboru v systému Git

Zobrazení historie v úložišti

Společně s prohlížením historie souboru v systému Git můžete také zobrazit změny provedené na úrovni úložiště. Stejně tak můžete zobrazit všechny provedené změny na úrovni úložiště. Historii úložiště můžete zobrazit následovně:

  1. Na panelu úložiště Git klikněte na ikonu Zobrazit historii úložiště. Systém zobrazí historii v úložišti Git společně s podrobnostmi o každém z potvrzení.

  2. Můžete si tak prohlédnout zprávu o potvrzení, datum a čas potvrzení souborů, tagy přiřazené k potvrzení a podrobnosti o uživateli, který soubory potvrdil.

  3. Historie úložiště obvykle zahrnuje seznam souborů, které byly potvrzeny na úrovni úložiště. Kliknutím na každý ze souborů můžete zobrazit historii změn na úrovni souborů.

Využívání systému Git ke spolupráci

Jednou z nejvíce odlišných funkcí systému Git jsou větve. Na rozdíl od většiny systémů správy verzí mohou být větve systému Git považovány za nezávislé řádky všech vašich přiřazených souborů nebo kódů. Ve výchozím nastavení má vaše úložiště jednu větev označenu jako „hlavní“. Hlavní větev je základní nebo definitivní větev. Z této hlavní větve můžete vytvářet další větve a dále je upravovat.

Když vytváříte kopii nadřazené větve, můžete také vytvořit větev z jiné větve. To umožňuje pracovat nezávisle v obou větvích stejného úložiště Git. Například je možné v jedné větvi pracovat na nové funkci pro web a provádět změny ve větvi jiné.

Úložiště Git umožňuje také sloučit větve v případě, že chcete začlenit změny z aktuální větve do cílové větve. Po sloučení dvou větví budou obě větve i nadále samostatně existovat. To znamená, že můžete pokračovat v práci u nadřazené i cílové větve.

Když větší počet vývojářů a návrhářů pracuje v aplikaci Dreamweaver na společném webovém místě, každý z nich si může vytvořit z hlavní větve svou vlastní větev a provádět v ní změny nezávisle na ostatních. V případě potřeby pak mohou snadno sloučit své změny s jinou větví a pak opět pracovat ve svých vlastních větvích.

Další informace o vytváření a správě větví v systému Git naleznete v následujících tématech:

Vytváření větví v systému Git

  1. Na panelu Soubory vyberte rozevírací seznam obsahující všechny větve.

  2. Klikněte na tlačítko Spravovat větve.

    Vytvoření větve v systému Git
    Vytvoření větve v systému Git
  3. V levém spodním rohu dialogového okna Správa větví klikněte na znaménko +.

    Ve spodní části dialogového okna Správa větví klikněte na znaménko „plus“.
    Ve spodní části dialogového okna Správa větví klikněte na znaménko „plus“.
  4. V dialogovém okně Vytvořit novou větev vyberte původní větev, ze které chcete vytvořit kopii.

    Pokud se jedná o první větev, kterou vytváříte, bude tato původní větev vaší hlavní větví.

    Výběr typu větve
    Výběr typu větve

  5. V poli Název větve zadejte název nové větve.

  6. Klikněte na tlačítko OK.

Sloučení větví

  1. Na panelu Soubory vyberte rozevírací seznam obsahující všechny vaše větve.

  2. Klikněte na tlačítko Spravovat větve. V dialogovém okně Správa větví vyberte větev, kterou chcete sloučit.

  3. Ve spodní části dialogového okna klikněte na ikonu (ikona Sloučit větve).

  4. V dialogovém okně Sloučit větve vyberte cílovou větev. Tato větev představuje cílové úložiště, se kterým chcete svou větev sloučit.

    Případně můžete také zadat zprávu spojenou s tímto sloučením.

  5. Kliknutím na tlačítko OK sloučíte větev s cílovou větví.

    Sloučení větví v systému Git
    Sloučení větví v systému Git

    Pokud jsou změny v souboru přicházející z jednoho potvrzení v konfliktu se změnami z jiné větve, proces sloučení se pozastaví. Systém zobrazí zprávu o konfliktu společně se soubory, které jsou jeho příčinou.

    Panel Git také obsahuje informace o souborech, u kterých došlo ke konfliktu. Všimněte si ikony, která označuje, že došlo ke konfliktu.

    Panel Git se soubory, u kterých během sloučení došlo ke konfliktu
    Panel Git se soubory, u kterých během sloučení došlo ke konfliktu

    Než bude možné ve sloučení pokračovat, musíte vyřešit konflikt pomocí možnosti Přeskládat nebo pokračováním ve sloučení pomocí příkazu „no-ff“.

  6. Pokud se během slučování setkáte s konfliktem, zvolte jednu z následujících možností:

    • Použít přeskládání: jestliže se rozhodnete vybrat možnost Přeskládat, vaše stávající změny se aplikují na konflikty v cílové větvi. Po výběru přeskládání a kliknutí na tlačítko OK otevřete panel Git a prohlédněte si soubory, které zatím nejsou potvrzeny. Poté můžete buď přeskládání zrušit, nebo je spustit znovu. Po zrušení přeskládání se přeskládání zastaví a v cílové větvi se neprovedou žádné změny. Po novém spuštění přeskládání se provedené změny u konfliktů v cílové větvi vynechají.
    • Vytvořit potvrzení pro sloučení i v případě, že sloučení proběhne s příkazem „--ff“: potvrzení je možné dokončit i navzdory konfliktům mezi vaší větví a větví cílovou. V takovém případě lze sloučení vynutit a tak změny v cílové větvi přepsat změnami z vaší větve.

    Další informace o přeskládání v systému Git naleznete v tématu Přeskládání systému Git.

Práce se vzdálenými úložišti

Vzdálená úložiště v systému Git představují verze projektu, které jsou hostovány v jiné síti. Přístup ke vzdáleným úložištím získáte tak, že vytvoříte spojení s těmito úložišti. V závislosti na přístupových právech uvedených ve vzdáleném úložišti budete mít buď přístup jen pro čtení, nebo přístup s povolením zápisu.

Pokud pracujete v týmu, vzdálené úložiště vám pomůže odesílat a získávat data z jiných úložišť. Na panelu Git v aplikaci Dreamweaver můžete vytvořit vzdálené připojení nebo využívat nejrůznější příkazy systému Git, jako je např. Přenesení, Odesílání Git, Vyžádání Git nebo Vzdálené obnovení.

Přečtěte si následující postupy, které popisují vytváření a správu vzdálených úložišť.

Přidání vzdáleného úložiště

Podle potřeby můžete přidat vzdálené úložiště pro sdílení souborů, sledovat průběh práce nebo získat přístup k souborům z projektu uloženým v jiné síti. Přidáním vzdáleného úložiště navazujete vzdálené spojení s cílovým úložištěm. Aplikace Dreamweaver umožňuje vytvářet vzdálené úložiště na panelu Git.

Než přidáte vzdálené úložiště, ujistěte se, že toto jiné úložiště má povoleno nastavení veřejného přístup.

  1. Na panelu Git klikněte na možnost Vytvořit vzdálené připojení.

  2. Zadejte název vzdáleného úložiště.

  3. Zadejte adresu URL a přihlašovací údaje pro vzdálené úložiště.

    Abyste měli jistotu, že jste při zadávání vzdáleného úložiště zadali platnou adresu URL, klikněte po zadání adresy na tlačítko Test. Po klepnutí na tlačítko Test se ověří platnost adresy URL.

    Tento test nelze použít pro ověřování přihlašovacích údajů.

    Přidání vzdáleného úložiště v aplikaci Dreamweaver
    Přidání vzdáleného úložiště

    Pozor:

    Pokud nezadáte platnou adresu URL nebo přihlašovací údaje, dojde při používání příkazů, jako je Vyžádání Git, Odesílání Git, Přenesení atd., k chybám.

  4. Klikněte na tlačítko OK.

    Po přidání vzdáleného úložiště se toto úložiště přidá do rozevíracího seznamu v horní části panelu Git. Můžete také zobrazit další ikony pro používání příkazů Odesílání Git, Vyžádání Git, Přenesení ze vzdáleného úložiště a obnovení počítadel.

    Přidání vzdáleného úložiště v systému Git
    Přidání vzdáleného úložiště v systému Git

Správa vzdálených úložišť

Po přidání vzdáleného úložiště a navázání připojení můžete přenést a odesílat soubory ze vzdáleného úložiště do místního úložiště. Stejně tak můžete do vzdáleného úložiště odesílat své soubory. Před prvním použitím příkazu Odesílání Git je však nutné nejprve soubory ze vzdáleného úložiště přenést.

Nezapomeňte před odesláním souborů nejprve potvrdit všechny vaše soubory v místním úložišti. Pokud místní úložiště obsahuje připravené soubory, použití příkazu Odesílání Git proběhne neúspěšně. 

V aplikaci Dreamweaver můžete provádět následující operace Git:

Přenést vše

Kliknutím na tlačítko přenesete všechny soubory ze všech vzdálených připojení. Doporučujeme příkaz Přenést Git použít ještě před použitím příkazu Odesílání Git nebo Vyžádání Git. Tato akce pouze přenese soubory ze vzdáleného úložiště bez provedení změn v místním úložišti.

Vyžádání souborů ze vzdáleného úložiště

Vyžádání lze použít u jednoho úložiště nebo jejich skupiny. Po kliknutí na ikonu Vyžádání Git systém otevře dialogové okno Vyžádání Git s řadou možností.

  1. Kliknutím na ikonu (ikona Vyžádání Git) na panelu Git vyžádáte upravené soubory ze vzdáleného úložiště a sloučíte změny v místním úložišti.

  2. V dialogovém okně Vyžádání Git vyberte větev sledování, určete, zda chcete vyžádat změny z aktuální, nebo jiné větve, a nakonec upravte nastavení vyžádání.

    Použití příkazu Vyžádání Git ze vzdálených úložišť
    Použití příkazu Vyžádání Git ze vzdálených úložišť

  3. Standardně je vybrána možnost Výchozí sloučení. V takovém případě jsou soubory ze vzdáleného úložiště vyžádány do místního úložiště a změny se sloučí místně.

  4. Podle potřeby můžete také zvolit jednu z následujících možností:

    • Vyhnout se ručnímu slučování: tuto možnost vyberte, pokud chcete zakázat ruční sloučení souborů.
    • Sloučit bez potvrzení: tuto možnost vyberte, pokud chcete pokračovat ve sloučení ve vzdáleném úložišti i bez potvrzení připravených souborů.
    • Použít přeskládání: tato možnost slouží k použití přeskládání. Pokud se rozhodnete pro přeskládání, použijí se změny z aktuální větve a provedou se v rámci historie větve, ze které soubory vyžadujete. Historie nejnovějšího potvrzení větve se přepíše tak, aby soubory odpovídaly verzím z cílové větve, ze které vyžadujete soubory. I když je výsledkem přeskládání čistá historie větve, je nutné dbát při používání přeskládání zvýšené opatrnosti.
    • Použít částečný reset: tato možnost slouží k provedení částečného resetu nebo částečného přeskládání. Funkce Použít částečný reset je užitečná v případě, že soubory ze vzdáleného úložiště chcete vyžádat poprvé. V takovém případě vzdálené úložiště působí jako nadřazené úložiště, ze kterého místní úložiště přijme všechny provedené změny. Změny v místním úložišti však budou zachovány. Soubory, které nejsou ve vzdáleném úložišti k dispozici, ale které se nachází v místním úložišti, systém Git nerozezná. Po provedení částečného resetu se tyto soubory zobrazí jako odstraněné soubory. Pokud se rozhodnete tyto soubory v místním úložišti zachovat, změny ze vzdáleného úložiště budou ztraceny.

    Pozor:

    Jestliže budete v částečném resetu pokračovat, nerozeznané soubory budou odstraněny.

Odeslání souborů do vzdáleného úložiště

Po propojení se vzdálenými úložišti se při každé úpravě a potvrzení upravených souborů tyto změny v systému Git uloží. Ikona (Odesílání Git) na panelu Git zobrazuje počet upravených souborů. Tyto soubory lze nyní odeslat na vzdálené úložiště.

Při použití příkazu Odesílání Git se potvrzené soubory v místním úložišti odešlou na vzdálené úložiště.

Postup odeslání souborů z aplikace Dreamweaver:

  1. Na panelu Git klikněte na ikonu Odesílání Git.

    Systém otevře dialogové okno Odesílání Git. Zde můžete buď odeslat vaše potvrzené soubory do aktuální sledované větve, nebo do jiné větve, kterou sami určíte.

    Odeslání místních potvrzených souborů do vzdáleného úložiště Git
    Odeslání místních potvrzených souborů do vzdáleného úložiště Git

  2. V tomto dialogovém okně můžete také upravit nastavení odesílání. Standardně je vybrána možnost Výchozí odesílání.

  3. Vybrat ale můžete také následující možnosti:

    • Nucené odeslání: tato možnost slouží k nucenému odeslání změn do vzdáleného úložiště bez ohledu na možné konflikty.
    • Odstranit vzdálenou větev: tato možnost slouží k odstranění stávající vzdálené větve a odeslání místních souborů do vzdáleného úložiště.
  4. Volitelně můžete označením pole Odesílat tagy zajistit odeslání tagů do vzdáleného úložiště.

  5. Klikněte na tlačítko OK.

    Pokud byl zjištěn konflikt mezi lokálními změnami a změnami provedenými ve vzdáleném úložišti, doporučujeme před odesláním změn nejprve vyřešit všechny konflikty. 

    V takovém případě musíte vyžádat změny ze vzdáleného úložiště, poté vyřešit konflikty a nakonec odeslat soubory bez dalších konfliktů.

Hledání souborů na panelu Git

Pole hledání na panelu úložiště Git umožňuje vyhledat soubory podle jejich názvu. Tato možnost je zejména užitečná v případě, že máte velký počet souborů přiřazených s vaším webovým místem.

Pokud budete chtít vyhledat soubor, jednoduše zadejte jeho název do pole Hledat. Okamžitě se tak zobrazí soubory, které obsahují hledanou frázi.

Přidání souborů na seznam ignorovaných položek

Pokud nechcete, aby úložiště Git s některým souborem pracovalo, můžete tento soubor přidat do složky .gitignore. Systém Git bude poté soubory v této složce při provádění akcí, jako je potvrzení, odeslání a vyžádání, ignorovat. Nezapomeňte soubor .gitignore potvrdit ve vašem úložišti, aby i ostatní uživatelé, kteří by mohli vaše úložiště klonovat, věděli o souborech ve složce .gitignore.

Soubory do složky .gitignore přidáte na panelu Soubory v aplikaci Dreamweaver. Vyberte soubor, který chcete v systému Git ignorovat, klikněte na něj pravým tlačítkem a vyberte možnost Git > Přidat do .gitignore.

Přidání souborů do složky .gitignore
Přidání souborů do složky .gitignore

Soubory ze složky .gitignore můžete kdykoli odebrat výběrem tohoto souboru na panelu Soubory. Následně klikněte pravým tlačítkem a vyberte možnost Git > Odebrat z .gitignore.

Po úpravě tohoto souboru se ujistěte, že jste soubor .gitignore potvrdili v místním i vzdáleném úložišti.

Používání systému Git prostřednictvím příkazového řádku

V předchozích částech tohoto článku jste se naučili používat panel Git (UI) k provádění úkolů, jako je přiřazení úložiště Git k webu, vytvoření a správa vzdáleného připojení, odesílání souborů do úložiště nebo vyžádání souborů z něj. Za pomoci příkazů Git můžete také provádět tyto i jiné akce.

Při provádění úloh Git pomocí terminálu postupujte následovně:

  • Klikněte na možnost Okno > Git a poté na ikonu Otevřít konzoli pro bash/terminál.
  • Na panelu Soubory přejděte na zobrazení Git. Klikněte na ikonu Otevřít terminál Git vedle rozevíracího seznamu úložišť.

Nejběžnější příkazy Git naleznete v tématu Přehled příkazů Git

Poznámka:

Některé akce, jako je uložení do úschovny Git nebo kombinování potvrzení po odeslání, jsou v současné době možné pouze z příkazového řádku.

Při provádění určitých akcí, například při inicializaci úložiště Git z příkazového řádku se tyto akce projeví také v rozhraní aplikace Dreamweaver.

Nicméně pokud není aplikace Dreamweaver spuštěna, tak při úpravě souborů pomocí příkazového řádku se zobrazí při dalším spuštění aplikace Dreamweaver tato zpráva:

Zpráva při změně souborů pomocí CLI
Zpráva při změně souborů pomocí CLI

Nastavení předvoleb systému Git v aplikaci Dreamweaver

Díky předvolbám systému Git v aplikaci Dreamweaver můžete definovat některá nastavení pro používání systému Git v aplikaci Dreamweaver. Dialogové okno Předvolby slouží k nastavení předvoleb systému Git, jako je cesta k terminálu, nastavení časového limitu apod.

  1. Vyberte možnost Úpravy > Předvolby.

  2. V dialogovém okně Předvolby vyberte kartu Git.

  3. V dialogovém okně Předvolby Git upravte následující možnosti:

    • Cesta ke spustitelnému souboru Git: soubor .exe vašeho klienta Git. Pokud se tento spustitelný soubor nachází v jiném umístění, přejděte do složky s uloženým souborem Git.exe.
    • Výchozí časový limit pro operace Git: zadejte časový limit v sekundách pro všechny vzdálené operace Git.
    • Cesta k terminálu: úplnou cestu ke spustitelnému souboru, jehož otevřením spustíte terminál Git.
    • Argumenty příkazu: možnost připojení případných argumentů příkazu pro příkazy Git.
    Nastavení předvoleb systému Git v aplikaci Dreamweaver
    Nastavení předvoleb systému Git v aplikaci Dreamweaver

  4. Kliknutím na tlačítko Použít uložte provedené nastavení.

Poznámka:

Nové nastavení se projeví až po restartování aplikace Dreamweaver.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online