Naučte se nastavit navigaci mezi vašimi webovými stránkami. Využijte možnost propojit soubory a dokumenty, aktualizovat, měnit a zkoušet odkazy v aplikaci Dreamweaver.

Před vytvořením odkazu se ujistěte, že víte, jak pracují absolutní, k dokumentu relativní a ke kořenu webového místa relativní cesty. Můžete vytvořit několik typů odkazů v dokumentu:

  • odkaz na jiný dokument nebo soubor, jako například soubor grafický, soubor filmu, PDF nebo zvukový soubor;

  • odkaz na pojmenovanou kotvu, který přejde na specifické místo v dokumentu;

  • odkaz na e-mail, který vytvoří nový prázdný e-mail s předem vyplněnou adresou příjemce;

  • nulové odkazy a skriptové odkazy, které používáte k připojení chování k objektu nebo k vytvoření odkazu, který provede kód JavaScript.

K vytvoření odkazu z obrazu, objektu nebo textu na jiný dokument nebo soubor můžete použít inspektor Vlastnosti a ikonu Ukázat na soubor.

Aplikace Dreamweaver vytvoří odkazy na jiné stránky na webu s použitím cest relativních k dokumentu. Aplikaci Dreamweaver můžete také určit, aby nové odkazy vytvářela s použitím cest relativních ke kořenové složce webu.

Poznámka:

Pokaždé uložte nový soubor předtím, než vytvoříte cestu relativní k dokumentu; cesta relativní k dokumentu je bez pevně stanoveného výchozího bodu neplatná. Pokud vytvoříte cestu relativní k dokumentu před uložením souboru, aplikace Dreamweaver bude až do uložení souboru dočasně používat absolutní cestu začínající parametrem „file://“. Po uložení souboru aplikace Dreamweaver převede cestu s parametrem „file://“ na cestu relativní.

Můžete připojit chování k jakémukoliv odkazu v dokumentu. Zvažte užití následujících chování když vkládáte navázané elementy do dokumentů:

Nastavit textu stavového řádku

Určuje text zprávy a zobrazí ho ve stavovém řádku v levém dolním rohu okna prohlížeče. Toto chování můžete použít například k popisu cílového místa odkazu ve stavovém řádku místo zobrazení související adresy URL.

Otevřít okno prohlížeče

Otevře adresu URL v novém okně. Můžete určit vlastnosti nového okna, včetně jeho názvu, velikosti a atributů (zda má okno nastavitelnou velikost, zda má pruh nabídek a podobně).

Nabídka odkazů

Upraví nabídku odkazů. Můžete měnit seznam nabídek, určit jiný připojený soubor nebo změnit umístění prohlížeče, ve kterém se připojený dokument otevře.

Abyste vytvořili odkazy z obrazu, objektu nebo textu na jiný dokument nebo soubor, můžete použít ikonu složky nebo pole Odkaz v inspektoru Vlastnosti.

  1. Vyberte text nebo obraz v zobrazení Návrh okna dokumentu.
  2. Otevřete inspektor Vlastnosti (Okna >Vlastnosti) a proveďte jeden z následujících úkonů:
    • Klepněte na ikonu složky napravo od pole Odkaz a procházejte obsah a vyberte soubor.

      Cesta k připojenému dokumentu se zobrazí v poli URL. Pomocí rozbalovací nabídky „Relativní k“ v dialogovém okně Vybrat soubor vytvořte cestu relativní k dokumentu nebo ke kořenovému adresáři a klikněte na tlačítko OK. Typ cesty, který vyberete, se vztahuje pouze na aktuální odkaz. (Můžete změnit výchozí nastavení pole Relativní k pro webové místo.)

    • Zadejte cestu a název souboru aktuálního dokumentu v poli Odkaz.

      Chcete-li vytvořit odkaz na dokument ve webovém místě, zadejte cestu relativní k dokumentu nebo ke kořenu webového místa. Chcete-li vytvořit odkaz na dokument mimo webové místo, zadejte absolutní cestu včetně protokolu (například http://). Tento postup můžete použít k zadání odkazu na soubor, který ještě nebyl vytvořen.

  3. Z rozevíracího seznamu Cíl vyberte umístění, ve kterém se má dokument otevřít:

    • _blank načte připojený dokument do nového nepojmenovaného okna prohlížeče.
    • _parent načte připojený dokument v rodičovském rámci nebo v rodičovském okně rámce, který obsahuje odkaz. Pokud není rámec který obsahuje odkaz vnořený, tak se připojený dokument načte v celém okně prohlížeče.
    • _self načte připojený dokument ve stejném rámci nebo okně jako odkaz. Tento cíl je výchozí, takže ho obvykle nemusíte určovat.
    • _top načte připojený dokument v celém okně prohlížeče, a tím odstraní všechny rámce.
    • _new načte připojený dokument do nového okna.
  1. Vyberte text nebo obraz v zobrazení Návrh okna dokumentu.
  2. Vytvořte odkaz jedním z následujících dvou způsobů:
    • Přetáhněte ikonu Ukázat na soubor (cílovou ikonu) vpravo od pole Odkaz v inspektoru Vlastnosti na viditelnou kotvu v aktuálním dokumentu, viditelnou kotvu v jiném otevřeném dokumentu, element s přiřazeným jedinečným ID nebo na dokument v panelu Soubory.

    • Držte klávesu Shift a proveďte přetažení z výběru na viditelnou kotvu v aktuálním dokumentu, viditelnou kotvu v jiném otevřeném dokumentu, element s přiřazeným jedinečným ID nebo na dokument v panelu Soubory.

    Poznámka:

    Na jiný otevřený dokument můžete odkázat pouze za předpokladu, že dokumenty nejsou v okně dokumentu maximalizované. Chcete-li dokument uspořádat jako dlaždice, vyberte možnost Okno > Uspořádat > Stupňovitě nebo Okno > Uspořádat > Dlaždice. Pokud ukážete na otevřený dokument, přesune se tento dokument ve chvíli, kdy provádíte tento výběr, do popředí obrazovky.

Příkaz Hypertextový odkaz umožňuje vytvořit textový odkaz na obraz, objekt nebo na jiný dokument nebo soubor.

  1. Umístěte textový kurzor do dokumentu na místo, kde chcete, aby se odkaz objevil.
  2. Proveďte jeden z následujících úkonů, abyste zobrazili dialogové okno Hypertextový odkaz:

    • Vyberte volbu Vložit > Hypertextový odkaz.

    • V kategorii Společné na panelu Vložit klikněte na tlačítko Hypertextový odkaz.

  3. V poli Text zadejte text odkazu.
    Z rozevíracího seznamu Odkaz vyberte název souboru, na který chcete vytvořit odkaz. Můžete také kliknout na ikonu složky a procházením vybrat soubor, na který chcete odkazovat.

  4. V rozbalovací nabídce Cíl vyberte okno, ve kterém by se měl soubor otevřít, nebo zadejte jeho název.

    V rozbalovacím seznamu se objeví názvy všech rámců, které jste zadali v aktuálním dokumentu. Pokud určíte rámec který neexistuje, připojená stránka se otevře v novém okně, které má název jaký jste určili. Můžete také vybírat z následujících vyhrazených cílových názvů:

    • _blank načte navázaný soubor do nového nepojmenovaného okna prohlížeče.
    • _parent načte navázaný soubor do rodičovské sady rámců nebo okna rámce, který obsahuje odkaz. Pokud rámec, který obsahuje odkaz, není vnořený, navázaný soubor se načte do celého okna prohlížeče.
    • _self načte navázaný soubor do stejného rámce nebo okna jako odkaz. Tento cíl je výchozí, takže ho obvykle nemusíte určovat.
    • _top načte navázaný soubor do celého okna prohlížeče, a odstraní tak všechny rámce.
    • _new načte připojený dokument do nového okna.
  5. Do pole Pořadové číslo zadejte číslo pořadí procházení.
  6. Do pole Titul zadejte titul pro odkaz.
  7. Do pole Přístupová klávesa zadejte klávesový ekvivalent (jedno písmeno) pro výběr odkazu v prohlížeči.
  8. Klepněte na tlačítko OK.

Aplikace Dreamweaver ve výchozím nastavení vytváří odkazy na jiné stránky webu pomocí cest relativních k dokumentu. Chcete-li místo toho používat cesty relativní ke kořenové složce webu, musíte nejdříve v aplikaci Dreamweaver vybrat místní kořenovou složku, která bude sloužit jako ekvivalent kořenové složky dokumentů na serveru, a definovat tak místní složku. Aplikace Dreamweaver použije tuto složku k přiřazení cest relativních ke kořenové složce webu k souborům.

  1. Vyberte volbu Web > Správa webů.
  2. V dialogovém okně Správa webových míst poklepejte na vaše webové místo v seznamu.
  3. V dialogovém okně Nastavení webového místa rozbalte možnost Další nastavení a vyberte kategorii Lokální informace.
  4. Nastavte relativní cesty nových odkazů výběrem volby Dokument nebo Kořen webového místa.

    Změnou tohoto nastavení se nepřevedou cesty existujících odkazů, když klepnete na tlačítko OK. Toto nastavení platí pouze u nových odkazů, které vytvoříte pomocí aplikace Dreamweaver.

  5. Klepněte na tlačítko Uložit.

    Nové nastavení cesty se vztahuje pouze na aktuální webové místo.

Můžete použít inspektor Vlastnosti pro vytvoření odkazu na konkrétní část dokumentu tím, že nejdříve vytvoříte pojmenované kotvy. Pojmenované kotvy umožní nastavit v dokumentu značky, které jsou často umístěny u konkrétního tématu nebo nahoře v dokumentu. Pak můžete vytvořit odkazy na tyto pojmenované kotvy, které návštěvníka rychle přesunou na určenou pozici.

Vytvoření odkazu na pojmenovanou kotvu se skládá ze dvou kroků. Nejdříve vytvoříte pojmenovanou kotvu, pak vytvoříte odkaz na tuto pojmenovanou kotvu.

Vytvoření ukotvení

  1. V okně dokumentu vyberte a označte položku, kterou chcete nastavit jako ukotvení.

  2. Otevřete Inspektor vlastností a zkontrolujte, zda má vybraná položka přiřazený identifikátor. Pokud je pole ID prázdné, identifikátor přidejte. Například „Kotva“.

    Vytvoření ukotvení
    Vytvoření ukotvení

    Po přidání ID si všimněte změny v kódu. Na místě kurzoru se do vašeho kódu vloží výraz id="<ID name>".

    ID ukotvení v&nbsp;kódu
    Přidání ukotvení pro odkazy

  1. V zobrazení Návrh okna dokumentu vyberte text nebo obraz, ze kterého chcete odkaz vytvořit.
  2. Do pole Odkaz v inspektoru Vlastnosti zadejte znak čísla (#) a název kotvy. Například abyste vytvořili odkaz na kotvu nazvanou „top“ v aktuálním dokumentu, zadejte #top. Abyste vytvořili odkaz na kotvu pojmenovanou „top“ v jiném dokumentu ve stejné složce, zadejte názevsouboru.html#top.

    Poznámka:

    V názvech kotev se rozlišují malá a velká písmena.

  1. Otevřete dokument obsahující pojmenovanou kotvu.

    Poznámka:

    Pokud ukotvení nevidíte, vyberte v zobrazení návrhu možnost Zobrazit > Možnosti zobrazení návrhu > Vizuální pomůcky > Neviditelné elementy a ukotvení tak zviditelněte.

  2. V zobrazení Návrh okna dokumentu vyberte text nebo obraz, ze kterého chcete odkaz vytvořit. (Pokud je toto jiný otevřený dokument, musíte se do něj přepnout.)
  3. Proveďte jeden z následujících úkonů:
    • Klikněte na ikonu Ukázat na soubor (cílová ikona) vpravo od pole Odkaz v inspektoru Vlastnosti a přetáhněte ji na kotvu, na kterou chcete vytvořit odkaz: bez ohledu na to, jestli se jedná o stejný dokument nebo o kotvu umístěnou v jiném otevřeném dokumentu.

    • V okně Dokument se stisknutou klávesou Shift táhněte z vybraného textu nebo obrazu na kotvu, na kterou chcete vytvořit odkaz bez ohledu na to, jestli se jedná o stejný dokument nebo o kotvu umístěnou v jiném otevřeném dokumentu.

Pokud klepnete na odkaz na e-mail, otevře se nové prázdné okno zprávy (s použitím mailového programu asociovaného s uživatelským prohlížečem). V okně e-mailové zprávy se automaticky vyplní pole Komu adresou zadanou v e-mailovém odkazu.

  1. V zobrazení Návrh okna dokumentu umístěte textový kurzor tam, kde chcete, aby se odkaz na e-mail objevil, nebo vyberte text nebo obraz, který chcete, aby fungoval jako odkaz na e-mail.
  2. Abyste vložili odkaz, proveďte jeden z následujících úkonů:
    • Vyberte volbu Vložit > Odkaz na e-mail.

    • V kategorii Společné na panelu Vložit klikněte na tlačítko E-mailový odkaz.

  3. Do pole Text zadejte nebo upravte tělo e-mailu.
  4. Do pole E-mail zadejte e-mailovou adresu a pak klepněte na tlačítko OK.
  1. Vyberte text nebo obraz v zobrazení Návrh okna dokumentu.
  2. V poli Odkaz v inspektoru Vlastnosti zadejte mailto: a pak e‑mailovou adresu.

    Nevkládejte žádné mezery mezi dvojtečku a e-mailovou adresu.

Automatické vyplnění předmětu e-mailu

  1. Vytvořte odkaz na e-mail pomocí inspektoru Vlastnosti, jak je popsáno výše.
  2. V poli Odkaz inspektoru Vlastnosti přidejte kód ?subject= za částí s e-mailem a za znaménko rovná se zadejte předmět. Nevkládejte žádné mezery mezi otazník a konec e-mailové adresy.

    Kompletní záznam bude vypadat následovně:

    mailto:uzivatel@domena.com?subject=Pošta z našich stránek

Nulový odkaz je odkaz bez přiřazeného cíle. Nulové odkazy se používají pro připojení chování k objektům nebo k textu na stránce. Můžete například k nulovému odkazu připojit nějaké chování, takže toto chování zamění obraz nebo zobrazí absolutně polohovaný element (AP element) ve chvíli, kdy se ukazatel přesune nad odkaz.

Odkazy na skripty provedou kód JavaScript nebo volání funkce jazyka JavaScript a jsou užitečné k tomu, aby podaly návštěvníkům dodatečné informace o položce bez toho, že by museli opustit aktuální webovou stránku. Když návštěvník klepne na konkrétní položku, můžete odkazy na skripty použít také k provádění výpočtů, ověřování formulářů nebo ke zpracování jiných úkolů.

  1. Vyberte text, obraz nebo objekt v zobrazení Návrh okna dokumentu.
  2. v inspektoru Vlastnosti zadejte do pole Odkaz javascript:; (slovo javascript následované dvojtečkou, následovanou středníkem).
  1. Vyberte text, obraz nebo objekt v zobrazení Návrh okna dokumentu.
  2. Do pole Odkaz v inspektoru Vlastnosti zadejte javascript: a pak nějaký kód JavaScript nebo voláním funkce. (Nevkládejte žádnou mezeru mezi dvojtečku a kód nebo volání.)

Aplikace Dreamweaver může aktualizovat odkazy z dokumentu a na něj bez ohledu na to, jak jej v rámci lokálního webu přesunete nebo přejmenujete. Tato funkce pracuje nejlépe, pokud uložíte kompletní webové místo (nebo jeho kompletní samostatnou součást) na lokální disk. Aplikace Dreamweaver soubory ve vzdálené složce nemění, pokud do ní neumístíte místní soubory nebo je na vzdáleném serveru nezpřístupníte.

K urychlení procesu aktualizace může aplikace Dreamweaver vytvořit soubor s vyrovnávací pamětí, ve kterém se budou ukládat informace o všech odkazech ve vaší místní složce. Vyrovnávací paměť se aktualizuje na pozadí pokaždé, když přidáváte, měníte nebo odstraňujete odkazy v lokálním webovém místě.

  1. Vyberte volbu Úpravy > Předvolby (Windows) nebo Dreamweaver > Předvolby (Macintosh).
  2. V dialogovém okně Předvolby vyberte volbu Všeobecné ze seznamu kategorií na levé straně.
  3. V sekci Volby dokumentu Všeobecných předvoleb vyberte volbu z rozbalovací nabídky Aktualizovat odkazy při přemísťování souborů.

    Vždy

    Automaticky aktualizuje všechny odkazy z a na vybraný dokument kdykoliv ho přesunete nebo přejmenujete.

    Nikdy

    Neaktualizuje automaticky odkazy z a na vybraný dokument, když ho přesunete nebo přejmenujete.

    Dotaz

    Zobrazí dialogové okno, které vypíše všechny soubory ovlivněné změnou. Abyste aktualizovali odkazy v těchto souborech, klepněte na tlačítko Aktualizovat, nebo klepněte na tlačítko Neaktualizovat, abyste zachovali soubory v nezměněné podobě.

  4. Klepněte na tlačítko OK.

Vytvoření vyrovnávacího souboru pro webové místo

  1. Vyberte volbu Web > Správa webů.
  2. Vyberte webové místo a pak klepněte na tlačítko Upravit.
  3. V dialogovém okně Nastavení webu rozbalte možnost Další nastavení a vyberte kategorii Lokální informace.
  4. V kategorii Lokální informace vyberte volbu Povolit vyrovnávací paměť.

    Při první úpravě nebo odstranění odkazů na soubory v místní složce po spuštění aplikace Dreamweaver budete vyzváni k načtení vyrovnávací paměti. Pokud klepnete na tlačítko Ano, aplikace Dreamweaver načte vyrovnávací paměť a aktualizuje všechny odkazy na soubor s provedenými změnami. Pokud klepnete na tlačítko Ne, je změna zaznamenána ve vyrovnávací paměti, ale aplikace Dreamweaver vyrovnávací paměť nenačte a odkazy neaktualizuje.

    Načtení vyrovnávací paměti může v případě větších webů trvat i několik minut, protože aplikace Dreamweaver musí srovnáním časových značek souborů na lokálním webu s časovými značkami zaznamenanými ve vyrovnávací paměti určit, zda je vyrovnávací paměť aktuální. Pokud jste žádné soubory mimo aplikaci Dreamweaver nezměnili, můžete bez obav klepnout na zobrazené tlačítko Stop.

Nové vytvoření vyrovnávací paměti

  1. V panelu Soubory vyberte volbu Webové místo > Další volby > Znovu vytvořit vyrovnávací paměť webového místa.

Kromě toho, že aplikace Dreamweaver aktualizuje odkazy automaticky vždy, když soubor přesunete nebo přejmenujete, můžete ručně změnit všechny odkazy (včetně e‑mailových, FTP, nulových a skriptových odkazů) tak, aby směrovaly na jiné místo.

Tato volba je nejvhodnější pro situace, kdy chcete odstranit soubor, na který odkazují jiné soubory, ale můžete ji použít i pro jiné účely. Například předpokládejme, že text „filmy měsíce“ odkazuje na /filmy/cervenec.html v celém webovém místě. Prvního srpna byste změnili tyto odkazy tak, že budou odkazovat na /filmy/srpen.html.

  1. Vyberte soubor v zobrazení Lokální v panelu Soubory.

    Poznámka:

    Pokud měníte odkaz na e-mail, FTP, nulový odkaz nebo odkaz na skript, nemusíte vybírat soubor.

  2. Vyberte možnost Web > Možnosti webu > Změnit odkaz v celém webovém místě.

  3. Zadejte všechny tyto možnosti v dialogovém okně Změnit odkaz v celém webovém místě:

    Změnit všechny odkazy na

    Klikněte na ikonu složky procházejte obsah a vyberte cílový soubor, pro který chcete zrušit odkazy. Pokud měníte odkaz na e-mail, FTP, nulový odkaz nebo odkaz na skript, zadejte celý text odkazu, který měníte.

    Na odkazy na

    Klikněte na ikonu složky a procházejte obsah a vyberte nový soubor, na který chcete odkazovat. Pokud měníte odkaz na e-mail, FTP, nulový odkaz nebo odkaz na skript, zadejte celý text nového odkazu.

  4. Klepněte na tlačítko OK.

    Pomocí formátu cesty, který je v dokumentu použitý, aplikace Dreamweaver aktualizuje všechny dokumenty, které odkazují na vybraný soubor, aby směrovaly k novému souboru (pokud například původní cesta byla relativní k dokumentu, nová cesta bude také relativní k dokumentu).

    Poté, co změníte odkaz v celém webovém místě, se z vybraného souboru stane sirotek (to znamená, že žádný ze souborů na disku na něj neodkazuje). Můžete ho bez obav odstranit, aniž byste přerušili jakékoli odkazy v lokálním webu aplikace Dreamweaver.

    Poznámka:

    Protože k těmto změnám dochází lokálně, musíte ručně odstranit odpovídající osiřelý soubor i ve vzdálené složce a odeslat nebo zpřístupnit všechny soubory, jejichž odkazy byly změněny; v opačném případě návštěvníci webového místa neuvidí změny.

Odkazy nejsou v rámci aplikace Dreamweaver aktivní. To znamená, že nemůžete otevřít připojený dokument klepnutím na odkaz v okně Dokument.

  1. Proveďte jeden z následujících úkonů:
    • Klikněte na odkaz pravým tlačítkem a vyberte možnost Otevřít připojenou stránku.

    • Stiskněte klávesu Ctrl (Windows) nebo Cmd (Macintosh) a poklepejte na odkaz.

    Poznámka:

    Připojený dokument musí být uložen na lokálním disku.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online