Využívejte aplikaci Fireworks a Dreamweaver pro zjednodušení úprav, optimalizaci a vkládání webové grafiky na stránky HTML.

Tato funkce není ve verzích aplikace Adobe Dreamweaver CC k dispozici.

Vložení obrazu aplikace Fireworks

Aplikace Dreamweaver a Fireworks podporují a sdílejí řadu způsobů úprav obrazu, včetně převodu na odkazy, obrazové mapy, řezy tabulek a mnoho dalšího. Obě aplikace společně nabízejí zjednodušení úprav, optimalizace a vkládání webové grafiky na stránky HTML.

Grafiku exportovanou z aplikace Fireworks můžete vložit přímo do dokumentu aplikace Dreamweaver příkazem Vložit obraz, nebo můžete vytvořit novou grafiku Fireworks z vyhrazeného místa pro obraz aplikace Dreamweaver.

  1. V dokumentu aplikace Dreamweaver umístěte kurzor do místa, kde se má obraz objevit, a pak proveďte jeden z následujících úkonů:
    • Vyberte volbu Vložit > Obraz.

    • V kategorii Běžné na panelu Vložit klepněte na tlačítko Obraz nebo ho přetáhněte do dokumentu.

  2. Vyhledejte požadovaný soubor exportovaný z aplikace Fireworks a klepněte na tlačítko OK (Windows) nebo Otevřít (Macintosh).

    Poznámka:

    Pokud soubor aplikace Fireworks není součástí aktuálního webového místa aplikace Dreamweaver, objeví se zpráva, zda chcete soubor zkopírovat do kořenové složky. Klikněte na tlačítko Ano.

Úpravy obrazu aplikace Fireworks nebo tabulky aplikace Dreamweaver

Když otevřete a upravujete obraz nebo řez obrazu, který je součástí tabulky aplikace Fireworks, aplikace Dreamweaver spustí aplikace Fireworks a ten otevře soubor PNG, z něhož byly obraz nebo tabulka exportovány.

Poznámka:

Předpokládá se, že je aplikace Fireworks nastavena jako primární externí editor obrazů PNG. Aplikace Fireworks je také často nastavena jako výchozí editor obrazů JPEG a GIF, i když u těchto formátů souborů můžete chtít jako výchozí editor nastavit Photoshop.

Když je obraz součástí tabulky aplikace Fireworks, můžete otevřít a upravovat celou tabulku Fireworks, pokud v HTML kódu nechybí poznámka <!--fw table-->. Pokud byl zdrojový soubor PNG exportován z aplikace Fireworks do webového místa aplikace Dreamweaver pomocí nastavení aplikace Dreamweaver Styl HTML a obrazy, vloží se do HTML kódu automaticky komentář k tabulce aplikace Fireworks.

  1. V aplikaci Dreamweaver otevřete inspektor Vlastnosti (Okna > Vlastnosti), pokud již není otevřený.
  2. Obraz nebo řez obrazu otevřete klepnutím na něj.

    Pokud vyberete obraz, který byl exportován z aplikace Fireworks, v inspektoru Vlastnosti je výběr označen jako obraz nebo tabulka aplikace Fireworks a zobrazuje se u něj název zdrojového souboru PNG.

  3. Pokud chcete otevřít aplikaci Fireworks a začít s úpravami, proveďte jeden z následujících úkonů:
    • v inspektoru Vlastnosti klepněte na tlačítko Upravit.

    • Podržte klávesu Ctrl (Windows) nebo Apple (Mac OS) a poklepejte na vybraný obraz.

    • Klepněte pravým tlačítkem myši (Windows) nebo s klávesou Ctrl (Macintosh) na vybraný obraz a z kontextové nabídky vyberte volbu Upravit pomocí Fireworks.

    Poznámka:

    Pokud aplikace Fireworks nedokáže najít zdrojový soubor, objeví se výzva k vyhledání zdrojového souboru PNG. Pokud pracujete se zdrojovým souborem aplikace Fireworks, změny se ukládají do zdrojového i exportovaného souboru, jinak je aktualizován jen exportovaný soubor.  

  4. V programu Fireworks upravte zdrojový soubor PNG a pak klikněte na tlačítko Hotovo.

    Aplikace Fireworks uloží změny do souboru PNG, exportuje aktualizovaný obraz (nebo HTML a obrazy), a vrátí vstup do aplikace Dreamweaver. V aplikaci Dreamweaver se zobrazí aktualizovaný obraz nebo tabulka.

    Výukovou lekci o integraci programů Dreamweaver a Fireworks najdete na adrese www.adobe.com/go/vid0188_cz.

Optimalizace obrazu aplikace Fireworks pomocí aplikace Dreamweaver

Pomocí aplikace Dreamweaver můžete rychle upravovat obrazy a animace aplikace Fireworks. V aplikaci Dreamweaver můžete změnit nastavení optimalizace, animace a velikost a oblast exportovaného obrazu.

  1. V programu Dreamweaver vyberte požadovaný obrázek a proveďte jednu z následujících akcí:
    • Vyberte volbu Příkaz > Optimalizovat obraz

    • Klepněte na tlačítko Upravit nastavení obrazu v inspektoru Vlastnosti.

  2. Proveďte úpravy v dialogovém okně Náhled obrazu:
    • Chcete-li upravit nastavení optimalizace, klepněte na záložku Volby.

    • Chcete-li upravit velikost a oblast exportovaného obrazu, klepněte na záložku Soubor.

  3. Až skončíte, klepněte na tlačítko OK.

Úpravy vyhrazených míst pro obrazy aplikace Dreamweaver pomocí aplikace Fireworks

V dokumentu aplikace Dreamweaver můžete vytvořit vyhrazené místo pro obraz a pak spustit aplikaci Fireworks a vytvořit v něm grafiku nebo tabulku aplikace Fireworks, která bude vložena na vyhrazené místo.

Abyste vytvořili nový obraz z vyhrazeného místa pro obraz, musíte mít v počítači instalovány aplikace Dreamweaver i Fireworks.

  1. Zkontrolujte, zda jste nastavili aplikaci Fireworks jako editor obrazů PNG.
  2. V okně dokumentu klepněte na vyhrazené místo pro obraz a tím ho vyberte.
  3. Spusťte aplikaci Fireworks v režimu Editace z aplikace Dreamweaver jedním z následujících postupů:
    • v inspektoru Vlastnosti klepněte na tlačítko Vytvořit.

    • Stiskněte klávesu Ctrl (Windows) nebo Apple (Macintosh) a pak poklepejte na vyhrazené místo pro obraz.

    • Klepněte pravým tlačítkem myši (Windows) nebo s klávesou Ctrl (Macintosh) na vyhrazené místo pro obraz a pak vyberte volbu Vytvořit obraz ve Fireworks.

  4. Použijte volby aplikace Fireworks k vytvoření obrazu.

    Aplikace Fireworks rozpozná následující nastavení vyhrazeného místa pro obraz, která jste mohli provést při práci s vyhrazeným místem pro obraz v aplikaci Dreamweaver: velikost obrazu (odpovídá velikosti plátna v aplikaci Fireworks), identifikátor obrazu (který aplikace Fireworks použije jako výchozí název zdrojového i exportovaného souboru) a zarovnání textu. Aplikace Fireworks také rozpozná odkazy a některé typy chování (například záměnu obrazu, rozbalovací nabídku a nastavení textu), které jste připojili k vyhrazenému místu pro obraz během práce v aplikaci Dreamweaver.

    Poznámka:

    I když aplikace Fireworks nezobrazuje odkazy, které jste přidali k místu pro obraz, zachovává je. Pokud vytvoříte aktivní oblast a v aplikaci Fireworks přidáte odkaz, neodstraní se odkaz přidaný k vyhrazenému místu pro obraz v aplikaci Dreamweaver; pokud ale v aplikaci Fireworks vytvoříte v novém obrazu řez, aplikace Fireworks odstraní odkaz v dokumentu aplikace Dreamweaver v okamžiku, kdy vyhrazené místo pro obraz nahradíte.

    Aplikace Fireworks nerozeznává níže uvedená nastavení vyhrazeného místa pro obraz: zarovnání obrazu, barva, svislá a vodorovná mezera a mapy. Tyto vlastnosti jsou v inspektoru Vlastnosti vyhrazeného místa pro obraz zakázané.

  5. Až skončíte, klepnutím na tlačítko Hotovo zobrazte výzvu k uložení.
  6. V textovém poli Uložit do vyberte složku, která je definována jako výchozí složka lokálního webového místa aplikace Dreamweaver.

    Pokud vyhrazené místo pro obraz při vkládání do dokumentu aplikace Dreamweaver pojmenujete, aplikace Fireworks tento název vyplní do pole Název souboru. Název můžete změnit.

  7. Klepnutím na tlačítko Uložit uložíte soubor PNG.

    Objeví se dialogové okno Export. Toto dialogové okno slouží k exportu obrazu ve formátu GIF nebo JPEG nebo v případě obrazů složených z řezů ve formátu HTML s obrazy.

  8. V textovém poli Uložit do vyberte složku, která je definována jako složka lokálního webového místa aplikace Dreamweaver.

    V poli Název se automaticky zobrazí název souboru PNG. Název můžete změnit.

  9. V poli Uložit jako soubor typu vyberte typ souboru nebo souborů, které chcete exportovat, například Jen obrazy nebo HTML a obrazy.
  10. Klepnutím na tlačítko Uložit uložíte exportovaný soubor.

    Soubor je uložen a vstup se vrátí do aplikace Dreamweaver. V dokumentu aplikace Dreamweaver nahradí exportovaný soubor nebo tabulka aplikace Fireworks vyhrazené místo pro obraz.

O rozbalovacích nabídkách aplikace Fireworks

Aplikace Fireworks umožňuje snadné a rychlé vytváření rozbalovacích nabídek založených na CSS.

Kromě rozšiřitelnosti a rychlého stahování mají rozbalovací nabídky vytvořené v aplikaci Fireworks následující výhody:

  • Položky nabídek mohou být indexovány vyhledávači.

  • Položky nabídek mohou číst programy pro čtení z obrazovky, což zlepšuje přístupnost webových stránek.

  • Kód vytvořený aplikací Fireworks vyhovuje normám a lze ho ověřovat.

    Rozbalovací nabídky aplikace Fireworks můžete upravovat v aplikaci Dreamweaver nebo pomocí aplikace Fireworks, ale ne oběma způsoby. Změny provedené v aplikaci Dreamweaver se v aplikaci Fireworks nezachovají.

Úpravy rozbalovacích nabídek aplikace Fireworks v aplikaci Dreamweaver

Rozevírací nabídky můžete vytvářet v aplikaci Fireworks 8 nebo novější a pak je upravovat pomocí aplikace Dreamweaver nebo aplikace Fireworks (pomocí úprav se zpětným převodem), ale ne oběma způsoby. Pokud nabídky upravíte v aplikaci Dreamweaver a pak v aplikaci Fireworks, ztratíte všechny dříve provedené změny, kromě textového obsahu.

Pokud chcete nabídky upravovat pomocí aplikace Dreamweaver, můžete pomocí aplikace Fireworks vytvořit rozbalovací nabídku a pak ji upravovat a přizpůsobovat jen v aplikaci Dreamweaver.

Pokud chcete nabídky upravovat pomocí aplikace Fireworks, můžete použít funkci úprav se zpětným převodem v aplikaci Dreamweaver, ale neměli byste nabídky upravovat přímo v aplikaci Dreamweaver.

  1. V aplikaci Dreamweaver vyberte tabulku aplikace Fireworks, která obsahuje rozbalovací nabídku a pak klikněte na tlačítko Upravit v inspektoru Vlastnosti.

    Zdrojový soubor PNG se otevře ve Fireworks.

  2. V aplikaci Fireworks upravte nabídku pomocí Editoru rozbalovacích nabídek a pak klepněte na tlačítko Hotovo v pruhu nástrojů aplikace Fireworks.

    Aplikace Fireworks odešle upravenou nabídku zpět do aplikace Dreamweaver.

    Pokud jste rozbalovací nabídku vytvořili v aplikaci Fireworks MX 2004 nebo starší verzi, můžete ji upravit v aplikaci Dreamweaver pomocí dialogového okna Zobrazit rozbalovací nabídku, které najdete v panelu Chování.

Úpravy rozbalovací nabídky vytvořené v aplikaci Fireworks MX 2004 nebo starší verzi

  1. V aplikaci Dreamweaver vyberte aktivní oblast nebo obraz, které spouštějí rozbalovací nabídku.
  2. V panelu Chování (Shift+F3) poklepejte na tlačítko Zobrazit rozbalovací nabídku v seznamu Akce.
  3. Proveďte požadované změny v dialogovém okně Rozbalovací nabídka a klepněte na tlačítko OK.

Určení předvoleb otevření a úprav zdrojových souborů aplikace Fireworks

Pokud pomocí aplikace Fireworks upravíte obrazy, aplikace Fireworks je obvykle do webových stránek exportuje ze zdrojového souboru PNG. Pokud otevřete obrazový soubor v aplikaci Dreamweaver a chcete ho upravit, aplikace Fireworks automaticky otevře zdrojový soubor PNG a pokud ho nenalezne, zobrazí výzvu k nalezení souboru PNG. Pokud chcete, můžete nastavit předvolby v aplikaci Fireworks tak, aby aplikace Dreamweaver otevřela vložený soubor, nebo aby aplikace Fireworks nabídla možnost práce s vloženým obrazovým souborem nebo se zdrojovým souborem aplikace Fireworks vždy, když v aplikaci Dreamweaver otevřete soubor.

Poznámka:

Aplikace Dreamweaver rozpozná předvolby otevření a úprav v aplikaci Fireworks jen v některých případech. Konkrétně musíte otevřít a optimalizovat obraz, který není součástí tabulky aplikace Fireworks a který obsahuje poznámky k návrhu se správnou cestou ke zdrojovému PNG souboru.

  1. V aplikaci Fireworks vyberte volbu Úpravy > Předvolby (Windows) nebo Fireworks > Předvolby (Macintosh) a pak klepněte na záložku Spustit a upravit (Windows) nebo vyberte volbu Spustit a upravit z rozbalovací nabídky (Macintosh).
  2. Zadejte předvolby, které se použití při úpravě nebo optimalizaci obrazů aplikace Fireworks vložených do externí aplikace:

    Vždy použít zdrojový PNG

    Automaticky otevře soubor PNG aplikace Fireworks definovaný v poznámce k návrhu jako zdroj umístěného obrazu. Aktualizován je zdrojový soubor PNG a jemu odpovídající vložený obraz.

    Nikdy nepoužít zdrojový PNG

    Automaticky otevře umístěný obraz aplikace Fireworks, nezávisle na tom, zda existuje zdrojový soubor PNG. Aktualizován je pouze vložený obraz.

    Dotaz při spuštění

    Zobrazí dotaz, zda se má otevřít zdrojový soubor PNG. Z tohoto dotazu můžete také nastavit globální předvolby spouštění a úprav.

Vložení HTML kódu aplikace Fireworks do dokumentu aplikace Dreamweaver

Z aplikace Fireworks můžete příkazem Export exportovat a uložit optimalizované obrazy a soubory HTML do umístění ve složce webového místa aplikace Dreamweaver. Soubor pak můžete vložit do aplikace Dreamweaver. Aplikace Dreamweaver umožňuje vložení kódu HTML generovaného pomocí aplikace Fireworks, včetně obrazů, řezů a jazyka JavaScript, do dokumentu.

  1. V dokumentu aplikace Dreamweaver umístěte kurzor do místa, kam chcete vložit kód HTML z aplikace Fireworks.
  2. Proveďte jeden z následujících úkonů:
    • Vyberte volbu Vložit > Obrazové objekty > Fireworks HTML.

    • V kategorii Běžné na panelu Vložit klepněte na tlačítko Obrazy a z rozbalovací nabídky vyberte volbu Fireworks HTML.

  3. Klepnutím na tlačítko Procházet vyberte soubor Fireworks HTML.
  4. Pokud už pro soubor nemáte další použití, vyberte volbu Soubor po vložení odstranit. Výběr této volby nemá žádný vliv na zdrojový soubor PNG asociovaný se souborem HTML.

    Poznámka:

    Pokud je soubor HTML na síťovém disku, je trvale odstraněn – není přesunut do koše.

  5. Kliknutím na tlačítko OK vložíte kód HTML spolu s přidruženými obrazy, řezy a skripty jazyka JavaScript do dokumentu programu Dreamweaver.

Vložení kódu HTML Fireworks do aplikace Dreamweaver

Rychlou možností, jak vložit obrazy a tabulky generované v aplikaci Fireworks do aplikace Dreamweaver je přímé zkopírování a vložení kódu HTML Fireworks do dokumentu aplikace Dreamweaver.

Kopírování a vložení kódu HTML Fireworks do aplikace Dreamweaver

  1. V aplikaci Fireworks vyberte volbu Úpravy > Kopírovat kód HTML.
  2. Postupujte podle pokynů průvodce, který vás provede nastaveními exportu HTML a obrazů. Na výzvu zadejte složku webového místa aplikace Dreamweaver jako cíl exportovaných obrazů.

    Průvodce exportuje obrazy do vybraného cíle a zkopíruje kód HTML do schránky systému.

  3. V dokumentu aplikace Dreamweaver umístěte kurzor do místa, kam chcete vložit kód HTML, a pak vyberte volbu Úpravy > Vložit kód HTML Fireworks.

    Veškerý kód HTML a JavaScript související s exportovanými soubory Fireworks je zkopírován do dokumentu aplikace Dreamweaver a všechny odkazy na obrazy jsou aktualizovány.

Export a vložení HTML Fireworks do aplikace Dreamweaver

  1. V aplikaci Fireworks vyberte volby Soubor > Exportovat.
  2. Zadejte složku webového místa aplikace Dreamweaver jako cíl exportovaných obrazů.
  3. V rozbalovací nabídce Export vyberte volbu HTML a obrazy.
  4. V rozbalovací nabídce HTML vyberte volbu Kopírovat do schránky a pak klepněte na tlačítko Export.
  5. V dokumentu aplikace Dreamweaver umístěte kurzor do místa, kam chcete vložit exportovaný HTML a pak vyberte volbu Úpravy > Vložit kód HTML Fireworks.

    Veškerý kód HTML a JavaScript související s exportovanými soubory Fireworks je zkopírován do dokumentu aplikace Dreamweaver a všechny odkazy na obrazy jsou aktualizovány.

Aktualizace kódu HTML Fireworks vloženého do aplikace Dreamweaver

V aplikaci Fireworks nabízí volba Soubor > Aktualizovat HTML alternativu k technice otevření a úprav používané k úpravám souborů Fireworks vložených do aplikace Dreamweaver. Příkaz Aktualizovat HTML umožňuje úpravu zdrojového souboru PNG v aplikaci Fireworks s následnou automatickou aktualizací veškerého exportovaného kódu HTML a obrazových souborů vložených do dokumentu aplikace Dreamweaver. Tento příkaz umožňuje aktualizaci souborů aplikace Dreamweaver i pokud aplikace Dreamweaver neběží.

  1. V aplikaci Fireworks otevřete zdrojový soubor PNG a proveďte úpravy.
  2. Vyberte volbu Soubor > Uložit.
  3. V aplikaci Fireworks vyberte volbu Soubor > Aktualizovat HTML.
  4. Vyhledejte soubor programu Dreamweaver obsahující kód HTML, který chcete aktualizovat, a kliknutím na možnost Otevřít.
  5. Najeďte na cílovou složku, do níž chcete umístit aktualizované obrazové soubory, a klikněte na tlačítko Vybrat (Windows) nebo tlačítko Vybrat (Macintosh).

    Fireworks aktualizuje kód HTML a JavaScript v dokumentu programu Dreamweaver. Aplikace Fireworks také exportuje aktualizované obrazy související s kódem HTML a uloží obrazy do vybrané cílové složky.

    Pokud aplikace Fireworks nenalezne odpovídající kód HTML, který má být aktualizován, nabídne možnost vložení nového kódu HTML do dokumentu aplikace Dreamweaver. Aplikace Fireworks vloží sekci JavaScript nového kódu na začátek dokumentu a HTML tabulku nebo odkaz na konec dokumentu.

Vytvoření webového alba fotografií

Funkce Vytvořit webové album fotografií byla od verze Dreamweaver CS5 zavržena.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online