Naučte se vkládat a upravovat multimediální objekty na webových stránkách aplikace Dreamweaver, používat poznámky k návrhu a mnohé další.

Kromě souborů SWF a FLV můžete v dokumentu aplikace Dreamweaver vkládat další zvukové či obrazové objekty. Pokud s multimediálním objektem vložíte atributy usnadnění přístupu, je možné je nastavit a upravit jejich hodnoty v kódu HTML.

  1. V okně dokumentu vložte textový kurzor do místa, kam chcete objekt vložit.
  2. Vložte objekt jedním z následujících úkonů:
    • V kategorii HTML na panelu Vložit vyberte ikonu typu objektu, který chcete vložit.

    • Vyberte příslušný objekt v podnabídce Vložit > HTML.

    • Zobrazí se dialogové okno, které umožňuje vybrat zdrojový soubor a zadat určité parametry multimediálního objektu.

    Poznámka:

    Pokud nechcete, aby se taková dialogová okna zobrazovala, vyberte volbu Úpravy > Předvolby > Všeobecné (Windows) nebo Dreamweaver > Předvolby > Všeobecné (Macintosh) a zrušte výběr volby Při vkládání objektů zobrazit dialog. Chcete-li nahradit předvolby nastavené pro zobrazení dialogových oken, podržte při vkládání objektu klávesu Ctrl (Windows) nebo Alt (Macintosh). 

  3. Zadejte hodnoty do dialogového okna Vybrat soubor a klikněte na tlačítko OK.

    Poznámka:

    Pokud jste při vkládání multimédií v dialogovém okně Úpravy > Předvolby vybrali zobrazení atributů, zobrazí se dialogové okno Atributy usnadnění přístupu.

  4. Nastavte atributy usnadnění přístupu.

    Poznámka:

    Atributy multimediálních objektů můžete upravit také tak, že vyberete objekt a v zobrazení kódu upravíte kód HTML nebo klikněte pravým tlačítkem (Windows) nebo se stisknutou klávesou Ctrl (Macintosh) a vyberete Upravit kód tagu.

    Titul

    Zadejte titul multimediálního objektu.

    Přístupová klávesa

    Do textového pole zadejte klávesový ekvivalent (jedno písmeno), kterým vyberete objekt formuláře v prohlížeči. Tím návštěvníkovi umožníte přístup k objektu pomocí klávesy Ctrl (Windows) a této přístupové klávesy. Pokud například zadáte jako přístupovou klávesu B, můžete pomocí kláves Ctrl+B vybrat objekt v prohlížeči.

    Pořadové číslo

    Zadejte číslo představující pořadí objektu formuláře při procházení pomocí tabulátoru. Nastavení pořadí procházení pomocí tabulátoru je užitečné, když máte na stránce další odkazy a objekty formuláře a potřebujete, aby jimi uživatel procházel v určitém pořadí. Pokud nastavíte pořadí procházení pro jeden objekt, nezapomeňte ho nastavit i pro všechny ostatní.

  5. Klikněte na tlačítko OK vložte multimediální objekt.

    Poznámka:

    Pokud kliknete na tlačítko Zrušit, zobrazí se v dokumentu vyhrazené místo pro multimediální objekt, ale aplikace Dreamweaver k němu nepřiřadí atributy ani tagy pro usnadnění přístupu.

    Chcete-li zadat zdrojový soubor nebo nastavit rozměry a jiné parametry a atributy, použijte pro každý objekt inspektor Vlastnosti. U objektu je možné upravit atributy usnadnění přístupu.

Spuštění externího editoru multimediálních souborů

v aplikaci Dreamweaver můžete spustit externí editor pro úpravu většiny multimediálních souborů. Je také možné zadat editor, který má aplikace Dreamweaver pro úpravy souboru spustit.

  1. Zkontrolujte, zda je typ multimediálního souboru ve vašem systému přiřazen k nějakému editoru.

    Chcete-li zjistit, jaký editor je k typu souboru přiřazen, vyberte v aplikaci Dreamweaver volby Úpravy > Předvolby a v seznamu kategorií vyberte volbu Typy souborů/editory. Klepnutím na příponu souboru ve sloupci Přípony zobrazíte přiřazený editor nebo editory ve sloupci Editory. Editor přiřazený k typu souboru lze změnit.

  2. Poklepáním na multimediální soubor v panelu Soubory ho otevřete v externím editoru.

    Editor, který se spustí při poklepání na soubor v panelu Soubory, se nazývá primární editor. Pokud například poklepete na soubor obrazu, aplikace Dreamweaver ho otevře v primárním externím editoru obrazů, například v aplikaci Adobe Fireworks.

  3. Pokud nechcete pro úpravy souboru použít primární externí editor, můžete použít jiný provedením následujících úkonů:
    • v panelu Soubory klepněte na název souboru pravým tlačítkem (Windows) nebo s klávesou Ctrl (Macintosh) a v kontextové nabídce vyberte volbu Otevřít v programu.

    • V zobrazení Návrh klepněte na multimediální element na aktuální stránce pravým tlačítkem (Windows) nebo s klávesou Ctrl (Macintosh) a v kontextové nabídce vyberte volbu Upravit v programu.

Určení editoru spouštěného z aplikace Dreamweaver

Můžete určit editor, který má aplikace Dreamweaver použít pro úpravy určitého typu souboru, a přidávat nebo odstraňovat typy souborů, které aplikace Dreamweaver rozpoznává.

Určení externích editorů pro spouštění daného typu souborů

  1. Vyberte volbu Úpravy > Předvolby a v seznamu kategorií vyberte volbu Typy souborů/editory.

    Přípony souborů, například .gif, .wav a .mpg, jsou uvedeny vlevo v seznamu Přípony. Přiřazené editory pro vybranou příponu jsou uvedeny vpravo v seznamu Editory.

  2. V seznamu přípony vyberte příponu typu souboru a proveďte jeden z následujících úkonů:
    • Chcete-li k typu souboru přiřadit nový editor, klepněte na tlačítko plus (+) nad seznamem Editory a vyplňte dialogové okno, které se zobrazí.

      Například výběrem ikony aplikace Acrobat ho přiřadíte k typu souboru.

    • Chcete-li určitý editor změnit na primární editor typu souboru (to znamená, že se tento editor otevře při poklepání na typ souboru v panelu Soubory), vyberte ho v seznamu Editory a klepněte na Změnit na primární.

    • Chcete-li zrušit přiřazení editoru k typu souboru, vyberte editor v seznamu Editory a klepněte na tlačítko minus (-) nad seznamem Editory.

Přidání nového typu souboru a přiřazeného editoru

  1. Klikněte na tlačítko plus (+) nad seznamem Přípony a zadejte příponu typu souboru (včetně tečky na začátku přípony) nebo více souvisejících přípon oddělených mezerami.

    Můžete například zadat .xml .xsl a přiřadit tak tyto typy souborů k editoru XML nainstalovanému v systému.

  2. Klepnutím na tlačítko plus (+) nad seznamem Editory a vyplněním dialogového okna, které se zobrazí, vyberete editor typu souboru.

Odstranění typu souboru

  1. Vyberte typ souboru v seznamu Přípony a klepněte na tlačítko minus (-) nad seznamem Přípony.

    Poznámka:

    Odstranění typu souboru nelze vrátit zpět, a proto si tuto operaci rozmyslete.

Používání poznámek k návrhu s multimediálními objekty

Podobně jako k jiným objektům v aplikaci Dreamweaver můžete přidávat poznámky k návrhu i k multimediálním objektům. Poznámky k návrhu jsou přiřazeny k určitému souboru a jsou uloženy v samostatném souboru. Pomocí poznámek k návrhu lze sledovat další informace o souborech přiřazené k dokumentům, například názvy zdrojů obrazů a poznámky ke stavu souboru.

  1. Klepněte pravým tlačítkem (Windows) nebo s klávesou Ctrl (Macintosh) na objekt v okně dokumentu.

    Poznámka:

    Před přidáním poznámek k návrhu k objektu je nutné definovat místo.

  2. V kontextové nabídce vyberte volbu Poznámky k návrhu stránky.
  3. Zadejte do poznámky k návrhu požadované informace.

    Poznámka:

    Poznámku k návrhu lze k multimediálnímu objektu přidat také v panelu Soubory. Vyberete soubor, zobrazíte kontextovou nabídku a zvolíte Poznámky k návrhu.

Přidat video (ne FLV)

Na webové stránky můžete různými způsoby a v různých formátech přidávat video. Uživatelé mohou video stahovat nebo (v případě, že je streamované) ho přehrávat již při stahování.

  1. Vložte klip do složky webového místa.

    Klipy jsou často ve formátu AVI nebo MPEG.

  2. Vytvořte na klip odkaz nebo ho vložte do stránky.

    Chcete-li na klip vytvořit odkaz, zadejte pro něj text, například „Stáhnout klip“, vyberte tento text a v inspektoru Vlastnosti klepněte na ikonu složky. Vyhledejte soubor videa a vyberte ho.

    Poznámka:

    Aby uživatel mohl zobrazit běžné streamované formáty, například Real Media, QuickTime nebo Windows Media, musí si stáhnout pomocnou aplikaci (zásuvný modul).

Vložení obsahu zásuvného modulu

Pro zásuvný modul prohlížeče můžete vytvořit obsah (například film QuickTime), který lze následně pomocí aplikace Dreamweaver vložit do dokumentu HTML. Mezi typické zásuvné moduly patří programy RealPlayer a QuickTime a některé soubory obsahu zahrnují soubory mp3 a filmy QuickTime.

Filmy a animace závislé na zásuvných modulech prohlížeče lze přehrávat přímo v zobrazení Návrh v okně dokumentu. Můžete přehrát všechny elementy zásuvných modulů zároveň, abyste viděli, jak se bude uživatelům stránka zobrazovat, nebo je přehrávat zvlášť, abyste mohli zkontrolovat, zda jste vložili správný multimediální element.

Poznámka:

Není možné zobrazovat náhled filmů nebo animací závislých na ovládacích prvcích ActiveX.

Po vložení obsahu pro zásuvný modul prohlížeče nastavte parametry obsahu pomocí inspektoru Vlastnosti. Chcete-li v inspektoru Vlastnosti zobrazit následující vlastnosti, vyberte objekt zásuvného modulu.

Inspektor Vlastnosti nejdříve zobrazí nejpoužívanější vlastnosti. Klepnutím na rozbalovací šipku v pravém dolním rohu zobrazíte všechny vlastnosti.

Vložení obsahu zásuvného modulu a nastavení jeho vlastností

  1. V zobrazení Návrh v okně dokumentu umístěte textový kurzor do místa, kam chcete obsah vložit, a proveďte jeden z následujících úkonů:
    • V kategorii Společné na panelu Vložit klikněte na tlačítko Média a z nabídky vyberte ikonu Zásuvný modul .

    • Vyberte volbu Vložit > Média > Zásuvný modul.

  2. V dialogovém okně, které se zobrazí, vyberte soubor obsahu pro zásuvný modul a klikněte na tlačítko OK.
  3. V inspektoru Vlastnosti nastavte volby zásuvného modulu.

    Název

    Určuje název identifikující zásuvný modul pro skriptování. Název zadejte do neoznačeného textového pole zcela vlevo v inspektoru Vlastnosti.

    Š a V

    Určuje šířku a výšku v obrazových bodech přiřazenou objektu na stránce.

    Zdroj

    Určuje soubor zdroje dat. Klepněte na ikonu složky a soubor vyhledejte nebo zadejte přímo název souboru.

    URL modulu

    Určuje adresu URL atributu pluginspace. Zadejte úplnou adresu URL místa, odkud mohou uživatelé zásuvný modul stáhnout. Pokud uživatel, který si zobrazí stránku, zásuvný modul nemá, prohlížeč se ho pokusí stáhnout z této adresy URL.

    Zarovnání

    Určuje způsob zarovnání objektu na stránce.

    Mezera S a mezera V

    Zadejte velikost prázdného místa nad, pod a po stranách zásuvného modulu v obrazových bodech.

    Okraj

    Určuje šířku okraje kolem zásuvného modulu.

    Parametry

    Otevře dialogové okno, ve kterém lze zadat další parametry, které budou předány zásuvnému modulu. Mnoho zásuvných modulů reaguje na speciální parametry.

    Klepnutím na tlačítko Atribut také můžete zobrazit atributy přiřazené vybranému zásuvnému modulu. V tomto dialogovém okně můžete upravovat, přidávat a odstraňovat různé atributy, například šířku a výšku.

Spuštění obsahu zásuvného modulu v okně dokumentu

  1. Vložte jeden nebo více prvků médií pomocí jedné z metod popsaných v předchozí části.
  2. Proveďte jeden z následujících úkonů:
    • Vyberte jeden z vložených multimediálních elementů a vyberte volbu Zobrazení > Zásuvné moduly > Spustit nebo klepněte na tlačítko Spustit v inspektoru Vlastnosti.

    • Výběrem volby Zobrazení > Zásuvné moduly > Spustit všechny spustíte všechny multimediální elementy na vybrané stránce, které jsou závislé na zásuvných modulech.

    Poznámka:

    Příkaz Spustit vše platí pouze pro aktuální dokument; neplatí tedy například pro jiné dokumenty v sadě rámců.

Zastavení obsahu zásuvného modulu

  1. Vyberte multimediální element a vyberte volbu Zobrazení > Zásuvné moduly > Zastavit nebo klepněte na tlačítko Zastavit v inspektoru Vlastnosti.

    Chcete-li zastavit veškerý obsah zásuvných modulů, vyberte volbu Zobrazení > Zásuvné moduly > Zastavit všechny.

Řešení problémů se zásuvnými moduly

Pokud jste se řídili postupem pro spuštění obsahu zásuvného modulu v okně dokumentu, ale obsah se nespustil, vyzkoušejte následující:

  • Zkontrolujte, zda je příslušný zásuvný modul nainstalován na vašem počítači a obsah je kompatibilní s používanou verzí zásuvného modulu.

  • V textovém editoru otevřete soubor UnsupportedPlugins.txt ve složce Configuration\Plugins\ a zjistěte, zda je v něm zásuvný modul uveden. Tento soubor udržuje přehled o zásuvných modulech, které v aplikaci Dreamweaver způsobují problémy, a nejsou proto podporovány. (Pokud se u určitého zásuvného modulu vyskytnou problémy, zvažte jeho přidání do tohoto souboru.)

  • Zkontrolujte, zda máte dostatek paměti. Některé zásuvné moduly vyžadují další 2 až 5 MB paměti.

Ovládání multimédií pomocí chování

Na stránku můžete přidat chování spouštějící a zastavující různé multimediální objekty.

Ovladač Shockwave nebo Flash

Umožňuje přehrání, zastavení, převinutí nebo přechod na snímek v soubor filmu Shockwave nebo SWF.

Přehrát zvuk

Umožňuje přehrát zvuk; můžete například přehrát zvukový efekt, když uživatel přesune ukazatel myši přes odkaz.

Zkontrolovat zásuvný modul

Umožňuje kontrolovat, zda mají návštěvníci vaší stránky nainstalovaný požadovaný zásuvný modul, a odkazovat je na různé adresy URL podle toho, zda ho mají nebo ne. To se týká pouze zásuvných modulů, protože chování Zkontrolovat zásuvný modul nekontroluje ovladače ActiveX.

Ovládání multimediálních objektů pomocí parametrů

Definujte zvláštní parametry, které umožní řídit soubory SWF a zásuvné moduly. Parametry se používají s tagy object, embedapplet. Parametry nastavují atributy specifické pro různé typy objektů. Soubor SWF může například používat parametr kvality <paramname="quality"value="best"> pro tag objektu. Dialogové okno Parametr je dostupné v inspektoru Vlastnosti. Informace o parametrech vyžadovaných objektem, který používáte, najdete v dokumentaci.

Poznámka:

Pro určování datových souborů pro ovládací prvky ActiveX neexistuje žádný široce uznávaný standard. V dokumentaci najdete popis parametrů, které lze použít pro používaný widget ActiveX.

Zadání názvu a hodnoty parametru

  1. V okně Dokument vyberte objekt, který může obsahovat parametry.

  2. Otevřete inspektor Vlastnosti (pokud již není otevřený) a klepněte na tlačítko Parametry v dolní polovině inspektoru Vlastnosti. (Zkontrolujte, zda je inspektor Vlastnosti rozbalený.)

  3. Klepněte na tlačítko plus (+) a do příslušných sloupců zadejte název a hodnotu parametru.

Odstranění parametru

  1. Vyberte parametr a stiskněte tlačítko minus (-).

Změna pořadí parametrů

  1. Vyberte parametr a použijte tlačítka s šipkou nahoru a dolů.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online