Naučte se používat panel Soubory ke správě, přenášení a synchronizování souborů a složek mezi místními a vzdálenými místy v aplikaci Dreamweaver. Přečtěte si také další informace o principech funkce Automatické obnovení v aplikaci Dreamweaver.

Panel Soubory v aplikaci Dreamweaver umožňuje přístup k souborům spojeným s vaším webem a jejich správu. Můžete přepínat mezi zobrazením FTP a zobrazením Git v panelu Soubory a spravovat soubory pomocí FTP serveru nebo úložiště Git.

Pokud budete chtít panel Soubory otevřít, klikněte na tlačítko Okno > Soubory nebo stiskněte klávesu F8 (systém Windows) nebo Shift + ⌘ + F (systém Mac).

Poznámka:

Pokud jste webové místo nenastavili, panel Soubory bude jednoduše obsahovat seznam všech jednotek nebo složek ve vašem systému. V takovém případě jej můžete používat pouze pro prohlížení souborů. Soubory nelze přenášet mezi vzdáleným a vaším místním systémem. 

Další informace o výhodách nastavení webu a pokyny pro vytvoření takového webu naleznete v tématu O webech aplikace Dreamweaver.

Čtěte dál a zjistěte, jak používat panel Soubory v každém z těchto zobrazení.

Práce s panelem Soubory v zobrazení FTP

Zobrazení FTP vám umožní zobrazit soubory a složky, kontrolovat, zda jsou připojené k aplikaci Dreamweaver, a provádět standardní operace údržby, například otevírání a přesouvání souborů. Panel Soubory také pomáhá spravovat a přenášet soubory ze vzdáleného serveru a na tento server.

Po nastavení webového místa v aplikaci Dreamweaver můžete panel Soubory používat následovně:

  • přistupovat k webům, serveru a lokálním diskům,
  • zobrazovat soubory a složky,
  • spravovat soubory a složky v panelu Soubory.
  • Synchronizace souborů a složek mezi místním a vzdáleným serverem

Čtěte dál a zjistěte, jak používat panel Soubory v rámci zobrazení FTP.

Možnosti panelu Soubory

V nejjednodušší formě panel Soubory obsahuje seznam výhradně místních souborů ve vašem počítači. Jak budete panel Soubory používat více, tedy nastavovat weby, nastavovat připojení ke vzdáleným serverům, povolovat zpřístupňování nebo vyhrazování, panel Soubory začne nabízet další možnosti.

Panel Soubory může vypadat takto:

  • Pokud není v aplikaci Dreamweaver definován žádný web
  • Pokud je definován web, ale není definován server
  • Pokud je definován web, jsou definována připojení k serveru a je povoleno zpřístupňování a vyhrazování souborů

Informace o definování webu a serveru naleznete v tématu O webech aplikace Dreamweaver.

Pokud není v aplikaci Dreamweaver definován žádný web

Vzhled panelu Soubory, pokud není v aplikaci Dreamweaver definován žádný web
Vzhled panelu Soubory, pokud není v aplikaci Dreamweaver definován žádný web

Pokud je definován web, ale není definován server

Během definování webu v aplikaci Dreamweaver se zobrazí soubory na vašem webu. Panel Soubory obsahuje také tlačítko Definovat servery, které otevře výzvu pro definování připojení ke vzdálenému a testovacímu serveru.

Vzhled panelu Soubory, pokud je v aplikaci Dreamweaver definován web, ale nejsou definovány servery
Vzhled panelu Soubory, pokud je v aplikaci Dreamweaver definován web, ale nejsou definovány servery

Pokud je definován web i servery a je povoleno zpřístupňování a vyhrazování

Po definování webu a serveru jsou vám k dispozici všechny možnosti na panelu Soubory. Pokud povolíte zpřístupnění a vyhrazení, budou vám dostupné i tyto možnosti.

Získejte další informace o možnostech panelu Soubory.

Další informace o povolení zpřístupnění a vyhrazení naleznete v tématu Zpřístupnění/vyhrazení souborů.

Vzhled panelu Soubory, když je definován web, nastaveno připojení ke vzdálenému serveru a povoleno zpřístupňování a vyhrazování
Vzhled panelu Soubory, když je definován web, nastaveno připojení ke vzdálenému serveru a povoleno zpřístupňování a vyhrazování

A. Rozbalovací nabídka Webové místo B. Zobrazení souborů C. Připojení ke vzdálenému serveru D. Získání souborů ze vzdáleného serveru E. Vložení souborů na vzdálený server F. Vyhrazení souborů G. Zpřístupnění souborů H. Synchronizace se vzdáleným serverem I. Rozbalit/sbalit J. Aktualizovat K. Operace se soubory 

Panel Soubory můžete přesunout podle potřeby a nastavit jeho předvolby.

Poznámka:

Zobrazení Soubory webového místa, Testovací server a tlačítko Synchronizovat se zobrazí pouze v rozbaleném panelu Soubory.

Rozbalovací nabídka Webové místo

Umožňuje vybrat webové místo aplikace Dreamweaver a zobrazit soubory tohoto místa. Ke všem souborům na lokálním disku můžete přistupovat také pomocí nabídky Web. Je to jednodušší než pomocí aplikace Průzkumník Windows (systém Windows) nebo aplikace Finder (systém Mac).

Zobrazení souborů

Umožňuje zobrazit soubory umístěné v kořenové složce místního, vzdáleného nebo testovacího serveru. Po výběru možnosti z rozbalovací nabídky se zobrazí soubory v odpovídajícím zobrazení.

Připojení ke vzdálenému serveru

(protokol FTP, RDS a WebDAV) Slouží k připojení ke vzdálenému webovému místu nebo odpojení od něj. Aplikace Dreamweaver se standardně odpojí od vzdáleného webového místa při nečinnosti trvající déle než 30 minut (pouze FTP). Chcete-li změnit tento časový limit, vyberte volbu Úpravy > Předvolby (Windows) nebo Dreamweaver > Předvolby (Macintosh) a vlevo v seznamu kategorií vyberte volbu Webové místo.

Získání souborů ze vzdáleného serveru

Zkopíruje vybrané soubory ze vzdáleného webového místa do lokálního webového místa (přepíše existující lokální kopii souboru). Pokud je povoleno Zapnout zpřístupňování a vyhrazování souborů, lokální kopie jsou pouze pro čtení; soubory zůstávají ve vzdáleném webovém místě přístupné pro vyhrazení ostatními členy týmu. Pokud je možnost Zapnout zpřístupňování a vyhrazování souborů vypnutá, kopie souborů budou mít práva pro čtení i zápis.

Vložení souborů na vzdálený server

Zkopíruje vybrané soubory z lokálního webového místa do vzdáleného webového místa.

Vyhrazení souborů

Přenese kopii souboru ze vzdáleného serveru do lokálního webového místa (přepíše existující lokální kopii souboru) a na serveru označí soubor jako vyhrazený. Pokud není pro aktuální webové místo povolena možnost Zapnout zpřístupňování a vyhrazování souborů, tato možnost není dostupná.

Zpřístupnění souborů

Přenese kopii lokálního souboru do vzdáleného serveru a nastaví soubor na přístupný pro úpravy pro všechny uživatele. Lokální‎ soubor se změní na pouze pro čtení. Pokud není pro aktuální webové místo povolena možnost Zapnout zpřístupňování a vyhrazování souborů, tato možnost není dostupná.

Synchronizovat se vzdáleným serverem

Synchronizuje soubory mezi lokálními a vzdálenými složkami.

Rozbalit/sbalit

Rozbalí nebo sbalí panel Soubory, aby zobrazoval jeden nebo dva panely. V rámci rozšířeného zobrazení je k dispozici další možnost Zobrazit záznam FTP webového místa. Když je panel Soubory sbalený, zobrazuje obsah lokálního webového místa, vzdáleného webového místa nebo testovacího serveru jako seznam souborů. Když je panel rozbalený, obsahuje místní webové místo a vzdálené webové místo nebo testovací server.

Aktualizovat

Obnoví seznamy lokálních a vzdálených adresářů. Pokud jste v dialogovém okně Definice webového místa odznačili volbu Automaticky aktualizovat seznam lokálních souborů nebo volbu Automaticky aktualizovat seznam vzdálených souborů, pomocí tohoto tlačítka obnovíte seznamy adresářů.

Operace se soubory

Zobrazení aktivit souboru na pozadí.

Možnost Zobrazit záznam FTP webového místa je k dispozici po rozbalení panelu Soubory kliknutím na ikonu Rozbalit/sbalit.

Zobrazit záznam FTP webového místa

V dílčích panelech panelu Soubory zobrazuje strukturu souborů vzdálených i lokálních webových míst. (Nastavení předvoleb určuje, které webové místo se zobrazí v levém panelu a které v pravém.) Výchozím zobrazením panelu Soubory je zobrazení Soubory webového místa.

Poznámka:

Aplikace Dreamweaver zkopíruje soubory, které jste vybrali v aktivním dílčím panelu v panelu Soubory. Pokud je aktivní dílčí panel Vzdálené, vybrané soubory vzdálených nebo testovacích serverů se zkopírují do lokálního webového místa; pokud je aktivní panel Lokální, aplikace Dreamweaver zkopíruje verze souborů vzdáleného nebo testovacího serveru vybraných lokálních souborů do lokálního webového místa.

Poznámka:

Aplikace Dreamweaver zkopíruje soubory, které jste vybrali v aktivním dílčím panelu v panelu Soubory. Pokud je aktivní dílčí panel Lokální, vybrané lokální soubory se zkopírují do vzdáleného webového místa nebo testovacího serveru; pokud je aktivní dílčí panel Vzdálené, aplikace Dreamweaver zkopíruje lokální verze vybraných souborů vzdáleného serveru do vzdáleného webového místa.

Pokud odesíláte soubor, který ještě ve vzdáleném webovém místě neexistuje, a je povolena volba Zapnout zpřístupňování a vyhrazování souborů, soubor se do vzdáleného webového místa přidá jako „vyhrazený“. Chcete-li přidat soubor jako nevyhrazený, klepněte na tlačítko Zpřístupnit soubory.

Zobrazení souborů a složek

Pomocí panelu Soubory můžete zobrazit soubory a složky spojené i nespojené s webovým místem aplikace Dreamweaver. Když v panelu Soubory zobrazujete webová místa, soubory nebo složky, můžete měnit velikost zobrazovací oblasti a pro webová místa aplikace Dreamweaver můžete rozbalit nebo sbalit panel Soubory.

v panelu Soubory můžete pro weby aplikace Dreamweaver také nastavit, které weby – lokální nebo vzdálené – se standardně zobrazí ve sbaleném panelu. Pomocí možnosti Vždy zobrazit můžete přepnout zobrazení obsahu v rozbaleném panelu Soubory.

Vyhledávání souborů na panelu Soubory (pouze pro uživatele systému Mac OS a služby Creative Cloud)

Pomocí funkce Hledání Live můžete vyhledávat soubory podle názvu nebo textu, který obsahují. Vyhledávání probíhá na webu vybraném na panelu Soubory. Pokud na tomto panelu není žádný web uveden, funkce vyhledávání se nezobrazí. Další informace naleznete v části Hledání souborů podle názvu nebo obsahu.

Změna velikosti zobrazovací oblasti v rozbaleném panelu Soubory

Panel Soubory (Okno > Soubory) rozbalte a přetažením pruhu oddělujícího obě zobrazení zvětšete nebo zmenšete zobrazovací oblast pravého nebo levého panelu.

Změna zobrazení webového místa v panelu Soubory (pouze webová místa aplikace Dreamweaver)

Pomocí panelu Soubory můžete zobrazit soubory umístěné v kořenové složce místního, vzdáleného nebo testovacího serveru.

Ve sbaleném panelu Soubory (Okno > Soubory) vyberte z rozbalovací nabídky Zobrazení webového místa položku Lokální zobrazení, Vzdálený server nebo Testovací server.

Ve výchozím nastavení se v nabídce Zobrazení webového místa zobrazí lokální zobrazení.

Zobrazení souborů v kořenovém adresáři místního/vzdáleného webu nebo testovacího serveru
Zobrazení souborů v kořenovém adresáři místního/vzdáleného webu nebo testovacího serveru

Zobrazení souborů mimo webové místo aplikace Dreamweaver

Pomocí rozbalovací nabídky Web vyhledejte počítač podobně jako v aplikaci Průzkumník Windows (systém Windows) nebo Finder (systém Macintosh).

Práce se soubory v zobrazení FTP

Soubory můžete otevřít nebo přejmenovat, přidat, odebrat nebo odstranit, nebo panel Soubory po provedení změn obnovit.

Pro webová místa aplikace Dreamweaver můžete také určit, které soubory (v lokálním nebo vzdáleném webovém místě) byly aktualizovány od posledního přenosu.

Otevření souboru

  1. v panelu Soubory (Okna > Soubory) vyberte z rozbalovací nabídky (kde se zobrazuje aktuální webové místo, server nebo disk) webové místo, server nebo disk.
  2. Vyhledejte soubor, který chcete otevřít.
  3. Proveďte jeden z následujících úkonů:
    • Poklepejte na ikonu souboru.

    • Klepněte pravým tlačítkem (Windows) nebo s klávesou Ctrl (Macintosh) na ikonu souboru a vyberte volbu Otevřít.

      Aplikace Dreamweaver otevře soubor v okně Dokument.

Vytvoření souboru nebo složky

  1. v panelu Soubory (Okna > Soubory) vyberte soubor nebo složku.

    Aplikace Dreamweaver vytvoří nový soubor nebo složku v aktuálně vybrané složce nebo ve stejné složce, kde je aktuálně vybraný soubor.

  2. Klepněte pravým tlačítkem (Windows) nebo s klávesou Ctrl (Macintosh) a vyberte volbu Nový soubor nebo Nová složka.
  3. Zadejte název nového souboru nebo složky.
  4. Stiskněte klávesu Enter (Windows) nebo Return (Macintosh).

Odstranění souboru nebo složky

  1. v panelu Soubory (Okna > Soubory) vyberte soubor nebo složku, kterou chcete odstranit.
  2. Klepněte pravým tlačítkem (Windows) nebo klepněte se stisknutou klávesou Ctrl (Macintosh) a vyberte možnosti Úpravy > Odstranit.

Přejmenování souboru nebo složky

  1. v panelu Soubory (Okna > Soubory) vyberte soubor nebo složku, kterou chcete přejmenovat.
  2. Chcete-li aktivovat název souboru nebo složky, proveďte jeden z následujících úkonů:
    • Klepněte na název souboru, chvíli počkejte a pak klepněte ještě jednou.

    • Klepněte pravým tlačítkem (Windows) nebo klepněte se stisknutou klávesou Ctrl (Macintosh) na ikonu souboru a vyberte možnosti Úpravy > Přejmenovat.

  3. Zadejte nový název místo existujícího.
  4. Stiskněte klávesu Enter (Windows) nebo Return (Macintosh).

Přemístění souboru nebo složky

  1. v panelu Soubory (Okna > Soubory) vyberte soubor nebo složku, kterou chcete přemístit.
  2. Proveďte jeden z následujících úkonů:
    • Zkopírujte soubor nebo složku a vložte ho do nového umístění.

    • Přetáhněte soubor nebo složku do nového umístění.

  3. Chcete-li zobrazit soubor nebo složku v novém umístění, obnovte panel Soubory.

Obnovení panelu Soubory

Pokud budete chtít zobrazení v panelu Soubory načíst znovu, proveďte jeden z následujících úkonů:

  • Klikněte pravým tlačítkem (Windows) nebo s klávesou Ctrl (Macintosh) na soubor nebo složku a vyberte volbu Obnovit.
  • (Pouze webová místa aplikace Dreamweaver) v panelu nástrojů panelu Soubory klikněte na tlačítko Obnovit (tato volba obnoví oba panely).

Poznámka:

Aplikace Dreamweaver obnoví panel Soubory, když provedete změny v jiné aplikaci a vrátíte se do aplikace Dreamweaver.

Hledání souborů ve webovém místě aplikace Dreamweaver

Aplikace Dreamweaver usnadňuje hledání vybraných, otevřených, vyhrazených nebo nedávno změněných souborů ve webovém místě. Také můžete hledat novější soubory v lokálním nebo vzdáleném webovém místě.

Hledání otevřených souborů ve webovém místě

  1. Otevřete soubor v okně dokumentu.
  2. Vyberte volbu Webové místo > Vyhledat ve webovém místě.

    Aplikace Dreamweaver vybere soubor na panelu Soubory.

    Poznámka:

    Pokud není dokument otevřený v okně dokumentu součástí aktuálního webového místa v panelu Soubory, aplikace Dreamweaver se pokusí určit, ke kterému z webových míst aplikace Dreamweaver soubor patří; pokud aktuální soubor patří pouze jednomu lokálnímu webovému místu, aplikace Dreamweaver otevře toto webové místo v panelu Soubory a soubor zvýrazní.

Vyhledání a výběr vyhrazených souborů ve webovém místě aplikace Dreamweaver

Ve sbaleném panelu Soubory (Okna > Soubory) klikněte v pravém horním rohu na nabídku Volby a vyberte volbu Úpravy > Vybrat vyhrazené soubory.

Aplikace Dreamweaver vybere soubory na panelu Soubory.

Hledání vybraného souboru v lokálním nebo vzdáleném webovém místě

  1. v panelu Soubory vyberte soubor v zobrazení Lokální nebo Vzdálené (Okna > Soubory).
  2. Klikněte pravým tlačítkem (systém Windows) nebo s klávesou Ctrl (systém Mac) a vyberte možnost Vyhledat v lokálním webovém místě nebo Vyhledat na vzdáleném serveru (podle toho, kde jste soubor vybrali).

    Aplikace Dreamweaver vybere soubor na panelu Soubory.

Vyhledání a výběr souborů novějších v lokálním webovém místě než ve vzdáleném webovém místě

Ve sbaleném panelu Soubory (Okna > Soubory) klepněte v pravém horním rohu na nabídku Volby a vyberte volbu Úpravy > Vybrat novější lokální.

Aplikace Dreamweaver vybere soubory na panelu Soubory.

Vyhledání a výběr souborů novějších ve vzdáleném webovém místě než v lokálním webovém místě

Ve sbaleném panelu Soubory (Okna > Soubory) klepněte v pravém horním rohu na nabídku Volby a vyberte volbu Úpravy > Vybrat novější vzdálené.

Aplikace Dreamweaver vybere soubory na panelu Soubory.

Hledání nedávno změněných souborů ve webovém místě

  1. Ve sbaleném panelu Soubory (Okna > Soubory) klepněte v pravém horním rohu na nabídku Volby a vyberte volbu Úpravy > Vybrat nedávno změněné.
  2. Chcete-li určit data vyhledávání pro vytvoření zprávy, proveďte jeden z následujících úkonů:
    • Chcete-li vytvořit zprávu o všech souborech změněných v posledních dnech, vyberte volbu Soubory vytvořené nebo upravené v posledních a do pole zadejte číslo.

    • Chcete-li vytvořit zprávu o všech souborech upravených v určitém časovém období, klikněte na přepínač Soubory vytvořené nebo změněné mezi a určete rozsah dat.

    Vyhledání nedávno upravených souborů
    Vyhledání nedávno upravených souborů

  3. (Volitelné) Chcete-li omezit vyhledávání v daném období na soubory změněné určitým uživatelem, do pole Změnil zadejte uživatelské jméno.

    Poznámka:

    Tato volba je dostupná pouze pro zprávy o webových místech Contribute.

  4. Pokud je to nutné, určete pomocí přepínače, kde se mají zobrazit soubory vypsané ve zprávě:

    Lokální počítač

    Pokud webové místo obsahuje statické stránky.

    Testovací server

    Pokud webové místo obsahuje dynamické stránky.

    Jiné umístění

    Pokud chcete do textového pole zadat cestu.

    Poznámka:

    Tato možnost předpokládá, že jste definovali testovací server v dialogovém okně Definice webového místa. Pokud jste nedefinovali testovací server a nezadali prefix URL tohoto serveru nebo vytváříte zprávu pro více než jedno webové místo, je tato možnost nedostupná.

  5. Kliknutím na tlačítko OK uložte provedené nastavení.

    Aplikace Dreamweaver v panelu Soubory zvýrazní soubory, které byly změněny v daném časovém období.

Identifikace a odstranění nepoužívaných souborů

Soubory, které už nejsou používány ostatními soubory ve webovém místě, můžete nalézt a odstranit.

  1. Vyberte možnost Web > Možnosti webu > Zkontrolovat odkazy v celém webu.

    Aplikace Dreamweaver zkontroluje všechny odkazy ve webovém místě a zobrazí přerušené odkazy v panelu Výsledky.

  2. Z nabídky v panelu Kontrola odkazů vyberte volbu Osamocené soubory.
    Zobrazení osamocených souborů – souborů bez příchozích odkazů
    Zobrazení osamocených souborů – souborů bez příchozích odkazů

    Aplikace Dreamweaver zobrazí všechny soubory, na které nevedou žádné odkazy. To znamená, že žádný ze souborů ve webovém místě neodkazuje na tyto soubory.

  3. Vyberte soubory, které chcete odstranit, a stiskněte klávesu Delete.

    Poznámka:

    Přestože na tyto soubory nevede odkaz z žádných jiných souborů, některé z těchto souborů mohou obsahovat odkazy na jiné soubory. Při jejich odstraňování proto buďte opatrní.

Přístup k webům, serveru a lokálním diskům

K souborům a složkám ve webovém místě aplikace Dreamweaver můžete přistupovat, měnit je a ukládat, stejně jako soubory a složky, které nepatří do webového místa aplikace Dreamweaver. Kromě webových míst aplikace Drive máte přístup k serveru, lokálnímu disku nebo pracovní ploše.

Než budete moci přistupovat ke vzdálenému serveru, musíte aplikaci Dreamweaver pro práci s tímto serverem nastavit.

Poznámka:

Vytvoření webového místa aplikace Dreamweaver je nejlepší způsob správy souborů. Informace o výhodách vytvoření webu a informace o tom, jak web vytvořit, naleznete zde: O webech aplikace Dreamweaver.

Otevření existujícího webového místa aplikace Dreamweaver

v panelu Soubory (Okna > Soubory) vyberte z nabídky (kde se zobrazuje aktuální webové místo, server nebo disk) webové místo.
Otevření existujícího webového místa aplikace Dreamweaver
Otevření existujícího webového místa aplikace Dreamweaver

Otevření složky na vzdáleném serveru FTP nebo RDS

  1. v panelu Soubory (Okna > Soubory) vyberte z nabídky (kde se zobrazuje aktuální webové místo, server nebo disk) název serveru.

    Poznámka:

    Zobrazí se názvy serverů, pro které byla aplikace Dreamweaver nastavena.

  2. Vyhledejte a upravte soubory, jak jste normálně zvyklí.

Přístup k lokálnímu disku nebo pracovní ploše

  1. v panelu Soubory (Okna > Soubory) z nabídky (kde se zobrazuje aktuální webové místo, server nebo disk) vyberte volbu Pracovní plocha, Lokální disk nebo Jednotka CD.
  2. Vyhledejte soubor a pak proveďte libovolné z následujících úkonů:
    • otevřete soubory v aplikaci Dreamweaver nebo jiné aplikaci,
    • přejmenujte soubory,
    • zkopírujte soubory,
    • odstraňte soubory,
    • přetáhněte soubory.
      • Když přetahujete soubory z jednoho webového místa aplikace Dreamweaver do jiného nebo do složky, která není součástí webového místa aplikace Dreamweaver, aplikace Dreamweaver zkopíruje tento soubor do umístění, kam jste ho přetáhli. 
      • Pokud přetahujete soubor v rámci webového místa aplikace Dreamweaver, aplikace Dreamweaver přesune soubor do umístění, kam jste ho přetáhli. 
      • Pokud přetahujete soubor, který není součástí webového místa aplikace Dreamweaver, do složky, která není součástí webového místa aplikace Dreamweaver, aplikace Dreamweaver přesune soubor do umístění, kam jste ho přetáhli.

    Poznámka:

    Chcete-li přesunout soubor, který aplikace Dreamweaver standardně kopíruje, podržte při přetahování stisknutou klávesu Shift (Windows) nebo Cmd (Macintosh). Chcete-li zkopírovat soubor, který aplikace Dreamweaver standardně přesunuje, podržte při přetahování stisknutou klávesu Ctrl (Windows) nebo Alt (Macintosh).

Přizpůsobení zobrazení podrobností souborů a složek na panelu Soubory

Když zobrazíte webové místo aplikace Dreamweaver na panelu Soubory, ve výchozím nastavení se zobrazí pouze struktura souborů a složek. Podle potřeby však můžete vzhled panelu Soubory přizpůsobit a zobrazit v něm i následující podrobnosti:

  • Poznámky
  • Velikost
  • Typ
  • Datum poslední změny souboru
  • Podrobnosti o vyhrazení
Pokud budete chtít tyto sloupce zahrnout do zobrazení na panelu Soubory, klikněte pravým tlačítkem na panel nástrojů a vyberte možnosti, které chcete zobrazit.
Zobrazení a skrytí podrobností o souborech a složkách na panelu Soubory
Zobrazení a skrytí podrobností o souborech a složkách na panelu Soubory

V dialogovém okně Správa webových míst > Rozšířená nastavení > Sloupce zobrazení souborů můžete provést některá další přizpůsobení sloupců:

Přizpůsobení sloupců zobrazení souboru v dialogovém okně Správa webových míst > Rozšířená nastavení > Sloupce zobrazení souborů
Přizpůsobení sloupců zobrazení souboru v dialogovém okně Správa webových míst > Rozšířená nastavení > Sloupce zobrazení souborů

Změna pořadí sloupců

V nabídce Správa webových míst > Rozšířená nastavení > Sloupce zobrazení souborů vyberte název sloupce a kliknutím na tlačítko se šipkou nahoru nebo dolů upravte polohu vybraného sloupce.

Poznámka:

Můžete změnit pořadí libovolného sloupce kromě sloupce Název, který je vždy první.

Přidání, odstranění nebo změna podrobností o sloupcích

  1. Vyberte volbu Web > Správa webů.
  2. Vyberte webové místo a klepněte na tlačítko Upravit.
  3. Rozbalte možnost Další nastavení a vyberte kategorii Sloupce zobrazení souborů.
  4. Vyberte sloupec a kliknutím na tlačítko plus (+) sloupec přidejte.

  5. Do pole Název sloupce zadejte název sloupce.
    Přidání vlastních sloupců
    Přidání vlastních sloupců

  6. Vyberte hodnotu z nabídky Přiřadit k poznámkám k návrhu nebo zadejte vlastní.

    Poznámka:

    Nový sloupec musíte přiřadit k poznámce k návrhu, aby se data zobrazila v panelu Soubory.

  7. Vyberte zarovnání, abyste určili, jak bude text ve sloupci zarovnán.
  8. Chcete-li sloupec zobrazit nebo skrýt, vyberte nebo odznačte volbu Zobrazit.
  9. Chcete-li sdílet sloupec se všemi uživateli připojenými k danému vzdálenému webovému místu, vyberte volbu Sdílet se všemi uživateli tohoto webového místa.

Chcete-li sloupec odstranit, vyberte jej a klikněte na tlačítko minus (-). 

Poznámka:

Sloupec se odstraní okamžitě a bez dalšího potvrzení, ujistěte se proto před kliknutím na tlačítko minus (-), že sloupec opravdu chcete odstranit.

Uspořádání sloupců na panelu Soubory

Na panelu Soubory klikněte na záhlaví sloupce, podle kterého chcete údaje uspořádat.

Poznámka:

Chcete-li uspořádat sloupec opačně, než ho uspořádala aplikace Dreamweaver, klikněte na záhlaví sloupce znovu (přepíná se uspořádání vzestupně nebo sestupně).

Automatické obnovení souborů

Jestliže bude aplikace Dreamweaver neočekávaně ukončena z důvodu chyby systému, výpadku napájení nebo kvůli jiným problémům, můžete obnovit všechny neuložené změny provedené v souborech, na kterých jste pracovali.

Funkce automatické obnovení automaticky zálohuje všechny neuložené soubory v aplikaci Dreamweaver. Pokud dojde k chybě, zobrazí se při dalším spuštění aplikace Dreamweaver následující dialogové okno.

Poznámka:

Soubor musel být uložený alespoň jednou, aby ho aplikace Dreamweaver mohla obnovit.

Automatické obnovení v aplikaci Dreamweaver
Automatické obnovení v aplikaci Dreamweaver

Při otevření aplikace Dreamweaver po pádu můžete obnovit, nebo zrušit poslední změny souboru:

  • Obnovit – pomocí této volby můžete otevřít automaticky uloženou verzi souboru
  • Zrušit – pomocí této volby můžete otevřít poslední uloženou verzi souboru

Poznámka:

Automatické ukládání v aplikaci Dreamweaver probíhá přibližně každých pět sekund (v závislosti na operačním systému).

Práce s panelem Soubory v zobrazení Git

Zobrazení Git v panelu Soubory umožňuje připojení k úložišti Git a správu souborů pomocí úložiště Git. Panel Soubory funguje jako rozhraní k provádění různých operací jako potvrzení, vytvoření a zrušení fáze, přidání do gitignore atd.

Zobrazení Git můžete použít k provádění následujících činností:

  • Zobrazení souborů souvisejících s webovým místem, v úložišti Git
  • Synchronizace souborů a složek mezi vaším místním úložištěm a úložištěm Git
  • Zobrazení nesledovaných, připravených a potvrzených souborů
  • Přístup k terminálu Git

Úložiště Git lze také spustit z tohoto panelu, pokud se tak již nestalo. Při vytváření webu v aplikaci Dreamweaver můžete přiřadit úložiště Git k vašemu webu. Pokud jste to neučinili při vytváření webu, můžete inicializovat úložiště Git pomocí panelu Soubory.

Chcete-li inicializovat úložiště, klikněte na možnost Inicializovat úložiště Git z panelu Soubory. Soubory spojené s vaším webem jsou okamžitě viditelné v zobrazení Git spolu s jejich stavem.

Inicializujte úložiště Git z panelu Soubory.
Inicializujte úložiště Git z panelu Soubory.

Sledujte stav souborů.

Stav souborů spojených s úložištěm Git můžete zobrazit z panelu Soubory. Při inicializaci úložiště Git jsou soubory zobrazeny zeleně. To znamená, že soubory nejsou sledovány a v úložišti Git ještě neexistují.

Při potvrzení souboru se soubor zobrazí v panelu Soubory bíle. To znamená, že soubor byl potvrzen v úložišti Git, které jste si vybrali. 

Nyní, když upravíte a uložíte soubor po potvrzení, se barva souboru v panelu Soubory změní na žlutou. To znamená, že soubory ve vašem úložišti a v úložišti Git nejsou synchronizovány.

Další informace o pracovním postupu správy verzí v úložišti Git naleznete v části Používání systému Git pro správu verzí.

Vytváření a správa větví

Můžete vytvářet a spravovat větve lokálně pomocí panelu Soubory. Chcete-li vytvořit větev, vyberte rozevírací seznam v horní části panelu. Klikněte na Spravovat větve a poté na znak + v dialogovém okně Spravovat větve.

Můžete zvolit původní větev a vytvořit novou větev. Také můžete odstranit větev a sloučit jednu větev s jinou.

Chcete-li se dozvědět více o správě místních větví pomocí panelu Soubory, viz část Vytvořit a spravovat větve.

Provádění základních akcí úložiště Git

Kromě inicializaci a správy větví, můžete z panelu Soubory také provádět různé akce úložiště Git. Z panelu Soubory vyberte soubor, klikněte pravým tlačítkem myši a proveďte jednu z následujících akcí:

  • Klepněte na tlačítko Přidat do .gitignore a přidejte do složky gitignore vybraný soubor nebo soubory. S těmito soubory nebude úložiště Git manipulovat a nebudou na nich prováděny žádné akce.
  • Klikněte na tlačítko odebrat z .gitignore, chcete-li odstranit soubor ze složky gitignore.
  • Klikněte na možnost Fáze, chcete-li fázovat vybraný soubor. Vytvoření fází je jeden krok za potvrzením souboru v úložišti Git.
  • Klepněte na tlačítko Zrušit fázi, chcete-li odstranit soubor z fáze.
  • Klepněte na možnost Fázovat vše, chcete-li fázovat všechny soubory v úložišti.
  • Klepněte na možnost Zrušit všechny fáze, chcete-li zrušit fáze všech souborů v úložišti.
  • Klepněte na tlačítko Diff, chcete-li zobrazit změny v souboru mezi předchozím provedením a aktuální verzí.
  • Klikněte na možnost Historie souboru a potvrďte historii změn a akcí vybraného souboru.
  • Klepnutím na tlačítko Obnovit soubor odvoláte všechny změny provedené v souboru a obnovíte předchozí potvrzenou verzi.
  • Klepnutím na tlačítko Potvrdit všechny fáze potvrdíte soubory, které jste fázovali, z tohoto úložiště.
Z panelu Soubory můžete provést akce úložiště Git.
Z panelu Soubory můžete provést akce úložiště Git.

Chcete-li se dozvědět více o každé z těchto akcí a o úložišti Git v aplikaci Dreamweaver, přečtěte si část Použití úložiště Git v aplikaci Dreamweaver.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online