Získejte další informace o použití tabulek za účelem prezentace obsahu vašeho webu. Zároveň se naučte rozdělovat a slučovat buňky tabulky a importovat nebo exportovat tabulková data.

Tabulky jsou účinné nástroje pro zobrazení tabulkových dat a rozvržení textu a grafiky na stránce HTML. Tabulka je tvořena jedním nebo více řádky; každý řádek se skládá z jedné nebo více buněk. Přestože sloupce nejsou obvykle v kódu HTML jednoznačně určeny, aplikace Dreamweaver umožňuje pracovat se sloupci stejně jako s řádky a buňkami.

Aplikace Dreamweaver zobrazí šířku tabulky a šířku sloupce pro každý sloupec tabulky pokaždé, když je tabulka vybrána, nebo když je v tabulce textový kurzor. Vedle hodnot šířky se nachází šipky nabídky záhlaví tabulky a nabídky záhlaví sloupce. Nabídky nabízí rychlý přístup k často používaným příkazům pro práci s tabulkami. Zobrazení hodnot šířky a nabídek můžete zapnout nebo vypnout.

Pokud nevidíte šířku tabulky nebo sloupce, pak tabulka nebo sloupec nemá v kódu HTML určenou šířku. Pokud jsou zobrazena dvě čísla, pak viditelná šířka zobrazená v zobrazení Návrh nesouhlasí se šířkou zadanou v kódu HTML. K tomu může dojít, když změníte velikost tabulky přetažením pravého dolního rohu nebo když přidáte do buňky obsah, který je větší než nastavená šířka buňky.

Pokud například nastavíte šířku sloupce na 200 obrazových bodů a vložíte obsah, který roztáhne šířku sloupce na 250 obrazových bodů, zobrazí se pro tento sloupec dvě čísla: 200 (šířka zadaná v kódu) a (250) v závorkách (viditelná šířka sloupce zobrazená na obrazovce).

Poznámka:

Rozvržení stránek můžete také vytvářet pomocí CSS.

Priority formátování tabulek v HTML

Při formátování tabulek v zobrazení Návrh můžete nastavit vlastnosti celé tabulky nebo vybraných řádků, sloupců nebo buněk v tabulce. Když je vlastnost, například barva pozadí nebo zarovnání, nastavena na jednu hodnotu pro celou tabulku a jiná hodnota dané vlastnosti je nastavena pro jednotlivé buňky, formátování buňky má přednost před formátováním řádku, které má zase přednost před formátováním tabulky.

Pořadí priority formátování tabulky je následující:

  1. Buňky
  2. Řádky
  3. Tabulka

Pokud například nastavíte jako barvu pozadí jedné buňky modrou barvu a pak nastavíte jako barvu pozadí celé tabulky žlutou, modrá buňka se nezmění na žlutou, protože formátování buňky má přednost před formátováním tabulky.

Poznámka:

Když nastavíte vlastnosti sloupce, aplikace Dreamweaver změní podle toho atributy tagu td všech buněk ve sloupci.

O slučování a rozdělování buněk

Sloučením libovolného počtu sousedních buněk – pokud celý výběr tvoří přímý úsek nebo obdélník buněk – můžete vytvořit jednu buňku, která přesahuje přes několik sloupců nebo řádků. Buňku můžete rozdělit na libovolný počet řádků nebo sloupců bez ohledu na to, zda byla před tím sloučena. Aplikace Dreamweaver automaticky znovu uspořádá tabulku (přidáním potřebných atributů colspan nebo rowspan), aby vytvořil požadované uspořádání.

V následujícím příkladu byly buňky v prostředním sloupci prvních dvou řádků sloučeny do jedné buňky zasahující do dvou řádků.

Sloučené buňky
Sloučené buňky

Vložení tabulky a přidání obsahu

Pomocí panelu Vložit nebo nabídky Vložit vytvořte novou tabulku. Pak vložte text a obrazy do buněk tabulky stejným způsobem, jako jste vkládali text a obrázky mimo tabulku.

  1. Umístěte textový kurzor na místo, kde se má tabulka zobrazit.

    Poznámka:

    Pokud je dokument prázdný, můžete umístit textový kurzor pouze na začátek dokumentu.

    • Vyberte možnost Vložit > Tabulka.

    • V kategorii HTML na panelu Vložit klikněte na položku Tabulka.

  2. Nastavte atributy v dialogovém okně Tabulka a kliknutím na tlačítko OK vytvořte tabulku.
    Vytvoření tabulky
    Vytvoření tabulky

    Řádky

    Určuje počet řádků tabulky.

    Sloupce

    Určuje počet sloupců tabulky.

    Šířka tabulky

    Určuje šířku tabulky v obrazových bodech nebo v procentech šířky okna prohlížeče.

    Tloušťka okraje

    Určuje šířku okraje tabulky v obrazových bodech.

    Mezery buněk

    Určuje počet obrazových bodů mezi sousedními buňkami tabulky.

    Poznámka:

    Když neurčíte jednoznačně hodnoty tloušťky okraje nebo mezer buněk a odsazení buněk, většina prohlížečů zobrazí tloušťku okraje tabulky a odsazení buněk s hodnotou 1 obrazový bod a mezery buněk s hodnotou 2 obrazové body. Chcete-li se ujistit, že prohlížeče zobrazují tabulku bez okrajů, odsazení nebo mezer, nastavte hodnoty Odsazení buňky a Mezery buněk na 0.

    Odsazení buňky

    Určuje počet obrazových bodů mezi okrajem buňky a jejím obsahem.

    Žádné

    Vypíná záhlaví sloupce nebo řádku v tabulce.

    Doleva

    Nastaví první sloupec tabulky jako sloupec záhlaví, abyste mohli zadat záhlaví každého řádku tabulky.

    Nahoru

    Nastaví první řádek tabulky jako řádek záhlaví, abyste mohli zadat záhlaví každého sloupce tabulky.

    Obojí

    Umožňuje zadat záhlaví sloupců a řádků v tabulce.

    Poznámka:

    Záhlaví je vhodné používat v případě, že návštěvníci stránek používají programy pro čtení z obrazovky. Programy pro čtení z obrazovky čtou záhlaví tabulky a pomáhají uživatelům udržovat přehled o informacích v tabulce.

    Popisek

    Titulek tabulky, který se zobrazí mimo tabulku.

    Přehled

    Obsahuje popis tabulky. Text přehledu je čten pouze programy pro čtení z obrazovky, ale nezobrazí se v prohlížeči.

Import a export tabulek

Tabulková data vytvořená v jiné aplikaci (například Microsoft Excel) a uložená ve formátu textu s oddělovači (s položkami oddělenými tabulátory, čárkami, dvojtečkami nebo středníky) můžete importovat do aplikace Dreamweaver a formátovat je jako tabulku.

Také můžete exportovat data tabulky z aplikace Dreamweaver do textového souboru, ve kterém je obsah sousedních buněk oddělen oddělovači. Jako oddělovače můžete použít čárky, dvojtečky, středníky nebo mezery. Při exportu tabulky se exportuje celá tabulka; nelze exportovat pouze části tabulky.

Poznámka:

Pokud chcete použít pouze některá data v tabulce – například prvních šest řádků nebo prvních šest sloupců – zkopírujte příslušné buňky obsahující požadovaná data, vložte tyto buňky mimo tabulku (vytvoří se nová tabulka) a exportujte tuto novou tabulku.

Import dat tabulky

  1. Vyberte možnost Soubor > Import > Importovat tabulková data.

  2. Určete volby tabulkových dat a klikněte na tlačítko OK.

    Datový soubor

    Název souboru, který se má importovat. Klepnutím na tlačítko Procházet vyberte soubor.

    Oddělovač

    Oddělovač použitý v importovaném souboru.

    Pokud vyberete Jiný, napravo od rozbalovací nabídky se zobrazí textové pole. Zadejte oddělovač použitý v souboru.

    Poznámka:

    Určete oddělovač, který byl použit při uložení datového souboru. Pokud to neuděláte, soubor se neimportuje správně a data nebudou v tabulce správně formátována.

    Šířka tabulky

    Šířka tabulky

    • Výběrem volby Přizpůsobit datům nastavíte šířku sloupců podle nejdelšího textového řetězce ve sloupci.

    • Výběrem volby Nastavit určíte pevnou šířku tabulky v obrazových bodech nebo jako hodnotu v procentech šířky okna prohlížeče.

    Okraj

    Určuje šířku okraje tabulky v obrazových bodech.

    Odsazení buňky

    Počet obrazových bodů mezi obsahem buňky a hranicemi buňky.

    Mezery buněk

    Počet obrazových bodů mezi sousedními buňkami tabulky.

    Poznámka:

    Pokud neurčíte jednoznačně hodnoty okraje, mezer buněk a odsazení buněk, většina prohlížečů zobrazí okraje a odsazení buněk v tabulce s hodnotou 1 obrazový bod a mezery buněk 2 obrazové body. Pokud chcete, aby webové prohlížeče zobrazovaly tabulku bez odsazení a mezer, nastavte hodnoty Odsazení buňky a Mezery buněk na 0. Chcete-li zobrazit okraje buněk a tabulky, když je okraj nastavený na hodnotu 0, vyberte volbu Zobrazení > Vizuální pomůcky > Okraje tabulky.

    Formátovat horní řádek

    Určuje formátování použité v horním řádku, pokud je nějaké vybráno. Vyberte si ze čtyř možností formátování: bez formátování, tučné, kurzíva nebo tučná kurzíva.

Export tabulky

  1. Umístěte textový kurzor do libovolné buňky tabulky.
  2. Vyberte volbu Soubor > Exportovat > Tabulka.
  3. Určete následující volby:

    Oddělovač

    Určuje, který znak bude použit jako oddělovač položek v exportovaném souboru.

    Rozdělení řádků

    Určuje, v jakém operačním systému budete exportovaný soubor otevírat: Windows, Macintosh nebo UNIX. (Různé operační systémy mají různé způsoby označení konce řádku textu.)

  4. Klepněte na tlačítko Exportovat.
  5. Zadejte název souboru a klepněte na tlačítko Uložit.

Výběr elementů tabulky

Můžete vybrat celou tabulku, řádek nebo sloupec najednou. Také můžete vybrat jednu nebo více jednotlivých buněk.

Když přesunete ukazatel nad tabulku, řádek, sloupec nebo buňku, aplikace Dreamweaver zvýrazní všechny buňky v tomto výběru, takže víte, které buňky se vyberou. To je užitečné, když máte tabulky bez okrajů, buňky přes více sloupců nebo řádků nebo vnořené tabulky. Barvu zvýraznění můžete změnit v předvolbách.

Poznámka:

Pokud umístíte ukazatel myši nad okraj tabulky a podržíte stisknutou klávesu Ctrl (Windows) nebo Apple (Macintosh), zvýrazní se celá struktura tabulky – tedy všechny buňky v tabulce. To je užitečné, pokud chcete vidět u vnořené tabulky strukturu jedné z tabulek.

Výběr celé tabulky

Jedním z následujících úkonů vyberte tabulku:

  • Kliknutím na levý horní roh tabulky vyberte požadovanou tabulku.
  • Klikněte do buňky tabulky a vyberte tag ze selektoru tagů v levém dolním rohu okna dokumentu.
  • Klepněte do buňky tabulky, klepněte na nabídku záhlaví tabulky a klepněte na tlačítko Vybrat tabulku. Nad dolním a pravým okrajem tabulky se zobrazí táhla výběru.
  • Klikněte do buňky tabulky a vyberte možnost Úpravy > Tabulka > Vybrat tabulku.

Výběr jednoho nebo více řádků nebo sloupců

  1. Umístěte kurzor nad levý okraj řádku nebo horní okraj sloupce.
  2. Když se ukazatel změní na výběrovou šipku, vyberte řádek nebo sloupec nebo tažením vyberte více řádků nebo sloupců.
    Výběr řádku
    Výběr řádku

Výběr jednoho sloupce

  1. Klepněte ve sloupci.
  2. Klikněte na nabídku záhlaví sloupce a vyberte volbu Vybrat sloupec.

Výběr jedné buňky

  1. Proveďte jeden z následujících úkonů:

    • Klepněte v buňce a vyberte tag <td> v selektoru tagů v levém dolním rohu okna dokumentu.
    • Klikněte v buňce se stisknutou klávesou Ctrl (Windows) nebo Cmd (Macintosh).

Výběr řádku nebo pravoúhlého bloku buněk

Proveďte jeden z následujících úkonů:
  • Táhněte z jedné buňky do druhé.

  • Klikněte do jedné buňky, kliknutím do stejné buňky se stisknutou klávesou Ctrl (Windows) nebo Cmd (Macintosh) tuto buňku vyberte a pak se stisknutou klávesou Shift klikněte do jiné buňky.

Výběr bloku buněk
Výběr bloku buněk

Výběr nesousedících buněk

Se stisknutou klávesu Ctrl (Windows) nebo Apple (Macintosh) klepněte na buňky, řádky nebo sloupce, které chcete vybrat.

Pokud není buňka, řádek nebo sloupec, na který klepnete se stisknutou klávesou Ctrl nebo Apple už vybraná, přidá se do výběru. Pokud je již vybraná, odstraní se z výběru.

Změna barvy zvýraznění elementů tabulky

  1. Vyberte možnost Úpravy > Předvolby (Windows) nebo Dreamweaver > Předvolby (Macintosh).
  2. V seznamu kategorií vlevo vyberte volbu Zvýraznění, proveďte jednu z následujících změn a klepněte na tlačítko OK.
    • Chcete-li změnit barvu zvýraznění elementů tabulky, klepněte na pole barvy pro hodnotu Myš nad a vyberte barvu zvýraznění v dialogovém okně pro výběr barvy (nebo zadejte hexadecimální hodnotu barvy zvýraznění do textového pole).

    • Chcete-li zapnout nebo vypnout zvýraznění elementů tabulky, vyberte nebo odznačte volbu Zobrazit pro hodnotu Myš nad.

    Poznámka:

    Tyto možnosti ovlivní všechny objekty, které aplikace Dreamweaver zvýrazní, když na ně najedete ukazatelem.  

Nastavení vlastností tabulky

Tabulky můžete upravit pomocí inspektoru Vlastnosti.

  1. Vyberte tabulku.
  2. Vlastnosti můžete podle potřeby upravit v panelu Inspektor vlastností (Okno > Vlastnosti).
    Vlastnosti tabulky
    Vlastnosti tabulky

    Identifikátor tabulky

    Identifikátor dané tabulky.

    Řádky a sloupce

    Počet řádků a sloupců v tabulce.

    W

    Šířka tabulky v obrazových bodech nebo v procentech šířky okna prohlížeče.

    Poznámka:

    Výšku tabulky obvykle nemusíte zadávat.

    Odsazení buňky

    Počet obrazových bodů mezi obsahem buňky a hranicemi buňky.

    Mezery buněk

    Počet obrazových bodů mezi sousedními buňkami tabulky.

    Zarovnání

    Určuje, kde se tabulka zobrazí vzhledem k ostatním elementům ve stejném odstavci, například textu nebo obrazům.

    Volna Doleva zarovná tabulku vlevo od ostatních elementů (aby se text ve stejném odstavci zalomil okolo tabulky vpravo); volba Doprava zarovná tabulku napravo od ostatních elementů (s textem zalomeným okolo tabulky vlevo); volba Na střed tabulku vystředí (text se zobrazí nad a/nebo pod tabulkou). Hodnota Výchozí znamená, že prohlížeč by měl používat výchozí zarovnání.

    Poznámka:

    Když zarovnání nastavíte na hodnotu Výchozí, vedle tabulky se nezobrazí žádný obsah. Chcete-li zobrazit tabulku vedle dalšího obsahu, použijte zarovnání Doleva nebo Doprava.

    Okraj

    Určuje šířku okraje tabulky v obrazových bodech.

    Poznámka:

    Pokud neurčíte jednoznačně hodnoty okraje, mezer buněk a odsazení buněk, většina prohlížečů zobrazí okraje a odsazení buněk v tabulce s hodnotou 1 obrazový bod a mezery buněk 2 obrazové body. Chcete-li se ujistit, že prohlížeče zobrazují tabulku bez odsazení nebo mezer, nastavte hodnoty Okraj, Odsazení buňky a Mezery buněk na 0. Chcete-li zobrazit okraje buněk a tabulky, když je okraj nastavený na hodnotu 0, vyberte volbu Zobrazení > Vizuální pomůcky > Okraje tabulky.

    Třída

    Nastavuje u tabulky třídu CSS.

    Poznámka:

    Aby byly následující možnosti viditelné, bude možná potřeba tabulku s nástrojem Inspektor vlastností rozšířit. Tabulku Inspektor vlastností rozšíříte klepnutím na rozbalovací šipku v pravém dolním rohu.

    Vymazat šířky sloupců a Vymazat výšky řádků

    a Vymazat výšky řádků odstraní všechny přímo zadané hodnoty výšky řádků nebo šířky sloupců z tabulky.

    Převést šířky v tabulce na obrazové body

    a Převést výšky v tabulce na obrazové body nastaví šířku nebo výšku každého sloupce v tabulce na aktuální šířku v obrazových bodech (také nastaví šířku celé tabulky na aktuální šířku v obrazových bodech).

    Převést šířky v tabulce na procenta

    a Převést výšky v tabulce na procenta nastaví šířku nebo výšku každého sloupce v tabulce na aktuální šířku vyjádřenou v procentech šířky okna dokumentu (také nastaví šířku celé tabulky na aktuální šířku v procentech šířky okna dokumentu).

    Pokud jste zadali hodnotu v textovém poli, stisknutím klávesy tabulátor nebo Enter (Windows) nebo Return (Macintosh) hodnotu aplikujte.

Nastavení vlastností buňky, řádku nebo sloupce

Buňky a řádky v tabulce můžete upravit pomocí inspektoru Vlastnosti.

  1. Vyberte sloupec nebo řádek.
  2. v inspektoru Vlastnosti (Okna > Vlastnosti) nastavte následující volby:

    Vodorovně

    Určuje vodorovné zarovnání obsahu buňky, řádku nebo sloupce. Obsah můžete zarovnat doleva, doprava nebo na střed buněk nebo můžete určit, aby prohlížeč používal svoje výchozí zarovnání (obvykle doleva pro běžné buňky a na střed pro buňky záhlaví).

    Svisle

    Určuje svislé zarovnání obsahu buňky, řádku nebo sloupce. Obsah můžete zarovnat nahoru, na střed, dolů nebo na účaří buněk, případně určit, aby prohlížeč používal svoje výchozí zarovnání (obvykle na střed).

    Š a V

    Šířka a výška vybraných buněk v obrazových bodech nebo v procentech šířky nebo výšky celé tabulky. Chcete-li zadat hodnotu v procentech, zadejte za hodnotou symbol procenta (%). Chcete-li nechat prohlížeč určit správnou šířku nebo výšku podle obsahu buňky a šířky a výšky ostatních sloupců nebo řádků, nechte pole prázdné (výchozí).

    Standardně prohlížeč určí výšku řádku a šířku sloupce podle nejširšího obrazu nebo nejdelšího řádku ve sloupci. Kvůli tomu se sloupec po přidání obsahu občas nastaví na mnohem širší než ostatní sloupce v tabulce.

    Poznámka:

    Výšku můžete zadat v procentech celkové výšky tabulky, ale řádek se s takto zadanou výškou v procentech nemusí zobrazit ve všech prohlížečích.

    Pozadí

    Barva pozadí buňky, sloupce nebo řádku vybraná pomocí výběru barvy.

    Sloučit buňky

    Sloučí vybrané buňky, řádky nebo sloupce do jedné buňky. Buňky lze sloučit pouze v případě, že tvoří obdélníkový nebo lineární blok.

    Rozdělit buňku

    Rozdělí buňku a vytvoří dvě nebo více buněk. Rozdělit můžete najednou pouze jednu buňku; pokud je vybráno více buněk, toto tlačítko je nedostupné.

    Nezalamovat

    Řádky se nezalamují, text se ponechá v dané buňce na jednom řádku. Pokud je zapnuta volba Nezalamovat, buňky se při psaní nebo vkládání dat rozšíří, aby se do nich vešla všechna data. (Obvykle se buňky rozšiřují vodorovně, aby se do nich vešlo nejdelší slovo nebo nejširší obraz v buňce a pak se podle potřeby rozšiřují svisle pro další obsah.)

    Záhlaví

    Naformátuje vybrané buňky jako buňky záhlaví tabulky. Obsah buněk záhlaví tabulky je standardně tučný a vystředěný.

    Poznámka:

    Šířku a výšku můžete zadat v obrazových bodech nebo procentech a můžete je převádět z obrazových bodů na procenta a zpět.

    Poznámka:

    Když nastavíte vlastnosti sloupce, aplikace Dreamweaver změní podle toho atributy tagu td všech buněk ve sloupci. Po nastavení určité vlastnosti řádku však aplikace Dreamweaver změní atributy tagu tr namísto úpravy atributů každého tagu td na řádku. Pokud se chystáte použít stejný formát pro všechny buňky na řádku, použití formátu s tagem tr podporuje vytvoření přehlednějšího a stručnějšího kódu HTML.

  3. Stiskem tabulátoru nebo klávesy Enter (Windows) nebo Return (Macintosh) aplikujte hodnotu.

Formátování tabulek a buněk

Vzhled tabulek můžete změnit nastavením vlastností tabulky a jejích buněk nebo použitím předem definovaného návrhu tabulky. Před nastavením vlastností tabulky a buňky je třeba si uvědomit priority formátování buněk, řádků a tabulek.

Poznámka:

Chcete-li formátovat text uvnitř buňky tabulky, použijte stejné postupy jako u textu mimo tabulku.

Změna formátu tabulky, řádku nebo sloupce

  1. Vyberte volbu tabulku, buňku, řádek nebo sloupec.
  2. v inspektoru Vlastnosti (Okna > Vlastnosti), klepněte na rozbalovací šipku v pravém dolním rohu a změňte vlastnosti podle potřeby.
  3. Změňte vlastnosti podle potřeby.

    Více informací o volbách získáte klepnutím na ikonu Nápověda v inspektoru Vlastnosti.

    Poznámka:

    Když nastavíte vlastnosti sloupce, aplikace Dreamweaver změní podle toho atributy tagu td všech buněk ve sloupci. Když ale nastavíte určité vlastnosti řádku, aplikace Dreamweaver změní atributy tagu tr místo změny atributů každého tagu td na řádku. Pokud se chystáte použít stejný formát u všech buněk na řádku, použitím formátování na tag tr vznikne přehlednější a stručnější kód HTML.

Přidání nebo úpravy hodnot pro usnadnění přístupu pro tabulku v zobrazení Kód

Upravte příslušné atributy v kódu.

Poznámka:

Chcete-li rychle najít tagy v kódu, klepněte v tabulce a v selektoru tagů v dolní části okna dokumentu vyberte tag <table> .

Přidání nebo úpravy hodnot pro usnadnění přístupu pro tabulku v zobrazení Návrh

  • Chcete-li upravit popisek tabulky, zvýrazněte ho a zadejte nový text.
    • Chcete-li upravit zarovnání popisku, vložte textový kurzor do popisku tabulky, klepněte pravým tlačítkem (Windows) nebo s klávesou Ctrl (Macintosh) a vyberte volbu Upravit kód tagu.

    • Chcete-li upravit přehled tabulky, vyberte tabulku, klikněte pravým tlačítkem (Windows) nebo se stisknutou klávesou Ctrl (Macintosh) a vyberte volbu Upravit kód tagu.

Změna velikosti tabulek, sloupců a řádků

Změna velikosti tabulek

Je možné změnit velikost celé tabulky nebo jednotlivých řádků a sloupců. Když změníte velikost celé tabulky, změní se podle toho velikost všech buněk v tabulce. Pokud mají buňky tabulky pevně zadanou šířku nebo výšku, změna velikosti tabulky změní vizuální velikost buněk v okně dokumentu, ale nezmění zadanou šířku a výšku buněk.

Velikost tabulky můžete změnit tažením jednoho z táhel výběru. Když je tabulka vybrána nebo je v ní umístěn textový kurzor, aplikace Dreamweaver zobrazuje šířku tabulky spolu s nabídkou záhlaví tabulky v horní nebo dolní části tabulky.

Někdy šířky sloupců nastavené v kódu HTML neodpovídají šířkám zobrazeným na obrazovce. Když k tomu dojde, můžete šířky sjednotit. V aplikaci Dreamweaver se zobrazují šířky tabulky a sloupců a nabídky záhlaví, které usnadňují rozvržení tabulek. Šířky a nabídky můžete podle potřeby zapnout nebo vypnout.

Změna velikosti řádků a sloupců

Šířku sloupce nebo výšku řádku můžete změnit v inspektoru Vlastnosti nebo tažením okrajů sloupce nebo řádku. Pokud máte při změně velikosti potíže, můžete šířku sloupce nebo výšku řádku odstranit a začít znovu.

Poznámka:

Podobně je možné změnit šířku a výšku buňky přímo v kódu HTML v zobrazení kódu.

Pokud je vybrána tabulka nebo je umístěn textový kurzor v tabulce, aplikace Dreamweaver zobrazí šířky sloupců spolu s nabídkami záhlaví sloupce v horní nebo dolní části sloupců. Nabídky záhlaví sloupce můžete podle potřeby vypnout a zapnout.

Změna velikosti tabulky

Vyberte tabulku. Pokud se nacházíte v živém zobrazení, Zobrazení elementu bude přístupné po zvolení tabulky. Kliknutím na ikonu vrstev přejdete do režimu formátování tabulky.

  • Chcete-li změnit vodorovnou velikost tabulky, přetáhněte táhlo výběru na pravé straně.

  • Chcete-li změnit svislou velikost tabulky, přetáhněte táhlo výběru na dolním okraji.

  • Chcete-li změnit oba rozměry tabulky, přetáhněte táhlo výběru v pravém dolním rohu.

Režim formátování tabulky v živém zobrazení ukončíte stisknutím klávesy Esc nebo kliknutím mimo tabulku. Tabulku můžete dále upravit použitím možností nabídky Úpravy > Tabulka.

Poznámka: Možnosti v nabídce Úpravy > Tabulka se liší podle toho, zda jste vybrali celou tabulku, nebo jedinou buňku. Pokud v živém zobrazení vyberete celou tabulku, v okně Zobrazení elementu se zobrazí tag „table“. Pokud vyberete konkrétní buňku, zobrazí se tag „td“. Budete-li chtít přepnout z režimu formátování buňky na formátování tabulky, klikněte na okraj tabulky.

Změna šířky sloupce při zachování šířky celé tabulky

  1. V zobrazení návrhu přetáhněte pravý okraj sloupce, který chcete změnit.

    Šířka sousedního sloupce se také změní, takže ve skutečnosti měníte velikost dvou sloupců. Vizuální zpětná vazba ukazuje, jak se sloupce změní; celková šířka tabulky zůstane zachována.

    Změna šířky sloupce při zachování šířky tabulky
    Změna šířky sloupce při zachování šířky tabulky

    Poznámka:

    Pokud v tabulkách, kde je šířka vyjádřena procentuálně (ne pomocí obrazových bodů), přetáhnete pravý okraj sloupce nejvíce vpravo, změní se šířka celé tabulky a všechny sloupce se podle toho rozšíří nebo zúží.

Změna šířky sloupce při zachování velikosti ostatních sloupců

  1. V zobrazení návrhu stiskněte klávesu Shift a přetáhněte okraj sloupce.

    Šířka jednoho sloupce se změní. Vizuální zpětná vazba ukazuje, jak se sloupce změní; celková šířka tabulky se přitom změní tak, aby se do ní vešel sloupec, jehož velikost měníte.

    Změna šířky sloupce při zachování šířky ostatních sloupců
    Změna šířky sloupce při zachování šířky ostatních sloupců

Vizuální změna výšky řádku

Přetáhněte dolní okraj řádku.

Sjednocení šířek řádku v kódu s vizuálními šířkami

  1. Klepněte do buňky.
  2. Klikněte na nabídku sloupce a vyberte volbu Nastavit všechny šířky stejně.

    Aplikace Dreamweaver nastaví šířky zadané v kódu podle vizuálních šířek.

Vymazání všech nastavených šířek nebo výšek v tabulce

  1. Vyberte tabulku.
  2. Proveďte jeden z následujících úkonů:
    • Vyberte možnost Úpravy > Tabulka > Vymazat šířky buněk nebo Úpravy > Tabulka > Vymazat výšky buněk.

    • V Inspektoru vlastností (Okna > Vlastnosti) klikněte na tlačítko Vymazat výšky řádků nebo Vymazat šířky sloupců .

    • Klikněte na nabídku záhlaví tabulky a vyberte možnost Odstranit všechny výšky nebo Odstranit všechny šířky.

Vymazání nastavené šířky sloupce

Klepněte do sloupce, klepněte na nabídku záhlaví sloupce a vyberte volbu Vymazat šířku sloupce.

Zapnutí nebo vypnutí šířek a nabídek tabulky a sloupců v zobrazení návrhu

Vyberte možnost Zobrazit > Možnosti zobrazení návrhu > Vizuální pomůcky > Šířky tabulky.

Přidání a odstranění řádků a sloupců

Chcete-li přidat a odstranit řádky a sloupce, vyberte volbu Změnit > Tabulka nebo použijte nabídku záhlaví sloupce.

Poznámka:

Stiskem tabulátoru v poslední buňce tabulky automaticky přidáte do tabulky další řádek.

Přidání jednoho řádku nebo sloupce

Klepněte do buňky a proveďte jeden z následujících úkonů:
  • Vyberte možnost Úpravy > Tabulka > Vložit řádek nebo Úpravy > Tabulka > Vložit sloupec.

    Nad textovým kurzorem se objeví řádek nebo se nalevo od textového kurzoru objeví sloupec.

  • Klikněte na nabídku záhlaví sloupce a vyberte volbu Vložit sloupec vlevo nebo Vložit sloupec vpravo.

     

Vložení více řádků nebo sloupců

  1. Klepněte do buňky.
  2. Vyberte možnost Úpravy > Tabulka > Vložit řádky nebo sloupce, vyplňte dialogové okno a klikněte na tlačítko OK.

    Vložit

    Určuje, zda se mají vložit řádky nebo sloupce.

    Počet řádků nebo počet sloupců

    Počet řádků nebo sloupců, které se mají vložit.

    Kde

    Určuje, zda se mají nové řádky nebo sloupce zobrazit před nebo po řádku/sloupci vybrané buňky.

Odstranění řádku nebo sloupce

Proveďte jeden z následujících úkonů:
  • Klikněte do buňky v řádku nebo sloupci, který chcete odstranit, vyberte možnost Úpravy > Tabulka > Odstranit řádek nebo Úpravy > Tabulka > Odstranit sloupec.

  • Vyberte celý řádek nebo sloupec a stiskněte klávesu Delete.

  • v inspektoru Vlastnosti (Okna > Vlastnosti) proveďte jeden z následujících úkonů:
    • Chcete-li přidat nebo odstranit řádky, zvyšte nebo snižte hodnotu Řádky.
    • Chcete-li přidat nebo odstranit sloupce, zvyšte nebo snižte hodnotu Sloupce.

Poznámka:

Aplikace Dreamweaver nezobrazí varování v případě, že odstraňujete řádky a sloupce obsahující data.

Rozdělení a sloučení buněk

Buňky můžete rozdělit nebo sloučit pomocí Inspektoru vlastností nebo možností v podnabídce Úpravy > Tabulka.

Sloučení dvou nebo více buněk v tabulce

  1. Vyberte sousedící buňky ve tvaru pruhu nebo ve tvaru obdélníku.

    V následujícím příkladu má výběr tvar obdélníku, buňky lze tedy sloučit.

    Buňky lze sloučit v obdélníku buněk
    Buňky lze sloučit v obdélníku buněk

    V následujícím příkladu není výběr obdélníkový, buňky tedy nelze sloučit.

    Buňky nelze sloučit, pokud není výběr obdélníkový
    Buňky nelze sloučit, pokud není výběr obdélníkový

  2. Proveďte jeden z následujících úkonů:
    • Vyberte možnost Úpravy > Tabulka > Sloučit buňky.

    • V rozbaleném Inspektoru vlastností HTML (Okna > Vlastnosti) klikněte na možnost Sloučit buňky.

    Poznámka:

    Pokud tlačítko nevidíte, kliknutím na rozbalovací šipku v pravém dolním rohu inspektoru vlastností zobrazíte všechny volby.

    Obsah jednotlivých buněk se umístí do výsledné sloučené buňky. Vlastnosti první vybrané buňky se použijí na sloučenou buňku.

Rozdělení buňky

  1. Klepněte do buňky a proveďte jeden z následujících úkonů:
    • Vyberte možnost Úpravy > Tabulka > Rozdělit buňku.

    • V rozbaleném Inspektoru vlastností HTML (Okna > Vlastnosti) klikněte na možnost Rozdělit buňku.

    Poznámka:

    Pokud tlačítko nevidíte, kliknutím na rozbalovací šipku v pravém dolním rohu inspektoru vlastností zobrazíte všechny volby.

  2. V dialogovém okně Rozdělit buňku vyberte, jak se má buňka rozdělit:

    Rozdělit buňku na

    Určuje, zda se má buňka rozdělit na řádky nebo sloupce.

    Počet řádků / Počet sloupců

    Určuje, na kolik řádků nebo sloupců se má buňka rozdělit.

Zvětšení nebo zmenšení počtu řádků nebo sloupců, do kterých buňka přesahuje

Proveďte jeden z následujících úkonů:
  • Vyberte možnost Úpravy > Tabulka > Zvětšit rozmezí řádků nebo Úpravy > Tabulka > Zvětšit rozmezí sloupců.

  • Vyberte možnost Úpravy > Tabulka > Zmenšit rozmezí řádků nebo Úpravy > Tabulka > Zmenšit rozmezí sloupců.

Kopírování, vložení a odstranění buněk

Je možné kopírovat, vložit nebo odstranit jednu buňku tabulky nebo více buněk najednou při zachování formátování buněk.

Buňky lze vložit v místě textového kurzoru nebo místo výběru v existující tabulce. Chcete-li vložit více buněk tabulky, obsah schránky musí být kompatibilní se strukturou tabulky nebo výběrem v tabulce, do kterého se buňky vloží.

Vyjmutí nebo kopírování buněk tabulky

  1. Vyberte jednu nebo více buněk ve tvaru pruhu nebo ve tvaru obdélníku.

    V následujícím příkladu má výběr buněk tvar obdélníku, buňky lze tedy vyjmout a kopírovat.

    Buňky lze vyjmout nebo zkopírovat v obdélníku buněk
    Buňky lze vyjmout nebo zkopírovat v obdélníku buněk

    V následujícím příkladu není výběr obdélníkový, buňky tedy nelze vyjmout nebo kopírovat.

    Buňky nelze vyjmout nebo kopírovat, pokud není výběr obdélníkový
    Buňky nelze vyjmout nebo kopírovat, pokud není výběr obdélníkový

  2. Vyberte volbu Úpravy > Vyjmout nebo Úpravy > Kopírovat.

    Poznámka:

    Pokud vyberete celý řádek nebo sloupec a vyberete volbu Úpravy > Vyjmout, celý řádek nebo sloupec se odstraní z tabulky (ne pouze obsah buněk).

Vložení buněk tabulky

  1. Vyberte místo, kam chcete buňky vložit:
    • Chcete-li nahradit existující buňky vkládanými, vyberte sadu existujících buněk se stejným rozvržením, jako mají buňky ve schránce. (Pokud jste například kopírovali nebo vyjmuli blok buněk 3 x 2, můžete vybrat pro nahrazení vložením jiný blok buněk 3 x 2.)

    • Chcete-li vložit celý řádek buněk nad určitou buňku, klikněte do této buňky.

    • Chcete-li vložit celý sloupec buněk vlevo od určité buňky, klikněte do této buňky.

    Poznámka:

    Pokud máte ve schránce méně než celý řádek nebo sloupec buněk, klikněte do buňky a vložíte buňky ze schránky, buňka, do které jste kliknuli, a její sousedé může být (záleží na poloze buňky v tabulce) nahrazena vkládanými buňkami.

    • Chcete-li pomocí vkládaných buněk vytvořit novou tabulku, umístěte textový kurzor mimo tabulku.
  2. Vyberte volbu Úpravy > Vložit.

    Pokud vkládáte do existující tabulky celé řádky nebo sloupce, řádky nebo sloupce se přidají do tabulky. Pokud vkládáte samotnou buňku, obsah vybrané buňky se nahradí. Pokud vkládáte výběr mimo tabulku, řádky, sloupce nebo buňky se použijí k definování nové tabulky.

Odstranění obsahu buněk se zachováním buněk

  1. Vyberte jednu nebo více buněk.

    Poznámka:

    Zkontrolujte, že výběr není tvořen celými řádky nebo sloupci.

  2. Stiskněte klávesu Delete.

    Poznámka:

    Pokud vyberete možnost Úpravy > Vymazat nebo stisknete klávesu Delete v okamžiku, kdy jsou vybrány pouze celé řádky nebo sloupce, z tabulky se odstraní celé řádky nebo sloupce, tedy ne pouze jejich obsahy.

Odstranění řádků nebo sloupců obsahujících sloučené buňky

  1. Vyberte řádek nebo sloupec.
  2. Vyberte možnost Úpravy > Tabulka > Odstranit řádek nebo Úpravy > Tabulka > Odstranit sloupec.

Vnoření tabulek

Vnořená tabulka je tabulka uvnitř buňky jiné tabulky. Vnořenou tabulku můžete formátovat stejně jako jinou tabulku; její šířka je ale omezena šířkou buňky, ve které se nachází.

  1. Klepněte do buňky existující tabulky.
  2. Vyberte volbu Vložit > Tabulka, nastavte volby tabulky a klepněte na tlačítko OK.

Uspořádání tabulek

Řádky tabulky můžete uspořádat podle obsahu jednoho sloupce. Také je možné použít složitější uspořádání podle obsahu dvou sloupců.

Nelze uspořádat tabulky obsahující atributy colspan nebo rowspan – to znamená tabulky obsahující sloučené buňky.

  1. Vyberte tabulku nebo klikněte do libovolné buňky.
  2. Vyberte možnost Úpravy > Tabulka > Uspořádat tabulku, nastavte možnosti v dialogovém okně a klikněte na tlačítko OK.

    Uspořádat podle

    Určuje, podle hodnot kterého sloupce se řádky tabulky uspořádají.

    Pořadí

    Určuje, zda se má sloupec uspořádat abecedně nebo číselně a zda se má uspořádat vzestupně (od A k Z, od nižších čísel k vyšším) nebo sestupně.

    Pokud sloupce obsahují čísla, vyberte volbu Číselně. Pokud použijete abecední uspořádání na seznam jednociferných a dvouciferných čísel, čísla se uspořádají jako slova (tedy například 1, 10, 2, 20, 3, 30) a ne jako čísla (například 1, 2, 3, 10, 20, 30).

    Pak podle/Pořadí

    Určuje pořadí uspořádání pro sekundární uspořádání podle jiného sloupce. Vyberte sloupec sekundárního uspořádání v rozbalovací nabídce Pak podle a pořadí sekundárního uspořádání podle v rozbalovací nabídce Pořadí.

    Uspořádat včetně prvního řádku

    První řádek tabulky bude začleněn do uspořádání. Pokud je prvním řádkem záhlaví, které by se nemělo přesunout, tuto volbu nezapínejte.

    Uspořádat řádky záhlaví

    Určuje, že se mají uspořádat všechny řádky v sekci thead (pokud existuje) pomocí stejného kritéria jako řádky sekce body. (Všimněte si, že řádky thead zůstávají v sekci thead a stále jsou zobrazeny v hodní části tabulky i po uspořádání.) Více informací o tagu thead najdete v panelu Reference (vyberte volbu Nápověda > Reference).

    Uspořádat řádky zápatí

    Určuje, že se mají uspořádat všechny řádky v sekci tfoot tabulky (pokud existují) pomocí stejných kritérií jako řádky body. (Všimněte si, že řádky tfoot zůstávají v sekci tfoot a stále jsou zobrazeny ve spodní části tabulky i po uspořádání.) Více informací o tagu tfoot najdete v panelu Reference (vyberte volbu Nápověda > Reference).

    Po provedení uspořádání zachovat barvy všech řádků

    Určuje, že atributy řádku tabulky (například barva) by měly po uspořádání zůstat asociovány se stejným obsahem. Pokud jsou řádky v tabulce formátovány pomocí dvou střídavých barev, nezapínejte tuto volbu, aby měla uspořádaná tabulka stále střídavě obarvené řádky. Pokud jsou atributy řádku specifické pro obsah každého řádku, výběrem této volby zajistíte, že tyto atributy zůstanou asociovány se správnými řádky v uspořádané tabulce.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online