Naučte se používat vizuální pomůcky pro rozvržení v aplikaci Dreamweaver, jako např. pro nastavení pravítek, nastavení vodítek rozvržení, používání vodítek se šablonami, používání mřížky rozvržení a používání obkreslovaného obrazu.

Nastavení pravítek

Pomocí pravítek můžete měřit, uspořádat a naplánovat rozvržení. Mohou se zobrazit na levém a horním okraji stránky se stupnicí v obrazových bodech, palcích nebo centimetrech.

  • Pravítka můžete zapnout nebo vypnout v nabídce Zobrazit > Možnosti zobrazení návrhu > Pravidla > Zobrazit/skrýt.
  • Chcete-li změnit počátek, přetáhněte ikonu počátku pravítek (v levém horním rohu zobrazení návrhu v okně dokumentu) na libovolné místo na stránce.
  • Chcete-li vrátit počátek do výchozí pozice, vyberte možnost Zobrazit > Možnosti zobrazení návrhu > Pravítka > Obnovit počátek.
  • Chcete-li změnit jednotky měření, vyberte volbu Zobrazení > Pravítka a pak vyberte volbu Obrazové body, Palce nebo Centimetry.

Nastavení vodítek rozvržení

Vodítka jsou čáry, které přetáhnete do dokumentu z pravítek. Pomáhají přesněji umístit a zarovnat objekty. Pomocí vodítek také můžete měřit velikost elementů stránky nebo napodobit panely (viditelné oblasti) webových prohlížečů.

Při zarovnání elementů můžete přitahovat elementy na vodítka a vodítka na elementy. (Aby funkce přitahovaní pracovala, musíte umístit elementy absolutně.) Vodítka můžete také zamknout, abyste zabránili ostatním uživatelům v jejich přemístění.

Vytvoření vodorovného nebo svislého vodítka

  1. Přetáhněte odpovídající pravítko.
  2. Umístěte vodítko do okna dokumentu a uvolněte tlačítko myši (přemístění vodítka lze provést dalším tažením).

    Poznámka:

    Standardně je poloha vodítka absolutní vzdálenost v obrazových bodech od horní nebo levé strany dokumentu a zobrazuje se vzhledem k počátku pravítka. Chcete-li nastavit polohu vodítka v procentech, stiskněte při vytvoření nebo přesunutí vodítka klávesu Shift.

Zobrazení nebo skrytí vodítek

  1. Vyberte volbu Zobrazení > Vodítka > Zobrazovat vodítka.

Přitahování elementů na vodítka

  • Pokud chcete přitahovat elementy k vodítkům, vyberte možnost Zobrazit > Možnosti zobrazení návrhu > Vodítka > Přitahovat na vodítka.
  • Pokud chcete přitahovat vodítka k elementům, vyberte možnost Zobrazit > Možnosti zobrazení návrhu > Vodítka > Přitahovat vodítka na elementy.

Poznámka:

Při změně velikosti elementů, například absolutně polohovaných elementů (AP elementů), tabulek a obrazů, se měněné elementy přitahují na vodítka.

Zamknutí nebo odemknutí všech vodítek

Vyberte možnost Zobrazit > Možnosti zobrazení návrhu > Vodítka > Zamknout vodítka.

Zobrazení a přemístění vodítka na požadovanou pozici

  1. Podržením ukazatele myši nad vodítkem zobrazte jeho polohu.
  2. Poklepejte na vodítko.
  3. Zadejte novou polohu v dialogovém okně Posunout vodítko a klepněte na tlačítko OK.

Zobrazení vzdálenosti mezi vodítky

Stiskněte klávesu Ctrl (Windows) nebo Apple (Macintosh) a umístěte ukazatel myši na libovolné místo mezi dvěma vodítky.

Poznámka:

Jednotky měření jsou stejné jako jednotky měření pravítek.

Napodobení panelu (viditelné oblasti) webového prohlížeče

Vyberte možnost Zobrazení > Možnosti zobrazení návrhu > Vodítka a vyberte z nabídky předem nastavenou velikost prohlížeče.

Odstranění vodítka

Přetáhněte vodítko z dokumentu.

Změna nastavení vodítek

  1. Vyberte možnost Zobrazení > Možnosti zobrazení návrhu > Vodítka > Upravit vodítka, nastavte následující možnosti a klikněte na tlačítko OK.

    Barva vodítka

    Určuje barvu čar vodítka. Klepněte na vzorek barvy a vyberte barvu v dialogovém okně pro výběr barvy nebo zadejte hexadecimální číslo do textového pole.

    Barva mezery

    Určuje barvu čar, které se zobrazují jako ukazatele vzdálenosti, když podržíte ukazatel myši mezi vodítky. Klepněte na vzorek barvy a vyberte barvu v dialogovém okně pro výběr barvy nebo zadejte hexadecimální číslo do textového pole.

    Zobrazovat vodítka

    Zobrazí vodítka v zobrazení návrhu.

    Přitahovat na vodítka

    Určuje, že při přesunování elementů ve stránce se elementy přitahují na vodítka.

    Zamknout vodítka

    Zamkne vodítka na místě.

    Přitahovat vodítka na elementy

    Při přetažení vodítek se vodítka přitáhnou na elementy stránky.

    Vymazat vše

    Odstranit všechna vodítka ze stránky

Používání vodítek s šablonami

Když přidáte vodítka do šablony aplikace Dreamweaver, všechny výskyty dané šablony zdědí vodítka. S vodítky v instancích předloh se ale zachází jako s upravitelnými oblastmi, aby je mohli uživatelé upravovat. Upravená vodítka v instancích předloh se obnoví na původní polohu při každé aktualizaci instance pomocí vzorové předlohy.

Do instance předlohy můžete také přidat vlastní vodítka. Vodítka přidaná tímto způsobem se nepřepíší při aktualizaci instance předlohy pomocí vzorové předlohy.

Používání mřížky rozvržení

Mřížka zobrazuje v okně dokumentu systém vodorovných a svislých čar. Je užitečná pro přesné umísťování objektů. Můžete určit, aby se absolutně polohované elementy stránky při přesunutí automaticky přitahovaly na mřížku, a změnit mřížku nebo řídit chování přitáhnutí pomocí nastavení mřížky. Přitahování funguje, ať je mřížka viditelná nebo ne.

Zobrazení nebo skrytí mřížky

Vyberte možnost Zobrazit > Možnosti zobrazení návrhu > Mřížka > Zobrazovat mřížku.

Zapnutí nebo vypnutí přitahování

Vyberte možnost Zobrazit > Možnosti zobrazení návrhu > Mřížka > Přitahovat na mřížku.

Změna nastavení mřížky

  1. Vyberte možnost Zobrazit > Možnosti zobrazení návrhu > Mřížka > Nastavení mřížky.

  2. Nastavte možnosti a klepnutím na tlačítko OK změny aplikujte.

    Barva

    Určuje barvu čar mřížky. Klepněte na vzorek barvy a vyberte barvu v dialogovém okně pro výběr barvy nebo zadejte hexadecimální číslo do textového pole.

    Zobrazovat mřížku

    Zobrazí mřížku v zobrazení návrhu.

    Přitahovat na mřížku

    Elementy stránky se přitahují na čáry mřížky.

    Mezery

    Určuje vzdálenost mezi čarami mřížky. Zadejte číslo a z nabídky vyberte volbu Obrazové body, Palce nebo Centimetry.

    Displej

    Určuje, zda se čáry mřížky zobrazují jako čáry, nebo tečky.

    Poznámka:

    Pokud není zapnutá volba Zobrazovat mřížku, mřížka se nezobrazuje v dokumentu a nejsou vidět žádné změny.

Používání obkreslovaného obrazu

Při použití obkreslovaného obrazu jako vodítka můžete znovu vytvořit návrh stránky vytvořený v grafické aplikaci, například Adobe Freehand nebo Fireworks.

Obkreslovaný obraz je obraz JPEG, GIF nebo PNG umístěný na pozadí okna dokumentu. Obraz můžete skrýt, nastavit jeho krytí a změnit jeho polohu.

Obkreslovaný obraz je viditelný pouze v aplikaci Dreamweaver (není viditelný při otevření stránky v prohlížeči). Když je obkreslovaný obraz viditelný, v okně dokumentu není viditelný skutečný obraz pozadí a barva pozadí; obraz i barva pozadí ale budou viditelné, jakmile stránku zobrazíte v prohlížeči.

Vložení obkreslovaného obrazu do okna dokumentu

  1. Proveďte jeden z následujících úkonů:
    • Vyberte možnost Zobrazit > Možnosti zobrazení návrhu > Obkreslovaný obraz > Načíst.

    • Vyberte možnost Soubor > Vlastnosti stránky a poté v kategorii Obkreslovaný obraz klikněte na tlačítko Procházet (vedle textového pole Obkreslovaný obraz).

  2. Přejděte na soubor s obrazem a klikněte na tlačítko OK.

  3. V dialogu Vlastnosti stránky nastavte průhlednost obrázku pomocí posuvníku Průhlednost obrázku a klikněte na tlačítko OK.

    Chcete-li přepnout do jiného obkreslovaného obrazu nebo změnit kdykoliv průhlednost aktuálního obkreslovaného obrazu, vyberte možnost Soubor > Vlastnosti stránky.

Zobrazení nebo skrytí obkreslovaného obrazu

Vyberte možnost Zobrazit > Možnosti zobrazení návrhu > Obkreslovaný obraz > Zobrazit.

Změna polohy obkreslovaného obrazu

  1. Vyberte možnost Zobrazit > Možnosti zobrazení návrhu > Obkreslovaný obraz > Nastavit polohu.

    • Chcete-li přesně zadat polohu obkreslovaného obrazu, zadejte hodnoty souřadnic do textových polích X a Y.

    • Chcete-li přesunout obraz o 1 obrazový bod, použijte kurzorové klávesy.

    • Chcete-li přesunout obraz o 5 obrazových bodů, stiskněte klávesu Shift a kurzorovou klávesu.

Obnovení polohy obkreslovaného obrazu

  1. Vyberte možnost Zobrazit > Možnosti zobrazení návrhu > Obkreslovaný obraz > Obnovit polohu.

    Obkreslovaný obraz se vrátí do levého horního rohu okna dokumentu (0,0).

Zarovnání obkreslovaného obrazu s vybraným elementem

  1. Vyberte element v okně dokumentu.
  2. Vyberte možnost Zobrazit > Možnosti zobrazení návrhu > Obkreslovaný obraz > Zarovnat s výběrem.

    Levý horní roh obkreslovaného obrazu se zarovná s levým horním rohem vybraného elementu.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online