Příručka uživatele Zrušit

Přidání videa v aplikaci Dreamweaver

  1. Příručka uživatele aplikace Dreamweaver
  2. Úvod
    1. Základy navrhování responzivních webů
    2. Co je nového v aplikaci Dreamweaver
    3. Vývoj webu v aplikaci Dreamweaver – přehled
    4. Dreamweaver / Běžné otázky
    5. Klávesové zkratky
    6. Systémové požadavky aplikace Dreamweaver
    7. Přehled funkcí
  3. Dreamweaver a Creative Cloud
    1. Synchronizace nastavení aplikace Dreamweaver ve službě Creative Cloud
    2. Knihovny Creative Cloud v aplikaci Dreamweaver
    3. Používání souborů Photoshop v aplikaci Dreamweaver
    4. Práce s aplikací Adobe Animate a Dreamweaver
    5. Extrahujte soubory SVG optimalizované pro web z knihoven
  4. Pracovní plochy a zobrazení aplikace Dreamweaver
    1. Pracovní plocha aplikace Dreamweaver
    2. Optimalizace pracovní plochy aplikace Dreamweaver pro vizuální vývoj
    3. Hledání souborů podle názvu nebo obsahu | Mac OS
  5. Nastavení webů
    1. O webech aplikace Dreamweaver
    2. Nastavení lokální verze webu
    3. Připojení k publikačnímu serveru
    4. Nastavení testovacího serveru
    5. Import a export nastavení webu aplikace Dreamweaver
    6. Přenos stávajících webových stránek ze vzdáleného serveru do kořenové složky lokálního webového místa
    7. Funkce usnadnění přístupu v aplikaci Dreamweaver
    8. Rozšířená nastavení
    9. Nastavení předvoleb webového místa pro přenos souborů
    10. Úprava nastavení serveru proxy v aplikaci Dreamweaver
    11. Synchronizace nastavení aplikace Dreamweaver ve službě Creative Cloud
    12. Používání systému Git v aplikaci Dreamweaver
  6. Správa souborů
    1. Vytváření a otevírání souborů
    2. Správa souborů a složek
    3. Získání souborů ze serveru a odeslání souborů na server
    4. Zpřístupnění/vyhrazení souborů
    5. Synchronizace souborů
    6. Porovnání souborů a nalezení rozdílů
    7. Maskování souborů a složek ve webu aplikace Dreamweaver
    8. Povolení poznámek k návrhu pro weby Dreamweaver
    9. Předcházení potenciálnímu zneužití modulu Gatekeeper
  7. Rozvržení a návrh
    1. Používání vizuálních pomůcek pro rozvržení
    2. O používání souborů CCS k rozvržení stránky
    3. Navrhování responzivních webů pomocí nástroje Bootstrap
    4. Vytvoření a používání multimediálních dotazů v aplikaci Dreamweaver
    5. Zobrazení obsahu pomocí tabulek
    6. Barvy
    7. Responzivní návrh s využitím rozvržení s plovoucí mřížkou
    8. Funkce Extrakt v aplikaci Dreamweaver
  8. CSS
    1. Vysvětlení kaskádových seznamů stylů
    2. Rozvržení stránek pomocí panelu CSS Designer
    3. Použití preprocesorů CSS v aplikaci Dreamweaver
    4. Postup nastavení předvoleb stylu CSS v aplikaci Dreamweaver
    5. Přesunutí pravidel CSS v aplikaci Dreamweaver
    6. Převedení inline CSS na pravidlo CSS v aplikaci Dreamweaver
    7. Práce s tagy div
    8. Použití přechodů na pozadí
    9. Vytváření a úprava efektů přechodů v aplikaci Dreamweaver
    10. Formátování kódu
  9. Obsah stránky a datové zdroje
    1. Nastavení vlastností stránky
    2. Nastavení vlastností nadpisů CSS a vlastností odkazu CSS
    3. Práce s textem
    4. Vyhledání a nahrazení textu, tagů a atributů
    5. Panel DOM
    6. Úpravy v živém zobrazení
    7. Kódování dokumentů v aplikaci Dreamweaver
    8. Výběr a zobrazení elementů v okně dokumentu
    9. Nastavení vlastností textu v Inspektoru vlastností
    10. Kontrola pravopisu webové stránky
    11. Pomocí vodorovných linek v aplikaci Dreamweaver
    12. Přidání a úprava kombinací písma v aplikaci Dreamweaver
    13. Práce s datovými zdroji
    14. Vložení a aktualizace dat v aplikaci Dreamweaver
    15. Vytvoření a správa oblíbených datových zdrojů v aplikaci Dreamweaver
    16. Vložení a úprava obrázků v aplikaci Dreamweaver
    17. Přidání multimediálních objektů
    18. Přidání videa v aplikaci Dreamweaver
    19. Vložení videa HTML 5
    20. Vložit soubory SWF
    21. Přidání zvukových efektů
    22. Vložte zvuk HTML5 v aplikaci Dreamweaver
    23. Práce s položkami knihoven
    24. Používání arabského a hebrejského textu v aplikaci Dreamweaver
  10. Odkazy a navigace
    1. O odkazech a navigaci
    2. Vytváření odkazů
    3. Obrazové mapy
    4. Odstraňování problémů s odkazy
  11. Ovládací prvky a efekty jQuery
    1. Používání widgetů jQuery UI a jQuery Mobile v aplikaci Dreamweaver
    2. Používání efektů jQuery v aplikaci Dreamweaver
  12. Kódování webových stránek
    1. Informace o psaní kódu v aplikaci Dreamweaver
    2. Prostředí pro psaní kódu v aplikaci Dreamweaver
    3. Nastavení předvoleb kódování
    4. Přizpůsobení barevného zvýraznění kódu
    5. Psaní a úprava kódu
    6. Našeptávání kódu a dokončování kódu
    7. Sbalení a rozbalení kódu
    8. Opakované použití kódu v podobě výstřižků
    9. Linting kódu
    10. Optimalizace kódu
    11. Úprava kódu v zobrazení Návrh
    12. Práce s obsahem hlavičky stránek
    13. Vložení zahrnutí na straně serveru v aplikaci Dreamweaver
    14. Používání knihoven tagů v aplikaci Dreamweaver
    15. Import vlastních tagů do aplikace Dreamweaver
    16. Práce s funkcemi JavaScriptu (obecné pokyny)
    17. Použití vestavěných chování jazyka JavaScript
    18. O XML a XSLT
    19. Provádění transformace XSL na straně serveru v aplikaci Dreamweaver
    20. Provádění transformace XSL na straně klienta v aplikaci Dreamweaver
    21. Přidání entit znaku pro XSLT v aplikaci Dreamweaver
    22. Formátování kódu
  13. Pracovní postupy pro různé produkty
    1. Instalace a používání rozšíření v aplikaci Dreamweaver
    2. Aktualizace v rámci aplikace v aplikaci Dreamweaver
    3. Vkládání dokumentů sady Microsoft Office v aplikaci Dreamweaver (jen ve Windows)
    4. Práce s aplikacemi Fireworks a Dreamweaver
    5. Úprava obsahu na webech Dreamweaver za pomoci aplikace Contribute
    6. Integrace mezi aplikacemi Dreamweaver a Business Catalyst
    7. Vytváření e-mailových kampaní na míru
  14. Šablony
    1. O předlohách aplikace Dreamweaver
    2. Rozpoznání předloh a dokumentů založených na předloze
    3. Vytvoření předlohy aplikace Dreamweaver
    4. Vytváření upravitelných oblastí v šablonách
    5. Vytváření opakovaných oblastí a tabulek v aplikaci Dreamweaver
    6. Použijte volitelné oblasti v předlohách
    7. Definování upravitelných atributů tagu v aplikaci Dreamweaver
    8. Postup vytvoření vnořených šablon v aplikaci Dreamweaver
    9. Úprava, aktualizace nebo odstranění předloh
    10. Export a import obsahu XML v aplikaci Dreamweaver
    11. Aplikace nebo odstranění předlohy z existujícího dokumentu.
    12. Úprava obsahu v předlohách Dreamweaver
    13. Pravidla syntaxe pro tagy předloh v aplikaci Dreamweaver
    14. Nastavení předvoleb zvýraznění pro oblasti předlohy
    15. Výhody používání předloh v aplikaci Dreamweaver
  15. Mobilní zařízení a zařízení s více displeji
    1. Vytvoření multimediálních dotazů
    2. Změna orientace stránky pro mobilní zařízení
    3. Vytvoření webových aplikací pro mobilní zařízení pomocí aplikace Dreamweaver
  16. Dynamické weby, stránky a webové formuláře
    1. Informace o webových aplikacích
    2. Nastavení počítače pro vývoj aplikací
    3. Řešení problémů s připojením databází
    4. Odstranění skriptů připojení v aplikaci Dreamweaver
    5. Návrh dynamických stránek
    6. Přehled zdrojů dynamického obsahu
    7. Definice zdrojů dynamického obsahu
    8. Přidání dynamického obsahu na stránky
    9. Změna dynamického obsahu v aplikaci Dreamweaver
    10. Zobrazení záznamů databáze
    11. Zajišťování a řešení potíží s živými daty v aplikaci Dreamweaver
    12. Přidání uživatelského chování serveru v aplikaci Dreamweaver
    13. Vytváření formulářů pomocí aplikace Dreamweaver
    14. Shromažďování informací od uživatelů pomocí formulářů
    15. Vytváření a povolení formulářů ColdFusion v aplikaci Dreamweaver
    16. Vytváření webových formulářů
    17. Rozšířená podpora formátu HTML5 pro elementy formuláře
    18. Vytváření formuláře pomocí aplikace Dreamweaver
  17. Vizuální vytváření aplikací
    1. Vytváření hlavních a podrobných stránek v aplikaci Dreamweaver
    2. Vytváření vyhledávacích stránek a stránek s výsledky
    3. Vytvoření stránky vložení záznamu
    4. Vytvoření stránky pro aktualizaci záznamu v aplikaci Dreamweaver
    5. Budování stránek pro odstranění záznamu v aplikaci Dreamweaver
    6. Používání příkazů ASP k úpravě databáze v aplikaci Dreamweaver
    7. Vytvoření registrační stránky
    8. Vytvoření přihlašovací stránky
    9. Vytvoření stránky, na kterou mají přístup pouze autorizovaní uživatelé
    10. Zabezpečení složek ve službě ColdFusion pomocí aplikace Dreamweaver
    11. Používání komponent ColdFusion v aplikaci Dreamweaver
  18. Testování, náhled a publikování webových stránek
    1. Náhled stránek
    2. Náhled webových stránek Dreamweaver na více zařízeních
    3. Testování webu aplikace Dreamweaver
  19. Odstraňování problémů
    1. Opravené problémy
    2. Známé problémy

 

 

Získejte další informace o vkládání videí na webové stránky a souborů FLV v aplikaci Dreamweaver.

Vložení videa na webové stránky (HTML5)

Kód HTML5 podporuje video a audiotagy, které umožňují uživatelům v prohlížeči přehrávat video a audiosoubory bez použití externího doplňku nebo přehrávače. Aplikace Dreamweaver podporuje pro přidávání video a audiotagů nápovědu při psaní kódu.

Video se otevře v živém zobrazení, které nabídne náhled videa vkládaného na webovou stránku.

Poznámka:

Na webovou stránku můžete vložit jakékoli video, v živém zobrazení se však některá videa nemusí otevřít. Audio a videotagy jsou v aplikaci Dreamweaver podporovány prostřednictvím doplňku Apple QuickTime. Pokud není doplněk Apple QuickTime v systému Windows nainstalován, multimediální obsah se na webové stránce nezobrazí.

Postup vkládání videa HTML5 naleznete v části Vkládání videí HTML5 v aplikaci Dreamweaver.

Vkládání souborů FLV

Vložit soubory FLV

Na webové stránky lze snadno přidat video FLV bez použití vývojového nástroje Flash. Abyste mohli začít, je nutné mít kódovaný soubor FLV.

Aplikace Dreamweaver vloží komponentu SWF, která zobrazuje soubor FLV při zobrazení v prohlížeči; tato komponenta zobrazuje vybraný soubor FLV spolu se sadou ovládacích prvků pro přehrávání.

Vybraný soubor FLV a sada ovládacích prvků pro přehrávání

Aplikace Dreamweaver nabízí následující možnosti zobrazení videa FLV návštěvníkům webového místa:

Stahované video

Stáhne soubor FLV na pevný disk návštěvníka webového místa a pak jej přehraje. Na rozdíl od tradičních metod přenosu videa typu „stáhnout a přehrát“ ale postupné stahování umožňuje přehrávání souboru videa ještě před dokončením stahování.

Streamované video

Načítá datový proud obsahu videa a přehrává jej na webové stránce po krátké době ukládání do vyrovnávací paměti, což zajišťuje plynulé přehrávání. Chcete-li na svých webových stránkách povolit datové proudy videa, musíte mít přístup k serveru Adobe® Flash® Media Server.

Abyste mohli s videem pracovat v aplikaci Dreamweaver, je nutné mít kódovaný soubor FLV. Můžete vkládat soubory videa vytvořené pomocí dvou druhů kodeků (technologií komprese/dekomprese): Sorenson Squeeze a On2.

Stejně jako u běžných souborů SWF aplikace Dreamweaver při vložení souboru FLV vloží kód, který zjistí, zda má uživatel správnou verzi aplikace Flash Player k zobrazení videa. Pokud uživatel správnou verzi nemá, na stránce se zobrazí alternativní obsah, který vyzve uživatele ke stažení nejnovější verze aplikace Flash Player.

Poznámka:

Aby uživatelé mohli zobrazit soubory FLV, musí mít v počítačích nainstalovánu aplikaci Flash Player 8 nebo novější. Pokud uživatel nemá nainstalovánu požadovanou verzi aplikace Flash Player, ale má aplikaci Flash Player 6.0 r65 nebo novější, v prohlížeči se místo alternativního obsahu zobrazí instalační program aplikace Flash Player. Pokud uživatel expresní instalaci odmítne, zobrazí se na stránce alternativní obsah.

Další informace o práci s videem najdete v technologickém centru Video Technology Center na adrese www.adobe.com/go/flv_devcenter_cz.

Vložení souboru FLV

  1. Vyberte možnost Vložit > HTML > Video Flash.

    Vkládání videa Flash
    Vkládání videa Flash

  2. V dialogovém okně Vložit soubor FLV vyberte volbu Stahované video nebo Streamované video v rozbalovací nabídce Typ videa.
  3. Vyplňte zbytek voleb dialogového okna a klepněte na tlačítko OK.
Poznámka:

Server Internet Information Server (IIS) společnosti Microsoft nezpracovává tagy vnořených objektů. Pro stránky ASP používá aplikace Dreamweaver při vkládání souborů SWF nebo FLV kód vnořených objektů / vložený kód místo kódu vnořených objektů.

Nastavení voleb postupného stahování videa

Pomocí dialogového okna Vložit soubor FLV můžete nastavit možnosti postupného stahování souboru FLV vloženého do webové stránky.

  1. Vyberte možnost Vložit > HTML > Video Flash (nebo klikněte na ikonu Video Flash v kategorii HTML na panelu Vložit).

  2. V dialogovém okně Vložit soubor FLV vyberte možnost Stahované video z nabídky Typ videa.
    Vkládání videa Flash
    Vkládání videa Flash

  3. Určete následující možnosti:

    URL

    Určuje relativní nebo absolutní cestu k souboru FLV. Chcete-li zadat relativní cestu (například mypath/myvideo.flv), klepněte na tlačítko Procházet, vyhledejte soubor FLV a vyberte ho. Chcete-li zadat absolutní cestu, zadejte adresu URL (například http://www.example.com/myvideo.flv) souboru FLV.

    Vzhled

    Určuje vzhled komponenty videa. Náhled vybraného vzhledu se zobrazuje pod rozevírací nabídkou Vzhled.

    Šířka

    Šířka souboru FLV v obrazových bodech. Aplikace Dreamweaver určuje šířku souboru FLV, kterou automaticky zobrazí v tomto poli.

    Výška

    Výška souboru FLV v obrazových bodech. Aplikace Dreamweaver automaticky optimalizuje výšku souboru FLV, kterou automaticky zobrazí v tomto poli.

    Poznámka:

    Hodnota Celkem se vzhledem představuje šířku a výšku souboru FLV a navíc šířku a výšku vybraného vzhledu.

    Omezit

    Zachová stejný poměr šířky a výšky komponenty videa. Tato volba je vybrána standardně.

    Přehrát automaticky

    Určuje, zda se video přehraje po otevření webové stránky.

    Automaticky přetočit zpět

    Určuje, zda se widget přehrávání vrátí po dokončení přehrávání videa do původní polohy.

  4. Klepnutím na tlačítko OK zavřete dialogové okno a přidáte soubor FLV na webovou stránku.

    Příkaz Vložit soubor FLV generuje soubor SWF přehrávače videa a soubor SWF vzhledu, pomocí kterých se obsah videa na stránce zobrazuje. (Zobrazení nových souborů může vyžadovat klepnutí na tlačítko Obnovit v panelu Soubory.) Tyto soubory jsou uloženy ve stejném adresáři jako soubor HTML, do kterého obsah videa přidáváte. Při odesílání stránky HTML obsahující soubor FLV odesílá aplikace Dreamweaver tyto soubory jako závislé soubory (v případě, že klepnete na volbu Ano v dialogovém okně Odeslat závislé soubory).

Nastavení voleb pro streamované video

Pomocí dialogového okna Vložit FLV můžete nastavit možnosti souboru streamovaného videa souboru FLV vloženého do webové stránky.

  1. Vyberte možnost Vložit > HTML > Video Flash (nebo klikněte na ikonu Video Flash v kategorii HTML na panelu Vložit).

  2. V rozevírací nabídce Typ videa vyberte možnost Streamované video.
    Nastavení možností pro streamované video
    Nastavení možností pro streamované video

    URI serveru

    Určuje název serveru, aplikace a instance ve formě rtmp://www.example.com/app_name/instance_name.

    Název streamu

    Určuje název souboru FLV, který chcete přehrát (například mojevideo.flv). Přípona .flv je volitelná.

    Vzhled

    Určuje vzhled komponenty videa. Náhled vybraného vzhledu se zobrazuje pod rozevírací nabídkou Vzhled.

    Šířka

    Šířka souboru FLV v obrazových bodech. Aplikace Dreamweaver určuje šířku souboru FLV a automaticky ji vyplňuje do tohoto pole.

    Výška

    Výška souboru FLV v obrazových bodech. Aplikace Dreamweaver určuje výšku souboru FLV v obrazových bodech a automaticky ji vyplňuje do tohoto pole.

    Poznámka:

    Celkem se vzhledem představuje šířku a výšku souboru FLV a navíc šířku a výšku vybraného vzhledu.

    Omezit

    Zachová stejný poměr šířky a výšky komponenty videa. Tato volba je vybrána standardně.

    Živý přenos videa

    Určuje, zda je obsah videa živý. Pokud vyberete volbu Živý přenos videa, přehrávač Flash Player přehraje živý přenos videa streamovaný ze serveru Flash® Media Server. Název živého přenosu videa se zadává do textového pole Název streamu.

    Poznámka:

    Chcete-li povolit živý přenos videa, musíte si v poli Vzhled vybrat jednu z možností vzhledu s haló efektem. Po výběru možnosti Živý přenos videa se ve vzhledu komponenty zobrazí pouze ovládání hlasitosti, protože s živým přenosem nelze manipulovat. Volby Přehrát automaticky a Automaticky přetočit zpět také nelze použít.

    Přehrát automaticky

    Určuje, zda se video přehraje po otevření webové stránky.

    Automaticky přetočit zpět

    Určuje, zda se widget přehrávání vrátí po dokončení přehrávání videa do původní polohy.

    Doba ukládání do vyrovnávací paměti

    Určuje čas ukládání do vyrovnávací paměti před spuštěním přehrávání videa v sekundách. Výchozí čas ukládání do vyrovnávací paměti je nastavený na hodnotu 0, takže video se začne přehrávat okamžitě po klepnutí na tlačítko Spustit. (Pokud je vybrána volba Přehrát automaticky, video se začne přehrávat okamžitě po navázání spojení se serverem.) Čas ukládání do vyrovnávací paměti nastavte v případě, že chcete použít video, které má větší požadavek na přenosovou rychlost než je rychlost připojení návštěvníka webového místa, nebo v případě, že provoz na Internetu může způsobit problémy s připojením nebo s šířkou pásma. Pokud například chcete na webovou stránku odeslat 15 sekund videa předtím, než ho webová stránka začne přehrávat, nastavte dobu ukládání do vyrovnávací paměti na hodnotu 15.

  3. Klepnutím na tlačítko OK zavřete dialogové okno a přidáte soubor FLV na webovou stránku.

    Příkaz Vložit soubor FLV generuje soubor SWF přehrávače videa a soubor SWF vzhledu, pomocí kterých se video na stránce zobrazuje. Tento příkaz také generuje soubor main.asc, který je nutné odeslat na server Flash Media Server. (Zobrazení nových souborů může vyžadovat klepnutí na tlačítko Obnovit v panelu Soubory.) Tyto soubory jsou uloženy ve stejném adresáři jako soubor HTML, do kterého obsah videa přidáváte. Při odesílání stránky HTML obsahující soubor FLV nezapomeňte odeslat soubory SWF na webový server a soubor main.asc na server Flash Media Server.

    Poznámka:

    Pokud již na serveru soubor main.asc existuje, ověřte si před odeslání souboru main.asc generovaného příkazem Vložit soubor FLV u správce serveru.

    Veškeré požadované multimediální soubory lze snadno odeslat vybráním vyhrazeného místa pro komponentu Video v okně Dokument aplikace Dreamweaver a klepnutím na tlačítko Odeslat médium v inspektoru Vlastnosti (Okna > Vlastnosti). Chcete-li zobrazit seznam těchto souborů, klepněte na tlačítko Zobrazit vyžadované soubory.

    Poznámka:

    Tlačítko Odeslat médium neodešle soubor HTML, který video obsahuje.

Úprava informací o stahování aplikace Flash Player

Při vložení souboru FLV do stránky vloží aplikace Dreamweaver kód, který zjišťuje, zda má uživatel správnou verzi aplikace Flash Player. Pokud ne, zobrazí se na stránce výchozí alternativní obsah, který uživatele vyzve ke stažení nejnovější verze. Tento alternativní obsah můžete kdykoli změnit.

Tento postup se vztahuje také na soubory SWF.

Poznámka:

Pokud uživatel nemá požadovanou verzi, ale má aplikaci Flash Player 6.0 r65 nebo novější, zobrazí se v prohlížeči expresní instalační program aplikace Flash Player. Pokud uživatel expresní instalaci odmítne, zobrazí se na stránce alternativní obsah.

  1. V zobrazení Návrh okna Dokument vyberte soubor SWF nebo FLV.
  2. Klepněte na ikonu oka v souboru SWF nebo FLV.

    Poznámka:

    Na zobrazení alternativního obsahu můžete přepnout také stisknutím kláves Ctrl a ]. Chcete-li se vrátit do zobrazení souborů SWF/FLV, stiskněte klávesy Ctrl + [, dokud není vybrán veškerý alternativní obsah. Pak stiskněte klávesy Ctrl + [ znovu.

  3. Upravte obsah stejným způsobem jako jiný obsah v aplikaci Dreamweaver.
    Poznámka:

    Jako alternativní obsah nelze přidat soubory SWF nebo FLV.

  4. Dalším klepnutím na ikonu oka se vrátíte k zobrazení souboru SWF nebo FLV.

Odstraňování problémů v souborech FLV

V této části najdete podrobné informace o nejběžnějších příčinách potíží se soubory FLV.

Potíže se zobrazením kvůli nepřítomnosti souvisejících souborů

Kód vytvořený aplikací Dreamweaver CS4 a novější se odvíjí od čtyř závislých souborů, které se od samotného souboru FLV liší:

  • swfobject_modified.js

  • expressInstall.swf

  • FLVPlayer_Progressive.swf

  • Soubor se vzhledem (např. Clear_Skin_1.swf)

Je třeba si uvědomit, že aplikace Dreamweaver CS4 a novější nabízí v porovnání s aplikací Dreamweaver CS3 další dva závislé soubory.

První dva z těchto souborů (swfobject_modified.js a expressInstall.swf) jsou nainstalovány ve složce Scripts (skripty), která, pokud neexistuje, je aplikací Dreamweaver vytvořena v kořenové složce vašeho webu.

Druhé dva soubory (FLVPlayer_Progressive.swf a soubor se vzhledem) jsou nainstalovány ve stejné složce, kde se nachází stránka s vloženým souborem FLV. Soubor se vzhledem obsahuje ovládací prvky souboru FLV a jeho název závisí na vzhledu, který jste vybrali v nabídce popsané v nápovědě k aplikaci Dreamweaver. Pokud jste např. vybrali vzhled s názvem „Clear Skin“, bude se soubor jmenovat Clear_Skin_1.swf.

Všechny čtyři závislé soubory je třeba nahrát na vzdálený server, jinak se soubor FLV nezobrazí správně.

Pokud tuto podmínku opomenete, nebude ve většině případů možné soubor FLV na webové stránce správně přehrát. Chybí-li některý ze souborů, zobrazí se na vaší stránce „bílé pole“.

Aby bylo jisté, že jste nahráli všechny závislé soubory, nahrajte stránku obsahující soubor FLV pomocí panelu Soubory v aplikaci Dreamweaver. Při nahrávání stránky se vás aplikace Dreamweaver zeptá, zda chcete nahrát závislé soubory (pokud jste tuto funkci nedeaktivovali). Klepněte na tlačítko Ano a soubory nahrajte.

Potíže se zobrazením při lokálním zobrazení náhledu stránek

Kvůli bezpečnostním aktualizacím v aplikaci Dreamweaver CS4 není možné příkazem Náhled v prohlížeči zkontrolovat stránku s vloženým souborem FLV, pokud v nastavení Definice webu v aplikaci Dreamweaver nenastavíte místní testovací server a náhled stránky nezobrazíte pomocí něj.

Za běžných okolností je testovací server potřeba pouze při vytváření stránek pomocí ASP, ColdFusion nebo PHP (viz Nastavení počítače pro vývoj aplikací). Při vytváření webových stránek pouze v jazyce HTML bez nastaveného testovacího serveru můžete stiskem klávesy F12 (Windows) nebo Opt+F12 (Macintosh) vytvořit na obrazovce soupravu ovládacích prvků vzhledu. Možným řešením je buď definovat testovací server a s jeho pomocí zobrazit náhled stránky, nebo nahrát soubory na vzdálený server a zobrazit je tam.

Poznámka:

Příčinou, která brání zobrazení náhledu lokálního obsahu souboru FLV, může být také nastavení zabezpečení. Společnost Adobe však zatím nedokázala tuto možnost potvrdit. Můžete zkusit nastavení zabezpečení upravit a ověřit, zda to váš problém vyřeší. Další informace o změnách nastavení zabezpečení naleznete v tématu Technická poznámka 117502.

Další možné příčiny potíží se soubory FLV

  • Pokud máte potíže se zobrazením náhledu na místním počítači, ujistěte se, že je v nabídce Úpravy > Předvolby > Náhled v reálném čase odznačena možnost Náhled s použitím dočasného souboru.

  • Ujistěte se, že vlastníte nejnovější zásuvný modul FlashPlayer

  • Vyhněte se přesouvání souborů a složek vně aplikaci Dreamweaver. Při přesouvání souborů a složek vně aplikaci Dreamweaver nelze zaručit správnou cestu k souborům související se soubory FLV.

  • Problémový soubor FLV můžete dočasně nahradit jiným, o kterém víte, že pracuje správně. Pokud tento náhradní soubor funguje, není problém v prohlížeči nebo počítači, ale v původním souboru FLV.

Úprava nebo odstranění komponenty FLV

Změňte nastavení videa na webové stránce výběrem vyhrazeného místa pro komponentu videa v okně dokumentu aplikace Dreamweaver a pomocí Inspektoru vlastností. Další možností je odstranění komponenty videa a její opětovné vložení pomocí nabídky Vložit > HTML > Video Flash.

Úprava komponenty FLV

  1. Vyberte vyhrazené místo pro komponentu videa v okně Dokument aplikace Dreamweaver kliknutím na ikonu FLV uprostřed vyhrazeného místa.
  2. Otevřete inspektor Vlastnosti (Okna > Vlastnosti) a proveďte změny.
    Poznámka:

    Pomocí inspektoru Vlastnosti nelze změnit typy videa (například z postupného stahování na streamované). Chcete-li změnit typ videa, odstraňte komponentu FLV a znovu ji vložte prostřednictvím položky Vložit > Média > FLV.

Odstranění komponenty FLV

  1. Vyberte vyhrazené místo pro komponentu FLV v okně Dokumentu aplikace Dreamweaver a stiskněte klávesu Delete.

Přidání videa (jiné formáty)

Postup přidávání videí, která nejsou ve formátu FLV, najdete v části Přidání videa (ne FLV)

Možná také budete chtít vědět, jak v aplikaci Dreamweaver vložit obsah zásuvného modulu, abyste mohli přehrávat soubory MP3 nebo videa Quicktime ve webovém místě aplikace Dreamweaver.

Další podobné nápovědy

 Adobe

Získejte pomoc rychleji a snáze

Nový uživatel?

Adobe MAX 2024

Adobe MAX
Konference věnovaná tvořivosti

14.–16. října Miami Beach a online

Adobe MAX

Konference věnovaná tvořivosti

14.–16. října Miami Beach a online

Adobe MAX 2024

Adobe MAX
Konference věnovaná tvořivosti

14.–16. října Miami Beach a online

Adobe MAX

Konference věnovaná tvořivosti

14.–16. října Miami Beach a online