Pliki można pobierać do edycji i odkładać na serwery lokalne i zdalne za pomocą systemu pobierania i odkładania w programie Dreamweaver, protokołu WebDAV lub narzędzia Subversion.

Jeżeli pracujesz w środowisku współpracy, to możesz odkładać pliki na serwery zdalne i lokalne oraz pobierać je stamtąd do edycji. Jeżeli jednak jesteś jedyną osobą pracującą na serwerze zdalnym, to możesz korzystać z poleceń Odbierz i Wyślij, bez potrzeby pobierania plików do edycji i odkładania.

Uwaga:

Funkcji Wyślij i Odbierz można używać na serwerze testowym. Natomiast nie można odkładać ani pobierać do edycji plików na serwerze testowym.

Pobranie pliku do edycji oznacza oświadczenie "Teraz ja pracuję nad tym plikiem - nie ruszaj go!" Gdy plik jest pobrany do edycji, to na panelu Pliki obok ikony pliku wyświetlana jest nazwa użytkownika, który pobrał plik oraz czerwony ptaszek (jeśli plik pobrał członek zespołu) albo zielony ptaszek (jeśli to ty edytujesz plik).

Odłożenie pliku powoduje, że inni członkowie zespołu mogą pobrać go do edycji. Gdy odkładasz plik po edycji, twoja wersja lokalna tego pliku otrzymuje atrybut 'tylko do odczytu'. Obok tego pliku na panelu Pliki pojawia się ikona kłódki. Uniemożliwia to wprowadzanie zmian w pliku.

Dreamweaver nie oznacza plików pobranych do edycji jako plików „tylko do odczytu” na serwerze zdalnym. Jeżeli prześlesz pliki za pomocą innej aplikacji niż program Dreamweaver, to może dojść do zastąpienia plików pobranych do edycji. Jednak w aplikacjach innych niż program Dreamweaver obok pliku pobranego do edycji w hierarchii plików widoczny jest plik LCK, co pozwala uniknąć podobnych sytuacji.

Konfigurowanie funkcji pobierania do edycji i odkładania plików

Zanim zaczniesz korzystać z funkcji pobierania pliku do edycji i odkładania, musisz skojarzyć serwis lokalny z serwerem zdalnym.

  1. Wybierz polecenie Serwis > Zarządzaj serwisami.
  2. Wybierz serwis i kliknij Edycja.
  3. Wybierz kategorię Serwery w oknie dialogowym Konfiguracja serwisu i wykonaj jedną z następujących czynności:
    • Kliknij przycisk Dodaj nowy serwer, aby dodać nowy serwer.

    • Wybierz istniejący serwer i kliknij przycisk Edytuj istniejący serwer.

  4. Zdefiniuj odpowiednie opcje podstawowe, a następnie kliknij przycisk Zaawansowane.
  5. Jeśli pracujesz w środowisku zespołowym (lub samodzielnie, ale korzystasz z kilku różnych komputerów), zaznacz opcję „Włącz pobieranie pliku do edycji”. Wyłącz tę opcję, jeśli chcesz wyłączyć funkcje pobierania i odkładania plików dla serwisu.

    Ta opcja jest użyteczna, gdyż informuje innych użytkowników, że plik został pobrany do edycji lub, że najnowsza wersja tego pliku znajduje się na innym komputerze.

    Jeżeli nie widać opcji pobierania do edycji i odkładania, to znaczy, że nie ma skonfigurowanego serwera zdalnego.

  6. Zaznacz opcję 'Otwierając, pobierz pliki do edycji', jeżeli chcesz automatycznie pobierać pliki do edycji, gdy dwukrotnie klikniesz je na panelu Pliki, aby je otworzyć.

    Otwieranie pliku za pomocą polecenia z menu Plik > Otwórz, nie powoduje pobierania pliku do edycji, nawet jeśli opcja ta jest wybrana.

  7. Ustaw pozostałe opcje:

    Nazwa konta używanego przy pobieraniu do edycji

    Nazwa ta pojawia się na panelu Pliki obok każdego pliku pobranego do edycji. Pozwala to członkom zespołu skontaktować się z odpowiednią osobą, gdy potrzebny im plik został pobrany do edycji.

    Uwaga:

    Jeśli pracujesz na kilku różnych komputerach, używaj innej nazwy konta do pobierania plików na każdym z nich (np. Ania-MacDomowy i Ania-PCBiuro). W ten sposób będzie wiadomo, gdzie jest najnowsza wersja pliku, jeśli zapomnisz ją zwrócić.

    Adres e-mail

    Jeśli wpiszesz adres e-mail, to po pobraniu przez ciebie pliku do edycji, to twoja nazwa użytkownika wyświetlana obok tego pliku na panelu Pliki będzie hiperłączem (będzie wyświetlana na niebiesko i podkreślona). Gdy ktoś kliknie to łącze, w ich domyślnym programie pocztowym otworzy się nowa wiadomość, z adresem e-mail tej osoby i tematem odpowiadającym nazwie pliku i serwisu.

Zwracanie plików do folderu zdalnego i pobieranie ich do edycji

Po skonfigurowaniu systemu pobierania i odkładania plików, możesz pobierać pliki do edycji z serwera zdalnego i odkładać je na ten serwer za pomocą panelu Pliki albo okna dokumentu.

Pobieranie plików do edycji za pomocą panelu Pliki

  1. Otwórz panel Pliki (Okno > Pliki) i zaznacz pliki, które pobrać do edycji z serwera zdalnego.

    Uwaga:

    Możesz zaznaczyć pliki w widoku Lokalny albo Zdalny, ale nie w widoku serwera testowego.

    Czerwony ptaszek oznacza, że inna osoba już pobrała tej plik do edycji. Symbol kłódki oznacza, że jest to plik tylko do odczytu (Windows) lub zablokowany (Macintosh).

  2. Wykonaj jedną z następujących czynności, aby pobrać pliki do edycji:
    • Kliknij przycisk Pobierz do edycji na pasku narzędziowym panelu Pliki.

    • Kliknij prawym przyciskiem myszy (Windows) lub przytrzymując klawisz Control (Macintosh), a potem wybierz polecenie Pobierz do edycji z menu kontekstowego.

  3. W oknie dialogowym Pliki zależne kliknij Tak, aby pobrać pliki zależne wraz z zaznaczonymi plikami, lub kliknij Nie, aby nie pobierać plików zależnych. Według ustawienia domyślnego, pliki zależne nie są pobierane. Opcję tę możesz ustawić za pomocą polecenia Edycja > Preferencje > Serwis.

    Uwaga:

    Na ogół warto pobierać pliki zależne wraz z nowym plikiem pobieranym do edycji. Jednak jeżeli najnowsze wersje plików zależnych są już na dysku lokalnym, nie trzeba pobierać ich ponownie.

    Obok ikony pliku lokalnego pojawi się zielony ptaszek, oznaczający, że plik został pobrany do edycji przez ciebie.

    Uwaga:

    Jeżeli pobierzesz do edycji plik, który jest w danym momencie aktywny, to otwarta wersja tego pliku zostanie nadpisana wersją pobraną do edycji.

Odkładanie plików za pomocą panelu Pliki

  1. Otwórz panel Pliki (Okno > Pliki) i zaznacz pliki pobrane do edycji.

    Uwaga:

    Możesz zaznaczyć pliki w widoku Lokalny albo Zdalny, ale nie w widoku serwera testowego.

  2. Wykonaj jedną z następujących czynności, aby odłożyć pliki:
    • Kliknij przycisk Odłóż na pasku narzędziowym panelu Pliki.

    • Kliknij prawym przyciskiem myszy (Windows) lub przytrzymując klawisz Control (Macintosh), a potem wybierz polecenie Odłóż z menu kontekstowego.

  3. Kliknij Tak, jeśli chcesz wysłać zależne pliki wraz z zaznaczonymi plikami. Kliknij Nie, aby nie wysyłać zależnych plików. Według ustawienia domyślnego, pliki zależne nie są wysyłane. Opcję tę możesz ustawić za pomocą polecenia Edycja > Preferencje > Serwis.

    Uwaga:

    Na ogół warto wysyłać pliki zależne wraz z nowym plikiem odkładanym na serwer. Jednak jeżeli najnowsze wersje plików zależnych są już na serwerze zdalnym, nie trzeba wysyłać ich ponownie.

    Obok ikony pliku lokalnego pojawi się ikona kłód, wskazująca, że plik ten jest teraz plikiem tylko do odczytu.

    Uwaga:

    Jeżeli odłożysz aktywny w danym momencie plik, to może on zostać automatycznie zapisany przed odłożeniem. Zależy to od ustawionych preferencji.

Odkładanie otwartego pliku z okna Dokument

  1. Sprawdź, czy plik, który chcesz odłożyć, jest otwarty w oknie dokumentu.

    Uwaga:

    Możesz odłożyć tylko jeden otwarty plik na raz.

  2. Wykonaj jedną z następujących czynności:
    • Wybierz polecenie Serwis > Odłóż.

    • Kliknij ikonę Zarządzanie plikami na pasku narzędziowym okna dokumentu. Z menu wybierz polecenie Odłóż.

      Jeśli bieżący plik nie jest częścią aktywnego serwisu w panelu Pliki, program Dreamweaver spróbuje określić, do którego serwisu lokalnego należy bieżący plik. Jeżeli bieżący plik należy do innego serwisu niż serwis aktywny na panelu Pliki, program Dreamweaver otworzy ten serwis i wykona operację odkładania.

    Uwaga:

    Jeżeli odłożysz aktywny w danym momencie plik, to może on zostać automatycznie zapisany przed odłożeniem. Zależy to od ustawionych preferencji.  

Cofanie pobrania pliku do edycji

Jeżeli pobierzesz plik do edycji, ale postanowisz go nie edytować (albo odrzucić wprowadzone zmiany), to możesz cofnąć operację pobierania i przywrócić oryginalny stan pliku.

Aby cofnąć pobranie pliku do edycji, wykonaj jedną z następujących czynności:

  • Otwórz plik w oknie dokumentu i wybierz polecenie Serwis > Cofnij pobieranie do edycji.

  • Otwórz panel Pliki (Okno > Pliki). Kliknij panel prawym przyciskiem myszy (Windows) lub przytrzymując klawisz Control (Macintosh) i wybierz polecenie Cofnij pobieranie do edycji.

    Lokalna kopia pliku przechodzi w stan "tylko do odczytu". Wszystkie wprowadzone przez ciebie zmiany zostaną utracone.

Korzystanie z WebDAV do odkładania i pobierania plików

Program Dreamweaver może łączyć się z serwerem używającym protokołu zarządzania wersjami WebDAV (Web-based Distributed Authoring and Versioning). Jest to zbiór rozszerzeń protokołu HTTP, który umożliwia obsługę współpracy przy edycji plików na zdalnych serwerach WWW. Więcej informacji: www.webdav.org

  1. Najpierw skonfiguruj serwis programu Dreamweaver (jeżeli jeszcze go nie masz), który będzie wskazywał folder lokalny, służący do przechowywania plików projektu.
  2. Wybierz polecenie Serwis > Zarządzaj serwisami i dwukrotnie kliknij swój serwis na liście.
  3. Wybierz kategorię Serwery w oknie dialogowym Konfiguracja serwisu i wykonaj jedną z następujących czynności:
    • Kliknij przycisk Dodaj nowy serwer, aby dodać nowy serwer.

    • Wybierz istniejący serwer i kliknij przycisk Edytuj istniejący serwer.

  4. Na ekranie Podstawowe wybierz opcję WebDAV z wyskakującego menu Połącz za pomocą. W razie potrzeby ustaw także pozostałe opcje na ekranie Podstawowe.
  5. Kliknij przycisk Zaawansowane.
  6. Zaznacz opcję Włącz pobieranie pliku do edycji. Wpisz następujące informacje:
    • W polu Nazwa do pobierania do edycji wpisz nazwę, po której rozpoznają cię inni członkowie zespołu.

    • W polu Adres e-mail wpisz swój adres e-mail.

      Nazwa i adres e-mail służą do identyfikowania właściciela na serwerze WebDAV i pojawiają się na panelu Pliki jako dane kontaktowe.

  7. Kliknij przycisk Zapisz.

    Dreamweaver skonfiguruje dostęp WebDAV do serwisu. Gdy użyjesz polecenia Odłóż albo Pobierz do edycji wobec dowolnego pliku w tym serwisie, to plik ten zostanie przesłany za pomocą protokołu WebDAV.

    Uwaga:

    Protokół WebDAV może nie zapewniać poprawnego pobierania do edycji plików z dynamiczną zawartością, np. znacznikami PHP albo dołączeniami po stronie serwera, ponieważ są one generowane przez operację HTTP GET w momencie pobierania.

Pobieranie i odkładanie plików za pomocą oprogramowania Subversion (SVN)

Uwaga:

W wersji Dreamweaver CC 2017 i nowszych wycofano obsługę platformy Subversion (SVN).

Program Dreamweaver może połączyć się z serwerem korzystającym z platformy Subversion (SVN). Jest to system kontroli wersji, który umożliwia wspólną pracę nad plikami przechowywanymi na serwerach WWW, np. zarządzanie nimi i ich edycję. Program Dreamweaver nie jest w pełni zintegrowany z systemem SVN, ale mimo to pozwala pobierać najnowsze wersje plików, wprowadzać w nich zmiany i zatwierdzać pliki.

Uwaga:

Program Dreamweaver CS5 korzysta z biblioteki klienta Subversion 1.6.6, natomiast program Dreamweaver CS5.5 korzysta z wersji 1.6.9 tej biblioteki. Późniejsze wersje biblioteki Subversion nie zapewniają zgodności wstecznej. Należy pamiętać, że aktualizacja innej aplikacji klienckiej (np. TortoiseSVN) do współpracy z nowszą wersją rozwiązania Subversion pociągnie za sobą również aktualizację lokalnych metadanych Subversion. W wyniku tego program Dreamweaver nie będzie już mógł komunikować się z rozwiązaniem Subversion. Problem ten nie występuje w przypadku aktualizacji serwera Subversion — te aktualizacje zapewniają zgodność wsteczną. W przypadku aktualizacji innej aplikacji klienckiej, współpracującej z wersją Subversion 1.7 lub nowszą, przed użyciem programu Dreamweaver w połączeniu z rozwiązaniem Subversion konieczne będzie uzyskanie uaktualnień publikowanych przez firmę Adobe. Więcej informacji na ten temat podano na stronie www.adobe.com/go/dw_svn_en.

Jeśli użytkownik korzysta z plików kontrolowanych za pomocą systemu SVN, firma Adobe zaleca stosowanie niezależnego narzędzia do porównywania plików. Porównanie plików i określenie różnic między nimi pozwala zorientować się, jakiego rodzaju zmiany wprowadzili w plikach inni użytkownicy. Więcej informacji o narzędziach do porównywania plików możesz znaleźć za pomocą wyszukiwarki internetowej, np. Google Search, wpisując hasło "narzędzia" i "porównywanie plików". Program Dreamweaver współpracuje z większością narzędzi innych firm.

Film poglądowy dotyczący pracy z systemem SVN w programie Dreamweaver znajduje się na stronie www.adobe.com/go/lrvid4049_dw.

Konfigurowanie połączenia SVN

Aby korzystać z aplikacji Subversion (SVN) jako systemu kontroli wersji w programie Dreamweaver, należy najpierw skonfigurować połączenie z serwerem SVN. Służy do tego kategoria opcji Kontrola wersji w oknie dialogowym Definicja serwisu.

Serwer SVN to repozytorium, czyli składnica plików. Użytkownicy mogą pobierać stamtąd pliki do edycji i odkładać je (potwierdzać). Składnica plików SVN różni się od zdalnych serwerów, z jakich na ogół korzysta się w programie Dreamweaver. W przypadku korzystania z programu SVN, zdalny serwer pełni rolę “serwera produkcyjnego” stron WWW, który obsługuje serwis na bieżąco. Natomiast zadaniem serwera SVN jest składowanie plików, które muszą być poddawane kontroli wersji. Typowy przepływ pracy z użyciem serwera SVN wiąże się z wielokrotnym pobieraniem plików do edycji i odkładaniem ich na ten serwer. Później pliki te są publikowane na serwerze zdalnym za pomocą programu Dreamweaver. Konfiguracja serwera zdalnego jest zupełnie inna od konfiguracji serwera SVN.

Konfigurowanie serwera SVN można rozpocząć tylko wtedy, gdy użytkownik ma dostęp do niego oraz do znajdującego się na nim repozytorium plików. Więcej informacji na temat rozwiązania SVN można znaleźć na stronie internetowej Subversion pod adresem http://subversion.apache.org/.

Aby skonfigurować połączenie z serwerem SVN, wykonaj następujące czynności:

  1. Wybierz polecenie Serwis > Zarządzaj serwisami. Wybierz serwis, dla którego chcesz skonfigurować kontrolę wersji, a następnie kliknij przycisk Edytuj.

    Uwaga:

    Jeśli dla serwisu nie skonfigurowano jeszcze folderów zdalnych i lokalnych w programie Dreamweaver, to przed wykonaniem kolejnych czynności trzeba skonfigurować przynajmniej serwis lokalny. (Na tym etapie serwis zdalny nie jest jeszcze wymagany, ale przed opublikowaniem plików w Internecie trzeba będzie go utworzyć). Więcej informacji zawiera sekcja Praca z serwisami programu Dreamweaver.

  2. W oknie dialogowym Konfiguracja serwisu wybierz kategorię Kontrola wersji.

  3. Z wyskakującego menu Dostęp wybierz polecenie Subversion.

  4. Ustaw opcje dostępu:

    • Z wyskakującego menu Protokół wybierz odpowiedni protokół. Dostępne protokoły to HTTP, HTTPS, SVN i SVN+SSH.

    Uwaga:

    Korzystanie z protokołu SVN+SSH wymaga specjalnej konfiguracji. Więcej informacji: www.adobe.com/go/learn_dw_svn_ssh_en.

    • Wprowadź adres serwera SVN w polu tekstowym Adres serwera (zwykle adres ma postać nazwaserwera.domena.com).

    • W polu tekstowym Ścieżka repozytorium wprowadź ścieżkę dostępu do repozytorium na serwerze SVN (zwykle ścieżka ma postać /svn/katalog_główny_użytkownika. Nazwę głównego folderu repozytorium SVN określa administrator serwera).

    • (Opcjonalnie) Jeśli chcesz używać innego numeru portu serwera niż domyślny, wybierz opcję Brak domyślnych i wpisz odpowiedni numer portu w polu tekstowym.

    • Wpisz swoją nazwę użytkownika na serwerze SVN i odpowiednie hasło.

  5. Kliknij przycisk Testuj, aby sprawdzić połączenie. Jeśli chcesz zamknąć okno dialogowe, kliknij przycisk OK. Potem kliknij przycisk Gotowe, aby zamknąć okno dialogowe Zarządzaj serwisami.

Po nawiązaniu połączenia z serwerem repozytorium SVN staje się dostępne i można je oglądać w panelu Pliki. Repozytorium wyświetla się za pomocą polecenia Widok repozytorium w wyskakującym menu Widok albo używając przycisku Pliki repozytorium (w rozwiniętym panelu Pliki).

Pobieranie najnowszych wersji plików

Podczas pobierania najnowszej wersji pliku z repozytorium SVN, program Dreamweaver łączy zawartość tego pliku z zawartością odpowiadającej mu kopii lokalnej. (Oznacza to, że jeśli odłożysz zatwierdzony plik na serwer, a ktoś go później zmodyfikuje, to przy kolejnym pobieraniu wprowadzone przez tę osobę modyfikacje zostaną dołączone do twojej lokalnej wersji pliku). Jeśli danego pliku nie ma jeszcze na lokalnym dysku twardym, to Dreamweaver po prostu pobiera taki plik.

Uwaga:

Pobierając pliki z repozytorium po raz pierwszy, należy używać pustego katalogu lokalnego albo takiego katalogu lokalnego, który nie zawiera plików o nazwach tożsamych z nazwami plików w repozytorium. Jeśli katalog lokalny będzie zawierał jakieś pliki o identycznych nazwach jak pliki ze zdalnego repozytorium, to przy pierwszej próbie program Dreamweaver nie zainstaluje plików repozytorium w katalogu lokalnym.

  1. Sprawdź, czy połączenie z serwerem SVN zostało prawidłowo skonfigurowane.

  2. Wykonaj jedną z następujących czynności:

    • Wyświetl lokalną wersję plików SVN w panelu Pliki, wybierając widok lokalny z wyskakującego menu Widok. (Jeśli posługujesz się rozwiniętym panelem Pliki, to widok lokalny wyświetla się automatycznie). Kliknij pożądany folder prawym przyciskiem myszy (Windows) lub przytrzymując klawisz Control (Macintosh) i wybierz polecenia Kontrola wersji > Pobierz najnowsze wersje.

    • Wyświetl pliki repozytorium, wybierając polecenie Widok repozytorium z wyskakującego menu Widok albo klikając przycisk Pliki repozytorium (w rozwiniętym panelu Pliki). Kliknij pożądany plik albo folder prawym przyciskiem myszy (Windows) lub przytrzymując klawisz Control (Macintosh) i wybierz polecenie Pobierz najnowsze wersje.

Uwaga:

Możesz też kliknąć prawym przyciskiem myszy i wybrać z menu kontekstowego polecenie Pobierz do edycji, albo zaznaczyć plik, kliknąć przycisk Pobierz do edycji i pobrać jego najnowszą wersję. Należy przy tym pamiętać, że SVN nie obsługuje przepływu pracy związanego z pobieraniem do edycji. Dlatego naciśnięcie tego przycisku nie spowoduje pobrania pliku do edycji w tradycyjnym znaczeniu tego terminu.

Zatwierdzanie odkładanych plików

  1. Sprawdź, czy połączenie z serwerem SVN zostało prawidłowo skonfigurowane.

  2. Wykonaj jedną z następujących czynności:

    • Wyświetl lokalną wersję plików SVN w panelu Pliki, wybierając widok lokalny z wyskakującego menu Widok. (Jeśli posługujesz się rozwiniętym panelem Pliki, to widok lokalny wyświetla się automatycznie). Następnie wybierz plik, który chcesz zatwierdzić i kliknij przycisk Odłóż.

    • Wyświetl pliki repozytorium, wybierając polecenie Widok repozytorium z wyskakującego menu Widok albo klikając przycisk Pliki repozytorium (w rozwiniętym panelu Pliki). Kliknij plik, który chcesz zatwierdzić, prawym przyciskiem myszy (Windows) lub przytrzymując klawisz Control (Macintosh), a następnie wybierz polecenie Odłóż.

  3. Przejrzyj czynności wymienione w oknie dialogowym Zatwierdzanie. W razie potrzeby wprowadź zmiany, a następnie kliknij przycisk OK.

    Aby zmienić czynność, zaznacz ją i kliknij jeden z przycisków na dole okna dialogowego Zatwierdzanie. Dostępne są dwie możliwości: zatwierdzanie i ignorowanie.

Uwaga:

Zielony znak “ptaszka” obok pliku w panelu Pliki oznacza plik zmieniony, który nie został jeszcze zatwierdzony i odesłany do repozytorium.

Uaktualnianie stanu plików lub folderów w repozytorium

Program pozwala uaktualnić stan SVN pojedynczego pliku lub folderu. Uaktualnienie nie powoduje odświeżenia całej zawartości ekranu.

  1. Sprawdź, czy połączenie z serwerem SVN zostało prawidłowo skonfigurowane.

  2. Wyświetl pliki repozytorium, wybierając polecenie Widok repozytorium z wyskakującego menu Widok albo klikając przycisk Pliki repozytorium (w rozwiniętym panelu Pliki).

  3. Kliknij prawym przyciskiem myszy (Windows) lub przytrzymując klawisz Control (Macintosh) dowolny folder lub plik w repozytorium i wybierz polecenie Uaktualnij status.

Uaktualnianie stanu lokalnych plików lub folderów

Program pozwala uaktualnić stan SVN pojedynczego pliku lub folderu. Uaktualnienie nie powoduje odświeżenia całej zawartości ekranu.

  1. Sprawdź, czy połączenie z serwerem SVN zostało prawidłowo skonfigurowane.

  2. Wyświetl lokalną wersję plików SVN w panelu Pliki, wybierając widok lokalny z wyskakującego menu Widok. (Jeśli posługujesz się rozwiniętym panelem Pliki, to widok lokalny wyświetla się automatycznie).

  3. Kliknij prawym przyciskiem myszy (Windows) lub przytrzymując klawisz Control (Macintosh) dowolny folder lub plik z panelu Pliki i wybierz polecenie Uaktualnij status.

Wyświetlanie poprawek pliku

  1. Sprawdź, czy połączenie z serwerem SVN zostało prawidłowo skonfigurowane.

  2. Wykonaj jedną z następujących czynności:

    • Wyświetl lokalną wersję plików SVN w panelu Pliki, wybierając widok lokalny z wyskakującego menu Widok. (Jeśli posługujesz się rozwiniętym panelem Pliki, to widok lokalny wyświetla się automatycznie). Kliknij plik, którego poprawki chcesz wyświetlić, prawym przyciskiem myszy (Windows) lub przytrzymując klawisz Control (Macintosh), a następnie wybierz polecenie Kontrola wersji > Pokaż poprawki.

    • Wyświetl pliki repozytorium, wybierając polecenie Widok repozytorium z wyskakującego menu Widok albo klikając przycisk Pliki repozytorium (w rozwiniętym panelu Pliki). Kliknij plik, którego poprawki chcesz wyświetlić, prawym przyciskiem myszy (Windows) lub przytrzymując klawisz Control (Macintosh), a następnie wybierz polecenie Pokaż poprawki.

  3. W oknie dialogowym Historia zmian zaznacz interesujące cię poprawki pliku i wykonaj jedną z następujących czynności:

    • Kliknij przycisk Porównaj z lokalną, aby porównać wybraną poprawkę pliku z jego lokalną wersją.

    Uwaga:

    Aby móc porównywać pliki należy zainstalować niezależne narzędzie do porównywania plików. Więcej informacji o narzędziach do porównywania plików możesz znaleźć za pomocą wyszukiwarki internetowej, np. Google Search, wpisując hasło "narzędzia" i "porównywanie plików". Program Dreamweaver współpracuje z większością narzędzi innych firm.

    • Kliknij przycisk Porównaj, aby porównać dwie wybrane poprawki pliku. Aby zaznaczyć jednocześnie dwie poprawki, należy je kliknąć, przytrzymując klawisz Control.

    • Kliknij przycisk Wyświetl, aby wyświetlić zaznaczoną poprawkę. Nie spowoduje to zastąpienia istniejącej, lokalnej kopii tego samego pliku. Zaznaczoną poprawkę można zapisać na dysku twardym w taki sam sposób, jak każdy inny plik.

    • Kliknij przycisk Zmień na bieżącą, aby zaznaczona poprawka otrzymała status najbardziej aktualnej w repozytorium.

Blokowanie i odblokowywanie plików

Blokując plik w repozytorium SVN, powiadamiasz tym samym innych użytkowników, że w danej chwili pracujesz nad plikiem. Inni użytkownicy mogą nadal edytować plik lokalnie, ale wprowadzonych zmian nie mogą zatwierdzić aż do momentu odblokowania pliku. Gdy zablokujesz plik w repozytorium, zostanie on oznaczony ikoną otwartej kłódki. Inni użytkownicy będą widzieć ikonę zamkniętej kłódki.

  1. Sprawdź, czy połączenie z serwerem SVN zostało prawidłowo skonfigurowane.

  2. Wykonaj jedną z następujących czynności:

    • Wyświetl pliki repozytorium, wybierając polecenie Widok repozytorium z wyskakującego menu Widok albo klikając przycisk Pliki repozytorium (w rozwiniętym panelu Pliki). Kliknij pożądany plik prawym przyciskiem myszy (Windows) lub przytrzymując klawisz Control (Macintosh) i wybierz polecenie Zablokuj albo Odblokuj.

    • Wyświetl lokalną wersję plików SVN w panelu Pliki, wybierając widok lokalny z wyskakującego menu Widok. (Jeśli posługujesz się rozwiniętym panelem Pliki, to widok lokalny wyświetla się automatycznie). Kliknij pożądany plik prawym przyciskiem myszy (Windows) lub przytrzymując klawisz Control (Macintosh) i wybierz polecenie Zablokuj albo Odblokuj.

Dodawanie nowego pliku do repozytorium

Niebieski plus obok nazwy pliku w panelu Pliki oznacza, że nie ma go jeszcze w repozytorium SVN.

  1. Sprawdź, czy połączenie z serwerem SVN zostało prawidłowo skonfigurowane.

  2. Otwórz panel Pliki i zaznacz plik, który chcesz dodać do repozytorium, a następnie kliknij przycisk Odłóż.

  3. W oknie dialogowym Zatwierdzanie sprawdź, czy dany plik został zaznaczony do zatwierdzania, a następnie kliknij przycisk OK.

Przenoszenie, kopiowanie, usuwanie i przywracanie plików

  • Aby przenieść plik, przeciągnij go do folderu docelowego w serwisie lokalnym.

    Po przeniesieniu pliku, program Dreamweaver oznacza plik w nowym miejscu znakiem Dodaj z historią. Natomiast plik w starym położeniu jest oznaczany znakiem Usuń. Po zatwierdzeniu tych plików, plik ze starego położenia znika.

  • Aby skopiować plik, zaznacz go, skopiuj (Edycja > Kopiuj) i wklej (Edycja > Wklej) w nowym miejscu.

    Po skopiowaniu i wklejeniu pliku, program Dreamweaver oznacza plik w nowym położeniu znakiem Dodaj z historią.

  • Aby usunąć plik, zaznacz go i naciśnij klawisz Delete.

    Program Dreamweaver umożliwia usunięcie tylko lokalnej wersji pliku albo zarówno wersji lokalnej, jak i wersji na serwerze SVN. Jeśli postanowisz usunąć tylko lokalną wersję, plik na serwerze SVN pozostanie bez zmian. Jeśli postanowisz usunąć również wersję na serwerze SVN, wersja lokalna otrzyma znak Usuń. Musisz przeprowadzić operację zatwierdzania pliku, aby nastąpiło jego usunięcie.

  • Aby przywrócić skopiowany lub przeniesiony plik w oryginalnym położeniu, kliknij plik prawym przyciskiem myszy i wybierz polecenie Kontrola wersji > Przywróć.

Rozwiązywanie konfliktów między wersjami plików

Jeśli plik pozostaje w konflikcie z innym plikiem na serwerze, możesz otworzyć go do edycji i oznaczyć jako rozpoznany. Na przykład, jeśli usiłujesz odłożyć plik, który jest niezgodny ze zmianami wprowadzonymi przez innego użytkownika, system SVN nie zezwala na zatwierdzenie pliku. Możesz wtedy pobrać najnowszą wersję pliku z repozytorium, wprowadzić zmiany w swojej kopii roboczej, oznaczyć plik jako rozpoznany, a następnie zatwierdzić go.

  1. Sprawdź, czy połączenie z serwerem SVN zostało prawidłowo skonfigurowane.

  2. Wyświetl lokalną wersję plików SVN w panelu Pliki, wybierając widok lokalny z wyskakującego menu Widok. (Jeśli posługujesz się rozwiniętym panelem Pliki, to widok lokalny wyświetla się automatycznie).

  3. Kliknij odpowiedni plik prawym przyciskiem myszy (Windows) lub przytrzymując klawisz Control (Macintosh), a następnie wybierz polecenie Kontrola wersji > Oznacz jako rozpoznane.

Praca w trybie offline

Podczas niektórych czynności związanych z przenoszeniem plików warto czasem wyłączyć dostęp do repozytorium. Można to zrobić, przechodząc w tryb pracy offline. Program Dreamweaver połączy się ponownie z repozytorium SVN w momencie wybrania czynności wymagającej takiego połączenia (pobieranie najnowszych wersji, zatwierdzanie itp.).

  1. Sprawdź, czy połączenie z serwerem SVN zostało prawidłowo skonfigurowane.

  2. Wyświetl lokalną wersję plików SVN w panelu Pliki, wybierając widok lokalny z wyskakującego menu Widok. (Jeśli posługujesz się rozwiniętym panelem Pliki, to widok lokalny wyświetla się automatycznie).

  3. Kliknij prawym przyciskiem myszy (Windows) lub przytrzymując klawisz Control (Macintosh) dowolny folder lub plik w panelu Pliki i wybierz polecenie Kontrola wersji > Przejdź do trybu offline.

Oczyszczanie lokalnego serwisu SVN

To polecenie pozwala usunąć z pliku blokady, dzięki czemu można wznowić niedokończone operacje. W przypadku wystąpienia błędów typu "zablokowane kopie robocze" polecenia tego należy użyć do usunięcia starych blokad.

  1. Sprawdź, czy połączenie z serwerem SVN zostało prawidłowo skonfigurowane.

  2. Wyświetl lokalną wersję plików SVN w panelu Pliki, wybierając widok lokalny z wyskakującego menu Widok. (Jeśli posługujesz się rozwiniętym panelem Pliki, to widok lokalny wyświetla się automatycznie).

  3. Kliknij plik, który chcesz oczyścić, prawym przyciskiem myszy (Windows) lub przytrzymując klawisz Control (Macintosh), a następnie wybierz polecenie Kontrola wersji > Oczyść.

Przenoszenie plików i folderów w serwisach kontrolowanych przez system Subversion

Przenoszenie lokalnych wersji plików lub folderów w ramach serwisu kontrolowanego przez rozwiązanie Subversion może narazić na problemy innych użytkowników, próbujących przeprowadzić synchronizację z repozytorium SVN. Na przykład jeśli przeniesie się plik w lokalnej strukturze folderów i przez kilka godzin nie zatwierdzi tej zmiany w repozytorium, to inny użytkownik może w tym czasie próbować pobrać najnowszą wersję tego pliku z poprzedniego miejsca. Dlatego też wszystkie pliki przeniesione lokalnie należy zawsze natychmiast zatwierdzać na serwerze SVN.

Pliki i foldery pozostają na serwerze SVN dopóki nie usunie się ich ręcznie. Zatem samo przeniesienie pliku do innego folderu lokalnego i zatwierdzenie tej zmiany nie spowoduje usunięcia starej wersji z poprzedniego miejsca na serwerze. Dla uniknięcia nieporozumień warto usuwać stare kopie przeniesionych plików i folderów.

Przeniesienie pliku lokalnie i zatwierdzenie go na serwerze SVN powoduje usunięcie historii wersji tego pliku.

Ta zawartość jest licencjonowana na warunkach licencji Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Posty z serwisów Twitter™ i Facebook nie są objęte licencją Creative Commons.

Informacje prawne   |   Zasady prywatności online