Podręcznik użytkownika Anuluj

Podgląd stron

  1. Podręcznik użytkownika programu Dreamweaver
  2. Wprowadzenie
    1. Podstawy projektowania serwisów WWW o elastycznym układzie
    2. Dreamweaver — co nowego
    3. Programowanie zawartości WWW za pomocą programu Dreamweaver — przegląd
    4. Dreamweaver / Popularne pytania
    5. Skróty klawiszowe
    6. Wymagania systemowe programu Dreamweaver
    7. Podsumowanie funkcji
  3. Program Dreamweaver a platforma Creative Cloud
    1. Synchronizowanie ustawień programu Dreamweaver z chmurą Creative Cloud
    2. Biblioteki Creative Cloud w programie Dreamweaver
    3. Używanie plików programu Photoshop w programie Dreamweaver
    4. Praca z programami Adobe Animate oraz Dreamweaver
    5. Wydzielanie przygotowanych do wyświetlania w Internecie plików SVG z bibliotek
  4. Przestrzenie robocze i widoki w programie Dreamweaver
    1. Przestrzeń robocza programu Dreamweaver
    2. Optymalizacja przestrzeni roboczej programu Dreamweaver do programowania wizualnego
    3. Wyszukiwanie plików według nazwy lub zawartości | Mac OS
  5. Konfigurowanie serwisów
    1. Informacje o serwisach programu Dreamweaver
    2. Konfigurowanie lokalnej wersji serwisu
    3. Nawiązywanie połączenia z serwerem publikacji
    4. Konfigurowanie serwera testowego
    5. Importowanie i eksportowanie ustawień serwisu programu Dreamweaver
    6. Przenoszenie istniejących serwisów z serwera zdalnego do lokalnego katalogu głównego serwisu
    7. Funkcje ułatwień dostępu w programie Dreamweaver
    8. Ustawienia zaawansowane
    9. Ustawianie preferencji serwisu dotyczących transferu plików
    10. Określanie ustawień serwera proxy w programie Dreamweaver
    11. Synchronizowanie ustawień programu Dreamweaver z chmurą Creative Cloud
    12. Korzystanie z systemu Git w programie Dreamweaver
  6. Zarządzanie plikami
    1. Tworzenie i otwieranie plików
    2. Zarządzanie plikami i folderami
    3. Odbieranie plików i wysyłanie ich na serwer
    4. Pobieranie plików do edycji i odkładanie ich na serwer
    5. Synchronizacja plików
    6. Porównywanie plików w poszukiwaniu różnic
    7. Maskowanie plików i folderów w serwisie programu Dreamweaver
    8. Włączanie funkcji Uwagi do projektu w serwisach programu Dreamweaver
    9. Zapobieganie potencjalnemu obejściu funkcji Gatekeeper
  7. Układ i projekt
    1. Korzystanie z wizualnych pomocy do układu
    2. Informacje o tworzeniu układu strony za pomocą stylów CSS
    3. Projektowanie elastycznych serwisów WWW z użyciem struktury Bootstrap
    4. Tworzenie i używanie zapytań o media w programie Dreamweaver
    5. Prezentacja zawartości za pomocą tabel
    6. Kolory
    7. Tworzenie reagujących projektów za pomocą układów elastycznej siatki
    8. Narzędzie Extract w programie Dreamweaver
  8. CSS
    1. Podstawowe informacje o stylach CSS
    2. Tworzenie układu strony za pomocą panelu Projektant CSS
    3. Korzystanie z preprocesorów CSS w programie Dreamweaver
    4. Ustawianie preferencji stylów CSS w programie Dreamweaver
    5. Przenoszenie reguł CSS w programie Dreamweaver
    6. Konwertowanie stylu CSS wewnątrz znacznika na regułę CSS w programie Dreamweaver
    7. Posługiwanie się znacznikami DIV
    8. Stosowanie gradientów na tło
    9. Tworzenie i edytowanie efektów przejść CSS3 w programie Dreamweaver
    10. Formatowanie kodu
  9. Zawartość strony i zasoby
    1. Ustawianie właściwości strony
    2. Ustawianie właściwości CSS dla nagłówków i łączy
    3. Praca z tekstem
    4. Znajdowanie i zastępowanie tekstu, znaczników i atrybutów
    5. Panel DOM
    6. Edytowanie w widoku aktywnym
    7. Kodowanie znaków dokumentu w programie Dreamweaver
    8. Zaznaczanie i wyświetlanie elementów w oknie Dokument
    9. Ustawianie właściwości tekstu na panelu Inspektor właściwości
    10. Sprawdzanie pisowni na stronie internetowej
    11. Używanie linii poziomych w programie Dreamweaver
    12. Dodawanie i modyfikowanie kombinacji czcionek w programie Dreamweaver
    13. Praca z zasobami
    14. Wstawianie i aktualizowanie dat w programie Dreamweaver
    15. Tworzenie list ulubionych zasobów w programie Dreamweaver i zarządzanie nimi
    16. Wstawianie i edytowanie obrazów w programie Dreamweaver
    17. Dodawanie obiektów multimedialnych
    18. Dodawanie zawartości wideo w programie Dreamweaver
    19. Wstawianie wideo HTML5
    20. Wstawianie plików SWF
    21. Dodawanie efektów dźwiękowych
    22. Wstawianie obiektów audio HTML5 w programie Dreamweaver
    23. Praca z elementami bibliotek
    24. Stosowanie pisma arabskiego i hebrajskiego w programie Dreamweaver
  10. Łączenie i przeglądanie
    1. Informacje o łączeniu i przeglądaniu stron
    2. Tworzenie łączy
    3. Mapy obrazu
    4. Rozwiązywanie problemów dotyczących łączy
  11. Efekty i widgety jQuery
    1. Używanie widgetów jQuery interfejsu użytkownika i elementów mobilnych w programie Dreamweaver
    2. Używanie efektów jQuery w programie Dreamweaver
  12. Tworzenie kodu serwisów WWW
    1. Informacje o tworzeniu kodu w programie Dreamweaver
    2. Środowisko programistyczne w programie Dreamweaver
    3. Ustawianie preferencji kodowania
    4. Dostosowywanie ustawień kolorowania kodu
    5. Pisanie i edytowanie kodu
    6. Podpowiedzi i uzupełnianie kodu
    7. Zwijanie i rozwijanie kodu
    8. Ponowne wykorzystywanie fragmentów kodu za pomocą funkcji Urywki
    9. Linting: oczyszczanie kodu z błędów
    10. Optymalizacja kodu
    11. Edytowanie kodu w widoku Projekt
    12. Praca z zawartością znacznika HEAD strony
    13. Wstawianie dołączeń po stronie serwera w programie Dreamweaver
    14. Korzystanie z bibliotek znaczników w programie Dreamweaver
    15. Importowanie własnych znaczników do programu Dreamweaver
    16. Używanie zachowań JavaScript (instrukcje ogólne)
    17. Stosowanie wbudowanych zachowań JavaScript
    18. Omówienie języków XML i XSLT
    19. Wykonywanie transformacji XSL po stronie serwera w programie Dreamweaver
    20. Wykonywanie przekształceń XSL po stronie klienta w programie Dreamweaver
    21. Dodawanie encji znaków w kodzie XSLT w programie Dreamweaver
    22. Formatowanie kodu
  13. Obiegi pracy związane z wieloma produktami
    1. Instalowanie i używanie rozszerzeń programu Dreamweaver
    2. Aktualizacje w aplikacji w programie Dreamweaver
    3. Wstawianie dokumentów Microsoft Office w programie Dreamweaver (tylko Windows)
    4. Praca z programami Fireworks i Dreamweaver
    5. Edycja zawartości w stronach programu Dreamweaver za pomocą aplikacji Contribute
    6. Integracja programu Dreamweaver z aplikacją Business Catalyst
    7. Tworzenie spersonalizowanych kampanii rozsyłanych pocztą elektroniczną
  14. Szablony
    1. Informacje o szablonach programu Dreamweaver
    2. Rozpoznawanie szablonów oraz dokumentów opartych na szablonach
    3. Tworzenie szablonu programu Dreamweaver
    4. Tworzenie edytowalnych regionów w szablonach
    5. Tworzenie powtarzalnych regionów i tabel w programie Dreamweaver
    6. Używanie regionów opcjonalnych w szablonach
    7. Definiowanie edytowalnych atrybutów znacznika w programie Dreamweaver
    8. Tworzenie zagnieżdżonych szablonów w programie Dreamweaver
    9. Edytowanie, aktualizowanie i usuwanie szablonów
    10. Eksportowanie i importowanie zawartości XML w programie Dreamweaver
    11. Stosowanie szablonu lub usuwanie go z istniejącego dokumentu
    12. Edycja zawartości w szablonach programu Dreamweaver
    13. Reguły składni dla znaczników szablonu w programie Dreamweaver
    14. Ustawianie preferencji podświetlenia dla regionów szablonów
    15. Korzyści wynikające z używania szablonów w programie Dreamweaver
  15. Urządzenia mobilne i obsługa wielu ekranów
    1. Tworzenie zapytań o media
    2. Zmiana orientacji strony na urządzeniach mobilnych
    3. Tworzenie aplikacji internetowych przeznaczonych na urządzenia mobilne za pomocą programu Dreamweaver
  16. Dynamiczne serwisy, strony i formularze WWW
    1. Podstawowe informacje o aplikacjach internetowych
    2. Konfigurowanie komputera do programowania aplikacji
    3. Rozwiązywanie problemów z połączeniami z bazą danych
    4. Usuwanie skryptów połączenia w programie Dreamweaver
    5. Projektowanie stron dynamicznych
    6. Omówienie źródeł zawartości dynamicznej
    7. Definiowanie źródeł zawartości dynamicznej
    8. Dodawanie dynamicznej zawartości do stron
    9. Modyfikowanie dynamicznej zawartości w programie Dreamweaver
    10. Wyświetlanie rekordów z bazy danych
    11. Udostępnianie aktywnych danych w programie Dreamweaver oraz rozwiązywanie problemów z takimi danymi
    12. Dodawanie własnych zachowań serwerowych w programie Dreamweaver
    13. Tworzenie formularzy w programie Dreamweaver
    14. Zbieranie informacji od użytkowników za pomocą formularzy
    15. Tworzenie oraz włączanie formularzy ColdFusion w programie Dreamweaver
    16. Tworzenie formularzy WWW
    17. Rozszerzona obsługa elementów formularza w języku HTML5
    18. Tworzenie formularzy za pomocą programu Dreamweaver
  17. Tworzenie aplikacji metodą graficzną
    1. Tworzenie stron wzorca i szczegółów w programie Dreamweaver
    2. Tworzenie stron wyszukiwania i wyników
    3. Tworzenie strony wstawiania rekordów
    4. Tworzenie strony uaktualniania rekordów w programie Dreamweaver
    5. Tworzenie stron usuwania rekordów w programie Dreamweaver
    6. Używanie poleceń ASP do modyfikacji bazy danych w programie Dreamweaver
    7. Tworzenie strony rejestracji
    8. Tworzenie strony logowania
    9. Tworzenie strony, do której dostęp będą mieli tylko uwierzytelnieni użytkownicy
    10. Zabezpieczanie folderów w aplikacji ColdFusion za pomocą programu Dreamweaver
    11. Korzystanie ze składników ColdFusion w programie Dreamweaver
  18. Testowanie, podgląd i publikacja serwisów WWW
    1. Podgląd stron
    2. Podgląd stron WWW programu Dreamweaver na wielu urządzeniach
    3. Testowanie serwisu programu Dreamweaver

 

Wyświetlanie stron internetowych w programie Dreamweaver i przeglądarkach

Funkcja podglądu w czasie rzeczywistym umożliwia wyświetlanie stron w przeglądarce i obserwowanie w czasie rzeczywistym efektów zmian wprowadzanych w kodzie.

Widok aktywny prezentuje koncepcyjny wygląd strony w Internecie i umożliwia edytowanie poszczególnych elementów w widoku Kod.

Widok Projekt również prezentuje ogólną koncepcję wyglądu tworzonej strony w Internecie, jednak nie renderuje strony w dokładnie taki sposób, jak to robią przeglądarki.

Funkcja Otwórz w przeglądarce pozwala sprawdzić, jak strony będą wyglądać w przeglądarkach. Jest to przydatne w przypadku stron, które korzystają z danych dynamicznych pobieranych z bazy danych, ponieważ proces ten nie zachodzi w czasie rzeczywistym.

Poniżej podano więcej informacji na temat różnych opcji podglądu dostępnych w programie Dreamweaver.

Podgląd w przeglądarce w czasie rzeczywistym

Wyświetlanie stron w czasie rzeczywistym podczas programowania i projektowania ich w programie Dreamweaver. Ta funkcja umożliwia jednoczesne programowanie i wyświetlanie podglądu stron WWW w wielu przeglądarkach. 

Podgląd zmian w czasie rzeczywistym w przeglądarce
Podgląd zmian w czasie rzeczywistym w przeglądarce

  1. Kliknij ikonę Podgląd w czasie rzeczywistym na pasku stanu programu Dreamweaver.

    Podgląd w czasie rzeczywistym
    Podgląd w czasie rzeczywistym

    Dostępne są opcje wyświetlenia podglądu stron WWW w czasie rzeczywistym w przeglądarce.

  2. Aby wyświetlić podgląd stron WWW w przeglądarce, kliknij jedną z dostępnych opcji przeglądarek.

    Przeglądarki uwzględnione na tej liście można edytować. Informacje o dodawaniu lub usuwaniu przeglądarki z tej listy podano w sekcji Ustawianie preferencji przeglądarek.

    Jeśli jest używany serwer testowy, należy pamiętać o włączeniu skonfigurowaniu dla niego opcji Automatycznie publikuj pliki na serwerze testowym. 

    Podgląd w czasie rzeczywistym wykorzystuje pliki przesyłane na serwer testowy. Włączenie automatycznej publikacji na serwerze testowym gwarantuje, że zmiany będą widoczne w czasie rzeczywistym.  

  3. Gdy pojawi się monit, zapisz stronę WWW i jej dokumenty powiązane.

    Zostanie wyświetlone okno przeglądarki ze stroną WWW.

  4. Kontynuuj pracę nad kodem strony. Wprowadzane zmiany będą natychmiast widoczne.

Ustawianie preferencji podglądu w przeglądarce

Funkcje podglądu w czasie rzeczywistym i podglądu w przeglądarce można przełączać. Można także ustawić preferencje, których będzie używać przeglądarka podczas wyświetlania podglądu serwisu, a także zdefiniować przeglądarkę podstawową i dodatkową.

Te preferencje przeglądarki będą następnie używane zarówno podczas wyświetlania podglądu serwisu na żywo w czasie rzeczywistym, jak i otwierania strony w przeglądarce.

  1. Wybierz polecenie Plik > Podgląd w czasie rzeczywistym > Edytuj listę przeglądarek.

    Podgląd w czasie rzeczywistym
    Opcja Domyślny podgląd statyczny w przeglądarce

    Jeśli wyłączono zaznaczenie opcji Domyślny podgląd statyczny w przeglądarce, to opcja podglądu w czasie rzeczywistym nie będzie dostępna. Aby otworzyć podgląd w przeglądarce, można użyć skrótów klawiaturowych przeglądarki podstawowej i dodatkowej. Można również użyć w tym celu menu Plik lub kliknąć ikonę podglądu urządzenia na pasku stanu.

  2. Aby dodać przeglądarkę do listy, kliknij przycisk Plus (+), wypełnij dane w oknie dialogowym Dodaj przeglądarkę i następnie kliknij przycisk OK.
  3. Aby usunąć przeglądarkę z listy, zaznacz przeglądarkę, a następnie kliknij przycisk Minus (-).
  4. Aby zmienić ustawienia dla wybranej przeglądarki, kliknij przycisk Edytuj, wprowadź zmiany w oknie dialogowym Edytuj przeglądarkę, a następnie kliknij przycisk OK.
  5. Wybierz opcję Przeglądarka główna albo Przeglądarka dodatkowa, aby określić, czy zaznaczona przeglądarka jest główna, czy dodatkowa.

    Naciśnięcie F12 (Windows) lub Option+F12 (Macintosh) otwiera główną przeglądarkę; Control+F12 (Windows) lub Command+F12 (Macintosh) otwiera dodatkową przeglądarkę.

  6. Zaznacz opcję Podglądaj używając pliku tymczasowego, aby utworzyć kopię do podglądu i debugowania na serwerze. (Wyłącz tę opcję, jeżeli chcesz bezpośrednio uaktualniać dokument).

Domyślny podgląd statyczny w przeglądarce: Ta opcja umożliwia użytkownikom wybór trybu podglądu plików w przeglądarce. Po zaznaczeniu tego pola wyboru użytkownicy będą mogli przeglądać pliki, wybierając z menu opcję „Otwórz w przeglądarce” lub używając skrótów. Jeśli ta opcja zostanie wyłączona, podgląd w przeglądarce będzie wyświetlany za pomocą funkcji Podgląd w czasie rzeczywistym. To pole wyboru jest domyślnie wyłączone, czyli używana jest funkcja podglądu w czasie rzeczywistym.

Podgląd stron w widoku aktywnym

Różnica między widokiem aktywnym a zwykłym widokiem projektowania w programie Dreamweaver polega na tym, że ten pierwszy zapewnia bardziej realistyczną symulację wyglądu i działania strony w przeglądarce, pozwalając jednocześnie na edycję zawartości. 

Widok aktywny można włączyć, pracując w widoku Projekt. Przejście do widoku aktywnego polega jednak na czymś innym niż włączenie jednego ze zwykłych widoków programu Dreamweaver (Kod, Podziel lub Projekt). Przechodząc z widoku Projekt do widoku aktywnego, uaktywnia się po prostu inny tryb tego pierwszego, to znaczy przechodzi się z trybu edycji do trybu podglądu.

Jeśli w chwili włączenia widoku aktywnego widok Projekt jest zablokowany, to kod pozostaje edytowalny, a zatem można go zmienić, a następnie odświeżyć widok aktywny i sprawdzić efekt wprowadzonych zmian. Podczas pracy w widoku aktywnym można przeglądać aktywny kod projektu. Innymi słowy, można włączyć widok kodu aktywnego, który zapewnia podgląd kodu wykonywanego przez przeglądarkę podczas generowania zawartości strony. Podobnie jak widok aktywny widok kodu aktywnego nie pozwala edytować strony.

Dodatkową zaletą widoku aktywnego jest możliwość zablokowania kodu JavaScript. Można na przykład przejść do widoku aktywnego i zatrzymać kursor nad tymi wierszami tabeli jQuery, które zmieniają kolor w odpowiedzi na działania użytkownika. Zablokowanie kodu JavaScript powoduje, że strona oglądana w widoku aktywnym zostaje zablokowana w bieżącym stanie. Po zablokowaniu strony można dokonać edycji kodu CSS lub JavaScript, a następnie odblokować stronę i sprawdzić efekt wprowadzonych zmian. Funkcja blokowania kodu JavaScript w widoku aktywnym przydaje się wtedy, kiedy trzeba wypróbować różne właściwości wyskakujących menu lub innych elementów interaktywnych; niektóre z tych właściwości są niedostępne w zwykłym widoku Projekt.

Aby wyświetlić podgląd stron w widoku aktywnym:

  1. Upewnij się, że pracujesz w widoku Projekt (Widok > Projekt) lub w widoku Kod i Projekt (Widok > Kod i Projekt).

  2. Kliknij przycisk Widok aktywny.

  3. (Opcjonalnie) Wprowadź zmiany w widoku Kod, na panelu Style CSS, w zewnętrznym arkuszu stylów CSS lub w innym pliku powiązanym.

    Chociaż widok aktywny nie umożliwia wprowadzania zmian, to klikając poszczególne elementy w tym widoku, zyskuje się dostęp do różnych opcji edycji w innych obszarach (np. na panelu Style CSS lub w widoku Kod).

    Gdy widok aktywny jest włączony, można wykonywać różne operacje na plikach powiązanych (np. na arkuszach stylów CSS). Plik powiązany należy otworzyć za pomocą paska narzędziowego Pliki powiązane, który znajduje się u góry okna dokumentu.

  4. Po wprowadzeniu zmian w widoku Kod lub w pliku powiązanym widok aktywny można odświeżyć, klikając przycisk „Odśwież” na pasku narzędziowym dokumentu lub naciskając klawisz F5.

  5. Aby powrócić do trybu edycji w widoku Projekt, kliknij ponownie przycisk widoku aktywnego.

Podgląd kodu aktywnego

Kod wyświetlany w widoku Aktywny kod przypomina kod źródłowy strony, który można obejrzeć za pomocą przeglądarki. Jednak kod źródłowy, który można wyświetlić w przeglądarce, ma charakter statyczny. Natomiast widok kodu aktywnego jest generowany dynamicznie i aktualizowany w wyniku interakcji ze stroną w widoku aktywnym.

  1. Upewnij się, że pracujesz w widoku aktywnym.

  2. Kliknij przycisk Aktywny kod.

    Program Dreamweaver wyświetli kod aktywny, który byłby wykonywany przez przeglądarkę. Kod ten będzie wyróżniony na żółto i nie będzie można go edytować.

    Podczas pracy z interaktywnymi elementami strony widok Aktywny kod podświetla dynamiczne zmiany w kodzie.

  3. Aby wyłączyć podświetlanie zmian w widoku Aktywny kod, wybierz polecenie Widok > Opcje widoku aktywnego > Podświetl zmiany w aktywnym kodzie.

  4. Aby powrócić do trybu edycji w widoku Kod, kliknij ponownie przycisk Aktywny kod.

Aby zmienić preferencje aktywnego kodu, wybierz polecenie Edycja > Preferencje (Windows) lub Dreamweaver > Preferencje (Macintosh). Następnie wybierz kategorię Kolorowanie kodu.

Blokowanie kodu JavaScript

Wykonaj jedną z następujących czynności:

  • Naciśnij F6

  • Wybierz opcję Zablokuj JavaScript z wyskakującego menu przycisku Widok aktywny.

Pasek informacyjny u góry okna dokumentu będzie zawierał informację, że kod JavaScript został zablokowany. Aby zamknąć pasek informacyjny, kliknij łącze zamykające.

Opcje widoku aktywnego

Oprócz opcji Zablokuj JavaScript, program zapewnia także inne opcje widoku aktywnego, które są dostępne w wyskakującym menu przycisku Widok aktywny lub za pośrednictwem polecenia Widok > Opcje widoku aktywnego.

Zablokuj JavaScript Pozwala zablokować elementy zależne od kodu JavaScript w ich bieżącym stanie.

Wyłącz JavaScript Pozwala wyłączyć kod JavaScript i wygenerować stronę ponownie przy założeniu, że w przeglądarce wyłączono kod JavaScript.

Wyłącz wtyczki Pozwala wyłączyć wtyczki i wygenerować stronę ponownie przy założeniu, że w przeglądarce wyłączono wtyczki.

Podświetl zmiany w aktywnym kodzie Włącza lub wyłączna podświetlanie zmian w widoku Aktywny kod.

Edytuj stronę widoku aktywnego w nowej zakładce Umożliwia otwieranie nowych zakładek dla dokumentów serwisu przeglądanych za pomocą paska narzędziowego Nawigacja w przeglądarce albo funkcji Śledź łącza. Najpierw należy przejść do takiego dokumentu, a następnie wybrać polecenie „Edytuj stronę widoku aktywnego w nowej zakładce”, aby utworzyć nową zakładkę dla dokumentu.

Śledź łącze Powoduje, że następne łącze kliknięte w widoku aktywnym stanie się aktywne. Łącza można uaktywniać również przez kliknięcie ich w widoku aktywnym z przytrzymanym klawiszem Control.

Stale śledź łącza Powoduje trwałe uaktywnienie łączy w widoku aktywnym — dopóki nie zostaną ponownie wyłączone albo dopóki nie zamknie się strony.

Automatycznie synchronizuj pliki zdalne Powoduje automatyczną synchronizację pliku lokalnego i zdalnego po kliknięciu ikony Odśwież na pasku narzędziowym Nawigacja w przeglądarce. Program Dreamweaver umieszcza plik na serwerze przed odświeżeniem widoku, tak że oba pliki są zsynchronizowane.

Użyj serwera testującego źródło dokumentu Opcja używana przede wszystkim dla stron dynamicznych (takich jak strony ColdFusion), dla których jest domyślnie włączona. Jeśli opcja ta jest zaznaczona, to jako źródło strony wyświetlanej w widoku aktywnym program Dreamweaver wykorzystuje plik z serwera testowego serwisu.

Używaj plików lokalnych jako łączy w dokumencie Ustawienie domyślne dla serwisów innych niż dynamiczne. Jeśli w przypadków serwisów dynamicznych, które korzystają z serwera testowego, opcja ta jest zaznaczona, to zamiast plików z serwera testowego program Dreamweaver używa lokalnych wersji plików, które zostały przyłączone do dokumentu (np. plików CSS i JavaScript). W takim wypadku można wprowadzić lokalne zmiany w plikach powiązanych i sprawdzić, jak będą wyglądać przed umieszczeniem na serwerze testowym. Jeśli opcja ta nie jest zaznaczona, program Dreamweaver używa tych wersji plików powiązanych, które znajdują się na serwerze testowym.

Ustawienia żądania HTTP Pozwala wyświetlić okno dialogowe ustawień zaawansowanych, w którym można określić ustawienia wyświetlania danych aktywnych. Aby uzyskać więcej informacji, kliknij przycisk Pomoc w oknie dialogowym.

Otwórz w przeglądarce

Stronę można podejrzeć w przeglądarce w dowolnej chwili; nie wymaga to wysyłania jej najpierw na serwer. Podczas przeglądania strony powinny działać wszystkie funkcje zależne od przeglądarki, takie jak zachowania JavaScript, łącza względne (zależne od dokumentu) i bezwzględne, formanty ActiveX® i wtyczki — pod warunkiem, że odpowiednie wtyczki i formanty ActiveX zostały zainstalowane w przeglądarce.

Przed otwarciem podglądu dokumentu w przeglądarce zapisz ten dokument; w przeciwnym razie przeglądarka nie pokaże najnowszych zmian.

  1. Kliknij prawym przyciskiem myszy nazwę pliku na pasku narzędziowym Dokument i wybierz polecenie Otwórz w przeglądarce.

    Uwaga:

    Jeśli na liście nie ma żadnej przeglądarki, wybierz polecenie Edycja > Preferencje lub Dreamweaver > Preferencje (Macintosh), a następnie kliknij kategorię Podgląd w przeglądarce po lewej stronie, aby wybrać przeglądarkę. Więcej informacji: Ustawianie preferencji podglądu w przeglądarce.

  2. Klikaj łącza i przetestuj zawartość strony.
    Uwaga:

    Zawartość połączona ścieżkami określonymi względem katalogu głównego serwisu nie będzie widoczna podczas podglądu dokumentów w przeglądarce lokalnej, jeżeli nie określi się serwera testowego lub nie zaznaczy opcji Przeglądaj, używając pliku tymczasowego w oknie Edycja > Preferencje > Podgląd w przeglądarce. Wynika to z faktu, że przeglądarki nie rozpoznają katalogów głównych zdefiniowanych w ramach serwisu. Działanie to wykonuje za nie serwer.

    Uwaga:

    Aby zobaczyć podgląd zawartości połączonej za pomocą ścieżek określonych względem katalogu głównego, umieść plik na zdalnym serwerze, a następnie wybierz polecenie Plik > Podgląd w przeglądarce.

  3. Zamknij stronę w przeglądarce, gdy skończysz testy.
Logo Adobe

Zaloguj się na swoje konto