Podręcznik użytkownika Anuluj

Tworzenie i otwieranie plików

  1. Podręcznik użytkownika programu Dreamweaver
  2. Wprowadzenie
    1. Podstawy projektowania serwisów WWW o elastycznym układzie
    2. Dreamweaver — co nowego
    3. Programowanie zawartości WWW za pomocą programu Dreamweaver — przegląd
    4. Dreamweaver / Popularne pytania
    5. Skróty klawiszowe
    6. Wymagania systemowe programu Dreamweaver
    7. Podsumowanie funkcji
  3. Program Dreamweaver a platforma Creative Cloud
    1. Synchronizowanie ustawień programu Dreamweaver z chmurą Creative Cloud
    2. Biblioteki Creative Cloud w programie Dreamweaver
    3. Używanie plików programu Photoshop w programie Dreamweaver
    4. Praca z programami Adobe Animate oraz Dreamweaver
    5. Wydzielanie przygotowanych do wyświetlania w Internecie plików SVG z bibliotek
  4. Przestrzenie robocze i widoki w programie Dreamweaver
    1. Przestrzeń robocza programu Dreamweaver
    2. Optymalizacja przestrzeni roboczej programu Dreamweaver do programowania wizualnego
    3. Wyszukiwanie plików według nazwy lub zawartości | Mac OS
  5. Konfigurowanie serwisów
    1. Informacje o serwisach programu Dreamweaver
    2. Konfigurowanie lokalnej wersji serwisu
    3. Nawiązywanie połączenia z serwerem publikacji
    4. Konfigurowanie serwera testowego
    5. Importowanie i eksportowanie ustawień serwisu programu Dreamweaver
    6. Przenoszenie istniejących serwisów z serwera zdalnego do lokalnego katalogu głównego serwisu
    7. Funkcje ułatwień dostępu w programie Dreamweaver
    8. Ustawienia zaawansowane
    9. Ustawianie preferencji serwisu dotyczących transferu plików
    10. Określanie ustawień serwera proxy w programie Dreamweaver
    11. Synchronizowanie ustawień programu Dreamweaver z chmurą Creative Cloud
    12. Korzystanie z systemu Git w programie Dreamweaver
  6. Zarządzanie plikami
    1. Tworzenie i otwieranie plików
    2. Zarządzanie plikami i folderami
    3. Odbieranie plików i wysyłanie ich na serwer
    4. Pobieranie plików do edycji i odkładanie ich na serwer
    5. Synchronizacja plików
    6. Porównywanie plików w poszukiwaniu różnic
    7. Maskowanie plików i folderów w serwisie programu Dreamweaver
    8. Włączanie funkcji Uwagi do projektu w serwisach programu Dreamweaver
    9. Zapobieganie potencjalnemu obejściu funkcji Gatekeeper
  7. Układ i projekt
    1. Korzystanie z wizualnych pomocy do układu
    2. Informacje o tworzeniu układu strony za pomocą stylów CSS
    3. Projektowanie elastycznych serwisów WWW z użyciem struktury Bootstrap
    4. Tworzenie i używanie zapytań o media w programie Dreamweaver
    5. Prezentacja zawartości za pomocą tabel
    6. Kolory
    7. Tworzenie reagujących projektów za pomocą układów elastycznej siatki
    8. Narzędzie Extract w programie Dreamweaver
  8. CSS
    1. Podstawowe informacje o stylach CSS
    2. Tworzenie układu strony za pomocą panelu Projektant CSS
    3. Korzystanie z preprocesorów CSS w programie Dreamweaver
    4. Ustawianie preferencji stylów CSS w programie Dreamweaver
    5. Przenoszenie reguł CSS w programie Dreamweaver
    6. Konwertowanie stylu CSS wewnątrz znacznika na regułę CSS w programie Dreamweaver
    7. Posługiwanie się znacznikami DIV
    8. Stosowanie gradientów na tło
    9. Tworzenie i edytowanie efektów przejść CSS3 w programie Dreamweaver
    10. Formatowanie kodu
  9. Zawartość strony i zasoby
    1. Ustawianie właściwości strony
    2. Ustawianie właściwości CSS dla nagłówków i łączy
    3. Praca z tekstem
    4. Znajdowanie i zastępowanie tekstu, znaczników i atrybutów
    5. Panel DOM
    6. Edytowanie w widoku aktywnym
    7. Kodowanie znaków dokumentu w programie Dreamweaver
    8. Zaznaczanie i wyświetlanie elementów w oknie Dokument
    9. Ustawianie właściwości tekstu na panelu Inspektor właściwości
    10. Sprawdzanie pisowni na stronie internetowej
    11. Używanie linii poziomych w programie Dreamweaver
    12. Dodawanie i modyfikowanie kombinacji czcionek w programie Dreamweaver
    13. Praca z zasobami
    14. Wstawianie i aktualizowanie dat w programie Dreamweaver
    15. Tworzenie list ulubionych zasobów w programie Dreamweaver i zarządzanie nimi
    16. Wstawianie i edytowanie obrazów w programie Dreamweaver
    17. Dodawanie obiektów multimedialnych
    18. Dodawanie zawartości wideo w programie Dreamweaver
    19. Wstawianie wideo HTML5
    20. Wstawianie plików SWF
    21. Dodawanie efektów dźwiękowych
    22. Wstawianie obiektów audio HTML5 w programie Dreamweaver
    23. Praca z elementami bibliotek
    24. Stosowanie pisma arabskiego i hebrajskiego w programie Dreamweaver
  10. Łączenie i przeglądanie
    1. Informacje o łączeniu i przeglądaniu stron
    2. Tworzenie łączy
    3. Mapy obrazu
    4. Rozwiązywanie problemów dotyczących łączy
  11. Efekty i widgety jQuery
    1. Używanie widgetów jQuery interfejsu użytkownika i elementów mobilnych w programie Dreamweaver
    2. Używanie efektów jQuery w programie Dreamweaver
  12. Tworzenie kodu serwisów WWW
    1. Informacje o tworzeniu kodu w programie Dreamweaver
    2. Środowisko programistyczne w programie Dreamweaver
    3. Ustawianie preferencji kodowania
    4. Dostosowywanie ustawień kolorowania kodu
    5. Pisanie i edytowanie kodu
    6. Podpowiedzi i uzupełnianie kodu
    7. Zwijanie i rozwijanie kodu
    8. Ponowne wykorzystywanie fragmentów kodu za pomocą funkcji Urywki
    9. Linting: oczyszczanie kodu z błędów
    10. Optymalizacja kodu
    11. Edytowanie kodu w widoku Projekt
    12. Praca z zawartością znacznika HEAD strony
    13. Wstawianie dołączeń po stronie serwera w programie Dreamweaver
    14. Korzystanie z bibliotek znaczników w programie Dreamweaver
    15. Importowanie własnych znaczników do programu Dreamweaver
    16. Używanie zachowań JavaScript (instrukcje ogólne)
    17. Stosowanie wbudowanych zachowań JavaScript
    18. Omówienie języków XML i XSLT
    19. Wykonywanie transformacji XSL po stronie serwera w programie Dreamweaver
    20. Wykonywanie przekształceń XSL po stronie klienta w programie Dreamweaver
    21. Dodawanie encji znaków w kodzie XSLT w programie Dreamweaver
    22. Formatowanie kodu
  13. Obiegi pracy związane z wieloma produktami
    1. Instalowanie i używanie rozszerzeń programu Dreamweaver
    2. Aktualizacje w aplikacji w programie Dreamweaver
    3. Wstawianie dokumentów Microsoft Office w programie Dreamweaver (tylko Windows)
    4. Praca z programami Fireworks i Dreamweaver
    5. Edycja zawartości w stronach programu Dreamweaver za pomocą aplikacji Contribute
    6. Integracja programu Dreamweaver z aplikacją Business Catalyst
    7. Tworzenie spersonalizowanych kampanii rozsyłanych pocztą elektroniczną
  14. Szablony
    1. Informacje o szablonach programu Dreamweaver
    2. Rozpoznawanie szablonów oraz dokumentów opartych na szablonach
    3. Tworzenie szablonu programu Dreamweaver
    4. Tworzenie edytowalnych regionów w szablonach
    5. Tworzenie powtarzalnych regionów i tabel w programie Dreamweaver
    6. Używanie regionów opcjonalnych w szablonach
    7. Definiowanie edytowalnych atrybutów znacznika w programie Dreamweaver
    8. Tworzenie zagnieżdżonych szablonów w programie Dreamweaver
    9. Edytowanie, aktualizowanie i usuwanie szablonów
    10. Eksportowanie i importowanie zawartości XML w programie Dreamweaver
    11. Stosowanie szablonu lub usuwanie go z istniejącego dokumentu
    12. Edycja zawartości w szablonach programu Dreamweaver
    13. Reguły składni dla znaczników szablonu w programie Dreamweaver
    14. Ustawianie preferencji podświetlenia dla regionów szablonów
    15. Korzyści wynikające z używania szablonów w programie Dreamweaver
  15. Urządzenia mobilne i obsługa wielu ekranów
    1. Tworzenie zapytań o media
    2. Zmiana orientacji strony na urządzeniach mobilnych
    3. Tworzenie aplikacji internetowych przeznaczonych na urządzenia mobilne za pomocą programu Dreamweaver
  16. Dynamiczne serwisy, strony i formularze WWW
    1. Podstawowe informacje o aplikacjach internetowych
    2. Konfigurowanie komputera do programowania aplikacji
    3. Rozwiązywanie problemów z połączeniami z bazą danych
    4. Usuwanie skryptów połączenia w programie Dreamweaver
    5. Projektowanie stron dynamicznych
    6. Omówienie źródeł zawartości dynamicznej
    7. Definiowanie źródeł zawartości dynamicznej
    8. Dodawanie dynamicznej zawartości do stron
    9. Modyfikowanie dynamicznej zawartości w programie Dreamweaver
    10. Wyświetlanie rekordów z bazy danych
    11. Udostępnianie aktywnych danych w programie Dreamweaver oraz rozwiązywanie problemów z takimi danymi
    12. Dodawanie własnych zachowań serwerowych w programie Dreamweaver
    13. Tworzenie formularzy w programie Dreamweaver
    14. Zbieranie informacji od użytkowników za pomocą formularzy
    15. Tworzenie oraz włączanie formularzy ColdFusion w programie Dreamweaver
    16. Tworzenie formularzy WWW
    17. Rozszerzona obsługa elementów formularza w języku HTML5
    18. Tworzenie formularzy za pomocą programu Dreamweaver
  17. Tworzenie aplikacji metodą graficzną
    1. Tworzenie stron wzorca i szczegółów w programie Dreamweaver
    2. Tworzenie stron wyszukiwania i wyników
    3. Tworzenie strony wstawiania rekordów
    4. Tworzenie strony uaktualniania rekordów w programie Dreamweaver
    5. Tworzenie stron usuwania rekordów w programie Dreamweaver
    6. Używanie poleceń ASP do modyfikacji bazy danych w programie Dreamweaver
    7. Tworzenie strony rejestracji
    8. Tworzenie strony logowania
    9. Tworzenie strony, do której dostęp będą mieli tylko uwierzytelnieni użytkownicy
    10. Zabezpieczanie folderów w aplikacji ColdFusion za pomocą programu Dreamweaver
    11. Korzystanie ze składników ColdFusion w programie Dreamweaver
  18. Testowanie, podgląd i publikacja serwisów WWW
    1. Podgląd stron
    2. Podgląd stron WWW programu Dreamweaver na wielu urządzeniach
    3. Testowanie serwisu programu Dreamweaver

 

Tworzenie, otwieranie, edytowanie, zapisywanie i przywracanie plików w programie Dreamweaver. Tworzenie szablonów i otwieranie plików powiązanych.

Program Dreamweaver udostępnia elastyczne środowisko do pracy z wieloma różnymi dokumentami WWW. Oprócz dokumentów HTML można tworzyć i otwierać wiele dokumentów tekstowych, m.in. JavaScript, PHP i CSS (Cascading Style Sheets).

Program Dreamweaver oferuje kilka opcji tworzenia nowego dokumentu. Możesz utworzyć:

  • Nowy, pusty dokument lub szablon

  • Dokument oparty na jednym z gotowych układów strony dołączonych do programu Dreamweaver, np. jednym z ponad 30 układów wykorzystujących style CSS

  • Dokument oparty na jednym z istniejących szablonów

    Można również ustawiać odpowiednio preferencje dokumentu. Na przykład jeżeli na ogół posługujesz się jednym rodzajem dokumentów, możesz ustawić ten rodzaj jako domyślny typ dokumentu w przypadku nowych stron.

    W widoku Projekt albo w widoku Kod można łatwo definiować właściwości dokumentu, np. znaczniki META, tytuł dokumentu, kolor tła i kilka innych cech strony.

Typy plików w programie Dreamweaver

W programie Dreamweaver można pracować nad różnymi typami plików. Podstawowym typem jest plik HTML. Pliki HTML (Hypertext Markup Language) zawierają język znacznikowy, który umożliwia wyświetlanie strony WWW w przeglądarce. Takie pliki można zapisywać z rozszerzeniem .html lub .htm. Domyślnie program Dreamweaver zapisuje pliki z rozszerzeniem .html.

Program Dreamweaver umożliwia tworzenie i edytowanie stron internetowych w języku HTML5. Dostępne są również układy startowe, umożliwiające tworzenie stron HTML5 od zera.

Poniżej wymieniono inne typy plików często używane w programie Dreamweaver:

CSS

Pliki z arkuszami stylów kaskadowych mają rozszerzenie .css. Służą do formatowania zawartości HTML i sterowania położeniem różnych elementów strony.

GIF

Pliki formacie GIF (Graphics Interchange Format) mają rozszerzenie .gif. Jest to popularny format grafiki internetowej, używany do wyświetlania komiksów, znaków logo, grafiki z przezroczystością oraz animacji. Pliki GIF mogą zawierać tylko 256 kolorów.

JPEG

Pliki w formacie JPEG (Joint Photographic Experts Group — jest to nazwa organizacji, która opracowała ten format) mają rozszerzenie .jpg i zawierają zazwyczaj fotografie lub obrazy w pełnych kolorach. Format JPEG najlepiej nadaje się do wyświetlania fotografii cyfrowych albo skanowanych, obrazów zawierających tekstury, obrazów ze stopniowymi przejściami kolorów oraz wszystkich tych obrazów, które składają się z ponad 256 kolorów.

XML

Pliki XML (Extensible Markup Language) mają rozszerzenie .xml. Zawiera dane w postaci nieprzetworzonej, które można formatować za pomocą języka XSL (Extensible Stylesheet Language).

Okno dialogowe Nowy dokument

Okno dialogowe Nowy dokument wyświetla wszystkie obsługiwane typy dokumentów, w tym PHP, XML oraz SVG.

Za pomocą tego okna dialogowego można również uzyskać dostęp do gotowych układów, szablonów i struktur.

Uwaga:

Wszystkie wyszczególnione w nim układy startowe są przygotowane do obsługi serwisów reagujących i zgodne ze standardem HTML5.

Tworzenie układu HTML od pustej strony

Tworząc stronę, można wykorzystać gotowy układ CSS. Można również utworzyć zupełnie pustą stronę i zbudować na niej własny układ.

  1. Wybierz polecenie Plik > Nowy.

  2. W kategorii Nowy dokument wybierz odpowiedni typ strony z kolumny Typ dokumentu. Na przykład aby utworzyć zwykłą stronę HTML, wybierz opcję HTML.

  3. Wybierz typ dokumentu z wyskakującego menu DocType. W większości przypadków można użyć domyślnej opcji, czyli  HTML5.

  4. Wybierz dodatkowe opcje w zależności od typu strony, którą chcesz utworzyć.

    • Brak: Wybierz tę opcję, jeśli chcesz utworzyć prostą stronę internetową bez użycia struktury.
    • Bootstrap: Szablony Bootstrap to gotowe układy utworzone z użyciem struktury Bootstrap. Wybierz tę opcję, jeśli chcesz tworzyć reagujące serwisy WWW, korzystając ze struktury Bootstrap. Domyślnie tworzony jest dokument Bootstrap 4.0.0.
    Uwaga:

    Wybierz tę opcję, jeśli zamierzasz tworzyć reagujące serwisy WWW z użyciem struktury Bootstrap.

  5. Jeśli nie używasz struktury:

    • Tytuł dokumentu: W tym polu należy wpisać tytuł dokumentu, który program Dreamweaver automatycznie doda do jego sekcji <head>.
    • DocType: Wybierz typ dokumentu z wyskakującego menu DocType. W większości przypadków można użyć domyślnej opcji, czyli HTML5.

    Wybór jednej z definicji typu dokumentu XHTML z menu DocType spowoduje, że strona będzie zgodna ze standardem XHTML. Np. aby zapewnić zgodność dokumentu HTML ze standardem XHTML, należy wybrać z wyskakującego menu opcję XHTML 1.0 Transitional albo XHTML 1.0 Strict. XHTML (Extensible Hypertext Markup Language) to nowa specyfikacja języka HTML jako jednego z zastosowań standardu XML. Mówiąc ogólnie, użycie języka XHTML udostępnia wszystkie zalety standardu XML, gwarantując jednocześnie zgodność wsteczną i przyszłą dokumentów WWW.

    Uwaga:

    Więcej informacji o języku XHTML można znaleźć w serwisie internetowym organizacji World Wide Web Consortium (W3C), który zawiera specyfikację XHTML 1.1 — XHTML modułowy (www.w3.org/TR/xhtml11/) oraz XHTML 1.0 (www.w3c.org/TR/xhtml1/), a także w serwisach walidatorów kodu XHTML w plikach opublikowanych w sieci WWW (http://validator.w3.org/) i plikach lokalnych (http://validator.w3.org/file-upload.html).

    • Dołącz CSS: Do strony można dołączyć istniejący układ CSS. Aby to zrobić, kliknij ikonę Dołącz arkusz stylów , znajdującą się nad panelem Dołącz plik CSS, i wybierz arkusz stylów CSS.
    Tworzenie nowej strony HTML bez użycia struktury
    Tworzenie nowej strony HTML bez użycia struktury

    Jeśli chcesz utworzyć nową stronę na podstawie kompozycji programu Photoshop, wybierz opcję „Skorzystaj z narzędzia Extract, aby zbudować stronę na podstawie kompozycji układu z programu Photoshop”.  

    Wybranie tej opcji powoduje otwarcie panelu Extract, na którym można przesłać plik PSD rozpocząć tworzenie strony HTML.

  6. Jeśli chcesz utworzyć reagującą stronę WWW, korzystając ze struktury Bootstrap:

    • CSS Bootstrap: Można utworzyć nowy arkusz stylów CSS struktury Bootstrap albo użyć istniejącego. Jeśli korzystasz z istniejącego pliku CSS, podaj ścieżkę do niego. Upewnij się, że ten plik CSS znajduje się w katalogu głównym serwisu.
    • Dołącz CSS: Do strony można dołączyć istniejący układ CSS. Aby to zrobić, kliknij ikonę Dołącz arkusz stylów , znajdującą się nad panelem Dołącz plik CSS, i wybierz arkusz stylów CSS.
    • Dołącz prefabrykowany układ: Wybierz tę opcję, jeśli masz już gotowy układ. Kliknij opcję Dostosuj, aby edytować siatkę i wartości punktów przerwań.
    Tworzenie nowej strony HTML z użyciem struktury Bootstrap
    Tworzenie nowej strony HTML z użyciem struktury Bootstrap

    Jeśli chcesz utworzyć nową stronę na podstawie kompozycji programu Photoshop, wybierz opcję „Skorzystaj z narzędzia Extract, aby zbudować stronę na podstawie kompozycji układu z programu Photoshop”.  

    Wybranie tej opcji powoduje otwarcie panelu Extract, na którym można przesłać plik PSD rozpocząć tworzenie strony HTML.

  7. Kliknij opcję Preferencje, jeżeli chcesz ustawić domyślne preferencje dokumentu, takie jak typ dokumentu, kodowanie i rozszerzenie pliku.

  8. Kliknij przycisk Utwórz.

  9. Zapisz nowy dokument (Plik > Zapisz).

  10. Zostanie wyświetlone okno dialogowe umożliwiające przejście do folderu, w którym chcesz zapisać plik.
    Uwaga:

    Warto zapisać go w serwisie programu Dreamweaver.

  11. Wpisz nazwę pliku w polu Nazwa pliku.

    W nazwach plików i folderów nie należy używać spacji ani znaków specjalnych. Nazwa pliku nie może zaczynać się od cyfry. W nazwach plików umieszczanych na serwerze zdalnym nie należy używać zwłaszcza znaków specjalnych (takich jak é, ç czy ¥) ani znaków interpunkcyjnych (np. średników, ukośników czy kropek). Wiele serwerów zmienia takie znaki podczas wysyłania, co spowoduje zerwanie wszystkich łączy do tych plików.

Tworzenie pustego szablonu

Za pomocą okna dialogowego Nowy dokument można tworzyć szablony programu Dreamweaver. Szablony są domyślnie zapisywane w folderze Szablony w strukturze serwisu.

Uwaga:

Szablon można utworzyć tylko wtedy, jeśli wcześniej został utworzony serwis. Więcej informacji o serwisach i ich tworzeniu podano w sekcji Informacje o serwisach programu Dreamweaver.

  1. Wybierz polecenie Plik > Nowy.

  2. W oknie dialogowym Nowy dokument wybierz kategorię Szablony serwisu.

  3. Wybierz typ dokumentu z wyskakującego menu DocType. Najczęściej pole to trzeba pozostawić w ustawieniu domyślnym, czyli XHTML 1.0 Transitional.

    Wybór jednej z definicji typu dokumentu XHTML z menu DocType (DTD) spowoduje, że strona będzie zgodna ze standardem XHTML. Np. aby zapewnić zgodność dokumentu HTML ze standardem XHTML, należy wybrać z wyskakującego menu opcję XHTML 1.0 Transitional albo XHTML 1.0 Strict. XHTML (Extensible Hypertext Markup Language) to nowa specyfikacja języka HTML jako jednego z zastosowań standardu XML. Mówiąc ogólnie, użycie języka XHTML udostępnia wszystkie zalety standardu XML, gwarantując jednocześnie zgodność wsteczną i przyszłą dokumentów WWW.

    Uwaga:

    Więcej informacji o języku XHTML można znaleźć w serwisie internetowym organizacji World Wide Web Consortium (W3C), który zawiera specyfikację XHTML 1.1 — XHTML modułowy (www.w3.org/TR/xhtml11/) oraz XHTML 1.0 (www.w3c.org/TR/xhtml1/), a także w serwisach walidatorów kodu XHTML w plikach opublikowanych w sieci WWW (http://validator.w3.org/) i plikach lokalnych (http://validator.w3.org/file-upload.html).

  4. Zaznacz opcję „Uaktualnij stronę po zmianie szablonu”, jeśli strona ma być automatycznie uaktualniana w przypadku modyfikacji szablonu.

  5. Kliknij przycisk Utwórz.

  6. Zapisz nowy dokument (Plik > Zapisz). Jeżeli do szablonu nie dodano jeszcze regionów edytowalnych, to pojawi się okno dialogowe informujące, że w dokumencie nie istnieją żadne regiony edytowalne. Kliknij przycisk OK, aby zamknąć okno dialogowe.

  7. W oknie dialogowym Zapisz jako wybierz serwis, w którym ma zostać zapisany szablon.
  8. W polu tekstowym Nazwa pliku wpisz nazwę nowego szablonu. Nie musisz dodawać rozszerzenia pliku do nazwy szablonu. Gdy klikniesz przycisk Zapisz, do nazwy nowego szablonu zostanie dołączone rozszerzenie .dwt, a szablon zostanie zapisany w folderze Szablony w strukturze serwisu.

    W nazwach plików i folderów nie należy używać spacji ani znaków specjalnych. Nazwa pliku nie może zaczynać się od cyfry. Nie używaj znaków specjalnych (takich jak é, ç czy ¥) ani znaków interpunkcyjnych (np. średników, ukośników czy kropek) w nazwach plików, które zamierzasz umieścić na serwerze zdalnym. Wiele serwerów zmienia takie znaki podczas wysyłania, co spowoduje zerwanie wszystkich łączy do tych plików.

Tworzenie strony opartej na szablonie

Dokumenty można tworzyć na podstawie własnych szablonów albo gotowych szablonów początkowych programu Dreamweaver. Po wybraniu szablonu można wyświetlić jego podgląd. W oknie dialogowym Nowy dokument można wybrać szablon z każdego z serwisów zdefiniowanych w programie Dreamweaver. Można również użyć panelu Zasoby, aby utworzyć nowy dokument z istniejącego szablonu.

Tworzenie dokumentu na podstawie szablonu

  1. Wybierz polecenie Plik > Nowy.

  2. W oknie dialogowym Nowy dokument wybierz kategorię Strona z szablonu.

  3. W kolumnie Serwis wybierz serwis programu Dreamweaver zawierający szablon, którego chcesz użyć. Potem wybierz szablon z listy po prawej stronie.

  4. Jeśli nie chcesz, aby strona była uaktualniana po każdej zmianie szablonu, na której ją oparto, wyłącz opcję Uaktualnij stronę po zmianie szablonu.

  5. Kliknij opcję Preferencje, jeżeli chcesz ustawić domyślne preferencje dokumentu, takie jak typ dokumentu, kodowanie i rozszerzenie pliku.

  6. Kliknij opcję Pobierz więcej zawartości, jeżeli chcesz się połączyć z serwisem Dreamweaver Exchange, z którego można pobierać dodatkową zawartość do projektowania stron.

  7. Kliknij przycisk Utwórz i zapisz dokument (Plik > Zapisz).

Tworzenie dokumentu z szablonu wybranego na panelu Zasoby

  1. Jeżeli panel Zasoby (Okno > Zasoby) nie jest jeszcze otwarty, otwórz go.

  2. Kliknij ikonę Szablony  umieszczoną po lewej stronie panelu Zasoby, aby wyświetlić listę szablonów w bieżącym serwisie.

    Uwaga:

    Jeżeli szablon, którego chcesz użyć, został utworzony niedawno, to konieczne może być kliknięcie przycisku Odśwież.

  3. Kliknij szablon, który chcesz zastosować, prawym przyciskiem myszy (Windows) lub przytrzymując klawisz Control (Mac OS). Wybierz polecenie Nowy z szablonu.

    Dokument otworzy się w oknie Dokument.

  4. Zapisz dokument.

Tworzenie strony na podstawie szablonu początkowego programu Dreamweaver

Do programu Dreamweaver dołączono kilka profesjonalnych plików startowych do tworzenia aplikacji na urządzenia mobilne. Można wykorzystać te przykładowe pliki jako punkt wyjścia przy projektowaniu stron do własnych serwisów.

Gdy tworzy się dokument oparty na szablonie początkowym, program Dreamweaver wykonuje jego kopię, co pozwala uniknąć nadpisania plików szablonu.

W oknie dialogowym Nowy dokument można wyświetlić podgląd przykładowego pliku i przeczytać krótki opis elementów graficznych dokumentu.

  1. Wybierz polecenie Plik > Nowy.

  2. W oknie dialogowym Nowy dokument wybierz kategorię Szablony początkowe.

    Szablony początkowe w programie Dreamweaver
    Szablony początkowe w programie Dreamweaver

    Po wybraniu poszczególnych opcji po prawej stronie panelu są wyświetlane szczegółowe informacje o przykładowej stronie oraz jej wizualizacja.

  3. Kliknij przycisk Utwórz.

    Nowy dokument i wszystkie jego pliki dynamicznie powiązane zostaną otwarte w oknie Dokument.

  4. Zapisz dokument (Plik > Zapisz).

Tworzenie nowych plików kodu w różnych językach programowania

W programie Dreamweaver można tworzyć pliki kodu w kilku różnych językach programowania.

Więcej informacji: Informacje o kodowaniu w programie Dreamweaver.

Wykonaj następujące instrukcje, aby utworzyć nowy plik kodu w programie Dreamweaver:

  1. Wybierz polecenie Plik > Nowy Dokument.

  2. Z menu Typ dokumentu wybierz rodzaj pliku programistycznego, który chcesz utworzyć.

  3. W kolumnie Typ dokumentu wybierz rodzaj dokumentu, który chcesz utworzyć (na przykład PHP).

    Tworzenie nowej strony PHP
    Tworzenie nowej strony PHP

  4. W zależności od wybranego typu pliku podczas tworzenia dokumentu będą dostępne dodatkowe opcje. 

    Na przykład w przypadku plików PHP można wybrać opcje DocType oraz niektóre opcje CSS.

  5. Kliknij przycisk Utwórz. Następnie zapisz dokument (Plik > Zapisz).

Zapisywanie i przywracanie dokumentów

Dokument możesz zapisać pod jego obecną nazwą i w tym samym miejscu, a także zapisać jego kopię pod inną nazwą i w innym miejscu.

Uwaga:

Nadając plikom nazwy, unikaj spacji i znaków specjalnych w nazwach plików i folderów. Przede wszystkim, nie używaj znaków specjalnych (takich jak é, ç czy ¥) ani znaków interpunkcyjnych (np. średników, ukośników czy kropek) w nazwach plików, które zamierzasz umieścić na serwerze zdalnym. Wiele serwerów zmienia takie znaki podczas wysyłania, co spowoduje zerwanie wszystkich łączy do tych plików. Ponadto nie zaczynaj nazwy pliku od liczby.

Zapisywanie dokumentu

  1. Wykonaj jedną z następujących czynności:
    • Aby nadpisać bieżącą wersję na dysku i zapisać wszystkie wprowadzone zmiany, wybierz polecenie Plik > Zapisz.
    • Aby zapisać plik w innym folderze lub pod inną nazwą, wybierz polecenie Plik > Zapisz jako.
  2. Zostanie wyświetlone okno dialogowe Zapisz jako. Przejdź do folderu, w którym chcesz zapisać plik.
  3. W polu tekstowym Nazwa pliku wpisz nazwę pliku.

  4. Kliknij opcję Zapisz, aby zapisać plik.

Zapisywanie wszystkich otwartych dokumentów

  1. Wybierz polecenie Plik > Zapisz wszystko.

  2. Jeżeli otwarte są niezapisane jeszcze dokumenty, to program wyświetli okno dialogowe Zapisz jako dla każdego takiego dokumentu.

    Zostanie wyświetlone okno dialogowe umożliwiające przejście do folderu, w którym chcesz zapisać plik.

  3. W polu tekstowym Nazwa pliku wpisz nazwę pliku i kliknij przycisk Zapisz.

Przywracanie ostatnio zapisanej wersji dokumentu

  1. Wybierz polecenie Plik > Przywróć.

    Pojawi się okno dialogowe z pytaniem, czy odrzucić zmiany i przywrócić poprzednio zapisaną wersję.

  2. Kliknij przycisk Tak, aby wrócić do poprzedniej wersji. Kliknij przycisk Nie, jeśli chcesz zachować zmiany.

    Uwaga:

    Jeżeli zapiszesz dokument i zamkniesz program Dreamweaver, to po kolejnym uruchomieniu programu nie będzie można przywrócić poprzednio zapisanej wersji.

Ustawianie domyślnego typu dokumentu i kodowania — preferencje

Jeśli większość stron w serwisie ma konkretny typ (np. są to dokumenty HTML, PHP lub JavaScript), preferencje dokumentu można ustawić w taki sposób, aby automatycznie tworzyć nowe dokumenty tego typu.

  1. Wybierz polecenie Edycja > Preferencje (Windows) lub Dreamweaver > Preferencje (Macintosh).

    Uwaga:

    Tworząc nowy dokument można również kliknąć przycisk Preferencje w oknie dialogowym Nowy dokument, aby określić preferencje nowych dokumentów.

  2. Z listy Kategoria po lewej stronie wybierz opcję Nowy dokument.

  3. Ustaw lub zmień preferencje stosownie do potrzeb i kliknij przycisk OK, aby je zapisać.

    Domyślny dokument

    Wybierz typ dokumentu, który będzie używany w przypadku nowo tworzonych stron.

    Domyślne rozszerzenie

    Określa preferowane rozszerzenie pliku (.htm lub .html) nowych stron HTML.

    Uwaga: Ta opcja nie jest dostępna w przypadku innych typów plików.

    Domyślny typ dokumentu (DTD)

    Wybierz jedną z definicji typu dokumentu (DTD) w standardzie XHTML, aby nowe strony były zgodne z tym standardem. Np. aby zapewnić zgodność dokumentu HTML ze standardem XHTML, należy wybrać z wyskakującego menu opcję XHTML 1.0 Transitional albo XHTML 1.0 Strict.

    Domyślne kodowanie

    Określa kodowanie używane przy tworzeniu nowej strony oraz otwieraniu dokumentu, w którym nie określono żadnego kodowania.

    Jeżeli wybierzesz kodowanie dokumentu w standardzie Unicode (UTF-8), kodowanie encji znakowych jest niepotrzebne, ponieważ UTF-8 umożliwia bezpieczne przedstawienie wszystkich znaków. Jeżeli wybierzesz inne kodowanie dokumentu, do wyświetlenia niektórych znaków konieczne może być kodowanie encji znakowych. Więcej informacji na temat encji znakowych zawiera strona www.w3.org/TR/REC-html40/sgml/entities.html.

    Jeżeli ustawisz kodowanie Unicode (UTF-8) jako domyślne kodowanie, to możesz dodać do dokumentu znacznik kolejności bajtów BOM. Aby to zrobić, zaznacz opcję Dołącz sygnaturę Unicode (BOM).

    Znacznik BOM to pierwsze 2-4 bajty na początku pliku tekstowego, które określają, czy jest to plik Unicode, a jeśli tak, to definiują kolejność bajtów w reszcie pliku. Ponieważ w standardzie UTF-8 nie ma kolejności bajtów, znacznik BOM dla UTF-8 jest opcjonalny. Natomiast dla standardów UTF-16 i UTF-32 jest obowiązkowy.

    Formuła normalizacji Unicode

    Jeżeli jako domyślne kodowanie ustawisz standard Unicode (UTF-8), to wybierz jedną z następujących opcji.

    Istnieją cztery formuły normalizacji Unicode. Najważniejsza jest Formuła C, ponieważ jest to formuła najczęściej używana w modelu znakowym sieci WWW. Adobe udostępnia pozostałe trzy formuły normalizacji Unicode dla zapewnienia pełnego wyboru.

    Pokaż okno dialogowe Nowy dokument po naciśnięciu Control+N

    Jeśli chcesz, aby po naciśnięciu tej kombinacji klawiszy (na komputerach Macintosh — „Command+N”) automatycznie tworzony był dokument o domyślnym typie, wyłącz tę opcję.

    W standardzie Unicode niektóre znaki są do siebie wizualnie podobne, ale mogą być w różny sposób przechowywane w dokumencie. Np. znak „ë” (e‑umlaut) może być reprezentowany przez pojedynczy znak, „e‑umlaut”, albo przez dwa znaki, „zwykłe e łacińskie” + „połączenie z umlautem”. Znak połączeniowy w Unicode to taki znak, który jest używany razem z poprzedzającym go znakiem. Zatem znak umlautu pojawi się nad „łacińskim e”. Obie formuły dają ten sam wygląd typograficzny, jednak różni się sposób ich zapisu w pliku.

    Normalizacja to proces polegający na zapewnianiu, by wszystkie znaki, które można zapisać na różne sposoby, zostały zapisane za pomocą tej samej formuły. Zatem wszystkie znaki „ë” w dokumencie zostaną zapisane jako pojedynczy znak „e‑umlaut”, albo jako znaki „e” + „połączeniowy umlaut”. W jednym dokumencie nie wystąpią dwie różne formuły.

    Więcej informacji na temat normalizacji Unicode i specyficznych formuł, których można używać, zawiera strona www.unicode.org/reports/tr15.

Otwieranie i edytowanie istniejących dokumentów

W programie Dreamweaver można otwierać istniejące strony WWW i dokumenty tekstowe, nawet jeżeli zostały utworzone w innych programach, i edytować je w widoku Projekt lub w widoku Kod.

Jeżeli otwierany dokument jest plikiem z programu Microsoft Word zapisanym jako dokument HTML, to można użyć polecenia Narzędzia > Oczyść kod HTML utworzony przez program Word, aby usunąć niepotrzebne znaczniki wstawiane przez program Word do plików HTML.

Aby oczyścić plik HTML lub XHTML, który nie został wygenerowany przez program Microsoft Word, użyj polecenia Narzędzia > Oczyść HTML. Więcej informacji: Oczyszczanie kodu HTML utworzonego przez program Microsoft Word.

Możesz również otwierać pliki tekstowe inne niż HTML, np. pliki JavaScript i XML, arkusze stylów CSS oraz pliki zapisane przez edytory tekstu.

  1. Wybierz polecenie Plik > Otwórz.

    Uwaga:

    Pliki możesz otwierać również za pomocą panelu Pliki.

  2. Przejdź do wybranego pliku i zaznacz go.
    Uwaga:

    Jeżeli pliki, które chcesz otwierać i edytować, nie są jeszcze zorganizowane w serwis programu Dreamweaver, warto zrobić to teraz, zamiast otwierać je z różnych miejsc. Więcej informacji: Informacje o serwisach programu Dreamweaver.

  3. Kliknij przycisk Otwórz.

    Dokument otworzy się w oknie dokumentu. Pliki JavaScript, pliki tekstowe i arkusze stylów CSS otwierają się domyślnie w widoku Kod. Pracując w programie Dreamweaver, możesz uaktualniać dokument i zapisywać zmiany w pliku.

Otwieranie plików powiązanych

Program Dreamweaver pozwala przeglądać pliki powiązane z głównym dokumentem bezpośrednio w oknie dokumentu. Na przykład jeśli z pewnym dokumentem głównym są powiązane pliki CSS i JavaScript, to można wyświetlać je i edytować w oknie dokument programu Dreamweaver, bez konieczności zamykania czy ukrywania głównego dokumentu.

Więcej informacji: Otwieranie plików dynamicznie powiązanych.

Uwaga:

Podczas pracy nad plikiem HTML można szybko wprowadzić zmiany w powiązanych z nim plikach CSS, JavaScript lub PHP bez potrzeby przełączania się na te pliki. Służy do tego funkcja Szybka edycja. Więcej informacji: Szybka edycja.

Wszystkie nazwy plików powiązanych z głównym dokumentem są wyświetlane domyślnie na pasku narzędziowym Pliki powiązane programu Dreamweaver, pod tytułem głównego dokumentu. Kolejność przycisków na pasku narzędziowym odpowiada kolejności łączy do plików powiązanych w głównym dokumencie.

Uwaga:

Jeśli pewien plik powiązany zostanie utracony, program Dreamweaver nadal będzie wyświetlał odpowiadający mu przycisk na pasku narzędziowym Pliki powiązane. Kliknięcie tego przycisku nie spowoduje jednak żadnej reakcji programu Dreamweaver.

Program Dreamweaver obsługuje pliki powiązane następującego typu:

  • Pliki skryptów po stronie klienta
  • Dołączenia po stronie serwera
  • Zewnętrzne arkusze stylów CSS (w tym zagnieżdżone arkusze stylów)

Wykonaj jedną z następujących czynności:

  • Na pasku narzędziowym Pliki powiązane, który znajduje się u góry okna dokumentu, kliknij nazwę wybranego pliku powiązanego.

  • Na pasku narzędziowym Pliki powiązane kliknij nazwę wybranego pliku powiązanego prawym przyciskiem myszy, a następnie wybierz z menu kontekstowego polecenie Otwórz jako oddzielny plik. Jeśli plik powiązany zostanie otwarty tą metodą, przestanie być widoczny główny dokument.

  1. Umieść punkt wstawiania w wierszu lub w obszarze, który jest zależny od pliku powiązanego.

  2. Poczekaj, aż pojawi się wskaźnik Nawigatora kodu, a następnie kliknij go, aby otworzyć okno Nawigatora.

  3. Aby wyświetlić informacje o pewnych elementach widocznych w oknie Nawigatora kodu, ustaw i zatrzymaj nad nimi kursor myszy. Na przykład jeśli chcesz zmienić właściwość konkretnego koloru CSS, ale nie znasz reguły dotyczącej tej właściwości, możesz zidentyfikować ją, zatrzymując kursor nad kolejnymi regułami, które są widoczne w oknie Nawigatora kodu.

  4. Kliknij interesujący Cię element, aby otworzyć odpowiadający mu plik powiązany.

Powrót do kodu źródłowego głównego dokumentu

  1. Kliknij przycisk Kod źródłowy na pasku narzędziowym Pliki powiązane.

Jeśli plik powiązany zostanie otwarty w widoku Projekt albo w widoku Kod i Projekt (widok podzielony), to będzie on wyświetlany w widoku podzielonym nad widokiem projektu głównego dokumentu.

Wybierając polecenie Widok > Podziel, można ustawić różne opcje podziału, aby dostosować ten widok.

Jeśli chcesz wyświetlać powiązane pliki tylko w widoku Kod, wybierz opcję Kod w górnej części paska.

Uwaga:

Standardowy widok Kod nie pozwala na jednoczesne wyświetlanie plików powiązanych z dokumentem i kodu źródłowego tego dokumentu.

Uwaga:

Fraza „widok Kod” w nazwie opcji wyświetlania odnosi się do kodu źródłowego głównego dokumentu. Na przykład jeśli zostanie zaznaczona opcja Widok > Widok Kod na wierzchu, to kod źródłowy głównego dokumentu będzie wyświetlany w górnej połowie okna dokumentu. Jeśli natomiast zostanie zaznaczona opcja Widok > Widok Kod po lewej, program Dreamweaver wyświetli kod źródłowy głównego dokumentu w lewej części okna Dokument.

Po otwarciu pliku HTML program Dreamweaver domyślnie wyświetla jego pliki powiązane na osobnych kartach. To domyślne zachowanie można wyłączyć w oknie Preferencje.

  1. Wybierz polecenie Edycja > Preferencje (Windows) lub Dreamweaver > Preferencje (Macintosh).

  2. W kategorii Ogólne odznacz opcję Włącz pliki powiązane.

Otwieranie plików dynamicznie powiązanych

Funkcja Pliki dynamicznie powiązane rozszerza możliwości funkcji Pliki powiązane, umożliwiając wyświetlanie plików powiązanych na stronach dynamicznych na pasku narzędziowym Pliki powiązane. Funkcja Pliki dynamicznie powiązane pozwala na wyświetlanie licznych elementów dołączanych dynamicznie, które są niezbędne do wygenerowania kodu wykonawczego popularnych systemów CMS z otwartym kodem źródłowym PHP, takich jak WordPress, Joomla! i Drupal.

Aby można było korzystać z funkcji plików dynamicznie powiązanych, niezbędny jest dostęp do lokalnego lub zdalnego serwera aplikacji PHP, na którym uruchomiono platformę WordPress, Drupal lub Joomla! Często stosuje się podejście polegające na skonfigurowaniu serwera aplikacji PHP na komputerze lokalnym z użyciem adresu localhost. Umożliwia to lokalne testowanie stron.

Przed przystąpieniem do testowania stron należy wykonać następujące kroki:

  • Skonfiguruj serwis programu Dreamweaver, pamiętając o wypełnieniu pola Adres WWW w oknie dialogowym Konfiguracja serwisu.

  • Skonfiguruj serwer PHP.

    Uwaga: serwer ten musi zostać uruchomiony przed rozpoczęciem korzystania z funkcji plików dynamicznie powiązanych w programie Dreamweaver.

  • Zainstaluj platformę WordPress, Joomla! lub Drupal na serwerze aplikacji. Więcej informacji:

  • W programie Dreamweaver zdefiniuj folder lokalny, do którego będą pobierane pliki z systemu CMS i w którym będziesz je edytować.

  • Definiuje lokalizację, w której zainstalowano pliki WordPress, Drupal lub Joomla, jako folder zdalny i testowy.

  • Pobierz pliki z systemu CMS w folderze zdalnym.

Po otwarciu strony skojarzonej z plikami dynamicznie powiązanymi program Dreamweaver może wykryć te pliki automatycznie albo pozostawić je do ręcznego wykrycia przez użytkownika. Aby ręcznie wykryć pliki dynamicznie powiązane, kliknij łącze na pasku informacji nad stroną. Ustawienie domyślne to wykrywanie ręczne.

  1. Wybierz polecenie Edycja > Preferencje (Windows) lub Dreamweaver > Preferencje (Macintosh).

  2. Przejdź do kategorii Ogólne i upewnij się, że zaznaczona jest opcja Włącz pliki powiązane.

  3. Z wyskakującego menu Pliki dynamicznie powiązane wybierz opcję Ręcznie lub Automatycznie. Można również całkowicie wyłączyć wykrywanie, wybierając opcję Wyłączone.

  1. Otwórz stronę, z którą są skojarzone pliki dynamicznie powiązane. Może to być np. strona index.php serwisu WordPress, Drupal lub Joomla!, znajdująca się w katalogu głównym tego serwisu.

  2. Jeśli ustawione jest ręczne wykrywanie plików dynamicznie powiązanych (jest to wartość domyślna), kliknij łącze Wykryj na pasku informacji, który znajduje się nad stroną w oknie dokumentu.

    Jeśli włączone jest automatyczne wykrywanie plików dynamicznie powiązanych, to na pasku Pliki powiązane pojawi się lista plików powiązanych dynamicznie.

Kolejność plików powiązanych i dynamicznie powiązanych na pasku narzędziowym Pliki powiązane jest następująca:

  • Statyczne pliki powiązane (czyli pliki powiązane, które nie wymagają dynamicznego przetwarzania);
  • Zewnętrzne pliki powiązane (pliki .css i .js), które są załączone do plików dołączanych dyrektywą INCLUDE z dynamicznej ścieżki na serwerze;
  • pliki dołączane dyrektywą INCLUDE z dynamicznej ścieżki na serwerze (pliki .php, .inc oraz .module).

Liczba plików powiązanych i dynamicznie powiązanych jest często duża, dlatego program Dreamweaver udostępnia opcję filtrowania tych plików. Pozwala to na precyzyjne odszukanie potrzebnego pliku.

  1. Otwórz stronę, z którą są skojarzone pliki powiązane.

  2. Wykryj pliki dynamicznie powiązane, jeśli to konieczne.

  3. Kliknij ikonę Filtruj pliki powiązane, która znajduje się po prawej stronie paska narzędziowego Pliki powiązane.

  4. Wybierz typy plików, które mają być wyświetlane na pasku narzędziowym Pliki powiązane. Domyślnie program Dreamweaver wyświetla wszystkie pliki powiązane.

  5. Aby utworzyć własny filtr, kliknij ikonę Filtruj pliki powiązane i wybierz opcję Filtr spersonalizowany.

    Okno dialogowe Filtr spersonalizowany umożliwia filtrowanie tylko dokładnie podanych nazw plików (np. style.css), rozszerzeń plików (np. .php) oraz wyrażeń wieloznacznych, zawierających gwiazdki (np. *menu*). W filtrze można wykorzystać wiele wyrażeń wieloznacznych, rozdzielając poszczególne wyrażenia średnikiem (np. style.css;*.js;*tpl.php).

Uwaga:

Po zamknięciu pliku ustawienia filtra nie są zapamiętywane.

Oczyszczanie kodu HTML utworzonego przez program Microsoft Word

Pliki zapisane w formacie HTML za pomocą programu Microsoft Word (w wersji Microsoft Word 97 i nowszych) można otworzyć w programie Dreamweaver, a następnie usunąć nadmiarowy kod HTML generowany przez program Word za pomocą polecenia Oczyść kod HTML utworzony przez program Word.

Kod usuwany przez program Dreamweaver to przede wszystkim znaczniki, których Word używa do formatowania i wyświetlania dokumentów, a które nie są potrzebne do wyświetlania pliku HTML.

Zachowaj kopię zapasową oryginalnego pliku programu Word (.doc), bo może się okazać, że po oczyszczeniu kodu HTML nie można już otworzyć takiego pliku w programie Word.

Uwaga:

Aby oczyścić plik HTML lub XHTML, który nie został wygenerowany przez program Microsoft Word, użyj polecenia Narzędzia > Oczyść HTML.

  1. Zapisz dokument Microsoft Word jako plik HTML.
    Uwaga:

    Pracując w systemie Windows, zamknij ten plik w Wordzie, aby uniknąć naruszenia zasad współużytkowania.

  2. Otwórz plik HTML w programie Dreamweaver.

    Aby obejrzeć kod HTML generowany przez program Word, przejdź do widoku Kod (Widok > Kod).

  3. Wybierz polecenie Narzędzia > Oczyść kod HTML utworzony przez program Word.

    Uwaga:

    Jeżeli program Dreamweaver nie może wykryć, w której wersji Worda zapisano plik, wybierz odpowiednią wersję z wysuwanego menu.

  4. Zaznacz lub wyłącz opcje oczyszczania. Wprowadzone preferencje zostaną zapisane jako domyślne ustawienia oczyszczania.

    Program Dreamweaver zastosuje ustawienia oczyszczania do dokumentu HTML i wyświetli rejestr dokonanych zmian (o ile opcja rejestrowania nie została wcześniej wyłączona).

    Opcje oczyszczania kodu HTML utworzonego przez program Microsoft Word
    Opcje oczyszczania kodu HTML utworzonego przez program Microsoft Word

    Usuń wszystkie oznaczenia programu Word

    Usuwa wszystkie znaczniki HTML dotyczące programu Microsoft Word, w tym kod XML w znacznikach HTML, niestandardowe metadane programu Word i znaczniki łączy stosowane w nagłówku dokumentu, znaczniki XML programu Word, znaczniki warunkowe wraz z zawartością oraz puste akapity i marginesy, pochodzące ze stylów. Każdą z tych opcji z osobna można wybierać za pomocą karty Szczegóły.

    Oczyść CSS

    Usuwa wszystkie style CSS dotyczące programu Word, w tym wewnątrz-znacznikowe style CSS, o ile to możliwe (tam, gdzie styl nadrzędny ma takie same właściwości), atrybuty stylu rozpoczynające się od „mso”, deklaracje stylów inne niż CSS, atrybuty stylów z tabel, a także wszystkie nieużywane definicje stylów z sekcji HEAD. Opcję tę można modyfikować za pomocą karty Szczegóły.

    Oczyść znaczniki <font>

    Usuwa znacznik HTML, konwertując domyślny tekst treści na tekst HTML w rozmiarze 2.

    Napraw błędnie zagnieżdżone znaczniki

    Usuwa znaczniki FONT wstawiane przez Worda na zewnątrz znaczników akapitów i nagłówków (znaczników blokowych).

    Zastosuj formatowanie źródła

    Stosuje do dokumentu opcje formatowania kodu źródłowego, określone w preferencjach formatu HTML i pliku SourceFormat.txt.

    Po zakończeniu pokaż dziennik

    Natychmiast po zakończeniu czyszczenia wyświetlane jest okno ostrzeżenia ze szczegółami zmian wprowadzonych w dokumencie.

  5. Kliknij przycisk OK lub — jeśli chcesz dalej dostosowywać opcje „Usuń wszystkie oznaczenia programu Word” oraz „Oczyść CSS” — kliknij zakładkę Szczegóły, a potem kliknij przycisk OK.

Logo Adobe

Zaloguj się na swoje konto