Informacje o korzystaniu z panelu Pliki w celu zarządzania plikami i folderami oraz przenoszenia i synchronizowania ich pomiędzy serwisami lokalnymi i zdalnymi, a także opis funkcji automatycznego odzyskiwania plików w programie Dreamweaver.

Panel Pliki w programie Dreamweaver zapewnia dostęp do plików powiązanych z serwisem oraz umożliwia zarządzanie nimi. Panel ten udostępnia dwa widoki: FTP oraz Git, umożliwiające zarządzanie plikami za pomocą serwera FTP oraz z użyciem repozytoriów Git.

Ab y otworzyć panel Pliki, wybierz polecenie Okno > Pliki lub naciśnij klawisz F8 (Windows) lub Shift-⌘-F (Mac).

Uwaga:

Jeśli serwis nie został skonfigurowany, panel Pliki wyświetla tylko listę wszystkich dysków i folderów w systemie. Można go używać wyłącznie do przeglądania plików. Nie można natomiast przesyłać plików między systemem zdalnym a komputerem lokalnym. 

Więcej informacji o tworzeniu serwisu i wynikających z tego korzyściach podano w sekcji Informacje o serwisach programu Dreamweaver. 

Poniżej opisano sposób korzystania z panelu Pliki w każdym z tych widoków.

Praca z panelem Pliki w widoku FTP

Widok FTP umożliwia wyświetlanie plików i folderów oraz sprawdzanie, czy zostały one skojarzone z serwisem programu Dreamweaver. Pozwala również na wykonywanie typowych operacji konserwacyjnych na plikach, takich jak ich otwieranie i przenoszenie. Ponadto panel Pliki ułatwia zarządzanie plikami i przenoszenie ich między komputerem lokalnym a serwerami zdalnymi. 

Po skonfigurowaniu serwisu w programie Dreamweaver panel Pliki umożliwia:

  • dostęp do serwisów, serwera i dysków lokalnych,
  • wyświetlanie plików i folderów,
  • zarządzanie plikami i folderami na panelu Pliki,
  • synchronizację plików i folderów między serwerem lokalnym a zdalnym.

Poniżej opisano sposób korzystania z panelu pliki w widoku FTP.

Opcje dostępne w panelu Pliki

W swojej najprostszej formie, panel Pliki wyświetla tylko listę lokalnych plików na komputerze. W miarę postępu prac (po skonfigurowaniu serwisu, ustawieniu połączeń z serwerami zdalnymi, włączeniu systemu pobierania do edycji i odkładania) na panelu Pliki będą się pojawiać kolejne opcje.

Tak wygląda panel Pliki:

  • Gdy w programie Dreamweaver nie zdefiniowano serwisu.
  • Po zdefiniowaniu serwisu, ale w sytuacji, gdy nie jest zdefiniowany serwer.
  • Gdy jest zdefiniowany serwis oraz połączenia z serwerem oraz włączony system pobierania i odkładania plików.

Informacje o definiowaniu serwisu i serwera podano w sekcji Informacje o serwisach programu Dreamweaver.

Gdy w programie Dreamweaver nie zdefiniowano serwisu

Wygląd panelu Pliki, gdy w programie Dreamweaver nie zdefiniowano serwisu
Wygląd panelu Pliki, gdy w programie Dreamweaver nie zdefiniowano serwisu

Po zdefiniowaniu serwisu, ale w sytuacji, gdy nie jest zdefiniowany serwer

Po zdefiniowaniu serwisu programu Dreamweaver zostaną wyświetlone pliki tego serwisu. Panel Pliki zawiera także przycisk Definiuj serwery, który umożliwia rozpoczęcie pracy nad definicjami połączeń z serwerem zdalnym i testowym.

Wygląd panelu Pliki po zdefiniowaniu serwisu w programie Dreamweaver, ale w sytuacji, gdy nie jest zdefiniowany serwer
Wygląd panelu Pliki po zdefiniowaniu serwisu w programie Dreamweaver, ale w sytuacji, gdy nie jest zdefiniowany serwer

Gdy jest zdefiniowany serwis oraz serwery oraz włączony system pobierania i odkładania plików

Po zdefiniowaniu serwisu i serwerów będą dostępne wszystkie opcje na panelu Pliki. Jeśli został włączony system pobierania plików do edycji i odkładania ich na serwer, to dostępne będą również opcje tego systemu.

Poniżej podano więcej informacji na temat zadań, które można wykonywać za pomocą panelu Pliki.

Informacje o włączaniu systemu pobierania plików do edycji i odkładania ich: Odkładanie i pobieranie plików.

Wygląd panelu Pliki po zdefiniowaniu serwisu i połączeń z serwerami zdalnymi oraz włączeniu systemu pobierania do edycji i odkładania
Wygląd panelu Pliki po zdefiniowaniu serwisu i połączeń z serwerami zdalnymi oraz włączeniu systemu pobierania do edycji i odkładania

A. Wyskakujące menu Serwis B. Widok plików C. Nawiązywanie połączenia z serwerem zdalnym D. Pobieranie plików z serwera zdalnego E. Wysyłanie plików na serwer zdalny F. Pobieranie plików do edycji G. Odkładanie plików H. Synchronizowanie z serwerem zdalnym I. Rozwijanie i zwijanie J. Odświeżanie K. Operacje na plikach 

Panel Pliki można swobodnie przenosić oraz ustawiać jego preferencje.

Uwaga:

Przyciski widoku plików serwisu i serwera testowego oraz przyciski do synchronizacji są widoczne tylko po rozwinięciu panelu Pliki.

Wyskakujące menu Serwis

Umożliwia wybranie serwisu programu Dreamweaver i wyświetlenie skojarzonych z nim plików. Za pomocą menu Serwis można również korzystać ze wszystkich plików na lokalnym dysku twardym, pełni więc ono podobną rolę, co Eksplorator Windows (w systemie Windows) lub program Finder (na komputerach Mac).

Widok plików

Umożliwia przeglądanie plików znajdujących się w katalogu głównym serwisu, na serwerze zdalnym albo na serwerze testowym. Wybierz odpowiednią opcję z wyskakującego menu, aby wyświetlić poszczególne widoki plików.

Nawiązywanie połączenia z serwerem zdalnym

(protokoły FTP, RDS i WebDAV) Łączy lub rozłącza z serwisem zdalnym. Program Dreamweaver rozłącza się domyślnie z serwisem zdalnym, jeśli upłynęło ponad 30 minut bezczynności (tylko protokół FTP). Aby zmienić ten limit czasu, wybierz polecenie Edycja > Preferencje (Windows) lub Dreamweaver > Preferencje (Macintosh). Z listy kategorii po lewej stronie wybierz opcję Serwis.

Pobieranie plików z serwera zdalnego

Kopiuje zaznaczone pliki z serwisu zdalnego do lokalnego (nadpisując istniejące kopie lokalne). Jeżeli włączona jest opcja „Włącz funkcje pobierania do edycji i odkładania plików”, to kopie lokalne mają status tylko do odczytu. Pliki są dostępne w serwisie zdalnym, skąd inni członkowie zespołu mogą je pobierać do edycji. Jeżeli opcja „Włącz funkcje pobierania do edycji i odkładania plików” jest wyłączona, to kopie plików będą miały atrybuty umożliwiające zarówno odczyt, jak i zapis.

Wysyłanie plików na serwer zdalny

Kopiuje zaznaczone pliki z serwisu lokalnego do zdalnego.

Pobieranie plików do edycji

Przenosi kopię pliku z serwera zdalnego do serwisu lokalnego (zastępując jego istniejącą kopię lokalną) i oznacza ten plik na serwerze jako „pobrany do edycji”. Ta opcja nie jest dostępna, jeżeli dla bieżącego serwisu wyłączono opcję „Włącz funkcje pobierania do edycji i odkładania plików”.

Odkładanie plików

Przenosi kopię pliku lokalnego na serwer zdalny i oznacza ten plik jako dostępny do edycji dla pozostałych użytkowników. Plik lokalny staje się plikiem tylko do odczytu. Ta opcja nie jest dostępna, jeżeli dla bieżącego serwisu wyłączono opcję „Włącz funkcje pobierania do edycji i odkładania plików”.

Synchronizacja z serwerem zdalnym

Synchronizuje pliki między folderem lokalnym a zdalnym.

Rozwiń/Zwiń

Rozwija lub zwija panel Pliki, tak aby wyświetlał jedno lub dwa okienka. Gdy panel jest rozwinięty, dostępna jest również dodatkowa opcja: Wyświetl dziennik FTP serwisu. Gdy panel Pliki jest zwinięty, wyświetla zawartość serwisu lokalnego, serwisu zdalnego albo serwera testowego jako listę plików. Po rozwinięciu jest wyświetlany serwis lokalny, a ponadto serwis zdalny lub serwer testowy.

Odśwież

Odświeża listę katalogów lokalnych i zdalnych. Za pomocą tego przycisku możesz ręcznie odświeżyć listę katalogów, jeżeli w oknie dialogowym Definicja serwisu wyłączona została opcja 'Automatycznie odśwież listę plików lokalnych' albo opcja 'Automatycznie odśwież listę plików zdalnych'.

Operacje na plikach

Wyświetla operacje na plikach przetwarzane w tle.

Opcja Wyświetl dziennik FTP serwisu jest dostępna po rozwinięciu panelu Pliki przez kliknięcie ikony Rozwiń/Zwiń.

Wyświetl dziennik FTP serwisu.

Wyświetla strukturę plików serwisu lokalnego i zdalnego w odpowiednich okienkach na panelu Pliki. (W preferencjach można ustawić, który serwis pojawia się w okienku po lewej stronie, a który po prawej). Widok plików serwisu to domyślny widok panelu Pliki.

Uwaga:

Pliki, które kopiuje program Dreamweaver, to pliki zaznaczone w aktywnym okienku na panelu Pliki. Jeśli aktywne jest okienko Zdalne, zaznaczone pliki serwera zdalnego lub testowego są kopiowane do serwisu lokalnego. Jeśli aktywne jest okienko Lokalne, program Dreamweaver kopiuje z serwera zdalnego lub testowego zaznaczone pliki lokalne i umieszcza je w serwisie lokalnym.

Uwaga:

Pliki, które kopiuje program Dreamweaver, to pliki zaznaczone w aktywnym okienku na panelu Pliki. Jeżeli aktywne jest okienko Lokalne, to zaznaczone pliki lokalne są kopiowane do serwisu zdalnego lub testowego. Jeżeli aktywne jest okienko Zdalne, to program Dreamweaver kopiuje lokalne odpowiedniki zaznaczonych plików serwera lokalnego i umieszcza je w serwisie zdalnym.

Jeżeli wysyłasz plik, którego nie ma jeszcze w serwisie zdalnym, a włączona jest opcja „Włącz funkcje pobierania do edycji i odkładania plików”, to plik ten zostanie dodany do serwisu zdalnego jako „pobrany do edycji”. Jeśli chcesz dodać plik bez stanu „pobrany do edycji”, kliknij przycisk Odłóż pliki.

Wyświetlanie plików i folderów

Na panelu Pliki można wyświetlać pliki i foldery, zarówno te skojarzone z serwisem programu Dreamweaver, jak i inne. Wyświetlając serwisy, pliki lub foldery na panelu Pliki można zmieniać rozmiar obszaru wyświetlania. W przypadku serwisów programu Dreamweaver można również zwijać i rozwijać panel Pliki.

Można też dostosować panel Pliki dla serwisów programu Dreamweaver, zmieniając widok wyświetlany domyślnie na zwiniętym panelu na serwis zdalny albo lokalny. Na rozwiniętym panelu Pliki można przełączać widoki zawartości, używając opcji Zawsze pokazuj.

Wyszukiwanie plików w panelu Pliki (Mac OS, tylko użytkownicy Creative Cloud)

Funkcja aktywnego wyszukiwania umożliwia znajdowanie plików na podstawie ich nazwy albo zawartego w nich tekstu. Do wyszukiwania używany jest serwis wybrany w panelu Pliki. Jeśli w panelu tym nie zaznaczono żadnego serwisu, opcja wyszukiwania nie będzie wyświetlana. Więcej informacji zawiera temat Wyszukiwanie plików według nazwy lub zawartości.

Zmiana rozmiarów obszaru widoku na rozwiniętym panelu Pliki

Pracując na rozwiniętym panelu Pliki (Okno > Pliki), przeciągnij pasek rozdzielający dwa widok, aby zmniejszyć lub zwiększyć powierzchnię okienka po lewej lub po prawej.

Zmiana widoku serwisu na panelu Pliki (tylko dla serwisów programu Dreamweaver)

Za pomocą panelu Pliki można wyświetlać pliki znajdujące się w lokalnym katalogu głównym serwisu, na serwerze zdalnym albo na serwerze testowym.

Otwórz panel Pliki (Okno > Pliki). Pracując na zwiniętym panelu, wybierz polecenie Widok lokalny, Serwer zdalny lub Serwer testowy z wyskakującego menu Widok serwisu.

Domyślnym ustawieniem w menu Widok serwisu jest Widok lokalny.

Wyświetlanie plików w lokalnym katalogu głównym serwisu oraz na serwerach zdalnych i testowych
Wyświetlanie plików w lokalnym katalogu głównym serwisu oraz na serwerach zdalnych i testowych

Wyświetlanie plików poza serwisami programu Dreamweaver

Wyskakujące menu Serwis umożliwia nawigację w systemie plików na komputerze w taki sam sposób, jak Eksplorator Windows (w systemie Windows) lub program Finder (na komputerach Macintosh).

Praca z plikami w widoku FTP

Pliki można otwierać, dodawać, przenosić, usuwać lub zmieniać ich nazwy, a także odświeżać panel Pliki po wprowadzeniu zmian.

W przypadku serwisów programu Dreamweaver można również określać, które pliki (w serwisie lokalnym lub zdalnym) zostały uaktualnione od ostatniego transferu.

Otwieranie pliku

  1. Otwórz panel Pliki (Okno > Pliki). Wybierz serwis, serwer albo dysk z wysuwanego menu (w którym pojawia się bieżący serwis, serwer lub dysk).
  2. Przejdź do pliku, który chcesz otworzyć.
  3. Wykonaj jedną z następujących czynności:
    • Kliknij dwukrotnie ikonę tego pliku.

    • Kliknij ikonę pliku prawym przyciskiem myszy (Windows) lub przytrzymując klawisz Control (Macintosh), a potem wybierz polecenie Otwórz.

      Program Dreamweaver otwiera plik w oknie Dokument.

Tworzenie pliku lub folderu

  1. Otwórz panel Pliki (Okno > Pliki) i zaznacz plik lub folder.

    Program Dreamweaver tworzy nowy plik lub folder wewnątrz zaznaczonego folderu albo w tym samym folderze, co zaznaczony plik.

  2. Kliknij prawym przyciskiem myszy (Windows) lub przytrzymując klawisz Control (Macintosh), a potem wybierz polecenie Nowy plik albo Nowy folder.
  3. Wpisz nazwę nowego pliku lub folderu.
  4. Naciśnij klawisz Enter (Windows) lub Return (Macintosh).

Usuwanie pliku lub folderu

  1. Otwórz panel Pliki (Okno > Pliki) i zaznacz plik lub folder, który chcesz usunąć.
  2. Kliknij prawym przyciskiem myszy (Windows) lub przytrzymując klawisz Control (Macintosh), a następnie wybierz polecenie Edycja > Usuń.

Zmiana nazwy pliku lub folderu

  1. Otwórz panel Pliki (Okno > Pliki) i zaznacz plik lub folder, którego nazwę chcesz zmienić.
  2. Wykonaj jedną z poniższych czynności, aby uaktywnić nazwę tego pliku lub folderu:
    • Kliknij w nazwie pliku, odczekaj moment i kliknij jeszcze raz.

    • Kliknij ikonę pliku prawym przyciskiem myszy (Windows) lub przytrzymując klawisz Control (Macintosh), a następnie wybierz polecenie Edycja > Zmień nazwę.

  3. Wpisz nową nazwę, usuwając istniejącą.
  4. Naciśnij klawisz Enter (Windows) lub Return (Macintosh).

Przenoszenie pliku lub folderu

  1. Otwórz panel Pliki (Okno > Pliki) i zaznacz plik lub folder, który chcesz przenieść.
  2. Wykonaj jedną z następujących czynności:
    • Skopiuj plik lub folder i wklej go w nowym miejscu.

    • Przeciągnij plik lub folder na nowe miejsce.

  3. Odśwież panel Pliki, aby wyświetlić plik lub folder w nowym miejscu.

Odświeżanie panelu Pliki

Aby odświeżyć widok w panelu Pliki, wykonaj jedną z następujących czynności:

  • Kliknij dowolny plik lub folder prawym przyciskiem myszy (Windows) lub przytrzymując klawisz Control (Macintosh), a potem wybierz polecenie Odśwież.
  • (Tylko dla serwisów programu Dreamweaver) Kliknij przycisk Odśwież na pasku narzędziowym panelu Pliki (ta opcja odświeża oba okienka panelu).

Uwaga:

Program Dreamweaver odświeża panel Pliki, gdy wprowadzisz zmiany w innej aplikacji, a potem wrócisz do programu Dreamweaver.

Odszukiwanie plików w serwisie programu Dreamweaver

Program Dreamweaver ułatwia znajdowanie zaznaczonych, otwartych, pobranych do edycji i ostatnio modyfikowanych plików w serwisie. Można także wyszukiwać pliki, które są nowsze w serwisie lokalnym lub zdalnym.

Znajdowanie otwartego pliku w serwisie

  1. Otwórz plik w oknie dokumentu.
  2. Wybierz polecenie Serwis > Znajdź w serwisie.

    Program Dreamweaver zaznaczy plik w panelu Pliki.

    Uwaga:

    Jeśli otwarty plik w oknie dokumentu nie jest częścią bieżącego serwisu na panelu Pliki, program Dreamweaver spróbuje określić, do którego z serwisów programu Dreamweaver ten plik należy. Jeśli bieżący plik należy tylko do jednego serwisu lokalnego, program Dreamweaver otworzy ten serwis na panelu Pliki i podświetli plik.

Odszukiwanie i zaznaczanie plików pobranych do edycji z serwisów programu Dreamweaver

Otwórz panel Pliki (Okno > Pliki). Na zwiniętym panelu kliknij menu Opcje w prawym górnym rogu i wybierz polecenie Edycja > Zaznacz pliki pobrane do edycji.

Program Dreamweaver zaznaczy pliki w panelu Pliki.

Znajdowanie zaznaczonego pliku w serwisie lokalnym lub zdalnym

  1. Zaznacz plik w widoku Lokalny lub zdalny na panelu Pliki (Okno > Pliki).
  2. Kliknij prawym przyciskiem myszy (Windows) lub przytrzymując klawisz Control (Macintosh) i wybierz polecenie Znajdź w serwisie lokalnym albo Znajdź na serwerze zdalnym (w zależności od miejsca zaznaczenia pliku).

    Program Dreamweaver zaznaczy plik w panelu Pliki.

Znajdowanie i zaznaczanie plików, które są nowsze w serwisie lokalnym niż w zdalnym

Otwórz panel Pliki (Okno > Pliki). Na zwiniętym panelu kliknij menu Opcje w prawym górnym rogu i wybierz polecenie Edycja > Zaznacz nowsze lokalne.

Program Dreamweaver zaznaczy pliki w panelu Pliki.

Znajdowanie i zaznaczanie plików, które są nowsze w serwisie zdalnym niż w lokalnym

Otwórz panel Pliki (Okno > Pliki). Na zwiniętym panelu kliknij menu Opcje w prawym górnym rogu i wybierz polecenie Edycja > Zaznacz nowsze zdalne.

Program Dreamweaver zaznaczy pliki w panelu Pliki.

Znajdowanie w serwisie niedawno zmodyfikowanych plików

  1. Otwórz panel Pliki (Okno > Pliki). Na zwiniętym panelu kliknij menu Opcje w prawym górnym rogu i wybierz polecenie Edycja > Zaznacz ostatnio zmodyfikowane.
  2. Wykonaj jedną z poniższych czynności, aby zdefiniować daty wyszukiwania do raportu:
    • Aby zgłaszane były wszystkie pliki zmodyfikowane w ciągu ostatnich kilku dni, wybierz opcję 'Pliki utworzone lub zmodyfikowane w ciągu ostatnich' i wpisz w polu liczbę.

    • Aby zgłaszane były wszystkie pliki zmodyfikowane w określonym przedziale czasu, kliknij przycisk opcji „Pliki utworzone lub zmodyfikowane pomiędzy” i podaj zakres dat.

    Znajdowanie niedawno zmodyfikowanych plików
    Znajdowanie niedawno zmodyfikowanych plików

  3. (Opcjonalnie) W pole 'Zmodyfikowany przez' można wpisać nazwę użytkownika, aby ograniczyć wyszukiwanie do plików zmodyfikowanych przez tego użytkownika w zadanym przedziale czasu.

    Uwaga:

    Ta opcja jest dostępna tylko w przypadku raportów dotyczących serwisów Contribute.

  4. Zaznacz przycisk opcji, aby wskazać, gdzie chcesz wyświetlać pliki umieszczone w raporcie (o ile to konieczne):

    Komputer lokalny

    jeżeli strona zawiera strony statyczne.

    Serwer testowy

    jeśli strona zawiera strony dynamiczne.

    Inne miejsce

    jeśli chcesz wprowadzić ścieżkę w polu tekstowym.

    Uwaga:

    Ta opcja zakłada, że w oknie dialogowym Definicja serwisu zdefiniowano serwer testowy. Jeżeli nie zdefiniujesz serwera testowego i nie wpiszesz prefiksu URL tego serwera, albo jeżeli uruchamiasz raport dla więcej niż jednego serwisu, opcja ta nie będzie dostępna.

  5. Kliknij przycisk OK, aby zapisać ustawienia.

    Program Dreamweaver podświetli na panelu Pliki te pliki, które zostały zmodyfikowane w zadanym przedziale czasu.

Wyszukiwanie i usuwanie nieużywanych plików

Pliki, które nie są już używane przez inne pliki w serwisie, można wyszukać i usunąć.

  1. Wybierz polecenie Serwis > Opcje serwisu > Sprawdź łącza w całym serwisie.

    Program Dreamweaver sprawdzi wszystkie łącza w serwisie i wyświetli zerwane łącza w panelu Wyniki.

  2. Wybierz polecenie Porzucone pliki z menu na panelu Kontroler łączy.
    Wyświetlanie porzuconych plików — plików, do których nie prowadzą żadne odsyłacze
    Wyświetlanie porzuconych plików — plików, do których nie prowadzą żadne odsyłacze

    Program Dreamweaver wyświetli wszystkie pliki, do których nie prowadzą żadne łącza. Oznacza to, że żaden z plików w serwisie nie zawiera hiperłączy do tych plików.

  3. Zaznacz pliki, które chcesz usunąć, a następnie naciśnij przycisk Usuń.

    Uwaga:

    Chociaż do wskazanych plików nie prowadzą żadne łącza, to te pliki mogą zawierać łącza do innych plików. Zachowaj zatem ostrożność, usuwając takie pliki.

Dostęp do serwisów, serwera i dysków lokalnych

Można otwierać, modyfikować i zapisywać pliki i foldery w serwisach programu Dreamweaver, a także pliki i foldery, które nie wchodzą w skład żadnego serwisu programu Dreamweaver. Oprócz serwisów programu Dreamweaver, użytkownik posiada również dostęp do serwerów, dysków lokalnych i pulpitu.

Zanim użytkownik uzyska dostęp do serwera zdalnego, należy skonfigurować program Dreamweaver do pracy z tym serwerem.

Uwaga:

Utworzenie serwisu programu Dreamweaver to najlepsza metoda zarządzania plikami. Informacje o tworzeniu serwisów i wynikających z tego korzyściach podano w sekcji Informacje o serwisach programu Dreamweaver.

Otwieranie istniejącego serwisu programu Dreamweaver

Otwórz panel Pliki (Okno > Pliki). Wybierz serwis z menu (w którym pojawia się bieżący serwis, serwer lub dysk).
Otwieranie istniejącego serwisu programu Dreamweaver
Otwieranie istniejącego serwisu programu Dreamweaver

Otwieranie folderu na zdalnym serwerze FTP lub RDS

  1. Otwórz panel Pliki (Okno > Pliki). Wybierz nazwę serwera z menu (w którym pojawia się bieżący serwis, serwer lub dysk).

    Uwaga:

    Nazwy serwerów pojawiają się w tym menu, jeśli program Dreamweaver skonfigurowano do ich obsługi.

  2. Przejdź do plików i edytuj je w zwykły sposób.

Dostęp do lokalnego dysku albo pulpitu

  1. Otwórz panel Pliki (Okno > Pliki). Wybierz nazwę opcję Pulpit, Dysk lokalny albo Dysk CS z menu (w którym pojawia się bieżący serwis, serwer lub dysk).
  2. Przejdź do pliku i wykonaj dowolne z następujących czynności:
    • Otwórz pliki w programie Dreamweaver albo w innej aplikacji
    • Zmień nazwy plików
    • Skopiuj pliki
    • Usuń pliki
    • Przeciągnij pliki
      • Jeśli przeciągnie się plik z jednego serwisu programu Dreamweaver do innego albo do folderu, który nie jest częścią serwisu programu Dreamweaver, program Dreamweaver kopiuje ten plik w miejscu, w którym został upuszczony.
      • Jeśli plik jest przeciągany w ramach tego samego serwisu programu Dreamweaver, program przeniesie plik do miejsca, w którym zostanie upuszczony.
      • Jeśli przeciągany plik, który nie jest częścią serwisu programu Dreamweaver nie wchodzącego w skład serwisu tego programu, program Dreamweaver przeniesie ten plik do miejsca, w którym zostanie upuszczony.

    Uwaga:

    Aby przenieść plik, który program Dreamweaver domyślnie kopiuje, przytrzymaj klawisz Shift (Windows) lub Command (Macintosh) podczas przeciągania. Aby skopiować plik, który program Dreamweaver domyślnie przenosi, przytrzymaj klawisz Control (Windows) lub Option (Macintosh) podczas przeciągania.

Dostosowywanie szczegółowych informacji o plikach i folderach wyświetlanych w panelu Pliki

Panel Pliki domyślnie wyświetla tylko pliki i strukturę folderów wchodzących w skład serwisu programu Dreamweaver. Można jednak dostosować wygląd tego panelu, aby wyświetlał następujące dane:

  • notatki,
  • rozmiar,
  • typ,
  • data i godzina ostatniej modyfikacji pliku,
  • informacje o pobieraniu do edycji.
Aby dodać te kolumny do panelu Pliki, kliknij prawym przyciskiem myszy na pasku narzędziowym i wybierz opcje, które chcesz wyświetlić.
Wyświetlanie i ukrywanie szczegółów plików i folderów w panelu Pliki
Wyświetlanie i ukrywanie szczegółów plików i folderów w panelu Pliki

Możesz wprowadzić włączenie korekty, korzystając z opcji zarządzaj witryny, Użytkownicy znający ustawienia zaawansowane > kolumny widoku pliku, okno dialogowe:

Dostosowywanie kolumn widoku pliku za pomocą okna dialogowego Zarządzaj serwisami > Ustawienia zaawansowane > Kolumny widoku plików
Dostosowywanie kolumn widoku pliku za pomocą okna dialogowego Zarządzaj serwisami > Ustawienia zaawansowane > Kolumny widoku plików

Zmiana kolejności kolumn

Otwórz okno dialogowe Zarządzaj serwisami > Ustawienia zaawansowane > Kolumny widoku plików, wybierz nazwę kolumny, a następnie kliknij przycisk ze strzałką w górę lub w dół, aby zmienić pozycję wybranej kolumny.

Uwaga:

Można zmieniać kolejność wszystkich kolumn z wyjątkiem kolumny Nazwa, która jest zawsze pierwsza.

Dodawanie, usuwanie lub zmiana kolumn

  1. Wybierz polecenie Serwis > Zarządzaj serwisami.
  2. Zaznacz serwis i kliknij opcję Edytuj.
  3. Rozwiń węzeł Ustawienia zaawansowane i wybierz kategorię Kolumny Widoku pliku.
  4. Zaznacz kolumnę i kliknij przycisk Plus (+), aby dodać nową kolumnę.

  5. W polu Nazwa kolumny wpisz nazwę kolumny.
    Dodawanie kolumn niestandardowych
    Dodawanie kolumn niestandardowych

  6. Wybierz wartość z menu Skojarz z uwagami do projektu albo wpisz własną wartość.

    Uwaga:

    Musisz skojarzyć nową kolumnę z uwagą do projektu, aby na panelu Pliki można było wyświetlać dane.

  7. Wybierz opcję wyrównania, określającą sposób wyrównywania tekstu w kolumnie.
  8. Włącz lub wyłącz opcję Pokaż, aby pokazać lub ukryć kolumnę.
  9. Zaznacz 'Udostępnij wszystkim użytkownikom tego serwisu', jeśli chcesz udostępnić tę kolumnę wszystkim użytkownikom, połączonym z serwisem zdalnym.

Aby usunąć kolumnę, zaznacz ją i kliknij przycisk Minus (-). 

Uwaga:

Kolumna zostanie usunięta natychmiast i bez potwierdzenia, zatem przed kliknięciem przycisku Minus (-) upewnij się, czy na pewno chcesz usunąć tę kolumnę.

Sortowanie kolumn w panelu Pliki

Otwórz panel Pliki i kliknij nagłówek kolumny, według której chcesz sortować.

Uwaga:

Kliknij nagłówek jeszcze raz, aby odwrócić porządek sortowania (rosnąco lub malejąco).

Automatyczne odzyskiwanie plików

Jeśli program Dreamweaver zostanie nieoczekiwanie zamknięty z powodu błędów systemowych, awarii zasilania lub innych problemów, można będzie odzyskać niezapisane zmiany w plikach.

Funkcja automatycznego odzyskiwania tworzy automatyczną kopię zapasową wszelkich niezapisanych plików programu Dreamweaver. W przypadku awarii po ponownym uruchomieniu programu Dreamweaver zostanie wyświetlone następujące okno dialogowe.

Uwaga:

Program Dreamweaver może odzyskać tylko pliki, które uprzednio zostały przynajmniej jednokrotnie zapisane.

Automatyczne odzyskiwanie plików w programie Dreamweaver
Automatyczne odzyskiwanie plików w programie Dreamweaver

Otwierając program Dreamweaver po awarii, można odzyskać lub odrzucić ostatnie zmiany pliku:

  • Odzyskaj — wybierz tę opcję, aby otworzyć automatycznie zapisaną wersję pliku.
  • Odrzuć — wybierz tę opcję, aby otworzyć ostatnią zapisaną w zwykły sposób wersję pliku.

Uwaga:

Program Dreamweaver automatycznie zapisuje pliki co około 5 sekund (zależy to od systemu operacyjnego).

Praca z panelem Pliki w widoku Git

Widok Git na panelu Pliki umożliwia nawiązywanie połączenia z repozytoriami Git oraz zarządzanie plikami z użyciem tego systemu. Panel Pliki pełni rolę interfejsu umożliwiającego wykonywanie różnych operacji, takich jak zatwierdzanie plików, umieszczanie ich w poczekalni i wyjmowanie z niej, dodawanie plików do listy gitignore itd.

W widoku Git można wykonywać następujące działania:

  • wyświetlać pliki powiązane z serwisem w repozytoriach Git,
  • synchronizować pliki i foldery między repozytorium lokalnym a systemem Git,
  • wyświetlać pliki nieśledzone, dodane do poczekalni i zatwierdzone,
  • otwierać terminal Git.

Za pomocą tego panelu można także zainicjować repozytorium Git, jeśli jeszcze tego nie zrobiono. Tworząc serwis w programie Dreamweaver, można powiązać z nim repozytorium Git. Jeśli procedura ta nie została wykonana podczas tworzenia serwisu, to można zainicjować takie repozytorium Git z panelu Pliki.

Aby zainicjować repozytorium, kliknij opcję Inicjuj Git na panelu Pliki. Pliki powiązane z serwisem od razu staną się dostępne w widoku Git. Będzie również wyświetlany ich status.

Inicjowanie repozytoriów Git z panelu Pliki
Inicjowanie repozytoriów Git z panelu Pliki

Wyświetlanie statusu plików

Na panelu Pliki można sprawdzić status plików powiązanych z repozytorium Git. Po zainicjowaniu repozytorium Git pliki są wyświetlane w kolorze zielonym. Oznacza to, że nie są śledzone i nie istnieją jeszcze w systemie Git.

Gdy plik zostanie zatwierdzony, jego kolor na panelu Pliki zmieni się na biały. Oznacza to, że plik został zatwierdzony w wybranym repozytorium Git. 

Jeśli plik po zatwierdzeniu zostanie zmodyfikowany i zapisany, jego kolor na panelu Pliki zmieni się na żółty. Oznacza to, że pliki w repozytorium lokalnym nie są zsynchronizowane z wersją w repozytorium w Git.

Więcej informacji o tym obiegu pracy: Korzystanie z systemu Git w celu kontroli wersji.

Tworzenie gałęzi i zarządzanie nimi

Za pomocą panelu Pliki można tworzyć gałęzie lokalne i zarządzać nimi. Aby utworzyć gałąź, otwórz rozwijaną listę na górze panelu. Wybierz opcję Zarządzaj gałęziami. Następnie kliknij ikonę + w oknie dialogowym Zarządzaj gałęziami.

Można będzie teraz wybrać gałąź oryginalną i utworzyć nową. Można również usuwać gałęzie i scalać je ze sobą.

Więcej informacji o zarządzaniu gałęziami lokalnymi za pomocą panelu Pliki podano w artykule Tworzenie gałęzi i zarządzanie nimi.

Wykonywanie podstawowych operacji Git

Oprócz inicjowania repozytorium i zarządzania gałęziami, na panelu Pliki można wykonywać także różne operacje Git. Zaznacz plik na panelu Pliki, kliknij go prawym przyciskiem myszy i wykonaj jedną z następujących czynności:

  • Kliknij opcję Dodaj do .gitignore, aby dodać zaznaczone pliki do folderu gitignore. Takie pliki nie będą przetwarzane przez system Git i nie będą na nich wykonywane żadne operacje.
  • Kliknij opcję Usuń z .gitignore, aby usunąć plik z folderu gitignore.
  • Kliknij opcję Poczekalnia, aby dodać zaznaczony plik do poczekalni. Poczekalnia to etap poprzedzający zatwierdzenie pliku w Git.
  • Kliknij opcję Usuń z poczekalni, aby wycofać plik z etapu poczekalni.
  • Kliknij opcję Wszystko do poczekalni, aby dodać do poczekalni wszystkie pliki w repozytorium.
  • Kliknij opcję Usuń wszystko z poczekalni, aby usunąć z poczekalni wszystkie pliki w repozytorium.
  • Kliknij opcję Diff, aby wyświetlić porównanie zmian w pliku między poprzednią zatwierdzoną wersją a wersją obecną.
  • Kliknij opcję Historia pliku, aby wyświetlić historię zmian i operacji zatwierdzania dla zaznaczonego pliku.
  • Kliknij opcję Przywróć plik, aby odrzucić wszystkie zmiany wprowadzone w pliku i przywrócić jego poprzednią zatwierdzoną wersję.
  • Kliknij opcję Zatwierdź wszystkie w poczekalni, aby zatwierdzić wszystkie pliki z tego repozytorium, które zostały umieszczone w poczekalni.
Wykonywanie operacji Git za pomocą panelu Pliki
Wykonywanie operacji Git za pomocą panelu Pliki

Więcej informacji o poszczególnych operacjach i obsłudze systemu Git w programie Dreamweaver podano w artykule Korzystanie z funkcji Git w programie Dreamweaver.

Ta zawartość jest licencjonowana na warunkach licencji Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Posty z serwisów Twitter™ i Facebook nie są objęte licencją Creative Commons.

Informacje prawne   |   Zasady prywatności online